
 

 

 

 

A Program for Computations 

of Foundation Settlements 
 

 

 

 

by 

Shin Tower Wang 

Jose A. Arrellaga 

Luis Vasquez 

 

 

for 

ENSOFT, INC. 

3003 W. Howard Lane 

Austin, Texas 78728 

United States of America 

 

 

 

 

 

(Release Date:  Feb. 2020) 

SETOFF – User’s Manual 



ii 

 

User’s Manual (Rel. Feb. 2020)  SETOFF v2020 
 

 

 

 

 

 

COPYRIGHT 

Copyright 1987-2020 by ENSOFT, INC. 

All rights reserved. 

Printed in the Unites States of America. Except as permitted under the 

United States Copyright Act of 1976, no part of this publication may be 

reproduced, translated, or distributed without the prior written approval 

of ENSOFT, INC. 

 

 

 

SOFTWARE LICENSE AGREEMENT & DISCLAIMER 

IMPORTANT NOTICE: Please carefully read the terms of the license 

agreement and disclaimer at the end of this book.  You signify acceptance 

with those terms by usage of the software. 

 

  



iii 

 

User’s Manual (Rel. Feb. 2020)  SETOFF v2020 
 

Table of Contents 
CHAPTER 1. Introduction ....................................................................................................................... 1-1 

1.1 Introduction ............................................................................................................................... 1-2 

1.2 Organization ............................................................................................................................... 1-2 

1.3 Capabilities of Program Setoff ................................................................................................... 1-2 

1.4 General Concepts ....................................................................................................................... 1-2 

1.5 Use of the Program .................................................................................................................... 1-3 

CHAPTER 2. Installation and Getting Started ......................................................................................... 2-1 

2.1 Installation Procedures .............................................................................................................. 2-2 

2.1.1 Installation of Single-User Version ..................................................................................... 2-2 

2.1.2 Introduction of Network Version ....................................................................................... 2-7 

2.1.3 Backup of Original Software .............................................................................................. 2-8 

2.1.4 Software Updates on the Internet ..................................................................................... 2-8 

2.2 Getting Started ........................................................................................................................... 2-8 

2.2.1 File Management ............................................................................................................... 2-8 

2.2.2 Data Input of Application Problem .................................................................................. 2-10 

2.2.3 Options Menu .................................................................................................................. 2-11 

2.2.4 Computation Menu .......................................................................................................... 2-12 

2.2.5 View Menu ....................................................................................................................... 2-12 

2.2.6 Show Menu ...................................................................................................................... 2-13 

2.2.7 Window ............................................................................................................................ 2-14 

2.2.8 Help Menu ........................................................................................................................ 2-14 

CHAPTER 3. References for Data Input .................................................................................................. 3-1 

3.1 File Menu ................................................................................................................................... 3-2 

3.1.1 File > New ........................................................................................................................... 3-2 

3.1.2 File > Open ......................................................................................................................... 3-2 

3.1.3 File > Save ........................................................................................................................... 3-2 

3.1.4 File > Save As ...................................................................................................................... 3-3 

3.1.5 File > Exit ............................................................................................................................ 3-3 

3.2 Data Menu ................................................................................................................................. 3-3 

3.2.1 Numeric Data Entries ......................................................................................................... 3-4 



iv 

 

User’s Manual (Rel. Feb. 2020)  SETOFF v2020 
 

3.2.2 Data > Title ......................................................................................................................... 3-5 

3.2.3 Data > Soil Layer Data ........................................................................................................ 3-5 

3.2.4 Data > Soil Compressibility Data ........................................................................................ 3-7 

3.2.5 Data > Settlement Points Data ......................................................................................... 3-10 

3.2.6 Data > Foundation Configuration .................................................................................... 3-11 

3.2.7 Data > Loaded Shallow Footings Area data ..................................................................... 3-12 

3.2.8 Data > Pile Foundation Data ............................................................................................ 3-14 

CHAPTER 4. References for Program Execution and Output Reviews ................................................... 4-1 

4.1 Introduction ............................................................................................................................... 4-2 

4.2 Computation Menu .................................................................................................................... 4-2 

4.2.1 Computation > Run Analysis .............................................................................................. 4-2 

4.2.2 Edit Input Text .................................................................................................................... 4-3 

4.2.3 Edit Processor-Run Notes .................................................................................................. 4-3 

4.2.4 Edit Output Text ................................................................................................................. 4-4 

4.3 View Menu ................................................................................................................................. 4-5 

4.3.1 View > Graphics .................................................................................................................. 4-5 

4.3.2 View > 3D View .................................................................................................................. 4-6 

4.4 Show Menu ................................................................................................................................ 4-7 

CHAPTER 5. Example Problems .............................................................................................................. 5-1 

5.1 Introduction ............................................................................................................................... 5-2 

5.2 Description of Output Tables ..................................................................................................... 5-2 

5.3 Installation of Example Files ...................................................................................................... 5-3 

5.4 Example 1 – Shallow Foundations ............................................................................................. 5-3 

5.4.1 Problem Description .......................................................................................................... 5-3 

5.4.2 Input and Output Data Files for Example 1 ........................................................................ 5-7 

5.4.3 Input Data File Text for Example 1 ..................................................................................... 5-7 

5.5 Example 2 – Single Deep Foundation ...................................................................................... 5-12 

5.5.1 Problem Description ........................................................................................................ 5-12 

5.5.2 Guidance and Steps for Data Input .................................................................................. 5-13 

5.5.3 Computation Menu .......................................................................................................... 5-17 

CHAPTER 6. Technical Information for Settlement Analysis .................................................................. 6-1 

6.1 Introduction ............................................................................................................................... 6-2 



v 

 

User’s Manual (Rel. Feb. 2020)  SETOFF v2020 
 

6.2 Soil Stratigraphy ......................................................................................................................... 6-2 

6.3 Soil Properties ............................................................................................................................ 6-2 

6.4 Change of Soil Stress Due to Foundation Loads ........................................................................ 6-3 

6.4.1 Rectangular Foundations ................................................................................................... 6-3 

6.4.2 Circular Foundations .......................................................................................................... 6-3 

6.4.3 Average Layer Stress Change ............................................................................................. 6-3 

6.5 Settlement Computation ........................................................................................................... 6-3 

CHAPTER 7. Technical References ......................................................................................................... 7-1 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

CHAPTER 1. Introduction 
  



CHAPTER 1 – Introduction – 1-2 

 

User’s Manual (Rel. Feb. 2020)  SETOFF v2020 
 

1.1 Introduction 

Welcome to the foundation settlement analysis program SETOFF (SETtlement Of Footing 

Foundations). This document and associated computer program provide methods to compute 

consolidation settlements at selected points due to the loads from foundations consisting of one or more 

footings and/or mats.  This program uses generally-accepted procedures to compute consolidation 

settlement for footing foundations. 

1.2 Organization 

This user’s manual is divided into five chapters.  Chapter 2 contains information for installation 

and running SETOFF v2020.  Chapter 3 contains a detailed guide to prepare the input data required by the 

program SETOFF, and Chapter 4 contains instructions for running the program and presenting computed 

settlement and graphics plots.  Chapter 5 contains a description of the output from the program SETOFF 

and the input and output for some example problems.  Chapter 6 contains a basic introduction to the 

computational procedures used by SETOFF in sufficient detail so users could make the computations 

manually. 

1.3 Capabilities of Program Setoff 

The program can be used to compute settlements at as many as 25 points due to the loading from as 

many as 50 footings and pile foundations with pile caps, represented as loaded areas. The soil stratigraphy 

includes up to 25 soil layers and as many as 10 soil compressibilities. 

The loaded areas may be rectangular or circular in shape, and they may be included in the 

foundation in any order or combination. A loaded area may be placed at the ground surface or at any 

depth below the ground surface. The pressure applied to the soil by a loaded area may be positive, as for 

structural loads, or negative, representing soil excavation. The effect of all loaded areas is included in 

computing settlements in all soil layers beneath all settlement points. Settlement results are considered to 

be the final settlement in regards to consolidation as a time-dependent function. 

Soil compressibility can be represented by typical data from laboratory consolidation tests, either 

directly as received from the laboratory or in a modified form. The compressibility data can be entered 

either as a series of points for a nonlinear curve or as the slope of a linear soil compressibility curve. 

1.4 General Concepts 

Settlement of structures supported on footings and mats was a mystery to designers and 

constructors for a long time. In 1925 Karl Terzaghi published his book Erdbaumechanik where an 

explanation of the settlement phenomenon was given. This initiated increased activity in the observation 

of actual structure settlement and in the development of computational procedures to predict such 

settlement. The computation of settlement for structures supported on soil-supported footings or mats has 

become an accepted procedure in geotechnical engineering. 

Total settlement of a foundation is generally considered to consist of two parts, elastic and 

consolidation settlement. Elastic settlement occurs because of the pseudo-elastic nature of most soils and 

it occurs immediately on application of the foundation load. Consolidation settlement takes place as the 

pore space in the soil is reduced under the foundation loading and it may require a period of time to be 
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fully developed. The elastic settlement may not be important because it takes place during construction as 

the structural loads are added. Because of this, some compensation for the elastic settlement may take 

place during construction. This does not mean, however, that elastic settlement should be overlooked. 

1.5 Use of the Program 

Computation of consolidation settlement may be divided into three parts. The first part is the 

determination of the soil stratigraphy and the representative properties of the soil in each stratum. The 

second part is the computation of the stress increase at pertinent points in the subsurface soils due to the 

foundation loading. The third part is the computation of settlement using the data from the first two parts. 

The computer program SETOFF will perform the latter two parts: computation of the stress increase and 

settlement. 

The settlements computed by the program SETOFF will be only as good as the input data. The soil 

stratigraphy and soil properties should be determined by an adequate soil investigation conducted by a 

competent geotechnical engineer. 

Settlement is very specific. The actual settlement observed in the field will depend on actual 

foundation loads and soil conditions and not on values assumed for design. The foundation loading used 

should be the actual sustained loads and not the maximum design loads. If the rebound from an 

excavation is to be computed, the input soil compressibility should adequately represent the action of the 

soil under reducing stress as well as increasing stress; this may not be the unmodified results from 

consolidation tests. If the computed settlement is borderline, it may be necessary for further analysis and 

interpretation of the output from program SETOFF by a competent engineer. 

Although this program will permit computation of settlement for complex foundations that would 

be too tedious for manual calculation, it should not be used without the input from a person familiar with 

all aspects of the settlement process. 
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2.1 Installation Procedures 

Program SETOFF is distributed with an associated USB Key (hardware key or dongle).  The 

hardware key consists of a device that is attached to an empty USB port (or USB hub) of the computer in 

use (or in the designated software server in the case of local network licenses).  This method of software 

protection has been found to provide compatibility with existing operating systems, better stability than 

other alternatives, and allows users to obtain software updates or replacements via downloads from the 

internet. 

Users with standard single-user licenses can check the following link to a PDF with Installation Notes: 

https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf 

Users with local network licenses can check the following link to a PDF with Network Installation Notes: 

https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf 

2.1.1 Installation of Single-User Version 

This version of SETOFF has been tested to be compatible with the following versions of the 

Microsoft Windows® operating systems: 2000, XP, Vista, and Windows 7 and 8, 8.1 and 10 in 32 and 

64-bit releases. 

The following guidelines are recommended during the installation process of SETOFF for single-

user licenses. 

1. Plug the supplied USB Key into one of the available USB ports in your computer.  The USB Key is 

plug-and-play compatible so the operating system will recognize the USB Key automatically and a 

small but solid green light should appear at the end of the USB Key (a flickering green light or no 

light indicate problems with the standard windows driver or with the USB Key). 

2. If the user installs from a distribution USB Memory Stick and the main installation program does not 

start automatically upon insertion of the Memory Stick then click on the Windows Start Menu 

button and select Run.  On the command line, type d:\setup.exe or e:\setup.exe, where d: or e: 

represents the drive that contains the distribution Memory Stick.  Click OK to execute the command 

and start the main installation program for ENSOFT’s software.  A screen similar to the one in 

Figure 2.1 should appear. 

3. If the user installs from a downloaded file then please run the downloaded file (double click) and go 

to instruction #5. 

4. Click anywhere on the Setoff 2020 icon and then click on the Install Standard button to start the 

installation of SETOFF. 

5. The user should read the license agreement shown in Figure 2.2.  Users can review the License 

Agreement online in the following link: 

https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf 

The installer will place the same file (Ensoft License and Disclaimer.pdf) in the installation 

directory.  Please click Yes if you agree and would like to proceed. 

6. Select Single-User License in Figure 2.3 then click Next.  

7. The user will be provided with an option to select a drive and directory for the installation of 

example files (see Figure 2.4).  Default installation directory is the following: 

https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf
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(Root Drive)\Ensoft\Setoff2020-Examples 

8. The user will also be asked to select a drive and directory for the installation of SETOFF (see Figure 

2.5).  Default installation directory (varies according to the Windows release where it is installed) is 

one of the following: 

(Root Drive):\Program Files (x86)\Ensoft\Setoff2020 

(Root Drive):\Program Files\Ensoft\Setoff2020 

If the desired directory does not exist, the installation program will automatically create a new 

directory in the chosen hard drive. 

 

Figure 2.1   Main Installation Screen for ENSOFT Software (may change with time) 

9. During the installation the user will be asked to set the file extension association for opening 

SETOFF v2020 input data files (see Figure 2.6).  If the user agrees (leaves the default check mark) 

then double clicking (or running) any input data file with extensions of the type filename.se4t will 

start the installed SETOFF v2020 software. 
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10. The user will be prompted to confirm the shortcut directory name that will be created in the 

Windows Start Menu (See Figure 2.7).  The default is Start Menu/Programs/Ensoft/Setoff2020.  

Windows 10 and 8 will automatically create an Ensoft tile with the same shortcuts. 

After the installation is finished, it is usually not necessary to reboot Windows for the program to 

run.  The user may run the program by selecting SETOFF v2020 from the standard links installed in the 

Microsoft Windows® Start Menu:  Start Menu > All Programs > Ensoft > Setoff2020 

 
 

 

Figure 2.2   Installation Screen with License Agreement (may change with time)  
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Figure 2.3  Selection of Single-User License (may change with time)  

 

Figure 2.4  Default Installation Directory for Example Files (may change with time) 
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Figure 2.5   Default Installation Directory for Program Files (may change with time)  

 

Figure 2.6   File Extension Association for SETOFF Data Files (may change with time)  



CHAPTER 2 – Installation and Getting Started – 2-7 

User’s Manual (Rel. Feb. 2020)  SETOFF v2020 
 

 

Figure 2.7   Default Shortcut Folder in Windows Start Menu (may change with time)  

2.1.2 Introduction of Network Version 

Special network licenses and USB hardware keys (network keys) are available for users that desire 

to operate SETOFF on a Windows network.  The network version is limited to users within a specified 

range of IP addresses at each licensed physical site.  Discounted rates apply for purchases of multiple 

network seats for the same site. 

Network versions of SETOFF have special subroutines written for installations in “software 

servers” and for installations of “individual clients”.  The “software server” is known as the computer that 

will be carrying the network key provided by ENSOFT, INC.  The software server is not necessarily the 

same as the existing network server.  Any computer in the existing Windows network may be designated 

software server for SETOFF as long as the network key is attached to an available USB port (or through 

an USB hub) and the “server” version of the software is installed on its hard drive.  Software “clients” 

may be all other computers of the network that have the program installed as client.  Client computers do 

not need any hardware key attached to their local system.  The program installed in “client computers” 

will be allowed to run as long as the computer designated as “software server” is accessible on the 

network with the proper operating system and with its network key secured in place. 

Users of the network version of SETOFF are allowed to have the software installed in as many 

computers as desired within their specified IP ranges of their local Windows network.  However, only a 

number of users equal to the total number of purchased licenses will be able to operate the program at the 

same time. 
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2.1.2.1 Installation of Network Version 

Installers of network licenses should refer to a separate booklet with installation instructions for the 

Network version of this product.  The document can be downloaded from the Ensoft web site: 

https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf 

Alternatively, the document can be requested via email to support@ensoftinc.com 

2.1.2.2 Silent Installations on Client Computers 

For installation of network licenses on local client computers there is an option for command-based 

installations that are completely silent (performed without other user input).  Instructions for silent 

installations on client computers can be downloaded from the Ensoft web site using the following link: 

https://www.ensoftinc.com/doc/Silent%20Install%20on%20Client%20Computers.pdf 

Alternatively, the document can be requested via email to support@ensoftinc.com 

2.1.3 Backup of Original Software 

The distributed software may be copied for backup purposes.  The program may be installed in 

several computers at the same time.  However, unless network licenses are purchased, the program will 

only operate in the computer that carries the appropriate USB Key. 

2.1.4 Software Updates on the Internet 

Occasionally, ENSOFT will produce software improvements and/or fixes and place the latest 

software programs on ENSOFT’s internet site.  Users can check for available updates by selecting Help > 

Check for Updates from the SETOFF menu.  Software users may freely download the latest program 

update from the PRODUCTS > Downloads link in the following site:  http://www.ensoftinc.com 

2.2 Getting Started 

A general diagram showing the menu choices and operational flow chart of program SETOFF is 

presented in Figure 2.8. The following paragraphs provide a short description of the operational features 

of SETOFF and should quickly enable the user to get started with the program. 

The program is started by double clicking the left mouse button anywhere in the SETOFF icon.  A 

new blank window will appear on the screen, with the following top-menu choices: File, Data, Options, 

Computation, View, Window, and Help. 

As a standard Windows feature, pressing the “Alt” key displays the menu operations with 

underlined letters.  Pressing the underlined letter after pressing “Alt” is the same as clicking the operation.  

For example, to open a New File, the user could press “Alt+F” followed by “N”, or “Ctrl+N”, or click 

File then New.  Additionally, holding the mouse cursor over an icon displays the icon function. 

2.2.1 File Management 

The File menu option contains five submenus, as shown in Figure 2.9; they are: 

• New to create a new data file. 

• Open…to open an existing data file. 

https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf
mailto:support@ensoftinc.com
https://www.ensoftinc.com/doc/Silent%20Install%20on%20Client%20Computers.pdf
mailto:support@ensoftinc.com
http://www.ensoftinc.com/
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• Save to save input data under the current file name. 

• Save As… to save input data under a different file name. 

• Exit   to exit program PYWALL. 

A history list of up to the last ten recently-opened data files is located between the Save As and the Exit 

options.  This list varies on each user’s computer and allows for easy access to recent data files. 

 

 

Figure 2.8   Sample organization and operational flow chart 
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Figure 2.9   File Menu 

Several additional files are created in every new SETOFF run.  A general description of these files 

is presented in Table 2.1.  Every successful run of SETOFF thus generates four text files in the same drive 

and directory where the input-data file was saved or opened.  Any of these files may be opened with 

standard text editors or word processing programs. 

File Name 
Extension 

Usage 
Description 

File  
Format 

Example  
Files 

filename.se4t Input-data file Text file Example 1.se4t 
Example 2.se4t 

filename.se4o Output-data file Text file Example 1.se4o 
Example 2.se4o 

filename.se4r Processor-run 
notes 

Text file Example 1.se4r 
Example 2.se4r 

filename.se4p Plot-data file Text file Example 1.se4p 
Example 2.se4p 

Table 2.1   Files created in SETOFF runs 

2.2.2 Data Input of Application Problem 

The Data menu contains several submenus, as shown in Figure 2.10.  The choices are listed below, 

along with a general description of their use.  In the default conditions, only Title, Soil Layer Data, Soil 

Compressibility Data, Settlement Points Data, and Foundation Configuration will be enabled 

(active).  The menus for Loaded Shallow Footing Areas and Pile Foundation Data are enabled 

depending on selected entries made by the user. 

Title ..................  single line of text with a general description for the project. 

Soil Layer Data .............. used to define the depth, effective unit weight, soil compressibility curve, and 

height factor for each soil strata. The maximum number of soil layers is limited to 25. 
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Soil Compressibility Curves ................ used to input the data for soil-compressibility curves. Users can 

enter a linear or a nonlinear curve. Linear soil-compressibility curves require an input for 

the slope of a logarithmic or of an arithmetic curve. Nonlinear curves are inputted by 

specifying the points of the compressibility curve (vertical strain vs. vertical pressure). 

Settlement Point Data  .. used to input the coordinates of the settlement points where settlement is 

desired to be computed. Users can also specify the particular soil layer where the 

settlement point is located (settlement is thus computed for all layers starting from the 

specified top soil layer). The maximum number of settlement points is 25. 

Foundation Configuration ................. used to define the number of shallow footing foundations and pile 

foundations with pile caps. The combined number of shallow and deep foundations is 

limited 50. For deep foundations, three different Pile-Capacity Options can be selected 

for settlement computations. Only one Pile-Capacity Option can be applied to 

computations for deep foundations. 

Loaded Shallow Footing Areas ....... used to input data for loading areas of shallow footing foundations. 

The shape of the loading areas can either be rectangular or circular.  

Pile Foundation Data .... used to input data for pile foundations. The input data includes the coordinates 

and depth of the pile cap; dimensions of the pile group; and loading.  

 

 

Figure 2.10   Data Menu 

2.2.3 Options Menu 

The Options menu allows the user to select either English Units (using pounds, feet, and inches) 

or SI Units (using kiloNewtons and meters) or any other consistent set of units of force (F) and length 

(L).  English units are enabled, as a default, for all new data files.  The user may change the system of 

units as many times as desired and values that were previously inputted will be automatically converted 

by the program. 

The user can also choose the preferred text editor. The user should input in this box the complete 

path and command line for the preferred text editor or word processor that will be used to examine and 

print the input, output, and processor plain text files created by the program.  As a default, the command 

line is used to operate the standard Microsoft Notepad text editor that is included with most Windows 
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installations.  However, there may be some instances when the output files are too large for Notepad and a 

different text editor or word processor should be used.  In those cases, it is suggested to use Microsoft 

WordPad or similar. 

2.2.4 Computation Menu 

The Computation menu can be accessed to run the analytical computations after all data are 

entered and saved.  After the computation is executed successfully this menu also allows for the reviews 

of plain-text input data, notes produced during computation, and output text data. 

Run Analysis ..  ............... this is selected to run the analytical computations.  This menu should be 

selected after all data have been entered and saved. 

Edit Input Text  ............... calls the chosen Text Editor (selected under Options > Text Editor) to 

observe and/or edit the analytical input data in plain-text format.  This selection becomes 

available after the input data has been saved to disk, or when opening an existing input-

data file. 

Edit Processor-Run Notes ............... calls the chosen Text Editor (selected under Options > Text 

Editor) to observe, format, and/or print the notes provided during processing.  This 

selection becomes available (or modified) after a run attempt has been made.  The user is 

encouraged to read the processor-run notes if the program is not running successfully.  

The processor-run notes may provide the user with some additional information about 

possible causes of the problem. 

Edit Output Text ............. this selection is used to call the chosen Text Editor (selected under Options > 

Text Editor) to observe, format, and/or print the analytical-output data.  This selection 

becomes available only after a successful run has been made.  Certain output files may be 

too large for the Microsoft Notepad editor, so other text editors would have to be used 

(Microsoft WordPad should be able to open most text files). 

 

 
Figure 2.11   Computation Menu 

 

2.2.5 View Menu 

The Graphics menu is used to observe plots of output data provided by a successful program run.  

Options for the observation of output curves under this menu are only enabled after a successful run has 

been made.  Even after performing successful runs, some options may still be disabled since the amount 

of output data depends on specifications provided in the input file of each program run.  Choices within 

this menu are briefly described below. 
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Graphics ......... displays the plan layout of the loading areas and a settlement curve connecting all 

specified settlement points. 

3D View ........... displays a 3-dimensional view of the soil stratigraphy and foundations. The user can 

adjust the view of the foundation plan with view functions such as pan, rotate, and zoom 

in/out. Output results can also be displayed on the model with options under the Show 

menu (which is only displayed while in 3D View mode). 

2.2.6 Show Menu 

The Show menu is only displayed when observing a 3D View graphics.  This menu (see Figure 

2.12) provides several options for display within the 3D View. 

Soil Layers ...... displays soil layers. 

Soil Layer Labels ........... displays the label for each soil layer. 

Soil Layer Depth Labels  .................. displays the depth of each soil layer. 

Footing Areas   .............. displays footing areas representing shallow foundations. 

Footing Areas Labels .... displays the ID Code of Loaded Area that was assigned for each foundation 

entered in the Loaded Shallow Footing Areas menu. 

Project Footing Areas to Ground .... extends the display of each footing area to the ground surface. 

Pile Cap Blocks.............. displays pile caps representing deep foundations. 

Settlement Points .......... displays location and identification of the defined settlement points. 

Settlement Results ........ opens the Settlement Results window where graphical representation of 

output results can be displayed in 3D View. Here the user can select to show bar plots, 

and/or values for each settlement point. 

 

 
Figure 2.12   Show Menu 
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2.2.7 Window 

The Window menu provides two standard functions for organizing open- screen windows and/or 

minimized screen-window icons. 

Cascade .......... this option organizes all open-windowed menus so that all become visible with their tops 

cascading from the top left portion of the screen. 

Arrange Icons .  ............... this option organizes the icons of all minimized windowed menus so that all 

become visible and aligned at the bottom portion of the screen. 

2.2.8 Help Menu 

The Help menu provides an online help reference on topics such as: using the program, entering 

data, information about variables used in the program and methods of analyses.  Submenu options, shown 

in Figure 2.13, are briefly described below.  The menu may be accessed at any time while in SETOFF. 

User’s Manual  ............... this selection calls the installed version of Adobe Acrobat or Acrobat Reader to 

open the User’s Manual.  This document is formatted as an Adobe PDF file. 

About ............... this provides a screen describing the program version, date, maintenance expiration date, 

USB serial number and methods for accessing technical support. 

Check for Updates ........ starts the default Internet browser and sends the user to a page that describes 

information about the user’s license (release and maintenance expiration date) as well as 

the latest release that is available for downloading at the Ensoft site.  Users may only run 

in full mode maintenance updates that were released before the expiration date of the 

user’s license. 

 
Figure 2.13   Help Menu 
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3.1 File Menu 

This menu contains options related to the management of input-data files and to exit the program.  

Input-data files created for SETOFF are provided with a standard file-name extension in the form of 

*filename*.se4t (where *filename* represents any allowable file name).  All input data files are standard 

text files and may be edited with any text editor or word-processing program. 

3.1.1 File > New 

Once the program is started, default values are used for certain operating parameters and a blank 

input-data file is created.  Selecting New under the File menu resets all SETOFF variables to either 

default or blank values, as appropriate.  This option should be selected when a new data file is desired to 

be created from a blank form.  This menu option may also be accessed with the Ctrl+N keyboard 

combination. 

3.1.2 File > Open 

This is used to open a file that has been previously prepared and saved to disk.  The File > Open 

window dialog, shown in Figure 3.1, is used to search for an existing input-data file.  By default, the file 

is initially searched in the directory where SETOFF was installed.  Standard windows-navigation 

procedures may be used to locate the name and directory of the desired project file.  This menu option 

may be accessed with the Ctrl+O keyboard combination.  

Every analytical run of SETOFF produces several additional files (previously described in Table 

2.1 of this manual).  The name of the input-data file indicates the names of all related files produced by a 

successful program run (output, graphics, and processor text files).  All the additional program files will 

be created in the same directory as the input file.  Input-data files that are partially completed may be 

saved and later opened for completion, run, and observation of results. 

Opening partially-completed SETOFF input files or invalid data files may produce an information 

window reporting that an “invalid or incomplete” file is being opened. The user should click the OK 

button and all partial-input data that was previously prepared should become available. 

The program allows users to read input-data files created for the previous SETOFF v3.0 or v2.0 

versions by selecting the drop-down arrow at the bottom right corner of the File > Open dialog box.  The 

program will automatically convert the opened older input files to the latest version of SETOFF when the 

user saves the opened file. 

3.1.3 File > Save 

This selection is used to save input data under the current file name.  With this method of storing 

data to disk, any input data that was previously saved with the same file name is replaced with the current 

parameters.  Input-data files are saved every time before proceeding with runs for analytical computation.   

When saving a data file, the SETOFF program will automatically add an extension of the type 

*.se4t to the name of the input data file.  The program is not able to save data files that are compatible to 

older versions/releases of SETOFF.  This menu option may also be accessed with the Ctrl+S keyboard 

combination. 
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3.1.4 File > Save As 

This selection allows the user to save any opened or new input data file under a different file name 

or different directory.  Any input data file saved under an existing file name will replace the contents of 

the existing file.  When saving a data file, the SETOFF program will automatically add an extension of 

the type *.se4t to the name of the input data file.  The program is not able to save data files that are 

compatible to older versions/releases of SETOFF. 

3.1.5 File > Exit 

This is selected to exit SETOFF.  Any input-data file that was modified and not yet saved to disk 

will produce a confirmation window before exiting the program. 

 
Figure 3.1  File > Open 

3.2 Data Menu 

The input of specific parameters for an application is controlled under selections contained within 

this menu (sample shown in Figure 3.2).  Not all of the entries under the Data menu may be enabled 

since some depend on other entries or selections made by the user.  It is recommended that the user 

choose each submenu and enter parameters in a consecutive manner starting from the top selection. 

Selecting or clicking any of the submenu choices contained in the Data menu produces various 

types of windows.  As a reminder of standard commands of Microsoft Windows®, open windows may be 

closed by all or some of the following methods: 

• clicking the OK button (if available),or 

• clicking the X-box on the upper-right corner of the window, or 

• double-clicking the SETOFF icon on the upper-left corner of the window, or 
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• clicking once on the SETOFF icon on the upper-left corner of the window and then choosing 

Close. 

Open windows may optionally be left open on the screen.  The selection of other menu options will 

then produce new windows on top of those that were left open. 

Many sub-windows of the Data menu will show an Add Row, Insert Row and/or Delete Row 

buttons.  The Add Row button always adds new rows at the end after all existing rows.  The Insert Row 

button always inserts a new row right after an existing row highlighted by the mouse.  Clicking on the 

Delete Row button deletes the row where the cursor is located. 

 

 

Figure 3.2  Sample Data Menu 

3.2.1 Numeric Data Entries 

Cells that require numeric data may accept entries of mathematical expressions in addition to 

simple numeric entries.  Entering a mathematical expression works similarly to normal numeric data.  The 

user types the expression that represents the data and presses the Return key to calculate the entered 

expression and to display the numeric result in the same cell. 

Table 3.1 below shows the list of supported operations and constants.  The order of operations 

follows the order in the list of Table 3.1.  Note that implicit multiplication (i.e. 2(4+6)) is not supported 

(instead, use 2*(4+6) for the previous example). 

The two constants that are currently supported are PI and e.  Implicit multiplications using 

constants is not supported (use 2*e instead of 2e).  Negation of the constants PI or e is not allowed.  For 

instance, instead of entering -PI the user must enter - (PI). 

Scientific notation (i.e. 1.65e8 or 1.65e-8) may be used to input very large or very small numbers.  

After an expression is calculated, very large or very small numbers will be displayed using scientific 

notation. 
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 OPERATORS  

Symbol  Description  

()  Parenthesis (may be nested)  

^  Exponentiation  

*  Multiplication  

/  Division  

+  Addition  

- Subtraction  

- Negation (same as subtraction)  

  

 CONSTANTS  

Symbol  Value  

PI (or pi)  3.1415927  

e (or E)  2.7182818  

Table 3.1  Supported Mathematical Operations and Constants 

3.2.2 Data > Title 

This activates the dialog box shown in Figure 3.3, where the user can enter a line of text containing 

a general description for the application problem.  Any combination of characters may be entered 

in the text box in order to describe a particular application.  The user input will be restrained 

automatically once the maximum length of text is reached.  The Title entered by the user will be printed 

in the output text file of the model. 

 
Figure 3.3  Sample Data > Title 

3.2.3 Data > Soil Layer Data 

A sample of this dialog box is shown in Figure 3.4. In general, for the computation of settlement, 

the soil stratigraphy is initially used to divide the subsurface soils into a series of layers. These basic 

layers may have to be further divided so that a layer boundary is provided whenever any of the following 

occurs: 

(a) soil stratum boundary; 

(b) groundwater level; 

(c) change in effective unit weight; 

(d) change in soil compressibility; 

(e) depth for any foundation; and 
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(f) depth to any settlement point. 

 

 

Figure 3.4  Sample Data > Soil Layer Data 

Particular care should be taken not to overlook item (e) and item (f) in the list above. The program 

will check for item (e) during data input and the run will terminate if the input depth for any foundation is 

not at an input-layer boundary. No such check, however, is made for item (f). If a settlement point is 

located below the ground surface and not at a layer boundary, some error in the computed settlement may 

result. The magnitude of the error will depend on specific conditions and cannot be predicted. 

In this dialog box the user defines the depth, effective unit weight, soil compressibility, and height 

(thickness) factor for each soil strata. The maximum number of soil layers is limited to 25. General 

descriptions of the data needed in each column of the Soil Layer Data menu are the following: 

Layer 

This is a sequential number that is provided for each soil layer. This number is automatically provided by 

the program as new rows are added. The maximum number of rows of soil layers that may be used is 

limited to 25. 

Top Depth 

This is the depth at the top of the soil layer that is being specified. The top of the first layer must always 

start at depth zero. Subsequent layers should start at the Bottom Depth of previous layers.  

Bottom Depth 
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This is the depth at the bottom of the soil layer being specified. The depth of the bottom of each layer 

should always be equal to the Top Depth of the immediately consecutive layer. 

Effective Unit Weight 

Values of effective unit weight for each soil depth are entered in standard units of force per unit volume. 

Unit weight (mass density) is usually determined in the laboratory by direct measurements on undisturbed 

samples obtained from soil borings.  Notice that entry of effective unit weight implies to use the total unit 

weight when above the water table and the submerged unit weight if below the water table. 

Soil Compressibility Curve No 

Users here specify the number (always an integer) of the compressibility curve that corresponds to each 

soil layer. Each curve number specified here is later defined under Data > Soil Compressibility Data. 

Soil Layer Thickness Factor, Hf 

This is a number that may vary from 0 to 1.0, representing the relative portion of the soil-layer thickness 

to use in the settlement computation for that layer. Normally, this factor is 1.0. Suppose, however, that a 

soil layer is composed of alternating layers of clay and sand with the total layer thickness consisting of 

one-half clay and one-half sand. If compressibility data for the layer is based on a consolidation test on 

the clay portion, a computation using the full layer thickness would result in a computed settlement for 

this layer that would be too large. If a layer thickness factor of 0.5 is used, the computed settlement would 

be a better approximation for the layered soil. 

3.2.4 Data > Soil Compressibility Data 

In program SETOFF, soil compressibility is entered using either data obtained from consolidation 

tests or taken as the slope of the linear compressibility curve. Three options are available for data input 

for soil compressibility. A sample window screen for this menu is shown on Figure 3.5. After inputting 

the data, the soil compressibility curves can be applied to the corresponding soil layer defined under Data 

> Soil Layer Data.  

 

 

Figure 3.5  Sample Data > Soil Compressibility Data 
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Typically, the compressibility data are entered as curves of Percent Change in Height (or 

Percent Vertical Strain) versus Applied Vertical Pressure. The Applied Vertical Pressure is entered in 

kips/ft^2 for English units and in kPa for SI metric units. Although the traditional method to present 

laboratory consolidation data has been to use Void Ratio (e) as the ordinate for the test curve, many 

laboratories now use Vertical Strain, frequently as a percent. For this program, vertical strain is entered as 

Percent Change in Height so that the input is in larger numbers. For example, a Percent Change in 

Height of 10.1, is a vertical strain of 0.0101 in./in. or mm/mm. The input of Percent Change in Height 

is converted by the program internally to vertical strain for settlement computation. The simple 

relationship between Percent Change in Height, F, and Void Ratio, e, is as follows: 

100
)1(

)(

0

0 
+

−
=

e

ee
F          (1) 

where 0e = initial void ratio 

Any one of three options can be used by the user to define each soil compressibility curve. Any 

input method can be used for any layer in any order or sequence. 

Option 1 – Define Semi-Log Compressibility Curve 

The first input option is to define the semi-log soil compressibility curve by a series of straight 

lines that best fit the curve. The curve to be input can be the actual laboratory test curve or one that has 

been modified by any method to produce a curve from the laboratory test results that is believed to better 

represent the actual field compressibility. The actual input are the Percent Change in Height and the 

Applied Vertical Pressure (on the log scale), of points that define the ends of the straight lines. A 

minimum of two points (one straight line) and a maximum of twenty-five points may be used. A sample 

input of a compressibility curve is illustrated on Figure 3.6. 
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Figure 3.6  Option 1 with Sample Data Points of Compressibility Curve 

 

Option 2 – Define Slope of Semi-Log Curve 

This option can be selected when the semi-log soil compressibility curve can be represented by a 

single straight line; this is a special case of Option 1 where there is only one line segment. The input is 

entered as the slope of the straight line and, for Option 2, it shall be entered as a positive number, (+)CF. 

If Option 2 is left with the default value of zero then the SETOFF program expects to use Option 1.  

Examples of when this input method could be used are a normally-consolidated clay, a sand layer with 

small or zero compressibility, or an unloading, or rebounding, compressibility curve. The relationship 

between (+)CF and the coefficient of compressibility, Cc, (the slope of the semi-log void ratio versus 

applied vertical pressure curve) is given by the following: 
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Option 3 – Define Slope of Arithmetic Curve 

The third option to enter soil compressibility is to enter the slope of an arithmetic Percent Vertical 

Strain versus Applied Vertical Pressure curve. To indicate that Method 3 is being used, the slope should 

be entered as a negative number different than zero. If Option 2 is left with the default value of zero then 

the SETOFF program expects to use Option 1. 

This method is not used for routine settlement analyses. It has been used, for example, to develop 

influence values to use in iterative computations to obtain compatibility between computed soil 

consolidation settlement and computed structural deflections of large mat foundations. The slope to be 

input in Option 3 is related to the coefficient of volume compressibility, mv, and the coefficient of 

compressibility, av, in the Terzaghi Theory of Consolidation (Terzaghi 1943a) by the following: 

100)( =− mvCF          (3) 
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3.2.5 Data > Settlement Points Data 

The foundation plan consists of the arrangement of loaded areas comprising the foundation and the 

locations of the settlement points. The loaded areas may be footings, mats, and pile caps carrying 

structural loads or areas representing excavations that are not backfilled. A loaded area must be either 

rectangular or circular in shape. The loaded areas, however, may be entered in any order or combination 

desired. 

The settlement points are the points where settlement is to be computed. They may be located 

anywhere in the foundation plan. They also may be located at or below the ground surface but, as 

indicated previously; they must be located on the surface of one of the soil layers established for the 

computation. 

Locations of the loaded areas and the settlement points are defined by coordinates from a set of 

arbitrarily selected axes. The coordinates, however, must be positive; that is, the loaded areas and 

settlement points must be in the first quadrant of the coordinate system.  

The location of each settlement point within the first quadrant of the established coordinate system 

is input by X-Coord, and Y-Coord as shown in Figure 3.7. Each point may be located at any depth 

provided it is located on the upper boundary of a soil layer established for the settlement computation. 

The soil layer number, on which the settlement point is located, is used to instruct the program at which 

the settlement computation begins. The maximum number of settlement points is limited to 25. 
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Figure 3.7  Sample Settlement Points Data 

 

3.2.6 Data > Foundation Configuration 

The Number of shallow foundations (footings and mats) and/or the Number of pile 

foundations with pile caps (deep foundations) can be entered in the first two entries. A sample of the 

dialog box entry is shown in Figure 3.8. The number of shallow and deep foundations that can be 

computed on a single model is limited to a combined total of 50. 

The Pile-Capacity Options are used for pile foundations with pile caps. The option that is selected 

by the user will be applied to each pile foundation in the model. The reference graphics on the right 

presents the details for each of the three Pile-Capacity Options: 

• Friction piles with the fictitious footing located on the top of the friction zone 

• Friction piles with the fictitious footing located at the 1/3 depth of friction zone 

• End-bearing piles with the fictitious footing located at the top of the firm strata 
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Figure 3.8  Sample Foundation Configuration 

 

3.2.7 Data > Loaded Shallow Footings Area data 

Each shallow foundation loaded area is identified by a name entered by the user under the column 

labeled ID Code of Loaded Area, with user-defined alphanumeric characters. The shape of each loaded 

area can be either Rectangular Area or Circular Area, selected by the user with a drop-down menu. The 

number of rows that are defined by the user in this dialog box must correspond to the Number of 

shallow foundations that was previously entered under Data > Foundation Configuration.  A sample 

of this dialog box is shown in Figure 3.9. 

The net Sustained Vertical Pressure to the Soil that is imposed by each loaded area is inputted 

by the user.  This value can be positive or negative.  The Depth to Bottom of Loaded Area (depth to 

base of loaded area) must also be furnished by the user, as shown in the sample of Figure 3.9. 

The shape of each loaded area is defined by clicking on the “Circular Area” or the “Rectangular 

Area” buttons in the last column. 

As shown in the sample definition in Figure 3.10, for Rectangular Area the user should enter the 

X-Coord at center of the area and Y-Coord at center of the area, which are the X- and Y- 

coordinates for the center of each rectangle.  The Width of the Rectangular Area is the length of the 

side in the X-direction.  The Length of the Rectangular Area is the length of the side in the Y-

direction.  The Angle Above the Horizontal Line is the angle (in degrees) that the side of the 

rectangular loaded area makes with the X-axis.  These three input values are evident for a loaded area 

with sides parallel to the coordinate axes, but they are not quite so clear for a loaded area whose sides are 

not parallel to the axes. Figure 3.9 provides graphical references of these input values for footings that are 

not parallel to the chosen axes. 
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Figure 3.9  Sample entry for Loaded Shallow Footing Areas 

 

Figure 3.10  Sample definition of a Rectangular Area 

As shown in the sample definition on Figure 3.11, for Circular Area the user should enter the X-

Coord at the center of the circle and Y-Coord at the center of the circle, which are the X- and Y- 

coordinates for the center of each circular area.  The Diameter of the Circle must also be entered to 

complete the geometry of circular loaded areas. 
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Figure 3.11  Sample definition of a Circular Area 

 

3.2.8 Data > Pile Foundation Data 

This entry is only enabled if the user enters 1 or more Number of pile foundations with pile caps 

(deep foundations) under the Data > Foundation Configuration dialog box.  A sample of the dialog box 

under Data > Pile Foundation Data is shown in Figure 3.12.  The number of rows that are defined by 

the user in this dialog box must correspond to the Number of pile foundations with pile caps that was 

previously entered under Data > Foundation Configuration.  Each row corresponds to one deep 

foundation with a pile cap. 

As shown in the sample definition in Figure 3.12, the user should enter the X-Coord at Center of 

Cap and the Y-Coord at Center of Cap, which are the X- and Y- coordinates for the center of each pile 

cap.  The defined coordinates should avoid the negative regions of the XY plane. 

The Length Along X-Direction and Width Along Y-Direction define the size of the pile cap.  

Areas in the negative region of the XY plane should be avoided. 

The Depth to the Base of the Pile Cap is used to define the location of the bottom of the pile 

cap.  This should be located at the surface of a soil layer. 

Depth of Zero Friction Near the Top is used to define a zone on the top of the pile where the 

user wants to assume no transfers in side resistance.  This value is taken from the top of the pile and down 

along the length of the pile. 

Pile Length is used to defines the length of the pile (or of the piles in the defined group of piles).  

Vertical Load at Pile Cap is used to define the vertical load that is applied on the pile cap. 

 

 
Figure 3.12  Sample Data > Pile Foundation Data 
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4.1 Introduction 

Error! Reference source not found. presents features related to execution of the program and 

includes methods of addressing run-time errors.  This Chapter also includes suggestions for reviewing 

input, output, and processor text files.  The final section of this Chapter includes descriptions of the 

graphical features.  The commands covered in this chapter are contained in the top menu, under the 

Computation and the Graphics titles. 

4.2 Computation Menu 

This menu option is selected to execute the program using the parameters that were saved in the 

input-data file.  Within the options contained under this menu, shown in Figure 4.1, there are commands 

that facilitate the reviews of the text files produced for storing input data, output results, and processor 

notes.  Detailed description of the submenu options contained under the Computation menu are 

explained in the following topics. 

 
Figure 4.1  Computation Menu 

4.2.1 Computation > Run Analysis 

An input file, after preparation or modification, should be saved to disk before selecting the 

Computation > Run Analysis submenu option, which executes the analytical portion of program 

SETOFF. 

The SETOFF program always first automatically saves the input data file before performing 

computations.  If the model was never saved then the program will prompt the user to save the data file.  

When saving a data file, the SETOFF program will automatically add an extension of the type *.se4t to 

the name of the input data file.  The program is not able to save data files that are compatible to older 

versions/releases of SETOFF. 

When the execution process is finished the active command is returned to the main SETOFF 

program with a screen indicating that computations are completed.  The user should always check the 

output text file for any error messages that were produced during computations. 

Several additional files are created in every new SETOFF run.  A general description of these files 

was presented earlier in Table 2.1.  Every successful run of SETOFF generates four text files in the same 

drive and directory where the input-data file was saved or opened.  Any of these files may be opened with 

standard text editors or word processing programs. 
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4.2.2 Edit Input Text 

This submenu option is used to review/edit the input-data file that is currently processed by the 

program.  This command becomes active after new data files have been saved to disk or when opening 

existing data files.  The command is helpful for experienced users who may want to change one or two 

parameters quickly using a plain-text editor, or for those users wishing to observe the prepared input data 

in text mode. 

This submenu automatically invokes the word processor or text editor specified in Options > Text 

editor.  The default setting is to use the utility program named notepad.exe provided by Microsoft 

Windows©.  Input-data files are automatically saved to disk with the user-specified file name and the 

extension of *.se4t by program SETOFF.  Use of the notepad program for editing the input data is shown 

in Figure 4.2. 

 

Figure 4.2  Sample use of Microsoft Notepad© with input text of Example Problem 1 

4.2.3 Edit Processor-Run Notes 

This submenu option is used to edit an intermediate text file that is automatically produced during 

each analytical run.  This file only may include notes produced during the processing of the input data.  

This submenu option becomes active after new data files have been saved to disk and executed, or when 

opening previously-executed data files. 
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This submenu automatically invokes the word processor or text editor specified in Options > Text 

editor.  The default setting is to use the utility program named notepad.exe provided by Microsoft 

Windows©.   

Files containing processor-run notes are automatically saved to disk with the same file name as the 

input-data file but with the extension *.se4r.  Use of the Microsoft Notepad© for editing the processor- 

run notes for Example Problem 1 is shown in Figure 4.3. 

Observation of the notes produced during a processor run may become helpful to debug a data file 

that did not produce a successful run. 

 

Figure 4.3  Sample processor-run notes for Example Problem 1 in Microsoft Notepad© 

4.2.4 Edit Output Text 

This submenu option is used to edit the output-text file that is automatically produced during each 

successful analytical run.  This command becomes active after new data files have been saved to 

disk and successfully executed, or when opening previously-executed data files. 

This submenu automatically invokes the word processor or text editor specified in Options > Text 

editor.  The default setting is to use the utility program named notepad.exe provided by Microsoft 

Windows©.   

Output files are automatically saved to disk with the same file name as the input-data file but with 

the extension *.se4o.  Use of Microsoft Notepad© for editing the output file for Example Problem 1 is 

shown in Figure 4.4. 
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The organization of results is displayed in the output text file as a series of tables. The tables are 

listed as follows: 

Table 1: Problem Control Parameters 

Table 2: Soil and Layer Information 

Table 3: Soil Compressibility Source and Data 

Table 4: Settlement Point Data 

Table 5: Loaded Area Information 

Table 6: Average Stress Increase 

Table 7: Computed Settlement 

 

 

Figure 4.4   Sample output-text file of Example Problem 1 in Microsoft Notepad© 

4.3 View Menu 

This menu is selected for observation of graphical results of the settlement curve(s) from the model 

and a three-dimensional representation of the model, which includes the soil stratigraphy, foundations and 

results. 

4.3.1 View > Graphics 

This menu can be selected after any successful computational run to display a plot of the 

computed settlement at the settlement points that were specified by the user.  A graph, similar to 

the sample in Figure 4.5, will display a series of lines connecting the selected settlement points on a 

model.  The user has the option to select with a check mark the settlement points that should be displayed 

in the resulting graphics.  The Print Settlement Curve button can be used to print the observed graphics. 
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Figure 4.5   Settlement curve for selected settlement points on a model 

 

4.3.2 View > 3D View 

This menu displays a three-dimensional model of the soil stratigraphy and foundations. A sample 

presentation of the 3D View menu for a model is shown in Figure 4.6.  This is a very useful tool 

to check the modeled foundations, soil stratigraphy and location of requested settlement points.  This is 

also useful for the observation of computed settlements within the modeled system. 

The selection of the 3D View menu enables the speed buttons shown in Figure 4.7 and also the new 

Show menu that is described in the next section of this manual. 

The speed buttons in the toolbar are used to manipulate the view of the soil and foundation model. 

Placing the mouse cursor over the buttons will display the button’s function.  Figure 4.7 shows additional 

descriptions for the 3D View speed buttons. 

 



CHAPTER 4 – Program Execution and Output Reviews – 4-7 

 

User’s Manual (Rel. Feb. 2020)  SETOFF v2020 
 

 

Figure 4.6   Sample 3D View of SETOFF Model 

 

Figure 4.7   Summary of Speed Buttons for 3D View 

4.4 Show Menu 

The Show menu is available only if the 3D View is selected in the View menu and as long as the 

3D View window is open.  A sample of the Show menu is included in Figure 4.8.  

Selections in the Show menu are described as follows: 

Soil Layers 

Displays soil layers defined in the model.  This is On by default. 

Soil Layer Labels 

Displays the label for each soil layer. 
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Soil Layer Depth Labels 

Displays the depth of each soil layer. 

Footing Areas 

Displays footing areas representing the shallow foundations in the model.  This is On by default. 

Footing Areas Labels 

Displays the ID Code of Loaded Area that was defined by the user for each loaded area (footing 

foundation).  See Section 3.2.7 for reference. 

Project Areas to Ground 

With this selection, the display of each loaded area is projected to the ground surface.  This is On by 

default. 

Pile Cap Blocks 

Displays pile cap blocks representing deep foundations defined in the model.  This is On by default. 

Settlement Points 

Displays the approximate location and label (numbering) of each settlement points that was defined in the 

model.  See Section 3.2.5 for reference. 

Settlement Results 

Opens the Settlement Results dialog box, shown in Figure 4.9, where graphical representation of output 

results can be displayed in 3D View.  

Show Settlement Results  ................... enables the display of settlement results. 

Show Bar Plot .  ............... displays a bar plot at each settlement point. This option is useful for comparing 

settlements at different points. The Bar Length Factor and Bar Width Factor can be 

adjusted to change the bar sizes for better viewing while maintaining the correct ratios for 

comparisons.  In addition, the Bar Plot can be displayed vertical (D Axis as default) or 

horizontal (X Axis or Y Axis). 

Show Values ....  ............... displays numerical values of settlement at each settlement point.  The Only 

Maximums option displays only the maximum value in the model. 

Show Settlement Points .  ................... displays the approximate location and label (numbering) of each 

settlement points that was defined in the model. 
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Figure 4.8  Sample Show Menu 

 
Figure 4.9  Sample Settlements Results dialog window for 3 D View 
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5.1 Introduction 

The output text file for the program SETOFF is presented in seven tables that are formatted to print 

on standard letter-size sheets (8.5 in x 11 in).  Tables 1 and 2 are combined on one section and Tables 3 to 

7 are “stand-alone” tables.  A stand-alone table contains only one type of data and can be removed 

without materially affecting the continuity of the output.  All of the output is considered important in 

verifying the input data and in aiding a manual check of the computational results.  The user may elect, 

however, to remove and discard some of the output tables when submitting on a formal report. 

5.2 Description of Output Tables 

The following paragraphs present brief descriptions of the information presented in the output 

tables. 

Table 1 - Units and Problem Parameters 

This table shows the units selected for the settlement computation and the parameters that are used 

to control the numerical model.  These parameters include the number of soil layers, number of soil 

compressibilities, number of settlement points and number of loaded areas that define the scope of the 

computation. 

Table 2 - Soil and Layer Information 

This table can be combined with Table 1 as the first section of the printout.  The information in 

Table 2 consists of input data and values computed from the input data.  The input data presented are the 

soil layer number, the thickness factor for the layer, the effective unit weight of the soil in the layer, and 

the identification number of the soil compressibility that should be used for the layer. The computed 

values include the depth to the center of the layer, the thickness of the layer, the overburden pressure at 

the center of the layer, and the initial percent vertical strain for the soil in the layer. 

Table 3 - Soil Compressibility Data 

This is a stand-alone table presenting the compressibility number, a description used to identity the 

soil compressibility, followed by the soil compressibility curve.  For a semilog nonlinear curve, the soil 

compressibility data consists of a series of percent vertical strain and applied vertical pressure values 

representing points defining the nonlinear compressibility curve.  For a linear curve, the soil 

compressibility data is the slope of the curve, a positive value for a semilog curve or a negative value for 

an arithmetic curve. 

Table 4 - Settlement Point Data 

This is a stand-alone table describing the identification of each settlement point along with the x- 

and y-coordinate for each point and the number of the soil layer on which it is located. 

Table 5 - Loaded Area Data 

The data for each loaded area consists of: an identification for the loaded area; an indication of the 

shape (1 for rectangle or 2 for circle); the x- and y- coordinate for the center of the loaded area; the length 

in the x-direction, the length in the y-direction, and the slope with the x-axis for rectangular areas 
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(diameter, zero and zero for circular areas); the sustained pressure applied to the soil by the area; and the 

depth to the base of the area. 

Table 6 - Average Stress Increase 

The information presented in this table is the computed average stress increase at the center of each 

layer beneath each settlement point. 

Table 7 - Computed Settlement 

This table presents the computed settlements which are the primary reason for the use of the 

program SETOFF.  The information presented is the computed settlement for each soil layer beneath each 

settlement point with a total settlement for each settlement point. 

The computed settlement for each layer and the total settlement for each settlement point is 

presented so the user can make comparisons with simple hand-computational checks of the computed 

settlement. 

Notice that the computer may calculate and total many small settlements that may not actually 

occur in the field.  For instance, many years ago, Terzaghi (1941) advanced a hypothesis that 

consolidation of undisturbed clay does not occur unless the stress increase exceeds some “threshold” 

value.  A rule-of-thumb for this “threshold” value is a stress increase of about ten percent of the effective 

overburden pressure.  The user may elect to use a smaller number of layers for the settlement by manually 

totaling the computed settlements for this smaller number of layers.  For consistency, however, the same 

number of layers should be used for all settlement points. 

5.3 Installation of Example Files 

All input and output files for the examples of SETOFF v2020 are installed with the program.  

During program installation, the user is provided with an option to select a drive and directory for the 

installation of example files (see Figure 2.4 in Section 2.1.1(7)).  If it was not changed by the user, the 

example files can be found in the following default installation directory: 

(Root Drive)\Ensoft\Setoff2020-Examples 

The input-data files for models created in SETOFF v2020 have extensions of the type filename.se4t 

(such as Example1.se4t), as previously indicated in Table 2.1. 

5.4 Example 1 – Shallow Foundations 

5.4.1 Problem Description 

Example Problem 1 is presented as one sample method that may be used for estimation of 

settlements.  This example can provide the user an idea on how to prepare the soil stratigraphy for a site 

and one way to interpret the soil compressibility curve obtained from consolidation tests.  The model also 

shows a distribution of several circular and rectangular loaded areas on the site plus selected points where 

consolidation is asked to be computed. 
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The soil conditions for this example problem are shown in Figure 5.1 with one of the soil 

compressibility curves for the site shown in Figure 5.2.  The foundation and settlement plan for the 

example are shown in Figure 5.3. 

 

Figure 5.1  Soil conditions for Example Problem 1 
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Figure 5.2  Soil Compressibility curve for Example Problem 1 
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Figure 5.3  Foundation plan for Example Problem 1 
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5.4.2 Input and Output Data Files for Example 1 

Users can read Section 5.3 of this manual for reference on the location of placement of the input and 

output data files for the example files installed with this program.  The input data files for all examples 

presented in this manual are installed automatically with the program. 

The input-data filename for Example 1 is the following: 

Example1 - Shallow Foundations.se4t 

The output-data filename for Example 1 is the following: 

Example1 - Shallow Foundations.se4o 

5.4.3 Input Data File Text for Example 1 

Selecting the menu Computation > Edit Input Text from within SETOFF will open the input data file 

(that was opened or last saved in SETOFF) using the selected text editor (default is Windows Notepad).  

It is not recommended to make any changes to the file while in this mode, unless the user is very 

knowledgeable about Windows file management and the SETOFF data-entry organization. 

The following is a reproduction of the text on the data input for Example 1.  This is copied here for 

reference to the original data file distributed with the program (in case it is accidentally modified later). 

 

SETOFF Version 2020.4.1 

SETOFF EXAMPLE PROBLEM 1 - Shallow Foundations 

1 

17 6 13 30 

1 5. 122. 1 1. 

2 7. 122. 1 1. 

3 9. 122. 1 1. 

4 12. 120. 1 1. 

5 15. 120. 1 1. 

6 18. 58. 1 1. 

7 21. 66. 2 1. 

8 24. 68. 2 1. 

9 28. 68. 2 1. 

10 32. 70. 2 1. 

11 37. 70. 3 1. 

12 47. 70. 4 1. 

13 57. 70. 4 1. 

14 67. 68. 5 1. 

15 77. 68. 5 1. 

16 87. 64. 6 1. 
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17 100. 64. 6 1. 

1 7 

CONSOLIDATION TEST 70-053, BORING 2, 15 FT (MODIFIED)        

0. 0.5 

1.1 3. 

1.5 4. 

1.9 5. 

2.65 6. 

4.5 8. 

13. 32. 

2 7 

CONSOLIDATION TEST 70-053, BORING 2, 35 FT (MODIFIED)        

0. 0.7 

0.7 3. 

1. 4. 

1.5 5. 

2.1 6. 

3.2 8. 

9.5 32. 

3 1 

SAND LAYER, ASSUMED INCOMPRESSIBLE                           

0.001 

4 5 

CONSOLIDATION TEST 70-053, BORING 4, 50 FT 

0. 1.88 

0.6 4. 

1.62 8. 

2.85 16. 

4.7 32. 

5 5 

CONSOLIDATION TEST 70-053, BORING 2, 65 FT 

0. 1.86 

1.16 4. 

2.64 8. 

4.22 16. 

6.36 32. 
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6 7 

CONSOLIDATION TEST 70-053, BORING 4, 90 FT 

0. 1.46 

0.2 2. 

1.06 4. 

3.4 8. 

4.1 16. 

4.9 20. 

7.2 32. 

1 225. 225. 2 

2 225. 250. 2 

3 225. 275. 2 

4 250. 275. 2 

5 275. 275. 2 

6 275. 300. 2 

7 250. 300. 2 

8 225. 300. 2 

9 279.34 369.62 2 

10 275. 345. 2 

11 262.5 323.35 2 

12 279.34 320.38 2 

13 300. 300. 2 

 A-1 

   2  225. 225. 10.  0.0   0.00   2. 5. 

 A-2 

   2  250. 225. 10.  0.0   0.00   2.2 5. 

 A-3 

   2  275. 225. 10.  0.0   0.00   2.4 5. 

 A-4 

   2  300. 225. 10.  0.0   0.00   2.2 5. 

 A-5 

   2  325. 225. 10.  0.0   0.00   2. 5. 

 B-1 

   2  225. 250. 10.  0.0   0.00   2.2 5. 

 B-2 

   1  250. 250. 15. 15. 0. 2.4 5. 
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 B-3 

   1  275. 250. 15. 15. 0. 2.4 5. 

 B-4 

   1  300. 250. 15. 15. 0. 2.4 5. 

 B-5 

   2  325. 250. 10.  0.0   0.00   2.2 5. 

 C-1 

   2  225. 275. 10.  0.0   0.00   2.2 5. 

 C-2 

   1  250. 275. 15. 15. 0. 2.4 5. 

 C-3 

   1  275. 275. 15. 15. 0. 2.4 5. 

 C-4 

   1  300. 275. 15. 15. 0. 2.4 5. 

 C-5 

   2  325. 275. 10.  0.0   0.00   2.2 5. 

 D-1 

   2  225. 300. 10.  0.0   0.00   2. 5. 

 D-2 

   2  250. 300. 10.  0.0   0.00   2.2 5. 

 D-3 

   2  275. 300. 10.  0.0   0.00   2.4 5. 

 D-4 

   2  300. 300. 10.  0.0   0.00   2.2 5. 

 D-5 

   2  325. 300. 10.  0.0   0.00   2. 5. 

 T-1 

   1  300. 345. 10. 10. 0. 2.8 7. 

 T-2 

   1  294.15 361.07 10. 10. 0.839 2.8 7. 

 T-3 

   1  279.34 369.62 10. 10. 5.673 2.8 7. 

 T-4 

   1  262.5 366.65 10. 10. 0.577 2.8 7. 

 T-5 

   1  251.51 353.55 10. 10. 2.747 2.8 7. 
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 T-6 

   1  251.51 336.45 10. 10. 0.364 2.8 7. 

 T-7 

   1  262.5 323.35 10. 10. 1.732 2.8 7. 

 T-8 

   1  279.34 320.38 10. 10. 0.176 2.8 7. 

 T-9 

   1  294.15 328.93 10. 10. 1.192 2.8 7. 

T-10 

   1  275. 345. 10. 10. 0. 2.8 5. 

0 

15 

EXECUT 
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5.5 Example 2 – Single Deep Foundation 

5.5.1 Problem Description 

This example deals with settlement on a single deep foundation.  As shown in Figure 5.4, a pile 

group of 2.75 m by 2.75 m is placed in a deep clay stratum supporting a vertical load of 1335 kN.  The 

soil stratigraphy consists of a 6-m sand layer and a 26- m clay layer reaching bedrock.  The soil stratum is 

divided into 5 layers with the respective properties of unit weight and soil compressibility.  The unit 

weights and compressibility information for the soil are shown in Figure 5.4.  The sand can be assumed to 

be incompressible and the clay is provided with the void ratio and coefficient of compressibility. 

Figure 5.4  Graphical Sketch for Example Problem 2 
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5.5.2 Guidance and Steps for Data Input 

5.5.2.1 Options – Units 

Before proceeding to the actual data input, the user should first select the type of units.  By default, 

standardized units are set to English Units.  For this example, the information was provided in SI units so 

SI Units should be selected under the Options > Units menu. 

 

 

5.5.2.2 Data menu 

In the next step, the user should go through the Data menu sequentially from top to bottom. 

5.5.2.3 Data > Title 

Enter any appropriate description for reference to this SETOF model and project. 

 

5.5.2.4 Data > Soil Layer Data 

Define the soil layers for the model, following the details provided in Figure 5.4.  Use the Add Row 

button or the Ctrl-A keyboard combination to define 5 layers.   

In the first column, enter the depths of the top of each layer.  The first layer must always be set at the to 0 

m as the Top Depth.   

Enter the depth to the bottom of the layer in the second column.   

Note for the third column that the value shall be the “effective” unit weight (total unit weight above the 

water table and submerged unit weight below the water table).  For layers 2-5 the unit weight of water is 

subtracted from the saturated unit weight to obtain the effective unit weight.   
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The soil compressibilities shall be defined in the next menu entry for Data > Soil Compressibilities.  

The user may have models with the same compressibility curve for some layers, but in this example the 

model is defining a different curve for each layer.   

Finally, the Layer Thickness Factor for the last column can be set to 1. 

 

5.5.2.5 Data > Soil Compressibility Data 

Define the compressibility curves that are used in the model.  Use the Add Row button or the Ctrl-A 

keyboard combination to define 5 rows.  The number of rows must be equal to the number of Soil 

Compressibility Curve No. used in the previous section (Data > Soil Layer Data). 

The first column labeled Curve # is automatically assigned to each row and corresponds to the curve 

number that shall be referenced under Soil Compressibility Curve No. in the Data > Soil Layer Data. 

In the second column, the user may enter any alphanumeric identification that can be used for ease of 

identification of each compressibility curve. 

Option 2 will be used to define each compressibility curve in this example, since the compressibility data 

shown in Figure 5.4 was provided as coefficients of compressibility with a void ratio. 

The Equation (2) in Section 3.2.4 is used to input the values under Option 2.  The sand layers can be 

assumed to be incompressible so the small value of 2 is entered.  For the clay layers, sample calculations 

using Equation 2 are shown in the following: 
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5.5.2.6 Data > Settlement Points Data 

Define the location (coordinates and soil layer) of settlement points where computations are desired.  Use 

the Add Row button or the Ctrl-A keyboard combination to define the necessary rows. 

Two settlement points are selected.  For this example, the first settlement point is defined at a distance 

outside the pile-group foundation.  The second settlement point is defined at the center of the pile-group 

foundation.  The Starting Soil Layer Number is layer #1 which is the top soil layer. 

 

5.5.2.7 Data > Foundation Configuration 

The user shall enter in this dialog box the number of shallow and deep foundations.  For this example, 

only one deep foundation is being examined.  Number of shallow foundations is thus left as 0 and 

Number of pile foundations with pile caps is set to 1. 

The proper Pile-Capacity Option must also be selected for the analysis of a deep foundation. Three 

options are available.  For this example, the second option is selected: Friction piles with the fictitious 

footing located at the 1/3 depth of friction zone. 

 



CHAPTER 5 – Example Problems – 5-16 

 

User’s Manual (Rel. Feb. 2020)  SETOFF v2020 
 

 

 

5.5.2.8 Data > Pile Foundation Data 

This dialog box is used to define each pile foundation.  Use the Add Row button or the Ctrl-A keyboard 

combination to define as many rows as Number of pile foundations with pile caps defined in the 

previous section.  In this example, only one pile foundation was defined. 
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The coordinates (50, 50) are entered to define the location of the center of the pile group.  It is 

recommended to keep the foundation in the positive XY plane region.  The coordinates of the center of 

the pile group also coincides with settlement point #1 defined previously. 

The pile group is 2.75 m by 2.75 m.  These values are entered under Length along X-direction and 

Width along Y-direction.  The Depth to the Base of the Pile Cap is set to 0 to set the bottom of the 

cap to the top of layer 1.  The Depth of Zero Friction near the Top can be considered as 0.  The Pile 

Length is 21 m and Vertical Load at Pile Cap is 1335 kN. 

 

5.5.3 Computation Menu 

After data input is complete, the SETOFF program is ready to execute an analysis. 

5.5.3.1 Computation > Run Analysis 

Select this menu to instruct SETOFF to perform the numerical calculations and upon a successful run a 

confirmation window should appear.  After a successful run, the input data and output results can be 

reviewed. 

 

5.5.3.2 Input Data File Text for Example 2 

Selecting the menu Computation > Edit Input Text from within SETOFF will open the input data file 

(that was opened or last saved in SETOFF) using the selected text editor (default is Windows Notepad).  

It is not recommended to make any changes to the file while in this mode, unless the user is very 

knowledgeable about Windows file management and the SETOFF data-entry organization. 

The following is a reproduction of the text on the data input for Example 2.  This is copied here for 

reference to the original data file distributed with the program (in case it is accidentally modified later). 
 

SETOFF Version 2020.4.1 

SETOFF EXAMPLE PROBLEM 2 - Single Deep Foundation 

2 

5 5 2 0 

1 3. 15.72 1 1. 

2 6. 8.74 2 1. 
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3 24. 9.37 3 1. 

4 29. 8.27 4 1. 

5 32. 9.69 5 1. 

1 1 

Comp Data 1 

2. 

2 1 

Comp Data 2 

2. 

3 1 

Comp Data 3 

44.44 

4 1 

Comp Data 4 

15.5 

5 1 

Comp Data 5 

15.29 

1 25. 25. 1 

2 50. 50. 1 

1 

1 

1 50. 50. 2.75 2.75 0. 0. 21. 1335. 

EXECUT 

5.5.3.3 3D View Samples for Example 2 

The View > 3D View menu offers the user with many features to display the modeled foundation system 

along with results.  The modeled system in elevation view can be easily displayed to check the depths of 

the foundation and the soil layering system.  A sample elevation is shown in Figure 5.5. 

The settlement results at the two defined points can be observed in the 3D View graphics using features 

from the Show > Settlement Results dialog box.  A sample elevation is shown in Figure 5.6. 
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Figure 5.5  Elevation 3D View of Example 2 

 

Figure 5.6  Settlement Results for Example 2 
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6.1 Introduction 

This document and the computer program SETOFF provide methods to compute consolidation 

settlements at selected points due to the loads from foundations consisting of one or more footings, pile 

foundations and/or mats. 

Settlements are computed by generally-accepted procedures (see, for example, Taylor 1948a).  The 

settlement computation procedure is simple but it must be repeated numerous times in computing 

settlement for many foundation plans and soil conditions.  For example, the computation of average stress 

increase at the center of each soil layer with 25 soil layers, 10 loaded areas, and 10 settlement points 

requires 2600 (10x10x25) computations of stress distribution.  Computing settlement would require 

another 250 calculations.  The program SETOFF does rapidly-performing repetitious calculations and 

extensive summations. 

A settlement analysis can be divided into three parts.  The first part is the determination of: (a) the 

soil stratigraphy and the pertinent properties of the soils at the site; and (b) the layout of the foundations 

and the points at which settlement computations are desired.  The second part is the determination of the 

stress change at pertinent depths below the ground surface beneath each selected settlement point due to 

the loading from all areas comprising the foundation.  The third part is the computation of settlement 

using the information from the first two parts.  The program SETOFF will accomplish the second and 

third parts quickly and efficiently, but the quality of the results will depend on the quality of the input data 

developed by the user in the first part.  

The computation of settlement is only as good as the data used for the computation.  The 

determination of soil conditions at a site should be under the direction of a competent geotechnical 

engineer. 

6.2 Soil Stratigraphy 

The sequence of soil layers at a site should be determined by a soil investigation.  A soil layer is 

defined not only by the type of soil — clay, silt, sand, gravel, etc. —, but also by the consistency of the 

soil — soft, stiff, loose, dense, etc.  Stratigraphy is determined by soil borings.  Sufficient borings should 

be made to establish soil stratigraphy over the area of the settlement computations.  Uniform conditions 

will require a smaller number of boring than will complex soil conditions. 

6.3 Soil Properties 

Soil properties should be determined by laboratory soil tests.  Soil properties such as water content, 

Atterberg limits, and strength are useful in the evaluation of general soil conditions, but only two soil 

properties, unit weight (mass density) and compressibility are specifically required for settlement 

calculation.  Unit weight (mass density) is determined in the laboratory by direct measurements on 

undisturbed samples from borings, and compressibility by consolidation tests, also on undisturbed 

samples from borings.  Sufficient tests should be made to fully evaluate these two soil properties within 

the effective depth of the settlement computations. 
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6.4 Change of Soil Stress Due to Foundation Loads 

The second part of a settlement analysis, as stated previously, is to determine the change in stress in 

each soil layer beneath each settlement point due to the loads from all loaded areas.  This is accomplished 

by summing the stresses computed at the top, middle and bottom of each layer beneath each settlement 

point from each loaded area.  Each stress distribution is computed for a unit loading and then rounded to 

five decimal places before it is multiplied by the input load for the loaded area.  This is to minimize the 

effects from distant loaded areas which probably are not significant in the actual case.  The average stress 

change for each layer is determined from these summed stress changes at the top, middle and bottom of 

the layer by Simpson’s Rule.  The stress distribution computations are based on equations obtained by 

integrating the Bousinesq Equations for the vertical stress at a point within a semi-infinite solid due to a 

point load on the surface. 

6.4.1 Rectangular Foundations 

Stress distribution from rectangular loaded areas is computed by Newmark’s Equation for the stress 

beneath the corner of a rectangular loaded area (Newmark 1935).  By proper addition and subtraction of 

the stress beneath the corner of four areas, the stress due to a rectangular area can be computed at any 

point whether it is directly beneath or outside the loaded area (Taylor 1948, Terzaghi 1943b). The stress 

distributions computed by this program are in agreement with values from tables given by Terzaghi 

(1943c). 

6.4.2 Circular Foundations 

Stress distribution for circular areas is computed by equations given by the Waterways Experiment 

Station, U.S. Army (W.E.S. 1953).  Stress distribution computation with these equations requires values 

for elliptic integrals of the first and of the second kind.  An approximate numerical routine was coded for 

this program to evaluate the elliptic integrals.  The elliptic integral values computed by this routine are 

accurate to at least five significant figures, which is sufficiently accurate for the stress computations.  

Values of stresses computed by this program at relative depths of 0 to 5 radii beneath points located 0, 

0.5, 1.0, 1.5 and 2.0 radii from the center of a circular area are in complete agreement with tabulated 

values presented by Jumkis (1971). 

6.4.3 Average Layer Stress Change 

The stress distributions from each loaded area are computed and summed for depths at the top, 

middle and bottom of each soil layer.  These values are used with Simpson’s Rule to compute the average 

stress change, pavg, for the layer by the following equation: 

pavg = (pt + 4 pm + pb)/6 (1) 

where pt, pm and pb are the stress changes at the top, middle, and bottom, respectively, for the soil 

layer. 

6.5 Settlement Computation 

The increment of settlement due to the average stress change is computed for each layer beneath 

each settlement point.  The increments for each layer beneath a settlement point are then summed to 
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obtain the computed settlement for that point.  The method used to compute the settlement for a layer 

depends on the method used to input the soil compressibility for that layer. 

If the soil compressibility is entered as points on a nonlinear semi-log curve (Method 1), then the 

following equation is used to compute settlement, si: 

si = (hi)(hf)(f1-fo)/(1-fo) (2) 

where 

  hi = layer height (thickness) 

  hf = layer thickness factor 

  fo = vertical strain at po 

  f1 = vertical strain at p1 

      po = overburden pressure 

            pavg = average stress change 

  p1 = po + pavg 

In the above equation, fo and f1, the vertical strains, are in decimal form and not in percent. 

If the soil compressibility for the layer is entered as the slope of a linear semi-log curve (Method 

2), then the settlement, si, is computed by: 

si = (hi )(hf)[(+)CF][log10(p1/po)] (3) 

where (+)CF is the slope of the linear semi-log compressibility curve and the other terms as defined 

above.  The (+)CF value in the above equation is in decimal form (automatically converted by the 

program from the input in percent.) 

If the soil compressibility for the layer is entered as the slope of a linear arithmetic soil 

compressibility (Method 3), then the settlement, si, is computed by: 

si = (hi )(hf)[(-)CF](pavg) (4) 

where (-)CF is the slope of the arithmetic compressibility curve, in decimal form,  in the range 

from po to p1 and the other terms as previously defined. 
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