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1.1 General Description 
 The program is aimed at the solution under static loading of two classes of problems encountered 
in structural engineering: a soil-supported mat or a structural slab.  The mat or structural slab is modeled 
with linear finite elements.  The shape may be rectangular, round, or irregular and the thickness may vary.  

 For the soil-supported mat, soil is assumed to have a linear response, defined as the subgrade 
modulus, and is characterized by a set of springs which can vary in stiffness at points under the mat.  The 
springs can reflect horizontal and vertical resistance.  The solution follows the classical Winkler model.  
This method of modeling soil has been widely used in the analysis of flexible beams and mats on elastic 
materials. Since the Winkler model, often referred to as a “one-parameter model”, cannot represent a 
continuous medium well, the modified Vlasov model by Vallabhan and Das (1988) was also introduced in 
GeoMat for solving the soil-structure interaction in continuous medium.  The modified Vlasov model 
accounts for the effect of the neglected shear strain energy in the soil and shear forces that come from 
surrounding soil by introducing an arbitrary parameter, γ, to characterize the distribution of the vertical 
displacement in an elastic foundation using an iterative procedure. The modified Vlasov model has 
improved the accuracy of the solution computed based on the Winkler soil model. 

 When a structural slab is analyzed, the supports can be assumed to exist at the edges, or along the 
interior of the slab, as for beams.  The edges of the slab are assumed to be simply supported or subjected to 
a moment.  The supports for the slab may be assumed to be unyielding or set of deflections may be specified.  
Iteration may be done externally to get agreement between deflection of the slab and that of the supporting 
beams.  This program has the ability to compute deformation and stresses of isotropic or orthotropic plates 
based on the first order Mindlin thick plate theory. The orthotropic plates include uniform plates with 
orthotropic reinforcements, plate with orthotropic enhanced ribs, and plate with one way box section.  The 
program also allows the user to define the orthotropic plates/slab with the user-specified properties. 

 GeoMat allows the user to specify loadings on the surface of the mat or slab as uniform, or 
distributed, or concentrated as from columns.  Horizontal loads may be applied as well as vertical.  The 
finite-element method employed by this program can take into account the variety of loadings as well as 
the properties of the material in a structure.  With modern methods of characterizing material in the mat or 
slab and with the capability of desktop computers, solutions to finite-element arrays proceed rapidly and 
with a degree of accuracy in the control of the user.   

 The program does not set a limit on the number of finite-element meshes for modeling.  Only the 
size of RAM in the user's computer will limit the available meshes.  The element types include 4-node 
linear elements, 8-node quadratic elements, and 9-node Lagrangian elements.  The soil is assumed to behave 
in the linear range, but the user may assign different values of subgrade stiffness at desired locations of the 
foundation. 

1.2 Method of Analyses 
 The engineer must make several initial steps in performing the analysis and design of a soil-
supported mat or a structural slab: 1. estimate the allowable bearing capacity of the mat or the resistance 
provided by the structural members supporting the slab; 2. estimate settlement and differential movement 
of the mat or slab; and 3. estimate the moments and shears for the structural design of the mat or slab.  
Assuming that a geotechnical engineer has provided information on the soil, leading to an estimate of the 
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bearing capacity of the mat, the experience of the structural engineer will allow for the sizing of the mat or 
slab for the initial analyses.  

 With regard to the soil-supported mat, the initial data provided by the geotechnical engineer may 
show a range of values because settlement and differential movement are difficult to estimate because the 
settlement is dependent on the stiffness of the soil and on the rigidity of the mat.  

 Loadings on a mat or a slab can vary widely in nature and magnitude.  The finite-element method 
has been the best tool to take into account the variety of loadings as well as the properties of the material 
in a structure.  With modern methods of characterizing material in the mat or slab and with the capability 
of desktop computers, solutions to finite-element arrays proceed rapidly and with a degree of accuracy in 
the control of the user.  

 For a given set of loadings, deformations and movements within the mat and slab can be computed, 
along with bending moment and shear stress at any point with the material.  These results provide the 
engineer with information used for the design of the system.  The method can be applied to a mat or slab 
that is circular, rectangular, or an irregular shape, leading to a powerful analytical tool interpreted 
comparably.  Furthermore, in only a few instances have measurements been made, using the necessary 
instrumentation, that reveal the detailed manner in which the foundation interacts with the supporting soil.  

 For the mat on foundation, information is available in technical literature on subgrade modulus.  
Plainly, the reaction of soil against the base of a foundation is dependent on the deflection of the foundation; 
therefore, the value of the subgrade modulus is not constant.  For many problems of a mat on foundation, 
however, a constant value of subgrade modulus will lead to acceptable solutions because deflections in 
most cases are relatively small.  The ability to compute the settlement of the mat at all points will allow the 
engineer to use judgment about the value of modulus being used and adjustment in the value can be made 
where indicated.  The ability to study the influence of the various parameters that entered in the problem 
gives the engineer powerful tools for analysis and design. 

1.3  Program Features and Change Log 

1.3.1 GeoMat 1.0 (2004) 

 The initial version was able to consider the soil-structure-interaction by using a generalized Finite-
element thick-plate model, and then analyze the behavior of slab or mat supported by soil springs as 
subgrade.  The first version of Program GeoMat has the following features that are designed to enhance 
the ability of the engineer to obtain usable results.  

• The program employs well-established analytical solutions for soil-structure interaction under 
static loading.  

• The program does not set a limit on the number of finite-element meshes for modeling.  Only 
the size of RAM in the user's computer will limit the available meshes.  The element types 
include 4-node linear elements, 8-node quadratic elements, and 9-node Lagrangian elements. 

• The soil is assumed to behave in the linear range, but the user may assign different values of 
subgrade stiffness at desired locations of the foundation. 

• The user may input various concentrated loads at nodal points, distributed loads at any 
element, and uniform loads for an entire mat or slab. 
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• The user may specify a mat or slab with any shape.  The program has the capability to 
generate automatically finite meshes for mats or slabs with rectangular shapes or circular 
shapes.   

• The program will display the layout of finite-element meshes with nodal numbers and element 
numbers. 

• The program will generate contour graphics of slab deformation and stress distribution.   

 A Windows GUI (Graphic User Interface) was used for input screens and file operation.  All 
variables have on-line text description or graphical symbols for definition.  Also, all input data can be saved 
and retrieved from disk.  Finally, graphical output of pressure distribution, deflection moment, and shear 
could be printed.  

1.3.2 GeoMat 2.0 (2014) 

 The second version was developed in 2014 with several significant upgraded features and is fully 
compatible with the latest operation systems including Microsoft Windows 7 and 8.    

• The program does not set a limit on the number of finite element meshes for modeling.  Only 
the size of RAM in the user's computer will limit the available meshes.  The element types 
include 4-node linear elements, 8-node quadratic elements, and 9-node Lagrangian elements. 

• The program enhances the contour graphics of slab deformation and stress distribution.  

• The program adds the function for “Section Cut” which is a useful tool to plot deflection, 
bending moment, or stress components along one or more straight cut lines.   

• This version has the ability to compute deformation and stresses of space orthotropic plates. 
Three common types covered in this version are: uniform plates with orthotropic 
reinforcements, plate with orthotropic enhanced ribs, and plate with one way box section.  

• This software also provides the option for inputting user-defined orthotropic properties. 

1.3.3 GeoMat 3.0 (2022) 

 The third version was developed in 2021 and 2022 with several significant upgraded features and 
is fully compatible with the latest operation systems including Microsoft Windows 10 and 11.    

• The program includes the modified Vlasov model by Vallabhan and Das (1988) for solving 
the soil-structure interaction in continuous medium.  The modified Vlasov model has 
improved the accuracy of the solution computed based on the Winkler soil model. 

• The program enhances the performance of 4-node linear elements in addition to the available 
choices on a high-order quadratic elements (8-node) and Lagrangian elements (9-node). 

• The program adds a template to generate automatically finite meshes for wind-turbine 
gravity foundations using octagon or circular shapes with various concrete thickness.   

• The program adds a practical example which is a useful reference for modeling the mat 
foundation supported by piles (pile-raft foundations).  

• This version has the ability to assign the external loads from anchor bolts, which may be 
arranged in circular rings, directly onto the associated nodes as inputted concentrated loads. 
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1.4 Technical Support 
 Although computer program GeoMat was designed to be distinguished by its ease of use and by its 
accompanying User’s Manual, some users may still have questions.  The technical staff at ENSOFT 
strongly supports all registered users with questions related to the installation or use of GeoMat, according 
to the stipulations presented below.  The software is provided with free maintenance service for the first 
year.  After the first year the user is encouraged to purchase the yearly maintenance services.  The yearly 
maintenance includes free download of the latest version/update and free technical support for installation 
and usage issues as described below. 

1.4.1 Preferred Methods of Software Support  

Software support is given, in order of preference, by the following methods:  

• Electronic mail to: support@ensoftinc.com 

• Fax to: (512) 244-6067 

• Telephone call to: (512) 244-6464, extension 2 

Users are encouraged to utilize electronic means of support via email.  In all technical support requests via 
email, please include the following information: 

• full software version/release/update (obtained from the Help > About dialog), 

• a description of the user’s problem or concern, 

• attach a copy of the input-data file that is associated with the issue/concern (files with 
name/extension of the type filename.slb), and  

• name and telephone number of the contact person and of the licensed user (or name and office 
location of the licensed company site and/or serial number of the USB Key). 

Although immediate answers are offered on most technical support requests, please allow up to two 
business days for a resolution in case of difficulties or schedule conflicts. 

Technical help by means of direct calls to our local telephone number, (512) 244-6464, is available, but is 
limited to the business hours of 9 a.m. to 5 p.m. (US central time zone, UTC −6:00). The current policy of 
Ensoft is that all telephone calls for software support will be answered free of charge if the user has a valid 
maintenance contract. 

1.4.2 Upgrade Verification and Internet Site 

Starting from GeoMat v2022 the software provides options for the user to check the most recent 
maintenance release through an internet connection by selecting Help > Check for Updates.  This 
command starts the default internet browser and will display the user’s maintenance expiration date, the 
user’s software release number and the most recent release number that is available for downloading. 

If the user’s version is not the latest version and the maintenance has not been expired, the user can 
download the latest version from our web server directly (www.ensoftinc.com).  Users may also consult 
our internet site for additional information on software updates, demos, and new applications; technical 
news; and company information.  

mailto:support@ensoftinc.com
http://www.ensoftinc.com/
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1.4.3 Renewal of Program Maintenance 

The cost to renew program maintenance will depend on the length of time for which the program 
maintenance has been expired.  There are small price increases with time after expiration.  The pricing 
policy for renewing a program maintenance that has not expired can be found on the Ensoft website at 
https://www.ensoftinc.com/order_form 

1.4.4 Changes of Support Policy  

The software support policy and associated expenses are subject to change at ENSOFT’s discretion and 
without specific mailed notices to the users. However, any change of rules will be verbally provided during 
telephone calls for software support.  

 

 

https://www.ensoftinc.com/order_form
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2.1 Installation Procedures 
 Program GeoMat is distributed with an associated USB key (hardware key or dongle).  The 
hardware key consists of a device that is attached to an empty USB port (or USB hub) of the computer in 
use (or in the designated software server in the case of local network licenses).  This method of software 
protection has been found to provide compatibility with existing operating systems, better stability than 
other alternatives, and allows users to obtain software updates or replacements via downloads from the 
internet. 

Before installing, your computer should be equipped with the following: 

• An open USB port 

• At least 30MB of free space 

• Windows 7,8,10,11 

 The file, contained in the distribution media, is a Windows-based program which will assist the 
user in installing all program modules into a user-selected directory with the proper settings used for the 
Windows environment.  The user is assumed to have basic knowledge in running applications under MS 
Windows.  The following steps are recommended for a successful installation. 

2.1.1 Installation of Single-User Version 

This version of GeoMat has been tested to be compatible with the following versions of the Microsoft 
Windows® operating systems: Win 11, 10, Windows 8.1, 8, 7, Vista, XP, 2000 in either 32 and 64-bit 
releases. 

The following guidelines are recommended during the installation process of GeoMat for single-user 
licenses. 
1. Plug the supplied USB Key into one of the available USB ports in your computer.  The USB Key is 

plug-and-play compatible so the operating system will recognize the USB Key automatically and a 
small solid green light should appear at the end of the USB Key (a flickering green light or no light 
indicate problems with the standard windows driver or with the USB Key). 

2. If the user installs from a distribution USB Memory Stick and the main installation program does not 
start automatically upon insertion of the Memory Stick then click on the Windows Start Menu button 
and select Run.  On the command line, type d:\setup.exe or e:\setup.exe, where d: or e: represents the 
drive that contains the distribution Memory Stick.  Click OK to execute the command and start the 
main installation program for ENSOFT’s software.  A screen similar to the one in Figure 2.1 should 
appear. 
If the user installs from a downloaded file, then please run the downloaded file (double click) and go 
to instruction #4. 

3. Click anywhere on the GeoMat 2022 icon and then click on the Install Standard button to start the 
installation of GeoMat. 

4. The user should read the license agreement shown in Figure 2.2.  Users can review the License 
Agreement online in the following link: 

https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf 

https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf
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The installer will place the same file (Ensoft License and Disclaimer.pdf) in the installation 
directory.  Please click Yes if you agree and would like to proceed. 

5. Select Single-User License in Figure 2.3 then click Next.  For network installations please contact 
Ensoft support (support@ensoftinc.com). 

6. The user will be provided with an option to select a drive and directory for the installation of example 
files (see Figure 2.4).  Default installation directory is the following: 
(Root Drive)\Ensoft\GeoMat2022-Examples 

7. The user will also be asked to select a drive and directory for the installation of GeoMat (see Figure 
2.5).  Default installation directory (varies according to the Windows release where it is installed) is 
one of the following: 
(Root Drive):\Program Files (x86)\Ensoft\GeoMat2022 
(Root Drive):\Program Files\Ensoft\GeoMat2022 
If the desired directory does not exist, the installation program will automatically create a new 
directory in the chosen hard drive. 

 
Figure 2.1 Main installation screen for ENSOFT software (may change with time) 

mailto:support@ensoftinc.com
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8. During the installation the user will be asked to set the file extension association for opening GeoMat 
v2022 input data files (see Figure 2.6).  If the user agrees (leaves the default check mark) then double 
clicking (or running) any input data file with extensions of the type filename.slb will start the installed 
GeoMat v2022 software. 

9. The user will be prompted to confirm the shortcut directory name that will be created in the Windows 
Start Menu (See Figure 2.7).  The default is Start Menu/Programs/Ensoft/GeoMat2022.  Windows 
11, 10 and 8 will automatically create an Ensoft tile with the same shortcuts. 

After the installation is finished, it is usually not necessary to reboot Windows for the program to run.  The 
user may run the program by selecting GeoMat v2022 from the standard links installed in the Microsoft 
Windows® Start Menu:  Start Menu > All Programs > Ensoft > GeoMat2022 
 

 
Figure 2.2   Installation Screen with License Agreement (may change with time)  
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Figure 2.3  Selection of Single-User License (may change with time)  

 
Figure 2.4  Default Installation Directory for Example Files (may change with time) 
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Figure 2.5   Default Installation Directory for Program Files (may change with time)  

 

Figure 2.6   File Extension Association for GeoMat Data Files (may change with time)  
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Figure 2.7   Default Shortcut Folder in Windows Start Menu (may change with time)  

2.1.2 Introduction of Network Version 

Special network licenses and USB hardware keys (network keys) are available for users that want to operate 
GeoMat on a Windows network.  A network version is licensed for employees of one or more specific 
office sites that are within white listed subnets.  Discounted rates apply for purchases of multiple network 
seats. 

Network versions of GeoMat have special subroutines written for installations in “license manager” and 
for installations of “individual clients”.  The “license manager” is known as the computer that will be 
carrying the network key provided by ENSOFT, INC.  The license manager is not necessarily the same as 
the existing network server but rather just a computer carrying the network key and managing the license.  
Any computer in the existing Windows network may be designated license manager for GeoMat as long as 
the network key is attached to an available USB port (or through an USB hub) and the “server” version of 
the software (or of the Ensoft Utilities) is installed on its hard drive.  Software “clients” may be all other 
computers of the network that have the program installed as client.  Client computers do not need any 
hardware key attached to their local system.  The program installed in “client computers” will be allowed 
to run as long as the computer designated as “license manager” is accessible on the network with the proper 
operating system and with its network key secured in place. 

2.1.2.1 Installation of Network Version 

Installers of network licenses should refer to a separate booklet with installation instructions for the 
Network version of this product.  The document can be downloaded from the Ensoft web site: 

https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf 

https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf
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Alternatively, the document can be requested via email to support@ensoftinc.com 

2.1.2.2 Silent Installations on Client Computers 

For installation of network licenses on local client computers there is an option for command-based 
installations that are completely silent (performed without other user input).  Instructions for silent 
installations on client computers can be downloaded from the Ensoft web site using the following link: 

https://www.ensoftinc.com/doc/Silent%20Install%20on%20Client%20Computers.pdf 

Alternatively, the document can be requested via email to support@ensoftinc.com 

2.1.3 Backup of Original Software 

The distributed software may be copied for backup purposes.  The program may be installed in several 
computers at the same time.  However, unless network licenses are purchased, the program will only operate 
in the computer that carries the appropriate USB Key. 

2.1.4 Software Updates on the Internet 

Occasionally, ENSOFT will produce software improvements and/or fixes and place the latest software 
programs on ENSOFT’s internet site.  Software users may download the latest program update from the 
PRODUCTS > Downloads link in the following site:  http://www.ensoftinc.com 

2.2 Getting Started 
 A first windows screen showing the menu choices, speed buttons, and operational controls of 
program GeoMat is presented in Figure 2.8. The following paragraphs provide a short description of the 
operational features of GeoMat and should quickly enable the user to get started with the program.  

 Several additional files are created in every new GeoMat run.  A general description of these files 
is presented in Table 2.1.  Every run of GeoMat thus generates four text files in the same drive and directory 
where the input-data file was saved or opened.  Any of these files may be opened with standard text editors 
or word-processing programs.  
 

File Name Extension Usage Description File Format Example Files 
*.slb Input data file GeoMat file example1.slb 
*.sin Input data file Text file example1.sin 
*.sou  Output data file Text file example1.sou 
*.sms Message file Text file example1.sms 
*.sds Timestep data file Text file example1.sds 

Table 2.1   Files created in GeoMat runs 

2.2.1 Starting the program 

 The program is started by double clicking the left mouse button anywhere in the GeoMat icon. A 
new window will appear on the screen, with the following top-menu choices: File, Edit, View, Input Data, 
Assign Data, Computation, Transform, Results, Options, Selection, Window, Help.  As a standard 

mailto:support@ensoftinc.com
https://www.ensoftinc.com/doc/Silent%20Install%20on%20Client%20Computers.pdf
mailto:support@ensoftinc.com
http://www.ensoftinc.com/
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Windows feature, all underlined letters of top menu operations indicate that choices may also be accessed 
by keyboard combinations of ALT + [letter] (where [letter] represents the desired underlined letter). 

 
Figure 2.8 Default starting screen for GeoMat 

A list of recently opened files is displayed in between Save As… and Exit. 

2.2.2 File Management 

The File menu contains several commands for file management and to create new models.  A sample is 
shown in Figure 2.9.  Brief descriptions for each entry are as follows: 

New   .................... ..……. to create a new data file.  

New from Template   ... to create a new mesh data file with the template. 

Open*   ........................... to open an existing data file.   

Close…   ........................ to close an existing data file.  

Save   ............................ to save input data under the current file name.  

Save As…   ..................... to save input data under a different file name.  

Print   ............................ to print the current graphics.  

Print Preview…   ……….. to view the graphic layout before sending to the printer.  

Print Setup   ................... to setup printer configuration. 

Page Setup   ................... to setup page border and configuration. 

Save As Bitmap   ……...... to save graphics using Bitmap format. 

Exit**   ........................... to exit Program GeoMat. 
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* Open…: If a partially completed GeoMat input file, or an invalid data file is opened, an information 
window reporting that an “invalid or incomplete” file is being opened. Clicking OK dismisses the 
message, and the previously saved data should be available.  If a complete input file is loaded, an 
information window reporting that “Data File: (name of file), has been read by GeoMat” should 
appear, and the user should click OK. 
 
** Exit:  If the input file was modified but unsaved, a prompt will appear asking if the user would like 
to save changes. 

 

Figure 2.9  Sample File Menu 

2.2.3 View Management of Program Window 

The View menu contains several toolbar options, as shown in Figure 2.10.  By default, these options are 
turned on when the program is launched.  The choices are listed below, along with a general description of 
their use.  
 
File Toolbar   …………. this option displays the toolbar associated with the options contained in the File and 

Help menus.  
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View Toolbar   .......... this option displays the toolbar associated with the options contained in the Transform 
menu.  

Select Toolbar   ……… this option displays the toolbar associated with the options contained in the Selection 
menu.  

Actions Toolbar   ...... this option displays the toolbar associated with the options contained in the Input Data 
menu.  

Status Bar   ............... this option displays the status bar at the bottom of the screen. 

 

 

Figure 2.10  View Menu 

2.2.4 Data Input for Program Operation 

The Input Data menu is provided for the control of program variables and preferences. The listing of menu 
options is shown in Figure 2.11 and the different submenu choices are briefly described below.  The user 
may select any of the options without concern for the sequential order. 
Title   ……………............. this option allows the user to title the current evaluation. It is displayed in the Input File 

and Output File.  

Material Properties   .. as a default, the program considers the cross-section of the slab to be uniform.  Young’s 
modulus, Poisson’s ratio, and slab thickness may be modified as needed.  This version 
has the ability to compute deformation and stresses of space orthotropic plates.  Four 
types are covered in this version: uniform plates with orthotropic reinforcements, plate 
with orthotropic enhanced ribs, plate with one way box section and general orthotropic 
plate. 

Node Coordinates   .... the user should input in this box the coordinates of the mesh to be drawn on the slab. 
This action is already performed for the user if the problem was designed using the 
New from template... option in the File menu.  

Time Stepping   .......... the user should input in this box the coordinates of the mesh to be drawn on the slab.  

Soil Stiffness   ............ this option allows the user to solve soil-slab interaction using Mindlin’s Equation or 
Vlasov approach.  
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Element Type   ........... three element types are available for use in the analysis: Linear 4-noded, Quadratic 8-
noded, and Lagrangian 9-noded.  

Element Connectivity   . this window allows the user to specify the connecting edges of the elements.  This 
action is already performed for the user if the problem was designed using the New 
from template... option in the File menu.  

Integration Points   ..... this option allows the user to select the number of integration points to be used in the 
analysis: 1x1, 2x2, or 3x3.  

Nodal Constraints   ..... this box allows the user to apply constraints at nodal points.  

Nodal Loads   ............... this option allows the user to apply loads at nodal points.  

Nodal Stiffness   …….... this option allows the user to apply stiffnesses at nodal points. 

Distributed Loads   .... this option allows the user to select the element location and intensity of distributed 
loads.  

Distributed Stiffness   . this option allows the user to select the element location and intensity of distributed 
stiffnesses.  

Concentrated Loads   .. this option allows the user to place a concentrated load at any location on the slab.  

Equivalent Concentrated Loads   .. this option allows the user to place concentrated loads from anchor 
bolts of the mounting plate to the top of the foundation.  The program will calculate 
the location of each anchor bolts arranged in a circular pattern and the distributed load 
on each anchor bolt based on the user-specified data. 

Concentrated Stiffness this option allows the user to place a concentrated stiffness at any location on the slab.  

Edge Loads   ............... this option allows the user to place a load along an edge.  

Edge Stiffness   .......... this option allows the user to place a stiffness along an edge.  

Node Sets   ................. this option allows the user to create node sets in order to facilitate the ease of defining 
nodal loads, stiffnesses, and constraints.  

Element Sets   ............ this option allows the user to create node sets in order to facilitate the ease of defining 
distributed loads, distributed stiffnesses, and material properties.  

Edge Sets   .................. this option allows the user to create node sets in order to facilitate the ease of defining 
edge loads and stiffness 

Section Cut   ................ This option allows users to define cut lines for XY curve plot.   
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Figure 2.11  Sample Input Data Menu 

2.2.5 Computation Options 

The Computations menu is provided to run the analytical computations after all data are entered and saved.  
After the computation is executed successfully, this menu also provides options for the reviews of plain-
text input data, notes produced during computation, and output data.  Submenu choices, shown in Figure 
2.12, are briefly described below.  
Run Analysis   ............. this option is chosen to run the analytical computations.  This option should be selected 

after all data have been entered and saved.  

View Input File   ......... this option calls Microsoft Notepad to observe and/or edit the analytical input data in 
plain-text format.  The option becomes available after the input data has been saved 
to disk, or when opening an existing input-data file. 
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View Output File   ...... this option calls Microsoft Notepad to observe, format, and/or print the analytical-
output data.  The option becomes available only after a successful run has been made.  
Certain output files may be too large for the Microsoft Notepad editor, so other text 
editors would have to be used (Microsoft WordPad should be able to open most text 
files).  

View Message File   .... this option calls Microsoft Notepad to observe the processor run notes which may 
include error messages. 

  

Figure 2.12  Computations Menu 

2.2.6 Manipulating the Slab Model 

The Transform menu is used to manipulate and transform the slab model displayed in the program window.  
The user may also access these operations via the View Toolbar shortcuts.  Submenu choices, shown in 
Figure 2.13, are briefly described below.  
Panning   .................. this function allows the slab model to be moved in the window.  

Rotate   .................... this function allows the slab model to be rotated around the origin.  

Zoom In/Out   ...……. this function zooms in and out on the slab model.  

Restart   ................... this function resets the view to the original YZ plane view.  

YZ View (Top)   ……... this orients the slab in the YZ plane, looking at the top of the slab.  

YZ View (Bottom)   ... this orients the slab in the YZ plane, looking at the bottom of the slab.  

XY View (Front)   ...... this orients the slab in the XY plane, looking at the front of the slab 

XZ View (Side)   ......... this orients the slab in the XZ plane, looking at the top of the slab.  

XYZ View (3Dview)   .. this orients the slab in an orthographic 3D view.  

Rotation Angles  ....... this option allows the user to specify the desired rotation angle.  
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Figure 2.13  Sample Transform Menu 

 

2.2.7 Results 

The Results menu provides additional options for viewing the slab after an analysis has been completed. 
The submenu options, shown in Figure 2.14, are described below.  
Select Step   ............. this option allows the user to choose the number of steps used in the solution.  

Deformed Mesh   .... this option displays the deformed shape of the slab, based on the user’s specified shape 
deformation factor.  The undeformed shape may also be displayed alongside the 
deformed shape.  

Contour Plot   .......... this option creates a contour plot of various output information, such as deflection, 
rotation, shear, moment, and stress. 

Section Cut Plot   ..... this option creates xy plots of various output information along the user-selected 
cutting lines, such as deflection, rotation, moment, and stress. 

Node Results   ..... this option displays deformation, plate forces, reactions, and plate stresses of one 
specific node. 
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Figure 2.14  Sample Results Menu 

 

2.2.8 Option Menu 

The Options menu provides various options for displaying data about the slab on-screen. Submenu options, 
shown in Figure 2.15, are briefly described below.  
Mark Nodes   ........... this option marks the nodal points.  

Node Numbers   ........ this option displays the node numbers.  

Element Numbers   ... this option displays the element number.  

Boundary Only   …….. this option shows the slab and its edge boundary. 

Local Axes   ............... this option displays the axes associated with the slab. 

Global Axes   ............. this option displays the global axes of the workspace.  

Solid Face   ……………. this option shows the elements as solid units. 

Show Thickness   ...... this option displays the thickness of the slab. 

Nodal Constraint   ..... this option displays the location of the user input nodal constraints 

Nodal Loads   .............  this option displays the location of the user input nodal loads. 

Nodal Stiffness   ........ this option displays the location of the user input nodal stiffnesses.  

Concentrated Loads    this option displays the location of the user input concentrated loads. 

Concentrated Stiffness     this option displays the location of the user input concentrated stiffnesses. 

Concentrated Total Stiffness  this option displays the nodal, concentrated, and distributed stiffnesses.  

Distributed Loads   ..... this option displays the user input distributed loads. 

Distributed Stiffness   . this option displays the user input distributed stiffness. 

Edge Loads   ............... this option displays the user input edge loads.  

Edge Stiffness   .......... this option displays the user input edge stiffnesses. 

Font and Color   .......... this option lets users control fonts and colors used for node/element number. 
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Figure 2.15 Available items contained in the Options menu 

 

2.2.9 Selection Menu 

The Selection menu provides options for selecting different members of the slab. Submenu options, shown 
in Figure 2.16, are briefly described below.  
Select Node   ............. this option allows the user to select a node using the mouse button. 

Selection Element   ... this option allows the user to select an element using the mouse button.  

Select Edge   ………….. this option allows the user to select an edge using the mouse button.  
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Figure 2.16 Options contained in the Selection menu 

 

2.2.10 Window Menu 

The Window menu provides the user with various ways to view the active documents.  Submenu options, 
shown in Figure 2.17, are briefly described below.  The open windows are listed at the bottom of the menu, 
after the divide line.  
New Window   .......... this option launches a copy of the current open window.  

Cascade   .................. this option stacks the open windows on top of one another.  

Tile Horizontal   ........ this option tiles the open windows horizontally.  

Tile Vertical   ............ this option tiles the open windows vertically.  

Arrange Icons   ........ this arranges the minimized windows 
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Figure 2.17 Options contained in the Window menu 

 

2.2.11 Help Menu 

The Help menu provides an online help reference on topics such as: using the program, entering data, 
information about variables used in the program, and methods of analyses.  The Help menu may be accessed 
at any time while in GeoMat.  Submenu options, shown in Figure 2.18, are briefly described below.  
Help Topics   ............. the main reference files for help are accessed through this submenu option.  Clicking 

on this option provides a screen with reference help for the following topics: File Menu, 
Edit Menu, View Menu, Input Data Menu, Computations Menu, Transform Menu, 
Results Menu, Options Menu, Selection Menu, Window Menu, and Help Menu. Under 
each topic are additional subtitles that corresponds to data-entry headings.  If the user 
selects one of those, a help screen on the topic is displayed. 

User’s Manual .......... this option is used to access a digital copy of the user’s manual  

Technical Manual .... this option is used to access a digital copy of the technical manual  

About   ...................... this displays a screen describing the program version, date, and methods for accessing 
technical support.  
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Figure 2.18 Options contained in the Help Menu



 

 

CHAPTER 3. Data Input 
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3.1 File Menu 
 This menu, shown in Figure 3.1, contains options related to the management of input data files and 
to exit the program.  Input data files created for GeoMat are provided with a standard file-name extension 
in the form of *.slb (where * represents any allowable file name).  All input-data files are standard text files 
and may be edited with any text editor or word-processing program. 
 

  
Figure 3.1 Window screen for the File menu 

 

3.1.1 File – New 
 Once the program is started, default values are used for certain operating parameters and a blank, 
input data file is created.  Selecting New under the File menu resets all GeoMat variables to either default 
or blank values, as appropriate.  This option should be selected when a new data file is desired to be 
created from a blank form.  This menu option may also be accessed with the Ctrl+N keyboard combination 

3.1.2 File – New from template 
 To assist the user in creating an input file, the New from template option may be selected. 
GeoMat provides three templates: conventional rectangular or circular plate, octagonal wind turbine 
foundation, or circular wind turbine foundation (Figure 3.2).  Later two options are specifically used for 
soil-slab interaction of wind turbine foundations by means of Vlasov or Mindlin approach.  
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Figure 3.2 Options for various template    

The first option is used for a conventional circular or a rectangular plate (Figure 3.3).  A new template 
dialog box prompts the user for the geometric and computational properties of the slab.  The shape, 
number of nodes for computation, dimensions, and number of grid divisions may be easily entered with 
this interface.  This automatically fills the Node Coordinate, Element Type, and Element Connectivity data 
in the Input Data menu. 

There are three types of shapes to choose from: Circular, Rectangular - Equally Spaced, and Rectangular - 
General Spacing.  With each option, the bottom portion of the window reflects the needed input to draw 
the slab model.  Examples of each screen associated with these choices are shown in Figure 3.3 to Figure 
3.5.  The Rectangular General Spacing allows users to input the grid locations, an example is shown in 
Figure 3.6.  The user may also select the element type to be used in the analysis. Three types are available: 
Linear 4 noded, Quadratic 8 noded, and Quadratic 9 noded. 

  
 

  
Figure 3.3 Input screen for the Circular option   
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Figure 3.4 Input screen for the Rectangular option – Equally Spaced option 

  

Figure 3.5 Input screen for the Rectangular option – Generally Spaced option 
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Figure 3.6 Grid Y direction input screen for the Rectangular option – Generally Spaced option 

If option 2 in Figure 3.2 is selected, a new template for octagon wind turbine foundation(WTB) is shown 
as in Figure 3.7. 𝐿𝐿1, 𝐿𝐿2 are plane dimensions for this octagon WTB.  𝐷𝐷 is the diameter for the circular 
pedestal.  𝐷𝐷1~𝐷𝐷3 are step sizes in the thickness direction.  In this template, loads 𝑃𝑃, 𝑉𝑉 and 𝑀𝑀 are optional.  
𝑃𝑃 is the vertical thrust force from tower weight, instrument weight or vertical component of wind loads.  
𝑉𝑉 is the shear force applied to the top of the foundation.  Note that if the shear force 𝑉𝑉 is non-zero, 
appropriate nodal constraints should be defined to avoid rigid body motion of the foundation. Non-zero 
loads 𝑃𝑃, 𝑉𝑉 and 𝑀𝑀 will be discretized to equivalent nodal loads by GeoMat automatically.  The default finite 
element is set to quadratic eight-noded element with 2x2 integration rule.  

Element refinement is determined by typical element size.  Majority of elements will be generated in the 
square shape and each edge will follow this size approximately.  The default element size is estimated by 
GeoMat.  Users can override it to generate a coarser mesh or a finer mesh by inputting a new size.  Angle 
𝛼𝛼 is the angle between load plane of 𝑉𝑉,  𝑀𝑀 and horizontal y axis.  Positive angle is in the clockwise 
direction.  As an example, entering 90 will define a wind load in the downward direction. 
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Figure 3.7 Template for octagon wind turbine foundation 

The third option for the new template is also a wind turbine foundation in circular shape (Figure 3.8).  𝑅𝑅1 
is the radius of the pedestal.  𝑅𝑅2 is the radius of the second circle.  𝑅𝑅3 is the radius at the foundation 
bottom.  Other parameters have the same meanings as the octagon wind turbine foundation.  
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Figure 3.8 Template for circular wind turbine foundation 

 

3.1.3 File – Open 
 This option is used to open a file that has been previously prepared and saved to disk.  The File -
>Open window dialog, shown in Figure 3.9, is used to search for an existing input-data file.  By default, 
the file is initially searched in the directory where GeoMat was installed.  Standard, windows-navigation 
procedures may be used to locate the name and directory of the desired project file.  This menu option 
may be accessed with the Ctrl+O keyboard combination.  

 Every analytical run of GeoMat produces several additional files, as described in Error! Reference 
source not found..  The name of the input-data file indicates the names of all related files produced by a 
successful execution (output, graphics, and processor-text files).  All the additional program files will be 
created in the same directory as the input file.  Input-data files that are partially completed may be saved 
and later opened for completion, run, and view of results.  

 Opening partially completed, input files or invalid data files may produce an information window 
reporting that an “invalid or incomplete” file is being opened.  The user should click the OK button and all 
partial-input data that was previously prepared should become available.  
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Figure 3.9 Window screen for the File – Open dialog   

 

3.1.4 File – Save 
 This option is used to save input data under the current file name.  With this method of storing 
data to disk, any input data that was previously saved with the same file name is replaced with the current 
parameters.  Input-data files should be saved every time before proceeding with runs for analytical 
computation.  This menu option may also be accessed with the Ctrl+S keyboard combination. 

3.1.5 File – Save As 
 This option allows the user to save any opened or new input data file under a different file name 
or different directory.  Any input data file saved under an existing file name will replace the contents of 
the existing file. 

3.1.6 File – Exit 
 This is selected to exit GeoMat.  Any input-data file that was modified and not yet saved to disk 
will produce a confirmation window before exiting the program (see Figure 3.10). 
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Figure 3.10 Message window advising that changes were not saved to disk 

 

3.2 Input Data Menu 
 The input of specific parameters for an application is controlled under options contained within 
this menu, shown in Figure 3.11.  It is recommended that the user chooses each submenu and enter 
parameters in a consecutive manner starting from the top option.  

 Selecting or clicking any of the submenu choices contained in the Data menu produces various 
types of windows.  As a reminder of standard commands of Microsoft Windows, open windows may be 
closed by all or some of the following methods: 

• clicking the OK button (if available), or  

• clicking the  box on the upper-right corner of the window, or  
• double-clicking the GeoMat icon on the upper-left corner of the window, or  
• using the Ctrl + o keyboard combination, or  
• clicking once on the GeoMat icon on the upper-left corner of the window and then choosing Close.  

 Open windows may optionally be left open on the screen. The selection of other menu options 
will then produce new windows on top of those that were left open.  
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 Many sub-windows of the Data menu will show an Add Row, Insert Row and/or Delete Row 
buttons.  The Add Row button always adds new rows at the end after all existing rows.  The Insert Row 
button always inserts a new row right after an existing row highlighted by the mouse.  Clicking on the 
Delete Row button deletes the row where the cursor is located.  

3.2.1 Numeric Data Entries and Sign Conventions 
 Cells that require numeric data only accept simple numeric entries.  Entering a mathematical 
expression works similarly to normal numeric data.  If a non-valid number is inputted, the program will 
display an error message.  

  The user is reminded to keep consistent units since units are not explicitly defined in the program. 
The sign conventions in this program are based on the right-hand rule, which use X direction for the load 
or displacement perpendicular to the plate and the plate planar dimension is defined in Y and Z directions. 

 Scientific notation (i.e. 1.65e8 or 1.65e-8) may be used to input very large or very small numbers.  
After an expression is calculated, very large or very small numbers will be displayed using scientific 
notation. 

 

Figure 3.11 Options contained in the Input Data menu 
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3.2.2 Input Data -Title 
 This option activates the window shown in Figure 3.12, where the user can enter a line of text 
containing a general description for the application problem.  Any combination of characters may be 
entered in the text box in order to describe a particular application.  The user input will be restrained 
automatically once the maximum length of text is reached.  This is done to prevent the user from going 
beyond the maximum permissible length of characters allowed for the title line. 

 

Figure 3.12 Window screen for sample Data – Title 

 

3.2.3 Input Data – Material Properties 
 This menu option launches the window shown in Figure 3.13, where the user can specify the type 
of materials.  The current version of GeoMat allows the user to select Isotropic plate/slab and Orthotropic 
plate/slab with various configuration. The properties may be varied across different sections by using the 
Add Material function.  The program will ask the user to select proper representation from the following 
five different categories: Isotropic, Orthotropic Reinforcement, Orthotropic Enhances Stiffener, 
Orthotropic One Way Box Section, and User Defined Property. 

Isotropic Properties 
 Enter the Element Number/Set and after the material selection click the Define button, the screen 
for material properties will be shown for data entry (Figure 3.14), including the location of the material 
properties of the slab.  The input requested is the Young’s Modulus, Poisson’s Ratio, and Slab Thickness.  
If the New from template option is used, the material properties are set to the default values of ALL for 
the Element Sets, 3000 for Young’s Modulus, 0.3 for Poisson’s Ratio, and 1 for Slab Thickness.   
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Figure 3.13 Window screen for material selection under Input Data Menu – Material Properties 

 

 

Figure 3.14 Window screen for material data Under Material Properties 

 

Orthotropic Properties 
This version can compute deformation and stresses of space orthotropic plates. Three types of orthotropic 
plates/slabs available in this version are: uniform plates with orthotropic reinforcements, plate with 
orthotropic enhanced ribs, and plate with one way box section.  This version also provides the option for 
inputting user-defined orthotropic properties.  

 
Type 1: Uniform plate with orthotropic reinforcement 
The input interface is shown in Figure 3.15.  As1 and As2 are areas of reinforcement above or below the 
plate neutral axis.  X1 and x2 are distances from the center of reinforcement to the neutral axis.   

Type 2: Plates with orthotropic enhanced stiffener 
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The input interface is shown in Figure 3.16.  The dimension and location of each component on the 
orthotropic plate are sketched and shown in the input screen for the user to follow.  

Type 3: Plates with one-way box section 
The input interface is shown in Figure 3.17.  The dimension and location of each component on the 
orthotropic plate are sketched and shown in the input screen for the user to follow, where t1=thickness 
of top plate, t2=thickness of vertical plates, t3=thickness of bottom plates. 

Type 4: User defined orthotropic plates 
This option allows the user to define orthotropic plates.  There are six input parameters that are needed 
for defining the orthotropic properties as shown in Figure 3.18.  The flexural and shear rigidities are 
defined in the technical manual.  (Note the x, y and z coordinate axes are defined differently than those 
used in user input GUI.) 
 

  

Figure 3.15 Window screen for material data Under Material Properties using uniform plate with 
orthotropic reinforcement 
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Figure 3.16 Window screen for material data Under Material Properties using orthotropic plate with 
enhanced stiffener 

 

  

Figure 3.17 Window screen for material data Under Material Properties using orthotropic plate with 
one-way box section 
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Figure 3.18 Window screen for material data Under Material Properties using user-defined section 

 

3.2.4 Input Data – Node Coordinates   
 This submenu allows the user to manually input the locations of each nodal point.  If the New 
from template option is used, the coordinates are automatically determined and entered here for the 
user.  For a mat that is neither rectangular nor circular, the user may enter the node coordinates one by 
one.  The user may also modify the automatically generated node coordinates by adding new node 
coordinates or revising the existing coordinates. 

3.2.5 Input Data – Time Stepping 
 If the user chooses to ask the program to estimate the soil subgrade stiffness based on the Young’s 
modulus of the foundation soil, the program will estimate the soil stiffness using iterative procedures until 
the compatibility between the mat movement and soil stiffness converges. The process uses non-linear 
iteration for achieving the convergence and the user needs to specify the parameters associated with the 
iteration process shown in Figure 3.19.  

 If the user enters the soil stiffness and support externally, “Time Stepping” is not needed and may 
leave default values for this option. 
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Figure 3.19 Window screen for Input Data Menu – Time Stepping 

 

3.2.6 Input Data – Soil Stiffness 
 This submenu is disabled as a default but may be enabled if the user chooses to ask the 
program to estimate the soil subgrade stiffness based on the Young’s modulus of the foundation soil.  
The program will estimate the soil stiffness using iterative procedures until the compatibility between 
the mat movement and soil stiffness converges.  The associated screen is shown in Figure 3.20.  Option 
1 does not consider soil stiffness.  This is the default option.  Users may also select option 2 to estimate 
soil stiffness using Vlasov approach.  Corresponding input window is shown as in Figure 3.21. The Young’s 
modulus at top and bottom can be different.  The default initial gamma=1 works well for most cases.  If 
soil depth is significantly high, the initial gamma can be greater than 1 and smaller than 5. Option 3 uses 
Mindlin equation to estimate soil stiffness (Figure 3.22).  Mindlin’s equations are also used to calculate 
the stress-strain behavior in the soil.  The detailed iteration procedures are discussed in the Technical 
Manual. 
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Figure 3.20 Window screen for Input Data Menu – Default option 

 

 

Figure 3.21 Window screen for Input Data Menu – Vlasov approach 
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Figure 3.22 Window screen for Input Data Menu – Mindlin equation 

 

3.2.7 Input Data – Element Type   
 This option allows the user to choose the type of element to be used in the analysis.  There are 
three options: Linear 4-noded, Quadratic 8-noded, and Lagrangian 9-noded.  If the New from template 
option is used, this choice is automatically made for the user. 

3.2.8 Input Data – Element Connectivity   
 This selection launches the Element Connectivity window.  This allows the user to define the 
nodes for each element number.  If the New from template option is used, these values are automatically 
filled in for the user.  The user can modify the data if an irregular shape is required for the meshes. 

3.2.9 Input Data – Integration Points   
 This submenu allows the user to select either a reduced or normal integration procedure to be 
used for the analysis.  For linear 4-noded elements, only one integration point in each element is available.  
Otherwise, the user can select 2x2 or 3x3 for the integration points. 

3.2.10 Input Data – Nodal Constrains   
 This submenu item opens the Nodal Constraints dialog box, as shown in Figure 3.23.  Here, the 
user inputs the node(s) where the restraint is located.  Both translational and rotational restraints at nodal 
points may be restricted using this feature. 
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Figure 3.23 Window screen for Input Data Menu – Nodal Constraints 

 

3.2.11 Input Data – Nodal Loads   
 This window allows the user to specify the location of a point load applied at a nodal point.  A 
sample screen of this box is shown in Figure 3.24. The units for nodal loads are F. 

 

Figure 3.24 Window screen for Input Data Menu – Nodal Loads 

 

3.2.12 Input Data – Nodal Stiffness     
 This window allows the user to specify the location of a concentrated stiffness applied at a nodal 
point.  A sample screen of this box is shown in Figure 3.25.  The units of nodal stiffness are F/L. 
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Figure 3.25 Window screen for Input Data Menu – Nodal Stiffness 

 

3.2.13 Input Data – Distributed Loads   
 This option displays the window shown in Figure 3.26.  The user may enter pressures which are 
distributed over an element or elements.  Both distributed force (the units are F/L2) and distributed 
moment (the units of are F-L/L2) can be specified.  

 

Figure 3.26 Window screen for Input Data Menu – Distributed Loads 

 

3.2.14 Input Data – Distributed Stiffness   
 This option displays the Distributed Stiffness input box, shown in Figure 3.27.  The user may enter 
here stiffnesses which are distributed over an element or elements.  Both rotational and translational 

stiffnesses can be specified.  The units for distributed translational stiffness are F/L
3
.  The units for 

distributed rotational stiffness are F-L/Rad./L
2
. 
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Figure 3.27 Window screen for Input Data Menu – Distributed Stiffness 

 

3.2.15 Input Data – Concentrated Loads   
 This option displays the window shown in Figure 3.28.  The user may specify the exact coordinates 
of a point load which is not located at a nodal point.  The units for concentrated force are F. The units for 
concentrated moment are F-L. 

 

Figure 3.28 Window screen for Input Data Menu – Concentrated Loads 

 

3.2.16 Input Data – Equivalent Concentrated Loads   
 This option displays the window shown in Figure 3.29.  This option allows the user to place 
concentrated loads from anchor bolts of the mounting plate to the top of the foundation.  The user can 
specify the number of circular rings for anchor bolt arrangement and the diameters of each ring.  The user 
also needs to specify the loads (six-degree of loading) applied on the foundation through the anchor bolts. 

 The program will calculate the location of each anchor bolt arranged in a circular pattern and the 
distributed load on each anchor bolt based on the user-specified data.  
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Figure 3.29 Window screen for Input Data Menu – Equivalent Concentrated Loads 

 

3.2.17 Input Data – Concentrated Stiffness   
 This option displays the Concentrated Stiffness input box, shown in Figure 3.30. The user may 
specify the exact location of a concentrated stiffness which is not located at a nodal point.  The units of 
concentrated translation stiffness are F/L.  The units of concentrated rotational stiffness are F-L/Radian.  

 

Figure 3.30 Window screen for Input Data Menu – Concentrated Stiffness 

3.2.18 Input Data – Edge Load   
 This option displays the Edge Load input box, shown in Figure 3.31.  The user may enter a line load 
to be evenly distributed along an edge.  
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Element: the user can select a single element or a group of elements with the same edge stiffness (see  
Input Data - Element Set). 

Side No.: each element may have 3 sides or 4 sides.  The user needs to specify which side with the edge 
stiffness. 

DOF Index:  there are 6 degrees of freedom on each edge node.  The degree freedom index is 1 for 
translation in X direction, 2 for translation in Y direction, 3 for translation in Z direction, 4 for rotation 
about X axis (not available in this program), 5 for rotation about Y axis, and 6 for rotation about Z axis. 

Load Node 1: each side of an element usually has either 2 nodes or 3 nodes.  Load Node 1 is for one of the 
edge nodes.  Enter the load (based on the DEF index) on this nodal point. 

Load Node 2: each side of an element usually has either 2 nodes or 3 nodes.  Load Node 2 is for the other 
one of the edge nodes.  Enter the load (based on the DOF index) on this nodal point. 

Load Node 3: each side of an element usually has either 2 nodes or 3 nodes.  Stiff Node 3 is for the middle 
node if a quadratic element is used.  Enter the load (based on the DEF index) on this nodal point. 

The units for edge translation load are F/L.  The units for edge bending moment are F-L/ L. 

 

Figure 3.31 Window screen for Input Data Menu – Edge Load 

 

3.2.19 Input Data – Edge Stiffnesses   
 This option displays the Edge Stiffnesses input box, shown in Figure 3.32. The user may enter 
stiffnesses which are distributed along an element edge.  

Element: the user can select a single element or a group of element with the same edge stiffness (see 
3.2.21 Input Data – Edge Sets). 

Side No.: each element may have 3 sides or 4 sides. The user needs to specify which side with the edge 
stiffness. 
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DOF Index:  there are 6 degrees of freedom on each edge node. The degree freedom index is 1 for 
translation in X direction, 2 for translation in Y direction, 3 for translation in Z direction, 4 for rotation 
about X axis (not available in this program), 5 for rotation about Y axis, and 6 for rotation about Z axis. 

Stiff Node 1: each side of an element usually has either 2 nodes or 3 nodes. Stiff Node 1 is for one of the 
edge nodes. Enter the translation or rotational stiffness (based on the DEF index) on this nodal point. 

Stiff Node 2: each side of an element usually has either 2 nodes or 3 nodes. Stiff Node 2 is for the other 
one of the edge nodes. Enter the translation or rotational stiffness (based on the DEF index) on this nodal 
point. 

Stiff Node 3: each side of an element usually has either 2 nodes or 3 nodes. Stiff Node 3 is for the middle 
node if quadratic element is used. Enter the translation or rotational stiffness (based on the DEF index) 
on this nodal point.   

The units for edge translation stiffness are F/L
2
. The units for edge rotational stiffness are F-L/Rad./L. 

 

Figure 3.32 Window screen for Input Data Menu – Edge Stiffnesses 

 

3.2.20 Input Data – Node Sets   
 This window, shown in Figure 3.33, allows the user to define groups of nodes.  This option 
facilitates the assignment of nodal properties by grouping nodes together into node sets.  The user enters 
an alpha-numeric name for the set, then selects the nodes to be placed in that group.  To use a defined 
node set, the name of the node set is entered in lieu of the node number.  By default, the set ALL is defined 
as the node set containing all of the nodes in the slab.  

 To select the nodes to be included in a named group, click the Define button.  This opens the 
screen shown in Figure 3.34. Using the Add Row button, enter the range of nodes to be added to the set.  
For greater ease in selecting nodes, use the Selection - Select Node function to “point and click” on the 
desired nodes.  
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Figure 3.33 Window screen for Input Data Menu – Node Sets 

 

 

Figure 3.34 Window screen for selecting nodal points under Input Data Menu – Node Sets 

 

 

3.2.21 Input Data - Element Set   
 This window, shown in Figure 3.35, allows the user to define groups of elements.  This option 
facilitates the assignment of element properties by grouping elements together into element sets.  The 
user enters an alpha-numeric name for the set, then selects the elements to be placed in that group.  To 
use a defined element set, the name of the element set is entered in lieu of the element number.  By 
default, the set ALL is defined as the element set containing all of the elements in the slab.  
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 To select the elements to be included in the group, click the Define button.  This launches a 
window similar to that seen in Figure 3.36.  For greater ease in selecting elements, use the Selection - 
Select Element function to “point and click” on the desired elements.  

 

Figure 3.35 Window screen for Input Data Menu – Element Sets 

 

 

Figure 3.36 Window screen for selecting nodal points under Input Data Menu – Element Sets 

3.2.22 Input Data – Edge Sets  
 This window, shown in Figure 3.37, allows the user to define groups of element edges.  This option 
facilitates the assignment of edge properties by grouping edges together into edge sets.  The user enters 
an alpha-numeric name for the set, then selects the edges to be placed in that group.  To use a defined 
edge set, the name of the edge set is entered in lieu of the element and edge number.  By default, the set 
ALL is defined as the set containing all of the edges in the slab.  
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Figure 3.37 Window screen for sample Input Data Menu – Edge Sets 

 

 To select the edges to be included in a named group, click the Define button.  This opens the 
screen shown in Figure 3.38.  Using the Add Row button, enter the edges to be added to the set.  For 
greater ease in selecting edges, use the Selection – Select Edge function to “point and click” on the desired 
edges.   

 

Figure 3.38 Window screen for selecting edges for Input Data – Edge Sets 

3.2.23 Input Data – Section Cut  
 Section cut is a useful tool to plot stress components along one or more straight cut lines.  The 
input interface is shown as in Figure 3.39.   

1. Number of sample division of each segment.  
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When one cut line passes through the region of a mesh element, it will be divided into several 
line segments by intersected elements.  The default segment division is 4 with equal spaces. 
Outputs are given at 5 points: two locate on finite element edges, three locate inside this 
element.  The default division number can be modified by user. 

2. Source of stress points:  
Two options are available to select the stress source for interpolation.  Option one use stresses 
from Gaussian integration points.  Another option uses stresses at the nodal position.  
Generally, stresses are accurate at Gaussian integration points.  The nodal values are averaged 
from adjacent elements and are less accurate.  But at region with sharp deformation gradient, 
stresses are often not continuous from one element to another.  Using the nodal value option is 
helpful to smooth the curve plot. 

3. Define cut lines 
The user inputs the end coordinates to define one cut line.  Two default cut lines are defined 
automatically: one horizontal and one vertical.  Both default cut lines pass through the origin 
point (0, 0).  Note that the coordinates of end nodes of one cut line shall locate outside of the 
plate. 

  

Figure 3.39 Window screen for sample Input Data Menu – Section Cut 

 
The cut line can be horizontal, vertical or in an arbitrary angle.  Section cut results can be found 
from the output file *.sou.  One sample is shown in Figure 3.40: 
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where “S” is the distance to the most left or top mesh edge.  

Figure 3.40 Sample of output data from Edge Sets option 

 

Default color for the cut lines is blue.  The cut line that is selected will be highlighted in red as in 
Figure 3.41.  Users can edit the coordinates of the start/end point of a cut line.  Then click Apply to 
make it effective.  

Default two cut lines can not be edited or deleted.

 

Figure 3.41 Window screen showing cutting sections by using Input Data Menu – Section Cut 



 

CHAPTER 4. Finite Element Mesh 
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4.1 Introduction 
Capability of mesh adjustment is added into version GeoMat 2022.  Users may refine current mesh 

for better convergence performance or make mesh coarser to reduce computing time.  However, this 
operation may delete previously defined materials, loads, constrains or stiffnesses.  Users shall check 
consistency before the new analysis. 

4.2 Mesh Refinement  
The mesh refinement option is incorporated into the Edit menu as shown in Figure 4.1.  Based on 
the template used to build previous mesh, a different interface window will prompt.  If previous 
mesh is built from conventional circular/rectangular plate template, the mesh refinement window 
will look like that Figure 4.2.  The default refinement factor for both y and z directions are set to 2 
which means element number in y and z directions will be doubled.  Refinement factor should be 
an integer. Any float number will be round up to an integer.  If the refinement factor is smaller than 
1, no new mesh is regenerated.  If users set the division in one direction to be 1, there will be no 
mesh refinement in that direction.  

Note this refinement approach is also applicable to unequally spaced mesh.  

 

Figure 4.1 Mesh adjustment options contained in the Edit menu 

Click button OK to close mesh refinement window.  A message window will pop up to remind users to 
check consistency because previous boundary conditions or materials may be not available (Figure 4.3). 
If Yes is clicked, new mesh will be generated as shown in Figure 4.4. 
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Figure 4.2 Mesh adjustment for conventional circular/rectangular plate 

 

 

Figure 4.3 Information message before mesh adjustment is processed 

If previous mesh is built from the template of octagon/circular wind turbine foundation, the mesh 
refinement input window will look like that in Figure 4.5.  Users may change the typical finite element 
size to a new value for the new mesh.  Previous geometry data and load data will be kept and convert 
to new mesh.  Users still should check consistency of materials, node constrains or other boundary 
conditions defined in previous mesh.  
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Figure 4.4 Refined mesh in both y and z directions 

 

 

Figure 4.5 Refine mesh for wind turbine foundation 
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4.3 Change of Element Type   
It is recommended in GeoMat to use quadratic eight-node element combined with 2x2 integration 
rule.  This element type provides good accuracy and efficiency so that it is appropriate for most 
cases.  If another element type is desired, users may click menu Edit->Change Element Type and 
select another one.  If quadratic eight-node is the current element type, only conversion to linear 
four-node or Lagrangian nine-node element type is available.  A message window will pop up to 
remind users to check consistency after conversion (Figure 5.7).  Since converting to a new element 
type will regenerate the mesh, all previously defined boundaries/materials may be invalid.  After a 
successful conversion, nodes will be highlighted in red as in Figure 4.8.  Click Options->Mark Nodes 
to disable node mark. 

 

Figure 4.6 Change element type from Edit menu 

 

 

Figure 4.7 Information message before change of element type is processed 
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Figure 4.8 Mesh after change of element type from 8-node to 4-node 

 

4.4 Change of Integration Rule  
 

Default integration rules in GeoMat are defined as following: 

• 1x1 or 2x2 are available to four-node element.  2x2 is recommended 
• 2x2 or 3x3 are available to eight-node element.  2x2 is recommended 
• 3x3 is available to nine-node Lagrangian element.  It is the only integration rule for 

this element type.  

Users may change integration rule by clicking menu Edit->Input Data->Integration Points then select 
one rule (Figure 5.9).  Changing integration does not regenerate the mesh.  Previously defined 
material, boundaries, various sets can be kept.   
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Figure 4.9 Change integration rule from Edit menu 
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5.1 Introduction 
 Chapter 4 presents options related to execution of the program and includes methods of 
addressing run-time errors.  This chapter also includes suggestions for reviewing input, output, and 
processor text files.  The final section of this chapter includes descriptions about the slab properties 
that may be observed in graphical form.  The commands covered in this chapter are contained in the 
top menu, under the Computation and the Results titles. 

5.2 Computation Menu 
 This menu is used to execute the program with the parameters that were saved in the input-data 
file.  Within the options contained under this menu, shown in Figure 5.1, there are commands that 
facilitate the reviews of the text files produced for storing input data, output results, and processor notes.  
Detailed description of the submenu options contained under the Computation menu is explained in the 
following sections.  

  

Figure 5.1 Options contained in the Computation menu 

 

 

5.2.1 Computation- Run Analysis 
 An input file, after preparation or modification, must be saved to disk before selecting the 
Computation -Run Analysis submenu option, which executes the analytical portion of program GeoMat. 
The module, a stand-alone program routine, is called for execution by the “shell” process of the 

environment in Microsoft Windows
©

.  
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 The user should remember to save the input data under a user-specified name before executing 
the analytical module.  When saving data to disk, GeoMat will automatically add an extension of the type 
*.slb to the name of the input file.  A sub-window is usually produced during the execution of the module.  
A finished execution of the module is determined when the sub-window closes.  

 At the beginning of the run, the analytical module will read the saved input data progressively, 
showing the line number which is being read.  If an input-data format is incorrect during reading, the 
analytical module will stop immediately and in many cases, it saves an error message and a status report 
in a file with the extension *.sms.  This file may be accessed by selecting View Message File in the 
Computation menu. 

 Within the processor-run notes, if all input data was read correctly, the analytical module will 
show the ending time of the analysis.  The analytical module automatically creates an output file with the 
same name as the input and with the extension *.sou.  Once a successful run is produced, the user may 
proceed to the next items for observation of results.  

5.2.2 Computation- View Input File 
 This submenu option is used to edit the input-data file in plain text mode.  This command becomes 
active after new data files have been saved to disk or when opening existing data files.  The command is 
helpful for experienced users who may just want to change one or two parameters quickly using the text 
editor, or for those users wishing to observe the prepared input data in text mode.  This submenu 
automatically invokes a text editor.  The default setting is to use the utility program named notepad.exe 

provided by Microsoft Windows
©

.  Input-data text files are automatically saved to disk with the extension 
of *.sin by program GeoMat. Use of the notepad for editing the input data for Example Problem 1 is shown 
in Figure 5.2.  

5.2.3 Computation- View Output File 
 This submenu option is used to edit the output-text file that is automatically produced during 
each analytical run.  This command becomes active after new data files have been saved to disk and 
successfully executed, or when opening previously-executed data files. 

 The submenu automatically invokes a text editor.  The default setting is to use the utility program 

named notepad.exe provided by Microsoft Windows
©

.  Output files are automatically saved to disk with 

the same file name as the input-data file but with the extension*.sou.  Use of Microsoft Notepad
©

for 
editing the output file for Example Problem 1 is shown in Figure 5.3. 
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Figure 5.2 Sample use of Microsoft Notepad for editing input text of Example Problem 1.  

 

5.2.4 Computation- View Message File 
 This submenu option is used to edit an intermediate text file that is automatically produced during 
each analytical run.  This file only includes notes produced during the processing of the input data.  This 
submenu option becomes active after new-data files have been saved to disk and executed, or when 
opening previously executed data files.  This submenu automatically invokes a text editor.  The default 

setting is to use the utility program named notepad.exe provided by Microsoft Windows
©

.  

 Files containing processor-run notes are automatically saved to disk with the same file name as 

the input-data file but with the extension *.sms.  Using of the Microsoft Notepad
©

for editing the 
processor-run notes for Example Problem 1 is shown in Figure 5.4.  Observation of the notes produced 
during a processor run may become helpful to debug a data file that did not produce a successful run.  A 
successful run usually produces a file of processor-run notes containing similar lines of text as those in 
Figure 5.4. 
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Figure 5.3 Sample use of Microsoft Notepad for view output text of Example Problem 1. 

 

5.3 Results Menu 
 This menu option is selected to observe the different graphical representations of the program 
results contained in the output file.  Submenu options contained under this menu are shown in Figure 5.5.  
All the graphical representation of output data that may be produced by the program are contained in 
the following commands of the Results menu:  

 Select Step  

 Deformed Mesh  

 Contour Plot  

 Selection Cut Plot  

 The observation of any of the above-listed options will activate the graphics mode of GeoMat. 
Several changes occur during use of the graphics mode: new mouse commands are enabled and a new 
top-menu option becomes available.  
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Figure 5.4 Sample use of Microsoft Notepad for view message file of Example Problem 1. 

 

  

Figure 5.5 Command options contained in Result menu   
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5.3.1 Results – Select Step 
 The user may select this command option to observe a graphical representation of the time 
steps used to compute the solution.  A sample screen of the Select Step command option is shown in 
Figure 5.6.  This is ideally used in conjunction with the other two available menu options, Deformed 
Mesh and Contour Plot. 

 

Figure 5.6 Sample screen of the Select Step command option   

 

5.3.2 Results – Deformed Mesh  
 The user may select this command option to observe a graphical representation of the deformed 
shape for the modeled slab.  A sample screen of the Deformed Mesh command option is shown in Figure 
5.7.  The shape factor for the amount of deformation may be varied by the user.  The user also may choose 
to display undeformed shapes together with the deformed shape, as seen in Figure 5.8 

 

Figure 5.7 Sample screen of the Deformed Mesh command option 
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Figure 5.8 Combined display of deformed and undeformed configuration  

 

5.3.3 Results – Contour Plot 
 The user may select this command option to observe a contour plot of the output on the surface 
of the slab model.  A sample screen of the Contour Plot command option is shown in Figure 5.9.  The user 
may choose from a variety of contour distributions: displacement, rotation, moment, shear, and stress.  
The user may select the default contour limits or modify them.  Contour types available are shading, lines, 
and shading and lines together.  Figure 5.10 demonstrates the appearance of the line contour option, and 
Figure 5.11 the shading contour option for vertical displacement.  Figure 5.12 and Figure 5.13 demonstrate 
the shading contour option for moment and stress distributions, respectively. 
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Figure 5.9 Sample screen of the Contour Plot command option   

 

 

Figure 5.10 Line contour option for vertical displacement in Contour Plot   
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Figure 5.11 Shading contour option for vertical displacement in Contour Plot   

 

  

Figure 5.12 Shading contour option for moment distribution in Contour Plot   
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Figure 5.13 Shading contour option for stress distribution in Contour Plot   

 

5.3.4 Results – Section Cut Plot  
 The user may select this command to plot plate forces along one pre-defined cut line as shown 
in Figure 5.14.  Different cut lines can be selected from the box under Cut Line Selection.  Variables can 
be selected from variable box locating on the right side.  Users can also change line color or line width.  

 

Figure 5.14 X-Y plot for plate forces along one cut line   
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5.3.5 Results – Nodal Result  
 The user may select this command to plot deformation, reaction, plate forces or plate stresses 
for one specific node (Figure 5.15).  Node number can be changed by clicking the small arrow or input a 
new node number directly.  Select variable type button can switch between various output types.  

 

Figure 5.15 Nodal output   

 

5.4 Speed Buttons in Graphics Mode  
 The user is provided with a set of speed buttons available in the View toolbar, which is associated 
with the commands in the Transform menu.  Submenu choices, in order of their appearance in the speed 
button toolbar (Figure 5.16), are briefly described below.  

Panning   ................... this function allows the slab model to be moved in the window.  

Rotate   ..................... this function allows the slab model to be rotated around the origin.  

Zoom In/Out   ……….. this function zooms in and out on the slab model.  

Restart   ................... this function resets the view to the original YZ plane view.  

YZ View (Top)   ......... this orients the slab in the YZ plane, looking at the top of the slab. This is demonstrated 
in Figure 5.17.  

YZ View (Bottom)   ..... this orients the slab in the YZ plane, looking at the bottom of the slab. This is 
demonstrated in Figure 5.18.  

XY View (Front)   ........ this orients the slab in the XY plane, looking at the front of the slab. This is 
demonstrated in Figure 5.19.  

XZ View (Side)   .......... this orients the slab in the XZ plan, looking at the side of the slab. This is demonstrated 
in Figure 5.20.  

XYZ View (3D View)   . this orients the slab in an orthographic 3D view.  This is demonstrated in Figure 5.21. 

Rotation Angles   ....... this option allows the user to specify the desired rotation angle. The input window is 
shown in Figure 5.22. 
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Figure 5.16 Speed Buttons for graphics manipulation     

 

  

Figure 5.17 Slab model displayed using the YZ View (Top) speed button        
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Figure 5.18 Slab model displayed using the ZY View (Bottom) speed button      

 

  

Figure 5.19 Slab model displayed using the XY View (Front) speed button        
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Figure 5.20 Slab model displayed using the XZ View (Side) speed button       

  

  

Figure 5.21 Slab model displayed using the XYZ View (3D View) speed button        
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Figure 5.22 Sample screen of the Rotation Angles command option      
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6.1 Introduction  
 The chapter presents several examples studied by using GeoMat.  In order to assure accuracy 
from the computer results, some examples have been compared with the results from close-form 
solutions or calculated by other analytical tools presented in the technical literature.  Although examples 
presented in this chapter validate the output generated by this software, no warranty, expressed or 
implied, is offered as to the accuracy of results from the program.  The program should not be used for 
design unless caution is exercised in interpreting the results and independent calculations are helpful to 
verify the general correctness of the results.  

 There are three types of output data provided by the computer.  The first type is the output file 
giving the formatted text that consists of an echo-print of the input data, nodal coordinates, boundary 
constrains, load distributions, deflection at each nodal point, and, most of all, the bending moment and 
stress distribution at the integration points of each element.  

 The second type of output presents the data for a graphics file that allows the code to produce 
plots.  All of the data are saved with ASCII format and mainly for internal use to present the graphics and 
contour plots based on the user’s selection.  The third type of output presents the status of execution 
with the user’s data.  It contains information about the iteration number, convergence condition, and the 
information about unsuccessful computation.  

 Example problems provide the user information on input and output of various cases and present 
a quick tutorial for real-world applications.  The user is encouraged to study these examples and, with 
modifications, may even use them to solve similar problems.  However, by no means can these limited 
examples explore the full functions and features provided by GeoMat. 

6.2 Example 1: Cantilevered square plate simulated by single 
quadratic element 

6.2.1 Problem Description  

 A square cantilever plate is modeled by a single 8-node isotropic plate element. Rotational 
restraints in the z direction are applied to nodes 1, 3, 4, and 5.  Along the restrained edge, nodes 6, 7, and 
8, translations in the x direction as well as rotational restraints in the y and z directions are applied. The 
length in the y and z direction is 10 in. and the thickness of the plate is 0.2 in. Young’s modulus is taken as 

10,000 kip/in
2
 (ksi) and Poisson’s ratio as 0.3. To model a uniform edge load, concentrated loads of P, 4P, 

and P are applied in the x direction at nodes 1, 2, and 3, where P = 0.01kip.  

6.2.2 Modeling Instruction 

 To model this slab in GeoMat, first go to File -> New from template. In the Slab Type dialog box 
select “Circular or Rectangular Conventional” and click Next.  In the Template dialog box, choose 
“Rectangular – Equally Spaced” for the Shape and “Quadratic 8 Noded” for the Element Type.  Enter the 
“Length” and “Width” as 10, and the “Number of Divisions” as 1.  Click OK to draw the slab on the screen 
(Figure 6.1).  
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 Go to Input Data -> Title and enter a name for the current project.  The name used here is Example 
1.  Click OK to save this as the project title.  Next, return to the Input Data menu and proceed to Material 
Properties.  Leave the default “Element Number/Set” value as ALL, select Isotropic under “Material 
Type” and click Define to open the Material Properties dialog box.  In the Material Properties dialog box 
modify the parameters to those given in the problem statement and then click OK to save the changes 
and close the dialog box.  In the Material Data Dialog box click OK to return to the main screen.  

 Before setting the nodal constraints and loads, it is recommended that the node numbers and 
marks are turned on.  To do so, go to menu Options -> Mark Nodes and Options -> Node Numbers.  Now 
that the nodes are marked, return to the Input Data menu, and select Nodal Constraints.  Use the Add 
Row button to create a new line.  In the Node Number column, enter the first node, 1.  Check the box in 
the “Rotation Z” column to restrain the rotations in the z direction.  Repeat for nodes 3, 4, and 5. For 
nodes 6, 7, and 8, check the “Displac. X”, “Rotation Y”, and “Rotation Z” columns.  Click Apply and then 
OK.  Next, proceed to the Input Data menu and select Nodal Loads.  To set the load of 0.01kip to node 1, 
click Add Row, check the box next to the “Force X” column to activate the input box, and enter 0.01 in 
the Input box.  For node 2, enter 0.04 in the “Force X” column and for node 3 enter 0.01.  Click Apply 
and then OK.  Figure 6.2 shows the slab with applied load and the nodal constraints, which can be obtained 
by going to the Options menu and select Nodal Constraint and Nodal Loads. 

  

Figure 6.1 Example 1 slab, shown with marked and labeled nodal points  
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Figure 6.2 Example 1 slab shown with nodal constrains and nodal loads  

 Before executing the file, go to File -> Save As… and save the file as example1.slb.  Once this is 
completed, go to menu Computations -> Run Analysis to launch the analysis.  When the analysis is 
completed, go to menu Computations -> View Output File.  

6.2.3 Output Results Review 
 When the analysis is completed, go to menu Computations -> View Output File.  Figure 6.3 shows 
part of the result file.  This output compares well to the results given in the text Finite Elements for 
Structural Analysis for this problem. 
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Figure 6.3 Review output file example1.sou for displacement results   

 
Figure 6.4 shows the deformed shape of the slab.  This graphic is produced using the Results -> Deformed 
Mesh option.  In the Deformed Shape dialog box check the “Show Deformed Shape” and “Show 
Undeformed Model” boxes then, set the “Deformed Shape Factor” to 5 and click Apply.  To display the 
contour plot, open the Results -> Contour Plot window.  Under “Contour Variable” select “Disp X,” and 
then click Apply. This output compares well to the results given in the text Finite Elements for Structural 
Analysis for this problem. 

  

Figure 6.4 Example 1 slab shown with nodal constrains and nodal loads  

 

6.3 Example 2: Fixed square plate subject to concentrated force at 
center 

6.3.1 Problem Description  

 This example models a fixed, square plate using eight-node isotropic plate elements with a 
concentrated load P applied at the center.  Taking advantage of symmetry, only a quarter of the plate will 
be modeled in this example.  

 Due to symmetry, restraints against rotations in the z direction are taken along an edge parallel 
to the z axis, and restraints against rotations in the y direction are taken along an edge parallel to the y 
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axis.  The fixed boundary is restrained against all translations and rotations.  The length of the quarter 
plate is 8 in. in both the y and z direction, with a thickness of 0.25 in., and is divided into a 4x4 network.  
Young’s modulus is 30,000 ksi and Poisson’s ratio is 0.3.  The center load, P, is 1 kip; however, due to 
symmetry, the load applied to the edge node will be 0.25 kip.  Figure 6.5 shows the configuration of the 
nodal constraints on the slab.  

  

Figure 6.5 Quarter model of fixed edge slab with center load    

 

6.3.2 Modeling Instruction 

 To compute this problem using GeoMat, use the New from template option in the File menu.  In 
the Slab Type dialog box select “Circular or Rectangular Conventional” and click Next.  In the Template 
dialog box, choose “Rectangular – Equally Spaced” for the Shape and “Quadratic 8 Noded” for the Element 
Type.  Enter the “Length” and “Width” as 8, and the “Number of Divisions” as 4.  Click OK to draw the slab 
on the screen.  

 Go to menu Input Data -> Title and enter a name for the current project; here it is Example 2. 
Click OK to save this as the project title.  Next, return to the Input Data menu and proceed to Material 
Properties.  Leave the default “Element Number/Set” value as ALL, select Isotropic under “Material 
Type” and click Define to open the Material Properties dialog box.  In the Material Properties dialog box 
modify the parameters to those given in the problem statement and then click OK to save the changes 
and close the dialog box.  In the Material Data dialog box click OK to return to the main screen.  
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 Before setting the nodal constraints and loads, it is recommended that the node numbers and 
marks are turned on.  To do so, go to menu Options -> Mark Nodes and Options -> Node Numbers.  

 In addition, it is helpful to define node sets to aid in the assigning of restraints and loads.  For this 
problem, four nodal sets were created using the Input Data -> Node Sets dialog.  To create the first node 
set, click on the Add Row button.  Enter the name BOTTOM into the edit box and click the Define button 
to launch the Node Set dialog.  Using the Add Row button, enter 1 under “Node Number/Set,” 8 under 
“Final” and 1 under “Increment” to select the nodes to be defined in this nodal set (nodes 1 through 8).  
For nodal set LEFT, nodes 1, 10, 15, 24, 29, 38, 43, and 52 are defined.  One way to input this data is by 
adding 2 rows.  For the first row, enter 1 under “Node Number/Set,” 43 under “Final” and 14 under 
“Increment.”  For the second row, enter 10 under “Node Number/Set,” 52 under “Final” and 14 under 
“Increment.”  For nodal set TOP, nodes 57 through 65 are defined.  For nodal set RIGHT, nodes, 9, 14, 
23, 28, 37, 42, 51, and 56 are defined.  Click OK to save these settings, as shown in Figure 6.6.   

 Now that the nodes are marked and node sets defined, return to the Input Data menu, and select 
Nodal Constraints.  Use the Add Row button to create a new line.  In the Node Number column, enter the 
name of one of the nodal sets.  As seen in Figure 6.5, nodal set BOTTOM corresponds to a rotational 
restraint in the y direction.  Check the box in the “Rotation Y” column to restrain the rotations in the y 
direction.  The nodal set LEFT corresponds to a rotational restraint in the z direction.  Check the box in 
the “Rotation Z” column to restrain the rotations in the z direction.  The nodal sets TOP and RIGHT are 
fixed in all directions.  Check all the boxes to restrain displacements and rotations in all direction.  Use 
Figure 6.5 as a guide.  Click Apply and then OK.  Next, proceed to menu Input Data -> Nodal Loads.  To 
set the load of 0.25 kip to node 1, the center node, click Add Row, enter 1 under “Node Number,” check 
the box next to the “Force X” column to activate the input box, and enter 0.25 in the input box.  Click 
Apply and then OK.  

 Before executing the file, go to menu File -> Save As… and save the file as example2.slb.  Once 
this is completed, go to Computations -> Run Analysis to launch the analysis.  
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Figure 6.6 Defining edge nodes (BOTTOM edge nodes highlighted)      

 

6.3.3 Output Results Review 
 When the analysis is completed, go to menu Computations -> View Output File.  The deflection 
at node 1, the center deflection for the fixed square plate, is 0.0335379.  Figure 6.7 shows the contour 
plot for the slab deflection.  To view this, go to Results -> Contour Plot, in the Contour Plot Options check 
“Show Contour Plot” and under “Contour Variable” select “Disp X” and then click Apply. This result 
corresponds exactly to the computer generated numerical result for a 4x4 network as reported in Finite 
Elements for Structural Analysis, which is within 0.4% of the classical solution, 0.033397 in. 
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Figure 6.7 Contour plot of displacement in X for slab in Example 2        

 

6.4 Example 3: Square slab on soil - distributed stiffness method 

6.4.1 Problem Description  

 This example is included to model a square concrete slab resting on soil using 8-node isotropic 
plate elements.  The slab is 24 ft x 24 ft and 10 in. thick.  Young’s modulus is taken as 3,000,000 psi and 
Poisson’s modulus is 0.2.  The subgrade modulus of the soil is assumed to be 200 psi per inch of deflection.  
A concentrated load of 10 kips is applied at the center of the slab.  

6.4.2 Modeling Instruction 

 To compute this problem using GeoMat, use the New from template option in the File menu.  In 
the Slab Type dialog box select “Circular or Rectangular Conventional” and click Next.  In the Template 
dialog box, choose “Rectangular – Equally Spaced” for the Shape and Quadratic 8 Noded” for the Element 
Type.  Enter the “Length” and “Width” as 288, and the “Number of Divisions” as 4, as shown in Figure 6.8.  
Click OK to draw the slab on the screen.   
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Figure 6.8 New Project from Template dialog screen for Example 3  

 Go to Input Data –> Title and enter a name for the current project; this one is Example 3.  Click 
OK to save this as the project title.  Next, return to the Input Data menu and proceed to Material 
Properties.  Leave the default “Element Number/Set” value as ALL, select Isotropic under “Material 
Type” and click Define to open the Material Properties dialog box.  In the Material Properties dialog box 
modify the parameters to those given in the problem statement and then click OK to save the changes 
and close the dialog box. In the Material Data dialog box click OK to return to the main screen. 

 To set the soil stiffness, go to menu Input Data -> Distributed Stiffness.  Add a row using the Add 
Row button.  Under the “Element Number” heading, enter ALL in the edit box, so the soil stiffness is 
distributed evenly beneath all of the slab elements.  Next, check the box under the “D. Tr. K X” column 
and enter 200 in the associated edit box.  Click Apply and then the OK button.  

 Next, go to menu Input Data -> Nodal Loads.  Add a row and enter the number of the middle 
node, 33.  Check off the “Force X” box and enter 10000 for the load.  Click Apply and then OK.  Figure 
6.9 shows the slab with the point load applied at the center and the distributed soil stiffness.  To set this 
view go to Options -> Nodal Loads and Options -> Distributed Stiffness. 

 Before executing the file, go to File -> Save As… and save the file as example3.slb.  Once this is 
completed, go to Computations -Run Analysis to launch the analysis. 

6.4.3 Output Results Review 

 When the analysis is completed, go to menu Computations -> View Output File.  The center 
deflection at node 33 is 0.00586678.  This result is very close to the Westergaard solution for this problem, 
0.0057 in., as reported in the text Discontinuous Orthotropic Plates and Pavement Slabs.  
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 Now let us consider a different case using the same slab.  This time, the 10 kip point load is applied 
along the edge of the slab.  Save a copy of example3.slb as example3b.slb.  Change the project title to 
Example 3b.  Move the nodal load from node 33 to node 5, positioning the load at the middle of the 
lower edge of the slab.  Save the file and run the analysis.  The maximum deflection under the edge load 
is 0.0220390.  The Westergaard closed form solution for this case is 0.019 in., as reported in the text 
Discontinuous Orthotropic Plates and Pavement Slabs. 

 

 

Figure 6.9 Slab of Example 3 shown with soil stiffness and center point load   

 

6.5 Example 4: Square slab on soil - Mindlin method 

6.5.1 Problem Description  

 This example uses the same slab and loading condition as Example 3 to estimate the deformation 
of the slab based on Young’s modulus of the soil which is entered externally.  Instead of using the given 
soil subgrade modulus as soil springs, Young’s modulus of soil is used to derive the soil stiffness beneath 
each nodal point.   

6.5.2 Modeling Instruction 
 To solve this problem using GeoMat, use the New from template option in the File menu.  In the 
Slab Type dialog box select “Circular or Rectangular Conventional” and click Next.  In the Template dialog 
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box, choose “Rectangular – Equally Spaced” for the Shape and “Linear 4 Noded” the Element Type.  Enter 
the “Length” and “Width” as 288, and the “Number of Divisions” as 8.  Click OK to draw the slab on the 
screen.  

 Go to Input Data –> Title and enter a name for the current project; this one is Example 4.  Click 
OK to save this as the project title.  In this model a reduced integration 4 node element will be used, to 
apply this go to Input Data -> Integration Points and select “1 x 1 (reduced).”  Return to the Input Data 
menu and proceed to Material Properties.  Leave the default “Element Number/Set” value as ALL, select 
Isotropic under “Material Type” and click Define to open the Material Properties dialog box.  In the 
Material Properties dialog box modify the parameters to those given in the problem statement from 
example 3 and then click OK to save the changes and close the dialog box. In the Material Data dialog box 
click OK to return to the main screen. 

 The nodal edges must be restrained since there is no nodal stiffness applied for this case. 
Following the procedure described in Example 2, create a node set named EDGE and set the edge nodes 
to it.  Go to Input Data -> Node Set then Add Row and enter the name EDGE into the edit box and click 
the Define button to launch the Node Set dialog.  Using the Add Row button, enter 1 under “Node 
Number/Set,” 9 under “Final” and 1 under “Increment” to select the nodes to be defined in the bottom 
edge (nodes 1 through 9).  Add a second row using the Add Row button, enter 73 under “Node 
Number/Set,” 81 under “Final” and 1 under “Increment” to select the nodes to be defined in the top edge 
(nodes 73 through 81).  Add a third row, enter 10 under “Node Number/Set,” 64 under “Final” and 9 under 
“Increment” to select the nodes to be defined in the left edge (nodes 10, 19, 28, 37, 46, 55, 64).  Add a 
fourth row, enter 18 under “Node Number/Set,” 72 under “Final” and 9 under “Increment” to select the 
nodes to be defined in the right edge (nodes 18, 27, 36, 45, 54, 63, 72).  Click Ok to go back to the Node 
Set dialog box, and then click Ok to return to the main screen.  Next, go to Input Data -> Nodal Constraints 
and restrain the EDGE set in the y and z directions.  Click on Add Row, enter EDGE under “Node Number”, 
and check “Displac Y,” “Displac Z” and “Rotation X.” Click Apply and then OK.  

To input the center load, go to Input Data -> Nodal Loads.  Add a row and enter the number of 
the middle node, 41.  Check off the “Force X” box and enter 10000 for the load.  Click Apply and then 
OK.  Figure 6.10 shows the slab with the point load applied at the center and the edge restraints.  Next, 
go to Input Data -> Soil Stiffness.  Select “Estimate Soil Stiffness using Mindlin Equation.  For this 
example, a Young’s modulus of 17000, a Poisson’s ratio of 0.4, and an initial stiffness of 700 are 
assumed, click OK to return to the main screen.  Go to Input Data -> Time Stepping, under “Max. 
Iterations/Step” enter 500, and under “Error Tolerance” enter 0.001, click Ok to return to the main screen. 

Before executing the file, go to File -> Save As… and save the file as example4.slb.  Once this is completed, 
go to Computations -Run Analysis to launch the analysis. 
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Figure 6.10 Slab of Example 4 shown with center load and edge restrains 

 

6.5.3 Output Results Review 

 Execute the file and view the output data.  To view the deformed shape, go to Results -> 
Deformed Mesh and check both options “Show Deformed Shape” and “Show Undeformed Model”.  The 
graphic shown in Figure 6.11 was produced using a deformation factor of 500.  The center deflection is 
reported to be 0.0061 inch.  The Young’s modulus and initial stiffness values will need to be varied until 
the output deflection approaches that of the known value.  A Young’s modulus of 17000 and an initial 
stiffness of 700 were used in this example. 
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Figure 6.11 Deformed shape of slab of Example 4 shown with center load and edge restrains 

 

6.6 Example 5: Slab on soil to support four columns (no rotation 
restraint)  

6.6.1 Problem Description  

 This problem models a square concrete slab resting on soil using 8-node isotropic plate elements.  
The slab is 10 ft. square and 2 ft. thick.  Young’s modulus is taken as 468,000 kip/ft2 (ksf) and Poisson’s 
modulus is 0.15.  The subgrade modulus of the soil is assumed to be 100 kcf.  A concentrated load of 125 
kips is applied to four nodes around the plate center.  

6.6.2 Modeling Instruction 

 To compute this problem using GeoMat, use the New from template option in the File menu.  In 
the Slab Type dialog box select “Circular or Rectangular Conventional” and click Next.  In the Template 
dialog box, choose “Rectangular – Equally Spaced” for the Shape and “Quadratic 8 Noded” for the  
Element Type.  Enter the “Length” and “Width” as 10, and the “Number of Divisions” as 5.  Click OK to 
draw the slab on the screen.  

 Go to menu Input Data -> Title and enter a name for the current project; this one is Example 5.  
Click OK to save this as the project title.  Next, return to the Input Data menu and proceed to Material 
Properties.  Leave the default “Element Number/Set” value as ALL, select Isotropic under “Material 
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Type” and click Define to open the Material Properties dialog box.  In the Material Properties dialog box 
modify the parameters to those given in the problem statement and then click OK to save the changes 
and close the dialog box. In the Material Data dialog box click OK to return to the main screen. 

 To set the soil stiffness, go to menu Input Data -> Distributed Stiffness.  Add a row using the Add 
Row button.  Under the “Element Number” heading, enter ALL in the edit box, so the soil stiffness is 
distributed evenly beneath all of the slab elements.  Next, check the box under the “D. Tr. K X” column 
and enter 100 in the associated edit box.  Click Apply and then OK button. 

 Next, go to Input Data -> Nodal Loads.  Because the load is applied in the center, and no node 
exists at that location, the load will be evenly divided among the four nodes of element 13 (39, 41, 56, 
and 58).  Add four rows and enter a load of 125 for each node.  Click Apply and then OK.  

 Before executing the file, go to File -> Save As… and save the file as example5.slb.  Once this is 
completed, go to Computations -> Run Analysis to launch the analysis.  

6.6.3 Output Results Review 

 When the analysis is completed, go to menu Computations -> View Output File.  The deflection 
at node 39 is 0.0508956 ft.  Moments 𝑀𝑀𝑦𝑦 at corner node of element 13, are 50.344 kip*ft/ft.  These results 
are close to the solution reported in the text Foundation Analysis and Design for this slab.  To view the 
how the slab deforms, go to Results -> Deformed Mesh, or to view the moment distribution, go to Results 
-> Contour Plot and select the desired moment.  

 

Figure 6.12 shows the deformed slab with a deformation shape factor of 5 with the undeformed outline. 
Figure 6.13 shows the contour plot of the moment in the y direction.  Figure 6.14 shows moment 𝑀𝑀𝑦𝑦 of 
node 39 using nodal output option.  
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Figure 6.12 Deformed shape of slab of Example 5   

 

Figure 6.13 Contour plot of moment distribution in the y direction of Example 5   
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Figure 6.14 Nodal output for moment My at node 39 in Example 5   

 

6.7 Example 6: Slab on soil to support four concentrated forces 
(restrained nodal rotation) 

6.7.1 Problem Description  

 This example uses the slab of Example 5, but this time assumes that nodes 39, 41, 56, and 58 are 
held against rotation in both y and z directions, simulating the presence of a fixed concrete column. Go to 
Input Data -> Nodal Constraints and add 4 rows.  Under the “Node Number” column input 39 for row 1, 
41 for row 2, 56 for row 3, and 58 for row 4, and check off “Rotation Y” and “Rotation Z” for each row.  
The deformation at node 39 drops to 0.0507750 ft., and the moment under the column becomes 44.19 
kip*ft/ft.  The deformed shape and the contour plot of the moment in the y direction are shown in Figure 
6.15 and Figure 6.16, respectively. 
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Figure 6.15 Apply node rotation constrains to simulate non-rotation at column foot in Example 6   

 

  

Figure 6.16 Contour plot of moment distribution in the y direction of Example 6   
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Figure 6.17 Moment My at node 39 in Example 6   

 

6.8 Example 7: Rectangular slab on soil subject to column loads 

6.8.1 Problem Description  
 This example considers a rectangular concrete raft supporting four columns.  The slab is 16m by 
12 m, and is 0.8m thick.  The concrete has a Young’s modulus of 30 GPa (30000 MPa) and a Poisson’s ratio 

of 0.2.  The subgrade modulus of the soil is 4 MN/m
3
.  The columns provide a concentrated load of 5MN, 

3MN, 6MN, and 8MN, respectively.  The column locations are shown in Figure 6.18.  

6.8.2 Modeling Instruction 

 To compute this problem using GeoMat, use the New from template option in the File menu.  In 
the Slab Type dialog box select “Circular or Rectangular Conventional” and click Next.  In the Template 
dialog box, choose “Rectangular – Equally Spaced” for the Shape and “Quadratic 8 Noded” for the Element 
Type.  In the Y-direction enter the “Length” as 16 and “Number of divisions” as 16, In the Z-direction 
enter the “Width” as 12 and “Number of divisions” as 12.  Click OK to draw the slab on the screen.  

 Go to Input Data -> Title and enter a name for the current project; this one is Example 7.  Click OK 
to save this as the project title.  Next, return to the Input Data menu and proceed to Material Properties.  
Leave the default “Element Number/Set” value as ALL, select Isotropic under “Material Type” and 
click Define to open the Material Properties dialog box.  In the Material Properties dialog box modify the 
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parameters to those given in the problem statement and then click OK to save the changes and close the 
dialog box. In the Material Data dialog box click OK to return to the main screen. 

 To set the soil stiffness, go to Input Data -> Distributed Stiffness.  Add a row using the Add Row 
button.  Under the Element Number heading, enter ALL in the edit box, so the soil stiffness is distributed 
evenly beneath all of the slab elements.  Next, check the box under the “D. Tr. K X” column and enter 4 in 
the associated edit box.  Click Apply and then the OK button.  

 Next, go to Input Data -> Nodal Loads.  The columns are located at nodes 109, 129, 409, and 429.  
At node 109, enter a load of 5MN in the x direction; at node 129, a load of 3 MN; at node 409 a load of 
8MN; and at node 429 a load of 6MN.  

 Before executing the file, go to File -> Save As… and save the file as example7.slb.  Once this is 
completed, go to Computations -> Run Analysis to launch the analysis.    

  

Figure 6.18 Location of columns on raft of Example 7   

 

6.8.3 Output Results Review 

 When the analysis is completed, go to Computations –> View Output File.  To view how the slab 
deforms, go to Results –> Deformed Mesh.  Figure 6.19 shows the deformed slab with a deformation 
shape factor of 10 together with the undeformed outline.  To view the moment, go to Results –> Contour 
Plot and select the desired moment axis.  The maximum moment in the y direction is 1767.2 m-kN at the 
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8 MN column.  The maximum moment in the x direction also occurs at the 8 MN column and is 1778.1 m-
kN.  Figure 6.20 shows the moment distribution of the raft along the y axis. 

 For viewing the section-cut plot, the user should click Section Cut item under Input Data menu 
and then select the cutting lines by default or by the user-specified.  To view the deflection along the 
cutting line, go to Results –> Section Cut Plot and select the desired cutting line and deflection as shown 
in Figure 6.21 for required display. 

  

Figure 6.19 Deformed shape of slab with column loads of Example 7   
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Figure 6.20 Moment distribution of the slab in the y direction of Example 7   

 

 

Figure 6.21 Deflection of the slab along the cutting line of Example 7   
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6.9 Example 8: Rectangular raft on soil to support columns and walls 

6.9.1 Problem Description 
 This example considers a rectangular concrete raft supporting 10 columns and three wall sections.  
The slab is 16m by 8 m and is 0.8m thick.  The concrete has a Young’s modulus of 30000 MPa and a 

Poisson’s ratio of 0.2.  The subgrade modulus of the soil is 30 MN/m
3
.  The location of the walls and 

columns and the mesh size are shown in Figure 6.22.  

 
Figure 6.22 Location of walls and columns in Example 8 

 

6.9.2 Modeling Instruction 

To compute this problem using GeoMat, use the New from template option in the File menu.  In 
the Slab Type dialog box select “Circular or Rectangular Conventional” and click Next.  In the Template 
dialog box, choose “Rectangular – Equally Spaced” for the Shape and “Quadratic 8 Noded” for the Element 
Type.  In the Y-direction enter the “Length” as 16 and “Number of divisions” as 10, In the Z-direction 
enter the “Width” as 8 and “Number of divisions” as 8.  Click OK to draw the slab on the screen.  

To set the soil stiffness, go to Input Data -> Distributed Stiffness.  Add a row using the Add Row 
button.  Under the Element Number heading, enter ALL in the edit box, so the soil stiffness is distributed 
evenly beneath all of the slab elements.  Next, check the box under the “D. Tr. K X” column and enter 30 
in the associated edit box.  Click Apply and then the OK button.  
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 Next, go to Input Data -> Nodal Loads.  The columns are located at nodes 1, 11, 21, 163, 169, 175, 
257, 267, 271, 277, 107, 103.  And the loads are 1.1, 1.22, 1.09, 0.29, 0.15, 0.83, 1.11, 1.05, 0.5, 1.34, 0.31, 
0.44 (MN), respectively.  The U-shape wall load is entered as follows.  Go to Input Data –> Edge Sets.  
Create a new edge set named WALL (Click Add Row and enter WALL under the “Set” column). Then select 
Define and add six rows as shown in Figure 6.23.  Once all the values are entered, click Apply and OK to 
return to the Edge Set dialog box, then click OK to return to the main screen.  To assign the load to the 
wall, go to Input Data –> Edge Loads.  Set the Edge column to WALL, under “DOF” enter 1 and place the 
0.600 MN load in the Load Node 1, 2 and 3 columns, click Apply and OK to return to the main screen. 

Before executing the file, go to File -> Save As… and save the file as example8.slb.  Once this is completed, 
go to Computations -> Run Analysis to launch the analysis.    

  

 Figure 6.23 Location of edge set for U-shape wall in Example 8  

 

6.9.3 Output Results Review 

 When the analysis is completed, go to Computations –> View Output File.  To view how the slab 
deforms, go to Results –> Deformed Mesh.  The deformed shape of the slab is shown in Figure 6.24.  
Moment distributions in the y and z directions are shown in Figure 6.25 and Figure 6.26.  Note the 
locations of positive and negative bending 
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Figure 6.24 Deformation of slab in Example 8  

 

  

Figure 6.25 Contour of bending moment Mz    
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Figure 6.26 Contour of bending moment My    

 

6.10 Example 9: Wind turbine foundation supported by drilled shafts 

6.10.1 Problem Description  

 A foundation design utilizing drilled shafts, hereafter referred to as a drilled shaft foundation, for 
a wind turbine generator would conceptually consist of a circular or square array of drilled shafts 
connected to a reinforced concrete cap (Figure 6.27).  The wind turbine tower would then be attached 
to the cap with the use of post-tensioned anchor bolts anchored to an embedment plate within the cap, 
or an embedded portion of the wind turbine tower, commonly referred to as an Embedded Stub or 
Foundation Mounting Part (FMP) as shown in Figure 6.28.  Drilled shafts would extend to a sufficient 
depth to resist design loads from overturning, torsion, and horizontal shear, as well as gravity loads from 
the wind turbine and associated components.   

 The unique requirements of structural design on a pile cap for a wind-turbine foundation include: 
(1) integrating the drilled shafts and the pier cap together so that the pile cap may reliably distribute the 
loads to each drilled shaft; and (2) integrating the base cap and the embedded mounting plate of the 
wind turbine tower to substantially reduce or eliminate the risk of pullout failure of the embedded 
mounting plate.  The punching-shear failure near the heavily loaded shaft as well as the surface 
reinforcement for delivering the required bending capacity of the pile cap should also be evaluated in the 
pile-cap design. 
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Figure 6.27 Conceptual sketch of drilled-shaft foundation supporting a wind turbine  

 

 The diameter of the concrete pile cap is 6.835 m and the thickness of the pile cap is 1.5 m.  The 
loads on the pile cap include (1) vertical load of 1108 kN, horizontal load of 550 kN, and bending moment 
of 21373.4 kN-m.  The embedded mounting plate hosts a total of 96 anchor bolts which are arranged in 
two circular rings (Figure 6.28).  The diameter of the outer ring is 1.959 m and the diameter of the inner 
ring is 1.839 m. 
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Figure 6.28 Dimension of pile cap and the embedded mounting plate with two rings of anchor bolts   

 

6.10.2 Modeling Instruction 

To compute this problem using GeoMat, use the New from template option in the File menu.  In 
the Slab Type dialog box select “Circular or Rectangular Conventional” and click Next.  In the Template 
dialog box, choose “Circular” for the Shape and “Linear 4 Noded” for the Element Type.  Enter the 
diameter as 6.835 m, and the “Number of Divisions” as 64, as shown in Figure 6.29.  Click OK to draw 
the slab on the screen.   

 Go to Input Data –> Title and enter a name for the current project; this one is Example 9.  Click 
OK to save this as the project title.  Next, return to the Input Data menu and proceed to Material 
Properties.  Leave the default “Element Number/Set” value as ALL, select Isotropic under “Material 
Type” and click Define to open the Material Properties dialog box.  In the Material Properties dialog box 
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modify the parameters to as Young’s modulus of 21,000,000 kN/m2, Poisson’s ratio of 0.3, and the 
thickness of 1.5 m.  Click OK to save the changes and close the dialog box. In the Material Data dialog 
box click OK to return to the main screen.  

 

  

Figure 6.29 New Project from Template dialog screen for Example 9  

 

 It can be assumed that the pile cap is restrained completely (not allowing any translations) at the 
top of drilled shafts.  The drilled shafts are assigned as node sets P1, P2, P3, P4, P5, P6, P7, and P8 based 
on the location.  

 To define the nodal sets (P1, P2, P3, P4, P5, P6, P7, and P8) to be used later for Nodal Constraints, 
click Node Set under Input Data Menu, and bring a dialog box as shown in Figure 6.30.  Add 8 new rows 
and assign the names P1, P2, P3, P4, P5, P6, P7, and P8.  Click the Define button under “Action” for 
each set name.  As shown in Figure 6.31 to Figure 6.34, the nodal points which are covered by the contact 
area were entered with some convenient arrays.  Those nodal points can be easily identified on the mesh 
plot by the Zone tool (Figure 6.35).  
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Figure 6.30 Node Set screen for Example 9  

    

Figure 6.31 Definition of Node Sets P1 and P2 for Example 9  

    

Figure 6.32 Definition of Node Sets P3 and P4 for Example 9  
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Figure 6.33 Definition of Node Sets P5 and P6 for Example 9  

   

Figure 6.34 Definition of Node Sets P7 and P8 for Example 9  
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 Figure 6.35 Node numbers on the screen for Example 9   

 

 

To set the nodal constraints, go to Input Data –> Nodal Constraints.  Add one row for each drilled shaft 
location using the Add Row button.  Under the Nodal Number heading, enter (P1, P2, P3, P4, P5, P6, P7, 
and P8) in the edit box, so the each represent the nodal points within the contact area of drilled shaft.  
Next, check the box under “Displac. X”, “Displac. Y”, and “Displac. Z” columns and enter 0 in the associated 
edit box (Figure 6.36).  Click Apply and then the OK button.  



CHAPTER 6 – Examples – 6-33 
 

User’s Manual (Rel. Aug/2022)  GeoMat v2022 

  

Figure 6.36 Nodal constraints dialog screen for Example 9  

 

 Next, go to Input Data –> Equivalent Concentrated Loads.  The user can specify two circular rings 
for hosting 48 anchors at each ring and enter the diameters of each ring.  The user also needs to specify 
the loads (Fx = 1108 kN, and My = 21373.4 kN) applied on the pile cap through the anchor bolts. Note that 
for this example the horizontal load was not applied since only actions out of plane were analyzed. 

 The program will calculate the location of each anchor bolt arranged in a circular pattern and the 
concentrated loads on each anchor bolt based on the anchor-bolt location and loading data as shown in 
Figure 6.37. 
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Figure 6.37 Equivalent concentrated loads screen for Example 9  

 Before executing the file, go to File –> Save As… and save the file as example9.slb.  Once this is 
completed, go to Computations –> Run Analysis to launch the analysis. 

 

6.10.3 Output Results Review 

 When the analysis is completed, go to Computations –> View Output File.  The maximum vertical 
displacement is approximately 0.113 mm under compression and 0.097 mm under tension as shown in 
Figure 6.38.  The contour of bending moment along the Y-axis is shown in Figure 6.39.  The contour of 
shear along the XY-planes is shown in Figure 6.40.  

 For viewing the section-cut plot, the user should click Section Cut item under Input Data menu 
and then select the cutting lines by default or by the user-specified.  To view the deflection along the 
cutting line, go to Results –> Section Cut Plot and select the desired cutting line and deflection as shown 
in Figure 6.41 for required display. 
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Figure 6.38  Contour of deflection of Example 9    

  

Figure 6.39  Contour of bending moment (My) of Example 9  
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Figure 6.40  Contour of shear on XY plane of Example 9  

 

 

Figure 6.41  Bending moment (Mz) along a cutting line of Example 9  
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6.11 Example 10: Square slab on soil - Vlasov method 

6.11.1 Problem Description  
This example considers a square concrete slab resting on the soil.  A concentrated force 𝑃𝑃 =

56 𝑘𝑘𝑘𝑘𝑘𝑘 is applied at the center of the slab (Figure 6.42).  The slab is 33 ft by 33 ft, and is 0.851ft thick. The 
Young’s modulus and the Poisson’s ratio of the slab and soil are listed in Table 6-1.  Assume the 
compressible thickness of the soil is 30 ft.  Bottom boundary of the soil is assumed to be fixed in x,y,z 
directions.  

 

Figure 6.42  Configuration of slab resting on soil of example 10  

Table 6-1: Parameters of slab and soil in example 10 

 Young’s modulus E(ksf)  Poisson’s ratio υ Thickness (ft) 
slab 432000 0.15 0.851 
soil 190 0.3 30 

 

 

6.11.2 Modeling Instruction 

To compute this problem using GeoMat, use the New from template option in the File menu.  In 
the Slab Type dialog box select “Circular or Rectangular Conventional” and click Next.  In the Template 
dialog box, choose “Rectangular – Equally Spaced” for the Shape and “Quadratic 8 Noded” for the Element 
Type.  Enter 33 for both “Length” and “Width”, and the “Number of Divisions” as 24.  Here a fine mesh is 
desired because coarse mesh can’t capture the peak forces near the concentrated load. Click OK to draw 
the slab on the screen. 

 Go to Input Data - Title and enter a name for the current project; this one is Example 10.  Click 
OK to save this as the project title.  Next, return to the Input Data menu and proceed to Material 
Properties.  Leave the default “Element Number/Set” value as ALL, select Isotropic under “Material 

30
 ft

soil

E  = 432000 ksfp

E  = 190 ksfs

p

s

x

y
z

= 0.3

P = 56 kip

slab

= 0.15



CHAPTER 6 – Examples – 6-38 
 

User’s Manual (Rel. Aug/2022)  GeoMat v2022 

Type” and click Define to open the Material Properties dialog box.  In the Material Properties dialog box 
modify the parameters to as Young’s modulus of 432000000 psf (432000 ksf), Poisson’s ratio of 0.15, 
and the thickness of 0.851 m.  Click OK to save the changes and close the dialog box. In the Material 
Data dialog box click OK to return to the main screen. To set the soil stiffness, go to Input Data –> Soil 
Stiffness.  Select the second option “Estimate Soil Stiffness using Vlasov Approach”.  Input soil properties 
as shown in Figure 6.43.  Keep the initial Gamma as 1.0.  This default value works well for most cases.  
Click OK to return to the main screen.  

 

Figure 6.43  Input soil properties in Vlasov approach  

Next, go to Input Data –> Nodal Loads.  The concentrated load is applied at the middle node (913).  Click 
Add Row to add one new row, input 913 as the node number.  Then check the option for Force X and 
input 56000 lbs (56 kip) as shown in Figure 6.44.  Display of node number can be controlled by menu 
Options –> Node Numbers. 
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Figure 6.44  Define concentrated load at slab center  

 

Before executing the file, go to File –> Save As… and save the file as example10.slb.  Once this is 
completed, go to Computations –> Run Analysis to launch the analysis. 

 

6.11.3 Output Results Review 
When the analysis is completed, go to Computations –> View Output File.  All deformation and 

internal forces are plotted into this file.  Since the number of nodes in this example is large, it is not 
convenient to look for the output for one specific node.  Go to Results –> Node Results, then input node 
number 913 which is loaded.  Check the deflection at this node is 0.01174 ft (Figure 6.45).  

 

Figure 6.45  View node output for one specific node  

Go to Results –> Section Cut Plot, select “My” as the field variables.  The distribution of moment “My” 
along the center line of the plate is plotted as shown in Figure 6.46.  Change field variable to “Qxy” to 
plot the shear force along the same cut line as in Figure 6.47.  Since a fine mesh is defined, the peak 
moment and shear force can be observed in these cut line plots. 
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Figure 6.46  Distribution of moment My along cut line 1 in example 10  

 

 

Figure 6.47  Distribution of shear force Qxy along cut line 1 in example 10  

In the Vlasov approach, parameters 𝛾𝛾, 𝑘𝑘 and 2𝑡𝑡 are iterated until convergence of displacements is 
reached.  The initial value of 𝛾𝛾 is set to 1 and the final 𝛾𝛾 increases to 1.81 as shown in Figure 6.48. 
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Figure 6.48  Output of γ, k and 2t in example 10  

 

The concentrated load of 56 k is applied at Node 913, which is approximately at the center of the 
slab.  The shear force at the cutting line clearly indicates the change of shear force from negative to 
positive before and after Node 913 with the concentrate load as shown in Figure 6.47.  The total change 
of shear force should yield the theoretical value of 56 k.  However, the accuracy of numerical solution will 
depend mostly on the element sizes used near the concentrated load as indicated in Figure 6.49.  When 
the element sizes are finer enough, the change of shear force gets closer to the theoretical value.  The 
result from finer meshes is also in agreement with those computed based a three-dimensional model 
using ABAQUS from Dassault Systems.  

 

Figure 6.49  Influence of mesh size to shear stress in example 10 
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6.12  Example 11: Circular wind turbine foundation – Vlasov method 

6.12.1 Problem Description  
This example considers a wind turbine foundation with circular shape (Figure 6.50). The 

parameters of soil are listed in Table 6-2. The depth of compressible soil is 30 ft.  Dimensions of the 
concrete foundation are also listed in Table 6-2. Applied loads include vertical thrust force 𝑃𝑃 =
696 𝑘𝑘𝑘𝑘𝑘𝑘, 𝑉𝑉 = 81.6 𝑘𝑘𝑘𝑘𝑘𝑘 , and 𝑀𝑀 = 25250 𝑘𝑘𝑘𝑘𝑘𝑘 ∙ 𝑓𝑓𝑓𝑓. The loads are applied in xy plane in GeoMat. Units used 
in this example are kip, ft. 

 

Figure 6.50  WTB foundation resting on soil of example 11  

Table 6-2: Parameters of slab and soil in example 11 

 Young’s 
modulus 
E(ksf) 

 Poisson’s 
ratio υ 

Thickness 
(ft) 

R1 
(ft) 

R2 
(ft) 

R3 
(ft) 

D1 
(ft) 

D2 
(ft) 

D3 
(ft) 

foundation 5.8e5 0.15  9 13.5 29 1 6.33 4 
soil 1320 0.2 30       

 

 

6.12.2 Modeling Instruction 
To compute this problem using GeoMat, use the New from template option in the File menu.  In the 
foundation type selection dialog, select “Circular wind turbine foundation.”  In the following template, 
input foundation dimensions and loads as shown in Figure 6.51. Keep the default division of 40.  Keep the 
default “Quadratic 8-noded” element type and “2x2” integration rule.  Click OK to generate the mesh. 
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Figure 6.51  Template for circular wind turbine foundation in example 11  

Now define material parameters for the concrete foundation.  Click menu Input Data –> Material 
Properties.  The foundation is divided into four sets based on different thicknesses.  Click the name under 
“Element Number/Set” will highlight selected element set in cyan color (Figure 6.52). 

Click button Define to change Young’s modulus E and Poisson’s ratio to 5.8e5 and 0.15 respectively for 
each element set.  Click OK to exit from the material property window. 

The next step is to define soil parameters.  Soil in the Vlasov approach is assumed to have one layer. Click 
menu Input Data->Soil Stiffness and select the second option “Estimate Soil Stiffness using Vlasov 
Approach.”  Change Young’s both modulus at top and bottom to be 1320 as shown in Figure 6.54. Change 
Poisson ratio to 0.2.  Click OK to exit. 

Click menu Input Data->Nodal Loads to check equivalent nodal loads calculated by GeoMat (Figure 6.55).  
Nodal loads are concentrated point forces in green color. Click OK to exit. 
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Figure 6.52  main window for material definition in example 11  

 

 

Figure 6.52  main window for material definition in example 11  
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Figure 6.53  Define Young’s modulus and Poisson ratio for each slab sets in  example 11  

 

 

Figure 6.54  Define soil property using Vlasov approach in example 11  

 

 

Figure 6.55  Check equivalent nodal loads in example 11  
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Click icon  on the toolbar to reset view to y-z plane.  Click menu Input Data->Nodal Constraints to 
define displacement boundary to remove rigid body motion.  Click Add Row to add one new line.  Click 

icon  to activate pick and select by mouse.  Pick the rightest node (node 682) and check “Displac. Y” 
and “Displac. Z.”  Keep displacement boundaries to be 0.  Similarly add other two rows to define fixed 
point at node 686 and 678.  Constrained nodes are displayed in Figure 6.56.  Click OK to exit.  

 

Figure 6.56  Apply nodal constraints to remove rigid body motion in example 111  

Before executing the file, go to File –> Save As… and save the file as example11.slb.  Once this is 
completed, go to Computations –> Run Analysis to launch the analysis. 

When analysis is done, open message file to review iterations of 𝛾𝛾, 𝑘𝑘 and 2𝑡𝑡.  Click menu Results-
>Section Cut Plot to plot deflection along the first cut line as shown in Figure 6.57.  The maximum is 
0.0106 ft (0.127in).  
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Figure 6.57  Deflection along cut line 1 in example 11  
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PROGRAM LICENSE AGREEMENT & DISCLAIMER 

IMPORTANT NOTICE:  The software you are about to install or previously have installed from Ensoft 
Incorporated (“ENSOFT”) is licensed only on the condition that you agree to the terms and conditions set forth 
below.  Please read the terms of this License Agreement & Disclaimer ("LICENSE") carefully. 
If you agree to be bound by the terms of this LICENSE, please check mark the box labeled “YES – I Accept the 
terms of this License Agreement!” during software installation so it can be installed on your computer. 
If you do not agree to the terms of this LICENSE, please check mark the box labeled “NO – I DO NOT Accept the 
terms of this License Agreement!” which will terminate the software installation. 
If the software is already installed and licensed, you have already agreed to the terms and conditions of this license, 
or someone has done so on your behalf. 
This LICENSE is a legal agreement between you (“USER”) – either an individual or a single entity– and ENSOFT 
for the ENSOFT software product that you are about to install or previously have installed (“PRODUCT”).  The 
PRODUCT collectively includes computer software and associated media, printed materials, hardware key (dongle), 
and electronic documentation.  The PRODUCT also includes any updates and supplements to the original 
PRODUCT that may have been produced by ENSOFT.  By installing, copying, downloading, accessing or otherwise 
using the PRODUCT, the USER agrees to be bound by the terms of this LICENSE.  If you (the USER) do not agree 
to the terms of this LICENSE, do not install or use the PRODUCT. 

SOFTWARE LICENSE & DISCLAIMER 

The PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual 
property laws and treaties.  The PRODUCT is licensed, not sold.  

1.  GRANT OF LICENSE 

This LICENSE grants you the following rights: 

1.1  INSTALLATION AND USE 

1.1.1  Single-User Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with ENSOFT and for 
one specific physical site (“SITE”) registered with ENSOFT.  You may install and use the PRODUCT on any 
number of computers at the licensed SITE.  However, the PRODUCT is fully operational only in the SITE computer 
that carries the appropriate PRODUCT’s hardware key (“KEY”) that is used as software protection device. 

1.1.2  Network Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with ENSOFT and for 
the specific physical site(s) (“SITE(S)”) and IP range registered with ENSOFT.  Each network seat that is purchased 
is provided with access for SITE(S) clients located within up to 2 subnets with unique third octets (“CLIENT 
SUBNETS”).  The minimum two-seat network license can be associated to a maximum of 4 CLIENT SUBNETS 
(within up to 4 unique third octets).  Purchase of additional network seats can extend the allowable range of 
CLIENT SUBNETS. 
The USER may install and use the PRODUCT on any computer in the licensed SITE(S) that is within the allowable 
CLIENT SUBNETS registered with ENSOFT.  Any one computer in the network can be designated as license 
server for the PRODUCT by carrying the appropriate PRODUCT’s hardware key (“KEY”) that is used as software 
protection device. 
This Network License strictly prohibits the PRODUCT to be used in or from computers located in office locations 
that are different than the licensed SITE(S) or outside the registered CLIENT SUBNETS.  Users in physical office 
locations other than the registered SITE(S) with ENSOFT are required to purchase additional licenses of the 
PRODUCT, even if the COMPANY is the same and/or if the additional offices are located in the same city. 
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2.  OTHER RIGHTS AND LIMITATIONS 

2.1  EDUCATIONAL VERSION 

If the PRODUCT was licensed with educational discounts, the use of the PRODUCT is strictly limited to academic 
or research activities of educators and/or students.  Any other usage voids all the rights under this LICENSE.  If in 
doubt, please contact ENSOFT to determine if you have a PRODUCT version that was licensed for educational 
purposes. 

2.2  LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY 

You may not reverse engineer, decompile, or disassemble the PRODUCT, except and only to the extent that such 
activity is expressly permitted by applicable law notwithstanding this limitation. 

2.3  RENTAL 

You may not rent, lease or lend the PRODUCT to third parties. 

2.4  TRADEMARKS 

This LICENSE does not grant you any rights in connection with any trademarks or service marks of ENSOFT. 

2.5  SUPPORT SERVICES 

ENSOFT shall provide you with limited support and maintenance services (“SUPPORT”) related to the PRODUCT 
during the initial year after purchase and for any additional SUPPORT term that the COMPANY elects to purchase 
for PRODUCT after the initial warranty period expires.   
Use of SUPPORT is limited to the ENSOFT policies and programs described in the PRODUCT’s User’s Manual, in 
documentation on the ENSOFT web site, and/or in other materials provided by ENSOFT. 
Any supplemental software code that may be provided to you as part of the SUPPORT or that is downloaded from 
the ENSOFT web site shall be considered part of the PRODUCT and subject to the terms and conditions of this 
LICENSE.  With respect to technical information you provide to ENSOFT as part of the SUPPORT, ENSOFT may 
use such information for its business purposes, including for product support, development or advertisements.  
However, ENSOFT will not utilize such technical information in a form that personally identifies the USER. 

2.6  SOFTWARE TRANSFER 

The initial user of the PRODUCT may make a permanent transfer of this LICENSE and PRODUCT and only 
directly to an end user.  This transfer must include all of the PRODUCT (including all component parts, the media 
and printed materials, any upgrades, this LICENSE, and the PRODUCT’s appropriate hardware KEY).  Such 
transfer may not be by way of consignment or any other indirect transfer.  The transferee of such one-time transfer 
must agree to comply with the terms of this LICENSE, including the obligation not to further transfer this LICENSE 
and PRODUCT. 

2.7  TERMINATION 

Without prejudice to any other rights, ENSOFT may terminate this LICENSE immediately if you fail to comply 
with the terms and conditions of this LICENSE.  In such event, you must destroy all copies of the PRODUCT and 
all of its component parts and provide evidence of such destruction in writing to ENSOFT within 3 business days. 

2.8  INDEMNIFICATION 

Within and during the terms of this LICENSE, ENSOFT warrants that the use of the initially provided PRODUCT 
does not infringe any patent, copyright, or trademark in the United States, and ENSOFT shall indemnify and hold 
USER harmless against any and all losses, damages and expenses, (including attorney’s fees) which USER may 
sustain or incur as a result of a breach of this warranty. 

2.9  CONFIDENTIAL INFORMATION 
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ENSOFT and the USER may have access to certain proprietary information and materials of the other that are 
confidential and of substantial value to the respective party, which value would be impaired if such information 
were disclosed to third parties ("CONFIDENTIAL INFORMATION").  ENSOFT and the USER agree that neither 
shall disclose any CONFIDENTIAL INFORMATION to any third party and shall take every reasonable precaution 
to protect CONFIDENTIAL INFORMATION. 
The provisions of this section shall not apply to any information which (i) is or becomes available to the public other 
than by breach of the LICENSE agreement by the receiving party, (ii) is rightfully received by receiving party from 
a third party without confidential limitations, (iii) is independently developed by receiving party's employees 
without access to CONFIDENTIAL INFORMATION, or (iv) is known to the receiving party without any restriction 
on its use or disclosure prior to first receipt of it from the disclosing party. 

3.  COPYRIGHT 

All title and intellectual property rights in and to the PRODUCT (including but not limited to any images, 
photographs, animations, video, audio, music, and text that may be incorporated into the PRODUCT), the 
accompanying printed materials, and any copies of the PRODUCT are owned by ENSOFT.  All title and intellectual 
property rights in and to the content which may be accessed through use of the PRODUCT is the property of the 
respective content owner and may be protected by applicable copyright or other intellectual property laws and 
treaties.  This LICENSE grants you no rights to use such content.  All rights not expressly granted are reserved by 
ENSOFT.  This PRODUCT is protected by the United States Copyright Law and International Copyright Treaty. 

4.  SOFTWARE DISCLAIMER  

Although the PRODUCT has been used with apparent success in many analyses, new information is developed 
continuously and new or updated PRODUCT releases may be written from time to time.  All users are requested to 
inform ENSOFT immediately if any errors are found in the PRODUCT.  As modifications, updates, or new versions 
are produced, the latest codes are posted on ENSOFT’s web site and made available to all visitors for free 
downloading. 
No warranty, expressed or implied, is offered as to the accuracy of results from ENSOFT’s PRODUCT.  The 
PRODUCT should not be used for design unless caution is exercised in interpreting the results and independent 
calculations are available to verify the general correctness of the results.  Users are assumed to be knowledgeable of 
the information in the printed documentation that is distributed with the digital media.  Users are assumed to 
recognize that the input parameters, eg., soil properties, increment length, tolerance on solution convergence, and 
many others, can have a significant effect on the solution and must be chosen carefully. Users should have a 
thorough understanding of the relevant theoretical criteria (appropriate references are suggested in the software 
documentation).  

5.  GOVERNING LAW 

This LICENSE is governed by the laws of the State of Texas and laws and treaties of the United States of America. 

6.  CONTACT INFORMATION 

Should you have any questions concerning this LICENSE or if you desire to contact ENSOFT for any reason, please 
use the following: 
Ensoft Incorporated 
3003 West Howard Lane 
Austin, Texas 78728 
United States of America 

NO OTHER WARRANTIES 
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TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, ENSOFT DISCLAIMS ALL OTHER 
WARRANTIES AND CONDITIONS, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED 
TO, IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 
PURPOSE, AND TITLE, WITH REGARD TO THE PRODUCT, AND THE PROVISION OF SUPPORT 
SERVICES.  THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS.  YOU MAY HAVE 
OTHERS, WHICH VARY FROM STATE/JURISDICTION TO STATE/JURISDICTION. 

LIMITATION OF LIABILITY 

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL ENSOFT BE 
LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES 
WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, 
BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) 
ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT OR THE FAILURE 
TO PROVIDE SUPPORT, EVEN IF ENSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.  IN ANY CASE, ENSOFT’S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS LICENSE 
AGREEMENT SHALL BE LIMITED TO THE GREATER OF THE AMOUNT ACTUALLY PAID BY YOU 
FOR THE PRODUCT OR U.S.$1.00. 
 

 

 
 


	Table of Contents
	List of Tables
	CHAPTER 1. Introduction
	1.1 General Description
	1.2 Method of Analyses
	1.3  Program Features and Change Log
	1.3.1 GeoMat 1.0 (2004)
	1.3.2 GeoMat 2.0 (2014)
	1.3.3 GeoMat 3.0 (2022)

	1.4 Technical Support
	1.4.1 Preferred Methods of Software Support
	1.4.2 Upgrade Verification and Internet Site
	1.4.3 Renewal of Program Maintenance
	1.4.4 Changes of Support Policy


	CHAPTER 2. Installation and Getting Started
	2.1 Installation Procedures
	2.1.1 Installation of Single-User Version
	2.1.2 Introduction of Network Version
	2.1.2.1 Installation of Network Version
	2.1.2.2 Silent Installations on Client Computers

	2.1.3 Backup of Original Software
	2.1.4 Software Updates on the Internet

	2.2 Getting Started
	2.2.1 Starting the program
	2.2.2 File Management
	2.2.3 View Management of Program Window
	2.2.4 Data Input for Program Operation
	2.2.5 Computation Options
	2.2.6 Manipulating the Slab Model
	2.2.7 Results
	2.2.8 Option Menu
	2.2.9 Selection Menu
	2.2.10 Window Menu
	2.2.11 Help Menu


	CHAPTER 3. Data Input
	3.1 File Menu
	3.1.1 File – New
	3.1.2 File – New from template
	3.1.3 File – Open
	3.1.4 File – Save
	3.1.5 File – Save As
	3.1.6 File – Exit

	3.2 Input Data Menu
	3.2.1 Numeric Data Entries and Sign Conventions
	3.2.2 Input Data -Title
	3.2.3 Input Data – Material Properties
	3.2.4 Input Data – Node Coordinates
	3.2.5 Input Data – Time Stepping
	3.2.6 Input Data – Soil Stiffness
	3.2.7 Input Data – Element Type
	3.2.8 Input Data – Element Connectivity
	3.2.9 Input Data – Integration Points
	3.2.10 Input Data – Nodal Constrains
	3.2.11 Input Data – Nodal Loads
	3.2.12 Input Data – Nodal Stiffness
	3.2.13 Input Data – Distributed Loads
	3.2.14 Input Data – Distributed Stiffness
	3.2.15 Input Data – Concentrated Loads
	3.2.16 Input Data – Equivalent Concentrated Loads
	3.2.17 Input Data – Concentrated Stiffness
	3.2.18 Input Data – Edge Load
	3.2.19 Input Data – Edge Stiffnesses
	3.2.20 Input Data – Node Sets
	3.2.21 Input Data - Element Set
	3.2.22 Input Data – Edge Sets
	3.2.23 Input Data – Section Cut


	CHAPTER 4. Finite Element Mesh Adjustment
	4.1 Introduction
	4.2 Mesh Refinement
	4.3 Change of Element Type
	4.4 Change of Integration Rule

	CHAPTER 5. Program Execution and Output Reviews
	5.1 Introduction
	5.2 Computation Menu
	5.2.1 Computation- Run Analysis
	5.2.2 Computation- View Input File
	5.2.3 Computation- View Output File
	5.2.4 Computation- View Message File

	5.3 Results Menu
	5.3.1 Results – Select Step
	5.3.2 Results – Deformed Mesh
	5.3.3 Results – Contour Plot
	5.3.4 Results – Section Cut Plot
	5.3.5 Results – Nodal Result

	5.4 Speed Buttons in Graphics Mode

	CHAPTER 6. Examples
	6.1 Introduction
	6.2 Example 1: Cantilevered square plate simulated by single quadratic element
	6.2.1 Problem Description
	6.2.2 Modeling Instruction
	6.2.3 Output Results Review

	6.3 Example 2: Fixed square plate subject to concentrated force at center
	6.3.1 Problem Description
	6.3.2 Modeling Instruction
	6.3.3 Output Results Review

	6.4 Example 3: Square slab on soil - distributed stiffness method
	6.4.1 Problem Description
	6.4.2 Modeling Instruction
	6.4.3 Output Results Review

	6.5 Example 4: Square slab on soil - Mindlin method
	6.5.1 Problem Description
	6.5.2 Modeling Instruction
	6.5.3 Output Results Review

	6.6 Example 5: Slab on soil to support four columns (no rotation restraint)
	6.6.1 Problem Description
	6.6.2 Modeling Instruction
	6.6.3 Output Results Review

	6.7 Example 6: Slab on soil to support four concentrated forces (restrained nodal rotation)
	6.7.1 Problem Description

	6.8 Example 7: Rectangular slab on soil subject to column loads
	6.8.1 Problem Description
	6.8.2 Modeling Instruction
	6.8.3 Output Results Review

	6.9 Example 8: Rectangular raft on soil to support columns and walls
	6.9.1 Problem Description
	6.9.2 Modeling Instruction
	6.9.3 Output Results Review

	6.10 Example 9: Wind turbine foundation supported by drilled shafts
	6.10.1 Problem Description
	6.10.2 Modeling Instruction
	6.10.3 Output Results Review

	6.11 Example 10: Square slab on soil - Vlasov method
	6.11.1 Problem Description
	6.11.2 Modeling Instruction
	6.11.3 Output Results Review

	6.12  Example 11: Circular wind turbine foundation – Vlasov method
	6.12.1 Problem Description
	6.12.2 Modeling Instruction


	CHAPTER 7. References
	License Agreement & Disclaimer

