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1.1 General Description 
EnFEM is a general-purpose finite element analysis software for simulating 2D mechanical 
behaviors of solid materials subjected to various loads. EnFEM is able to perform plane-strain, 
plane-stress, and axi-symmetric analyses with an emphasis on solving problems in geotechnical 
engineering. EnFEM is equipped with a variety of linear and non-linear material models, boundary 
conditions, and element types, to provide users a full array of analysis options necessary for 
solving both simple and complex geotechnical analyses. 

1.2 Features of the Program 
Program EnFEM has the following features that are designed to enhance the ability of the 
engineer to obtain usable results. 

 CAD-like interface for geometry creation/modification, assignment of analysis 
parameters, and post-processing. 

 Abundant material library with the following material models included; linear 
elasticity, Tresca plasticity, Von Mises plasticity, Mohr-Coulomb plasticity, 
Druker-Prager plasticity, Duncan-Chang hyperbolic elasticity, and Modified Cam-
Clay.  

 Multi-stage analysis for simulating sequentially applied loads, as well as 
geostatic (initial) soil stresses, and excavations.  

 Soil-structure interaction with computational contact analysis, capable of 
simulating material separations and sliding. 

 Powerful mesh generator to generate first or second-order, quadrilateral or 
triangular finite elements, in either structured, unstructured, or combined 
meshes. 

 Nonlinear direct solver based on parallel processing optimization.  
 OpenGL based graphics technology to plot contours accurately and quickly. 
 Multiple output options including; contour plots, vector plots, XY-plots, and 

cutline plots, for a wide array of categories and variables - including integrations 
(moments) and interactions, along a user-defined node path. 

 Completed examples files and accompanying manual to help users quickly learn 
the program, through common geotechnical engineering problems. 

1.3 Documentation 
The documentation provided with the computer program EnFEM consists of three volumes.  The 
User’s Manual contains full documentation about the operation of the program on personal 
computers.  The User’s Manual covers the areas of installation, general usage, as well as 
capabilities and various features.  The distribution of the User’s Manual is made via standard 
Adobe© PDF file format. 

The Technical Manual provides information about the theory and constitutive models 
incorporated in EnFEM, along with other technical aspects.  The Technical Manual includes 
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other helpful references related to concepts utilized in program EnFEM.  ENSOFT holds a 
copyright of the Technical Manual so it is distributed in protected form that can only be opened 
by licensed users of the EnFEM program. 

The Example Manual provides step by step guidance through a number of example problems 
common to geotechnical engineering.  Examples detailed in the Example Manual are included 
with the program installation for reference. The distribution of the Example Manual is made via 
standard Adobe© PDF file format. 

Manuals are installed with the EnFEM program and accessible via any one of the following three 
methods: i) from the Windows Start Menu, ii) from the Ensoft tile in Windows 8 and 10, or iii) 
from the “Help” menu within the EnFEM program. 

1.4 Contents of the EnFEM Package 
The standard package sent with EnFEM consists of the following items: 

 One USB Key (sometimes known as hardware key or dongle), 
 One USB Memory Stick with installation programs for all Ensoft software 

products (this may be missing in future releases, since the full program is 
available for downloading from the www.ensoftinc.com website). 

The user-selected installation directory (default directory is Program Files 
(x86)\Ensoft\EnFEM2019) contains the main Windows-program module (EnFEM2019.exe), the 
program engine for direct computations (EnFEM2019_DLL.dll), and other support files.  The 
User’s, Technical, and Example Manuals are also included in the installation directory.  Several 
modeling examples with input files (files with name/extension of the type filename.sep) are 
installed on a separate (Root Drive)\Ensoft\EnFEM2019-Examples subdirectory in the root 
Windows drive (usually c:\).  The installation directory for Example files can be changed by the 
user if desired. 

1.5 Hardware Requirements  
To use EnFEM, the user needs the following minimum hardware configuration:  

 Any personal computer with multi-core processor.  
 A hard disk with at least 5 GB of free space (large meshes may require more).  
 Microsoft Windows 7, Windows 8, Windows 8.1, or Windows 10 in either 32-bit 

or 64-bit releases. 
 Minimum of 4 GB of free RAM memory (8 GB recommended). 
 Open (available) USB port (v2 or newer). 
 Graphics card compatible to the Microsoft Windows™ operating system that is 

being used and also compatible with OpenGL. 
 A mouse or similar pointing device.  
 Optional: Any windows-compatible printer.  

http://www.ensoftinc.com/
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1.6 Technical Support 
Although computer program EnFEM was designed to be distinguished by its ease of use and by 
its helpful User’s and Example Manuals, some users may still have questions.  The technical staff 
at ENSOFT strongly supports all registered users with questions related to the installation or use 
of EnFEM, according to the stipulations presented below.  The software is provided with free 
maintenance service for the first year.  After the first year the user is encouraged to purchase 
the yearly maintenance services.  The yearly maintenance services include free download of the 
latest version and free technical support as described below. 

1.6.1 Preferred Methods of Software Support  

Software support is given, in order of preference, by the following methods:  

 Electronic mail to: support@ensoftinc.com 
 Fax to: (512) 244-6067 
 Telephone call to: (512) 244-6464, extension 2 

Users are strongly encouraged to utilize electronic means of support via email.  In all technical 
support requests via email, please include the following information: 

 Full software version/release/update (obtained from the “Help->About” dialog), 
 Description of the user’s problem or concern, 
 Attach a copy of the input-data file that is associated with the issue/concern 

(files with name/extension of the type filename.sep), and  
 Name and telephone number of the contact person and of the licensed user (or 

name and office location of the licensed company site and/or serial number of 
the USB Key). 

Although immediate answers are offered on most technical support requests, please allow up to 
two business days for a resolution in case of difficulties or schedule conflicts. 

Technical help by means of direct calls to our local telephone number, (512) 244-6464, is 
available, but is limited to the business hours of 9 a.m. to 5 p.m. (US central time zone, UTC 
−6:00). The current policy of Ensoft is that all telephone calls for software support will be 
answered free of charge if the user has a valid maintenance contract. 

1.6.2 Upgrade Verification and Internet Site  

EnFEM v2019 provides options for the user to check the most recent maintenance release 
through an internet connection by selecting “Help->Check for Updates” from within the 
software.  This command starts the default internet browser and will display the user’s 
maintenance expiration date, the user’s software release number and the most recent release 
number that is available for downloading. 

mailto:support@ensoftinc.com
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If the user’s version is not the latest version and the maintenance has not been expired, the user 
can download the latest version from our web server directly (www.ensoftinc.com).  Users may 
also consult our internet site for additional information on software updates, demos, and new 
applications; technical news; and company information.  

1.6.3 Renewal of Program Maintenance 

The cost to renew program maintenance will depend on the length of time for which the 
program maintenance has been expired.  There are small price increases with time after 
expiration.  The pricing policy for renewing a program maintenance that has not expired can be 
found on the Ensoft website at http://www.ensoftinc.com  

1.6.4 Changes of Support Policy  

The software support policy and associated expenses are subject to change at ENSOFT’s 
discretion and without specific mailed notices to the users. However, any change of rules will be 
verbally provided during telephone calls for software support. 

 

http://www.ensoftinc.com/
http://www.ensoftinc.com/
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2.1 Installation Procedures 
Program EnFEM is distributed with an associated USB Key (hardware key or dongle).  The USB Key 
consists of a device that is attached to a working USB port (or USB hub) of the computer in use 
(or in the designated software server in the case of local network licenses).  This method of 
software protection has been found to provide compatibility with existing operating systems, 
better stability than other alternatives, and allows users to obtain software updates or 
replacements via downloads from the internet. 

Users with standard single-user licenses can check the following link to a PDF with Installation 
notes: https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf 

Users with local network licenses can check the following link to a PDF with Network Installation 
Notes: https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf 

2.1.1 Installation of Single-User Version 

This version of EnFEM has been tested to be compatible with the following versions of the 
Microsoft Windows® operating systems:  Windows 7, 8, 8.1, and 10 in 32 and 64-bit releases. 

The following guidelines are recommended during the installation process of EnFEM for single-
user licenses. 

 Plug the supplied USB Key into one of the available USB ports in your computer.  
The USB Key is plug-and-play compatible so the operating system will recognize 
the USB Key automatically and a small but solid green light should appear at the 
end of the USB Key (a flickering green light or no light indicate problems with the 
standard windows driver or with the USB Key). 

 If the user installs from a distribution USB Memory Stick and the main installation 
program does not start automatically upon insertion of the Memory Stick then 
click on the “Windows Start Menu” button and select “Run”.  On the command 
line, type d:\setup.exe or e:\setup.exe, where d: or e: represents the drive that 
contains the distribution Memory Stick.  Click “OK” to execute the command and 
start the main installation program for ENSOFT’s software.  A screen similar to 
the one in Figure 2-1 should appear. 

 If the user installs from a downloaded file then please run the downloaded file 
(double click) and go to instruction #5. 

 Click anywhere on the “EnFEM 2019” icon and then click on the “Install 
Standard” button to start the installation of EnFEM.  

 The user should read the license agreement shown in Figure 2-2.  Users can 
review the License Agreement online in the following link: 

https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf 
The installer will place the same file (Ensoft License and Disclaimer.pdf) in the 
installation directory.  Please click “Yes” if you agree and would like to proceed. 

https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf
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 Select “Single-User License” in Figure 2-3 then click “Next”.  For network 
installations please contact Ensoft support (support@ensoftinc.com). 

 The user will be provided with an option to select a drive and directory for the 
installation of EnFEM (see Figure 2-4); the default is c:\Program Files 
(x86)\Ensoft\EnFEM2019.  If the desired directory does not exist, the installation 
program will automatically create a new directory in the chosen hard drive.  Most 
distribution files will be copied to the installation directory (either the default or 
the one selected by the user).  Example files are copied to the following 
subdirectory under the root Windows drive (unless selected differently by the 
user during installation): 

(Root Drive)\Ensoft\EnFEM2019-Examples 
 During the installation the user will be asked to set the file extension association 

for opening EnFEM 2019 input data files (see Figure 2-5).  If the user agrees 
(leaves the default check mark) then double clicking (or running) any input data 
file with extensions of the type filename.sep will start the installed EnFEM 2019 
software. 

 The user will be prompted to confirm the shortcut directory name that will be 
created in the “Windows Start Menu” (See Figure 2-6).  The default is Start 
Menu/Programs/Ensoft/EnFEM2019.  Windows 8 and 10 will automatically 
create an Ensoft tile with the same shortcuts. 

mailto:support@ensoftinc.com
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Figure 2-1: Main installation screen for ENSOFT software (may change with time) 

After the installation is finished, it is not necessary to reboot Windows for the program to run.  
The user may run the program by selecting “EnFEM v2019” from the standard links installed in 
the Microsoft Windows® Start Menu:  "Start Menu->All Programs->Ensoft->EnFEM2019” 

 
 



CHAPTER 2 – Installation & Getting Started – 2-5 
 

User’s Manual (Rel. May/2019)  EnFEM for Windows 

 
Figure 2-2: Installation screen with License Agreement (may change with time)  

 
Figure 2-3: Selection of Single-User License (may change with time)  
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Figure 2-4: Default Installation Directory for Program Files (may change with time)  

 
Figure 2-5: File Extension Association for EnFEM 2019 Data Files (may change with time)  
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Figure 2-6: Default Shortcut Folder in Windows Start Menu (may change with time)  

2.1.2 Introduction of Network Version 

Special network licenses and USB hardware keys (network keys) are available for users who desire 
to operate EnFEM on a Windows network.  The network version is limited to users with two or 
more licenses at the same physical site.  Discounted rates apply for users purchasing multiple 
licenses for the same site. 

Network versions of EnFEM have special subroutines written for installations in “software 
servers” and for installations of “individual clients”.  The “software server” or “license server” is 
the computer that will be carrying the Net USB Key provided by ENSOFT, INC.  The software server 
is not necessarily the same as the existing network server.  Any computer in the existing Windows 
network may be designated software server for EnFEM as long as the network key is attached to 
an available USB port (or through an USB hub) and the “server” version of the software is installed 
on its local drive.  Software “clients” may be all computers of the licensed site that have the 
program installed as client.  Software clients do not need any hardware key attached to their local 
ports.  The program installed in software clients will be allowed to run if their IP are within the 
allowable (licensed) IP ranges and if the computer designated as software server is accessible on 
the network with the proper operating system and with its network key secured in place. 

Users of the network version of EnFEM are allowed to have the software installed in as many 
computers as desired within the licensed IP ranges of their local Windows network.  However, 
only a number of users equal to the total number of purchased licenses will be able to operate 
the program at the same time. 
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2.1.2.1 Installation of Network Version 
Installers of network licenses should refer to a separate booklet with installation instructions for 
the Network version of this product.  The document can be downloaded from the Ensoft web site: 

https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf 

Alternatively, the document can be requested via email to support@ensoftinc.com 

2.1.2.2 Silent Installations on Client Computers 
For installation of network licenses on local client computers there is an option for command-
based installations that are completely silent (performed without other user input).  Instructions 
for silent installations on client computers can be downloaded from the Ensoft web site using the 
following link: 

https://www.ensoftinc.com/doc/Silent%20Install%20on%20Client%20Computers.pdf 

Alternatively, the document can be requested via email to support@ensoftinc.com 

2.1.3 Backup of Original Software 

The distributed software may be copied for backup purposes.  The program may be installed in 
several computers at the same time.  However, unless network licenses are purchased, the 
program will only operate in the computer that carries the appropriate USB Key. 

2.1.4 Software Updates on the Internet 

Occasionally, ENSOFT will produce software improvements and/or fixes and place the latest 
software programs on ENSOFT’s internet site.  Users can check for available updates by selecting 
“Help->Check for Updates” from the EnFEM menu.  Software users may freely download the 
latest program update from the “PRODUCTS->Downloads” link in the following site:  
http://www.ensoftinc.com 

2.1.5 Demonstration Mode 

If the USB hardware lock is not plugged into the computer when the program is opened, then 
EnFEM will operate in “Demonstration Mode”.  This mode is generally used for prospective users 
to perform simple testing in order to evaluate the program, as well as view the included 
example files (containing both input and output data).  Demonstration mode has several 
limitations as noted below: 

 Model files cannot be saved. 
 Existing model files can be opened in demonstration mode, but the file is “read-

only”.  Input data, mesh details, and results are visible, but changes cannot be 
saved. 

 Analysis is limited to 500-nodes. 
 Only the User and Example Manuals are accessible.   

https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf
mailto:support@ensoftinc.com
https://www.ensoftinc.com/doc/Silent%20Install%20on%20Client%20Computers.pdf
mailto:support@ensoftinc.com
http://www.ensoftinc.com/
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2.2 Getting Started 

2.2.1 User Interface 

The overall user interface of EnFEM is shown in Figure 2-7, and is described in the following 
sections. 

 

Figure 2-7: User interface of EnFEM 

The user interface includes a “Menu Bar” with drop-down menus, as well as “Toolbar” with a 
number of shortcut icons.  The command associated with each shortcut icon can also be found 
within the appropriate drop-down menu. Below the toolbar, is the “Working Zone”, in which users 
will create geometric entities, make selections, view the mesh, as well as plot various results.  
Below the working zone, is the “Information Panel”, that contains various interactive information 
and prompts.  When a command is being executed, the user will view and enter information in 
the various areas of this information panel. This panel contains: 

 Command information – shown when mouse is held over a shortcut icon. 
 Command prompt – message display for execution of command operation 
 Coordinate input box – for user input during specific commands 
 Cursor coordinates – coordinate display changes with cursor movement 
 Selection information - displays the number of selected geometry entities or FE 

elements 

In general, commands in EnFEM are executed in the following fashion: 
 Select command operation (either from drop down menu or shortcut icon). 
 Follow command prompt to make the appropriate selections, or input the desired 

numerical data in the coordinate input box. 
 RIGHT-CLICK on the mouse, to follow additional prompts for finishing the 

command operation. 
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2.2.2 Working Modes in EnFEM 

EnFEM has three fundamental modes: “CAD-mode”, “Mesh-mode”, and “Result-mode”. Working 
in “CAD-mode” users will create/modify geometric entities, define analysis input parameters 
(stages, boundary conditions, material properties, interactions, solver settings, etc.), define mesh 
parameters, and generate the mesh. “Mesh-mode” lets users check, evaluate, or interact with the 
generated finite element mesh.  After the analysis is completed, “Result-mode” is used to perform 
post-processing operations, and visualization of various results. In EnFEM, each mode will have 
its own menu bar and toolbar icons. 

2.2.3 Menu Bar Items 

Primary menu items used in EnFEM are displayed in Figure 2-8. Note, that these options may 
change slightly, based on which working mode is active. 

 

Figure 2-8: Menu bar system in EnFEM 
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2.2.4 Toolbar Shortcut Icons 

2.2.4.1 “CAD-mode” Toolbar Icons 
Figure 2-9 shows the “CAD-mode” toolbar icons. 

 

Figure 2-9: “CAD-mode” toolbar 

2.2.4.2 “Mesh-mode” Toolbar Icons 
Figure 2-10 shows the “Mesh-mode” toolbar icons.  Note that these icons are different than those 
seen in “CAD-mode”, and that some icons are disabled. 

 

Figure 2-10: “Mesh-mode” toolbar 

2.2.4.3 “Result-mode” Toolbar Icons 
Figure 2-11 shows the “Result-mode” toolbar icons.  Note that these icons are different than those 
seen in “CAD-mode” and “Mesh-mode”, and that some icons are disabled. 

 

Figure 2-11: “Result-mode” toolbar 
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2.2.5 Icons 

All icons used in EnFEM are listed as follows, along with their action.  Note the differences 
between “inactive”, and “active” icons. 

 Create a vertex  Create a vertex (operation active) 

 Create a straight line  
Create a straight line (operation 
active) 

 Create an arc  Create an arc (operation active) 

 Create a rectangle  Create a rectangle (operation active) 

 Create a polygon  Create a polygon (operation active) 

 Switch to “CAD-mode”  “CAD-mode” activated 

 “Show” vertices   

 “Show” region edges   

 “Show” shading of regions   

 Select vertices  Select vertices (selection active)  

 Select lines/arcs   Select lines/arcs (selection active) 

 Select regions   Select regions (selection active) 

 Delete   

 Switch to “Mesh-mode”  “Mesh-mode” activated 

 “Show” FE nodes   

 “Show” FE edges   

 “Show” shading of FE elements   

 Select FE nodes  Select FE nodes (selection active) 

 Select FE edges  Select FE edges (selection active) 

 Select FE elements  Select FE elements (selection active) 

 Delete mesh   

 Switch to “Result-mode”  “Result-mode” activated 

 Contour plots    

 Vector plots   

 X-Y plots   
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 X-Y cutline-plot   

 Pan-view 
 

Pan-view (operation active) 

 Zoom in/out 
 

Zoom in/out (operation active) 

 Zoom-window 
 

Zoom-window (operation active) 

 Zoom to extents   

 Reset view   

 Display control   

 “Show all” 2D objects   

 Snap to vertex 
 

Snap to vertex (selection active) 

 Snap to midpoint 
 

Snap to midpoint (selection active) 

 
Snap to center  
(circle/polygon/rectangle)  

Snap to center (selection active) 

 Snap to grid 
 

Snap to grid (selection active) 

 New project   

 Open existing project   

 Save project   
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2.2.6 File System 

A number of different files are generated when an analysis is created and performed in EnFEM.  
These files are listed below, by their file extensions, and accompanied by a brief description: 

 *.sep:  model file including geometry definitions, materials, boundary conditions, 
mesh and analysis controls, as well as other data. 

 *.fem:  neutral mesh file. 
 *.gsp:  results at Gaussian integration points in binary format. 
 *.log:  log file to record information during an analysis. 
 *.dat:  input file to nonlinear solver. 
 *.out:  results output file in ASCII format. 
 *.inr:  history of load increments. 
 *.ctb:  output of contact analysis in binary format. 

2.2.7 General Workflow for FE-Analysis in EnFEM 

In general, the following list outlines the workflow for creating and performing a FE-analysis using 
EnFEM: 

 In “CAD-Mode”… 
a. Set up working zone preferences (drawing space extents, grid size, 

background color, etc.) 
b. Create/modify geometric entities 
c. Define set-groups (selection sets for assignments or display) 
d. Define control data 
e. Define stage data 
f. Define and assign material properties 
g. Define and assign boundary conditions  
h. Define and assign interaction properties (if necessary) 
i. Define mesh controls 

i. General controls (element shape, element type, mesh type) 
ii. Assign global seed control 

iii. Assign local seed control (if necessary) 
j. Generate mesh 
k. Setup solver controls (optional) 
l. Submit analysis to the solver 

 In “Result-mode”… 
a. Use post-processing tools to visualize desired output (contours, X-Y Plots, 

etc.) 
 If necessary, modify model and repeat analysis as needed. 
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3.1 Global Coordinate System 
EnFEM uses a Cartesian coordinate system. The horizontal direction is parallel to the X-axis and 
the vertical direction is parallel to the Z-axis as shown in Figure 3-1. The positive Y-direction points 
‘into’ the screen.  

 

Figure 3-1: Global coordinate system in EnFEM 

If the analysis type selected is “axi-symmetric”, then an orange, dashed vertical line will also be 
displayed on screen at the symmetric axis, as shown in Figure 3-2. 

 

Figure 3-2: Axi-symmetric axis display 

Selecting "View->Global Axes", from the menu bar, will turn on/turn off the display of both the 
global axis, and the axi-symmetric axis (if this analysis type is selected). 

3.2 Creating Geometric Entities 
Since EnFEM is a 2D finite element analysis software, geometric entities in EnFEM are limited to 
two-dimensional objects (region), one-dimensional objects (line/arc), and zero-dimensional 
objects (vertex). Simple 2D objects including rectangles and straight-edge polygons can be created 
directly. Polygons containing curved edges can be created indirectly by converting from a series 
of independent closed lines/arcs.  

When creating geometry, it is important to understand that EnFEM contains independent or 
dependent geometric entities – vertices/lines/arcs. What defines these entities as independent 
or dependent is their associativity to a geometric region. Commands "create a vertex", "create a 
line", and "create an arc" create independent entities, with no direct associativity to a region. In 
general, the purpose of creating independent lines/arcs is to build a general polygon indirectly, or 
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to create an auxiliary line for editing/modifying operations. Independent lines/arcs are always 
displayed in blue so that they are easily identified.  Commands "create a rectangle" and "create a 
polygon" directly create regions which contain dependent entities. A general polygon converted 
from series of lines and arcs is also considered to contain dependent entities. Vertices, lines, and 
arcs of a region are dependent when they are part (“children”) of a region entity (“parent”). 
Dependent lines, and arcs will be shown as grey in color. Boundary conditions and mesh controls 
can only be applied to dependent entities in EnFEM. 

In general, it is good practice for the user to think about in advance; what type of boundary 
conditions are present and where/how they will be applied, any specific mesh refinement 
requirements, and what type of results are necessary, as these may all affect how the geometry 
is created. For example, perhaps an extra vertex is necessary along a region edge in order to apply 
point displacements at a specific location, or modelling the centerline of region is necessary to 
easily define results at that location. Material properties and boundary conditions are assigned to 
regions or region edges/vertices, respectively. Finite element meshes are generated on region 
objects only.  

Therefore, a valid model should contain only 2D regions and should have no independent vertices, 
lines, and/or arcs.  

3.2.1 Vertex  

Vertices are fundamental entities with zero dimensions. They are the endpoints of a line/arc, or 
the corner of a region. In EnFEM, creation of 1D and 2D objects always creates vertices 
automatically. Therefore, an independent vertex is seldom used. Sometimes, they can be used as 
geometry reference points to build a complicated polygon, but in this case, should be deleted 
before mesh generation. If an independent vertex occupies the same position as a dependent 
vertex of a region, errors may occur when applying boundary conditions, as they may be 
inadvertently applied to the independent vertex. 

In EnFEM, vertices are distinguished from finite element nodes.  

There are two methods to create a vertex in EnFEM: 

3.2.1.1 Creation with Mouse  

With EnFEM open, click  to switch to “CAD-mode” if necessary. Click the  icon on the 
toolbar to activate the vertex creation tool. In the information panel, the command prompt “Input 
new vertex” will be displayed. Move the mouse cursor to a desired location in the working zone 
and LEFT-CLICK. An independent vertex will be created and displayed in yellow color. 

To create a vertex with the mouse, in a more precise fashion, a “snap” technique can be used.  In 
this case the user can press and hold the CTRL key, in order to “snap” to a specific point (controlled 
by toolbar icons), and then LEFT-CLICK to create the vertex. More on this “snap” technique is 
discussed in Section 3.2.7 of this manual, as well as in the Example Manual. 
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NOTE:  Caution should be used when using the “snap” technique to create vertices, as not to 
create redundant vertices as mentioned in Section 3.2.1.  In general, it is not recommended to 
create independent vertices unless necessary, and care is used to remove them before analysis. 

3.2.1.2 Creation with Coordinate Input Box 
Alternately a vertex can be created by defining its coordinates directly. With EnFEM open, click 

 to switch to “CAD-mode” if necessary. Click the  icon on the toolbar to activate the vertex 
creation tool, and note that the command prompt displays the message “Input new vertex”. Click 
the coordinate input box under the working zone and key in X and Z-coordinates as shown in 
Figure 3-3. Note, that there is a “comma” used to separate the X and Z-coordinates. Press ENTER 
to create this vertex at the specified position.  

 

Figure 3-3: Using coordinate input box to create a vertex 

3.2.2 Line 

Lines are one-dimensional geometric entities with two end vertices, and are always straight in 
EnFEM. Independent lines are displayed in a blue color. Dependent lines are displayed in a grey 
color, slightly lighter than that of their parent region entities. 

Two methods are available in EnFEM to create a line: 

3.2.2.1 Creation with Mouse 

With EnFEM open, click  to switch to “CAD-mode” if necessary. Click the  icon on the 
toolbar to activate the line-creation tool. In the information panel, the command prompt “Input 
start vertex of line” will be displayed.  Move the mouse cursor to the desired location in the 
working zone and LEFT-CLICK to create the line-start vertex. A dashed line in cyan color (for the 
default black background of the working zone), or in red color (if working zone has white 
background) is displayed and follows the mouse as a preview of the line creation. Notice in the 
information panel, the command prompt “Input end vertex of line” is now displayed. Move the 
mouse cursor to the desired location of the line endpoint and LEFT-CLICK. A newly created line 
will be displayed on screen in blue color. Click the right mouse button and select "End Line 
Creation" to terminate the line creation command. 

NOTE: Line creation in EnFEM is continuous, so unless the line creation operation is terminated 
as described above, additional lines can be continuously created from the endpoint of the 
previous line. 
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To create a line with the mouse in a more precise fashion, a “snap” technique can be used.  In this 
case the user can press and hold the CTRL key, in order to “snap” to a specific point (controlled 
by toolbar icons), and then LEFT-CLICK to create the vertex of the line. More on this “snap” 
technique is discussed in Section 3.2.7 of this manual, as well as in the Example Manual. 

3.2.2.2 Creation with Coordinate Input Box 

With EnFEM open, click  to switch to “CAD-mode” if necessary. Click the  icon on the 
toolbar to activate the line creation tool, and note that the command prompt displays the 
message “Input start vertex of line”. Click the coordinate input box under the working zone and 
key in the X and Z-coordinates as shown in Figure 3-4. Press ENTER to create the line start vertex.  

If the mouse cursor is moved outside of the coordinate input box, after this entry, a dashed cyan 
line will be displayed on screen just as in the first method.  Notice the command prompt now 
displays the message “Input end vertex of line”.  Key in the desired coordinate of the end vertex 
and press ENTER. Click the right mouse button and select "End Line Creation" to terminate the 
line creation command. 

 

Figure 3-4: Using absolute coordinates to create start vertex of a new line 

NOTE: When keying in coordinates of the end vertex, there are two options: input as an absolute 
coordinate, or input as a relative coordinate. The format of absolute X and Z-coordinates is the 
desired coordinate numbers separated by a “comma”, as seen in Figure 3-4. The format of a 
relative coordinate input is displayed in Figure 3-5, where the X and Z-coordinates are wrapped 
by a pair of square brackets [ x,z ]. This input specifies that the line endpoint will be placed at a 
location ‘relative’ to the line start. In this example (Figure 3-5), the line endpoint is created at a 
position ‘100-units’ away from the line start vertex in both the positive-X and positive-Z directions.  

 

Figure 3-5: Using relative coordinates to create line end-vertex 

Both methods of line creation can be combined freely. Each time users create a new line-vertex; 
a prompt message will be displayed in front of the coordinate input box to remind users whether 
the line-start or line-end is currently being created.  
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Users may press ESC to terminate the current line creation operation.  However, the line creation 
icon will still be active, until manually deactivated. 

3.2.3 Arc 

An arc is a one-dimensional geometric entity which has three vertices - the center, the arc-start, 
and the arc-end – and always created in that sequence in EnFEM. Additionally, in EnFEM, arcs are 
always created in the counterclockwise direction. The color scheme for arcs is similar to that for 
lines: the blue color represents an independent arc, and the grey color represents a dependent 
arc which is part of a 2D region. 

Two methods are available to create an arc in EnFEM: 

3.2.3.1 Creation with Mouse 

With EnFEM open, click  to switch to “CAD-mode” if necessary. Click the  icon on the 
toolbar to activate the arc-creation tool. In the information panel, the command prompt “Input 
center vertex of arc” will be displayed. Move the mouse cursor to the desired location in the 
working zone and LEFT-CLICK to create the arc center-vertex. A dashed line in cyan color (for the 
default black background of the working zone), or in red color (if working zone has white 
background) is displayed to preview the position of the arc start-vertex. Notice in the information 
panel, the command prompt “Input start vertex of arc” is now displayed. Next, move the mouse 
cursor to the desired location and LEFT-CLICK to create the arc start-vertex. A dashed arc is now 
visible as seen in the middle image of Figure 3-6. Finally, notice in the information panel, the 
command prompt “Input end vertex of arc” is displayed. Move the mouse again, in the 
counterclockwise direction, and LEFT-CLICK for a third time to create the arc end-vertex and finish 
the arc creation.  

To create an arc with the mouse, in a more precise fashion, a “snap” technique can be used.  In 
this case the user can press and hold the CTRL key, in order to “snap” to a specific point (controlled 
by toolbar icons), and then LEFT-CLICK to create the vertex of the line. More on this “snap” 
technique is discussed in Section 3.2.7 of this manual, as well as in the Example Manual. 

   

Figure 3-6: LEFT-CLICK three times to create an arc with the mouse 

3.2.3.2 Creation with Coordinate Input Box 

With EnFEM open, click  to switch to “CAD-mode” if necessary. Click the  icon on the 
toolbar to activate the arc-creation tool and note the command prompt displays the message 
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“Input center vertex of arc”. Click the coordinate input box under the working zone and key in 
the X and Z-coordinates as shown in Figure 3-7. 

 

Figure 3-7: Key-in absolute coordinates of an arc center 

Press ENTER to create this point as the arc center-vertex. Notice that the command prompt now 
displays the message, “Input start vertex of arc”. Next, key in the desired absolute coordinates 
of the arc start-vertex and press ENTER.  Notice that the command prompt now displays the 
message, “Input end vertex of arc”. Finally, key in the desired absolute coordinates of the arc 
end-vertex and press ENTER to finish drawing the arc. 

Alternatively, relative coordinates can be used for creating the arc start-vertex, as seen in Figure 
3-8. 

 

Figure 3-8: Key in relative coordinates to create the arc start vertex 

Here [200,0] represents that the arc start-vertex will be created ‘200-units’ away from the arc 
center-vertex in the positive X-Direction.  

The arc end-vertex can also be created using relative coordinates as shown in Figure 3-9. Note 
that the relative coordinate input for the arc end-vertex has a different definition from that of the 
arc start-vertex. Here, [200,45] represents the arc radius of ‘200-units’, and the arc-angle of 
‘45-degrees’ (counterclockwise).   

 

Figure 3-9: Key in arc angle to create arc end vertex 

Both methods of arc-creation can be combined freely. Some useful tips are as follows: 

 Arcs are always created in the counterclockwise direction.  
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 Using the ‘snap-method’ to create the arc-end vertex at an existing vertex of 
another entity is applicable. However, if the existing vertex does not locate 
exactly on the arc path, the arc end-vertex may not be created at the expected 
location (will be created on arc-path). 

 Pressing the ESC key after the first click will cancel the current arc-creation 
operation. Pressing the ESC key after the second click will cancel the arc start-
vertex and wait for a new input for the arc start-vertex. 

 A closed circle should be created by combing two or more arcs. 

3.2.4 Rectangle 

A rectangle is a type of two-dimensional object, and is determined by two diagonal vertices, as 
modeled in EnFEM. Two methods are available to create a rectangle: 

3.2.4.1 Creation with Mouse 

With EnFEM open, click  to switch to “CAD-mode” if necessary. Click the  icon on the 
toolbar to activate the rectangle-creation tool. In the information panel, the command prompt 
“Input start vertex of rect.” will be displayed. Move the mouse cursor to the desired location in 
the working zone and LEFT-CLICK to create the first rectangle-vertex.  A dashed line in cyan color 
(for the default black background of the working zone), or in red color (if working zone has white 
background) is displayed to preview the rectangle creation, as seen in Figure 3-10. Notice in the 
information panel, the command prompt “Input end vertex of rect.” is now displayed. Next, move 
the mouse cursor to the desired location of the opposite corner of the rectangle and LEFT-CLICK 
to finish the rectangle creation. 

 

Figure 3-10: Create a rectangle with the mouse (white background) 

3.2.4.2 Creation with Coordinate Input Box 

With EnFEM open, click  to switch to “CAD-mode” if necessary. Click the  icon on the 
toolbar to activate the rectangle-creation tool, and note that the command prompt displays the 
message “Input start vertex of rect.”. Click the coordinate input box under the working zone and 
key in the desired X and Z-coordinates – “0,0” for example. Press ENTER to create the first 
diagonal vertex. Notice the command prompt now displays the message “Input end vertex of 
rect.”. Next, key in as second set of X and Z-coordinates – “200,100” for example – and press 
ENTER.  The rectangle has now been created using absolute coordinate input.   

NOTE: Alternatively, relative coordinates may be used for the second vertex, wrapping the input 
coordinates in a pair of square brackets [ x,z ]. This input specifies that the second vertex will be 
placed at a location ‘relative’ to the first – therefore using the width, and height of the rectangle. 
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Both methods of line creation can be combined freely. Pressing the ESC key before the second 
vertex will cancel the current rectangle creation operation. 

3.2.5 Simple Polygon 

A simple polygon is a type of two-dimensional object, and is created by connecting a series of 
vertices sequentially with straight lines. The minimum number of edges for a simple polygon is 
three (a triangle). There is no limitation on the maximum number of edges. 

Two methods are available to create a simple polygon in EnFEM: 

3.2.5.1 Creation with Mouse 

With EnFEM open, click  to switch to “CAD-mode” if necessary. Click the  icon on the 
toolbar to activate the polygon-creation tool. In the information panel, the command prompt 
“Input start vertex of polygon” will be displayed. Move the mouse cursor to a desired location in 
the working zone and LEFT-CLICK to create the first polygon-vertex.  A dashed line in cyan color 
(for the default black background of the working zone), or in red color (if working zone has white 
background) is displayed to preview the polygon creation, as seen in Figure 3-11. Notice in the 
information panel, the command prompt “Input next vertex of polygon” is now displayed. Repeat 
this step and LEFT-CLICK to pick as many additional vertices as desired for the polygon (greater 
than 3).  RIGHT-CLICK and select "Close Polygon" when finished, to terminate the polygon 
creation command.  

To create a polygon with the mouse in a more precise fashion, a “snap” technique can be used.  
In this case the user can press and hold the CTRL key, in order to “snap” to a specific point 
(controlled by toolbar icons), and then LEFT-CLICK to create the vertex of the polygon. More on 
this “snap” technique is discussed in Section 3.2.7 of this manual, as well as in the Example 
Manual. 

NOTE: If the first vertex is created by “snapping” to an existing vertex or a grid point, users may 
close the current polygon by “snapping” to the first vertex again.  

  

Figure 3-11: Create a polygon with the mouse 

If the ESC is pressed before creating the second vertex, the current polygon creation operation 
will be terminated.  Otherwise, the latest vertex creation will be canceled.  
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3.2.5.2 Creation with Coordinate Input Box 

With EnFEM open, click  to switch to “CAD-mode” if necessary. Click the  icon on the 
toolbar to activate the polygon-creation tool, and note that the command prompt displays the 
message “Input start vertex of polygon”. Click the coordinate input box under the working zone 
and key in the desired X and Z-coordinates – “0,0” for example. Press ENTER to create the first 
polygon vertex. Notice the command prompt now displays the message “Input next vertex of 
polygon”. Next, key in a second set of X and Z-coordinates, using either absolute or relative ([ x,z 
]) coordinates, and press ENTER to create a second vertex.  Repeat this process until the desired 
number of vertices has been created. When all polygon vertices are created, users may close the 
polygon by inputting the exact coordinates of the first vertex again, or by clicking the right mouse 
button and selecting “Close Polygon”.  

Both methods can be freely combined to create polygon vertices. 

3.2.6 General Polygon 

General polygons are different from simple polygons because they can include curved edges 
(arcs). Some examples of general polygons are shown in Figure 3-12. 

 

Figure 3-12: Examples of general polygons 

Unlike previous procedures to create a simple polygon, a general polygon is generated indirectly. 
General polygons are created from a series of closed, ‘head-toe’ connected lines and arcs, and 
then converted into a region with a simple operation. A general polygon with fan shape is used 
here as an example to illustrate the procedures. This fan object has two arcs and two straight lines 
as shown in Figure 3-13. 

The basic procedures are shown below using object creations previously described.  More detail 
can be found in the context of a full tutorial example in Example 1 - Thick cylinder subject to 
internal pressure, of the Example Manual. 

 Create two-arcs – an inner and outer – with the same center.  The arc lengths are 
arbitrary. 

 ‘Close’ the arcs by creating two lines connecting the endpoints of the arcs, as seen 
in Figure 3-13. 

 From the menu bar, select "Create->Polygon from Lines/Arcs" 

a. Notice that the line selection icon, , is automatically 
activated. 
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 Holding the SHIFT key, LEFT-CLICK to select all four lines/arcs, and release the 
SHIFT key when complete. RIGHT-CLICK and select “End Selection” from the 
popup menu. 

 Once complete a closed region will have been created as shown in Figure 3-13. 

  

Figure 3-13: Convert arcs and lines to a general polygon 

Some useful tips for creating general polygons, are as follows:  

 If selected arcs/lines do not form a closed region, an error message dialog box 
will appear when the command is executed. If this occurs, check line/arc 
intersections carefully, and delete and recreate lines/arcs as necessary.  

 Independent lines/arcs are shown in blue. After being converted to a new general 
polygon, these lines/arcs become parts of the new general polygon and are no 
longer independent. Their colors are changed to grey to indicate dependence. 
Dependent lines/arcs cannot be used to create another general polygon. If two 
general polygons share one edge, these two general polygons should be created 
by the following procedures: 

a. create edge segments of the first polygon  
b. select them and convert to the first general polygon 
c. create ALL edges for the second polygon, even if one or more edges 

overlap with edges from the first polygon. 
d. select newly created lines/arcs and convert them to the second general 

polygon (only independent line/arcs will be recognized in the conversion 
operation). 

 The minimum number of edges for common general polygon shapes is as follows: 
a. Triangular region – three lines,  
b. Pie-shaped region - one arc and two lines, 
c. Circular region – two arcs 

 By default, a region entity will render its edges and shaded internal area. For a 
curved region, arcs are rendered as short line segments on screen. If viewed in 
great detail, gaps may be visible between a shaded area and a curved boundary. 
This is a normal occurrence. 

 Lines/arcs should be ‘head-toe’ connected. Line/arc segments cannot be 
intersected, otherwise an invalid, entangled geometry is created. Some examples 
of invalid geometries are shown in Figure 3-14. 
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Figure 3-14: Invalid geometries for a general polygon 

3.2.7 Snap-Methods  

“Object snap” is a built-in feature of EnFEM to aid with geometry creation. This feature will allow 
users to place a vertex of the geometry at an exact point, while the geometry is being created. 

“Snap-to” options in EnFEM are as follows, and controlled by icons ( ) on the 
toolbar.  

 An existing vertex  
 End/midpoint/Center-point of a line or arc 
 Grid intersections  

In order to activate the “Snap” capability, the appropriate icon should first be active (see Section 
2.2.5).  While holding down the CTRL key, move the mouse cursor to the appropriate location, 
until the snap-icon appears. With the snap-icon visible click the left mouse button to create the 
vertex at that exact location. 

Figure 3-15 shows the “vertex” snap-icon visible during the creation of a new line. In this case the 
start-vertex of the new line is “snapped” to the corner vertex of an existing rectangle. 

 

Figure 3-15: Snap to the corner of a rectangle when create a new line 

This manual, as well as the EnFEM Example Manual will go on to refer to this technique 
throughout this document, as the ‘snap method’. Alternatively, it also may mention ‘snap to …’ 
with some geometric reference, as in ‘snap to the bottom-right vertex’. 

3.3 Selecting Geometric Entities 

3.3.1 Selection Types 

Many operations involve selection of geometric entities. Since three entity types are available in 
EnFEM, selection operations have three corresponding types: selection of vertices, selection of 
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lines/arcs, and selection of regions. Selection icons  are placed on the toolbar and 
control the selection of each specific entity. Before using the mouse to select any geometric 
entity, the corresponding selection icon should be activated. For example, in order to select a 
region edge, click to activate the line/arc selection icon and make sure the others are deactivated 

- as shown here, . Otherwise, if an unwanted entity is selected (in this case a vertex) 
when it should not be, errors may result. Many editing/modifying commands in EnFEM will 
activate correct selection icons automatically. Occasionally however, the user may need to 
activate/deactivate one or more selection icons manually. 

The following details the selection graphics (as seen in Figure 3-16): 
 Vertex - Red circle will be displayed around the selected vertex. 
 Line/arc – Selected lines/arc with be highlighted in red. 
 Region - Selected regions with be highlighted in cyan. 

NOTE: To clear the current selection set, make sure the corresponding selection icon is activated 
and LEFT-CLICK the mouse on a blank area of the screen. 

 

 

   

Figure 3-16: Selection of geometry entities: vertex, line/arc, and region 

3.3.2 Selection options 

There are two options for selecting operations – “click to select”, or using a selection window – 
both of which will be discussed in the following sections.   

3.3.2.1 Click to Select 
The first selection option simply requires the user to Left-Click on the desired entity (vertex, line, 
etc.), to select it.  If multiple objects are to be selected, then the user may hold the SHIFT key and 
select by LEFT-CLICK, the desired geometric entities one by one in succession. If an erroneous 
selection is made, while holding the SHIFT key, simply reselect the undesired object to remove it 
from the selection set.  

This approach is useful if only a small number of selections is necessary. 
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3.3.2.2 Selection Windows 
The second, and perhaps more convenient method, is to use a selection window. Two options are 
available for selection windows – “contained”, and “crossing”. Consider the “fan shaped” 
geometry in Figure 3-16 for the following sections. 

3.3.2.2.1 Contained Selection Window 
For “contained” selection, first move the cursor towards the bottom left corner of the geometry 
(a point at which all segments will be contained in a selection box). With the desired selection 
icon active, now click and hold the left mouse button, and move the cursor towards the top 
righthand corner of the display. A green selection window with solid edges is displayed on screen 
during this operation. When the selection window contains all four line/arc entities, release the 
mouse button to finish the operation.  

3.3.2.2.2 Crossing Selection Window 
Alternately, for a “crossing” selection, move the cursor to the upper right corner of the geometry. 
With the desired selection icon active, next, click and hold the left mouse button and drag the 
mouse cursor to the lower left direction. This will generate a crossing selection window, shown 
with yellow, dashed edges. All entities that intersect with the crossing window, and those that are 
inside it, are selected upon releasing the mouse button. 

3.4 Editing Geometric Entities 
The following editing operations are contained in EnFEM: "Copy to", "Mirror to", "Edit Vertex 
Coordinate", and "Translation", and are described below.  More detail can be found for these 
operations in the context of full tutorial examples, in the included Example Manual. 

3.4.1 Copy To 

The “copy to” function is used to generate identical geometric entities at a different position. 
Source objects should be independent entities such as independent vertices, independent 
lines/arcs, or regions. Dependent geometric entities cannot be copied. If the source object is a 
region to which a material type has been assigned, then this material assignment will also be 
copied. However, boundary conditions and contact/interaction definitions are not copied to the 
new region entity. 

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary. 
 On the menu bar, click "Edit->Copy to",  

a. All selection icons  will be activated automatically.  
b. On the bottom toolbar, below the working zone, the following command 

prompt is displayed - "Select geometry entities to copy". 
 Select the desired independent entities to copy. 
 RIGHT-CLICK and select "End Selection" from the popup menu. 

a. NOTE: Clicking "Cancel" will terminate the current “copy to” operation. 



CHAPTER 3 – Creating & Editing Geometric Entities – 3-15 
 

User’s Manual (Rel. May/2019)  EnFEM for Windows 

 A dialog box will open for defining an auxiliary line as the copy reference (Figure 
3-17). Key in the start and end coordinates of the auxiliary line.  

a. Since only the difference of the X and Z-coordinates is of interest, inputs 
can be arbitrary values. For example, enter in a start point of “0,0” and 
an ending point of “0,100”.  This copies the object, 100-units in the 
positive Z-direction 

 

Figure 3-17: Definition of auxiliary line as the copy reference 

 Click "OK" to close the dialog and complete the copy operation. The location of 
copied objects is the position of the source objects plus the shift of the auxiliary 
line.  

a. If "Cancel" is clicked instead of “Ok”, current copy operation will be 
terminated. 

NOTE: This operation will activate all three selection icons automatically. The user may turn off 
unnecessary selection icons manually.  

3.4.2 Mirror To 

The “mirror to” function is used to copy geometric entities ‘mirrored’ about a reference line. 
Source objects should be independent entities such as independent vertices, independent 
lines/arcs, or regions. Dependent geometric entities cannot be mirrored. If the source object is a 
region to which a material type has been assigned, then this material assignment will also be 
copied. However, boundary conditions and contact/interaction definitions are not copied to the 
new region entity. 

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary 
 On the menu bar, click "Edit->Mirror to".  

a. All selection icons  will be activated automatically.  
b. On the bottom toolbar, below the working zone, the following command 

prompt is displayed - "Select geometry entities to mirror". 
 Select the desired independent entities to mirror. 
 RIGHT-CLICK and select "End Selection" from the popup menu. 

a. NOTE: Clicking "Cancel" will terminate the current “mirror to” operation. 
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 A dialog box will open for defining an auxiliary line as the mirror axis (Figure 3-17). 
Key in the start and end coordinates of the auxiliary line. 

 Click "OK" to close the dialog and complete the mirror operation. Source and 
mirrored objects are symmetrical about the auxiliary line.  

a. If "Cancel" is clicked instead of “Ok”, current mirror operation will be 
terminated. 

NOTE: This operation will activate all three selection icons automatically. The user may turn off 
unnecessary selection icons manually.  

3.4.3 Edit Vertex Coordinate 

This operation is used to relocate one or more independent or dependent vertices to new 
positions. If the selected vertices belong to a region, only the selected vertices are relocated. This 
operation does not change the material assignment, boundary conditions, or contact interface 
definitions assigned to the region.  

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary 
 On the menu bar, click "Edit->Edit Vertex Coordinate".  

 Make sure that only the vertex selection icon  is activated. 
 On the bottom toolbar, below the working zone, the following command prompt 

is displayed - "Select vertex entities to edit coordinates". 
 Select the desired vertices to edit. 
 RIGHT-CLICK and select "End Selection" from the popup menu. 

a. NOTE: Clicking "Cancel" will terminate the current “mirror to” operation. 
 A dialog window will open, as shown in Figure 3-18. Check the appropriate option 

"Apply to X" and/or "Apply to Z", and input the desired new coordinates in the 
input box(es).  

 Click “OK” to close the dialog and complete vertex relocation.  
a. If "Cancel" is clicked instead of “Ok”, current mirror operation will be 

terminated. 

 

Figure 3-18: Edit vertex coordinates 
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NOTE: This operation relocates selected vertices and changes the region topology. Sometimes this 
operation may result in an inverted region direction or entangled topology. In EnFEM, all region 
objects use a counterclockwise direction for boundary condition assignment and mesh-seed 
control. If the direction of a region is inverted, switching to clockwise, issues will be encountered 
during boundary condition assignment and mesh generation. Users should be aware of the 
possibility of inverted region direction when editing vertices.  Figure 3-19, show two instances 
which should be avoided – crossing geometry and clockwise directions – when editing vertices.  

Additionally, relocating more than one selected vertex may generate redundant vertices and zero-
length line segments if both of the options "Apply to X" and "Apply to Z" are checked, and also 
should be avoided. 

 

Figure 3-19: Cases to avoid when editing vertex coordinates 

3.4.4 Translate  

This operation is used to move geometric entities (independent vertices, independent lines/arcs, 
and/or regions) by the distance provided by the user. The operation does not change the material 
assignment, boundary conditions, or contact interface definitions assigned to the region. 

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary 
 On the menu bar, click "Edit->Translate to".  

a. All selection icons  will be activated automatically. 
b. On the bottom toolbar, below the working zone, the following command 

prompt is displayed - "Select geometry entities to translate" 
 Select the desired independent entities to copy. 
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 RIGHT-CLICK and select "End Selection" from the popup menu. 
a. NOTE: Clicking "Cancel" will terminate the current “translate to” 

operation. 
 A dialog window will open, as shown in Figure 3-20. Key in the desired translation 

values for the X and Z-directions.  
 Click “OK” to close the dialog and complete the translation operation.  

a. If "Cancel" is clicked instead of “Ok”, current translation operation will be 
terminated. 

 

Figure 3-20: Translate objects 

NOTE: This operation will activate all three selection icons automatically. The user may turn off 
unnecessary selection icons manually. 

3.4.5 Delete  

This operation is used to delete independent vertices, independent lines/arcs, regions, or one 
dependent vertex of a region. Vertices of independent lines/arcs, and dependent lines/arcs of a 
region cannot be deleted.   

If one or more regions are deleted, this operation may have an influence on material assignments, 
boundary condition assignments, contact interface definitions, and mesh generation, among 
other input data. Users should check all relevant assignments and definitions carefully to maintain 
data integrity before running the analysis. 

If one dependent vertex of a region is deleted, its parent region will be updated based on two 
different situations: 

 If two arcs intersect at the deleted vertex and these two arcs belong to the same 
circle, a new arc will replace these two arcs. Following the counterclockwise 
direction, the new arc begins from the start vertex of the front arc and ends at 
the end vertex of the back arc. 

 Lines/arcs intersecting at the deleted vertex will be replaced by a new line. This 
line will connect the ends of the deleted lines/arcs directly. 

If there are two vertices at a common corner of two adjacent regions, it is recommended to hide 
one region before performing the delete operation on the desired vertex. In this scenario it is 
also recommended to reference Section 3.6 for valid geometric configurations. 
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Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary 
 On the menu bar, click "Edit->Delete". 

a. All selection icons  will be activated automatically. 
b. On the bottom toolbar, below the working zone, the following command 

prompt is displayed - "Select geometry entities to delete". 
c. Additionally, a warning message window will appear, as shown in Figure 

3-21. User’s may check the “Do not display…” option if desired. Click 
"Close" to close the warning message window. 

 Select the desired entities to delete. 
 RIGHT-CLICK and select "End Selection" from the popup menu to complete the 

operation. 
a. NOTE: Clicking "Cancel" will terminate the current “delete” operation. 

 

Figure 3-21: Warning message for deleting operation 

3.4.6 Undo/Redo 

The "Undo" operation provides users with a convenient way to cancel the latest editing/modifying 
operation, which includes those operations located on the menu bar under "Edit" and "Modify" 
drop-down menus. The "Redo" operation can recover an editing/modifying operation canceled 
by the "Undo" command.   

Note that the following limitations exist: 
 Creation operations do not have undo/redo options. 
 Operations under the "Data", "Mesh" and "Analysis" drop-down menus do not 

have undo/redo options. 
 Undo/redo will only occur for the last operation completed. 

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary 
 On the menu bar, click "Edit->Undo". 

a. For the “Redo” command, select "Edit->Redo". 
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3.5 Modifying Operations 
Modifying operations are available in EnFEM to “divide”, “merge”, “partition”, and/or 
“disassemble” existing independent geometric entities. The following sections details these 
operations. 

3.5.1 Divide Line/Arc by Intersection  

This operation is used to divide: two intersecting lines, two arcs, or one line and one arc. Note 
that these lines/arcs must be independent entities. 

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary. 
 On the menu bar, click "Modify->Divide Line/Arc by Intersection". 
 Select the desired geometric entities. 
 RIGHT-CLICK and select "End Selection" from the popup menu to complete the 

operation. 
a. NOTE: Clicking "Cancel" will terminate the current “divide” operation. 

The procedure is illustrated in Figure 3-22. The left image shows the two ‘source’ lines before 
being divided. The middle image shows the selected lines. The right image shows the verification 
of the division operation. In this example, two independent lines are divided into four 
independent lines, at their intersection point. 

   

Figure 3-22: Divide independent lines/arcs by intersection 

3.5.2 Merge Lines/Arcs 

This operation is used to merge two-line segments, or two-arc segments into one. These line or 
arc segments can be independent or dependent entities. If two lines are merged, a new line will 
be created connecting the outer vertices of the source lines. If two arcs are selected to be merged, 
these arcs must belong to the same circle.  

The procedure to perform the line/arc merging operation is detailed as follows: 

 Click  to switch to “CAD-mode” if necessary 
 On the menu bar, click "Modify->Merge Lines/Arcs". 
 Select the desired geometric entities.  
 RIGHT-CLICK and select "End Selection" from the popup menu to complete the 

operation. 
a. NOTE: Clicking "Cancel" will terminate the current “merge” operation 



CHAPTER 3 – Creating & Editing Geometric Entities – 3-21 
 

User’s Manual (Rel. May/2019)  EnFEM for Windows 

The procedure is illustrated in Figure 3-23. The left image shows three-line segments, of which 
the left two will be merged. The merged line segment is shown in the right image in Figure 3-23.   

   

Figure 3-23: Merge line segments 

NOTE:  This operation will merge two lines or two arcs only and is valid for both independent and 
dependent entities. Lines/arcs to be merged should be ‘head-toe’ connected. 

3.5.3 Partition Edge 

This operation is used to partition (divide) one or more region-edges with an auxiliary line. Extra 
vertices will be inserted at intersections between region edges and the auxiliary line. Users first 
need to create an independent line entity that will be used as the auxiliary line. After the partition 
operation, the auxiliary line is automatically deleted. 

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary. 
 Create an auxiliary line which intersects with the desired region edge. 
 On the menu bar, click "Modify->Partition Edge of Region". 

a. Make sure the line selection icon, , is activated. 
 Select the auxiliary line and region-edge. 
 RIGHT-CLICK and select "End Selection" from the popup menu to complete the 

operation. 
a. NOTE: Clicking "Cancel" will terminate the current “partition” operation. 
b. NOTE: If the auxiliary line is not provided, a window will open to allow the 

user to key-in the coordinates of the auxiliary line, as shown in Figure 
3-17.  

 Verify that source edges are partitioned appropriately.  
a. NOTE: The auxiliary line will be deleted automatically. 

This procedure is illustrated in Figure 3-24. 
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Figure 3-24: Partition Edge of Region 

3.5.4 Partition Region by Line 

This operation is used to partition (divide) one region into two separate regions with an auxiliary 
line. This operation requires that vertices of the auxiliary line be located on an edge of the source 
region. If there are no appropriate vertices available, the user may need partition the edges of the 
region using previously described methods. Additionally, after the partition, the newly generated 
regions must have at least three edges (triangle). 

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary. 
 Create an auxiliary line using two vertices on the region.  
 On the menu bar, click "Modify->Partition One Region by Line". 

a. Make sure that both the line and region selection icons, , are 
activated. 

 Select the auxiliary line and region. 
 RIGHT-CLICK and select "End Selection" from the popup menu to complete the 

operation. 
a. NOTE: Clicking "Cancel" will terminate the current “partition” operation. 

 Verify that the source region is partitioned.  
a. NOTE: The auxiliary line will be deleted automatically. 

These steps are illustrated in Figure 3-25. 
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Figure 3-25: Partition one region by an auxiliary line 

3.5.5 Merge Regions 

This operation is used to merge two or more neighboring regions. This operation requires that 
source regions have at least one common edge (matching dependent line and vertices – see Figure 
3-26). After the merging operation, original material assignments are not inherited by the new 
region, but boundary conditions and contact interfaces assigned to edges other than the common 
edge will be copied to the new region.  

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary. 
 On the menu bar, click "Modify->Merge Regions". 

a. Make sure that the region selection icon, , is activated. 
 Select the desired regions 
 RIGHT-CLICK and select "End Selection" from the popup menu to complete the 

operation. 
a. NOTE: Clicking "Cancel" will terminate the current “merge” operation. 

 Verify that the source regions are merged appropriately. 
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Figure 3-26: Examples of Common Edges for Merge Region 

3.5.6 Disassemble regions 

This operation disassembles one or more regions into a series of lines and arcs. Therefore, it is the 
reverse operation of generating a general polygon from lines/arcs. This operation provides users 
the maximum flexibility to modify geometric entities based on existing analysis models. However, 
after disassembly, all originally assigned material properties, boundary conditions, and contact 
interface definitions, etc., associated with the disassembled region will be lost. Local mesh control 
data on each individual line/arc segment may be preserved. 

NOTE: For two neighboring regions with one common edge, the common edge between the 
regions includes two dependent line/arc segments. Each of these belongs to its own parent 
region. Disassembling one region, will create one dependent (intact region) and one independent 
(for the disassembled region) line/arc on the common edge. 

Procedures to perform the operation are as follows: 

 Click  to switch to “CAD-mode” if necessary. 
 On the menu bar, click "Modify->Disassemble Region". 

a. Make sure that the region selection icon, , is activated. 
 Select the desired regions. 
 RIGHT-CLICK and select "End Selection" from the popup menu to complete the 

operation 
a. NOTE: Clicking "Cancel" will terminate the current “disassemble” 

operation. 
 Source regions are disassembled into series of independent lines and arcs. 
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3.6 Valid and Invalid Geometric Configurations  
Finite element analyses in geotechnical engineering typically studies the strength and 
deformation of soil materials, soil-structure interactions, and the strength of structural elements. 
Figure 3-27 illustrates a typical problem in this field – a retaining wall. In this example, three 
different materials are involved: the concrete of the retaining wall, and two different soil materials 
for each respective layer. For simplicity, the contact interface is not discussed in this section (refer 
to Section 3.8), and the retaining wall is assumed to be perfectly bonded with the soil materials.  

 

Figure 3-27: A typical problem in geotechnical engineering-retaining wall analysis 

In EnFEM, the physical bodies of the soil and the retaining wall are simulated by three-2D regions. 
‘Soil layer 1’ is the only rectangular region, while the ‘retaining wall’ and ‘soil layer 2’ regions are 
both general polygons. Since there is no contact interface, and the regions are perfectly bound 
together via the mesh, there is only one ‘geometry-set’ (a general term discussed more in Section 
3.8 below) existing in this model.   

Some general rules should be followed in developing geometric entities in EnFEM: 

 Each region object must be assigned one and only one material property. 
a. Therefore, for the geometric configuration of Figure 3-27, with three 

distinct material properties – three regions must be defined. 
 On common (adjacent) edges, neighboring regions should share line/arc 

segments, AND line/arc vertices - see Figure 3-26, and Figure 3-29 for this specific 
retaining wall reference. 

 Regions cannot be overlapping, or connected by only one vertex - as shown in 
Figure 3-28. In the case of the latter scenario, mesh generation will result in 
errors. 

 If regions are separated with gaps, they will be considered an independent region, 
and should have appropriate boundary conditions applied to create stability. 

retaining wall
soil layer 1

soil layer 2
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Figure 3-28: Invalid geometric configurations 

Considering these basic guidelines, reconsider the geometry of the retaining wall again. Figure 
3-29, shows this geometry-set broken down into the basic geometric entities. Red crosses 
represent the vertices of each region object. Although the retaining wall has a simple rectangular 
shape, it should be created as a six-edge polygon to maintain compatibility with the other two 
region entities. Violation of this region compatibility may result in failure during mesh generation 
or unpredictable results during analysis.  

 

Figure 3-29: Valid regions for retaining wall example 

Figure 3-29 depicts the minimum number of region entities to simulate the retaining wall problem 
in EnFEM, as three different materials are involved. Experienced users often simulate retaining 
walls with several rectangular sub-regions. Splitting a polygon into several quadrilateral regions 
makes it possible to generate a structured mesh - considered to achieve the greatest accuracy 
and efficiency. One may also consider taking the time to model a defined ‘centerline’ on the 
retaining wall in order to easily select certain results. The details of mesh generation are 
introduced in later chapters of this manual. 

3.7 Simulation of Voids 
Voids (holes) in soil are frequently found in geotechnical engineering problems when modeling 
tunnels or culverts. EnFEM uses an indirect method to generate voids in a geometric model. Figure 
3-30 shows a typical culvert example in geotechnical engineering. The green ring represents a 
concrete culvert. There is a horizontal line to separate the different soil layers that intersect with 
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the culvert. The upper and lower soil layers are represented by general polygons. If both soil layers 
are identical, users still should split the soil around the culvert with a horizontal line to create two 
general polygons to wrap an internal hole. The concrete culvert, and void, is modeled by two 
connected rings. More detail, can be found on this technique in Example 4 - Interaction (contact) 
analysis of buried culvert, of the Example Manual. 

 

Figure 3-30: Culvert analysis example 

3.8 Independent Geometry-Sets 
Since no interaction (contact) definitions are discussed in the previous examples shown in Figure 
3-27 and Figure 3-30, the common edges for adjoining regions are considered to be perfectly 
bound (via the mesh) to one another.  On the perfectly bonded interfaces (edges), the finite 
element nodes are shared by elements of adjacent regions which may also have different material 
properties. In these cases, only one independent ‘geometry-set’ is present – the whole adjoined 
geometry group.  

NOTE: This perfectly bonded condition, in which nodes are shared between bodies on the 
adjacent edge, is the default status of mesh creation.  Only with an interaction boundary condition 
(discussed later) can adjoining bodies be made to act independently. 

However, modelling a more ‘real-life’ scenario, and applying some interaction (contact) 
definitions can have a significant influence on the behavior of the model. Thus, the concept of 
independent ‘geometry-sets’ becomes important. To model the soil-structure interaction 
behaviors more accurately, a ‘contact interface’ should be defined between the structural 
element and soils. When this interaction is modeled in the context of these examples (Figure 3-27 
and Figure 3-30), the models then contain two independent ‘geometry-sets’: the structure 
configuration and the soil configuration. The interaction between the two sets, being controlled 
by the ‘contact’ boundary condition. A model in EnFEM may have more independent 
configurations if necessary, and each independent ‘geometry-set’ may contain one or more 
regions as necessary. In this case, due to this applied boundary condition, finite elements on either 
side of the contact interface (common edges) will no longer share finite element nodes. Closure 
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or separation in the normal direction, and sticking or sliding in the tangential direction along the 
contact interface, can be simulated when an interaction boundary condition is applied.  

More detail regarding Interaction (contact) definitions is introduced in CHAPTER 6 of this manual, 
and detailed examples can be found in the Example Manual.  



 

 

 

 

 

 

 

 

 

 

 

 

CHAPTER 4. Control Data, Stages, 
Material Properties, & 
Boundary Conditions 

  



CHAPTER 4 – Control Data, Stages, Material Properties, & Boundary Conditions – 4-2 
 

User’s Manual (Rel. May/2019)  EnFEM for Windows 

4.1 Introduction 
This chapter introduces operations to define analysis input parameters and controls including 
stage controls, material properties, and boundary conditions – all found under the “CAD-mode”, 
"Data" drop down menu on the toolbar.  

Interaction (contact) definitions will be introduced in a later chapter. 

The sequence of sub-sections in this chapter follows typical workflow procedures to develop a 
model in EnFEM. It is recommended to follow this workflow to develop a new model. 

4.2 Control Data 
Control data contains the project title, selection of analysis type, and the thickness definition (if 
applicable).Figure 4-1 shows the Control Data Dialog window and can be opened by selecting 
“Data->Control Data” from the menu bar. 

 

Figure 4-1: Input dialog box of Control Data 

This dialog allows users to define the following: 

 Project Title: 
a. Project descriptions (optional) 

 Analysis Type: 
a. Plane strain, plane stress, or axi-symmetric. 

i. If plane stress is selected, thickness should be input. 

NOTE: If the analysis type is set to "axi-symmetric", the horizontal coordinate becomes ‘radius, r’ 
and the vertical coordinate is ‘depth, z’. An orange dashed line will be displayed on screen to 
indicate the location of the axi-symmetric axis as shown in Figure 4-2. Additionally, from the menu 
bar, users can click "View->Global Axes" while in “CAD-mode” to display or hide the global axis 
and the axi-symmetric axis. 
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Figure 4-2: Axis layout for axi-symmetric analysis type 

4.3 Stage Management 
Problems in geotechnical engineering frequently involve various loads applied at different time 
periods, or have construction stages (i.e. excavations). EnFEM has the capability to perform multi-
stage simulations. 

On the menu bar, click "Data->Stage Management" to open the “Stage Group Management 
dialog” as shown in Figure 4-3. 

 

Figure 4-3: Dialog of Stage Group Management 

Completed stages are listed in the Stage Group window to the left. Analyses follow the stage 
sequence as listed in this Stage Group window. Stages follow a sequential order, and newly 
defined stages are added to the bottom of the list.  

Click "New" to create a new stage definition. Select an existing stage from the Stage Group list 
and click "Edit" to modify it. Select an existing stage from the Stage Group list and click "Delete" 
to remove the unwanted stage from the model. 

NOTE: Since the assignment of boundary conditions is related with stage definitions, it is 
recommended to finish stage definitions before assigning boundary conditions. 
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4.3.1 New Stage 

When a new stage is created the “Stage Definition dialog” window will open to let users define 
the new stage (Figure 4-4). A new stage has no default stage name, so it should be provided by 
users. Select the stage type from the drop-down list under the label "Type". If the "Initial Soil 
Stress" option is selected, there is no need for the user to define increment data. “Increment 
Controls” may be altered if desired, however, the default settings are sufficient for most cases. 
More detail on increment controls is described in a later section. 

Click "Save & Exit" to close the stage definition window. Click "Cancel" to cancel stage definition.  

  

Figure 4-4: Setup of a stage  

4.3.1.1 Initial Soil Stress Stage 
"Initial soil stress" is a special condition in geotechnical engineering. Many analyses start from 
such a condition, in which soil particles have non-zero stresses which keep equilibrium with self-
weight but are free of deformation. Additionally, some constitutive models, such as Modified 
Cam-Clay, requires correctly defined initial stresses.  Stresses in the initial state have three 
components: a vertical stress, and two lateral stresses – which are the principal soil stresses. 
EnFEM is able to estimate the initial stress status for normally consolidated soil or lightly 
consolidated soil. At this time, it is not applicable for heavily consolidated soil. 

There are two situations where it is necessary to define "Initial Soil Stress" in EnFEM: 

 CASE 1:  The model simulates actual geometric dimensions and working 
conditions, such as:  a shallow foundation on soil, a retaining wall in soil, or the 
stability analysis of a slope. The "Initial Soil Stress" stage should be the first stage 
and only the gravity load is applied in this stage. EnFEM estimates the initial soil 
stress automatically. At the end of the "Initial Soil Stress" stage, all three stress 
components in the soil are non-zero and they keep equilibrium with self-weight. 

 CASE 2:  The model is used to simulate a laboratory soil test. The soil sample is 
assumed to have uniform initial stresses and these stresses maintain equilibrium 
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with applied external pressure on the sample surface. Note that a gravity load 
should not be applied in this case. The "Initial Soil Stress" stage should be the first 
stage. 

If a stage is defined as an "Initial Soil Stress" type (Figure 4-5), the button for “Initial Stress Option” 
will be active. Clicking this will open the “Initial Stress Option dialog” as seen in Figure 4-6. Options 
are available for the calculation method, and for adding, updating, and deleting region-entities 
for which these definitions will be applied to.  For new models, the user will click “Add”, then 
select the appropriate geometry, and then RIGHT-CLICK and select “End Selection”, in order to 
add the desired regions into the “region list” and therefore associate with these controls. If an 
existing model is being updated, those regions defined under this control, will be highlighted in 
cyan and shown in the “region list”, and for which users may edit as desired. “Update”, will allow 
the user to replace all items in the “region list” at once with the selected geometry (follow similar 
procedure as the “Add” button).  “Delete” will allow the user to clear all items in the “region list” 
at once.  

Three methods are available to estimate initial soil stresses and are described as follows.  More 
technical information on these topics can be found in the EnFEM Technical Manual. 

4.3.1.1.1 𝐾𝐾0 Method 
This method is valid for flat ground and horizontally distributed soil layers only. Click the button 
"Input Data" to key in soil layer information and the coefficient of lateral stress (Figure 4-7). “Add 
line” adds a data line to the end of the list.  “Insert line” adds a data line below the row in which 
the cursor is placed. “Delete Line”, removes the row in which the cursor is placed. 

4.3.1.1.2 External File Method 
If the ground is not flat, or soil layers incline, the 𝐾𝐾0 method is not recommended. The second 
option can be selected wherein the initial stresses are read from an external stress file (Figure 
4-8). In order to generate the stress file in EnFEM, generally a separate ‘initial stress-only analysis’ 
is executed first, in which, materials are assumed to be elastic, and only the gravity load is applied. 
After this initial calculation, a stress report can be generated which can be used as the source of 
the external stress file. A second analysis is then performed referencing this file for the “Initial 
Stress Option”. This technique is detailed further in Example 11 – Excavation on Inclined Soil, of 
the Example Manual. 

4.3.1.1.3 ‘By-System’ Method 
In this method, initial soil stresses will be estimated from actual material models and actual 
contact interfaces. Deformation data generated by the gravity load will be ignored for subsequent 
stages (only stresses will be used). This option should be selected if the computation has 
convergence issues, especially during the initial stress stage. This situation may happen if soil-
structure interactions are simulated in the model.  
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Figure 4-5: Initial soil stress stage definition 

 

Figure 4-6: Initial soil stress options 

 

Figure 4-7: K0 method input options 
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Figure 4-8: External file option 

4.3.1.2 General Static Stage  
This option is applicable to most situations except for those that are predetermined to be “Initial 
Soil Stress” or "Excavation" types.  In this stage type, increment control is available to users. Users 
will need to enter in the “stage name” and then select the increment control from two options: 
"Automatic" or "Fixed". The “Automatic" option is shown in Figure 4-9, and in most cases is the 
recommended option. Default parameters are provided by the program, but may be changed by 
the user if desired.  The "Fixed" option requires only the maximum increment number to be 
provided.  A default value is provided by the program, but may be changed by the user if desired. 
The “use field variable” option is described in a later section, as well as more specific detail on 
increment control. 

 

Figure 4-9:  Automatic control of General Static Stage 

4.3.1.3 Excavation Stage 
This stage is used exclusively for soil excavations.  The same basic options are available as those 
in the “General Static” stage – “Automatic” or “Fixed” increment, and their specific input 
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parameters.  Default parameters are provided by the program and may be changed by the user if 
desired. The “use field variable” option is not available for the excavation stage definition. 

4.3.1.4 "Use field variable" Option 
The "use field variable" option (checkbox to the right of the stage type in Figure 4-9) allows users 
to control the change of material parameters according to a specific pattern. In EnFEM this option 
can be used to estimate the Factor of Safety of a slope by using the strength reduction method, 
where material strength is reduced according to a pattern defined on field variables. This option 
should be paired with a corresponding material definition, and is applicable to the Tresca, von 
Mises, Mohr-Coulomb, and Drucker-Prager material models. The process of how to change the 
pattern of parameters in the material property is described further in Section 4.4.8. Detailed 
procedures of how to use field variables can be found in, Example 3 – Analysis of Slope Stability 
Using Strength Reduction Factor, of the Example Manual. 

4.3.1.5 Control of Load Increments  
EnFEM is used for nonlinear analyses in geotechnical engineering. In general, loads are applied 
incrementally and convergence of each increment is obtained through iterations. EnFEM provides 
two increment control options: automatic or fixed. The "Automatic" option allows the program 
to determine the increment size (Figure 4-9). Users provide general control of the maximum and 
minimum increment sizes, and the maximum number of increments. In the "Fixed" option, the 
increment size is fixed as shown in Figure 4-10. All increments have the same size. If convergence 
cannot be reached during one increment, the calculation will be terminated. The only input for 
fixed increment control is the number of increments. The analysis uses uniformly sized load 
increments, in which each increment is equal to 1 divided by the number of increments (in this 
case 0.01). If the computation cannot reach convergence within the maximum number of 
iterations, or if it bifurcates in the current increment, the computation will be terminated 
automatically. 

 

Figure 4-10: Fixed load increment control 
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In EnFEM, the total load factor for each stage is set to “1”. Each loading increment will apply a 
fraction of the total loads which are applied in the current stage. Loads applied in the previous 
stages will remain until the end of the calculation. Assume a model has three stages named 
"gravity", "surcharge", and "backfill". The range of load increments for each stage will be assigned 
as follows:  0 → 1 for "gravity", 1 → 2 for "surcharge", and 2 → 3 for "backfill". When the 
increment is equal to 1, this indicates the end of the first stage and the start of the second stage. 

The following explains the parameters for the "Automatic" option: 

4.3.1.5.1 Maximum number of increments:  
This parameter sets the maximum allowable load increments for one stage. The default value is 
100. When the computation has difficulty to convere within a given load increment, the load 
increment is reduced and the solution will be attempted again. This may result in the total number 
of load increments greater than the default value of 100, as the total increment number is 
influenced by the size of a load increment. Users may define a new increment limit larger than 
100 if necessary. 

4.3.1.5.2 Initial increment size:   
The initial increment size is the first increment size used by the current stage. A value of 5% to 
10% is appropriate for most calculations. Occasionally a smaller initial size is necessary when the 
problem is highly nonlinear. 

4.3.1.5.3 Maximum increment size and minimum increment size:  
EnFEM uses a smart algorithm to control the increment size automatically. If convergence is easily 
reached, the size for the next increment may be increased. However, the increased increment 
size will not exceed the maximum size defined here. If the computation cannot reach 
convergence, or if the result bifurcates, the program will redo the computation using continuously 
smaller increment sizes until the minimum increment size is reached, or convergences occurs. If 
convergence still cannot be attained once reaching the minimum increment size, the computation 
will be terminated automatically. 

4.3.2 Edit Stage 

This option allows the user to modify an existing stage definition. Select an existing stage from 
the Stage Group window (Figure 4-3) and click "Edit" to open the “Stage Definition dialog”. Users 
can then modify the stage as desired. Note, that if stage ‘type’ is changed, other parameters 
(boundary conditions) may also be affected. Click "Save & Exit" to save changes to the model and 
close the “Stage Definition dialog”. Clicking "Cancel" will exit without saving changes. 

4.3.3 Delete Stage 

This option allows the user to remove existing stage definitions from the model. Select an existing 
stage from the Stage Group window (Figure 4-3), and click "Delete" to remove it from the model. 
There is no "undo" option to recover deleted stages, so caution should be used.  
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NOTE: If existing boundary conditions are related with a deleted stage, users should update the 
stage data for these boundary conditions. 

4.4 Material Properties 
EnFEM provides seven material models: linear elasticity, Tresca plasticity, von Mises plasticity, 
Mohr-Coulomb plasticity, Druker-Prager plasticity, Duncan-Chang hyperbolic elasticity, and 
Modified Cam-Clay. For more technical details on each material model, users may refer to the 
EnFEM Technical Manual.   

From the menu bar, click “Data->Material Properties” to open the “Material Group Management 
dialog”, where users can create, edit, or delete material property definitions (Figure 4-11).  

 

Figure 4-11: Material Group Management dialog 

Clicking "New" will open the “Material Property dialog” (Figure 4-12), and allow users to create a 
new material definition. Selecting a material from the “Material group list” and then clicking 
"Edit", will open the “Material Property dialog”, and allow users to edit an existing definition. 
Selecting a material from the “Material group list” and then clicking "Delete", will remove an 
existing definition from the model.   

NOTE: Input parameters will change based on the selected material.  Additionally, users should 
define a unique name for each material definition in a model.  Once the material parameters are 
defined in the “Material Property dialog”, the user should select “Save & Exit” to store the new 
material property to the model. 
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Figure 4-12: Material property dialog for linear elasticity model 

4.4.1 Linear Elasticity  

Material parameters for the linear elasticity model include unit weight, Young's Modulus, and 
Poisson's Ratio (as shown in Figure 4-12). Young's Modulus and Poisson’s Ratio should be defined 
appropriately. If gravity load is not considered, the unit weight can be input as zero. 

The behavior of soil materials is rarely close to that of linear materials except when the load is 
very small.  However, structural elements such as retaining walls, culverts, or piles are typically 
made up of concrete or steel, and exhibit linear elastic behavior to a certain degree. In most cases 
these structural elements can be modeled using the linear elastic material.  

4.4.2 Tresca Plasticity  

Tresca plasticity assumes that yielding occurs when the maximum shear stress reaches a critical 
value. This yielding function is defined in the equation below: 

𝚽𝚽 = 𝝉𝝉𝒚𝒚 −
𝟏𝟏
𝟐𝟐

(𝝈𝝈𝒎𝒎𝒎𝒎𝒎𝒎 − 𝝈𝝈𝒎𝒎𝒎𝒎𝒎𝒎) 

(4.4-1) 

Where, 𝜎𝜎𝑚𝑚𝑚𝑚𝑚𝑚 and 𝜎𝜎𝑚𝑚𝑚𝑚𝑚𝑚 are the maximum and minimum principal stresses. 

Figure 4-13 shows the input parameters required for the Tresca plasticity model. Young's 
Modulus, Poisson’s Ratio, and yielding stress should be defined appropriately. If gravity loading is 
not considered, the unit weight can be zero.  

The Tresca yielding criterion is pressure insensitive which means that hydrostatic pressure does 
not change the yielding stress. Therefore, Tresca plasticity is applicable for studying behavior of 
metal materials. It is seldom used to simulate soil behavior in geotechnical engineering. 
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The option "use field variable" is available with the Tresca plasticity model.  

 

Figure 4-13: Material property dialog for Tresca plasticity model 

4.4.3 von Mises Plasticity  

The von Mises plasticity model assumes that yielding occurs when the equivalent tensile stress, 
or equivalent von Mises stress, 𝜎𝜎𝑣𝑣, reaches the yield stress, 𝜎𝜎𝑦𝑦. This yielding function is defined in 
the equation below: 

𝚽𝚽 = 𝝈𝝈𝒚𝒚 − �𝟑𝟑
𝟐𝟐

[(𝝈𝝈𝟏𝟏 − 𝝈𝝈𝟐𝟐)𝟐𝟐 + (𝝈𝝈𝟐𝟐 − 𝝈𝝈𝟑𝟑)𝟐𝟐 + (𝝈𝝈𝟑𝟑 − 𝝈𝝈𝟏𝟏)𝟐𝟐] 

(4.4-2) 

Where, 𝜎𝜎1, 𝜎𝜎2 and 𝜎𝜎3 are principal stresses. The material parameters are displayed in Figure 4-14. 
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Figure 4-14: Material property dialog for von Mises plasticity model 

Young's Modulus, Poisson’s Ratio, and yielding stress should be defined appropriately. If gravity 
loading is not considered, the unit weight can be zero. 

Similar to the Tresca plasticity model, the von Mises yielding criterion is also pressure insensitive. 
Consequently, it is recommended that this plasticity model should only be used for metal 
materials. Occasionally, the behavior of undrained saturated clay can be properly simulated by 
the von Mises plasticity model. 

The option "use field variable" is available with the von Mises plasticity model.  

4.4.4 Mohr-Coulomb Plasticity 

The Mohr-Coulomb plasticity model assumes that yielding is the result of frictional sliding 
between material particles. The yielding criterion of Mohr-Coulomb plasticity is as follows: 

𝚽𝚽 = (𝝈𝝈𝒎𝒎𝒎𝒎𝒎𝒎 − 𝝈𝝈𝒎𝒎𝒎𝒎𝒎𝒎) + (𝝈𝝈𝒎𝒎𝒎𝒎𝒎𝒎 + 𝝈𝝈𝒎𝒎𝒎𝒎𝒎𝒎) 𝐬𝐬𝐬𝐬𝐬𝐬𝝓𝝓 − 𝟐𝟐𝒄𝒄𝐜𝐜𝐜𝐜𝐜𝐜𝝓𝝓 

(4.4-3) 

Where, 𝜎𝜎𝑚𝑚𝑚𝑚𝑚𝑚 and 𝜎𝜎𝑚𝑚𝑚𝑚𝑚𝑚 are the maximum and minimum principal stresses, 𝜙𝜙 is the friction angle 
and 𝑐𝑐 is the cohesive strength. 

Material parameters for the Mohr-Coulomb model are shown in Figure 4-15 . 
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Figure 4-15: Material property dialog for Mohr-Coulomb plasticity model 

Young's modulus, Poisson’s Ratio, cohesion, friction angle, and dilation angle are required for this 
model. Both angles have units of degrees. If gravity loading is not considered, the unit weight can 
be zero. 

The dilation angle can be equal to or different from the friction angle. If both angles are equal, an 
associated flow rule is applied. Otherwise, a non-associated flow rule will be used. 

The option "use field variable" is available with the Mohr-Coulomb plasticity model.  

Since the Mohr-Coulomb model is pressure sensitive and parameters are easy to obtain from the 
laboratory tests, this model is suitable to soil materials and is widely used in geotechnical 
engineering.  

4.4.5 Drucker-Prager Plasticity 

The Drucker-Prager plasticity model is proposed to smooth the flow rule and can be regarded as 
a smoothed approximation of the Mohr-Coulomb model. The yield criterion is defined as: 

𝚽𝚽 = 𝜶𝜶𝑰𝑰𝟏𝟏 + �𝑱𝑱𝟐𝟐 − 𝒌𝒌 

(4.4-4) 

where 𝐼𝐼1 is the first invariant of the stress tensor, and  𝐽𝐽2 is the second invariant of the deviatoric 
stress tensor. Parameters 𝛼𝛼  and 𝑘𝑘  are determined from criterion matching with the Mohr-
Coulomb plasticity model. 
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Figure 4-16: Material property dialog for Druker-Prager plasticity 

Parameters for the Druker-Prager plasticity model are shown in Figure 4-16. These parameters 
are similar with those used by the Mohr-Coulomb plasticity model (Young's modulus, Poisson’s 
Ratio, cohesion, friction angle, and dilation angle). The Druker-Prager plasticity model should 
match the Mohr-Coulomb model criteria based on how the following parameters 𝛼𝛼 and 𝑘𝑘 are 
determined: 

• Match the outer apex of the yielding surface on the 𝜋𝜋 plane of the Mohr-Coulomb criteria 

𝜶𝜶 =
𝟐𝟐 𝐬𝐬𝐬𝐬𝐬𝐬𝝓𝝓

√𝟑𝟑(𝟑𝟑 − 𝐬𝐬𝐬𝐬𝐬𝐬𝝓𝝓)
, 

(4.4-5) 

𝒌𝒌 =
𝟔𝟔𝒄𝒄 𝐜𝐜𝐜𝐜𝐜𝐜𝝓𝝓

√𝟑𝟑(𝟑𝟑 − 𝐬𝐬𝐬𝐬𝐬𝐬𝝓𝝓)
. 

(4.4-6) 

• Match the inner apex of the yielding surface of the Mohr-Coulomb criteria: 

𝜶𝜶 =
𝟐𝟐 𝐬𝐬𝐬𝐬𝐬𝐬𝝓𝝓

√𝟑𝟑(𝟑𝟑 + 𝐬𝐬𝐬𝐬𝐬𝐬𝝓𝝓)
, 

(4.4-7) 

𝒌𝒌 =
𝟔𝟔𝒄𝒄 𝐜𝐜𝐜𝐜𝐜𝐜𝝓𝝓

√𝟑𝟑(𝟑𝟑 + 𝐬𝐬𝐬𝐬𝐬𝐬𝝓𝝓)
. 

(4.4-8) 
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• Plane strain matching:  

𝜶𝜶 =
𝐭𝐭𝐭𝐭𝐭𝐭𝝓𝝓

�𝟗𝟗 + 𝟏𝟏𝟏𝟏 𝐭𝐭𝐭𝐭𝐭𝐭𝟐𝟐 𝝓𝝓
 , 

(4.4-9) 

𝒌𝒌 =
𝟑𝟑𝒄𝒄

�𝟗𝟗 + 𝟏𝟏𝟏𝟏 𝐭𝐭𝐭𝐭𝐭𝐭𝟐𝟐 𝝓𝝓
 . 

(4.4-10) 

Where, 𝜙𝜙 is the friction angle and 𝑐𝑐 is the cohesive strength. 

The option "use field variable" is available with the Drucker-Prager plasticity model.  

4.4.6 Duncan-Chang Hyperbolic Elasticity 

This model assumes that the stress-strain relationship is nonlinear. This nonlinear curve can be 
accurately approximated by a hyperbola. Figure 4-17 shows the parameter input window for the 
Duncan-Chang hyperbolic elastic model. Users have an option to choose "E-υ model" (control 
Poisson ratio) or "E-B model" (control bulk modulus). The tangent modulus 𝐸𝐸𝑡𝑡 is calculated from 
following equation: 

𝑬𝑬𝒕𝒕 = �𝟏𝟏 − 𝑹𝑹𝒇𝒇𝑺𝑺�
𝟐𝟐𝑲𝑲𝑷𝑷𝒂𝒂 �

𝝈𝝈𝟑𝟑
𝑷𝑷𝒂𝒂
�
𝒏𝒏

 

(4.4-11) 

where 𝑆𝑆 is the stress level given by: 

𝑺𝑺 =
(𝟏𝟏 − 𝐬𝐬𝐬𝐬𝐬𝐬𝝓𝝓)(𝝈𝝈𝟏𝟏 − 𝝈𝝈𝟑𝟑)
𝟐𝟐𝒄𝒄 𝐜𝐜𝐜𝐜𝐜𝐜𝝓𝝓 + 𝟐𝟐𝝈𝝈𝟑𝟑 𝐬𝐬𝐬𝐬𝐬𝐬𝝓𝝓

. 

(4.4-12) 

And, 

𝐾𝐾  =  modulus number 
𝑛𝑛  =  modulus exponent number 
𝑅𝑅𝑓𝑓  =  failure ratio 
𝑐𝑐  =  cohesive strength 
𝜙𝜙  =  friction angle 
𝜎𝜎1,𝜎𝜎3  =  major and minor principal stresses 
𝑃𝑃𝑎𝑎  =  atmosphere pressure 
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When defining parameters for the Duncan-Chang model, 𝜎𝜎1 and 𝜎𝜎3 should be compressive and 
input as positive numbers. If nonlinearity of the friction angle is considered, it can be determined 
from the following equation: 

𝝓𝝓 = 𝝓𝝓𝟎𝟎 − 𝒅𝒅𝒅𝒅 ∙ 𝐥𝐥𝐥𝐥𝐥𝐥 �
𝝈𝝈𝟏𝟏
𝑷𝑷𝒂𝒂
� 

(4.4-13) 

The failure ratio is given by the following relationship: 

𝑹𝑹𝒇𝒇 =
(𝝈𝝈𝟏𝟏 − 𝝈𝝈𝟑𝟑)𝒇𝒇
(𝝈𝝈𝟏𝟏 − 𝝈𝝈𝟑𝟑)𝒖𝒖

 

(4.4-14) 

Where, 

(𝜎𝜎1 − 𝜎𝜎3)𝑓𝑓  =  stress difference at failure 
(𝜎𝜎1 − 𝜎𝜎3)𝑢𝑢  =  asymptotic value of stress difference. 

 

Figure 4-17: Material property dialog for Duncan-Chang hyperbolic elasticity model 

In the case of unloading, the tangent modulus is replaced by the unloading modulus:  

𝑬𝑬𝒖𝒖𝒖𝒖 = 𝑲𝑲𝒖𝒖𝒖𝒖𝑷𝑷𝒂𝒂 �
𝝈𝝈𝟑𝟑
𝑷𝑷𝒂𝒂
�
𝒏𝒏
 

(4.4-15) 
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If "E-υ model" is selected, the tangent Poisson ratio is determined from the following: 

𝝊𝝊 =
𝑮𝑮 − 𝑭𝑭𝐥𝐥𝐥𝐥 �𝝈𝝈𝟑𝟑𝑷𝑷𝒂𝒂

�

𝟏𝟏 − 𝑫𝑫(𝝈𝝈𝟏𝟏 − 𝝈𝝈𝟑𝟑)

𝑲𝑲𝑷𝑷𝒂𝒂 �
𝝈𝝈𝟑𝟑
𝑷𝑷𝒂𝒂
�
𝒏𝒏
�𝟏𝟏 − 𝑹𝑹𝒇𝒇𝑺𝑺�

 

(4.4-16) 

Otherwise if "E-B model" is selected, tangent bulk modulus is computed as: 

𝑲𝑲𝒕𝒕 = 𝑲𝑲𝒃𝒃𝑷𝑷𝒂𝒂 �
𝝈𝝈𝟑𝟑
𝑷𝑷𝒂𝒂
�
𝒎𝒎

 

(4.4-17) 

Where, 𝐾𝐾𝑏𝑏  is the modulus number for the bulk modulus and 𝑚𝑚  is the modulus exponent of 
𝐾𝐾𝑏𝑏 (used to define the initial modulus). 

The parameter 𝜎𝜎3  represents the minor pre-consolidation stress in the stress history. This 
parameter must be bigger than 0.0 to start computation. 

4.4.7 Modified Cam-Clay  

The modified cam-clay model is a plastic strain-hardening model based on critical state theory. 
The mean pressure has a logarithmic relationship with the void ratio. Figure 4-18 shows 
parameters required by the modified cam-clay plasticity model in EnFEM. This model allows users 
to select "Constant Poisson Ratio υ" or "Constant Shear Modulus G" from Option 1, and to select 
"Drained" or "Undrained" from Option 2. Other parameters are defined as follows: 

 Unit Weight, γ 
 Lambda, λ = slope of normal consolidation line 
 Kappa, κ = slope of swelling line 
 CSL Slope, 𝑀𝑀 = slope of critical state line (p-q line) 
 Specific Vol, 𝑁𝑁 = specific volume at unit consolidation stress. 
 𝜈𝜈 = Poisson ratio 
 OCR = over consolidation ratio.  

a. NOTE: Normally consolidated or lightly over-consolidated soil is 
supported in EnFEM. 

In Figure 4-18, additional options are shown for the initial soil stress.  The user may use the “Use 
Default” setting or set the two extra parameters required: Initial Young's Modulus and Initial 
Poisson’s Ratio. These two parameters are only used for setting the initial soil stress.  Based on 
the assumed mean pressure, 𝑝𝑝, and the over-consolidation ratio, the Initial Young's Modulus can 
be estimated with the following steps: 
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 Calculate the specific volume corresponding with the assumed mean pressure 𝑝𝑝 

𝚪𝚪 = 𝑵𝑵− 𝝀𝝀log(𝒑𝒑𝒄𝒄) − 𝜿𝜿log �
𝒑𝒑
𝒑𝒑𝒄𝒄
� 

(4.4-18) 

 Calculate the bulk modulus  

𝑲𝑲 =
𝚪𝚪
𝜿𝜿
𝒑𝒑 

(4.4-19) 

 Calculate the Young's modulus 

𝑬𝑬 = 𝟑𝟑𝑲𝑲(𝟏𝟏 − 𝟐𝟐𝝂𝝂) 

(4.4-20) 

The Initial Poisson’s Ratio has another function to control lateral stresses for normally 
consolidated or lightly over-consolidated soil. The lateral stress factor 𝐾𝐾0  has the following 
relationship with the initial Poisson’s ratio: 

𝑲𝑲𝟎𝟎 =
𝝂𝝂

𝟏𝟏 − 𝝂𝝂
 

(4.4-21) 

 

Figure 4-18: Material property dialog for modified cam-clay plasticity model 
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4.4.8 Using Field Variables 

The option "Use Field Variable" is available for use with the Tresca, von Mises, Mohr-Coulomb, 
and Druker-Prager models. This option lets users control and apply a pattern of change for 
specified material properties. This option is typically used for slope stability analysis using the 
strength reduction method. In the “Material Property dialog”, “check” the box next to the label, 
to activate the "Edit" button. Then, click "Edit" to open the “Input Field Variable dialog” to define 
the pattern of change in the material properties - like that as seen in Figure 4-19. 

  

Figure 4-19: Definition of field variable 

“Add line” adds a data line to the end of the list.  “Insert line” adds a data line below the row in 
which the cursor is placed. “Delete Line”, removes the row in which the cursor is placed.  

Figure 4-19 shows an example of a material strength reduction pattern used in a slope stability 
analysis. This data is taken from Example 3 – Analysis of Slope Stability Using Strength Reduction 
Factor, of the Example Manual. Data in the column "Field Variable" represents different Factor’s 
of Safety. Data in the “cohesion”, “friction angle”, and “dilation angle” columns represent 
corresponding "reduced" values. The original value of cohesion in this example is equal to 
35000Pa. If the safety factor is assumed to be 1.4, the reduced cohesion at this point will be 
calculated as: 

𝟑𝟑𝟑𝟑𝟑𝟑𝟑𝟑𝟑𝟑 𝑷𝑷𝑷𝑷
𝟏𝟏.𝟒𝟒

= 𝟐𝟐.𝟓𝟓 × 𝟏𝟏𝟏𝟏𝟒𝟒𝑷𝑷𝑷𝑷 

(4.4-22) 

Similarly, the original friction angle is equal to 25°. When the factor of safety is 1.4, the 
reduced friction angle is calculated as: 

𝐚𝐚𝐚𝐚𝐚𝐚𝐚𝐚�
𝐭𝐭𝐭𝐭𝐭𝐭(𝟐𝟐𝟐𝟐°)
𝟏𝟏.𝟒𝟒 � = 𝟏𝟏𝟏𝟏.𝟒𝟒𝟒𝟒𝟒𝟒𝟒𝟒° 

(4.4-23) 
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If either the “Tresca” or “von Mises” plasticity models are used, only the column "Cohesion" 
in Figure 4-19 will be available. 

4.5 Assigning Material Properties 
After material properties have been defined, the next procedure is to associate the created 
materials with region-objects in the model. From the menu bar, click “Data->Material 
Assignment” to open the “Material Assignment dialog” as shown in Figure 4-20. 

 

Figure 4-20: Window to assign material property to region objects 

Two options are available to assign materials to corresponding region entities: "By Region" and 
“By Set”. Note that if using the “By Set” option, a region selection-set must be previously defined.  
More information on defining selection-sets can be found CHAPTER 5, of this manual.  

4.5.1 Assignment “By Region” 

If “By Region” is selected, a list of all available regions within the model are shown in the “Region 
List” window.  The regions are listed with a numerical identity (“Region#”). The following 
procedures outline this assignment process: 

 Select the desired region from the “Region List” 
a. Once selected the region will be highlighted in Cyan color 

 Select a previously defined material from the “Material Group” drop down list. 
 Click “Assign”. 

a. Once assigned the region will be highlighted in Purple color. 
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b. Note that details about the current assignment for the selected region, 
are displayed next to the “Region List”. 

4.5.2 Assignment “By Set” 

If “By Set” is selected, a list of all available region-sets within the model are shown in the “Set List” 
window.  Note that a region selection-set must be previously defined. The following procedures 
outline this assignment process: 

 Select the desired region from the “Set List” 
a. Once selected the whole set will be highlighted in Cyan color 

 Select a previously defined material from the “Material Group” drop down list. 
 Click “Assign”. 

a. Once assigned the whole set will be highlighted in Purple color. 
b. Note that details about the current assignment for the selected set, are 

displayed next to the “Set List”. 

4.5.3 Other Details 

If a region is already associated with a material, the "Assign" button will be not active. In this case 
the user will click “Update” to override the existing assignment. 

The button "Show All Assign." is used to display all material assignments in a representative color 
(Figure 4-21). The following colors are used to represent their respective materials: 

•  Linear elasticity model 

•  Tresca plasticity model 

•  von Mises plasticity model 

•  Mohr-Coulomb plasticity model 

•  Drucker-Prager plasticity model 

•  Duncan-Chang hyperbolic elasticity model 

•  Modified Cam-Clay model 

•  no material property assigned 

If the option "Show Region Name" is checked, the name of each region (i.e. Region 1) will be 
displayed on screen. 
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Figure 4-21: Material assignment shown with representative colors 

4.6 Boundary Conditions 
Boundary conditions in EnFEM include both, displacement conditions and stress/force conditions. 
A specialty interaction (contact) condition is also included for modeling soil-structure interaction, 
but is discussed separately in CHAPTER 6. From the menu bar, click “Data->Boundary Condition” 
to open the “Boundary Condition Group Management dialog” as shown in Figure 4-22. 

 

Figure 4-22: Boundary Condition Group Management dialog 
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Click "New" to create a new boundary condition definition. Select an existing definition from the 
B.C Group list and click "Edit" to modify it. Select a definition from the B.C Group list and click 
"Delete" to remove the unwanted boundary condition from the model. 

Clicking "New" will open the specific “Boundary Condition dialog”, as seen in Figure 4-23. Define 
a unique name for the B.C, select the specific “B.C Type”, and enter in the associated input 
parameters. Clicking “Save & Exit” will finish the definition. 

 

Figure 4-23: Boundary Condition dialog. 

For a FE analysis in geotechnical engineering, various boundary conditions are essential, such as 
gravity loads, external loading along geometry edges, and/or displacement constraints on edges 
or vertices.  Only a 2D geometric object (region) and its dependent entities (vertices, lines, arcs) 
are available for boundary condition assignments.  The drop box with the label “B.C. Type” 
includes six predefined boundary conditions, which will be covered in the following sections. 

4.6.1 Point Displacement  

The point displacement condition, is a displacement constraint applied to a dependent vertex, in 
the X and/or Z-directions. 

 

Figure 4-24: Point displacement B.C options 

The constraint is activated when the box associated with either direction is checked - as shown in 
Figure 4-24. Once active, the user may enter in the desired numerical value for the constraint.  
Positive X-values are to the right, and positive Z-values are upward. 
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4.6.2 Edge Displacement (orthogonal)  

The edge displacement (orthogonal) condition, is a displacement constraint applied to a 
dependent edge in the X and/or Z-directions.  In this case, the edge of the geometry must be 
parallel to the vertical or horizontal axis (aligned in an orthogonal direction).  

 

Figure 4-25: Edge displacement (orthogonal) B.C. options 

The constraint is activated when the box associated with either direction is checked - as shown in 
as in Figure 4-25. Once active, the user may enter in the desired numerical value for the constraint.  
Positive X-values are to the right, and positive Z-values are upward. 

Orthogonal displacement boundary conditions do not perform local-coordinate transitions, which 
improves solver performance, and are highly recommended if possible. 

4.6.3 Edge Displacement (inclined) 

The edge displacement (inclined) condition, is a displacement constraint applied to a dependent 
edge in the “normal” and/or “tangent” directions of an inclined edge (not aligned in an orthogonal 
direction). This definition is shown in Figure 4-26. 

  

Figure 4-26: Edge displacement (inclined) B.C. options 

The constraint is activated when the box associated with either direction is checked. If only 
“normal to edge” is checked, this B.C. is equivalent to a roller, constraining displacement in the 
direction normal to the edge. If both “normal” and “tangent” are checked, this B.C. will constrain 
the edge in both directions. Displacements pointing toward the inside of the region represent 
positive values for the normal direction. While displacements in a counterclockwise direction, 
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with respect to the region center, represent positive values for the tangent direction.  While 
available for use, the latter constraint (tangent) is rare in engineering practice 

4.6.4 Concentrated Force 

The concentrated force condition, is a force constraint (loading) applied to a dependent vertex of 
a region.  

  

Figure 4-27: Concentrated force B.C. options 

The constraint is activated when the box associated with either direction is checked - as shown in 
Figure 4-27. Once active, the user may enter in the desired numerical value for the constraint. 
Positive X-values are to the right, and positive Z-values are upward. 

This constraint cannot be assigned to finite element nodes. 

4.6.5 Surface Load 

The surface load condition, is a force constraint (loading) applied to a dependent external edge of 
a region. Surface load boundary conditions have two options: normal (pressure) and tangent 
(shear) as shown in Figure 4-28. Units for the surface load should be “Force/Sq. Unit Length”. 

 

Figure 4-28: Surface stress B.C. on edge 

The constraint is activated when the box associated with either direction is checked - as shown in 
Figure 4-28. Once active, the user may enter in the desired numerical value for the constraint. In 
EnFEM, edges of a region have counterclockwise directional path associated with them, about the 
region center, from “start” to “end”.  
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Figure 4-29: Positive directions of surface load B.C. 

A positive pressure is defined in the direction towards the inside of the region (Figure 4-29). 
Positive or negative values represent compressive or tensile forces on the surface respectively. A 
positive shear is defined in the counterclockwise direction, about the region center. 

Both pressure and shear options have two inputs: “start” and “end”. The “start” of the constraint 
is displayed visually, by a yellow circle at the starting vertex, while the “end” of the constraint is 
displayed visually with a blue circle at the ending vertex (Figure 4-29). If different values are 
entered for the “start” and “end” inputs, the force will vary linearly from “start” to “end”. 

NOTE:  Pressure or shear inputs in Figure 4-28 may vary from zero (start) to a positive or negative 
value (end), or vice-versa.  However, variations from a positive value (start) to a negative value 
(end), or a negative value (start) to a positive value (end), are not supported.  

4.6.6 Body Force/Gravity 

The body force/gravity condition, is a force constraint (loading) applied to a region object in the 
X and/or Z-directions.  

 

Figure 4-30: Body force/gravity B.C. definition 

The constraint is activated when the box associated with either direction is checked - as shown in 
as in Figure 4-30.  Once active, the user may enter in the desired numerical value for the 
constraint. Positive X-values are to the right, and positive Z-values are upward. 
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A common use of this condition is to apply gravity, or self-weight, to the region. In this case, to 
define the gravity load, the value input for the Z-direction (Figure 4-30) should be "-1". This 
assumes, that the unit weight of the material is defined as a positive value (in material property 
definition).  Here the symbol "-" represents that force is in the negative Z-direction (downward). 

4.6.7 Limitations to Modify Existing Boundary Conditions 

As mentioned previously users can modify previously defined boundary conditions from the 
“Boundary Condition Group Management dialog”, as shown in Figure 4-22.  Select an existing 
definition from the B.C Group list and click "Edit" to modify it. It should be noted however, that 
only the name, values, and active directions (i.e. X or Z) can be modified. Switching to another 
boundary condition type is not currently allowed and will produce and error message if 
performed. If it is necessary to define a new type of boundary condition, the user should create 
an entirely new boundary condition definition and delete the unused existing condition.  

4.7 Applying Boundary Conditions to Geometry 
After boundary conditions are created, then next step in building the analysis model is to associate 
the created conditions with the appropriate geometric objects. The previous sections defined the 
applicable geometry for each specific boundary condition definition. In general, all boundary 
condition conditions, except for the “body force/gravity” condition, are applied to external edges, 
or vertices on external edges of a region. This includes the edges of an internal void (hole), which 
is also regarded as an external edge. Boundary conditions cannot be applied to an edge shared by 
an adjacent region of the same geometry-set. 

From the menu bar, click “Data->Boundary Assignment” to open the “Boundary Condition 
Assignment dialog” as shown in Figure 4-31. All available boundary condition definitions are 
displayed in the “B.C. Group” window on the left-hand side of this dialog. The following outlines 
the procedure to assign a boundary condition to the geometry: 

 Select a boundary condition from the “B.C. Group” window. 
 Select the starting stage from the “BC Starts from Stage” drop down list. 

a. All available stages (previously defined) will be listed here for selection. 
b. NOTE: The life of a boundary condition starts from the beginning of the 

selected stage and persists to the final stage. 
 Click “Assign”. 

a. Depending on the B.C selected, the appropriate selection icon will be 

automatically activated ( , , or ). 
 Following the command prompt (below the working zone), select the appropriate 

geometry (vertex, edge, or region), on which the condition shall be applied to. 
a. Hold SHIFT while LEFT-CLICKING to select multiple geometries if 

necessary. 
i. NOTE: If multiple selections are made, the whole BC is applied to 

each selection. For example, assume a surface load condition of 



CHAPTER 4 – Control Data, Stages, Material Properties, & Boundary Conditions – 4-29 
 

User’s Manual (Rel. May/2019)  EnFEM for Windows 

35-psi. If 2-edges are selected to apply this BC to, each edge will 
have a load of 35-psi. 

 
 

 RIGHT-CLICK and select "End Selection" from the popup menu. 
a. After the assignment is made, “Boundary Condition Information” will be 

displayed at the right of the “Boundary Condition Assignment dialog”.  In 
addition, a visual icon will be displayed, representing the condition, at the 
specific location on the geometry. 

 

Figure 4-31: Boundary condition assignment dialog 

If users are not satisfied with a previously defined assignment, select it from the “B.C. Group” 
window, and click "Del Assign" to clear corresponding stage and geometric objects assignment. 
The condition can then be re-assigned as needed following the previously mentioned steps. 

If the boundary condition has been applied to any geometric entities, when selecting from the 
“B.C. Group” list, a corresponding B.C. symbol will be displayed and the geometry highlighted in 
orange. EnFEM has following boundary condition symbols: 

 
‘roller’ on orthogonal edge 

 
‘pin’ on orthogonal edge 

 
‘pin’ on vertex 

 
concentrated force on vertex 
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‘roller’ on inclined edge 

 
‘pin’ on inclined edge 

 
surface load on edge 

 
shear load on edge 

 

Clicking “Show All”, in the bottom left corner of the “Boundary Condition Assignment dialog”, will 
display all applied boundary conditions simultaneously. This display provides a convenient visual 
check for the user, to confirm that boundary conditions have been correctly defined and assigned 
(Figure 4-32). 

 

Figure 4-32: “Show all” B.C. for a visual check 

After applying a “body force/gravity” to a selected region, the corresponding region will be 
highlighted in a beige color and orange arrows will be marked at each vertex to indicate the force 
direction - as shown in Figure 4-33. 
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Figure 4-33: Example applied Body Force/Gravity B.C. 

It is possible to apply the “body force/gravity” B.C. in incremental fashion if desired, by using 
multiple Stage and B.C definitions. However, the sum of the increments should be equal to 1.
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5.1 Introduction 
A selection-set in EnFEM provides users a convenient way to group geometric entities for various 
uses. These groups can be collections of regions, edges, or vertices. Defined sets can then be used 
to display and hide specific regions, to assign materials, and for post processing - such as plotting 
result curves along a defined edge-set. Additionally, soil-structure interaction analysis often 
involves different materials with properties that may be drastically different, usually soil and 
concrete. Resulting stresses in concrete are much higher than those in soil, making it difficult to 
visually identify the soil stresses in a contour plot clearly. Using an individual “selection-set” for 
the soil and concrete regions, allows the user to hide this concrete region and plot the contour on 
the soil independently, and providing a clearer picture of the desired result.  These techniques are 
shown in detail with practical use cases in the EnFEM Example Manual.  

The following sections detail the use of the “Set Tool” and the “Display Tool” used for “selection-
sets”. 

5.2 Set Tool 

Operations to create a selection-set are only available in “CAD-mode”. Click  to switch to 
“CAD-mode” if necessary. From the menu bar, click "Tools->Set Tool" to open the “Set Definition 
dialog” window (Figure 5-1). 

 

Figure 5-1: Define sets in EnFEM 

5.2.1 Define a New Set:  

Procedures to define a new selection-set are as follows: 

 Select the appropriate “Set Option”  
 Input a unique “Set Name”.  

a. The “Set Description” is optional.  
 Click "Add Set".  

a. Depending on the “Set Option” the appropriate selection icon will be 

automatically activated ( , , or ). 
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b. NOTE: If the “Set Option” is set to "ALL", users will need to manually 
activate the necessary selection icons. 

 Select the desired entities to add to the selection-set, based on the “Set Option”. 
a. Hold SHIFT while LEFT-CLICKING to select multiple geometries if 

necessary. 
 RIGHT-CLICK and select "End Selection" from the popup menu to finish the set 

creation.  

After definitions are made, each new selection-set will be listed in the “Set Group window” at the 
left of the dialog.  Clicking through the “Set Option” choices, will change the “Set Group window” 
to display each defined set for a specific “Set Option”. 

5.2.2 Delete an Existing Set: 

Procedures to delete an existing selection-set are as follows: 

 Select a set from the “Set Group window”.  
a. Notice that the set-information (name, description) are displayed.  

 Click "Delete Set".  
 Click “Yes” at the warning message to continue the operation. 

The selection-set will then be removed from the model database. 

5.2.3 Update an Existing Set: 

Procedures to update an existing selection-set are as follows: 

 Select a set from the “Set Group window”.  
a. Notice that the current set-information (name, description) is displayed.  

 Change the “Set Name” and “Set Description”, if desired 
 Click "Update Set". 
 Reselect geometric entities, if necessary. 
 RIGHT-CLICK and select "End Selection" from the popup menu to finish the 

update. 

If users wish to only update the “Set Name” and “Set Description”, without any geometry updates, 
the previous steps should still be taken, but Step 4 (geometry selection) can be skipped. 

NOTE: Clicking on the “Set Name” will highlight the corresponding geometry objects associated 
with the selected “Set”.  However, if a “Set” has no object associated with it, then a warning 
message will appear. 
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5.3 Display Tool 
After creating region-sets, users are able to control whether those sets are displayed or hidden 

using the “Display Tool”.  From the menu bar, click "Tools->Display Tool", or click the  icon 
from the toolbar, to open the “Display Control dialog” window as seen in Figure 5-2.  

 

Figure 5-2: Display control by set group 

Note that only region sets are displayed in the set group. Select a set from "Set Group" and click 
"Display" to display region objects defined in this selected set and hide all other region objects. 
Clicking "Hide" will hide region objects defined in the selected set and display all other region 

objects. The "Display All" button, or  icon, is used to display all region objects in the model 
simultaneously. Display control by set group is available in both “CAD-mode” and “Result-mode”. 
It is not available in “Mesh-mode”.  
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6.1 Introduction 
The “interaction” boundary condition defines how two adjacent regions behave with one another. 
By default, when the mesh of two adjacent regions is created, the two bodies automatically act 
as a perfectly bonded pair (through shared nodes on the common edge). Interactions between 
structures and soil materials are commonplace in geotechnical engineering. Some well-known 
examples of those interactions are between soil-culvert, soil-retaining wall, and soil-pile 
configurations. Also referred to as ‘contact analysis’, generally, an interaction analysis in 
geotechnical engineering involves two materials with significant differences in their material 
properties. The object of softer material is defined as the "slave body". The second object, of a 
stiffer material, is defined as the "master body". In general, interactions occur between the "slave 
surface" and the "master surface". The interaction algorithm in EnFEM employs the well-known 
"Node-to-Segment" method. In other words, slave surfaces are represented by a series of “slave-
nodes” and master surfaces are represented by a series of “master-segments” after discretization 
(mesh creation). In EnFEM, linear finite elements, Q4 or T3, should be used when interaction 
conditions are defined. 

EnFEM does not allow the existence of gaps along the interface surface (edge), so there should 
be exact overlap (one dependent edge on top of the other) between master and slave surfaces. 

6.2 Interaction Definition Management 
Interactions should be defined after creating all region objects and necessary region selection-
sets. In “CAD-mode”, from the menu bar, click "Data->Interaction" to open the “Interaction Group 
Management dialog” window as shown in Figure 6-1. 

 

Figure 6-1: Dialog of Interaction Group Management 

Click "New" to create a new interaction definition. Select an existing definition from the 
“Interaction Group” list and click "Edit" to modify it. Select an existing interaction definition from 
the “Interaction Group” list and click "Delete" to remove the unwanted definition from the model. 
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6.2.1 New Interaction Definition 

When a new interaction definition is created, the “Interaction dialog” window will open to let 
users define the new condition (Figure 6-2). Users should perform the following procedures to 
define the condition: 

 Enter in the name of the condition.  
 Select the desired “Interface Option.” 
 Enter the appropriate “Coefficient of Friction” (if necessary). 
 Click “Add Master Surf.” and “Add Slave Surf.” to define the interaction 

geometry. 

a. Click “Add Master/Slave Surf.” (note that the line selection icon,  is 
automatically activated), make the appropriate geometry selections, and 
then RIGHT-CLICK and select “End Selection” from the popup menu. 

b. It is recommended to use the “Display Tool” and “Zoom-In/Out” 
operations to hide/display appropriate regions in order to make selection 
of the interface geometry easier. 

 Click "Save & Exit" to exit from the “Interaction dialog” window. 

 

Figure 6-2: Create a new interaction group 

6.2.1.1 Interface Options 
There are three options to define the behavior of the interaction surfaces: “contact”, “tie”, or 
“free-face”.  

6.2.1.1.1 Contact Option 
The "contact" option can simulate real mechanical behaviors on the interface like sliding, normal 
pressure (without penetration), and separations. The condition consists of a Normal and Tangent 
“contact status”. The Normal contact status will be either a “separation” (gap) or “in-contact”. 
The Tangent contact status will be either “sticking” or “sliding”.  
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6.2.1.1.2 Tie Option 
The "tie" option is used to perfectly bond two bodies together along the common interface 
surface. Finite element nodes on the tied interface will have exactly the same displacements in 
both the X and Z-directions. This behavior is similar to a perfectly bonded condition of the mesh 
(if no interaction condition were applied). However, with a “tie” interaction condition applied, the 
user will be able to see the various output options of the interaction condition.  In addition, a 
“tied” connection will not have convergence issues that a “contact” connection may face. 
Therefore the “tie” option may be used temporarily on the interaction interface in order to help 
quickly troubleshoot any convergence issues in the model, before easily switching back to the 
“contact” option for the real case. 

6.2.1.1.3 Free-Face Option 
The "free-face" option is used to create independent edges, and is generally used in addition to 
the “contact” option. If the "free-face" option is used, adjacent regions on both sides of the free 
face will have their own independent meshes. Edges defined as a "free-face" provide no 
deformation restraint to one another – allowing both separations and penetrations. This option 
is used generally used to simplify contact interfaces and improve convergence when small edges 
appear in the model, such as the tip of a very long retaining wall or pile, or the tip of a long 
concrete soil nail. This issue, is more noticeable if the geometry at these ‘tip’ edges is a sharp right 
angle rather than using a half-circle for a smoother transition. Using this option, and setting the 
‘tip-edge’ as the free face, may improve convergence performance, if a sharp right angle is used. 

6.2.1.2 Coefficient of Friction 
The coefficient of friction is used only if the “contact” analysis option is selected. It is not used if 
the "tie", or “free-face” options are selected. 

The value of the coefficient of friction varies from 0.0 to 1.0. A coefficient of 0.0 is used for a 
perfectly smooth interface (frictionless). While a coefficient of 1.0 is the allowable maximum 
factor. In geotechnical engineering, the coefficient of friction is often in the range of 0.3 to 0.5. 

6.2.1.3 Master and Slave Surfaces 
As mentioned previously, the interaction algorithm in EnFEM employs is the "Node-to-Segment" 
method. The assignment of the “master” and “slave” surface, are defined here, in the “Interaction 
dialog” window.  Click “Add Master Surf”, select the desired geometry (edges), and RIGHT-CLICK 
and select “End Selection” to complete the assignment – follow the same steps for the “slave” 
surfaces.  “Master” surfaces are highlighted in blue (Figure 6-3), while “slave” surfaces are 
highlighted in green (Figure 6-4).  If a “master” or “slave” surface has been previously or 
mistakenly defined, clicking “Del. Master (or Slave) Surface” will clear the assignment.  Some 
recommendations for the assignment of the “Master-Slave” surfaces are as follows: 

6.2.1.3.1 For the “contact” and “tie” options: 
If the "contact" or “tie” option is used, it is typical for the “master” body (and corresponding 
surface) to be defined as that with the stiffer material of the two interacting bodies, while the 
“slave” should be defined as the body with less stiffness. For example, if a concrete pile is 
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interacting with soil, the concrete should be defined as the “master” body, and the soil the “slave” 
body.  A second reference may be used based on mesh refinement, whereby the “master” body 
(and corresponding surface) is defined as that with less refinement (larger element size), while 
the “slave” should be defined as the body with more refinement (smaller element size). 

6.2.1.3.2 For the “free-face” option: 
In general, either body each side of the adjacent edge, can be defined and the “master” or “slave” 
body if the “free-face” option is selected.  

 

Figure 6-3: Define master interaction surfaces 

 

Figure 6-4: Define slave interaction surfaces 

6.3 Edit Interaction Definition 
This option allows the user to modify an existing interaction definition. Select the desired 
interaction definition from the “Interaction Group Management dialog” window (Figure 6-1) and 
click “Edit” to open the “Interaction dialog” window. Users can then modify the condition as 
desired, including changing the “interface option”, “coefficient of friction”, and reassignment of 
“master” and “slave” surfaces. After editing, click "Save & Exit" to save the changes and return 
back to the “Interaction Group Management dialog” window. 
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6.4 Delete Interaction Definition 
This option allows the user to delete an existing interaction definition. Select the desired 
interaction definition from the “Interaction Group Management dialog” window (Figure 6-1) and 
click “Delete” to remove the definition from the model database. Click "OK" to exit from the 
“Interaction Group Management dialog” window when finished. 
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7.1 Introduction 
Soil excavation is commonly found in many geotechnical engineering projects, such as the 
construction of high-rising building foundations, subway tunnels, slope strengthening, and buried 
culverts. To simulate this construction process in Finite Element Analysis, finite elements need to 
be partially removed to simulate effects of excavation. EnFEM provides the option of element 
deactivation for this type of excavation analysis. 

7.2 Define New Deactivation Condition 

7.2.1 Prerequisite model setup: 

In general, excavation analysis is highly nonlinear and the excavated area should be divided into 
several, thinner sub-regions, to be excavated incrementally. In EnFEM, the following steps are 
necessary before a deactivation condition can be created: 

 Create geometric sub-regions to divide the excavated area in several smaller 
layers. 

 Create region “selection-sets” for each excavated sub-region. 
a. NOTE: It is recommended to name each set according to its excavation 

order (i.e. “excv_set_layer_1”, etc.). 
 In addition to any other stages in the analysis, define a stage (excavation type) for 

each excavated sub-region. 
a. The excavation stages should be after any “initial-stress” stage 
b. NOTE: It is recommended to name each stage according to its excavation 

order (i.e. “excv_layer_1”, etc.). 
 Continue to finish defining any other model parameters (material assignments, 

boundary conditions, etc.). 

7.2.2 Define Deactivation 

With necessary prerequisite conditions met, click "Data->Deactivate” to open the “Deactivation 
dialog” window as shown in Figure 7-1.  The following procedures outline the steps to complete 
the excavation definition in the “Deactivation dialog” window: 

 

Figure 7-1: Region deactivation dialog – During (left) and After (right) 
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 Click the first cell in the “Stage” column, and select the first stage in the analysis 
from the drop-down menu – typically an “Initial-Stress” stage. 

a. Repeat this step incrementally, until all stages of the analysis are listed in 
order, from start to finish. 

 Click each cell in the “Set Deactivate” column, and select the corresponding 
region “selection-set” (previously defined) from the drop-down menu, that will 
be deactivated in the selected “Stage”. 

a. NOTE: If the stage is not of the type, “excavation”, then “None” should 
be selected in the “Set Deactivation” column. 

In reference to Figure 7-1, the first stage, “ints” is an initial-stress stage, and therefore no 
deactivated selection-set is associated with this stage.  Notice that the previously defined 
excavation stages and their corresponding deactivated regions, are defined incrementally until 
the end of the analysis.  

When one region-set is deactivated, its contribution will be removed from total gravity load. Finite 
elements from deactivated regions also have no contribution to the global system stiffness. 
Deactivation of a region will also deactivate related boundary conditions, including contact 
interfaces, automatically. 

Users may preview the defined process by clicking the “Animation” button.  This will cycle 
through the defined deactivation procedure once, and then stop automatically.  Repeat as 
necessary to provide visual confirmation of the deactivation definitions. Click “OK” to finish the 
definition and exit the “Deactivation dialog” window. 

This technique is detailed further in Example 10 – Analysis of Excavation with Cantilever Retaining 
Wall, of the Example Manual 
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8.1 Introduction 
The mesh plays one of the most important roles in finite element analyses. The mesh has a 
significant influence on both the computing efficiency, and the accuracy of results. Too much 
refinement and a large number of elements, yields slower computation times and larger data files 
that may be difficult to manage.  Too few refinements and a smaller number of elements, may 
produce faster results, but those results may lack accuracy.  The key to a quality mesh is to strike 
a balance between these two positions, in which it is generally recommended to create the final 
mesh based on several iterative trials/comparisons to study the effects of the mesh on the actual 
results.  

In EnFEM, the typical workflow involves users determining the mesh type, the element shape, the 
element type and integration rule, global element sizes, and applying any local refinements, 
before generating the finite element mesh. 

8.1.1 Finite Element Types in EnFEM 

Many finite element types have been proposed throughout the history of Finite Element Analysis 
to solve various problems in solid mechanics, fluid dynamics, acoustics, and electronics and 
magnetics. In the field of solid mechanics, stresses and deformations are the primary results of 
interest. Figure 8-1 shows four widely used finite elements in this field, and which are available in 
EnFEM. 

 

Figure 8-1: Types of finite elements used in EnFEM 

The shape of elements in Figure 8-1 can be grouped into two categories: quadrilateral and 
triangular. For each element shape category, there is also one linear, and one quadratic, element 
type.  The quadratic types, include additional nodes at the midpoints of each element edge, rather 
than just those at each endpoint. Elements of the quadrilateral shape are Q4, and Q8 elements. 
Elements of the triangular shape are T3, and T6 elements.  The following sections detail these 
different element types. In addition, more technical detail may be found in the EnFEM Technical 
Manual. 

8.1.1.1 Linear Quadrilateral Element - Q4 
The linear quadrilateral element, or Q4, has four nodes and four straight edges. Nodes are 
counted in the counterclockwise direction. The Gaussian integration rules are illustrated in Figure 
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8-2. The red crosses indicate the Gaussian integration points. The left image represents the full 
Gaussian integration rule, in which four integration points are used. A reduced Gaussian 
integration is shown in the right image, in which the only integration point is located at the center 
of the element. Displacements are interpolated linearly inside the element. Field variables like 
stresses or strains vary linearly (full integration) or are constant (reduced integration), depending 
on the selected integration rule. In general, this element has good performance for most analysis 
types in solid mechanics. If bending behavior is significant, as is the case when simulating beams, 
this element suffers from shear locking when the full integration rule is used. Thus, additional 
refinement of the mesh should be used to reduce the influence of shear locking. 

 

Figure 8-2: Gaussian integration rules for Q4 element 

8.1.1.2 Quadratic Quadrilateral Element - Q8 
The quadratic quadrilateral element, or Q8, has eight nodes and four edges. Nodes are counted 
in the counterclockwise direction, and start with the endpoint nodes before moving to the 
midpoint nodes.  The model geometry edges can be straight or curved initially. In EnFEM, the FE 
edges of Q8 elements are always straight, initially. Gaussian integration rules for the Q8 element 
are displayed in Figure 8-3. The left image represents the full integration rule, with nine 
integration points. The right image shows the reduced rule with four integration points. 
Displacements are interpolated quadratically inside the element. Field variables like stresses and 
strains are interpolated by quadratic functions (full integration) or linear functions (reduced 
integration), depending on the selected integration rule. In general, the reduced rule may be 
considered to have better performance over the full integration rule for most cases in solid 
mechanics. It is accurate, efficient, and does not suffer from shear locking. In EnFEM, if contact 
interfaces are not involved in the analysis, Q8 elements are preferred.  
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Figure 8-3: Gaussian integration rules for Q8 element 

8.1.1.3 Linear Triangular Element - T3 
The linear triangular element, or T3, has three nodes and three straight edges. Nodes are counted 
in the counterclockwise direction. The Gaussian integration rule is shown in Figure 8-4. This 
element has one integration point. Strains and stresses are constant inside the element domain, 
so this type of element is also known as the “constant strain element”.  In general, T3 elements 
also suffer from shear locking and therefore are commonly not considered suitable for flexure 
dominated analyses. Reliable results for this type of stress-analysis often requires a very fine mesh 
if T3 elements are used. 

 

Figure 8-4: Gaussian integration rule for T3 element 

8.1.1.4 Quadratic Triangular Element - T6 
The quadratic triangular element, or T6, has six nodes and three straight edges. Nodes are 
counted in the counterclockwise direction, and start with the endpoint nodes before moving to 
the midpoint nodes. The model geometry edges can be straight or curved initially. In EnFEM, the 
FE edges of T6 elements are always straight, initially. Displacements are interpolated 
quadratically. The Gaussian integration rule is shown in Figure 8-5. These elements use the three-
point integration rule, and generally have much better performance than T3 elements. Stresses 
and strains vary linearly inside the element.  

 

Figure 8-5: Gaussian integration rule for T6 element 
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8.1.2 Structured/Unstructured Mesh 

After defining an element type, users must decide on the structure of the mesh.  Both “structured” 
and “unstructured” meshes are available in EnFEM, and users will define either type for each 
region in the model. Both mesh types can be combined freely in a model with multiple regions, 
but only one mesh type may be defined per region.  Figure 8-6 shows a sample of structured (at 
left) and unstructured (at right) meshes. The structured mesh is such that each internal node has 
fixed number of neighboring nodes. The unstructured mesh is such that the number of 
neighboring nodes around an internal node is undetermined. 

 

Figure 8-6: Structured and unstructured meshes 

In general, finite elements in a structured mesh have less distortion and are considered to be of 
better quality. In Figure 8-6, two identical rectangles are assigned with the same global FE size. 
The number of elements in the structured mesh is clearly less than that of the unstructured mesh. 
A smaller number of elements is one benefit of using a structured mesh, as computation times 
typically will decrease with less elements. However, a structured mesh is only applicable to region 
objects with four sides only, where the number of discretized elements on opposite sides of the 
region must be equal. Users may split a larger polygon, with more than four sides, into several 
smaller four-sided regions which are then allowed to use a structured mesh. 

In mechanical analysis in geotechnical engineering, structural members like retaining walls, piles, 
and/or culverts are frequently found. Although these structural members may have regular 
rectangular, or ring shapes, they are difficult to represent with a single four-sided rectangle or 
ring in EnFEM due to geometric compatibility issues with other regions in the model – like soil 
layers for example. However, members can easily be divided into several smaller four-side region 
objects. A simple example of this is shown in Figure 8-7. The retaining wall, made from polygon 
GFEKLMH (at left), has more than four sides to due to the adjacent regions (not shown) 
representing soil layers. This polygon is divided into three, four-sided sub-regions - rectangles 
GFEH, EKNH, KLMN (at right). The structured mesh can then be applied to each of these sub-
regions. Additionally, in post processing, a structured mesh is required to plot results of integrated 
forces, like moments or shear forces.  
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Figure 8-7: Sub-divide a multi-edge polygon into four-sided rectangles 

8.1.3 General Mesh Generation Guidelines 

To generate high quality meshes in EnFEM, users should use following recommendations: 

 Use quadrilateral elements (Q4, Q8) as much as possible. If complex geometries 
are present, they can be divided it into smaller regions with more regular shapes. 
This is helpful to improve mesh quality. 

 If contact analysis is not present in the model, it is recommended to use Q8 
elements (reduced integration rule) exclusively 

 If contact analysis is present, it is recommended to use Q4 elements (full 
integration rule) exclusively. Adjust mesh refinement if necessary. 

 For a structural member in the model, like a retaining wall, a culvert, or a pile, 
divide the geometry into several four-sided subregions, if possible, and set the 
mesh type for this member as a structured mesh. 

 Refine the mesh at locations suffering from steep stress gradients (stress 
concentrations). Use a coarse mesh at locations far away from the area of 
interest. 

 
Mesh operations are only available in “CAD-mode” and can be found in the “Mesh” drop-down 

menu on the menu bar. Click  to switch to “CAD-mode” if necessary. To generate a finite 
element mesh in EnFEM has following general steps: 

 Define mesh controls:  
a. Select element shape, mesh type, element type, and integration rules 

 Define global seed control 
a.  Assign a global element size if a uniform mesh is expected 

 Define local seed controls (if necessary) 
a. Local seed controls can be used to adjust element size, refine bias 

direction, and refine bias pattern.  
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b. Local seed control is a powerful and essential tool to aide in generating a 
high-quality mesh with the optimal number of nodes.  

c. If local seed control is applied to all region edges, global seed control can 
be ignored.  

 Verify mesh settings 
a. View edge divisions, seed assignments, and element type assignments 

 Generate mesh 

8.2 Defining the Mesh 

8.2.1 Mesh Controls 

The mesh control operation is used to determine the element shape and mesh type, and to select 
the element type and integration rules. In “CAD-Mode, from the menu bar, select “Mesh->Mesh 
Control”.  Select the desired region(s) and then RIGHT-CLICK and select “End Selection” from the 
popup menu. This will open the “Interaction dialog” window (Figure 8-8).  

 

Figure 8-8: Mesh control dialog 

In the left of this dialog, a “Region List” of the selected regions is displayed.  Region names are 
automatically generated by the program following the rule “Region + number”. If selected regions 
do not have mesh properties previously defined, the default assignment is a "Quadrilateral", 
“Quadratic Q8" element. Either “Structured” or “Unstructured” mesh types may be defaulted to, 
depending on the shape of the selected geometry. If selected regions have previously assigned 
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mesh properties, those assigned settings will displayed. Select the desired option for the element 
shape. Next, select the desired options for the element shape, mesh type, element option, and 
integration rule, with the following references: 

 If the source region does not have four edges, only the "Unstructured" option is 
applicable.  

 If the option "Linear Q4" is selected and contact interfaces are involved in the 
model, it is recommended to use the full integration rule (“reduced” remains 
unchecked).  

 For the "Quadratic Q8" option, in general it is recommended to use the reduced 
integration rule.  

 There is no integration option for the triangle element shape.  

 

 

The mesh generator in EnFEM supports hybrids of structured, and unstructured meshes in the 
same model, however there are several limitations on mesh generation in EnFEM: 

 Quadratic elements (Q8, T6) cannot be combined with linear elements (Q4, T3) 
 If a structured mesh is desired, the region of interest should be a four-sided 

region. Division numbers on opposite sides must be equal.  
a. NOTE: There is no edge number limitation for an unstructured mesh. 

 A mixture of quadrilateral and triangular elements is not supported in EnFEM. 

8.2.2 Global Seed Control 

After defining the global mesh control settings, more work is necessary to determine the element 
size on each region edge. In EnFEM, element size is controlled by setting the “seed spacing” on 
region edges. There is no control of seed spacing inside a region. During discretization, one FE 
node is placed at the seed position.   

The “global seed control” operation applies a universal element size to all regions in the model so 
that the generated mesh will be uniform. From the menu bar, click “Mesh->Global Seed Control” 
to open the “Global Seed Control dialog” window as shown in Figure 8-9. 
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Figure 8-9: Global seed control 

The default global mesh size is the smaller of the two following calculations: 

 Default mesh size is equal to the longest edge divided by 20, 
OR, 

 Default mesh size is equal to the shortest edge divided by 4. 

The user may change the default global mesh size by manually entering in a specified value as 
desired. Click “Assign” to apply the element size to all regions. After clicking "Assign", red circles 
are displayed on each edge to indicate the location of each seed (Figure 8-9).  Click “Close” to exit 
from this dialog. 

8.2.3 Local Seed Control 

Practical geotechnical problems are often complicated by highly nonlinear mechanical behaviors, 
local stress concentration, and/or significant dimensional differences, among others. In these 
problems, a uniform mesh may not provide enough resolution in an area of stress concentration. 
However, an overly-fine mesh greatly increases the calculation time. Local mesh control is 
essential to striking a balance between these issues. By using appropriate local seed controls, a 
locally refined mesh may be created with smooth transitions from the finely meshed area to the 
coarsely meshed area.   

From the menu bar, click “Mesh->Local Seed Control”, select the desired edge(s), and RIGHT-
CLICK and select "End Selection" from the popup menu to open the “Individual Seed Control 
dialog” window (Figure 8-10).  Options for “Seed Controls”, “Number of Divisions”, “Bias 
Direction”, and “Seed Distribution Style” are defined here, as well as viewing existing “Seed 
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Information”, if the selected edge has been previously defined. Input parameters in this dialog 
vary based on specific selections of the “Seed Controls” and “Seed Distribution Style”. Notice when 
the “Seed Control” is set to “By Number”, and by making different selections of the “Seed 
Distribution Style” option, the input parameter for the “Number of Divisions” changes based on 
the selection. This is also similar if the “Seed control” is set to “By Size”, and “Seed Distribution 
Style” option changes.  Once, the appropriate selections and input are made, click “Assign” to 
apply those to the model.  Click “Close” when complete and repeat the process for any other 
desired edges. The following sections discuss these settings in more detail. 

 

Figure 8-10: Individual seed control dialog 

8.2.3.1 Seed Control and Sizing Options 
Two main options are available for the seed control – “By Number” or “By Size”.  Sizing controls 
are also available in the form of “Number of Divisions”, “Uniform Size”, “Ratio of Max/Min”, 
“Minimum Size”, and “Maximum Size”.  As mentioned previously the sizing controls may vary 
based on the selected “Seed Control” and “Seed Distribution Style”. 

8.2.3.2 Seed Distribution Style 
Three options are available for the seed distribution style – “Uniform”, “One-Way”, and “Two-
Way” (Figure 8-11).  The “Uniform” distribution style makes the seed spacing equal along the 
selected edges. The “One-Way” distribution style reduces seed spacing along the provided 
direction. The “Two-Way” distribution style reduces seed intervals towards the middle of the edge 
or towards both ends of the edge, depending on the “bias direction”.  

NOTE: If multiple edges are selected at once, for the local seed controls, only the “Uniform” style 
will be available for selection. The keyboard shortcut “CTRL+L” can be used to start the “Local 
Seed Control” operation again, for repeated definitions. 
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Figure 8-11: Seed distribution style in EnFEM 

8.2.3.3 Bias 
Both the “One-Way” and “Two-Way” distribution styles use a directional bias, meaning that seed 
spacing is reduced in a defined direction along the edge. The “One-Way” distribution style reduces 
seed spacing along the provided direction. The “Two-Way” distribution style reduces seed 
intervals towards the middle of the edge or towards both ends of the edge, depending on the 
“bias direction”.  When either one of these styles are selected, arrows highlighted in red, are 
displayed on the selected edge to clearly show the refining direction(s). If this arrow display shows 
in the opposite direction as desired, the user may “check” the box for “Reverse Bias Direction”.  
This arrow display will then change in the opposite direction as previous. 

8.2.3.4 Example 
A simple example seen in Figure 8-12, highlights using local mesh controls to refine the mesh 
about one vertex – in this case Vertex B (left image).  The right image shows the final seed 
distributions, refined around Vertex B, and transitioning outward to a less refined distribution. 
Note that the seed-spacing around the specified vertex of interest is equal. It is important to keep 
similar spacing around a shared vertex to obtain high-quality meshes. In cases of local stress 
concentrations, local refinement is essential to reduce the stress gradient. 
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Figure 8-12: Local mesh refinements around Vertex B 

8.2.3.5 Seed Information 
Once local seeds are assigned to an edge, or if selecting an edge that has a previous definition, 
calculated “Seed Information” is shown at the bottom of the “Individual Seed Control dialog” 
window (Figure 8-10).  Note that the calculated minimum and maximum element sizes may not 
be exactly equal to the user’s input. 

8.2.4 Other Mesh Tools 

EnFEM provides some convenient tools to let users verify seed distributions and predict mesh 
quality before generating the mesh. To avoid any unexpected errors, it is recommended to review 
mesh definitions and properties using the following tools, before trying to generate the mesh. 

8.2.4.1 Show Edge Division 
From the menu bar, click "Mesh->Show Edge Division" to show division numbers on all edges as 
seen in Figure 8-13. Following the same command, will turn the edge divisions off.   

This is an especially useful feature if a structured mesh is defined, as opposing edges must have a 
matching number of edge divisions for a structured mesh. 

 

Figure 8-13: Division numbers displayed 
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After setting the global seed control, each edge has a division number calculated by program. In 
general, longer edges will have larger division numbers than short edges, as shown in Figure 8-14. 
However, there is a conflict with the structured mesh requirements if this is the case. Showing 
the edge division, and using the local seed controls should be used to correct this violation.  

 

Figure 8-14: Incompatible division number for a structured mesh 

8.2.4.2 Show Seeds 
From the menu bar, click "Mesh->Show Seeds" to show all specified seed distributions, as seen 
in Figure 8-15. Following the same command, will turn the seed visual off.  This provides a useful 
visual to verify that seed distributions are defined as expected. 

 

Figure 8-15: Seed distribution displayed 

8.2.4.3 Show Mesh Assignment 
From the menu bar, click "Mesh->Show Mesh Assignment" to show all specified mesh property 
assignments.  Following the same command, will turn the assignment visual off. This command 



CHAPTER 8 – Finite Elements & Mesh Generation – 8-14 
 

User’s Manual (Rel. May/2019)  EnFEM for Windows 

shades regions in specific colors according to the assigned mesh properties, as seen in Figure 8-16. 
This provides another visual verification tool to confirm mesh properties are defined as expected, 
before the mesh is generated. 

 

Figure 8-16: Display mesh assignment in color 

 

Four colors are used to shade regions according to their mesh assignment: 

•  quadrilateral and structured 
•  triangle and structured 
•  quadrilateral and unstructured 
•  triangle and unstructured 
•  no mesh property defined 

8.3 Special Cases 

8.3.1 Mesh Control on Contact Surfaces 

Contact surfaces require special attention when defining local seed control. The following is a 
general rule: 

 If the interface is curved, matched meshes should be used.  
 If the interface is straight, matched meshes are highly recommended.  

a. NOTE: In this case a matched mesh refers to nodes from adjacent edges, 
that are at the same location (Figure 8-18). 

 The element size on the slave surface cannot be larger than the paired element 
size on the master surface. 

Figure 8-17 depicts a curved interface with unmatched meshes, for a retaining wall and soil 
interface. Since linear elements (Q4, T3) were used to discretize the interface, gaps are 
unavoidable in the initial undeformed configuration. Initial contact detection fails to find active 
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contact pairs due to the existence of gaps, and thus the retaining wall will miss contact constraints. 
Because of this failure, some elements may suffer from rigid body motions and the computation 
may fail to converge no matter how small the load increment size. 

 

Figure 8-17: Non-matched mesh on curved interface 

Figure 8-18 shows a matched mesh on the same retaining wall-soil interface. Initial contact 
detection will not fail with this interface. 
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Figure 8-18: Matched mesh on curved interface 

As mentioned in earlier sections, the algorithm to solve interaction problems in EnFEM is based 
on the "Node-to-Segment" approach. Here the "node" belongs to the slave body, and the 
"segment" belongs to the master body. Penetration of the "slave node" into the "master segment" 
will be checked frequently to ensure impenetrability between contacting bodies. However, 
penetration of a “master node” is never checked against the “slave body” in this algorithm. 
Therefore, if the element size on the “master body” is smaller than that of the “slave body”, 
penetration of the “master body” into the “slave body” may occur and cannot be detected by the 
program. It is recommended to use matched meshes on the contact interfaces whether the 
interface is curved or not. The benefits of using matched initial meshes are: 

 easy to adjust mesh  
 easily satisfy mesh requirement for "master - slave" contact pair 
 combined with uniform seed distribution, contact stress has less oscillation  

Figure 8-19 shows another matched mesh on retaining wall-soil interfaces on the vertical edges. 
This meshing strategy is highly recommended in EnFEM. 
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Figure 8-19: Matched mesh on vertical edges 

8.4 Mesh Generation 
Once all parameters are defined for the mesh, click “Mesh->Run Mesh Generation” from the 
menu bar to start the men generator. If this mesh is successfully generated, it will be displayed 
automatically, and the program will switch to “Mesh-Mode” (Figure 8-20).  

 

Figure 8-20: Mesh-mode interface (with nodal display on) 

8.4.1 Unsuccessful Mesh Generation 

If the mesh generation is unsuccessful, warning/error messages may appear with some 
description of the issue.  Make any necessary adjustments, and then re-generate the mesh. 
Common issues during mesh generation are listed in the following sections. 
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8.4.1.1 Edge Division Numbers for Structured Mesh 
If a region is assigned to be a structured mesh, and opposite sides of the region have different 
edge-divisions, an error message will appear like that seen in Figure 8-21.   

 

Figure 8-21: Edge-division error message for structured mesh 

8.4.1.2 Overlapping Edges 
Another common issue for new users is geometry created with invalid overlapping edges. Refer 
to Section 3.6 for reference on valid and invalid geometries, and best practices. If overlapping 
edges are present, this will generate a non-conforming mesh, which in turn may produce 
undesired analysis results.  Before mesh generation is complete, the program will check for these 
kinds of invalid edges and an error message will appear (like that seen in Figure 8-22) if present.  
EnFEM also will mark these invalid overlapped edges in red color for easy identification. 

 

Figure 8-22: Invalid edge error message 

8.5 Mesh-Mode 
Once the mesh is successfully generated, EnFEM automatically switches from “CAD-Mode” to 
“Mesh-Mode”.  “Mesh-Mode” is a transition before running the analysis but still has some useful 
features for the user.  From the menu bar, under the “Mesh” menu the following features are 
available. 

 “Mesh->Delete Mesh” to directly delete the generated mesh. 
 “Mesh->Mesh Properties” displays the current number of elements and nodes 

(Figure 8-22). 
 “Mesh->Show Node Numbers” displays node number assignments. 

a. Select again to turn off display. 
 “Mesh->Show Element Numbers” displays element number assignments. 

a. Select again to turn off display. 
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Figure 8-23: Mesh properties 

In addition, in “Mesh mode” (or in “CAD-mode”) the analysis settings can be defined and the 
analysis started, as noted in CHAPTER 9. 

 



 

 

 

 

 

 

 

 

 

 

 

 

CHAPTER 9. Analysis 
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9.1 Introduction 
Nonlinear analysis using finite elements in geotechnical engineering is quite complicated. 
Sometimes calculations cannot converge and end in early termination, or sometimes calculations 
take considerable amounts of time. EnFEM provides default solver settings that are appropriate 
for most use cases, however some experienced users may desire to change these settings for 
more complex analysis options. Therefore, EnFEM provides users the option to adjust solver 
settings as desired, to improve convergence rates. 

9.2 Analysis Settings 
From the menu bar, click “Analysis->Analysis Setting” to open the “Analysis Setting dialog” 
window, as shown in Figure 9-1.  Default settings are automatically entered in each field, and may 
be changed as desired.  The specific setting options are as described in the following sections. 

 

Figure 9-1: Analysis setting 

9.2.1 Solver Options 

EnFEM uses the direct solver for the solution of the system of equations. The solver is based on 
multithreading and parallelization techniques that usually reduce the computational time in 
multicore systems. EnFEM will detect and use available CPU cores automatically. 

9.2.2 Convergence Options 

The convergence setting has two controls – “relative tolerance” and “maximum iteration 
number”. “Relative tolerance” is the ratio of force residual to all applied external loads. A force 
residual is collected from each finite element, which is the difference between internal nodal 
forces and external loads. The default value, 1e-5, is a balance of accuracy and efficiency and is 
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appropriate for most calculations. Users may enlarge or reduce this value if desired. If a smaller 
value is selected, more iterations are expected.  

“Maximum iteration number” controls the maximum allowable number of iterations for each load 
increment. If the counted iteration number exceeds this limitation, the program will mark a failure 
of convergence and retry by using a smaller load increment. The default iteration limit, 12, works 
well for most situations.  

9.2.3 Interaction Controls 

The interaction setting is used for contact analysis only. It has three parameters: “normal penalty 
factor”, “tangent penalty factor”, and “maximum iteration number” for the interaction check.  The 
penalty approach is used in EnFEM for contact analyses. This method requires estimation of a 
penalty value before computation. The default penalty value automatically determined by the 
program is generally appropriate for most cases. EnFEM provides users the option to adjust the 
“normal” and “tangent” penalty values by multiplying the default penalty value by a factor.   

The “maximum iteration number” for the interaction is used to limit iterations to determine 
contact status. Change of contact status will trigger a new iteration until the force residual is 
smaller than the tolerance and no change of contact status occurs. The default maximum iteration 
number for interaction check is 12. For example, if an interaction interface contains a large 
number of FE nodes and change of contact status involving many nodes, the default iteration 
setting will likely not reach convergence. In this scenario the increment size will be reduced, and 
then check will be retried with the smaller increment size. Sometimes only the first one or two 
increments need more iterations to reach convergence of contact status. In this case using a 
number larger than 12 rather than allowing the program to automatically reduce increment size, 
often saves CPU time. 

9.2.4 Output Options 

EnFEM uses a smart output control to save time and storage space of results. “Output frequency” 
controls how often to write calculated results to the file on the hard drive.  This option is effective 
if a small increment size is being used, thus creating a large total number of increments. Results 
of the first and the last increments are always output. 

Four output contents are available in EnFEM: “displacements”, “boundary reactions”, “element 
stresses” at Gaussian points, and “contact stresses”.  Users may “check” the content of interest 
desired for output. 

9.3 Run Analysis 
In “CAD-Mode” or “Mesh-Mode”, click “Analysis->Run Analysis” from the menu bar to open the 
“Run Analysis dialog” window, as shown in Figure 9-2. 
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Figure 9-2: Job submission and options 

All available stages of the analysis model will be displayed in this dialog window.  Only stages with 
a “check mark” next to the name will be submitted to the solver, while those without the “check 
mark” will not be run.  

9.3.1 Generate Analysis File 

The button "Generate Analysis File" can be used to generate the solver input file (.dat) in ASCII 
format. This is a readable file primarily used for technical support purposes.  Experienced users 
may use this file to track possible issues easily.  

9.3.2 View Analysis File 

The button "View Analysis File" will open this analysis file (.dat) automatically using the Windows 
Notepad program, for user review.  

9.3.3 Run 

The button "Run" will submit the job to the nonlinear solver, and generate an analysis input file. 
A command window will open up to display convergence information of each load increment. All 
information displayed in the command window, shall be saved to the “log-file” (.log). If the user 
wishes to terminate the analysis early, the keyboard shortcut “CTRL+C” may be used within the 
command window, or the command window can be closed directly by clicking the  button.  
When solver finishes the analysis, or terminates the analysis because of an error, the “log-file” 
(.log) will be opened automatically. It is recommended to review the history of convergence in 
this log-file. If any errors have occurred and EnFEM fails to generate the analysis input file, an 
error message will be produced, like that seen in Figure 9-3. Related information can be found in 
the “.log file”. 

 

Figure 9-3: Analysis file error message 
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The output file (.out) and the log file (.log) are both available for users’ review. They can be 
reached from the menu bar, by clicking "Analysis->View Output File", or "Analysis->View 
Message File", respectively.  

9.3.3.1 Computation Result 
In general, the computation will end in two ways – either a successful completion of the analysis, 
or an early termination.  

9.3.3.1.1 Successful Computation  
In this case, the analysis successfully ends without issue, or any error messages. Thus, users can 
go into post-processor directly to view the desired results. 

9.3.3.1.2 Early Termination 
In this case, the analysis aborts due to errors. This case is common in nonlinear FE simulation. 
There are many reasons that may cause an abnormal abort, such as: large load-increment size, 
local failure of material, non-convergence of a contact interface, or the model itself has some 
implicit errors. In this case, users need to carefully check the completed output, including the “.log 
file”.  If any partial results are available, judgement of the results based on engineering experience 
is necessary to find errors, and make any needed corrections.  

 



 

 

 

 

 

 

 

 

 

 

 

 

CHAPTER 10. Post-Processing of 
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10.1 Introduction 
Visualization of results is generally known as post-processing in finite element analysis. Post-
processing in EnFEM has four types of data visualization: “contour plots”, “displacement vectors”, 
“X-Y curve plots”, and “cutline plots”.  These options are described in more detail in the following 
sections. 

10.1.1 Result-Mode 

Post-processing in EnFEM takes place in the “Result-mode”.  With an analysis previously 

completed, users will click the  icon to switch into “Result-mode”.  If results are available, the 

initial mesh will be plotted on screen (Figure 10-1). Users may click  or  to go back to 
“CAD-mode” or “Mesh-mode”, at any time. 

 

Figure 10-1: Initial “Result-mode” display 

10.1.2 Stage Selection 

Before plotting any results, users may select a specific stage(s) for output. From the menu bar, 
click "Results->Stage Selection". The “Stage Selection dialog” window will open up as shown in 
Figure 10-2. “Checked” stages will be available for output operations, and those left “unchecked” 
are left out. This is often a useful feature for XY-Plots, for example, when there is a desire to plot 
only the loading stages, and leave the initial stress stage unplotted. All stages are selected for 
output by default. Columns after the stage name detail the “start increment”, “end increment”, 
and “stage type”. 
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Figure 10-2: Select stages for output 

10.2 Post-Processing Options 

10.2.1 Contour Plot 

The contour plot in EnFEM is based on Open-GL graphics technology which provides fast, accurate 
rendering of contour outputs on screen. Contour plots of field variables give users a visible color-
based image to easily identify trends in displacement, local stress/strain concentrations, local 

failure of material, among others. From the toolbar, click the contour plot icon, , and the 
“Contour Plot dialog” window will open, as shown in Figure 10-3. 

 

Figure 10-3: Dialog of contour plot 

Variables available for display in the contour plot are divided into four groups: "Deformation", 
"Stress", "Strain", and "Soil variables". Contents of each group are listed as follows: 
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10.2.1.1 Deformation 
 u1:  displacement component in X-direction (horizontal) 
 u2:  displacement component in Z-direction (vertical) 
 u_mag:  displacement magnitude 

𝒖𝒖𝒎𝒎𝒎𝒎𝒎𝒎 = �𝒖𝒖𝟏𝟏𝟏𝟏𝟐𝟐 + 𝒖𝒖𝟐𝟐𝟐𝟐𝟐𝟐  

(10.2-1) 

10.2.1.2 Stress 
 σ11, or S11:  stress component in X-direction (horizontal) 
 σ22, or S22:  stress component in Z-direction (vertical) 
 σ12, or S12:  shear stress component 
 σ33, or S33:  stress component in Y-direction (perpendicular to screen) 
 mean stress, P:  

𝑷𝑷 =
𝝈𝝈𝟏𝟏𝟏𝟏 + 𝝈𝝈𝟐𝟐𝟐𝟐 + 𝝈𝝈𝟑𝟑𝟑𝟑

𝟑𝟑
 

(10.2-2) 

 equivalent shear stress, q 

𝒒𝒒 = �𝟑𝟑𝑱𝑱𝟐𝟐 = �(𝝈𝝈𝟏𝟏𝟏𝟏 − 𝝈𝝈𝟐𝟐𝟐𝟐)𝟐𝟐 + (𝝈𝝈𝟐𝟐𝟐𝟐 − 𝝈𝝈𝟑𝟑𝟑𝟑)𝟐𝟐 + (𝝈𝝈𝟑𝟑𝟑𝟑 − 𝝈𝝈𝟏𝟏𝟏𝟏)𝟐𝟐 + 𝟔𝟔𝝈𝝈𝟐𝟐𝟏𝟏𝟏𝟏
𝟐𝟐

 

(10.2-3) 

 major principal stress, P1, or PS1 
 minor principal stress, P2, or PS2 

10.2.1.3 Strain 
 ε11, or E11:  component of total strain in X-direction (horizontal)   
 ε22, or E22:  component of total strain in Z-direction (vertical) 
 ε12, or E12:  component of shear strain  
 ε33, or E33:  component of total strain in Y-direction (perpendicular to screen) 
 EEQ:  equivalent magnitude of total strain 

𝜺𝜺𝒆𝒆𝒆𝒆 =
√𝟑𝟑
𝟐𝟐
�(𝜺𝜺𝟏𝟏𝟏𝟏 − 𝜺𝜺𝟐𝟐𝟐𝟐)𝟐𝟐 + (𝜺𝜺𝟐𝟐𝟐𝟐 − 𝜺𝜺𝟑𝟑𝟑𝟑)𝟐𝟐 + (𝜺𝜺𝟑𝟑𝟑𝟑 − 𝜺𝜺𝟏𝟏𝟏𝟏)𝟐𝟐 + 𝟑𝟑𝜺𝜺𝟏𝟏𝟏𝟏𝟐𝟐  

(10.2-4) 

 ε11
p , or PE11:  component of plastic strain in X-direction, (horizontal) 

 𝜀𝜀22
𝑝𝑝 , or PE22:  component of plastic strain in Z-direction (vertical) 
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 𝜀𝜀12
𝑝𝑝 , or PE12:  component of shear plastic strain 

 𝜀𝜀33
𝑝𝑝 , or PE33:  component of plastic strain in Y-direction (perpendicular to 

screen) 
 𝜀𝜀𝑒𝑒𝑒𝑒
𝑝𝑝 , or PEEQ:  equivalent magnitude of plastic strain 

𝜺𝜺𝒆𝒆𝒆𝒆
𝒑𝒑 =

√𝟑𝟑
𝟐𝟐
��𝜺𝜺𝟏𝟏𝟏𝟏

𝒑𝒑 − 𝜺𝜺𝟐𝟐𝟐𝟐
𝒑𝒑 �𝟐𝟐 + �𝜺𝜺𝟐𝟐𝟐𝟐

𝒑𝒑 − 𝜺𝜺𝟑𝟑𝟑𝟑
𝒑𝒑 �𝟐𝟐 + �𝜺𝜺𝟑𝟑𝟑𝟑

𝒑𝒑 − 𝜺𝜺𝟏𝟏𝟏𝟏
𝒑𝒑 �𝟐𝟐 + 𝟑𝟑�𝜺𝜺𝟏𝟏𝟏𝟏

𝒑𝒑 �𝟐𝟐 

(10.2-5) 

10.2.1.4 Soil variables 
 Pore pressure 
 Consolidation stress, Pc 
 Void ratio: 
 Active yielding 

Clicking on any of the “Variable” selections will automatically refresh the contour plot. The list 
under the label “Increments” shows the available increments for selected stages. Selecting any of 
the increments will also refresh the contour plot. There are several display options in the top-right 
part of the window.  Options for displaying the contour, the deformed shape with scaling factor 
and the undeformed mesh, as well as various contour types and editing numerical limits are 
available to the user.   

 

Figure 10-4: Plot contour as line 
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Figure 10-5: Plot contour to show both shade and line 

Three different options of “contour type” are available: “shading” (default), “lines”, or both 
“shading and lines”. Figure 10-4 shows an example of line contours, while Figure 10-5 is an 
example of the combined option.  

Users can change the “contour limits” as desired by entering new minimum or maximum values, 
as well as the number of contour divisions. Click “Apply” to set the new limits, and notice that the 
contour scaling reflects these changes. The button “Default Limits” is used to restore the original 
default contour limits, if necessary. Below the “Increment List”, checking the box “Show 
Animation”, enables controls for an animated display of the contour results.  Click the button 

, to play the contour animation. The animation will play once, from start to finish.  If 
desired, contour limits for the animation may be changed using the “Minimum/Maximum” fields 
This can be repeated as necessary. 

Click “Close” to exit the “Contour Plot dialog” window. After exiting, the contour image will be 
cleared from the screen. 

10.2.2 Plot Displacement Vector 

The displacement vector plot is a way to clearly illustrate displacement direction and magnitude 

of material parcels. From the toolbar, click the  icon to open the “Displacement Vector 
dialog”, as shown in Figure 10-6. This figure shows the displacement vectors on a foundation 
settlement example from Example 2 - Analysis of shallow foundation subject to vertical 
settlement, of the EnFEM Example Manual. 



CHAPTER 10 – Post-Processing of Results – 10-7 
 

User’s Manual (Rel. May/2019)  EnFEM for Windows 

 

Figure 10-6: Displacement vector of soil due to settlement of foundation 

User may select any available increment from the “Increment History” list, select the appropriate 
“Vector Variable” (“total displacement”, is default), and select the “multiplier” value to increase 
or decrease of the size of the displacement vectors. Users can plot displacement vectors for 
components in the X-direction, Z-direction, or the combined magnitude and direction.  

10.2.3 X-Y Plot 

The X-Y plot is an important output option that illustrates the internal relationship between two 
parameters. The X-Y plot in EnFEM has two distinct categories: 

 Historic Result X-Y plot 
a. Plots results of a single node versus increment history. 
b. Only “Primary Variables” (deformation, stress, strain, etc.) or “Reaction 

Forces” are available “Categories” for plotting. 
 Field Result X-Y Plot 

a. Plots results at selected increments only. 
b. For plotting results along a defend node-path. 
c. All result “Categories” are available for plotting (including interaction 

interfaces). 

The following sections detail options for X-Y Plots.  Additional step-by-step detail using practical 
examples, can be found in the EnFEM Example Manual. 
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10.2.3.1 Historic Result X-Y Plot 
Historic X-Y Plot is used to plot results of a single specified node versus the increment history. 
Available “Categories” for historic X-Y Plots are “Primary Variables” (deformation, stress, strain, 
etc.) and “Reaction Forces”. 

Click the  icon on the toolbar to open the “X-Y plot dialog” as seen in Figure 10-7. This figure 
shows an example plot of displacement in the X-direction versus the increment history of the 
selected stages (in this case the initial stress stage is turned off in the result). 

 

Figure 10-7: X-Y Plot for Historic Result  

With the “X-Y plot dialog” open, the following procedures should be followed: 

 Select “Historic Result” as the data source. 
 Input the desired node number into the “Node List” entry. 

a. NOTE: Users many need to turn on the node numbers (“Mesh->Show 
Node Numbers”) and use zoom operations to determine the exact node 
of interest.  

 Select the desired option from the “Category” drop-down list. 
a. NOTE: Only “Primary Variables” (deformation, stress, strain, etc.) or 

“Reaction Forces” are available for “Historic Plots”. 
 Select the desired option from the “Variables” drop-down list. 
 Note that the content of increment history becomes grey because the historic 

option is selected.  
 Click "Plot" to plot the desired curve. 
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10.2.3.2 Field Result X-Y Plot 
The Field Result X-Y Plot is used to plot results of specified variable along a path defined by a node 
list. Data in this plot are extracted from a selected load increment, and all result “Categories” are 
available for plotting (including interaction interfaces).  

Click the  icon on the toolbar to open the “X-Y plot dialog” as seen in Figure 10-8. This figure 
shows an example plot of stresses along a selected node path at the selected load increment. 
Notice the node path that is entered in the “Node List” rather than just a single node. When a 
node path is used, the X-axis of the plot is the real distance of each node, in relation to the first 
node in the list. 

 

Figure 10-8: X-Y Plot for Field Result 

With the “X-Y plot dialog” open, the following procedures should be followed: 

 Select “Field Result” as the data source. 
 Input the desired node-path into the “Node List” entry. 

a. NOTE: Users many need to turn on the node numbers (“Mesh->Show 
Node Numbers”) and use zoom operations to determine the exact node 
of interest.  

b. NOTE: See the following sections for options of node-path entry. 
 Select the desired option from the “Category” drop-down list. 

a. NOTE: All result “Categories” are available for plotting (including 
interaction interfaces). 

 Select the desired option from the “Variables” drop-down list. 
 Select the desired load increment. 
 Click "Plot" to plot the desired curve. 

The following sections detail node-path entry options and formats. 
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10.2.3.2.1 Manual Entry of Node-Path 
When specifying a Field Result X-Y Plot, a desired series of nodes must be input. The first option 
is to input this series manually, for which there are several options detailed below. 

10.2.3.2.1.1 Individual Entry 
The first option is a simple input of nodes, each separated by a comma - “1,3,5,6,10…X”.  The user 
may choose to use this option if the nodes along the desired path are not in any fixed numerical 
order. This method can be used in combination with the “fixed interval” input described below, 
by simply using a comma for separation. 

10.2.3.2.1.2 Fixed Interval 
The second option provides more structured input, if the series of nodes has a fixed interval. In 
this case, the input can be written as:   

13:45:2 or, 117:112:-1 

The first number is in reference to the “start” node, while the second is the “end” node.  The third 
number is in reference to the “interval”.  Therefore, the first input will extract a node series from 
13 to 45, using every other node - “13, 15, 17, 19, ..., 45”.  Whereas the second input is equal to 
a node series of “117, 116, 115, 114, …, 112”.  This method can be used in combination with the 
“random entry” input as described above, by simply using a comma for separation. 

10.2.3.2.2 Node-Path Entry Using Predefined ‘Edge-Sets’ 
The alternative option to manual entry for specifying a node-path is using a predefined ‘edge-set’.  
This is the most convenient way to define the path, but does require that an “edge selection-set” 
(see CHAPTER 5) be previously defined, for the desired path.   

With the “X-Y plot dialog” open, the following procedures should be followed: 

 Select the “Field Result” option 
 Click the button "By Set", above the “Node List” entry, to open the “Set Selection 

dialog” window, as seen in Figure 10-9. 
a. All of the previously defined selection-sets of the model are displayed in 

this window, detailed by their “Set-Name” and “Set-Type” (description). 
 Select one edge-set and click "OK". 

a. NOTE: The “Node List” entry will now display "User Defined Set".  
 Select the desired “Category”, “Variable”, and “Load increment”, and click “Plot” 

when finished. 
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Figure 10-9: Select an ‘edge-set’ for Field Result X-Y Plot 

10.2.3.2.3 Plotting Integrated Variables (moment, shear, or thrust) 
The category of “Integrated Forces” for Field Result X-Y Plots is specifically designed to show 
integrated force output for structural elements in geotechnical engineering. For example, an 
engineer may be interested in moments and shears of a wall structure in a retaining wall-soil 
interaction analysis, or thrust forces inside a culvert while evaluating the design of the structure. 
Creating an integrated force plot comes with some additional steps that supplement the normal 
process for producing a Field Result X-Y Plot.  They are as follows: 

 Integration forces can only be plotted from the single object of interest – typically 
a structural member. This structural member may be represented by more than 
one region. Use the “Set Tool” and “Display Tool” to define a selection-set, and 
display only the member of interest - such as a culvert or wall region.  

a. NOTE:  If there is more than one structural member that requires 
integrated force output, only display one structural member at a time. 

 When inputting the node-path of interest, using nodes along the centerline of the 
structural object is required. Therefore, a structured mesh should be used on 
such structural objects, while specifying the edge division such that nodes are 
present along the centerline.  In this case, the node-path along the centerline is 
then manually entered. This may tedious, and difficult depending on the mesh 
refinement.  Taking some extra steps while creating the geometry of the 
structural object, by using sub-regions - in which a geometric edge is defined 
along the centerline - will allow the user to create a selection-set for these desired 
nodes and simplify plotting procedures in post-processing.  

a. NOTE: Using nodes on an external boundary of the structural object is not 
recommended 

Figure 10-10 shows the moment distribution along a culvert at the last load increment, using a 
manually entered node-set.  Additional step-by-step detail using practical examples, can be found 
in the EnFEM Example Manual. 
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Figure 10-10: Moment of culvert along given node path 

10.2.3.2.4 Plotting Interaction Variables 
Plotting interaction variables is another useful feature in EnFEM that gives valuable information 
to the user in soil-structure interaction problems.  For example, plotting pressure on the retaining 
wall interface, or plotting the contact status along the interface to determine if gaps are present. 
Creating an interaction variable plot comes with some additional steps that supplement the 
normal process for producing a Field Result X-Y Plot.  They are as follows:  

 Use the “Set Tool” to define edge selection-sets for each of the desired interfaces.  
For example, one edge-set for the active side of a retaining wall, and a second for 
the passive side. 

a. NOTE: These edges should be continuous, and only nodes on the ‘slave 
interaction-surface’ are available to plot contact stresses in EnFEM, so 
make sure to define edge-sets appropriately. 

Figure 10-11 shows an example of normal pressure VS depth along an interaction interface. The 
start node is determined by EnFEM implicitly. If users want to check where the XY plot starts, 
users may compare the node list to the nodal location in the model, from an externally saved file 
(process detailed in following sections). 
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Figure 10-11: Normal interaction pressure versus depth 

10.2.3.3 Other Plot Options 
Additional options for X-Y Plots are available to give user’s added flexibility. They are as follows: 

10.2.3.3.1 Curve Options 
A number of options exist to manipulate the plot, at right of the “Increment History”, under the 
name “Curve Options”. “Checking” these options will enact various changes in the visual 
representation or direction of the plot. 

10.2.3.3.2 ‘Save to File’ Options 
A second option available is to export the X-Y Plot data to an external file, in order to save for 
further processing. 

The default save directory is the same as the model file, and the output file name is that of, 
“current analysis filename_xy.dat". Under the “File Save Option” users may change this to point 
to a specific file directory, or specify another filename as desired. Clicking "Save to File" will export 
the file, and a message window will appear to confirm the export was completed successfully. 

If the option "Append to File" is checked, new data exported will be appended to the end of the 
file, provided the path and filename are the same as already exists. 

Additional step-by-step detail using practical examples, can be found in the EnFEM Example 
Manual. 

10.2.3.4 Available Categories and Variables for Plotting 
In addition to those output variables available for Contour Plots, the following are also available 
for X-Y Plots. 
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10.2.3.4.1 Integrated Force Category 
 Moment:  Integration of normal stresses to calculate the moment on defined 

sections along a node-path.  
a. It has the unit:  “Force*length” 

 Shear:  Integration of stresses tangent to sections. 
a. It has the unit:  “Force” 

 Thrust:  Integration of stresses normal to sections.  
a. It has the unit:  “Force” 

 
NOTE: These “sections” are perpendicular to the node path and located at each nodal 
position in the path. For example, at each node along the node-path, an integration 
is performed for the nodes at the specific cross-section of the object of interest. Only 
one object of interest, subject to the X-Y Plot, should be displayed. Additionally, a 
structured mesh is recommended for producing this type of result. 

10.2.3.4.2 Interaction Category 
 Normal Pressure :  Calculated stress components which are in the normal 

direction to the contact interface. It has the unit:  “Force/sq.unit length”. 
 Tangent Shear:  Calculated tangent (frictional) stress components which are in 

the tangent direction to the contact interface. It has the unit:  “Force/sq.unit 
length”. 

 Normal Status:  Numerical values are plotted corresponding to the status of the 
contact condition:  1=interface is open (gap), 2=interface is closed (no gap) 

 Tangent Status:  Numerical values are plotted corresponding to the status of the 
contact condition: 0=not in contact, 1=in contact and “sticking condition”, 2=in 
contact and “sliding condition”. 

10.2.3.4.3 Reaction Force Category 
 x Reaction :  Calculated reaction forces in the direction of the X-axis. It 

summarizes all forces from the provided node-path.  
a. It has the unit:  “Force”. 

 z Reaction:  Calculated reaction forces in the direction of the Z-axis. 
a. It has the unit:  “Force”. 

10.2.4 Cutline Plot 

If the mesh is unstructured, it is almost impossible to find a straight-line node-path set inside the 
FE mesh, to produce a typical X-Y Plot. In this case, the “Cutline Plot” option is a convenient and 

useful tool. From the menu bar, click "Result->Cutline", or use the toolbar icon, , to open the 
“X-Y Plot on Cutline” window as seen in Figure 10-12. This figure shows an example plot of 
displacement in the Z-direction at the selected load increment.  
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Figure 10-12: X-Y Cutline Plot 

With the “X-Y Plot on Cutline window” open, the following procedures should be followed: 

 Input the X and Z-coordinates of two ends of the desired cutline. 
 Click "Add" to add this new cutline into the “Cutline List” window. 

a. A red straight line is then displayed on screen to show the cutline location 
in reference to the model.  

 Select the field variable, and load increment of interest 
a. NOTE: Only “Primary Variables” (deformation, stress, strain, etc.) are 

available for Cutline Plots. 
 Click "Plot". 

 
Note that the X-axis refers to the distance along the cutline.  The “start point” of the cutline refers 
to zero on the X-axis, and “end point” will refer to the maximum value (distance) of the axis.  

If a cutline line passes through an internal void (hole), the plot connects the two points on the 
inner faces of the void by a straight line. 

Similar to typical X-Y Plots, the option is available to export the Cutline Plot data to an external 
file, in order to save for further processing. The default save directory is the same as the model 
file, and the output file name is that of, “current analysis filename_cut.dat". Under the “File Save 
Option” users may change this to point to a specific file directory, and specify another filename 
as desired. Clicking "Save to File" will export the file, and a message window will appear to confirm 
the export was completed successfully. 

If the option "Append to File" is checked, new data exported will be appended to the end of the 
file, provided the path and filename are the same as already exists. 

 



 

 

 

 

 

 

 

 

 

 

 

 

CHAPTER 11. Miscellaneous Tools & 
Options 
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11.1 “CAD-Mode” Options Menu 

11.1.1 Grid Space  

This tool is used to change the spacing of the background gird-lines in “CAD-mode”. From the 
menu bar, click “Options->Grid Size” to open the “Grid Size dialog” window as seen in Figure 11-1. 

 

Figure 11-1: Grid size dialog 

Input new values to change the spacing of background grid-lines in the X and Z-directions. Click 
“OK” to exit. Clicking “Default” will reset to the default grid size. The default grid size is 100x100. 
This can be a useful tool for model creation, as users can “Snap” to the grid when creating various 
geometric entities. 

11.1.2 Drawing Space 

This tool is used to change the default distance of the model extents on screen. From the menu 
bar, click “Options->Drawing Space” to open the “Drawing Space Extents dialog” window as seen 
in Figure 11-2. Input new extents and click “OK” to exit. Clicking “Default” will reset to the default 
space extents. 

 

Figure 11-2: Drawing space extent dialog 

11.1.3 Background Color 

The background color for the “CAD-mode” and “Mesh-mode” display windows is set to black by 
default. Users can change this as desired to improve visualization. From the menu bar, click 
"Options->Background Color" to open the “Background Color dialog” window, as seen in Figure 
11-3. Use the drop-down menu to pick the desired color and click "OK". This information is saved 
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into the model database, so that when the model is closed and re-opened, this setting will be 
preserved. Clicking “Use Default” will reset these options. 

 

Figure 11-3: Change background color 

11.2 Zoom Operations 
The following zoom operations are employed in EnFEM: 

11.2.1 Pan View 

Click to activate the  icon. Hold the left mouse button while moving the mouse. View will 
translate with the motion of mouse. 

11.2.2 Zoom In/Out 

Click to activate the  icon. Hold the left mouse button and move the mouse. When the mouse 
moves from the top of the screen to the bottom of the screen, the view zooms out (minimizes). 
When the mouse moves from the bottom of the screen to the top of the screen, the view zooms 
in (maximizes). The mouse scroll wheel can also be used to perform the zoom in/out operations.  

11.2.3 Zoom to Window 

Click to activate the  icon, move the mouse cursor to an appropriate location on screen.  LEFT-
CLICK and hold, and drag the mouse creating a rectangular zoom-window.  Release the mouse 
button when the desired geometry is within the rectangle. The view inside the zoom window will 
be enlarged to fill the whole EnFEM window.  

11.2.4 Zoom to Extents 

Click the  icon to zoom to the model extents. This operation is used to show the whole model 
and scale as large as possible. 

11.2.5 Reset View 

Click the  icon to reset the whole EnFEM window to the default view.  
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11.3 “Result-Mode” Options Menu 

11.3.1 Font and Color 

In “Result-mode”, users can change the background color, and also the font color, size, and type. 
From the menu bar, click "Options->Font and Color" to open the “Font and Color dialog” window 
as shown in Figure 11-4. 

 

Figure 11-4: Change color and font for result window 

Make the appropriate selections for the various options available and click "Apply" to activate 
these changes. Click "Close" to exit. Clicking “Use Default” will reset these options. 
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Nonlinear FE analysis involves knowledge of the finite element method, engineering judgment, 
and some experience with numerical simulation. Several reference books are listed here as 
reading materials: 

1. C.S. Desai and John T. Christian, Numerical methods in geotechnical engineering, 
McGrawHill,1977 

2. David M. Potts and Lidija Zdravković, Finite element analysis in geotechnical engineer: 
theory, Thomas Telford,1999 

3. EA de Souza Neto, D perić and DRJ Owen, Computational methods for plasticity: theory 
and applications, John Wiley and sons, 2008 

4. R.D. Cook, D.S. Malkus, M.E. Plesha and R.J. Witt, Concepts and applications of finite 
element analysis 4th version, John Willey & sons, 2002 
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PROGRAM LICENSE AGREEMENT & DISCLAIMER 

IMPORTANT NOTICE:  The software you are about to install or previously have installed from Ensoft 
Incorporated (“ENSOFT”) is licensed only on the condition that you agree to the terms and conditions set 
forth below.  Please read the terms of this License Agreement & Disclaimer ("LICENSE") carefully. 
If you agree to be bound by the terms of this LICENSE, please check mark the box labeled “YES – I 
Accept the terms of this License Agreement!” during software installation so it can be installed on your 
computer. 
If you do not agree to the terms of this LICENSE, please check mark the box labeled “NO – I DO NOT 
Accept the terms of this License Agreement!” which will terminate the software installation. 
If the software is already installed and licensed, you have already agreed to the terms and conditions of this 
license, or someone has done so on your behalf. 
This LICENSE is a legal agreement between you (“USER”) – either an individual or a single entity– and 
ENSOFT for the ENSOFT software product that you are about to install or previously have installed 
(“PRODUCT”).  The PRODUCT collectively includes computer software and associated media, printed 
materials, hardware key (dongle), and electronic documentation.  The PRODUCT also includes any 
updates and supplements to the original PRODUCT that may have been produced by ENSOFT.  By 
installing, copying, downloading, accessing or otherwise using the PRODUCT, the USER agrees to be 
bound by the terms of this LICENSE.  If you (the USER) do not agree to the terms of this LICENSE, do 
not install or use the PRODUCT. 

SOFTWARE LICENSE & DISCLAIMER 

The PRODUCT is protected by copyright laws and international copyright treaties, as well as other 
intellectual property laws and treaties.  The PRODUCT is licensed, not sold.  

1.  GRANT OF LICENSE 

This LICENSE grants you the following rights: 

1.1  INSTALLATION AND USE 

1.1.1  Single-User Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with 
ENSOFT and for one specific physical site (“SITE”) registered with ENSOFT.  You may install and use 
the PRODUCT on any number of computers at the licensed SITE.  However, the PRODUCT is fully 
operational only in the SITE computer that carries the appropriate PRODUCT’s hardware key (“KEY”) 
that is used as software protection device. 

1.1.2  Network Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with 
ENSOFT and for the specific physical site(s) (“SITE(S)”) and IP range registered with ENSOFT.  Each 
network seat that is purchased is provided with access for SITE(S) clients located within up to 2 subnets 
with unique third octets (“CLIENT SUBNETS”).  The minimum two-seat network license can be 
associated to a maximum of 4 CLIENT SUBNETS (within up to 4 unique third octets).  Purchase of 
additional network seats can extend the allowable range of CLIENT SUBNETS. 
The USER may install and use the PRODUCT on any computer in the licensed SITE(S) that is within the 
allowable CLIENT SUBNETS registered with ENSOFT.  Any one computer in the network can be 
designated as license server for the PRODUCT by carrying the appropriate PRODUCT’s hardware key 
(“KEY”) that is used as software protection device. 
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This Network License strictly prohibits the PRODUCT to be used in or from computers located in office 
locations that are different than the licensed SITE(S) or outside the registered CLIENT SUBNETS.  Users 
in physical office locations other than the registered SITE(S) with ENSOFT are required to purchase 
additional licenses of the PRODUCT, even if the COMPANY is the same and/or if the additional offices 
are located in the same city. 

2.  OTHER RIGHTS AND LIMITATIONS 

2.1  EDUCATIONAL VERSION 

If the PRODUCT was licensed with educational discounts, the use of the PRODUCT is strictly limited to 
academic or research activities of educators and/or students.  Any other usage voids all the rights under this 
LICENSE.  If in doubt, please contact ENSOFT to determine if you have a PRODUCT version that was 
licensed for educational purposes. 

2.2  LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY 

You may not reverse engineer, decompile, or disassemble the PRODUCT, except and only to the extent 
that such activity is expressly permitted by applicable law notwithstanding this limitation. 

2.3  RENTAL 

You may not rent, lease or lend the PRODUCT to third parties. 

2.4  TRADEMARKS 

This LICENSE does not grant you any rights in connection with any trademarks or service marks of 
ENSOFT. 

2.5  SUPPORT SERVICES 

ENSOFT shall provide you with limited support and maintenance services (“SUPPORT”) related to the 
PRODUCT during the initial year after purchase and for any additional SUPPORT term that the 
COMPANY elects to purchase for PRODUCT after the initial warranty period expires.   
Use of SUPPORT is limited to the ENSOFT policies and programs described in the PRODUCT’s User’s 
Manual, in documentation on the ENSOFT web site, and/or in other materials provided by ENSOFT. 
Any supplemental software code that may be provided to you as part of the SUPPORT or that is 
downloaded from the ENSOFT web site shall be considered part of the PRODUCT and subject to the terms 
and conditions of this LICENSE.  With respect to technical information you provide to ENSOFT as part of 
the SUPPORT, ENSOFT may use such information for its business purposes, including for product 
support, development or advertisements.  However, ENSOFT will not utilize such technical information in 
a form that personally identifies the USER. 

2.6  SOFTWARE TRANSFER 

The initial user of the PRODUCT may make a permanent transfer of this LICENSE and PRODUCT and 
only directly to an end user.  This transfer must include all of the PRODUCT (including all component 
parts, the media and printed materials, any upgrades, this LICENSE, and the PRODUCT’s appropriate 
hardware KEY).  Such transfer may not be by way of consignment or any other indirect transfer.  The 
transferee of such one-time transfer must agree to comply with the terms of this LICENSE, including the 
obligation not to further transfer this LICENSE and PRODUCT. 

2.7  TERMINATION 

Without prejudice to any other rights, ENSOFT may terminate this LICENSE immediately if you fail to 
comply with the terms and conditions of this LICENSE.  In such event, you must destroy all copies of the 
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PRODUCT and all of its component parts and provide evidence of such destruction in writing to ENSOFT 
within 3 business days. 

2.8  INDEMNIFICATION 

Within and during the terms of this LICENSE, ENSOFT warrants that the use of the initially provided 
PRODUCT does not infringe any patent, copyright, or trademark in the United States, and ENSOFT shall 
indemnify and hold USER harmless against any and all losses, damages and expenses, (including 
attorney’s fees) which USER may sustain or incur as a result of a breach of this warranty. 

2.9  CONFIDENTIAL INFORMATION 

ENSOFT and the USER may have access to certain proprietary information and materials of the other that 
are confidential and of substantial value to the respective party, which value would be impaired if such 
information were disclosed to third parties ("CONFIDENTIAL INFORMATION").  ENSOFT and the 
USER agree that neither shall disclose any CONFIDENTIAL INFORMATION to any third party and shall 
take every reasonable precaution to protect CONFIDENTIAL INFORMATION. 
The provisions of this section shall not apply to any information which (i) is or becomes available to the 
public other than by breach of the LICENSE agreement by the receiving party, (ii) is rightfully received by 
receiving party from a third party without confidential limitations, (iii) is independently developed by 
receiving party's employees without access to CONFIDENTIAL INFORMATION, or (iv) is known to the 
receiving party without any restriction on its use or disclosure prior to first receipt of it from the disclosing 
party. 

3.  COPYRIGHT 

All title and intellectual property rights in and to the PRODUCT (including but not limited to any images, 
photographs, animations, video, audio, music, and text that may be incorporated into the PRODUCT), the 
accompanying printed materials, and any copies of the PRODUCT are owned by ENSOFT.  All title and 
intellectual property rights in and to the content which may be accessed through use of the PRODUCT is 
the property of the respective content owner and may be protected by applicable copyright or other 
intellectual property laws and treaties.  This LICENSE grants you no rights to use such content.  All rights 
not expressly granted are reserved by ENSOFT.  This PRODUCT is protected by the United States 
Copyright Law and International Copyright Treaty. 

4.  SOFTWARE DISCLAIMER  

Although the PRODUCT has been used with apparent success in many analyses, new information is 
developed continuously and new or updated PRODUCT releases may be written from time to time.  All 
users are requested to inform ENSOFT immediately if any errors are found in the PRODUCT.  As 
modifications, updates, or new versions are produced, the latest codes are posted on ENSOFT’s web site 
and made available to all visitors for free downloading. 
No warranty, expressed or implied, is offered as to the accuracy of results from ENSOFT’s PRODUCT.  
The PRODUCT should not be used for design unless caution is exercised in interpreting the results and 
independent calculations are available to verify the general correctness of the results.  Users are assumed to 
be knowledgeable of the information in the printed documentation that is distributed with the digital media.  
Users are assumed to recognize that the input parameters, eg., soil properties, increment length, tolerance 
on solution convergence, and many others, can have a significant effect on the solution and must be chosen 
carefully. Users should have a thorough understanding of the relevant theoretical criteria (appropriate 
references are suggested in the software documentation).  

5.  GOVERNING LAW 
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This LICENSE is governed by the laws of the State of Texas and laws and treaties of the United States of 
America. 

6.  CONTACT INFORMATION 

Should you have any questions concerning this LICENSE or if you desire to contact ENSOFT for any 
reason, please use the following: 
Ensoft Incorporated 
3003 West Howard Lane 
Austin, Texas 78728 
United States of America 

NO OTHER WARRANTIES 

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, ENSOFT DISCLAIMS ALL 
OTHER WARRANTIES AND CONDITIONS, EITHER EXPRESSED OR IMPLIED, INCLUDING, 
BUT NOT LIMITED TO, IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE, AND TITLE, WITH REGARD TO THE PRODUCT, AND 
THE PROVISION OF SUPPORT SERVICES.  THIS LIMITED WARRANTY GIVES YOU SPECIFIC 
LEGAL RIGHTS.  YOU MAY HAVE OTHERS, WHICH VARY FROM STATE/JURISDICTION TO 
STATE/JURISDICTION. 

LIMITATION OF LIABILITY 

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL 
ENSOFT BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL 
DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF 
BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY 
OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE 
SOFTWARE PRODUCT OR THE FAILURE TO PROVIDE SUPPORT, EVEN IF ENSOFT HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  IN ANY CASE, ENSOFT’S ENTIRE 
LIABILITY UNDER ANY PROVISION OF THIS LICENSE AGREEMENT SHALL BE LIMITED TO 
THE GREATER OF THE AMOUNT ACTUALLY PAID BY YOU FOR THE PRODUCT OR U.S.$1.00. 
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