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1.1 General Description 
 LPile is a special purpose program that can analyze a driven pile or a drilled shaft under 
lateral loading. The program computes deflection, shear, bending moment, and soil response with 
respect to depth in nonlinear soils. The program has graphical features for presentation of results 
and has additional features for special analyses. 
 The soil and rock are modeled using lateral load-transfer curves (p-y curves) based on 
published recommendations for various types of soils and rocks. The p-y curves are internally 
generated by the program. Alternatively, the user can input values for p-y curves for a soil layer. 
The program also contains specialized procedures for computing p-y curves in layered soil profiles.  
 Several types of pile-head loading conditions may be selected, and the structural properties 
of the pile may be varied along the pile length. Additionally, LPile provides guidelines for the 
layout of rebar arrangements and general design references for reinforced pile sections using the 
ACI 318 code. 

1.2 Program Development History 
1.2.1 LPile 1.0 for MS-DOS (1986) 

 When the IBM XT® personal computer was introduced in 1984, Dr. Lymon C. Reese, the 
founder of Ensoft, Inc., foresaw the benefits and improvements in analysis and design of pile 
foundations from using improved computer software. The development of LPile for its first 
commercial distribution was begun in 1985 and was completed in 1986. The general theory and 
methodology of LPile 1.0 was similar in features to COM624, which was run on large mainframe 
computers. LPile was completely rewritten using a new solver and features were provided for 
interactive input. LPile was developed for analyzing single piles and drilled shafts under lateral 
loading. This version of LPile was compiled using the IBM Fortran compiler to run on the IBM 
XT personal computer. LPile Version 1.0 had the following features: 

• The program could generate p-y curves internally for soft clay, stiff clay with free water, 
stiff clay without free water, and sand. The program also allowed users to input user-
defined p-y curves for a selected layer. 

• Modifications of the p-y curves for layered soils were introduced in the program based on 
the recommendations of Georgiadis (1983). 

• A total of four boundary conditions and loading types were available for the pile head. 
Distributed loading could also be specified at any pile depth. 

• An interactive input was provided for the user to prepare the input data step-by-step. 
• An analysis feature was provided for including tip-resistance curves. 

1.2.2 LPile 2.0 for MS-DOS (1987) 
 With the introduction of improved graphics hardware for personal computers such as color 
graphics monitors and an improved processor on IBM® AT-class computers, the features for 
graphical display of computed pile deflection, bending moment, shear, and soil resistance became 
desirable for engineering software. LPile 2.0 was introduced in 1987 with a companion graphics 
program. Improvements were also made on the main program and input data editor. 
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1.2.3 LPile 3.0 for MS-DOS (1989) 
 With the wide adoption of LPile by government agencies, universities, and engineering 
firms during the first three years, improvements in ease-of-use were considered essential. LPile 
3.0 was introduced in 1989 with an input data editor featuring pull-down menus, input tables, and 
on-screen help commands. Color graphics for CGA, EGA, and VGA displays were added to the 
output graphics post-processor program. The main program also added the new technical features: 

• New p-y criteria for vuggy limestone/rock. 
• Options for modifying internally-generated p-y curves for group action effects. 
• The pile head could be positioned either above or below the ground surface. 

1.2.4 LPile 4.0 for MS-DOS (1993) 
 LPile 4.0 was released in 1993, about four years after the previous upgrade. Features added 
to this version were: 

• New p-y criteria for cemented soils whose strength is represented using both cohesion and 
friction angle. 

• New p-y criteria for sand based on the recommendations of the American Petroleum 
Institute’s API-RP2A (1987). 

• New p-y procedures for including the effect of sloping ground on p-y curves for clays and 
sands. 

• New graphic plots for representing load versus deflection at the pile head and load versus 
maximum bending moment. 

1.2.5 LPile Plus 1.0 for MS-DOS (1993) 
 New technology for pile foundations enabled the incorporation of nonlinear properties for 
the pile’s flexural rigidity during analysis of their lateral deflections. Earlier, a companion 
computer program named STIFF was developed in 1987 to compute the relationship of applied 
moment versus flexural rigidity of a pile, and to compute the ultimate bending capacity for a 
specified structural section. LPile Plus was thus developed in 1993 by combining the capabilities 
of LPile 4.0 and STIFF. With the added functionality obtained from STIFF, LPile Plus had the 
capability to take into account the flexural rigidity of uncracked and cracked sections, which led 
to a improved solution for the flexibility of a pile under lateral loading. 

1.2.6 LPile Plus 1.0 for Windows (1994) 
 The introduction of Windows 3.1 from Microsoft, Inc. as the new platform for personal 
computers pushed software development into a new era with a demand for user-friendly features. 
LPile Plus 1.0 for Windows was released in 1994 with input preprocessor and output post-
processor developed specifically for the Windows operating system. 

1.2.7 LPile Plus 2.0 for Windows (1995) 
 The initial windows version for LPile Plus was released in 1994. The preprocessor program 
used a mouse with pull-down menu, dialog boxes, grid tables, and push buttons to improve the 
process of data entry. The graphics program, also running within the Windows platform, supported 
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any printer device recognized by the Windows environment. The main program added a feature 
for users to specify the rebar area at each location. 

1.2.8 LPile Plus 3.0 for Windows (1997) 
 With the 32-bit operating systems provided by Microsoft Windows 95 and Windows NT, 
software developers were provided with tools to develop user interfaces with advanced, high-
resolution graphics. LPile Plus 3.0 was developed based on the technological advances for new 
user interfaces. The significant new features of this upgrade are summarized as follows: 

• A new soil criterion for weak rock was added to the previously existing eight soil types. 
The p-y criterion for weak rock is primarily applicable to the weathered sandstone, 
claystone, and limestone with uniaxial compressive strengths of less than 1,000 psi. 

• An option was added to compute pile-head deflection versus pile length. This option 
generated a graph of pile length versus pile-head deflection that is helpful for determining 
the critical pile length. 

• A feature was added to compute values for a foundation stiffness matrix that may be used 
in structural analysis models for a certain range of loads. In this new feature, the program 
creates curves of incremental loading versus foundation stiffness components K22, K23, K32, 
and K33, as shown in Figure 1.1. 

 
Figure 1.1  Pile-head Stiffness Components 

• Improved features for file-management were also included to help the user. The user could 
use menu commands for data entry, computation, review of output, and display of graphics 
in a single computer program. 

• Data could be input in either SI units or US customary units and existing data could be 
converted to the other system of units.  

• All grid tables and entry fields for data entry were developed with functions that understand 
mathematics formulas and were aware of the current system of units.  

• The graphical display of output curves features a new interface that provided the ability to 
zoom in on areas of particular interest. The user may thus observe detailed behavioral 
measurements of any portion of the modeled pile. 
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1.2.9 LPile Plus 3.0M (Soil Movement Version) for Windows (1998) 
 An advanced version for LPile Plus was developed and was released in 1998 as Version 
3.0M. The LPile Plus 3.0M software is the standard LPile Plus 3.0 version with the addition of 
two additional capabilities: 

• The user is able to input a profile of soil movements versus depth as additional loading on 
the pile. The soil movements of the soil may be produced from any action that causes soil 
movements, such as movements due to slope instability, lateral spreading during 
earthquakes, and seepage forces. Version 3.0M uses an alternative solver for the governing 
differential equation to account for the lateral movement of the soils. 

• The user can input data for nonlinear curves of bending stiffness versus bending moment 
for different pile sections. This feature is useful for cases where the pile has different 
structural properties along its depth. 

1.2.10 LPile Plus 4.0/4.0M for Windows (2000) 
 LPile 4.0/4.0M was developed for compatibility with Windows NT, 95, 98, and 2000. 
Modules used for computations were compiled as dynamic link library functions, which 
significantly improved performance. The new features for this upgrade can be summarized as 
follows: 

• The program has the capability to generate and take into account nonlinear values of 
flexural stiffness (EI). These values are generated internally by the program based on 
cracked/uncracked concrete behavior and user-specified pile dimensions, and material 
properties for reinforced concrete sections. The program adds a new feature for analyzing 
prestressed concrete sections in Version 4.0. 

• The user can specify both deflection and rotation at the pile as a new set of boundary 
conditions in Version 4.0. 

• LPile Plus 4.0 can perform pushover analyses and analyze the pile behavior after a plastic 
hinge (yielding) develops.  

• Soil-layer data structures and input dialogs are improved in Version 4 to help the user enter 
data conveniently with default values provided. More than 100 error-checking messages 
are added into Version 4.0 

• Files opened recently will be listed under File Menu. New options for graphics title, 
legends and plot of rebar arrangement are incorporated into Version 4.0. 

• New data and formats are added to the output file in Version 4.0 

1.2.11 LPile Plus 5.0 for Windows (2004) 
 LPile Plus 5.0 was developed to meet needs for more versatility. Two more p-y criteria 
were added into the program. The feature of specifying soil movement became a standard in the 
program. The user can use a presentation graphics utility to prepare various engineering plots in 
high quality for presentations and reports. The new features for this version can be summarized as 
follows: 

• Version 5 allows the user to define multiple sections with nonlinear bending properties. 
This feature permits the designer to place reinforcing steel on sections of a drilled shaft as 
needed, depending on the computed values of bending moment and shear. 
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• Version 5 allows the user to enter externally computed moment vs. EI curves for multiple 
sections.  

• Version 5 can analyze the behavior of piles subjected to free-field soil movement in lateral 
direction. Free field displacements are soil motions that may be induced by earthquake, 
nearby excavations, or induced by unstable soils.  

• The p-y criteria for liquefiable sand developed by Rollins, et al. (2005a, 2005b), and p-y 
criteria for stiff clay with user-specified initial k values, recommended by Brown (2002), 
were added into Version 5.0. 

• The types and number of graphs generated by Version 5 have increased over previous 
versions. More importantly, the graphs may now be edited and modified by the user in an 
almost unlimited number of ways. 

• Many hints and notes were added into input windows to assist the user in selecting proper 
data for each entry. 

1.2.12 LPile 6 for Windows (2010) 
 The procedures for computation of flexural rigidity (EI) of pile were completely rewritten 
and introduced for Version 6. The new procedures are more numerically robust and generally 
produce moment-curvature relationships that are smoother and, in the case of reinforced concrete 
sections, slightly stiffer and stronger. 
 The input dialogs for structural sections now show the cross-section of the pile that updates 
to illustrate the current section data. The cross-section, number, and type of reinforcement are 
drawn to scale.  
 The user can specify either US customary units (pounds, inches, and feet) or SI units 
(kilonewtons, millimeters, and meters) for entering and displaying data. Most commonly used 
customary units such as lbs/ft2 for shear strength and lbs/ft3 for effective unit weight are used in 
Version 6.0. In general, units of inches or millimeters are used for cross-section dimensions, feet 
or meters are used for depth and length dimensions, and pounds or kilonewtons are used for force 
dimensions 
 Twelve p-y criteria for different types of soil and rock are included in Version 6.0.  
 The input dialogs for definition of soil properties have been improved to aid the user. 
Default values for some input properties are provided. Hints and notes are also shown on input 
dialogs to assist the user for data entry.  
 Over 175 error and warning messages have been provided, making it easy for occasional 
users to run the program and to solve run-time errors. 
 LPile Version 6 has the capability of performing analyses for Load and Resistance Factor 
Design. Up to 100 load combinations may be defined and up to 100 unfactored loads may be 
defined. Load case combinations are defined by entering the load factors for each load type and 
the resistance factors for both flexure and shear. Optionally, the user may enter the load and 
resistance factor combinations by reading an external plain-text file.  
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1.2.13 LPile v2012 – Data Format 6 
 LPile is currently being sold with a software maintenance contract. Users with active 
maintenance contracts may receive all updates and maintenance releases of LPile. In this system, 
the use of version numbers has been modified to permit the user to understand the basic differences 
between different releases of the program.  
 The first number is the calendar year of the release of the program. The second number is 
the data file format version number. Thus, all versions of the program that have the same data file 
format number can exchange data files without modification. The third number in the version 
number is the release version of the program since the data file format number was introduced. 
 The user should recognize that while all versions of the program with the same data file 
format number are largely compatible with one another, that the later release numbers of the 
program will often have additional features that earlier releases may lack. Thus, all users are 
encouraged to use the latest version of the program. 

1.2.14 LPile v2013 – Data Format 7 
 LPile 2013-7-01 introduced three analysis features to LPile. The first analysis feature was 
a modification of the controls used for pile-head stiffness matrix values to permit more choices by 
the user over how the computations were controlled. The second analysis feature added was an 
automatic pushover analysis control that permitted the user to perform pushover analyses using 
pile-head fixity options that were either free-head, fixed-head, or both for a range of pile-head 
displacements controlled by the user. The third analysis feature was an automatic pile buckling 
analysis with options for different pile-head fixity conditions. 
 Additional changes were made the user-interface. More speed buttons were provides to 
enable quick access to input and editing of all types of data and for display of graphics. In addition, 
new features were provided to check the Internet for new versions of the software and to open the 
User’s Manual and Technical Manual. 

1.2.15 LPile v2015 – Data Format 8 
 LPile 2015 introduced several new features, along with general improvements in the user 
interface.  The first analysis feature was the addition of  

• The p-y curve for massive rock developed by Liang et al. (2009).  
• Features to analyze multiple distributed loading profiles and multiple soil movement 

profiles defined for different load cases in conventional analysis. The original features to 
apply a single distributed load profile or a single soil movement profile to all cases were 
retained. 

• The addition of input of a section’s shear capacity for evaluation in Load and Resistance 
Factor Design analysis. 

• Soil layer profiles were added to all speed graphs displaying pile performance results 
versus depth. 

• The ability to import load test data for pile-head shear versus lateral deflection and bending 
moment versus depth for comparison to computed results. 

 Changes to the user interface included combination graphs of pile deflection, bending 
moment, and shear force versus depth and pile deflection, pile curvature, and bending moment 
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versus depth, and modification of the existing graphs of soil movements versus depth to show 
multiple soil movement profiles. 

1.2.16 LPile v2016 – Data Format 9 
• The p-y curve for the hybrid model for liquefied sand developed by Franke and Rollins 

(2013).  
• A feature to add additional sizes of reinforcing steel, including hollow bars and pipes. This 

feature is included under the Tools Menu.  
• A feature for running a list of data files sequentially (also called batch run mode). This 

feature is included under the Tools Menu. 

1.2.17 LPile v2018 – Data Format 10 
• Expanded pile section with new feature to estimate the nonlinear flexural response of shafts 

with structural cores using H (weak or strong) or other wide flange sections. 
• Another new feature on the structural model of pile sections is the ability to include the 

confinement effect for rectangular and circular shafts for moment-curvature analyses 
(following the Mander, Priestley & Park 1988 model for confined concrete). 

• Users can now select longitudinal reinforcement with user-defined bar area in any 
structural section that includes longitudinal rebar.  This is useful to model bars with some 
degree of degraded conditions (eg, from corrosion). 

• For structural analyses of pile sections, LPILE can now automatically build the full 
interaction diagram for each section (Data > Axial Thrust Loads for Interaction Diagram). 

• Users can choose to turn off the soil-layering correction criteria in models with multiple 
layers or to only use for layers of different soil types (p-y criteria). 

• This version allows for the modeling and analysis of embedded piles where the pile head 
is below one or more soil layers.  Previous versions required the pile head to be restricted 
within the top layer. 

• An improved computation method is being incorporated for models that have both, soil 
movement and batter piles/sloping ground (either).  In these models LPILE now uses a 
more conservative and theoretically-correct approach of opposite (different quadrants) p-y 
curves for computations of soil resistance and soil pressure. 

• All result plots can be exported to formatted Microsoft Excel spreadsheets (data and 
graphics) for ease of presentation editing. 

1.2.18 LPile v2019 – Data Format 11 
• Equivalent Elastoplastic Moment Curvature.  This is a definition used by engineers and 

consultants in seismic areas (based in technical documentation from CALTRANS) to 
define the formation of plastic hinges in piles analyzed under extreme loading or for push-
over analyses.  The post-hinge behavior is clearly defined in the deflection curves for 
pushover models. 

• EnCPT Import.  Ability to open data files with complete soil layering and properties 
defined by the new EnCPT v2019 program.  This separate program allows geotechnical 
consultants to offer to their clients new services for detailed interpretation of their CPT 
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tests into various layering and soil properties that can be used quickly and customized in 
LPILE v2019 models. 

• Optional input of a linear-elastic or nonlinear moment-vs-rotation curve at the pile tip that 
can be used to account for the response of short or very large diameter piles. 

• Standard list of CFCC strands are now available for all prestressed pile sections. 
• New option to Extend Printed p-y Curves up to Maximum Demand Displacement (under 

the Data > Program Options and Settings > Generate p-y Curves at User -Specified 
Depths).  With a checkmark on this new option, the program will print the p-y curves after 
the analyses are completed and it will extend the p-y curve to the maximum demanded 
displacement (for all load cases). 

• Improved computations of buckling to take into account increased flexural stiffness with 
increased axial loads in concrete sections (Data > Program Options and Settings > 
Compute Pile Buckling Analysis).  Also added a new feature for users to specify a minimum 
compression load for buckling analysis. 

• New 3D View graphics to easily observe and present LPILE models and main results (in 
outline graphics with optional display of maximum values). 

• Program now keeps applicable values/properties of soils when users change the soil types.  
This is helpful to speed up unnecessary repeats of data entry. 

• When inserting a new row entry of pile loads/boundary conditions the program now 
reproduces the entry that is just above the new row.  This can help users entering similar 
load/boundary conditions. 

• Improvements were made to calculations of rebar stress/strain in section analyses. 

1.2.19 LPile v2022 – Data Format 12 
• Introduces the ability to specify concentrated loads (bending moment and/or shear) at any 

point along the length of the pile. 
• New features for analyzing the effects of short piles with large diameter: specification of 

Moment Resistance at Pile Tip and/or Moment due to Side Resistance along the Pile. 
• Introduction of new p-y criteria for “Small Strain Sand” with refined study of the early 

response of sands under small lateral movements.  The new p-y curves are associated to 
the shear wave velocity/shear wave modulus of sand layers. 

• All changes to plot/graphics (titles, legends, etc) done by the user are now associated and 
saved with the LPile model. 

• Introduces the option to analyze the effects of shear deformations in elastic pile sections. 
• New optional estimation of resistance factors and shear capacity of reinforced concrete pile 

sections based on ACI 318-14 code specifications. 
• Users are now able to evaluate and observe in one model the effects of varying pile 

penetrations (to check influence in deflection, bending moment and/or shear profiles). 
• Definition of ground slope has been expanded so as to include a slope on one or both sides 

of the modeled pile. 
• Pushover analyses of elastoplastic pile sections can now be stopped if a second plastic 

hinge is developed. 
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• Models with multiple load cases at pile head are now easier to prepare with new ability to 
Copy/Paste load definitions from clipboard or from external file. 

• Users are now able to enjoy the new v2022 Technical Manual in standard PDF file format. 
• Improvement in the Tools > Multi-File Analysis (Batch Run) Controls with ability to read 

an external text file containing the list of files for a large batch run (up to 100 files).  Also 
improved the memory handling for large batch runs. 

• Minor changes were also made throughout the program interface to improve data input and 
output displays. 

1.3 Contents of the LPILE Package 
The standard package sent with LPILE consists of the following items: 

• One USB Key (sometimes known as hardware key or dongle), 

• One USB Memory Stick with installation programs for all Ensoft software products (this may 
be missing in future releases, since the full program is available for downloading from the 
www.ensoftinc.com website). 

1.4 Default Installation Directories 
The directories for installation of program files and for example files are selected by the user during 
program installation.  Default values are provided by the installer and confirmed or changed by 
the user. 

1.4.1 Directory for Main Program Files 
Program files are installed by default in the following directory: 

Root Drive:\Program Files (x86)\Ensoft\LPile2022 

In most cases the Root Drive is the c:\ drive so the default is: 

c:\Program Files (x86)\Ensoft\LPile2022 

Main program files are the following: 

LPile2022.exe is the main Windows-program module (executable/application), 

Lpile12CE.dll  is the program engine for direct computations, 

libiomp5md.dll  is an internal runtime library, 

User’s and Technical Manuals are also included in the main installation directory. 

1.4.2 Directory for Example Files 
Several modeling examples with input files (files with name/extension of the type filename.lp12d) 
are installed on a separate folder that defaults to: 

Root Drive:\Ensoft/LPile2022-Examples 

In most cases the Root Drive is the c:\ drive so the default is: 

http://www.ensoftinc.com/
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c:\Ensoft/LPile2022-Examples 

1.5 Hardware Requirements  
To use LPILE, the user needs the following minimum hardware configuration: 

• Any personal computer with an Intel® Pentium® or newer processor.  
• A hard disk with at least 50 MB of free space.  

• Microsoft Windows™ 2000, XP, VISTA, Windows 7, Windows 8, Windows 8.1 or Windows 
10 or 11 in either 32-bit or 64-bit releases.  A release of the Microsoft Windows™ system that 
is newer than those listed may need a new update of the software. 

• Minimum of 640 KB of free RAM memory. 

• Open (available) USB port (v2 or newer). 

• Graphics card compatible to the Microsoft Windows™ operating system that is being used and 
also compatible with OpenGL. 

• A mouse or similar pointing device.  

• Optional: Any windows-compatible printer.  

1.6 Technical Support 
Although the LPILE computer program was designed for ease of use in practical commercial 
applications, questions may be answered in the accompanying User’s and Technical Manuals.  In 
addition, the technical staff at ENSOFT strongly supports all registered users with questions 
related to the installation or use of LPILE, according to the stipulations presented below.  The 
software is provided with free maintenance service (including support) for the first year.  After the 
first year the user is encouraged to purchase the yearly maintenance service.  The yearly 
maintenance service includes free download of the latest version and free technical support for 
installation and usage issues as described below. 

1.6.1 Preferred Methods of Software Support  
Software support is given, in order of preference, by the following methods:  

• Electronic mail to: support@ensoftinc.com 

• Fax to: (512) 244-6067 

• Telephone call to: (512) 244-6464, extension 2 

Users are strongly encouraged to utilize electronic means of support via email.  In all technical 
support requests via email, please include the following information: 
1. full software version/release/update (obtained from the Help > About dialog), 
2. a description of the user’s problem or concern, 
3. attach a copy of the input-data file that is associated with the issue/concern (files with 

name/extension of the type filename.lp12d), and  
4. name and telephone number of the contact person and of the licensed user (or name and office 

location of the licensed company site and/or serial number of the user’s USB Key). 

mailto:support@ensoftinc.com
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Although immediate answers are offered on most technical support requests, please allow up to 
two business days for a resolution in case of difficulties or schedule conflicts. 

Technical help by means of direct calls to our local telephone number, (512) 244-6464, is available, 
but is limited to the business hours of 9 a.m. to 5 p.m. (US central time zone, UTC −6:00). The 
current policy of Ensoft is that all telephone calls for software support will be answered free of 
charge if the user has a valid maintenance contract. 

1.6.2 Upgrade Verification and Internet Site 
Starting from LPILE v2016 the software provides options for the user to check the most recent 
maintenance release through an internet connection by selecting Help > Check for Updates.  This 
command starts the default internet browser and will display the user’s maintenance expiration 
date, the user’s software release number and the most recent release number that is available for 
downloading. 

If the user’s version is not the latest version and the maintenance has not been expired, the user 
can download the latest version from our web server directly (www.ensoftinc.com).  Users may 
also consult our internet site for additional information on software updates, demos, and new 
applications; technical news; and company information.  

1.6.3 Renewal of Program Maintenance 
The cost to renew program maintenance will depend on the length of time for which the program 
maintenance has been expired.  There are small price increases with time after expiration.  The 
pricing policy for renewing a program maintenance that has not expired can be found on the Ensoft 
website at https://www.ensoftinc.com/order_form 

1.6.4 Changes of Support Policy  
The software support policy and associated expenses are subject to change at ENSOFT’s discretion 
and without specific mailed notices to the users. However, any change of rules will be verbally 
provided during telephone calls for software support.  

 
 

http://www.ensoftinc.com/
https://www.ensoftinc.com/order_form
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2.1 Installation Procedures 
Program LPILE is distributed with an associated USB Key (hardware key or dongle).  The USB 
Key consists of a device that should be attached to a working USB port (or USB hub) of the 
computer in use (or in the designated software server in the case of local network licenses).  This 
method of software protection has been found to provide compatibility with existing operating 
systems, better stability than other alternatives, and allows users to obtain software updates or 
replacements via downloads from the internet. 

Users with standard single-user licenses can check the following link to a PDF with Installation 
Notes: https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf 

Users with local network licenses can check the following link to a PDF with Network Installation 
Notes: https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf 

2.1.1 Installation of Single-User Version 
This version of LPILE has been tested to be compatible with the following versions of the 
Microsoft Windows® operating systems: 2000, XP, Vista, and Windows 7 and 8, 8.1, 10 and 11 
in 32 and 64-bit releases. 

The following guidelines are recommended during the installation process of LPILE for single-
user licenses. 
1. Plug the supplied USB Key into one of the available and working USB ports in your computer.  The 

USB Key is plug-and-play compatible so the operating system will recognize the USB Key 
automatically and a small but solid green light should appear at the end of the USB Key (a flickering 
green light or no light indicate problems with the standard windows driver or with the USB Key). 

2. If the user installs from a distribution USB Memory Stick and the main installation program does not 
start automatically upon insertion of the Memory Stick then click on the Windows Start Menu 
button and select Run.  On the command line, type d:\setup.exe or e:\setup.exe, where d: or e: 
represents the drive that contains the distribution Memory Stick.  Click OK to execute the command 
and start the main installation program for ENSOFT’s software.  A screen similar to the one in 
Figure 2.1 should appear. 

3. If the user installs from a downloaded file, then please run the downloaded file (double click) and go 
to instruction #5. 

4. Click anywhere on the Lpile 2022 icon and then click on the Install Standard button to start the 
installation of LPILE. 

5. The user should read the license agreement shown in Figure 2.2.  Users can review the License 
Agreement online in the following link: 

https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf 
The installer will place the same file (Ensoft License and Disclaimer.pdf) in the installation 
directory.  Please click Yes if you agree and would like to proceed. 

6. Select Single-User License in Figure 2.3 then click Next.  For network installations please contact 
Ensoft support (support@ensoftinc.com). 

https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf
mailto:support@ensoftinc.com
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7. The user will be provided with an option to select a drive and directory for the installation of 
example files (see Figure 2.4).  Default installation directory is the following: 
(Root Drive):\Ensoft\Lpile2022-Examples 

8. The user will also be asked to select a drive and directory for the installation of LPILE (see Figure 
2.5).  Default installation directory (varies according to the Windows release where it is installed) is 
one of the following: 
(Root Drive):\Program Files (x86)\Ensoft\Lpile2022 
(Root Drive):\Program Files\Ensoft\Lpile2022 
If the desired directory does not exist, the installation program will automatically create a new 
directory in the chosen hard drive. 

 
Figure 2.1   Main Installation Screen for ENSOFT Software (may change with time) 

9. During the installation the user will be asked to set the file extension association for opening LPILE 
v2022 input data files (see Figure 2.6).  If the user agrees (leaves the default check mark) then 
double clicking (or running) any input data file with extensions of the type filename.lp12d will start 
the installed LPILE v2022 software. 
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10. The user will be prompted to confirm the shortcut directory name that will be created in the 
Windows Start Menu (See Figure 2.7).  The default is Start Menu/Programs/Ensoft/Lpile2022.  
Windows 11, 10 and 8 will automatically create an Ensoft tile with the same shortcuts. 

After the installation is finished, it is usually not necessary to reboot Windows for the program to 
run.  The user may run the program by selecting LPile v2022 from the standard links installed in 
the Microsoft Windows® Start Menu:  Start Menu > All Programs > Ensoft > Lpile2022 
 

 

 
Figure 2.2   Installation Screen with License Agreement (may change with time)  
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Figure 2.3  Selection of Single-User License (may change with time)  

 
Figure 2.4  Default Installation Directory for Example Files (may change with time) 
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Figure 2.5   Default Installation Directory for Program Files (may change with time)  

 
Figure 2.6   File Extension Association for LPILE Data Files (may change with time)  
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ENS 
Figure 2.7   Default Shortcut Folder in Windows Start Menu (may change with time)  

2.1.2 Introduction of Network Version 
Special network licenses and Net USB Key (network hardware key) are available for users that 
desire to operate LPILE on a Windows network.  The network version is limited to users within a 
limited range of IP addresses that are employed at a named licensed office site. 

Network versions of LPILE have special subroutines written for installations in “software servers” 
(License Servers) and for installations of “individual clients” (Client Computers).  The “software 
server” is the computer that will be carrying the network key provided by ENSOFT, INC.  The 
software server is not necessarily the same as the existing network server.  Any computer in the 
existing Windows network may be designated software server for LPILE as long as the Net USB 
Key is attached to a working USB port (or through an USB hub) and the “server” version of the 
software or of the Ensoft Utilities is installed on its hard drive. 

Software “clients” are other computers of the network that are accessed by employees of the 
licensed office site and that have the software installed as client.  Client computers do not need 
any hardware key or dongle attached to their local system.  The program installed in “client 
computers” will be allowed to run as long as the computer designated as “software server” is 
accessible on the network with the proper operating system and with its network key secured in 
place. 
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2.1.2.1 Installation of Network Version 

Installers of network licenses should refer to a separate booklet with installation instructions for 
the Network version of this product.  The document can be downloaded from the Ensoft web site: 

https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf 

2.1.2.2 Silent Installations on Client Computers 

For installation of network licenses on local client computers there is an option for command-
based installations that are completely silent (performed without other user input).  Instructions for 
silent installations on client computers can be downloaded from the Ensoft web site using the 
following link: 

https://www.ensoftinc.com/doc/Silent%20Install%20on%20Client%20Computers.pdf 

2.1.3 Backup of Original Software 
The distributed software may be copied for backup purposes.  The program may be installed in 
several computers at the same time.  However, unless network licenses are purchased, the program 
will only operate in the computer that carries the appropriate USB Key. 

2.1.4 Software Updates on the Internet 
Occasionally, ENSOFT will produce software improvements and/or fixes and place the latest 
software programs on ENSOFT’s internet site.  Users can check for available updates by selecting 
Help > Check for Updates from the PYWALL menu.  Software users may freely download the 
latest program update from the PRODUCTS > Downloads link in the following site:  
http://www.ensoftinc.com 

2.2 Getting Started 
A flow chart showing the menu choices and features of LPile is presented in Figure 2.8. The 
following paragraphs provide a description of the program functions and will guide the user in 
using the program. 

https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Silent%20Install%20on%20Client%20Computers.pdf
http://www.ensoftinc.com/
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Figure 2.8  Principal Operations of LPile 

Start the program by navigating to the App shortcut in the Windows Start Menu and clicking on 
it.  The main program window will appear in the default condition shown in Figure 2.9. You should 
see a program window with a toolbar at the top with the following choices: File, Data, 
Computation, Graphics, Tools, Window, and Help. A button bar is displayed under the menu bar 
that provides quick access to most of the features of LPile. 

 
Figure 2.9  Main Window of LPile 

As a standard Windows feature, pressing the Alt key displays the menu operations with underlined 
letters. Pressing the underlined letter after pressing Alt is the same as clicking the operation. For 
example, to open a New File, the user could press Alt-F, N, in sequence, Ctrl+N, or click File then 
New. Additionally, holding the mouse cursor over a button will show a help bubble that describes 
the button’s function. 

Data Menu Computation 
Menu

Tools
Menu

Graphics
Menu

File Menu

Most menu commands are accessible via the button bar

Help
Menu
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2.2.1 File Menu and Buttons 

The File menu shown in  

Figure 2.10 is used to control basic file operations for input data files. Most of these program 
functions are also available from the button bar by pressing the button with the identical icon. 

 

Figure 2.10  File Menu 

A list of most-recently-used files is displayed in between Save As… and Exit. 
New: Create a new data file. 
Open…: Open an existing data file. If a partially completed LPile input file, or an invalid 
data file is opened, an information dialog reporting that an “invalid or incomplete” file is 
being opened. Clicking OK dismisses the message, and the previously saved data should 
be available. If a complete input file is loaded, an information dialog reporting that “Data 
File: (name of file), has been read by LPile” should appear, and the user should click OK. 
Save: Save input data under the current file name. 
Save As…: Save input data under a different file name. 
Save LRFD Combos…: Save LRFD Combinations in separate data file (visible only when 
in LRFD mode after entering or loading some Load and Resistance Cases). 
Exit: Exit the program. If the input file was modified but unsaved, a prompt will appear 
asking if the user would like to save changes. 

The group of four speed buttons at the left side of the button bar (shown in Figure 2.11) provide 
access to the New, Open, Save, and Save As commands. 
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Figure 2.11  Speed Buttons for File Management 

2.2.2 Data Menu and Buttons 
Please refer to Chapter 3 for a detailed discussion of this pull-down menu. 

The group of speed buttons shown in Figure 2.12 provides access to the data editing commands in 
the different modes of analysis. Not all of these speed buttons are enabled, since they depend on 
specific options and features that are selected by the user for modeling. 

 

(a) Buttons Available for Conventional Analysis 

 

(b) Buttons Available for LRFD Analysis 

 

(c) Buttons Available for Compute Nonlinear EI Only Analysis 

Figure 2.12  Speed Buttons for Data Input for Different Analysis Modes 

 Five speed buttons are provided to review the input data in graphical form.  The top middle 
button shown in Figure 2.13 displays the pile and soil layer profile in elevation view while the top 
right button displays a three-dimensional representation of the pile and soils.  The lower right 
button presents a set of charts for reviewing the input soil and rock properties. The upper left button 
presents a graph of distributed lateral loading versus depth. The lower left button presents a three-
panel graph of the p-modifier versus depth, y-modifier versus depth, and the ratio of p-modifier 
over y-modifier versus depth. 

 
Figure 2.13  Speed Buttons for Input Data Review 
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2.2.3 Computation Menu and Buttons 
 The Computation menu shown in Figure 2.14 is provided to access commands to analyze 
the input data and to view the input and output report files generated during an analysis. 

 
Figure 2.14  Computation Menu 

 The Run Analysis button shown in Figure 2.15 analyzes the current input data and the View 
Report button displays the current output report. Analyses can be performed successfully only 
after all data has been entered and saved. If the data has not been saved, LPile will prompt the user 
to save the file. If the data file has been named, the existing data set will automatically be re-saved 
to disk prior to running an analysis. 

 
Figure 2.15  Speed Buttons for Run Analysis and View Report 

2.2.3.1 Run Analysis 

 The Computation > Run Analysis command processes the current input data. Analyses can 
be performed successfully only after all data has been entered and saved.  If the data has not been 
saved, LPile will prompt the user to save the file.  If the data file has been named, the existing data 
set will automatically be re-saved to disk prior to running an analysis. 

 A general description of the files created by LPILE is presented in Table 2.1.  Every 
successful run of LPILE thus generates several text files in the same drive and directory where the 
input-data file was saved or opened.  Any of these files may be opened with standard text editors 
or word processing programs. 

File Description File Extension 
Input file for LPile *.lp12d 
Output report file *.lp12o 

Processor run notes file *.lp12r 
Graphics titles file *.lp12t 

LRFD load and resistance combinations *.lr12d 
Moment-curvature output files *.txt 

Table 2.1  File Types and File Extensions 
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 If there are input or runtime errors during execution, appropriate error messages will appear 
in the dialog box. In most cases, the program will display information that explains the causes of 
error and suggest corrective actions. If the analysis is completed, but non-fatal warning messages 
for unusual situations warranting the attention of the user are generated, the appropriate warning 
will be shown prior to displaying a summary graph of the analytical results. If no error or warning 
messages are generated, the summary graph of results will be displayed after the analysis is 
completed.  

2.2.3.2 View Input Text 

The Computation > View Input Text File command activates the user-specified text editor to display 
the analytical input data in plain-text format. This command is available after the input data has 
been saved, or when opening an existing input-data file. It is useful for experienced users who may 
just want to change quickly one or two parameters using the text editor, or for users wishing to 
observe the prepared input data in text mode. 

2.2.3.3 View Processor Run Notes 

 The program begins each analysis by first saving the current data to disk, then starting the 
analysis routine that reads the input data from the saved disk file. If an error is detected, the 
program will display a message dialog that informs the user about the type of error and, in many 
cases, will suggest a solution for the error. Input errors may consist of missing data, erroneous 
data, or inconsistent data. Usually, the content of the error message dialog is copied to the 
Computation > View Processor-Run Notes file. If the processor-run notes end without listing the 
line “The Execution is in progress…,” the user should check the input corresponding to the last 
line read and the line that immediately follows (that was not read). In some cases, the processor-
run notes will also include an error message.  

2.2.3.4 View Output Report 

 The Computation > View Output Text File command opens the output report in the text 
editor. This command becomes available only after a successful run has been made. Some output 
files may be too large for Microsoft Notepad to handle, so other text editors (Microsoft WordPad, 
for example) might need to be used. Often, some versions of Microsoft Windows will 
automatically switch to the alternative program without intervention by the user. Output report 
files usually contain the following information: 

• Authorized user name, company, and security device serial number information. 
• The date and time of the analysis. 
• When nonlinear bending sections are part of the data, the output will contain results of 

computations of nominal bending moment capacity and nonlinear moment curvature, including 
bending stiffness as a function of axial thrust force, including a report of the input data as well as 
tables of the computational results. 

• A report of input data for pile analysis. Users are strongly recommended to check this report of 
input data for mistakes. 

• If selected, reports for selected p-y curves at user-specified output depths. 
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• Tables of computed values of deflection, bending moment, shear, soil resistance, and related 
information, as a function of depth for the pile. 

• Reports of convergence performance of the finite-difference approximations, providing data 
about the maximum moment and lateral force imbalances observed during execution (maximum 
imbalances should usually consist of small numbers). 

• Summary tables, containing information about the results and number of iterations performed 
until convergence was reached. 

• An optional summary table of pile-head deflection versus pile length. 
• An optional summary table of foundation stiffness matrix components. 

2.2.4 Graphics Menu and Buttons 
 Please refer Chapter 4 of this manual for a detailed discussion of the Graphics Menu. 
 The group of buttons shown in Figure 2.16 provides access to the graphs generated by 
LPile. Not all buttons shown will be enabled, the enabled buttons depend on the options selected 
and the output generated in each analysis. 

 
Figure 2.16  Graphics Buttons 

2.2.5 Tools Menu 
The Tools Menu has the entries shown in Figure 2.17 that are described as follows. 

 
Figure 2.17  Tools Menu 

Simple Calculator.  This entry provides a simple calculator for the user’s convenience. 

Battered Pile Load Calculator.  Provides a special calculator to compute axial and transverse 
forces acting on battered piles as computed from user-inputted horizontal 
and vertical loadings. 

The third to fifth entries provide a means of entering additional sizes of reinforcing steel bar sizes 
to LPile. Note that this feature provides a means of entering hollow bars and steel access tubes. 

Edit Custom Reinforcing Steel Bar Sizes.  Displays an input table to enter and edit the data 
for the custom reinforcing bar sizes. 
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Load Custom Bar Sized into Memory.  Transfers the data for custom reinforcing bars into 
the memory of LPile and enters the names of the bars into the drop-down 
combination edit controls for selection of the size of reinforcing bars. Note 
that the custom bar sizes are at the bottom of the drop-down lists for bar 
sizes available for normally reinforced concrete sections. 

Save Data File of Custom Bar Sizes.  Saves the custom bar sizes to a data file named 
Custom_Rebar.dat. This data file is stored in the same program folder as 
the main LPile program. When LPile is started, LPile checks the program 
folder for a file with this name. If the file is found, it is read and the data 
is stored into program memory. Thus, it is not necessary for the user to re-
enter the custom bar data each time the program is run. Whenever the user 
wishes to exchange data files with another user, the data file for custom 
bar sizes should also be provided to the other user, as the list of custom 
bar sizes is not included as part of the LPile data file. 

Multi-File Analysis.  This entry provides a feature to define a list of existing LPile data files 
to be run as a batch and the command to perform the batch analysis. This 
feature is discussed in more detail in Chapter 5. 

2.2.6 Window Menu 
 The Cascade command on the Windows menu organizes all open windows so that they are 
all visible.  

2.2.7 Help Menu 
 The Help menu provides commands to view the manuals for LPile, descriptions of 
messages, information on technical support, program updates to LPile and access to the utility to 
check the associated USB Key (for license information). The Help pull-down menu is shown in 
Figure 2.18. Descriptions of the pull-down menu commands are described in the following 
sections. 

 
Figure 2.18  Help Menu 
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2.2.7.1 LPile Manuals 
 This command opens a side menu to commands to view the User’s Manual and Technical 
Manual for LPile. These manuals can also be opened from the Windows Start Menu. 

2.2.7.2 List of Input Error Messages 
 This command opens a dialog that lists the input error messages generated by LPile. The 
full list of input error messages is listed in Appendix 1.  

2.2.7.3 List of Runtime Error Messages 
 This command opens a dialog that lists the runtime error messages generated by LPile. The 
full list of runtime error messages is listed in Appendix 2.  

2.2.7.4 List of Warning Messages 
 This command opens a dialog that lists the warning messages generated by LPile. Note 
that when warning message are displayed computations can be performed by LPile, but that the 
results of the computations may be in error due to input values that may not be appropriate. The 
purpose of the warning messages is to call the user’s attention to input values that may not be 
correct. The full list of warning messages is listed in Appendix 3.  

2.2.7.5 Information on Technical Support  
 Displays information about eligibility for receiving technical support and how to receive 
technical support from Ensoft. 

2.2.7.6 Check for Updates to LPile 
 Opens the LPile update page in the user’s default browser. Note that some anti-virus 
programs may require the user to grant permission to LPile to open the Internet browser program. 

2.2.7.7 Ensoft Key Inquirer 
Access to the utility that is used to check for licensing information on the USB Key that is 

connected to a working USB port of the computer in use. This provides information such as serial 
number, maintenance expiration date, etc. 

2.2.7.8 About LPile 
 This command provides a dialog describing the program version, date, and methods for 
accessing technical support. Other information about the program licensing and maintenance 
expiration date, program version, and program release date are also shown. An example is shown 
below. 
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Figure 2.19  Example of About LPile Dialog 

 



 

 

CHAPTER 3. Input of Data 
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3.1 General Notes for Data Input 
 The input of required data for an analysis is controlled by the options chosen in the Data > 
Options and Settings dialog. It is recommended that the user select and enter data in a progressive 
manner, starting from the top of the Data menu. Most Windows may optionally be left open on 
the screen. The selection of other menu commands will then open additional windows on top of 
those that were left open. Many of the input dialogs will have buttons to add, delete, or insert rows 
for data. The Add Row button (Ctrl+A) always adds a new row to the end of all existing rows, and 
the Delete Row button (Ctrl+D) deletes the row where the cursor is currently located. 
 All entry cells that require numeric data may accept mathematical expressions as entries. 
In general, one may enter numerical expressions in the same manner as most spreadsheet programs 
allow, but one must omit the leading equal sign. Entering a mathematical expression works 
similarly to entering normal numeric data; the user simply types the expression then presses the 
“Enter” key.  
 A list of supported operations and numerical constants are shown in Table 3.1, along with 
the order of precedence of operations. Implicit mathematical operations using constants is not 
inferred. Instead, the user must enter an expression with an operator, e.g. 2*pi instead of 2pi. 
Negation of the constants π or e is not allowed directly, but these constants may be bracketed by 
parentheses. For instance, instead of entering –pi the user must enter −(pi). Scientific notation is 
inferred by the program if “e” or “E” is immediately following by a number (e.g. 29e6 or 0.5e−5) 
for input of large or small numbers. After an expression is evaluated, the computed numbers will 
be displayed using standard numerical notation. 

Mathematical Operator 
(listed in order of precedence 

Description 

( ) Parenthesis (may be nested) 

^ Exponentiation 

* Multiplication 

/ Division 

+ Addition 

– Subtraction/Negation 

Mathematical Constant Value 

pi  (π) 3.14159265358979324… 

e (base of natural logarithms) 2.71828182845904524… 

Table 3.1  Mathematical Operators and Numerical Constants Used in LPile Input 
Dialogs 
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3.2 Speed Buttons for Data Entry 
 The button bar contains a set of buttons to open the dialogs for the entry and manipulation 
of data. The buttons for data entry for conventional analysis are shown in Figure 3.1, for 
Computation of EI only are shown in Figure 3.2, and for LRFD Analysis are shown in Figure 3.3. 

 
Figure 3.1  Buttons for Data Entry and Manipulation for Conventional Analysis 

 
Figure 3.2  Buttons for Data Entry and Manipulation for Computation of Nonlinear EI Only 

 
Figure 3.3  Buttons for Data Entry and Manipulation for LRFD Analysis 

3.3 Data Menu 
 The editing commands are presented on the Data menu shown in Figure 3.4. The 
commands in the upper three sections of the Data menu are enabled by default when LPile is 
started. Many commands under the Data menu are enabled by activation of relevant program 
options. Not all buttons are enabled by default, the buttons that are enabled on the Data menu 
depend on the options that the user selected for each analysis (under Data > Options and Settings). 
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Figure 3.4  Data Menu 

 The icons shown in the Data menu are the same as those used to access the same editing 
dialogs via the speed button bar.  

3.4 Project Information Dialog 
 The Data > Project Information dialog, shown in Figure 3.5, is used to enter identifying 
information for the current analysis. Entry of Project Information is optional. Five lines of 
information can be entered. Default prompts for project, job number, client, engineer’s name, and 
description are provided, but may be over-written with any information provided by the User. Also 
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shown in the dialog is additional information on file path, input and output filenames, date and 
time of analysis that is routinely written in the output report file. 

 
Figure 3.5  Sample Data > Project Information Input Dialog 

3.5 Options and Settings Dialog 
 Almost all program options have been consolidated into the Data > Options and Settings 
input dialog box. The Data > Options and Settings dialog is used to select options and settings for 
each set of data being analyzed by LPile. This input dialog provides options that are generally 
grouped into: Computational Options, Engineering Units Options, Analysis-Control Options, 
Output Options, Loading Options, and Text Viewer Options. There are default settings provided 
if the user does not have any desire to make a change. The user should remember to click the OK 
button in order to save the accepted selections; otherwise, the selections will not be stored when 
the dialog is closed. 
 There are several computational options displayed in the upper left corner of the Data > 
Options and Settings dialog shown in Figure 3.6. These options are: 
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Figure 3.6  Program Options and Settings Dialog 

3.5.1 Computational Options 
The Computational Options are: 
 Conventional Analysis Mode 

If checked, LPile permits input of up to 100 load cases for various pile-head loading and 
displacement conditions. When Conventional Analysis Mode is selected, several additional 
options further below become active. 

 LRFD Analysis Mode (Load and Resistance Factors) 
If checked, LPile will perform Load and Resistance Factor Design (LRFD) computations. 
In this mode, the user may enter up to 100 unfactored shear and moment loads of various 
loading types (dead load, live load, etc.). All loads are assumed to be for shear and moment 
pile-head loading conditions. The program will then add all loads of the same load type to 
obtain the total unfactored load for each loading type. Optionally, the LRFD case load 
combinations may be either read from or saved to an external file (with the file type of lrfd) 
or may be entered by the user. 

 Nonlinear EI Only Mode 
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If checked, LPile will compute nonlinear moment-curvature relations and nominal 
(unfactored) and ultimate (factored) moment capacities of the pile sections for the specified 
axial thrust force values. 

The following options become active for Conventional and LRFD analyses. 
 Include Pile Batter and/or Ground Slope 

Activates the Data > Pile Batter/Ground Slope menu. 
 Use Modification Factors for p-y Curves 

Activates the Data > Modification Factors for p-y Curves menu.  These modification factors 
are usually employed to account for “Group Action” from closely-spaced piles. 

 Include Shearing Resistance at Pile Tip 
Activates the Data > Shear-Resistance Curve at Pile-Tip menu. 

 Include Moment Resistance at Pile Tip 
Activates Data > Moment-Resistance Curve at Pile-Tip menu. 

 Include Moment due to Side Resistance along Pile 
Activates the Data > Side-Resistance Along Pile menu. 

 Include Shear Deformation Effects 
This is only available for Data > Pile Properties using Elastic sections (for those section 
names with the word “Elastic”). The influence for consideration of shear deformation is 
expected to be small for most cases.  The theoretical background for this option is explained 
in the separate Technical Manual. 

The following options become active only when using Conventional analyses. 
 Use Loading by Single Distributed Load Profile 

Activates the Data > Distributed Lateral Loading menu to enter a single distributed loading 
(for one or all load cases). 

 Use Separate Distributed Load Profiles for Each Load Case 
Activates the Data > Distributed Lateral Loading menu to enter several data of distributed 
loading that can be associated to each load case. 

 Use Loading by Single Soil Movement Profile 
Activates the Data > Lateral Soil Movements menu to enter a single set of soil movements 
(for one or all load cases). 

 Use Separate Soil Movement Profiles for Each Load Case 
Activates the Data > Lateral Soil Movements menu to enter several data sets of soil 
movements that can be associated to each load case. 

 Use Single Concentrated Load Profile 
Activates the Data > Concentrated Loads Along Pile menu to enter a single set of 
concentrated loads (Shear and/or Bending Moment) at any point along the length of the 
pile (for one or all load cases). 

 Use Separate Concentrated Load Profiles for Each Load Case 
Activates the Data > Concentrated Loads Along Pile menu to enter several data sets of 
concentrated loads (Shear and/or Bending Moment) at any point along the length of the 
pile that can be associated to each load case. 
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 Consider Variation of Pile Length 
Activates the Data > Controls for Computation of Variable Pile Length Analysis menu. 

 Compute Pile-Head Stiffness Matrix Values 
If this option is selected, LPile computes the pile-head stiffness matrix values according to 
the control values set by the user in the Data > Controls for Computation of Pile-head 
Stiffness Matrix dialog discussed in Section 3.16.4.  

 Compute Push-over Analysis 
If this option is selected, LPile computes the pushover analysis according to the controls 
set by the user in the Data > Controls for Computation of Pushover Analysis dialog 
discussed in Section 3.16.7. 

 Compute Pile Buckling Analysis 
If this option is selected, LPile computes the pile-buckling analysis according to the 
controls set by the user in the Data > Controls Computation of Pile Buckling Analysis 
discussed in Section 0. 

The following options are for the Response of Layered Soils: 
 Use Layering Correction (Method of Georgiadis) 
 Do not compute layering correction if layer above is of same type 

3.5.2 Output Options 
 Several options are provided to control the output reports generated during LPile analyses. 
These options are enabled by checking the check boxes described below. 

3.5.2.1 Generate p-y Curves at User-Specified Depths 
 Checking this option activates the feature to output p-y curves at the depths that are 
specified by the user under the separate Data > Output Depths of p-y Curves menu. Note that for 
battered piles, the specified depth is the vertical depth below the pile head, not the distance along 
the axis of the pile. 

3.5.2.2 Extend Printed p-y Curves to Maximum Demanded Displacement 
 By default, the program prints the p-y curves before performing the analysis setting the 
maximum value of lateral displacement based on the diameter of the pile and soil model. In some 
cases, the demanded displacement may be higher than the maximum default value, by clicking this 
option the program will print the p-y curves after the analyses are completed and if for any depth 
the demanded displacement is higher than the default maximum displacement the program will 
print the p-y curve up to that displacement. 

3.5.2.3 Printing Increment 
 The user may specify the output increment for where results will be printed in the table of 
output. As a default, results are printed at every finite increment of pile length. This option is 
disabled if the user has a check mark on the separate Output Summary Tables Only option. A value 
of 1 prints the values at every node; 2 prints values at every other node, etc. Note that the printing 
increment is used only for the generation of the output report, but not for the generation of output 
graphs. 
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3.5.2.4 Output Summary Tables Only 
 Checking this option simplifies considerably the output text file by only printing summary 
tables (applicable to Conventional Analysis Mode and/or LRFD Analysis Mode). 

3.5.2.5 Use Narrow Output Report Format 
 This option controls the printed width of the output reports (output text file), permitting 
printing on letter-size paper without word wrapping of long lines. It is necessary to specify a fixed-
pitch font of 10 point or smaller size to display the output correctly. The user should be aware that 
only the most important columns of output results are displayed when this option is selected.  

3.5.3 Engineering Units of Input Data and Computations 
 The user can specify either US Customary System (USCS) units using pounds, inches, and 
feet or SI Units for the International System of Units (Système international d’unités or SI) units 
using millimeters, meters, and kilonewtons for entering and displaying data. The prior setting for 
engineering units is remembered by the program. Thus, when LPile is started, the default units are 
the engineering units used in the prior analysis. If a data file is read by LPile, the engineering units 
are switched to the units specified in the data file. 
 All input data is converted to consistent units of length and force before computations are 
made. The consistent units are either pounds and inches or kilonewtons and meters. 

3.5.4 Loading Type and Number of Cycles of Loading 
 The user can specify either static or cyclic loading in the option group for Loading Type 
and Number of Cycles of Loading. Selection of type of loading is important when analyzing piles 
under lateral forces for certain soil types. Further information on the influence of loading type is 
included in the Technical Manual. 
 In general, cyclic loading is primarily used for low frequency, large amplitude storm wave 
or wind loads. Dynamic loading from earthquakes and machine vibrations are not the same as 
cyclic loads considered in LPile. When cyclic loading is selected, the user must also specify the 
number of cycles of loading, ranging from 2 to 5,000 cycles. The effect of cyclic loading is to 
change how the soil resistance is computed in certain types of p-y curves, as described in the 
Technical Manual. 
 Dynamic loading from earthquakes can be analyzed by LPile if equivalent pseudo-static 
loads are input. Pseudo-static loads are sized in a manner that results in computed moments and 
deflections that roughly equivalent to those developed during seismic loading events. 
 Dynamic loading from machine vibrations or most other sources of harmonic loading 
should not be analyzed using LPile because LPile is not capable of determining the frequency 
response of the foundation and other inertial effects. Instead, the user is directed to the use of the 
DynaN, DynaPile, and/or DynaMat programs from Ensoft for the performance of dynamic 
response analyses. 

3.5.5 Analysis Control Options 
 The Analysis Control Options are used to specify the Number of Pile Increments, the 
Maximum Number of Iterations, the Convergence Tolerance on Deflections, and the Deflection 
Iteration Limit at Pile Head. 
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3.5.5.1 Number of Pile Increments 
 The quality of the finite-difference numerical solution obtained by LPile is proportional to 
the square of the length of the pile increment. The length of the pile increment is computed by 
dividing the length of the pile by the number of pile increments. 
 The error in the solution computed by LPile is defined as the difference between the 
approximation and the exact analytical solution. The two sources of error in finite difference 
methods are round-off error, the loss of precision due to computer rounding of decimal quantities, 
and truncation error or discretization error, the difference between the exact solution of the finite 
difference equation and the exact quantity assuming perfect arithmetic (that is, assuming no round-
off error).  
 The default number of pile increments is 100, the minimum number of pile increments is 
40, and maximum number of pile increments is 500. 
 Often the user may opt to use an odd number of increments to obtain computed results at 
specific rounded valued of depth. For example, a user may opt to use 140 increments to obtain 
results for every 0.5 feet of depth for a 70-ft-long pile. 

3.5.5.2 Maximum Number of Iterations 
 The maximum number of iterations performed by the program for the pile solution can be 
set by the user. Many problems will converge in fewer than 50 iterations unless a plastic hinge is 
being developed in an analysis using nonlinear EI. If a pushover analysis is being performed using 
the displacement and moment pile-head boundary condition, the iterations limit should be set to 
the maximum value of 1,000 iterations to allow plastic hinges to develop in the pile. 

Recommended 500 to 750 

Lower Limit 100 

Upper Limit: 1,000 

Table 3.2  Recommended Ranges for Maximum Number of Iterations 

 The user should be aware that specifying 1,000 iterations has a special feature. If the 
problem is solved using fewer than 1,000 iterations, the solution has met the convergence tolerance 
and excessive deflection criteria. However, if the program reached the limit of 1,000 iterations, the 
program is highly unlikely to obtain convergence. Instead, the program outputs the last iterative 
solution obtained and the solution stops.  

3.5.5.3 Convergence Tolerance 
 The value entered for convergence tolerance is used to stop an analysis when the absolute 
value of the change in deflection of every nodal point on the pile is less than the convergence 
tolerance. The default value for convergence tolerance is 0.00001 inches or 2.54×10–7 meters. 
Using a smaller value for convergence tolerance usually does not improve the quality of the 
solution and in some conditions may result in failure to obtain a solution. Using a larger 
convergence tolerance is sometimes required, but the user should cautious when using values 
larger the 0.0001 inches or 2.54×10–6 meters. 
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3.5.5.4 Limit on Excessive Lateral Pile Deflection 
 The limit on excessive lateral pile deflection is used to end analyses in which the iterative 
solution is diverging without limit. The user should enter a value of deflection for the pile head 
that is grossly excessive to stop the analysis. The default value is 100 inches or 2.54 meters. If the 
user wished to modify this value, a recommended value is 10 times the pile diameter. Lowering 
the Excessive Deflection Value to less than 100 inches or 2.54 meters is not recommended.  

3.5.6 Data from Load Test 
 It is possible to enter and save load test data input into LPile and to display the load test 
data along with the results computed by LPile on the graphs of pile-head shear force versus pile-
head deflection and bending moment versus depth. The ability to enter and save load test data is 
enabled by checking this option. 

3.5.7 Internet Update Notice Query 
 Checking the Check Internet for Program Update on Program Startup option restores the 
automatic display of this query dialog if this option has been turned off. 

3.5.8 Text Viewer Options 
 The user should enter the complete path and command line for their preferred text editor 
or word processor. As a default, the command line c:\windows\notepad.exe sets Microsoft Notepad 
as the default text editor. An internal text editor can also be selected. The selected text editor will 
be used for View Input Text File, View Processor Run Notes, View Output Text File, and Text 
Viewer under the Computation Menu. 

3.6 Pile Properties 
3.6.1 General Description of Input 
 LPile has features to evaluate the nonlinear bending stiffness relationships for deep 
foundations made from normally-reinforced concrete, steel sections, and prestressed concrete. 
These features can determine how the effective bending stiffness varies as the concrete cracks in 
tension and the reinforcing steel yields.  
 The user must click the OK button in order to save the accepted selections; otherwise, the 
selections will not be saved when the input dialog is closed. 

3.6.2 Section Type and Shape 
 A typical tab page for Section Type and Shape is shown in Figure 3.7. There are 18 general 
types of sections and a pile may have up to 20 different sections of different section types. The 
default section type is an Elastic Section (non-yielding). All other section types have non-linear 
moment-curvature relationships. 
 The sample dialog box shown in Figure 3.7 is for an H-pile defined as an elastic section, 
after definition of the structural shape. Once the section shape and dimensions have been properly 
defined, a scale drawing of the section or section profile is displayed on the right side of the screen, 
as shown below. 
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 The user should note the tab pages shown in the input dialog. For an elastic section, only 
two tabs are shown. For other types of sections, the number of tab pages shown will depend on the 
section type that is selected by the user.  
 The memo shown below the tab pages gives a general description of the section type and 
may provide special guidance in its use and construction. 

 

 
Figure 3.7  Pile Section, Section Type Tab 

3.6.3 Warning and Error Messages 
 LPile provides warning messages and advice for the user’s external design with several 
structural types. The purpose for these warning messages is to alert the user with design geometries 
that may be difficult to construct and to alert if unusual parameters are specified by the user for 
their pile section. A short discussion of several types of the warning messages follows. 

3.6.3.1 Spacing of Reinforcement 
 Warning messages are displayed for the drilled shaft sections when the spacing between 
reinforcing bars is less than five times the size of the coarse aggregate specified by the user. If the 
spacing is smaller than this limit, the likelihood of the occurrence of voids in the concrete is 
increased due to the inability of the fresh concrete to flow around the bars. 
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3.6.3.2 Percentage of Reinforcement 
 Warning messages are displayed for the drilled shaft sections when the percentage of axial 
reinforcement is either less than 0.5 percent or greater than 8 percent. A caution message will be 
displayed if the percentage of axial reinforcement is between 0.5 and 0.95 percent.  

A lower limit for axial reinforcement was discussed on page 362 of O’Neill and Reese 
(1999). In cases where the moments and shear forces developed in the shaft are very small (i.e., at 
depth in long shafts), the minimum steel percentage can be less than 1 percent.  Brown et al. (2018) 
mentions a lower bound of 0.5% longitudinal steel and suggested only for sections without moment 
demand and where the area of concrete is greater than required to resist axial compression. 

Section 10.6.1.1 of ACI 318-14 and Section 5 of AASHTO state that the minimum area of 
longitudinal reinforcement must not be less than 1 percent of the gross concrete area. However, if 
the cross-section is larger than that required by consideration of structural resistance, then Section 
10.3.1.2 of ACI 318-14 allows a reduced effective area not less than one half of the total area to 
be used to determine the minimum reinforcement and design strength. This criterion can be used 
in many cases where drilled shafts are designed with large diameters in order to develop large 
enough geotechnical side and base resistance in soils and some soft rocks.  
 The upper limit of 8 percent reinforcement is not attainable in all shaft sizes. From a 
practical perspective, it is necessary to use bundled bar arrangements to attain reinforcement ratios 
greater than 4.5 percent in many shaft diameters.  In practice, many drilled shafts are typically 
designed with longitudinal reinforcements between 1% and 2% of gross area. 

3.6.3.3 Level of Prestressing After Losses 
 LPile is capable of computing the level of prestress after losses for prestressed sections. 
LPile will display warning messages if the prestress after losses is less than 600 psi or more than 
1,200 psi. Note that the value of prestress after losses depends on the types of piles available and 
generally cannot be specified ahead of time by the design engineer, so it is imperative that the 
design engineer obtain this information from the pile supplier.  

3.6.4 Elastic Sections 
 Elastic pile sections require input for the section length in feet or meters, section shape 
(rectangular, circular, pipe, strong or weak H-pile, or embedded circular pole), sectional 
dimensions in inches or millimeters at the top and bottom of the section, and the modulus of 
elasticity (Elastic Mod.) of the pile material in psi or kPa for the full section. 
Nine cross-sectional shapes are available for elastic sections.  These shapes are: 

• General shape, user should enter the diameter, area and moment of inertia at top 
and bottom of section. 

• Rectangular shape defined by the width and depth of section (used to compute area 
and moment of inertia – which can both be modified by the user if necessary) at top 
and bottom of section. 

• Circular shape without void defined by diameter (used to compute area and moment 
of inertia – which can both be modified by the user if necessary) at top and bottom 
of section. 
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• Pipe shape defined by outer diameter and wall thickness (used to compute area and 
moment of inertia – which can both be modified by the user if necessary) at top and 
bottom of section. 

• H-Pile Strong Axis shape (web perpendicular to neutral axis), defined by flange 
width, depth of section, flange thickness and web thickness (used to compute area 
and moment of inertia – which can both be modified by the user if necessary). 

• H-Pile Weak Axis shape (web aligned with neutral axis), defined by flange width, 
depth of section, flange thickness and web thickness (used to compute area and 
moment of inertia – which can both be modified by the user if necessary). 

• AISC Strong Axis pile shape (web perpendicular to neutral axis), defined by user’s 
selection of W, M, S, HP or Pipe section in drop down lists. 

• AISC Weak Axis pile shape (web aligned with neutral axis), defined by user’s 
selection of W, M, S, HP or Pipe section in drop down lists. 

• Embedded Pole defined by diameter of drilled hole and bending properties of the 
embedded pole. 

 The general, rectangular, circular, pipe and embedded pole sections may be tapered with 
depth.  The H-pile sections, and AISC sections cannot be tapered with depth.  
 In the case of tapered sections, the section dimensions at top and bottom of section are 
checked to determine if the section is tapered or not. If the section is tapered, values of cross-
sectional area and moment of inertia are recomputed from the cross-sectional dimensions 
interpolated with depth and the input values for cross-sectional area and moment of inertia are 
ignored. If the section is not tapered, the input values for cross-sectional area and moment of inertia 
are used in computations.  
 In the case of the embedded pole section, the p-y curves are computed using the diameter 
of the drilled hole and the bending stiffness is defined by the properties of the embedded pole. In 
general, it is advised that the embedded pole option be used only if the backfill placed around the 
pile has a shear strength that is more than ten times the shear strength of the surrounding soil 
profile. 
 The purpose of the input is to define the bending stiffness of the pile. LPile is capable of 
computing the moment of inertia at each nodal point in the section from the structural dimensions 
interpolated over the length of the pile. Thus, for many tapered sections the moment of inertia 
varies nonlinearly with depth. 
 The elastic sections are the only type of section that does not have a defined moment 
capacity. As such, elastic sections are often used when it is desired to determine the lateral 
geotechnical capacity of the soil profile. In such cases, it is best to model the loading of the pile 
using the pushover analysis feature discussed in Section 3.16.7. 

3.6.5 Elastic Sections with Specified Moment Capacity 
 The elastic section with specified moment capacity is similar to the elastic section, with 
the additional feature of a user-specified moment capacity (Plas. Mom. Cap.). The resulting 
moment versus curvature relation is elastic-plastic, so if the moment in the pile does not reach the 
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moment capacity, the results of computations will be the same as for an elastic section with the 
same dimensional properties. 
 The general, rectangular, circular, pipe and embedded pole sections may be tapered with 
depth. The H-pile sections, and AISC sections cannot be tapered with depth.  
 In the case of tapered sections, the dimensions at top and bottom of section are checked to 
determine if the section is tapered or not. If the section is tapered, values of cross-sectional area 
and moment of inertia are recomputed from the cross-sectional dimensions interpolated with depth 
and the input values for cross-sectional area and moment of inertia are ignored. If the section is 
not tapered, the input values for cross-sectional area and moment of inertia are used in 
computations.  
 In the case of tapered elastic sections with specified moment capacity, the assumption is 
made that the yield stress of the pile material is uniform over the length of the section. The yield 
stress of the pile material is computed from the specified moment capacity at the top of the section 
and is used to compute the plastic moment capacity along the length of the section. 

3.6.6 Rectangular Concrete Piles 
 The bending stiffness and nominal moment capacity of the section are computed using the 
methods discussed in Chapter 5 of the LPile Technical Manual.  
 The properties for the rectangular concrete pile are defined by the length, width, and depth 
of section; the compressive strength of concrete; and the number, positions, yield stress, and 
modulus of elasticity of the reinforcing steel bars. Sample tab pages for the required input data are 
shown in Figure 3.8 through Figure 3.11. 

In the Rebars tab (Figure 3.10), placement of a check mark under Plain Concrete – No 
Rebars allows for modeling of a section without any steel reinforcement. 

  
Figure 3.8  Dimensions Tab Page for Rectangular Concrete Section 
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Figure 3.9  Concrete Tab Page for Rectangular Concrete Section 
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Figure 3.10  Rebars Tab Page for Rectangular Concrete Section 
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Figure 3.11  Trans. Reinf. Tab Page and Show of Section for Rectangular Concrete Section 

(after entries on all tabs) 

 If the user chooses to enter the distribution of longitudinal reinforcing bars manually 
(Rebar Pattern > Manual), the program will ask the user if the auto-generated layout should be 
copied onto the manual table for editing (see Figure 3.12).  Selecting Yes may be helpful so the 
user simply edits the automated layout.  

The positions of the reinforcing steel bars are defined using an x-y coordinate system with 
the origin positioned at the centroid of the section. The user must enter the positions of the bars 
and must select the size of bars from the available sizes programmed in LPile. The sample rebar 
layout table (from previous figures) is shown in Figure 3.13 but with a slight change on the X 
Coordinate of the central 4 bars (done for demonstration purposes). Once the position and size of 
reinforcing steel has been entered, LPile will display a scale drawing of the section as shown in 
Figure 3.14. 
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Figure 3.12  Confirmation Screen for Selection of Manual Rebar Pattern  

 

 
Figure 3.13  Sample Manual Rebar Layout Table for Rectangular Concrete Section 
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Figure 3.14  Section Type, Dimensions, and Cross-section Properties Dialog for Rectangular 

Concrete Section Showing Manual Rebar Layout After Definition 

3.6.7 Round Concrete Shafts (Bored Piles) 
 The properties of drilled shafts (also called bored piles) are defined by the length and outer 
diameter of the shaft; the number, positions, yield stress, and modulus of elasticity of the 
reinforcing steel bars; and the compressive strength of concrete. Features are provided in LPile to 
compute the positions of circular bar arrangements with single-bar, two-bar, and three-bar bundles 
utilizing the clear cover dimension and any accidental offset of the bar cage from the shaft center. 
In addition, the position and size of bars can be manually edited if desired. 
 The dialog shown in Figure 3.15 is an example of the Section Type and Shape tab after 
the Round Concrete Shaft (Bored Pile) option has been selected. This drawing of the cross-section 
shows the current size, number, bundling, and positions of the reinforcing bars selected.  
 The Shaft Dimensions tab page is used to enter the Length of Section and the Section 
Diameter. All data entry cells for which input is not required are disabled. 
 The Concrete tab page, similar to the one shown previously in Figure 3.9, shows the 
compressive strength of concrete and the maximum size of coarse aggregate. The maximum size 
of coarse aggregate is used when LPile checks the spacing dimension between bars to ensure that 
sufficient space is provided for the concrete to flow during placement of concrete. 
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Figure 3.15  Tab for Selection of Section Type Showing Deafult Cross-Section of Round 

Concrete Shaft 

The layout of reinforcement is defined in the Rebars tab by specifying the size of 
reinforcement, number of bars, bar bundle size, concrete cover thickness, and offset of the 
reinforcement cage from the centroid (if any) as shown in Figure 3.16. The drawing of the cross-
section automatically updates to indicate any changes in the geometric properties of the reinforcing 
bars. In the Rebars tab (Figure 3.16), placement of a check mark under Plain Concrete – No 
Rebars allows for modeling of a section without any steel reinforcement. 
 When entering data for the arrangement of reinforcing steel, the user’s attention is drawn 
to the advice of the comment note in the lower part of the Rebars dialog box. It is important for 
the designer to anticipate whether or not temporary casing is used. When temporary casing is used 
in construction, best design practice is to specify a concrete cover thickness of 4 inches (100 mm) 
so that standard size shaft spacers (typically 3 inches or 75 mm) can be used to center the 
reinforcing steel inside the temporary casing. After concrete is placed and the temporary casing is 
removed, the concrete in the shaft will flow outward to fill the volume left by the casing and the 
annular space outside of the casing. 
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Figure 3.16  Rebars Tab for Reinforcing Bar Properties 

 Users may optionally enter details for the transverse reinforcement in the Trans. Reinf. tab 
(see Figure 3.17).  After entering the transverse reinforcement, if the user also selects (placing a 
check mark) Estimate Resistance Factors and Shear Capacity in the Section Type tab, the output 
text file will include references of the nominal shear structural capacity (concrete and steel 
contributions) based on the ACI 318 code. 
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Figure 3.17  Sample Trans. Reinf. Tab 

3.6.8 Round Concrete Shaft with Permanent Casing 
 The properties of Round Concrete Shaft with Permanent Casing are defined by the length 
and outer diameter of the casing; the wall thickness of the casing; the yield stress and modulus of 
elasticity of the casing; the number, positions, yield stress, and modulus of elasticity of the 
reinforcing steel bars; and the compressive strength of concrete.  
 The Shaft Dimensions tab page, shown in Figure 3.18 shows the dimensions for the outer 
diameter and wall thickness of the permanent casing. The drawing of the cross-section will 
automatically update to show any changes in the shaft geometric properties for casing or 
reinforcing bars. 
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Figure 3.18  Tab Sheet for Shaft Dimensions for Drilled Shaft with Permanent Casing 

 The tab page for Rebars is similar to that used for drilled shafts, except that the label for 
the entry cell for concrete cover has to be modified to indicate that the cover dimension is measured 
inside the permanent casing, as shown in Figure 3.19. In the Rebars tab, placement of a check 
mark under Plain Concrete – No Rebars allows for modeling of a section without any steel 
reinforcement. 
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Figure 3.19  Tab Sheet for Rebars for Drilled Shaft with Permanent Casing 

 The Steel Properties tab page is used to enter casing material properties, as shown in Figure 
3.20. This is visible only for the drilled shaft sections that utilize permanent casing. The material 
properties required for permanent casing are the yield stress and modulus of elasticity. 
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Figure 3.20  Tab Sheet for Steel Properties for Drilled Shaft with Permanent Casing 

3.6.9 Round Concrete Shaft with Permanent Casing and Core/Insert 
The properties of round concrete drilled shafts with permanent casing and core are defined by:  

• the length and outer diameter of the casing;  
• the wall thicknesses of the casing/core and dimensions of the core/insert; 
• the yield stress and modulus of elasticity of the casing and core/insert;  
• the number, positions, yield stress, and modulus of elasticity of the reinforcing steel bars 

(if any); and  
• the compressive strength of concrete.  

In addition, the user may specify if the core is filled with concrete (if core is a pipe) by checking 
the appropriate box on the Steel Properties tab page. 
 The Shaft Dimensions tab page for a drilled shaft with casing and core/insert is shown in 
Figure 3.21. The drawing of the cross-section will automatically update to show any changes in 
the shaft geometric properties for casing, core, or reinforcing bars. 
 The values entered for the wall thickness of the casing and/or core may be zero to model a 
shaft without a casing or core. This feature enables one to model a drilled shaft with a structural 
steel insert/core. 
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Figure 3.21  Tab Sheet forShaft Dimensions of Drilled Shaft with Casing and Core 

 The tab page for material properties of the casing and core is labeled Steel Properties and 
is shown in Figure 3.22. Also shown on this tab page is the check box to indicate if the core is 
filled or unfilled with concrete. In addition, the core type is selected in this section. Please note 
that the dimensions for the casing and core/insert are entered in the Shaft Dimensions tab.  
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Figure 3.22  Tab Sheet for Casing and Core/Insert Material Properties 

 In most problems, the influence of the concrete inside the core has little effect on the 
computed bending stiffness, but may have a noticeable effect on the computed axial compressive 
structural capacity of the section. 
 The tab page for rebar is identical to that shown for drilled shaft with permanent casing. In 
the Rebars tab, placement of a check mark under Plain Concrete – No Rebars allows for modeling 
of a section without any steel reinforcement. 

3.6.10 Steel Pipe Section 
 The properties of steel pipe piles are defined by the length, outside diameter, and wall 
thickness of the pile section and entered in the Pipe Pile Dimensions tab, as shown in the sample 
of Figure 3.23. The material properties are the yield stress and modulus of elasticity, entered in the 
Steel Properties tab, as shown in the sample of Figure 3.24. 
 The computed curve of moment versus curvature for a sample steel pipe pile is shown in 
Figure 3.25(a). Alternatively, a steel pile section could be modelled as an elastic-plastic section. 
However, the development of plastic yielding across the cross-section will not be modelled and 
the utilized moment versus curvature relationship is bilinear as shown in Figure 3.25(b). 
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Figure 3.23  Pipe Pile Dimensions Tab Page for Steel Pipe Piles 

 
Figure 3.24  Pipe-Casing-Core Properties Tab Page for Steel Pipe Pile 
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(a) 

 

 (b) 

Figure 3.25  Comparison of Moment vs. Curvature for (a) Steel Pipe Pile and (b) Elastic-Plastic 
Pipe Pile with Similar Properties 

3.6.11 Round Prestressed Concrete  
 The properties of round prestressed concrete piles are defined by the length and diameter 
of the pile, the compressive strength of concrete, the prestressing reinforcement details, and the 
loss of prestress. 
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 The usual procedure for the LPile user is to enter the pile dimensions, compressive strength 
of concrete, number and size of prestress reinforcement strands, and concrete cover dimension. 
The Prestressing tab page for entering prestressing data for all types of prestressed concrete piles 
is shown in Figure 3.26. Once the prestressing size, number, and geometry are entered, the cross-
section of the pile should be drawn by LPile. If the cross-section is not drawn properly, there is an 
error in the input data.  

 
Figure 3.26  Prestressing Tab Page Common to All Prestressed Pile Types 

 As a designer, the engineer can specify the length, diameter, concrete compressive strength, 
and reinforcement of a prestressed pile, but must find out from the pile supplier what value the 
expected fraction of loss of prestress is expected to be. Sometimes, the supplier will provide the 
final prestress after losses. The engineer can then determine the fraction of loss of prestress if the 
initial prestressing forces before losses are also provided. The common practice for pile suppliers 
is to use 70 percent of the rated prestressing capacity of the reinforcement as the prestress force. 
This value is programmed in LPile for the listed sizes and types or prestress reinforcement. 
 Next, the user enters the fraction of loss provided by the pile supplier. For preliminary 
computations prior to selecting a pile supplier, the user may enter a value in the typical range 
between 0.10 and 0.20. The value of prestress after losses is computed by LPile by pressing the 
button to Compute 70% Prestress Force and Stress. The value computed by LPile will be shown 
in the dialog and will be classified as OK if the prestress after losses is in the range of 600 to 1,200 
psi (4.14 to 8.27 MPa), or as too high or too low if outside of this range. 
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3.6.12 Round Prestressed Concrete with Void 
 The properties of round prestressed concrete piles with void are defined by the length and 
diameter of the pile, the diameter of the hollow core void, the compressive strength of concrete, 
and the prestressing reinforcement and loss of prestress.  
 The input for the Round Prestressed Concrete with Void is the same as for the Round 
Prestressed Concrete without void, with the exception of the entry of the diameter of the core 
void. Please refer to the discussion in Section 3.6.11 for information about the computation of 
prestress after losses. 

3.6.13 Square Prestressed Concrete 
 The properties of square prestressed concrete piles are defined by the length and width of 
the pile, the size of the corner chamfer, the compressive strength of concrete, and the prestressing 
reinforcement and loss of prestress. 
 The input for the Square Prestressed Concrete pile is largely the same as for the Round 
Prestressed Concrete pile without void, with the exception of the entry of the dimensions for the 
pile width and corner chamfer. Please refer to the discussion in Section 3.6.11 for information 
about the computation of prestress after losses. 
 An additional feature for the square prestressed pile is the feature to generate automatically 
rectangular strand layouts with circular, square, or weak square arrangements as shown in Figure 
3.27. The different layout patterns will be displayed in the cross-section drawing when the number 
of prestressing strands is varied.  



CHAPTER 3 – Input of Data – 3-33 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

  

  

 (a) Circular (b) Square (c) Weak Square  

Figure 3.27  Automatic Prestressing Arrangements for Square Prestressed Piles 

 

3.6.14 Square Prestressed Concrete with Void 
 The properties of square prestressed concrete piles with void are defined by the length and 
width of the pile, the size of the corner chamfer, the diameter of the hollow core void, the 
compressive strength of concrete, and the prestressing reinforcement and loss of prestress. 
 The input for the Square Prestressed Concrete with Void is similar to the Round 
Prestressed Concrete with Void, with the exception of the entry of the dimensions for the pile 
width and corner chamfer. Please refer to the discussion in Section 3.6.11 for information about 
the computation of prestress after losses and to Section 3.6.13 for information about automatic 
prestressing strand arrangements. 

3.6.15 Octagonal Prestressed Concrete 
 The properties of octagonal prestressed concrete piles are defined by the length and width 
of the pile, the compressive strength of concrete, and the prestressing reinforcement and loss of 
prestress. The procedures used to compute the nonlinear bending properties for the octagonal shape 
are identical to those used for the Square Prestressed Concrete except that the size of the corner 
chamfer is defined internally to produce the octagonal shape.  
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3.6.16 Octagonal Prestressed Concrete Pile with Void 
 The properties of octagonal prestressed concrete piles with void are defined by the length 
and width of the pile, the diameter of the hollow core void, the compressive strength of concrete, 
and the prestressing reinforcement and loss of prestress. The procedures used to compute the 
nonlinear bending properties for the octagonal shape are identical to those used for the Square 
Prestressed Concrete with Void except that the size of the corner chamfer is defined internally to 
produce the octagonal shape.  

3.6.17 Steel H Section 
 The properties of steel H section piles (strong and weak axis sections) are defined by the 
length, flange width, section depth, flange thickness, and wall thickness of the pile section as 
shown in Figure 3.28, for the strong axis section, and in Figure 3.29, for the weak axis section. 
The material properties are the yield stress and modulus of elasticity are similar to the Steel Pipe 
Section as shown in Figure 3.24. 

3.6.18 Steel AISC Section 
 The properties of steel AISC section piles (strong and weak axis sections) are defined by 
the length, and selection of the section type and the section name. The program will fill the flange 
width, section depth, flange thickness, and wall thickness of the pile section from the database. A 
sample is shown in Figure 3.30, for the strong axis section, and in Figure 3.31 for the weak axis 
section. The material properties are the yield stress and modulus of elasticity are similar to the 
Steel Pipe Section as shown in Figure 3.24. 
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Figure 3.28  Dimensions Tab Page for Strong Axis H Piles 

  
Figure 3.29  Dimensions Tab Page for Weak Axis H Piles 
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Figure 3.30  Dimensions Tab Page for Strong Axis AISC Piles 

  
Figure 3.31  Dimensions Tab Page for Weak Axis AISC Piles 
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3.6.19 User Defined Nonlinear Bending Section 
 The properties of piles with nonlinear bending are defined by the length and width of the 
pile and the user-specified nonlinear bending properties. Nonlinear bending properties are defined 
by levels of axial thrust force and associated curves of either nonlinear bending stiffness versus 
bending moment or nonlinear bending moment versus bending curvature.  
 The type of nonlinear data is selected by the user by checking the appropriate radio button 
for the Type of Nonlinear Bending Input Data on the Nonlinear EI tab page shown in Figure 3.32. 
The buttons used to enter nonlinear bending data are enabled once the type of nonlinear bending 
data has been selected. Next, the user enters the values of axial thrust force for which curves for 
nonlinear bending are to be entered in the data table shown in Figure 3.33.  
 If more than one section with defined nonlinear bending is being defined, the values of 
axial thrust force of Section 1 are copied to the other section(s).  
 A curve of nonlinear bending data is required for each input value for axial thrust force by 
pressing the button to the right of the thrust force value shown in Figure 3.33 to open the input 
tables shown in Figure 3.34. 

The table shown will depend on the type of nonlinear bending data that was selected. It is 
possible to enter nonlinear bending data by either reading an external text file or pasting values 
from the Windows clipboard.  

 
Figure 3.32  Nonlinear EI Tab Page 
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Figure 3.33  Table for Entering Axial Thrust Forces for Nonlinear Bending Data 

   

(a)                                                                   (b) 

Figure 3.34  Tables for Entry of (a) Nonlinear Moment versus Curvature Data and (b) 
Nonlinear Moment versus Bending Stiffness 
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 To enter data from an external text file, the user located the text file using the Browse 
button and then pressing the Read Values from File button. The format of the external text file 
requires that values are entered with the moment value first and either the EI or curvature value 
second with one data pair per line. A maximum of 150 data points may be entered. 
 It is important for the user to understand that LPile cannot validate the input data for 
nonlinear bending. Consequently, it is left to the user to examine the charts of the input data and 
to verify that the input data is correct. 

3.6.20 Options for Nonlinear Sections 
For nonlinear sections, up to three options may be available.  These optional checks are described 
in the following sections. 

3.6.20.1 Adjust Softening of Moment Curvature 
 This option is available for sections with concrete. If this option is checked (default) the 
program will adjust the softening in the moment curvature curve due to cracking or crushing of 
the concrete.  

           

(a)                                                                   (b) 

Figure 3.35  Example of Option Adjust Softening of Moment Curvature (a) Not Adjusted (b) 
Adjusted 

3.6.20.2 Compute Equivalent Elastoplastic Moment Curvature (CALTRANS) 
 This option is available for all nonlinear sections except User-Defined Non-linear Bending 
Section. If this option is checked the program will compute the equivalent elastoplastic moment 
curvature following CALTRANS recommendations. Please note that by selecting this option, the 
program will use the equivalent moment curvature for all the required analyses.  
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Figure 3.36  Example of Option Compute Equivalent Elatoplastic Moment Curvature 

(CALTRANS) 

3.6.20.3 Estimate Resistance Factor and Shear Capacity 
 This option is available for all nonlinear reinforced concrete sections (Rectangular 
Concrete Section, Round Concrete Shaft, Round Concrete Shaft with Permanent Casing and 
Round Shaft with Casing and Core/Insert). If this option is checked, the program will compute the 
resistance factor and nominal shear capacity of the pile sections (concrete and steel contributions) 
using the ACI 318-14 code guidelines but user must enter data for transverse reinforcement under 
the Trans. Reinf. tab. 
In models using the LRFD Analysis Mode, this checked selection will override any resistance factor 
that was inputted by the user for the LRFD analysis (under Data > Load and Resistance Cases). 

3.7 Soil Layers 
 Three types of data can be entered in LPile to define the lateral load-transfer relationships 
between the pile and soil. Most basic of these are the definitions of soil layering, soil types, and 
soil properties used to compute the lateral load-transfer (p-y) curves. The soil layering and p-y 
curves are discussed in Section 3.7.1. 
 The p-y curves can be affected by the combined pile batter and ground slope. The input of 
pile batter and ground slope angles is discussed in Section 3.8 
 The p-y curves may be modified by the p-y modification factors to account for the effects 
of group action for pile groups and earth retaining structures. The input of p-y modification factors 
is discussed in Section 3.9. 
 It is also possible to define lateral load-transfer at the tip of the pile in addition to p-y curves 
that define lateral load-transfer along the length of the pile. The tip shear versus tip movement 
curves are generally important only for short piles for which significant movement of the pile tip 
can develop. The development of tip shear is highly dependent on the construction practices used 
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to install the pile. Consequently, no dependable methods have been developed to compute the 
curves of tip shear resistance and most relationships are determined from the results of site-specific 
load testing programs. The input of tip shear resistances is discussed in Section 3.10 
 A key concept in LPile is the definition of the vertical coordinate system used to define 
soil layering and pile properties. The origin of this coordinate system is always located at the point 
of application of lateral loads (usually same as pile head). If it is desired to vary the vertical position 
of the pile head relative to the soil layering, it will be necessary to correct the data defining the soil 
layering. A utility function, Data > Shift Pile Elevation in Soil Profile, is included in LPile to assist 
in this task and is discussed in Section 3.13. 

3.7.1 Soil Layering and p-y Curve Models 
 This dialog Data > Soil Layers is used to specify the different types of soil to be used for 
the automatic generation of lateral load-transfer curves (p-y curves). LPile will automatically 
generate the selected curves unless the user specifies and enters user-input p-y curves. An example 
of this dialog is shown in Figure 3.37. 

 
Figure 3.37  Dialog for Definition of Soil Layering and Soil Properties  

The following is a description of the input data for this dialog. 
Layer Number: The soil layer number is assigned automatically to each soil layer with Layer 1 
being the uppermost layer. This number is automatically provided by the program as additional 
rows of soil layers are created. The maximum number of soil layers that may be entered is 40. 
p-y Curve Model: There are several internal types of soils plus user-input p-y curves that can be 
specified in LPile using this dropdown box. These types are: 

Soft Clay (Matlock) 
API Soft Clay w/User Defined J 
Stiff Clay with Free Water (Reese) 
Stiff Clay without Free Water (Reese) 
Modified Stiff Clay without Free Water 
Sand (Reese) 
API Sand (O’Neill) 
Small Strain Sand 
Liquefied Sand (Rollins) 
Liquefied Sand Hybrid Model 
Weak Rock (Reese) 
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Strong Rock (Vuggy Limestone) 
Piedmont Residual 
Massive rock 
Loess 
Silt (Cemented Soils) 
Elastic Subgrade 
User-input p-y curves 

Top of Soil Layer Below Pile Head: Values for the top of the soil layer are entered relative to the 
origin of the depth coordinates. The origin of depth coordinates is usually the pile head, which is 
the point of application of boundary conditions and corresponding loads. 
A positive value for the Top Layer entry indicates a distance measured downward from the top of 
the pile. A negative value indicates a distance measured above the top of the pile (only used for 
when the pile head is embedded below the ground surface). The value of zero may be used in the 
first layer if the pile head is at the level of the ground line. 
Bottom of Soil Layer Below Pile Head: Values for the bottom of the soil layer are also entered 
according to the origin of coordinates. The coordinate of the bottom of each layer should always 
be equal to the coordinate of the top of the immediately consecutive layer. The bottom of the last 
soil layer must at least reach the same depth as the bottom of the modeled pile  
Soil Properties: The last column contains a context-sensitive button that varies depending on the 
p-y curve soil type selected. The table button activates a soil type specific data entry dialog where 
the user enters effective unit weight, shear strength parameters, and any other required soil/rock 
property parameters, depending on the soil type selected. Descriptions follow. 

3.7.1.1 Comments on p-y Curve Models 
The following comments are made about the different p-y curve models. 

With the exception of the silt model for cemented c-φ materials, all of the models are based on 
load tests of full-sized piles in which the pile diameter is typically in the range of 300 to 1,200 mm 
(12 to 48 inches). While it is possible to test piles with larger diameters, it is usually not possible 
to load such large diameter pile to failure. Consequently, if a significant variation of lateral load 
transfer characteristics due to pile diameter exists, it may not be accurately modeled by the p-y 
curve formulations. 
Stiff clay with free water, in general, is used to represent soil conditions where stiff clay is the top 
layer in the soil profile and there is water existing above the ground line or in any conditions where 
it is believed that any annular space between the pile and soil may fill with water. 
A discussion of the theory of p-y curves for different types of soils is included in the Technical 
Manual. 

3.7.1.2 Common Soil Properties for p-y Curves 
Effective Unit Weight: Values of effective unit weight for each soil depth are entered in units of 
force per unit volume. The program will linearly interpolate values of unit weight located between 
the top and bottom depths of the layer. Soil layers should be sub-divided anywhere step changes 
in values are needed, such as at the depth of the water table. \ 
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k Value for Soil Layers: This is the value for k used in the equation Es = k x. This constant is in 
units of force per cubic length and depends on the type of soil and lateral loading imposed to the 
pile group. It has two different uses: (1) to define the initial (maximum) value of Es on internally 
generated p-y curves of stiff clays with free water and/or sands; and (2) to initialize the Es array 
for the first iteration of pile analysis.  Recommended k values are included in the Technical Manual 
for each criteria where it is applicable. Different k values are recommended if the c-φ soils are like 
cemented sand or like quartz type of silty sand (non-cemented silt). 
Undrained Shear Strength: Values of undrained shear strength (cu) for clays and silts at each depth 
are entered in standard units of force per unit area. The undrained shear strength is not needed for 
sand layers. The undrained shear strength is generally taken as half of the unconfined compressive 
strengths.  

Internal Friction (degrees): Values of the angle of internal friction φ for sands and/or silts at each 
soil depth are entered in degrees.  

Strain Factor E50: Values of ε50 strain at 50% of the maximum stress. The strain factor ε50 for 
clays at each soil depth are entered in dimensionless units of strain.   
If soil test data are available, the user may enter the value based on the stress-strain curves 
measured in the soil laboratory. The p-y curves for weak rocks need a strain parameter krm which 
is analogous to ε50. More information regarding krm and ε50 can be found in the Technical Manual. 
Initial Mass Modulus for Weak Rock: The initial mass modulus for weak rock should be entered 
for this value. This value may be measured in the field using an appropriate test or may be obtained 
from the product of the modulus reduction ratio and Young’s modulus measured on intact rock 
specimens in the laboratory 
Uniaxial Compressive Strength: This value is the uniaxial compressive strength of weak rock at 
the specified depth. Values at elevations between the top and bottom elevations will be determined 
by linear interpolation.  
Any input values that are considered unreasonable are flagged in the output file and a warning 
dialog box is displayed. However, the analysis is performed normally. 
Rock Quality Designation: The secondary structure of the weak rock is described using the Rock 
Quality Designation (RQD). Enter the value of RQD in percent for the weak rock. 
Strain Factor krm: The parameter krm for weak rock typically ranges between 0.0005 and 0.00005. 
The input dialog for weak rock is shown in Figure 3.38 as an example. 
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Figure 3.38  Dialog for Properties of Weak Rock 

The input for massive rock requires strength parameters defined using the Hoek-Brown strength 
criterion. In addition to effective unit weight and uniaxial compressive strength, these parameters 
include: 
Hoek-Brown Material index, mi, is a dimensionless number ranging from 4 to 32 that depends on 
the type of rock.  
Poisson’s Ratio. Guidance for selecting a value for Poisson’s ratio as a function of the compression 
and shear wave velocities in rock is discussed in the Technical Manual.  
Geologic Strength Index, GSI, is a dimensionless number ranging from zero to 100 that depends 
on the quality of the massive rock. 
Two options are provided for determining the rock mass modulus for massive rock. For Option 1, 
the user inputs a value for the intact rock modulus and leaves the input for rock mass modulus 
equal to zero. In Option 1, the program computes a value of rock mass modulus based in the input 
data. For Option 2, the user inputs a non-zero value for rock mass modulus. In Option 2, the 
program will ignore any value input for the intact rock modulus. The input dialog for massive rock 
is shown in Figure 3.39 as an example. 

 
Figure 3.39  Dialog for Properties of Massive Rock 
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3.7.2 User Input p-y Curves 
 Data for user-input p-y curves are input using two linked dialog boxes. The first dialog box 
is used to enter values of effective unit weight at the top and bottom of the soil layer and to open 
the input dialog box for entry of the p-y curve data. 

 
Figure 3.40  Dialog for Effective Unit Weights of User-input p-y Curves 

 The second input dialog box is used to enter the p-y curve data. The user may enter data in 
one of three ways. The user may add enough rows to accommodate the data and enter the data 
manually, the user by paste the data into the table via the Windows clipboard, or read an external 
text data file. The input dialog is shown below. The graph in the dialog shows the current data. It 
may be necessary for the user to move the cursor to an adjacent cell to update the graph of the p-y 
curve. An example of the input dialog for a user-input p-y curve is shown in Figure 3.41.  

 
Figure 3.41  Dialog for User-input p-y Curve Values 
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 This layer type allows the user to enter specific relationships of soil resistance (p) and 
lateral movement of the pile (y) at specified depths. These cases usually arise when local data for 
the soil response are available. To use external p-y curves, the user needs to select User Input p-y 
Curves under the p-y Curve Soil Model column in the Soil Layers dialog. Then, clicking on the 
context-sensitive button in the far right column opens a dialog where the user can input the 
effective unit weight of the soil. Finally, the user can define lateral deflection and soil resistance 
values for points in the upper and lower curves by clicking on the corresponding External p-y 
Curve for Layer button in the far right column. A general description for the data needed for User-
Input p-y Curves is listed below. 

Lateral Deflection: y-values of lateral movement must be entered in units of length. As a 
reference, a review of the theory of “Soil Response” is included in Part II, Chapter 3 of the 
Technical Manual. 
Soil Resistance: p-values of lateral load intensity must be entered in units of load per unit 
depth. As a reference, a review of the theory of “Soil Response” is included in Part II, 
Chapter 3 of the Technical Manual. 

3.8 Pile Batter and Ground Slope 
 This input dialog is enabled if the user placed a check mark under Data > Options and 
Settings > Include Pile Batter and/or Ground Slope.  The user specifies the ground slope and batter 
angles using the Data > Pile Batter/Ground Slope dialog shown in Figure 3.42. The interactive 
drawing in the dialog realistically illustrates the ground slope and pile batter angles along with the 
sign convention for loading. If flat ground slope is selected and the pile is vertical, the angles will 
be zero. If necessary, users are able to specify different angles (or horizontal/zero slope) for a 
sloping ground to the right and left of the pile. 

Ground Slope Angle: This is the angle, in degrees, formed between a sloped ground surface 
and the horizontal surface. As indicated in the following figure, the value of the ground 
slope angle is positive if the pile tends to move downhill upon application of the lateral 
load. The lateral capacity provided by soils in a positive slope is thus reduced. Piles that 
tend to move uphill in a sloping ground use negative values of ground slope angle. The 
lateral capacity provided by soils in a negative ground slope is thus increased. 
Pile Batter Angle: The sign convention that is used to account for battered piles also 
depends on the direction of the applied lateral load and is shown in the figure. 
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Figure 3.42  Dialog for Definition of Pile Batter and Slope of Ground Surface 

3.9 p-y Modification Factors  
 This input dialog is enabled if the user placed a check mark under Data > Options and 
Settings > Use Modification Factors for p-y Curves.  This input dialog is inactive under default 
conditions. The Data > Modification Factors for p-y Curves input dialog allows the user to enter 
modification factors for soil resistance (p) and/or lateral movement of the pile (y) at specified 
depths. A maximum of 80 entries of modification factors for p-y curves may be used in an analysis. 
The program allows the input of modification factors for any depths of the soil profile. The p-y 
modification factors only apply to p-y curves that are internally generated by the program. If the 
user requests a report of internally-generated p-y curves, the output curves will include the changes 
produced by the specified p-y modification factors. An example of this input dialog is shown in 
Figure 3.43.  
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Figure 3.43  Dialog for p-Multipliers and y-Multipliers versus Depth Below Pile Head 

 Distance from Pile Head: These values represent the depths where modification factor for 
p-y curves are being specified. Intermediate values of p-y modification factors located between 
two specified depths are obtained by linear interpolation of the specified factors. It is therefore 
necessary to have at least two entries of modification factors. Modification factors must be entered 
in ascending order of depths. 
 p-Multiplier: The p-multiplier values may be larger or smaller than one. However, in most 
cases these values are smaller than one to account for group effect of closely-spaced piles or drilled 
shafts. A large reduction in p-values (and/or increase of y-values) may also be used to represent 
liquefiable layers of sand. 
 y-Multiplier: The y-multiplier values may be larger or smaller than one. However, in most 
cases these values are larger than one to account for group effect of closely-spaced piles. A large 
increase in y-values (and/or reduction of p-values) may also be used to represent liquefiable layers 
of sand. 

3.10 Shear-Resistance Curve at Pile Tip 
 This input dialog is enabled if the user placed a check mark under Data > Options and 
Settings > Include Shearing Resistance at Pile Tip.  The Data > Shear-Resistance Curve at Pile 
Tip dialog allows the user to enter a shear-resistance curve at the bottom of the pile. This input 
dialog is inactive under default conditions. A maximum of 50 points may be defined in the shear-
resistance curve at the pile tip. A minimum of two points are required to form a curve. An example 
of this input dialog is shown in Figure 3.44.  
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Figure 3.44  Sample Dialog for Tip Shear Resistance versus Lateral Tip Displacement 

The input is the forces Fbs shown in pink in Figure 3.47 that will develop from lateral 
movements of the pile tip. 
 In general, shearing resistance at the pile tip would only be applicable to those cases where 
the pile is short (with only one point of zero deflection along their depth). In addition, these curves 
are likely to make noticeable differences only when using large diameter shafts that deform largely 
by rotation without large amounts of bending. 
 The user may enter data in one of three ways. The user may add enough rows to 
accommodate the data and enter the data manually, the user by paste the data into the table via the 
Windows clipboard, or read an external text data file. The input dialog is shown above. The graph 
in the dialog shows the current data. It may be necessary for the user to move the cursor to an 
adjacent cell to update the graph of the tip shear curve. 

3.11 Moment-Resistance Curve at Pile Tip 
 This input dialog is enabled if the user placed a check mark under Data > Options and 
Settings > Include Moment Resistance at Pile Tip.  The Data > Moment-Resistance Curve at Pile 
Tip dialog (see Figure 3.45) allows the user to enter a moment-resistance curve at the bottom of 
the pile.  The rotation is in units of Radians while the corresponding Moment Resistance is in units 



CHAPTER 3 – Input of Data – 3-50 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

of Force - Length.  A maximum of 50 points may be defined in the moment-resistance curve at the 
pile tip. A minimum of two points (representing an elastic spring) are required for this entry. 

 
Figure 3.45  Sample Dialog Box for Moment-Resistance Curve at Pile Tip 

The input is basically an equivalent nonlinear rotational spring that would represent the 
impact resulting from the Frb forces shown in blue color in Figure 3.47.   

In general, moment resistance at the pile tip would only be applicable to those cases where 
the pile is short (with only one point of zero deflection along the depth). In addition, these curves 
are likely to make noticeable differences only when using large diameter shafts that deform largely 
by rotation without large amounts of bending. 
 The user may enter data in one of three ways. The user may add enough rows to 
accommodate the data and enter the data manually, the user by paste the data into the table via the 
Windows clipboard, or read an external text data file. The input dialog is similar to the tip shear 
resistance input dialog. The graph in the dialog shows the current data. It may be necessary for the 
user to move the cursor to an adjacent cell to update the graph of the tip moment curve. 

3.12 Side Resistance Along Pile 
 This input dialog is enabled if the user placed a check mark under Data > Options and 
Settings > Include Side Resistance Along Pile.  This input dialog is inactive under default 
conditions. A maximum of 50 points may be defined in the table. 
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The Data > Side-Resistance Along Pile dialog (see Figure 3.46) allows the user to specify 
the unit side friction that shall be engaged at various depths along the pile.  The unit side friction 
is in units of pressure: Force (Side Resistance) per Unit Area (Circumferential). 

 
Figure 3.46  Sample Dialog Box for Side Resistance Along Pile 

At every specified depth the program will compute a force couple (one in tension side and 
one in compression side, see Fs forces in red in Figure 3.47) based on the user’s input of unit side 
friction and the circumferential area of the pile (calculated internally from the pile diameter).  LPile 
has internal algorithms to reduce the force couples according to the distances from the neutral axis. 
 Users may take into account that the side resistances may not develop near the ground 
surface in clayey soils that may separate/gap from the pile. 
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Figure 3.47  Schematics of Forces on Large Piles 

 In general, the side resistance along the pile is mostly applicable to models where the pile 
is relatively short (with only one point of zero deflection along the depth). In addition, these forces 
are likely to make noticeable differences only when using large diameter shafts that deform largely 
by rotation without considerable amounts of bending. 
 The user may enter data in one of three ways. The user may add enough rows to 
accommodate the data and enter the data manually, the user by paste the data into the table via the 
Windows clipboard, or read an external text data file. The input dialog is similar to the tip shear 
resistance input dialog. The graph in the dialog shows the current data. It may be necessary for the 
user to move the cursor to an adjacent cell to update the plot. 

3.13 Shift Pile Elevation in Soil Profile 
 Occasionally the user may have the need to raise or lower the position of the pile in the soil 
profile or may desire to check the entry depths of soil and rock layers against elevation data for 
the project site. These actions can be performed by using the Shift Pile Elevation in Soil Profile 
command under the Data menu. 
 An example of the Shift Pile Elevation input dialog is shown in Figure 3.48. In this 
example, the pile head is initially positioned at the ground surface, so the depth of the top of layer 
1 is zero (remember that the position of the pile head is the origin of the vertical coordinate system 
used in LPile). 
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Figure 3.48  Dialog for Shifting of Pile Elevation Relative to Input Soil Profile Showing a Pile 

Head at the Top of the Soil Profile 

 If the user wishes to move the pile vertically within an entered soil profile, the user enters 
the elevation shift in the upper data edit box and presses the Shift Pile Elevation button. To move 
the pile downwards, the user enters a positive number and to move the pile upwards the user enters 
a negative number. The Shift Pile Elevation dialog shown below shows the results for a case in 
which the pile was moved down by 2 meters. The summary report shown in Figure 3.49 shows 
that the top of the first layer has been moved to −2 meters, but that the thicknesses of the layers 
are unchanged. 
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Figure 3.49  Dialog for Shifting of Pile Elevation Relative to Input Soil Profile After Shifting a 

Pile Head To Be Below the Ground Surface 

 If the user wishes to compare the depths of the soil layer profile to elevation data, the user 
enters a value for the elevation of the ground surface and presses the View Elevations Report 
button. The Shift Pile Elevation dialog can display the report in two formats that are selected by 
pressing the appropriate Elevation Coordinate Type radio button. The default format is the LPile 
Depth Coordinates and the other format is the Elevations Relative to Datum. The dialog box shown 
below is an example where the ground surface elevation is 6 meters and the Elevations Relative to 
Datum option has been selected. 

3.14 Output Depths for p-y Curves 
 The user may ask the program to plot internally-generated p-y curves at user-specified 
depths. These curves are not used in the analysis, as LPile computes exact values of p for every 
corresponding value of y for every node along the length of the pile. Many of the various 
parameters needed to compute the output p-y curves are output in the output report file from LPile. 
 This input dialog is enabled if the user placed a check mark under Data > Options and 
Settings > Generate p-y Curves at User-Specified Depths.  This input dialog is inactive under 
default conditions. 
 The depths can be entered in any order. LPile will sort the depth values from top to bottom 
and eliminate duplicate entries prior to performing computations. No p-y curves will be computed 
if an output depth is either above the ground surface or below the pile tip and a warning message 
will be output by the program. 
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 An example of the input dialog for Data > Output Depths of p-y Curves is shown in Figure 
3.50. It should be noted that the depth is the vertical depth below the pile head, not the depth along 
the axis of the pile.  

  

 (a)     (b) 

Figure 3.50  Output Depths of p-y Curves Below Pile Head, (a) Dialog for p-y Curve Output 
Depths, (b) Measurement of Vertical Depths  

3.15 Import Soil Layers from EnCPT Soil File 
 The user may import the soil layering from a Soil File generated by the separate EnCPT 
program. An example of the input dialog for p-y Import Soil Layers from EnCPT soil File is shown 
in Figure 3.51. It should be noted that the program will overwrite the current definition of soil 
layering.  

 
Figure 3.51  Example of Window Import Soil Layers from EnCPT Soil File  
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3.16 Conventional Loading Analysis 
 The conventional loading analysis is the same type of analysis used in all versions of LPile 
older than Version 6. In this type of analysis, up to 100 pile-head loadings of various types can be 
specified. In addition, distributed lateral loading can be specified and the distributed lateral loading 
will be applied to all pile-head loading cases. 

3.16.1 Pile Head Loading 
 The Data > Pile Head Loading dialog shown in Figure 3.52 allows the user to enter the 
desired boundary conditions and corresponding loading at the pile head. There are five options for 
boundary conditions at the pile head. The user selects the desired boundary condition using a 
dropdown list of the choices described below. 
The program allows up to 100 rows of boundary conditions and corresponding loading at the pile 
head.  Users may choose to define multiple load cases/boundary conditions outside LPile on a 
spreadsheet or other program.  Those definitions can be imported into LPile via Clipboard 
(Copy/Paste) or via text file (“.txt” extension) with comma-separated values. 
Each row of a text file used for loading definition (or each spreadsheet row) shall have six values 
to define each load entry.  Up to 100 rows (load definitions) can be defined with the following 
guideline for each line (all numeric values separated by commas, no spaces in between): 

Value1,Value2,Value3,Value4,Value5,Value6 
Each of the six values above is a numeric entry and defined as indicated in Table 3.3 

Variable Definition Value Description 
Value1 Pile-Head Loading Condition 1 Shear (Cond1) [lb or kN] and  

Bending Moment (Cond2) [in-lb or kN-m] 
  2 Shear (Cond1) [lb or kN] and 

Slope (Cond2) [radians] 
  3 Shear (Cond1) [lb or kN] and  

Rotational Stiffness (Cond2) [Moment/rad] 
  4 Displacement (Cond1) [in or m] and 

Bending Moment (Cond2) [in-lb or kN-m] 
  5 Displacement (Cond1) [in or m] and 

Slope (Cond2) [radians] 
Value2 (Cond1) num Enter numeric value 
Value3 (Cond2) num Enter numeric value 
Value4 Axial Load num Enter numeric value [lb or kN] 
Value5 Compute Top y vs. L? 1 No 
  2 Yes 
Value6 Run Analysis? 1 Yes 
  2 No 

Table 3.3  Guideline for Loading Definition File/Table 

The user may instruct LPile for the computation of pile top deflection versus pile length for any of 
the specified load cases.  However, users should read the notes in the Technical Manual for proper 
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usage of this function.  Also, use of this option is restricted to cases using any of the first three 
pile-head conditions, as the pile-head deflection will not vary for the fourth and fifth pile-head 
loading conditions. 

3.16.1.1 Pile-Head Loading Types 
 Shear and Moment: This boundary condition is selected to specify values of applied lateral 
load in units of force and applied moment in units of force × length at the pile head. This condition 
implies that the pile head is free to rotate and move laterally. The lateral force is considered positive 
when applied from left-to-right. The moment is considered positive when applied clockwise. 
 Shear and Slope: In this boundary condition, the user defines the applied lateral load in 
units of force and the slope in radians at the pile head. The lateral force is considered positive when 
applied from left-to-right. The slope is positive when the pile head rotates counterclockwise. A 
fixed-head condition (with no restrictions to lateral movements) may be modeled by specifying a 
slope equal to zero. 
 Shear and Rotational Stiffness: For this boundary condition, the user defines the applied 
lateral load in units of force and a value for rotational stiffness (moment per radian of rotation) at 
the pile head. The lateral force is considered positive applied from left-to-right. The values for 
rotational stiffness are always positive. A fixed-head condition (with no restrictions to lateral 
movements) may optionally be modeled by specifying a large value of rotational stiffness. This 
boundary condition should be selected if the user wants to model an elastically restrained pile-
head connection. 

 
Figure 3.52  Sample Dialog for Input of Conventional Pile-head Loading 
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 Displacement and Moment: This is selected to specify values of lateral displacement and 
moment at the pile head. The displacement is considered positive applied from left-to-right. The 
moment is considered positive when applied clockwise. 
 Displacement and Slope: This is selected to specify values of lateral displacement and the 
pile-head slope in radians. The displacement is considered positive applied from left-to-right. The 
slope is positive when the pile head rotates counterclockwise. 

3.16.1.2 Condition 1  
 This value is the first load in the loading type description; shear force for the first three 
loading type conditions and displacement for the last two loading type conditions. 

3.16.1.3 Condition 2  
 This value is the second load in the loading type description. 

3.16.1.4 Axial Load  
 This value is input in units of force. It is applied at the pile head and may be entered after 
specifying the boundary conditions as well as the corresponding loading. Axial loads entered in 
this column are used in two parts of the computations. Firstly, the axial thrust force is used in the 
computations of nonlinear moment-curvature behavior. Secondly, the axial force is used to account 
for secondary moments produced when the pile deflects (also known as P-δ effects). 

3.16.1.5 Compute Top y versus L 
 This column contains a drop-down yes/no option for performing computations of top 
deflection versus pile length for this pile head loading condition if the selected pile-head loading 
condition does not prescribe the pile-head lateral deflection value. No computations of top 
deflection versus pile length will be made if either the Displacement-Moment or the Displacement-
Slope pile-head condition is specified. 
 With a positive (Yes) request to generate the curve of top deflection versus pile length, 
LPILE takes the specified pile length along with ten consecutive reductions to half of the specified 
pile length, solving the analytical computations for each case. As output, the user is provided with 
the plot Top Deflection vs. Pile Length. In the output text the user is provided with a table that 
includes the pile-top results from each run with different pile length. 
 The outputted results may contain less than ten different points (pile lengths) if excessive 
pile deflections are found in the reduced pile lengths. A method that may increase the number of 
successful runs at reduced pile penetrations is to increase the Iterations limit (from the default of 
100 to the limit of 500). 
 If few points or even no results are provided, it is possible that the pile penetration is already 
too close to the critical length and any further reduction causes excessive deflections and no 
successful computations. In those cases, it is suggested to increase the original pile length so that 
the program can calculate several points on the plot and summary of pile length versus top 
deflection. If the pile length is increased, the user must remember to specify soil parameters that 
reach the new pile tip. It is recommended to reduce the specified pile length if a horizontal line is 
observed in the plot of pile length versus top deflection. 
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 It is recommended not to select this option on initial runs until the user knows to have a 
good working analytical model. This option is also not recommended for cases when the user also 
requests to compute Pile-Head Stiffness Matrix Components. 

3.16.1.6 Run Analysis 
 This column contains a drop-down yes/no option for performing analysis for the current 
pile head loading condition. With a positive (Yes) request the program will perform the analysis; 
however, with a negative (No) request the program will not perform the analysis for the current 
pile head loading condition. 

3.16.2 Distributed Lateral Loading 
 The data entry for distributed lateral loading for conventional analysis is controlled either 
using a single input dialog if a single distributed load profile is used for all conventional loading 
cases or using two linked input dialogs if distributed loading profiles are defined independently 
for the various conventional loading cases.  
 These dialog boxes are enabled if the user placed a check mark under Data > Options and 
Settings > Use Loading by Single Distributed Load Profile. or under Data > Options and Settings 
> Use Separate Distributed Load Profiles for Each Load Case.  These input dialogs are inactive 
under default conditions. A maximum of 50 points may be defined in the table. 

In the first dialog, the user checks whether to include distributed lateral loads. If the option 
is checked, the button to show the input dialog is enabled and the user may display the input dialog 
for distributed lateral loading. Examples of these dialogs are shown in Figure 3.53. 
 The program allows up to 50 different input points of lateral load values, which are placed 
in units of load per unit length of pile. The user must enter values in increasing magnitudes of 
depth. The program linearly interpolates the values of lateral loads existing between specified 
depths. A minimum of two entries (two depths) of distributed lateral loading are needed. 
 The user may enter data in three ways. The user may add enough rows to the table and 
enter the data manually, the user may paste the data into the table via the Windows clipboard, or 
the user may direct LPile to read an external text file containing the data. The Distributed Lateral 
Loads dialog is shown in Figure 3.54. The graph in the dialog shows the current data. It may be 
necessary for the user to move the cursor to a different cell to update the graph of the distributed 
lateral loading. 
 It is not possible for LPile to verify data. It is left to the user to view the graph of the 
distributed load data and to verify its correctness.  
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       (a)                                                                            (b) 

Figure 3.53  Dialogs for Multiple Distributed Lateral Loads for Conventional Loading, (a) 3 
Load Cases, (b) Distributed Load Profile Data for Load Case 1 
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Figure 3.54  Dialog of Values of Distributed Lateral Loads versus Depth 

3.16.2.1 Modeling of Point Shear Forces Below Pile Head 
 This modeling technique is useful to model the application of point shear loads and 
moments below the pile head. It is necessary for the user to understand how LPile applies the 
distributed lateral loads to the pile in order to model these loadings accurately. In performing the 
computations, LPile integrates along the distributed lateral load profile for each pile node from 
one-half a pile increment above the node to one-half a pile increment below the node. At the top 
and bottom nodes on the pile, the integration spans only one-half a pile increment either above or 
below the top or bottom increment as needed. The result of the integral is applied as a point force 
at the node in question.  
 In the case of an applied point shear value, the user may specify the distributed lateral load 
intensity acting over a small increment spanning the point of application. For example, if the pile 
is 50 feet long (600 inches) and has 100 increments, each pile increment is six inches long and the 
nodes are located at 0 inches, 6 inches, 12 inches, 18 inches, and so on down to the pile tip at 600 
inches. If the point load is to be applied at 4 feet, 10 inches (58 inches), it is necessary to apply the 
distributed load in a way that effectively centers the applied load at the preferred location, while 
extending to the closest nodal point. In this example, the distributed lateral load should extend 
from the point of application (58 inches) to the closest nodal point (at 60 inches). The upper 
boundary of the applied zone should extend an equal distance above the point of application to 56 
inches (see Figure 3.55). When LPile computes the equivalent nodal point loads for this example, 
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one-third of the applied force result is applied at the nodal point above the point of load application 
and the remain two-thirds is applied at the closest node. 

 
Figure 3.55  Recommendation for Modeling of Lateral Force Applied Below the Pile Head 

 It is important for the user to recognize that if the nodal point spacing changes for any 
reason, the boundaries of the equivalent loading zone must be re-computed by the user. 

3.16.2.2 Modeling of Moments Below Pile Head 
 With the option of distributed loading the user may apply an equivalent concentrated 
moment about a nodal point. To model concentrated moments, it is necessary to apply equal and 
opposite in action distributed lateral loads to the nodal increments above and below the nodal point 
where the moment is to be applied. The reason for this is the integration of distributed lateral loads 
is performed for each nodal point. If the two distributed loads were applied over a single increment, 
the equal and opposite forces would cancel each other. Figure 3.56 illustrates the principle of 
applying equal and opposite equivalent forces to model a concentrated moment in the pile. 

 
Figure 3.56  Recommendation for Modeling of Moment Applied Below the Pile Head 
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3.16.3 Loading by Lateral Soil Movements 
The input dialog Data > Lateral Soil Movements is inactive by default but enabled if the 

user places a check mark under Data > Options and Settings > Use Loading by Single Soil 
Movement Profile or under Data > Options and Settings > Use Separate Soil Movement Profiles 
for Each Load Case.  A maximum of 50 points may be defined in the table.  A maximum of 50 
entries is allowed for definition of the soil movement profile in an analysis.  
 LPile provides two options for specifying free-field soil movement in the soil profile. 
Either a single soil movement profile can be applied to all load cases or independent soil movement 
profiles can be specified for each conventional loading case. The soil movement profile may be 
defined only along a portion of the pile length if desired. In general, a pile under lateral load moves 
against a soil mass. However, in some cases, the soil itself will move and the soil loading or 
reaction must be considered by taking into account the relative movement between the soil and the 
pile. LPile will automatically generate the soil reaction at each pile node consistent with the relative 
movement between the soil and pile at that particular depth.  
 The input dialog for soil movements versus depth is shown in Figure 3.57. The user may 
enter data in one of three ways. The user may add enough rows to accommodate the data and enter 
the data manually, the user may paste the data into the table via the Windows clipboard, or read 
an external text data file. The graph in the dialog shows the current data. It may be necessary for 
the user to move the cursor to an adjacent cell to update the graph of lateral soil movement. 
 Depth Below Pile Head: These values represent the x-coordinate corresponding to the 
depths where the soil movement occurs. Intermediate values of soil movement located between 
two specified depths are obtained by linear interpolation of the specified values. It is therefore 
necessary to have at least two entries of depths. Soil movement must be entered in ascending order 
of depths. 
 Lateral Soil Movement: The soil movement values may be positive for soil moving from 
left to right or negative for soil moving from right to left. However, it is critical that the soil 
movement occurs in the same direction as the applied loads.  
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Figure 3.57  Dialog for Input of Soil Movements versus Depth Below Pile Head 

3.16.4 Concentrated Loads Along Pile 
The input dialog Data > Concentrated Loads Along Pile is inactive by default but enabled 

if the user places a check mark under Data > Options and Settings > Use Single Concentrated 
Load Profile or under Data > Options and Settings > Use Separate Concentrated Load Profiles 
for Each Load Case.  A maximum of 50 entries is allowed for definition of applied loads along 
the pile length.  When selecting separate load profiles, the user must enter as many load profiles 
as load cases. 
 A sample input dialog for Concentrated Loads is shown in Figure 3.58. The user may enter 
data in one of three ways. The user may add enough rows to accommodate the data and enter the 
data manually, the user may paste the data into the table via the Windows clipboard, or read an 
external text data file. 
 Distance to Pile Head: These values represent the x-coordinate corresponding to the depths 
where the concentrated load is applied. Concentrated loads must be entered in ascending order of 
distances (depths). 
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 Shear: The horizontal (lateral) load, or shear, may be positive when applied from left to 
right or negative from right to left.  This is specified in units of force (lb or kN). 
 Moment: The bending moment may be positive when applied clockwise or negative when 
counter-clockwise.  This is specified in units of force-length (lb-in or kN-m). 

 
Figure 3.58  Sample Dialog for Input of Concentrated Loads Along Pile 

3.16.5 Evaluations of Variable Pile Lengths 
The input dialog Data > Controls for Computation of Variable Pile Length Analysis is 

inactive by default but enabled if the user places a check mark under Data > Options and Settings 
> Consider Variation of Pile Length.  The dialog for Controls for Variable Pile Length Analysis is 
presented in Figure 3.59. 
 This program feature allows users to evaluate the lateral response of multiple pile lengths.  
Users are provided with same basic loading options as those under Data > Pile Loading, which is 
disabled when using this feature.  The dialog box allows users for automatic selection of pile 
lengths within certain limits, to select pile lengths based on increments specified by the user or to 
enter specific pile lengths manually. 



CHAPTER 3 – Input of Data – 3-66 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

 
Figure 3.59  Sample Dialog for Controls for Variable Pile Length Analysis 

 All resulting graphs from this feature will show the results for all pile length evaluations 
that were defined by the user.  An example of output graph for lateral pile deflections is provided 
in Figure 3.60. 

 
Figure 3.60  Sample Pile Deflection Graph for Various Pile Lengths 
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3.16.6 Computation of Pile-head Stiffness Matrix Components 
 The dialog Data > Controls for Computation of Stiffness Matrix is shown in Figure 3.61.  
This dialog is inactive by default but enabled if the user places a check mark under Data > Options 
and Settings > Compute Pile-Head Stiffness Matrix Values. 
 The feature for computation of pile-head stiffness matrix values has three options to control 
how the values are computed. In the first method, which is identical to the method used in versions 
of LPile prior to LPile 2013, the loads used for computation of pile-head stiffness are those 
specified in load case 1 for conventional loading. This method does not allow the user to control 
the lateral displacement and pile-head rotation, so the second and third options were added to 
provide this capability. In the second method, the maximum displacement and rotation are set by 
the values computed for load case 1 for conventional loading. In the third method, the user may 
specify the maximum pile-head displacement and rotation. 

 
Figure 3.61  Dialog for Controls for Computation of Stiffness Matrix 

 The definitions of the pile-head stiffness values and their engineering units computed by 
LPile are the following: 
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3.16.7 Pushover Analysis 
The input dialog Data > Controls for Computation of Pushover Analysis is inactive by 

default but enabled if the user places a check mark under Data > Options and Settings > Compute 
Push-over Analysis.  The dialog for Controls for Pushover Analysis is presented in Figure 3.62. 
 The program feature for pushover analysis has options for different pile-head fixity and the 
setting of the range and distribution of pushover deflection. The output of the pushover analysis is 
displayed in graphs of pile-head shear force versus deflection and maximum moment developed 
in the pile versus deflection. 
 The pushover analysis is performed by running a series of analyses for displacement-zero 
moment pile-head conditions for pinned head piles and analyses for displacement-zero slope pile-
head conditions for fixed head piles. The displacements used are controlled by the maximum and 
minimum displacement values specified and the displacement distribution method. The 
displacement distribution method may be either logarithmic (which requires a non-zero, positive 
minimum and maximum displacement values), arithmetic, or a set of user-specified pile-head 
displacement values. The number of loading steps sets the number of pile-head displacement 
values generated for the pushover analysis.  
 The axial thrust force used in the pushover analysis must be entered in the dialog. If the 
pile being analyzed is not an elastic pile, the user should make sure that the axial thrust force 
entered matches one of the values for axial thrust entered in the conventional pile-head loadings 
table to make sure that the correct nonlinear bending properties are used in the pushover analysis. 
If the values do not match, the nonlinear bending properties for the next closest axial thrust will 
be used by LPile for the pushover analysis. 

 
Figure 3.62  Dialog for Controls for Pushover Analysis 

 Results from a pushover analysis are presented in the following two figures. Figure 3.63 
(similar plot obtained from Graphics > Pushover Shear vs. Top Deflection) presents the pile-head 
shear force versus displacement for pinned and fixed head conditions and indicates the maximum 
level of shear force that can be developed for the two conditions. Similarly, Figure 3.64 (similar 
plot obtained from Graphics > Pushover Moment vs. Top Deflection) presents the maximum 
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moment developed in the pile (a prestressed concrete pile in this example) versus displacement 
and shows that a plastic hinge develops in the fixed head pile at a lower displacement than for the 
pinned head pile. 
 Unless the user selects the CALTRANS Equivalent ElastoPlastic Moment Curvature 
(Section 3.6.20.2), it is often not possible to identify the displacement at which a plastic hinge 
forms in the graph of pile-head shear force versus displacement. Instead, the user should examine 
the graph of maximum moment developed in the pile versus displacement to determine the lateral 
pile-head displacement at which the maximum developed moment is reached. The lateral 
displacements at which the plastic moment forms are indicated in Figure 3.63 and Figure 3.64. 
 For pile sections modeled as Equivalent ElastoPlastic Moment Curvature (Section 
3.6.20.2), the user may select to Stop Analysis if Second Plastic Hinge is Developed.  In such 
cases, if plastic hinges are developed the LPile program will indicate the formation of hinges in 
the Graphics > Pushover Shear vs. Top Deflection and in the Graphics > Pushover Moment vs. 
Top Deflection plots.  A sample set of pushover result plots for an LPile model using pile section 
with Equivalent ElastoPlastic Moment Curvature is shown in Figure 3.65. 
 In general, it is not possible to develop more than one plastic hinge in a pile if the pile-head 
condition is pinned. It is sometimes possible to develop two plastic hinges in the pile if the pile-
head condition is fixed.  

 
Figure 3.63  Pile-head Shear Force versus Displacement from Pushover Analysis 

Formation of 
plastic hinge
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Figure 3.64  Maximum Moment in Pile versus Displacement from Pushover Analysis 

 
Figure 3.65  Sample Pushover Results for Pile Section with ElastoPlastic Moment Curvature 

3.16.8 Pile Buckling Analysis 
The input dialog Data > Controls for Computation of Pile Buckling Analysis is inactive by 

default but enabled if the user places a check mark under Data > Options and Settings > Compute 
Pile Buckling Analysis.  The dialog for the Controls for Pile Buckling Analysis is shown in Figure 
3.66. 

Formation of 
plastic hinge
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 The feature for performing an analysis of pile buckling has options for the pile-head fixity 
condition, pile-head loadings, maximum compression loading, and number of loading steps. The 
pile buckling analysis is performed by applying the pile-head loading conditions, then increasing 
the axial thrust loading from zero to the maximum compression load in the number of loading 
steps specified.  

  
Figure 3.66  Dialog for Controls for Pile Buckling Analysis 

 The results of the pile buckling analysis are presented in a graph along with an estimate of 
the axial buckling capacity for the pile-head loading condition. This graph displays the pile-head 
lateral deflection versus axial thrust force, a fitted hyperbolic curve, and the estimated pile buckling 
capacity. 
 The hyperbolic curve is fitted to the computed results using the following procedure. 
 The typical results from the pile buckling analysis are similar to those shown in Figure 
3.67. In this figure, P is the axial thrust force and y0 is the pile-head deflection for the case of 
minimum axial load (P0). These results are then redrawn with every deflection value shifted to the 
left by an amount equal to y0, as shown in Figure 3.68. 
 The form of the hyperbolic curve to be fitted is 

𝑃𝑃 =
𝑦𝑦 − 𝑦𝑦0

𝑏𝑏 + 𝑎𝑎(𝑦𝑦 − 𝑦𝑦0)
𝑏𝑏 + 𝑃𝑃0 

 This may be rearranged in the form of straight line with a slope a and intercept b as 

𝑦𝑦 − 𝑦𝑦0
𝑃𝑃 − 𝑃𝑃0

= 𝑏𝑏 + 𝑎𝑎(𝑦𝑦 − 𝑦𝑦0) 

 The computed results are then redrawn as in Figure 3.69 and least-squares curve fitting is 
used to compute the curve fitting parameters a and b. 
 The estimate pile buckling capacity Pcrit is computed using  
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𝑃𝑃𝑐𝑐𝑐𝑐𝑐𝑐𝑐𝑐 − 𝑃𝑃0 =
1
𝑎𝑎

 

 LPile can graph the computed results, the fitted curve, and the estimated pile buckling 
capacity. A typical graph is shown in Figure 3.70. 

 
Figure 3.67  Typical Results for a Pile Buckling Analysis 

 
Figure 3.68  Computed Pile Buckling Result Shifted to the Left 
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Figure 3.69  Redrawn Pile Buckling Results Used for Curve Fitting 

 
Figure 3.70  Results from Pile Buckling Analysis 

 In this graph, the response curve is plotted with symbols and the fitted curve is drawn 
without symbols. The filled curve overlies the curve for computed pile response, so the line for 
computed pile response is not visible but the symbols on the response curve are visible. 
 When performing a pile buckling analysis, the user must guard against specifying a 
maximum axial load that is too high. This can be checked by examining the sign of deflection of 
the lateral deflection value for zero axial load. In a proper analysis, the magnitude of lateral 
deflection at higher values of axial thrust will have the same sign as that for zero axial thrust and 
the deflection values will be larger in magnitude, as shown in Figure 3.70.  
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 The estimated pile buckling capacity for elastic piles is computed from the shape of the 
pile-head response curve and is not based on the magnitude of maximum moment compared to the 
plastic moment capacity of the pile. For nonlinear piles, the buckling capacity may be determined 
by either the maximum axial compression capacity or plastic moment capacity of the pile. For 
piles with nonlinear bending behavior, the buckling capacity estimated by the hyperbolic curve 
may over-estimate the actual buckling capacity if the buckling capacity is controlled by the pile’s 
plastic moment capacity. Thus, for analyses of nonlinear piles, the user should compare the 
maximum moment developed in the pile to the plastic moment capacity. If the two values are close, 
the buckling capacity should be reported as the last axial thrust value for which a solution was 
reported.  
 If the section is either a drilled shaft (bored pile) or prestressed concrete pile with low levels 
of reinforcement, it may be possible to obtain buckling results for axial thrust values higher than 
the axial buckling capacity, but the sign will be reversed. The reason for this is a large axial thrust 
value will create compression over the full section. This causes the moment capacity to be 
controlled by crushing of the concrete and not by yield of the reinforcement. An example of a pile 
buckling analysis that used axial thrust values that were too high is shown in Figure 3.71. 

 
Figure 3.71  Example of Correct (green symbols) and Incorrect (red symbols) Pile Buckling 
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3.17 Input of Load Testing Data 
The input dialog Data > Data from Lateral Load Test is inactive by default but enabled if 

the user places a check mark under Data > Options and Settings > Input Data for Load Test for 
Comp. to Computed Values.  The dialog for Lateral Load Test Data is presented in Figure 3.72. 
 Data for pile response measured during lateral load testing may be entered into LPile and 
displayed along with computed results. When this option is selected, the user is required to enter 
values of pile-head shear force loading versus lateral deformation. Optionally, the user may enter 
values of moment developed in the pile versus depth below the pile head for each pile-head shear 
force value. 

3.17.1 Controls for Input of Load Test Data 
 Entry of load test data is controlled using the dialog box shown in Figure 3.72. The basic 
data entered are the pile-head shear versus displacement data. Optionally, the user may enter values 
of bending moment and/or lateral displacement versus depth. Lastly, the user may select whether 
or not the load test values are included in the graphs generated by LPile. 
 It is also possible for LPile to save load test data that has been entered as a text file and to 
read a text file containing the load test data. 
 The user should note that load test data is not saved as part of the LPile input data. Thus, 
each time LPile is restarted for a new analysis, it will be necessary to re-enter the load test data 
either by reading from the previously saved text file or by re-entering the data to LPile. 
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Figure 3.72  Dialog for Control of Input and Saving of Load Testing Data 

3.17.2 Input of Load Test Data without Data for Bending Moments 
 An example of the dialog for entering pile-head shear force versus lateral deformation is 
shown in Figure 3.73. Data must be entered directly in the current system of units being used by 
LPile. However, if an existing file of load test data is being read via the load test data controls 
shown in Figure 3.72, the engineering units of the load test data is saved in the text file and the 
data will be converted, if needed, to the current system of units being used by LPile. 

3.17.3 Input of Load Test Data for Bending Moments and Deflection versus Depth 
 If input of bending moment and/or lateral deflection data versus depth may be specified by 
marking the check boxes in Figure 3.72 to include data versus depth. The user may input a profile 
of bending moment and/or lateral deflection versus depth for each pile head loading level for which 
data is available via the data controls shown in Figure 3.74. The columns displayed will depend 
on the check boxes marked in the controls dialog. The input dialogs for bending moment and 
lateral deflections versus depth are shown in Figure 3.75.  
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Figure 3.73  Dialog for Input of Pile-head Shear Force versus Lateral Deformation from Load 

Testing, if input of Bending Moment and/or Lateral Movement versus Depth is not specified. 
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Figure 3.74  Dialog for Input of Pile-head Shear Force versus Lateral Deformation from Load 

Testing, if input of Bending Moment and Lateral Deflection versus Depth are specified. 
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Figure 3.75  Dialogs for Input of Bending Moment and Lateral Deflection versus Depth from 

Load Testing. 

3.18 Load and Resistance Factor Design 
 Data for load and resistance design computations is entered using two input dialogs. 
Unfactored loads are entered in one dialog and the definitions of load and resistance factors to be 
used are entered in the second dialog. A summary report of computed load cases is also provided 
to aid the user in verifying the factored loads computed for the defined load cases. The following 
sections describe these dialogs and the summary report. 
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3.18.1 Unfactored Loads 
 The input dialog for unfactored loads shown in Figure 3.76 allows the user to define the 
type of load, horizontal force, vertical force, overturning moment, and to control the use and input 
of distributed loading data. All unfactored loads must be defined as combinations of horizontal 
shear force, over-turning moment, axial thrust force, and distributed lateral loads normal to the 
axis of the pile. 

 
Figure 3.76  Dialog for Definition of Unfactored Pile-head Loadings for LRFD Analysis 

 The unfactored load definition includes the type of load. The load types are: 
Dead load 
Live load 
Earthquake 
Impact 
Wind 
Water 
Ice 
Horizontal Soil Pressure 
Live Roof 
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Rain 
Snow 
Temperature 
Special (for any type of load not listed above) 

 If the user wishes to enter data for a distributed lateral loading, an input dialog identical to 
that shown in Figure 3.54 on page 3-61 is displayed. 

3.18.2 Load Cases and Resistance Factors 
 The user controls the definition of load cases either by reading the LRFD load case data 
file from the Data > Options and Settings dialog box or by entering the specific load case in the 
dialog shown in Figure 3.77 (Data > Load and Resistance Cases). To include a load type in a 
load case combination, the user enters a positive, non-zero value. In addition, the user may enter 
the resistance factors for structure resistance in bending and shear capacity and may enter a 
descriptive name for the load case combination.  

 
Figure 3.77  Dialog for LRFD Load Combinations and Structural Resistance Factors 

 The current version of LPile does not compute structural shear capacity for all type of piles, 
but allows the user to input a value of shear capacity for each pile section.  The factored shear 
capacity is computed by LPile by multiplying the resistance factor for shear by the input value for 
shear capacity. If the value of factored shear capacity is non-zero, LPile will evaluate the shear in 
the pile section by comparing the maximum developed shear force to the factored shear capacity 
in each pile section. 

For Round Concrete Shaft and Rectangular Concrete Shaft, LPile can optionally select to 
Estimate Resistance Factors and Shear Capacity (if transverse reinforcement is also specified) 
according to the ACI 318-14 code.  This is done by selecting the appropriate checkmark in the 
Data > Pile Properties dialog box.  Results are included in sections of the output text file. 
 In the case of pile sections defined as elastic-plastic piles with tapered dimensions, the 
value of shear capacity at each pile nodal point is computed by interpolation between the values at 
the top and bottom of the section and the developed shear force is compared to the shear capacity 
at every nodal point in the section. 
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3.18.3 Summary of Factored Load Cases 
 The summary of factored load cases is provided for the user to view the factored loads 
computed by LPile. LPile computes this summary by first adding all pile-head loading of the same 
type together, then multiplying the sum by relevant load factor.  
 In the case of distributed loads, the program integrates the individual distributed load 
profiles and computes the equivalent concentrated forces at nodes on the pile, adds all forces from 
the same load type together, and then multiplies the sum by the relevant load factor.  
 The summary report has three general sections. The first section shows the totals of the 
unfactored loads. The second part shows the computed factored loads for each load case in turn. 
The third part shows the factored load cases in tabular form. The content of the summary report is 
saved under the filename of the data file with the file extension of LRFD_Summary_Report. An 
example of the summary report is shown in Figure 3.78. 

 
Figure 3.78  Summary Report of Computed Factored Load Combinations for LRFD Analysis 

3.19 Computation of Nonlinear EI Only 
3.19.1 Axial Thrust Loads for Interaction Diagram 
 If the user selects the program option to Compute Nonlinear EI Only, the user may generate 
a structural interaction diagram by entering multiple axial thrust values. The thrust values may be 
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entered in any order and LPile will sort the values from lowest to highest and remove duplicate 
entries before performing computations. An example of the input dialog for setting axial thrust 
force values is shown in Figure 3.79. An example of the input dialog for entering axial thrust force 
values is shown in Figure 3.80. 
 Example 5, discussed in Section 1.1, demonstrates how to compute nonlinear EI only and 
how to produce both unfactored and factored interaction diagrams. 
 
 

  
Figure 3.79  Dialog for Axial Thrust Forces for Computation of Interaction Diagram 
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Figure 3.80  Dialog to enter Axial Thrust Forces for Computation of Interaction Diagram 
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4.1 Introduction 
 The Graphics menu is used to display graphs of output data after a successful analysis. 
Options for the display of graphs under the Graphics menu are only enabled after a successful 
analysis has been made. Even after performing a successful analysis, some graphing may be 
disabled since the types of graphical output are controlled by the selected program options. 

4.2 Types of Graphics 
 Two types of graphics are provided by LPile; fast graphics and presentation graphics. Fast 
graphics are graphs that can be displayed either from the Graphics menu or by clicking a button 
on the button bar. Fast graphics have limited features for modifying the graphs and their contents. 
Presentation charts are displayed using the Presentation Charts command from the Graphics menu 
or by pressing the  button on the button bar. 

4.3 Graphics Mouse Commands 
The following mouse commands are available within a graphic window: 

Mouse Action Event Description 

Left click and drag down and right Magnifies the area within the drag/release 

Right click Zoom out 

Double click on legend entry Turns the selected curve on or off 

4.4 Graphics Buttons 
 The buttons shown in Figure 4.1 will display charts of the computed results when enabled 
after an analysis. If the program feature required to generate a graph is not activated, the 
corresponding button will not be enabled. 

    
Figure 4.1  Speed Buttons for Graphics 

4.5 Graphics Menu 
A sample Graphics menu is shown in Figure 4.2.  Graphs for which buttons exist on the button bar 
have the identical icon as shown in the Graphics menu entries. 
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Figure 4.2  Sample Graphics Menu 
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4.6 Plot Menu 
The Plot menu is visible only when a fast graphic is being displayed. A sample Plot menu is shown 
below. 

 
Figure 4.3  Sample Plot Down Menu 

Show Legend turns the display of the graph’s legend on or off. 
Show Soil Layer turns the display of the soil profile on or off on graphs of pile response versus 
depth. The soil profile is not shown on other types of graphs  
Show Markers can either turn the display of data point markers on or off or change the increment 
for the display of the markers. Markers can be displayed at every point, second point, fifth point, 
or tenth point. 
 Font Size is used to change the size of the fonts used on the graph. 
 Line Width is used to change the width of the graph lines. 
 Graph Title is used to enter a graph title and to specify the position of the graph title. 
 Edit Legend is used to edit the curve names displayed in the graph’s legend. 
 Active Curves is used to turn the display of individual curves on or off. 
 Print is used to print the graph on the active printer. 
 Page Setup is used to change the active printer and to configure the page margins. 
Save To Disk is used to save the currently displayed graph to disk as a bitmap file. The Presentation 
Charts utility is used to save the graph in other graphics file formats. See Section 4.9 for more 
information about the Presentation Charts utility. 
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4.7 Graphics of Input Data 
4.7.1 Pile-Soil Geometry 
 This command in the Graphics menu displays a graphical representation of the side view 
of the modeled pile and soil layers. This command becomes active after data of Pile Properties, 
Soil Layers, Soil Weight, and Soil Strength have been entered under the Data menu, or when 
opening previously-executed data files. The angles of ground slope and pile batter and the 
proportions of the pile sections are accurately portrayed in this view.  

4.7.2 3D View 
 This command in the Graphics menu displays a 3D graphical representation of the pile 
modeled and soil layers. The angles of ground slope and pile batter and the proportions of the pile 
sections are accurately portrayed in this view. The user has options to pan, zoom and rotate the 
view. While this view is active the Show 3DView menu will be visible that allows the user to hide 
parts of the model or show other features like axes, boundary conditions and distributed loading.  
 

 
Figure 4.4  Example of the 3D View Window 
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4.7.3 Summary Charts of Soil Properties 
 This Graphics menu command displays summary charts of soil properties. The number of 
charts varies from four to eight charts, depending on the soil layer types contained in the soil 
profile. An example of the Summary Charts of Soil Properties is shown in Figure 4.5. 

 
Figure 4.5  Example of Summary Graphs of Soil Properties 

4.7.4 Distributed Lateral Loads vs. Depth 
This menu is only enabled when users selected the Data > Program Options and Settings > Use 
Loading by Single Distributed Load Profile along with Data > Distributed Lateral Loading. This 
Graphics menu command displays charts of distributed lateral loads versus depth for both 
conventional analysis and LRFD analysis modes of computation. 

4.7.5 p and y Modifiers versus Depth 
This menu is only enabled when users selected the Data > Program Options and Settings > Use 
Modification Factors for p-y Curves along with Data > Modification Factors for p-y Curves.  This 
Graphics menu command displays charts of p and y modifiers versus depth and the ratio of the p 
and y modifiers versus depth. In computations, the ratio of the p and y modifiers is used to adjust 
the p-y curves when computing the effective soil modulus. Thus, if the ratio is equal to the default 
ratio of 1, the p-y curves are not modified in the computations. 

4.7.6 p-y Curves 
This menu is only enabled when users selected the Data > Program Options and Settings > 
Generate p-y Curves at User-Specified Depths along with Data > Output Depths of p-y Curves.   
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Notice that the “p” values are in units of force per unit depth of pile and the “y” values are in units 
of lateral movement of the pile.  Some p-y curves at ground surface may be all zeros and not 
display correctly so users may choose to print at some depth below ground surface. 

4.7.7 User-Input p-y Curves 
This Graphics menu command displays charts of any user-input p-y curves entered as data. If no 
curves are input, this Graphics command will not be enabled. 
The user-input p-y curves displayed by this graphics command are plotted using the input data for 
the curves at the top and bottom of the soil layer. The curves displayed with this graphics command 
are not interpolated with depth. 

4.8 Graphics of Computational Results 
4.8.1 View Results 
 The View Results speed button displays summary charts of the principal results from the 
last computational model. The type and number of charts displayed in the View Results window 
depends on the various program options that were selected for the model. The minimum number 
of charts displayed is three and the maximum number of charts displayed is eight. An example of 
the View Results window is shown in Figure 4.6. 

 
Figure 4.6  Example of View Results Window 

4.8.2 Lateral Deflection versus Depth 
This Graphics menu command displays a graph lateral deflection versus depth for the modeled 
pile. This curve is automatically generated in all analytical runs for a laterally loaded pile. The 
number of points on the deflection curve is equal to the selected number of pile increments. Several 
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curves may be contained in this graphics if the user selects to input several load cases.  For models 
with multiple load cases, this plot only displays the results for the first twenty loads.  To see the 
other results, the user must select the Plot > Active Curves menu. 

4.8.3 Bending Moment versus Depth 
This Graphics menu command displays a graph bending moment versus depth along the pile. This 
curve is automatically generated in all analytical runs for a laterally loaded pile. The number of 
points on the moment curve is equal to the selected number of pile increments. Several curves may 
be contained in this graphics if the user selects to input several load cases.  For models with 
multiple load cases, this plot only displays the results for the first twenty loads.  To see the other 
results, the user must select the Plot > Active Curves menu. 

4.8.4 Shear Force versus Depth 
This Graphics menu command displays a graph of shear force versus depth along the pile. This 
curve is automatically generated in all analytical runs for a laterally loaded pile. The number of 
points on the shear curve is equal to the selected number of pile increments. Several curves may 
be contained in this graphics if the user selects to input several load cases. For models with multiple 
load cases, this plot only displays the results for the first twenty loads.  To see the other results, 
the user must select the Plot > Active Curves menu. 

4.8.5 Mobilized Soil Reaction versus Depth 
This Graphics menu command displays a graph of soil reaction versus depth along the pile. This 
curve is automatically generated in all analytical runs for a laterally loaded pile. The number of 
points on the soil-reaction curve is equal to the selected number of pile increments. Several curves 
may be contained in this graphics if the user selects to input several load cases. For models with 
multiple load cases, this plot only displays the results for the first twenty loads.  To see the other 
results, the user must select the Plot > Active Curves menu. 

4.8.6 Deflection, Moment, and Shear Force versus Depth 
This Graphics menu command displays three side-by-side graphs of pile deflection, bending 
moment, and shear force versus depth along the pile. This graphical display can be shown for all 
analytical runs for a laterally loaded pile. The scaling for the depth axis is the same for all three 
graphs and allows for comparison of pile deflection, bending moment and shear force values versus 
depth along the pile. 

4.8.7 Deflection, Curvature, and Moment versus Depth 
This Graphics menu command displays three side-by-side graphs of pile deflection, bending 
curvature, and bending moment versus depth along the pile. This graphical display can be shown 
for all analytical runs for a laterally loaded pile. The scaling for the depth axis is the same for all 
three graphs and allows for comparison of pile deflection, bending curvature, and bending moment 
values versus depth along the pile. This graph may be useful in analyses of pile response due to 
loading by lateral spread of soil after seismic events. 
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4.8.8 Mobilized Pile EI versus Depth 
This Graphics menu command is available when the pile has a nonlinear moment-curvature 
relationship. This chart shows the value of mobilized EI along the length of the pile. This chart is 
useful to display the sections with either cracked-section EI or where plastic hinges develop. 

4.8.9 Slope versus Depth 
This Graphics menu shows the value of the slope (in radians) along the length of the pile. 

4.8.10 Load versus Top Deflection 
This Graphics menu command is enabled if the user specifies two or more load cases in the input 
data. The specified load cases must have varying lateral loads with or without changes in applied 
moments or applied axial loads. The user may select this Graphics command to display a graph of 
curve of applied lateral load versus pile-top deflection.  

4.8.11 Load versus Max Moment 
This Graphics menu command is enabled if the user specifies two or more load cases in the input 
data. The specified load cases must have varying lateral loads with or without changes in applied 
moments or applied axial loads. The user may select this Graphics command to display a graph of 
applied lateral load versus maximum bending moment along the pile length.  

4.8.12 Top Deflection versus Pile Length 
This Graphics menu command is enabled if the user selects Yes under Compute Top y vs L? 
(Generate Pile Length versus Top Deflection) in the Data > Pile Head Loading menu for a load 
case for conventional loading.  The user may select this Graphics command to display a graph of 
pile length versus pile-head deflection for the load cases evaluated with this option.  

4.8.13 EI versus Moment 
This Graphics menu command is enabled whenever the nonlinear bending is evaluated for a pile 
section. The user may select this Graphics command to display a graph of bending stiffness versus 
bending moment. Values of bending stiffness shown in these curves are used internally in each 
finite increment of pile analysis when the user selects the analysis of pile response with nonlinear 
EI. The number of curves depends on the number of axial loads specified for section analysis. 

4.8.14 Moment versus Curvature 
This Graphics menu command is enabled whenever the nonlinear bending is evaluated for a pile 
section. The user may select this Graphics command to display a graph of bending moment versus 
curvature. These curves are helpful to find the ultimate bending moment of the modeled cross 
section. The number of curves depends on the number of axial loads used for section analysis or 
the number of axial thrust forces defined by the pile-head loading conditions. 

4.8.15 Interaction Diagram 
This Graphics menu command is enabled if the user selected to perform a section analysis and 
inputs several axial thrust load cases for the analysis. The user may select this Graphics command 
to display an unfactored interaction diagram (ultimate bending moment versus axial load) of the 
modeled cross section. These curves are helpful to find the ultimate bending moment for several 



CHAPTER 4 – Display of Graphics – 4-10 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

axial load cases in the modeled cross section. The number of curves depends on the number of 
axial loads used for section analysis or the number of axial thrust loads defined by the pile-head 
loading conditions. 

4.8.16 All K’s versus Deflection and Rotation 
 This Graphics Menu command displays six charts simultaneously of K22, K23, K32, K33 
versus pile-head displacement and rotation plus pile-head reactions and displacements for free-
head and fixed-head pile fixity conditions. 

4.8.17 All K’s versus Shear and Moment 
 The Graphics Menu command displays six charts simultaneously of K22, K23, K32, K33 
versus pile-head shear and moment plus pile-head reactions and displacements for free-head and 
fixed-head pile fixity conditions. 

4.8.18 Individual K’s versus Force and Moment 
 This Graphics Menu command opens a submenu for displaying the individual curves of 
pile-head stiffnesses versus force and moments. The submenu is shown in Figure 4.7. 

 
Figure 4.7  Sub-menu for Pile-head Stiffnesses versus Pile-head Force and Moment 

4.8.18.1 K22 versus Pile-head Shear Force 
 This Graphics Menu command is enabled when the Generate Foundations Stiffness option 
is selected. When enabled, the selection of this command will show a curve of the K22 (shear 
force/deflection) component of a 6×6 foundation stiffness matrix. The user should refer to Section 
3.16.4 for more information about the feature for computing pile-head stiffnesses. 

4.8.18.2 K23 versus Pile-head Shear Force 
 This Graphics Menu command is enabled when the Generate Foundations Stiffness option 
is selected. When enabled, the selection of this command will show a curve of the K23 (shear 
force/rotation) component of a 6×6 foundation stiffness matrix. The user should refer to Section 
3.16.4 for more information about the feature for computing pile-head stiffnesses. 

4.8.18.3 K32 versus Pile-head Moment 
 This Graphics Menu command is enabled when the Generate Foundations Stiffness option 
is selected. When enabled, the selection of this command will show a curve of the K32 
(moment/deflection) component of a 6×6 foundation stiffness matrix. The user should refer to 
Section 3.16.4 for more information about the feature for computing pile-head stiffnesses. 

4.8.18.4 K33 versus Pile-head Moment 
 This Graphics Menu command is enabled when the Generate Foundations Stiffness option 
is selected. When enabled, the selection of this command will show a curve of the K33 
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(moment/rotation) component of a 6×6 foundation stiffness matrix. The user should refer to 
Section 3.16.4 for more information about the feature for computing pile-head stiffnesses. 

4.8.19 Individual K’s versus Pile-head Deflection and Rotation 
 This Graphics Menu command opens a submenu for displaying the individual curves of 
pile-head stiffnesses versus pile-head deflection and rotation. The submenu is shown in Figure 4.8. 

 
Figure 4.8  Submenu for Pile-head Stiffnesses versus Deflection and Rotation 

4.8.19.1 K22 versus Pile-head Deflection 
 This Graphics Menu command is enabled when the Generate Foundations Stiffness option 
is selected. When enabled, the selection of this command will show a curve of the K22 (shear 
force/deflection) versus pile top deflection. 

4.8.19.2 K23 versus Pile-head Rotation  
 This Graphics Menu command is enabled when the Generate Foundations Stiffness option 
is selected. When enabled, the selection of this command will show a curve of the K23 (shear 
force/rotation) versus pile top rotation. 

4.8.19.3 K32 versus Pile-head Deflection 
 This Graphics Menu command is enabled when the Generate Foundations Stiffness option 
is selected. When enabled, the selection of this command will show a curve of the K32 
(moment/deflection) versus pile top deflection. 

4.8.19.4 K33 versus Pile-head Rotation 
 This Graphics Menu command is enabled when the Generate Foundations Stiffness option 
is selected. When enabled, the selection of this command will show a curve of the K33 
(moment/rotation) versus pile top rotation. 

4.8.20 Pushover Shear Force versus Top Deflection 
This Graphics menu is available only if the user placed a check mark under Data > Options and 
Settings > Compute Push-over Analysis and performed a push-over analysis.  This graph may 
contain either one or two curves depending on the pile-head fixity condition selected in the Data 
> Controls for Computation of Pushover Analysis.  
This graph shows the pile-head shear force developed as a function of pile-head deflection. For 
piles with nonlinear bending, it may be possible to see the point at which a plastic hinge develops, 
but this point may be more easily seen in the graph of pushover moment versus top deflection, 
discussed subsequently. 
For pile sections modeled as Equivalent ElastoPlastic Moment Curvature (Section 3.6.20.2), if 
plastic hinges are developed the LPile program will indicate the formation of hinges in the 
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Graphics > Pushover Shear vs. Top Deflection and in the Graphics > Pushover Moment vs. Top 
Deflection plots. 

4.8.21 Pushover Moment versus Top Deflection 
This Graphics menu is available only if the user placed a check mark under Data > Options and 
Settings > Compute Push-over Analysis and performed a push-over analysis.  This graph may 
contain either one or two curves depending on the pile-head fixity condition selected in the Data 
> Controls for Computation of Pushover Analysis.  
The moment value displayed in the graph is the maximum moment developed in the pile. If the 
pile has a single section with nonlinear bending properties, it is possible to see at which value of 
top deflection the moment capacity is reached by where the curve becomes horizontal. If the pile 
has more than one section with different moment capacities, it may not be possible to determine 
when the moment capacity is reached in sections with lower moment capacities. 
For pile sections modeled as Equivalent ElastoPlastic Moment Curvature (Section 3.6.20.2), if 
plastic hinges are developed the LPile program will indicate the formation of hinges in the 
Graphics > Pushover Shear vs. Top Deflection and in the Graphics > Pushover Moment vs. Top 
Deflection plots. 

4.8.22 Pile Buckling Thrust versus Top Deflection 
This Graphics menu is available only if the user placed a check mark under Data > Options and 
Settings > Compute Pile Buckling Analysis and performed a buckling analysis.  The display of this 
graph depends on the parameters entered in the Data > Controls for Computation of Pile Buckling 
Analysis.  
LPile can graph both the pile buckling thrust versus computed pile top deflection, the fitted 
hyperbolic curve, and the estimated pile buckling capacity determined from the fitted hyperbolic 
curve. A typical graph for pile buckling analysis is shown in Figure 3.70. 

4.8.23 Soil Movement and Deflection versus Depth 
This Graphics menu is available only if the user placed a check mark under Data > Options and 
Settings > Use Loading by Single Soil Movement Profile or Data > Options and Settings > Use 
Separate Soil Movement Profiles for each Load Case and entered the parameters under Data > 
Lateral Soil Movements.  This graph displays a combined chart of lateral pile deflection and user-
inputted soil movements versus depth.   

4.9 Presentation Charts 
 This Graphics Menu command opens a graphing tool to customize the various aspects of a 
presentation chart, such as font type, size, and style, line colors, styles, and widths, data point 
markers, legend text and font, and axis and grid scaling. A detailed description of each function 
and options are given in the associated Help file for the Presentation Charts tool. 
 The Presentation Charting utility can generate up to 28 different types of graphs. The type 
of chart is selected from the drop-down combo box above the chart. Note that only the charts 
capable of being drawn are offered in the drop-down combo box. 
 If desired by the user, two graphs can be displayed side-by-side. While both graphs may 
be edited and exported, chart templates can be saved and applied to only the left chart. 



CHAPTER 4 – Display of Graphics – 4-13 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

4.9.1 Saving and Applying Presentation Chart Templates 
 After the left chart has been edited for export, a chart template with these chart features 
and font styles may be saved for later application for each type of chart (i.e. use separate templates 
for graphs of p-y curves, lateral deflection vs. depth, moment vs. depth, etc.). The chart template 
files are saved in the same folder as the other data and output files for LPile. The chart template 
files will have the filename extension “tee.” 
 The chart settings saved in the chart template include the axis scaling settings. If a chart 
template contains fixed axis scaling settings, the chart may not display the complete range of 
results after it has been applied and require some editing to restore the display of the full range of 
results. Thus, it is recommended that the chart axis scaling remain in the automatic mode prior to 
saving the chart template. 

4.9.2 Exporting Presentation Charts 
 It is possible to export and save the presentation charts in several graphics formats. In 
addition, it is possible to copy graphs to the Windows clipboard for pasting into word processing 
or graphical presentation programs such as Microsoft Word and Microsoft PowerPoint. Most users 
find using the Enhanced Windows Metafile graphics format to be most flexible in use, highest in 
quality, and to result in the smallest word processing file size. 

4.10 3D-View Results 
 This Graphics Menu command opens the 3D View Window which display a 3D 
representation of the model being analyzed. This option allows to display graphically some results 
as explained below. 

4.10.1 Deformed Shape 
 The program will open the Deformed Shape Window which allows the user to select the 
load case to display. The user can also enter the magnification factor to be applied to the resulted 
deflections. 
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Figure 4.9  Example of Deformed Shape Option 

4.10.2 Contour Plot 
 The program will open the Contour Plot Window which allows the user to select the load 
case and the type of result to display. The user can also change the maximum and minimum values 
of the contour if desired. 
 

  

Figure 4.10  Example of Contour Plot Option 
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4.10.3 Pile Diagrams 
 The program will open the Pile Diagrams Window which allows the user to select the load 
case and the type of result to display. The user can also scale the values to display and select to 
display the maximum values. 
 

  

Figure 4.11  Example of Pile Diagrams Option 

 

4.10.4 Pile Lateral Results 
 The program will open the Pile Lateral Results Window which allows the user to select the 
node of the model to show the numerical results. The user can also select la load case desired to 
display the values. 
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Figure 4.12  Example of Pile Lateral Results Option 

 

4.11 Export Graphs to Excel 
 This Graphics menu allows the user to export the graphs to an excel file. After selecting 
this option, the Export to Excel Window will appear (similar to Figure 4.13, precise content will 
change based on the model parameters selected by the user). In this dialog box, select the graphs 
desired to export and then click on the Generate Excel File button. Please note that the user needs 
to save the excel file afterwards. 
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Figure 4.13  Sample Export to Excel Window 

 
 



 

 

CHAPTER 5. Tools Menu 
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 The Tools Menu is activated from the Main Menu bar of the program. The Tools Menu has 
six entries. The functions of these entries are discussed in the following sections of this chapter. 
 The Tools Menu has the six entries shown in Figure 5.1.  

 
Figure 5.1  Tools Menu 

5.1 Simple Calculator 
 The first entry of the Tools Menu provides a simple calculator for the user’s convenience. 
When active, the simple calculator appears as shown in Figure 5.2. 

 
Figure 5.2  Simple Calculator 

 The calculator has two display areas. A “tape” display is shown on top. The tape display 
shows the sequence of calculator operations. The answer display is shown below the tape display. 
 The buttons on the top of the calculator buttons have the following functions: 

CT Clears the content of the tape display, 
Back Deletes the last digit entered (a backspace key), 
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CE Clears the last full number entered into the calculator, and  
C Clears all the numbers entered into the calculator. 

 The function buttons on the right-hand side of the calculator have the following functions: 

Sqrt Computes the square root of the current number, 
% Divides the current number by 100 to express the number as a percentage, and  
1/x Computes the reciprocal of the current number. 

 The buttons on the left-hand side of the calculator control the memory functions. The 
memory functions are: 

MS Store a number to memory, 
M+ Add the current number to the number stored in memory, 
M– Subtract the current number from the number stored in memory, 
MC Clear (erase) the number stored in memory, and  
MR Recall the number stored in memory. 

Note that the MC and MR buttons are enabled only when a number is stored in memory. 

5.2 Battered Pile Load Calculator  
 The second entry of the Tools Menu provides a special-purpose calculator to compute axial 
and transverse forces acting on battered piles from horizontal and vertical loadings. 
 This calculator is intended only for use with conventional analyses in which lateral loading 
is applied perpendicular to the axis of the unbent pile and axial loads are applied along the axis of 
the pile. 
 This calculator obtains the batter angle of the pile from the input value for pile batter and 
the values of horizontal and vertical loading from the input fields of the calculator. 
 Values of transverse shear force and axial force for the specified batter angle are computed 
when the user presses the button to Compute and Chart Rotated Forces. The Chart that is generated 
shows how the rotated forces vary over batter angles ranging from –45 to +45 degrees. The 
symbols on the curves indicate the values for the specified batter angle. 
 The computation performed by the calculator is  
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Figure 5.3  Battered Load Calculator 

Where: 

 β is the batter angle in radians, 
 VH is the horizontal force, 
 PV is the vertical force, 
 VT is the shear force perpendicular to the pile axis, and 
 PA is the axial force along the pile axis. 

5.3 Custom Reinforcing Bar Data Entry and Editing 
 The third to fifth entries provide a means of entering addition sizes of reinforcing steel bar 
sizes to LPile. Note that this feature provides a means of entering hollow bars and steel access 
tubes. 
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Figure 5.4  Dialog for Editing of Custom Rebar Data 

 The third entry displays an input table to enter and edit the data for the custom reinforcing 
bar sizes. 
 The fourth entry will transfer the data for custom reinforcing bars into the memory of LPile 
and enter the names of the bars into the drop-down combination edit controls for selection of the 
size of reinforcing bars. Note that the custom bar sizes are at the bottom of the drop-down lists for 
bar sizes available for normally reinforced concrete sections. 
 The fifth entry saves the custom bar sizes to a data file named Custom_Rebar.dat. This data 
file is stored in the same program folder as the main LPile program. When LPile is started, LPile 
checks the program folder for a file with this name. If the file is found, it is read and the data is 
stored into program memory. Thus, it is not necessary for the user to re-enter the custom bar data 
each time the program is run.  
 Whenever the user wishes to exchange data files with another user, the data file for custom 
bar sizes should also be provided to the other user, as the full list of custom bar sizes is not included 
as part of the LPile data file. 

5.4 Multi-File Analysis (Batch Run Utility) 
 The sixth entry provides a feature to define a list of existing LPile data files to be run as a 
batch and the command to perform the batch analysis.  
 The control dialog for multi-file analysis is shown in Figure 5.5. The dialog is operated by 
adding a file to the list by pressing the Add File to List button. The Add File to List button will 
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open an input dialog in which either single or multiple files can be selected from any folder. The 
list of selected files is shown in the upper text pane of the control dialog. 

 
Figure 5.5  Dialog for Multi-File Analysis Controls 

 If needed, files can be deleted from the list by entering the file number and pressing the 
Delete File No. button. 
 The file list may be cleared by pressing the Clean the File List button. 
 Once the file list is complete, the user directs LPile to process the list of files by pressing 
the Run All Analyses button.  
 The processing time for each file and the warning or error message status of each file is 
shown in the lower text pane of the control dialog. This text pane displays the Run Messages  
 If desired the file list can be saved and re-opened by pressing the appropriate buttons. 
 Lastly, if the user wishes to save the Run Messages, he may do so by pressing the Save 
Run Msg File button. 
 
 



 

 

CHAPTER 6. Example Problems 
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The problems in this chapter are provided as examples of the types of applications that may be 
solved using LPile. Each example focuses on a particular computational feature of the program. 
The input files for the examples are automatically copied to a sub-folder named Lpile2022-
Examples under the common Ensoft folder on the root directory of the computer during 
installation. The data files are named with descriptive names and are copied to separate sub-folders. 
For example, the path to the directory for Example 1 is: 

C:\Ensoft\Lpile2022-Examples\Example 1 Elastic Steel Pile in Sloping Ground\ 
Example problems provide information on input and output of various cases, and present a quick 
tutorial for different applications. The user is encouraged to study these examples and, with 
modifications, may use them to solve similar problems. However, by no means can these limited 
examples explore the full functions and features provided by LPile. 
The main features of each example included with LPile are summarized as follows. 
Example 1 – Elastic steel pile in sloping ground. Among other aspects, this problem uses sample 
applications of the following program features: 

pile made of a standard structural steel shape, modeled as elastic pile with specified 
moment capacity, 
pile-head fixed against rotation, 
report of internally-generated p-y curves at different depths for verification purposes, 
application of several lateral loads, and 
sloping ground surface. 

Example 2 – Nonlinear bored pile in sloping ground. This example includes the following program 
features: 

pile is a drilled shaft, 
comparison of values obtained with pile head fixed and free against rotations, 
application of several lateral loads, 
analysis with nonlinear bending stiffness, and 
usage of sloping ground surface. 

Example 3 – Steel pile supporting an offshore platform. Includes the following program features: 
pile made of two different steel sections, 
pile with head elastically restrained against rotations, and 
cyclic loading. 

Example 4 – Buckling of a pile column. This example includes the following program features: 
steel pipe pile, 
pile head free to rotate, and 
application of several axial loads. 

Example 5 – Ultimate bending moment for bored piles. Includes the following program features: 
reinforced concrete pile of circular cross section, 
nonlinear materials, 
report of interaction diagram, and 
report of nonlinear flexural rigidity. 
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Example 6 – Foundation Stiffness of Concrete Pile with Nonlinear Flexural Rigidity. Includes the 
following program features: 

reinforced concrete pile of circular cross section, 
pile with head free to rotate, 
nonlinear materials, 
report of interaction diagram, 
report of nonlinear flexural rigidity, and 
generation of foundation stiffness components. 

Example 7 – User Input of Distributed Load and External p-y Curves. Includes the following 
program features: 

reinforced concrete pile of circular cross section with two different section properties, 
pile with head free to rotate, 
input of distributed lateral load on a section length of pile with linear variation, and 
input of externally-specified p-y curves. 

Example 8 – Case Study of Piles in Cemented Sands. Includes the following program features: 
reinforced concrete pile of circular cross section, 
pile with head free to rotate, 
input of several lateral loads, and 
use of internal p-y curves for silts. 

Example 9 – Sample of Various Program Options. Includes the following program features: 
drilled shaft with reinforced concrete cross-section and belled bottom, 
pile with head free to rotate, 
sample coordinates for embedded pile head, 
use of p-reduction factors assuming closely spaced piles, 
use of several soil layers, 
input of shear-resistance curve at pile tip, and 
determination of top deflections versus varying pile lengths. 

Example 10 – Drilled shaft in soft clay 
multi-section drilled shaft with under-ream and toe, and  
uniform rebar cage in upper sections. 

Example 11 – LRFD analysis 
input of unfactored loads 
input of load and resistance factor combinations 

Example 12 – Liquefied sand with lateral spread 
lateral spread modelled using lateral soil movement versus depth 

Example 13 – Top deflection versus pile length for square elastic pile 
example compares standard and modified versions of p-y curves for stiff clay without free 
water, and 
computation of curves of top deflection versus pile length for multiple levels of loading. 

Example 14 – Pushover analysis of prestressed concrete pile 
Example 15 – Pile with input nonlinear bending properties 
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Example 16 – Analysis of pile loaded by distributed lateral loads 
Example 17 – Analysis of double-section, rock socketed drilled shaft 
Example 18 – Analysis of drilled shaft with permanent casing 
Example 19 – Analysis of drilled shaft with permanent casing and core 
Example 20 – Design analysis of embedded pole 
Example 21 – Analysis of a tapered elastic pile 
Example 22 – Analysis of a tapered elastic-plastic pile 
Example 23 – Output of p-y curves at user specified depths  
Example 24 – Analysis of pile loaded by soil movements 
Example 25 – Verification of elastic pile in elastic subgrade 

Example 26 – Verification of the P-δ effect 
Example 27 – Analysis of Prestressed Concrete Pile 
Example 28 – Analysis of Lateral Spread 
Example 29 – Input from Load Test 
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6.1 Example 1 – Steel Pile in Sloping Ground 
 The general description and geometrical configuration of Example 1 is shown in Figure 
6.1. The pile is a standard structural steel shape (HP14×89), two layers of soil are present, and the 
ground surface is sloping downward with respect to the lateral loading. 
 In an actual design, the data shown in this example problem might be for a trial run. That 
is, the selection of the particular section for the pile and its length might change in the course of 
the computations. Furthermore, the soil profile has been idealized and in an actual case there would 
almost certainly be a need for consideration of the variation of the soil properties with depth and 
across the site. 
 The axial service load on the pile axis is 88.8 kN (20 kips). If the load factor (global factor 
of safety) is taken as 2.5, the axial load P to be used in the computations is 222 kN (50 kips). As 
it will be seen, the bending moment capacity is affected only slightly by the presence of the axial 
load. 
 The sketch of the pile in Figure 6.1 shows that its top is fixed against rotation. Thus, it is 
assumed that the top of the steel section projects a sufficient distance into the reinforced-concrete 
base of a pile cap so that no rotation of the top of the pile will occur. This assumption is not strictly 
true, but research is to be done to yield expressions for the rotation of an embedded steel member 
into a concrete mat. The assumption of pile-head fixity is conservative for forces, because the 
maximum bending moment will occur at the top of the pile and any rotation of the pile head will 
cause a decrease in the maximum moment. However, the pile-head fixity ay not be conservative 
for displacements so users would need to check the influence of different fixity. 
 The computations that follow are aimed at finding the lateral load V that will cause a plastic 
hinge to develop at the top of the pile. Secondly, the computations should reveal if there is a 
possibility of excessive deflection. 
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Figure 6.1  General Description of Example 1 

 The pile section type selected for the analysis is the Elastic Pile with Specified Moment 
Capacity. With this type of section, it is possible to have the pile behave elastically up to the 
specified moment capacity then form a plastic-hinge when the moment in the pile equals the 
specified moment capacity. 
 The strong axis of the H-pile is perpendicular to the direction of loading, and data for this 
axis were included in Figure 6.1. From the steel handbook, the width of the section is 373 mm 
(14.696 in.) and the depth is 352 mm (13.86 in.).  
 The first consideration is the “diameter” to assign to the shape because the 
recommendations for p-y curves are based strongly on the results of experiments with cylindrical 
shapes. At the outset, it can be assumed that the soil in the flanges will move with the pile and that 
it will behave as a rectangular shape. Secondly, the equivalent diameter of the pile can be 
computed, as a first approximation, by finding a circular section with the same area as the 
rectangular section. Thus,  
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As shown above, this computation yields a diameter that is less than 10 percent larger than the 
width of the steel section.  
 The equivalent diameter may be entered as the width of the pile, or, conservatively, the 
actual width of 373 mm (14.686 in.) may be entered. The decision of which value to be entered is 
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left to the user, but the actual width will be used in this example. The values used in this example 
are shown in Figure 6.2 below. 

 
Figure 6.2  Dimensions and Properties Entered for Example 1 

 The user should understand how the values entered for Pile Properties can be manipulated 
to enter the desired data to LPile. LPile is programmed to compute values of cross-sectional area 
and moment of inertia from the input dimension values when the user presses the button to 
Compute Moment of Inertia and Areas and Draw Section. In the case of H-piles, often the 
computed areas of area and moment of inertia differ from the standard values published for design. 
If the user wishes to replace the computed value, the user may enter the standard values directly, 
but must remember not to press the button to compute values. If the user presses the button to 
compute values, the manually entered values will be replaced by the computed values. 
 The yield moment for the section may be computed by a procedure proposed by Horne 
(1978). With no axial compression load and with bending about the strong axis, the plastic moment 
strength is computed the product of the yield stress and plastic modulus as follows:  
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 In other cases where the pile extends above the ground surface, the designing engineer will 
need to consider the compact section properties of the pile. In some H-pile sections, the pile flanges 
may buckle at stress levels below the yield stress of steel and the section is called “non-compact.” 
For this pile section, the compact section stress criterion is 131.7 MPa. To consider the compact 
section criterion one substitutes the compact section stress for the yield stress. 
 The loading in this model is a sustained static loading, not a cyclic load. In some cases, the 
designer is faced with the problem of estimating the consolidation and creep of the clay and/or the 
additional deflection due to vibration of the sand. The value of shear strength indicates that the 
clay is overconsolidated; thus, as a first approximation, no significant consolidation or creep is 
assumed. In addition, the sand, well below the ground surface, is assumed not to densify due to 
possible vibration. These assumptions will need to be carefully reviewed after a preliminary 
solution is obtained. 
 The above discussion shows that static loading is appropriate for both the clay and the sand. 
Further, the recommendations for stiff clay above the water table are considered most appropriate. 
The next step is to find the value of pile-head shear force, V, that will develop a bending moment 
in the pile of 657 kN-m (5,815 in.-kips). 
 The results of the preliminary computations using the displacement-slope pile-head 
condition are shown in Figure 6.3 and Figure 6.4. As may be seen, the computations show that the 
pile will fail structurally when the axial load is held at 222 kN (50 kips) and the lateral load reaches 
a value of 410 kN (92 kips). The pile-head deflection at the failure loading was computed to be 
about 27 mm (1.06 in.). This deflection is considered tolerable; therefore, the failure of the pile is 
taken to be due to the development of a plastic hinge. 
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Figure 6.3  Generated Curve of Lateral Load versus Maximum Moment for Example 1. 

 
Figure 6.4  Generated Curve of Lateral Load versus Top Deflection for Example 1. 

 The safe loading level is found by dividing the loading at failure by 2.5, the global factor 
of safety, or V = 164 kN (37 kips) and P = 88.8 kN (20 kips).  
 The output report contains a summary of the input data, along with the values of four 
computed p-y curves that the user specified for output. The bottom section of the output report 
contains a table of pile response with the principal information needed by the engineer, where 
computed values are given as a function of depth. The table indicates that the length of the pile 
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may be decreased to 10 m (33 ft) and that there will be three points of zero deflection, a sufficient 
number to ensure that the pile behaves as a long pile. By reducing the length of the pile, some 
unneeded output can be eliminated and, further, the amount of internal computations performed 
by the computer is reduced. 
 Plots of lateral deflection and bending moment as a function of depth are shown in Figure 
6.5 and Figure 6.6. The loadings for the second analysis were a V of 164 kN (37 kips) and P of 
88.8 kN (20 kips). The computed deflection at the top of the pile was to be 4.0 mm (0.16 in.) and 
the maximum bending moment was 186 kN-m (138.5 ft-kips), a value that is well below 657 kN-
m (485 ft-kips) that would cause the pile to fail. The next step is to find the value of Pt that will 
develop a bending moment in the pile of 657 kN-m (5,815 in.-kips). 

 
Figure 6.5  Curve of Deflection versus Depth for Example 1, Second Analysis 

 The curve shown in Figure 6.6 shows that the maximum bending moment occurs at the top 
of the pile, where it is fixed against rotation. If the pile head is permitted to rotate slightly, the 
negative moment at the pile head will decrease and the value of the maximum positive moment, 
now at a depth of 2.9 m (9.5 ft), will increase. Further, it is of interest to note that the bending 
moment is virtually zero at depths of 5 m (16.4 ft) and below.  
 The input data and output files have the filename Example 1a HP 14x89 in sloping 
ground.lp12d. These files are found in the Examples folder with the program. The output files are 
not shown in this User’s Manual due to their length. 
 The filename for the second run is named Example 1b HP 14x89 in sloping ground, second 
run.lp12d. The input and output files are not shown here due to their length. 
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Figure 6.6  Bending Moment versus Depth for Example 1, Second Analysis 
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6.2 Example 2 – Drilled Shaft in Sloping Ground 
 This example is similar to Example 1, but in this case, the pile is replaced by a drilled shaft 
(bored pile). The soil properties and ground slope angle are the same as those used in Example 1. 
The design issue with a reinforced-concrete pile is to find the nominal bending moment capacity 
and an appropriate value of flexural stiffness (EI) to use in the computations. 
 As in Example 1, an axial thrust load of 88.8 kN (20 kips) is assumed. The pile head is 
assumed fixed against rotation in the first loading case and free to rotate in the second loading 
case. The problem is to find the lateral load for each case that will cause the shaft to fail. Both of 
these loading cases might be used in a practical problem to establish the bounds for the solution if 
the rotational restraint caused by embedment of the top of the pile causes the pile head to be 
between fixed and free. 
 A drilled shaft with an outside diameter of 760 mm (30 in.) and a length of 15.2 m (50 ft) 
is used in this example. The reinforcing steel consists of 12 bars with outside diameter of 25 mm 
(corresponding to No. 8 bars in US practice) and spaced equally around a 610 mm (24 in.) diameter 
circle as shown in Figure 6.7. The ultimate strengths of the reinforcing steel and the concrete are 
414 MPa (60 ksi) and 27.6 MPa (4.0 ksi), respectively. 
 Example 2a is the computation and plotting of the unfactored interaction diagram. This 
problem is configured by selecting the Compute Nonlinear EI Only option in the Data > Options 
and Settings dialog and by entering the structural dimensions and material properties of the pile’s 
cross-section.  
 When computing an interaction diagram, the user must enter the axial thrust forces for the 
analysis (Data > Axial Thrust Loads for Interaction Diagram). This means that the user must 
determine the maximum compressive and tensile axial capacities along with a number of 
intermediate axial thrust values. Usually, a bored pile in soil will fail by axial bearing capacity 
before the pile section will fail by crushing, so the upper limit may be limited by the computed 
axial bearing capacity, if this value is available. Otherwise, the user may opt to make two analyses, 
the first with zero axial thrust and the second with a number of axial thrust loads. After the first 
run, the user may read the estimated axial capacities of the pile section in compression and tension 
from the output text report and use these values to set the upper and lower values of axial thrust 
for the second analysis. 

 
Figure 6.7  Cross-section of Drilled Shaft for Example 2. 
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 An excerpt from the output report for Example 2a for the axial structural capacities is 
shown below: 

Axial Structural Capacities: 
---------------------------- 
 
Nom. Axial Structural Capacity = 0.85 Fc Ac + Fy As    =    13031.123 kN 
Tensile Load for Cracking of Concrete                  =    -1424.929 kN 
Nominal Axial Tensile Capacity                         =    -2532.072 kN 

 
 Using these values, axial thrust values were entered ranging from -2,500 to 13,000 kN. The 
resulting factored interaction diagram generated by the Presentation Graphics feature is shown in 
Figure 6.8. 
 The curves for moment versus curvature for multiple axial thrust forces are shown in Figure 
6.9 and the curves for EI versus bending moment are shown in Figure 6.10. 
 Computations of nominal bending moment capacities are determined when the concrete 
compressive strain at failure equals 0.003. For the axial load of 88.8 kN, the nominal bending 
moment capacity, Mnom, was taken from the curve as 731.8 kN-m. For design, a resistance factor 
for moment capacity equal to 0.65 was assumed, which gives a factored (ultimate) moment 
capacity of 475.7 kN-m.  
 The computations for nominal moment capacity could have been done for only the one 
axial load level, however, the full interaction diagram was developed to demonstrate the influence 
of axial load for this particular problem. As seen in Figure 6.8, an increase in the axial load up to 
a point will increase the value of the moment capacity so the axial thrust load was not multiplied 
by the global factor of safety to get the moment capacity.  
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Figure 6.8  Factored Interaction Diagram for Example 2a. 

 
Figure 6.9  Moment-Curvature Diagram for Example 2a. 
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Figure 6.10  Bending Stiffness versus Bending Moment for Example 2a. 

 In earlier versions of LPile, the user had to select a constant value of bending stiffness to 
use in an analysis. This is no longer needed, as LPile will automatically vary the value of bending 
stiffness in proportion to the bending curvature developed in the pile. 
 The load-deflection curves and moment versus shear force curves for free-head conditions 
are shown in Figure 6.11 and for fixed-head conditions are shown in Figure 6.12. The scales of the 
two figures have been set equal to aid comparing the two sets of graphs.  
 The free-head shaft reaches its nominal moment capacity at a shear load of approximately 
530 kN and its factored moment capacity at a shear load of 346 kN at a deflection of 0.035 m. The 
fixed-head shaft reaches it nominal moment capacity at a shear load of 550 kN and its factored 
moment capacity at a shear load of 352 kN at a deflection of 0.0076 m. By happenstance, the load-
carrying capacity of the two pile-head conditions are nearly equal. However, the load-deflection 
response of the fixed-head shaft is substantially stiffer. 
 To illustrate the differences in deflection and bending moment versus depth for the two 
pile-head fixity conditions, a fourth analysis was performed for pile-head shear loads equal to 346 
for the free-head shaft and 352 kN for the fixed-head shaft. The results of this analysis are shown 
in Figure 6.13.  
 The length of the pile may be reduced if there are more than two points of zero deflection, 
which ensures that the pile acts as a stable pile. LPile can perform a series of analyses with different 
lengths of piles, so the user can compare pile length versus deflection at the pile head. The curves 
of Graphics > Top Deflection vs Pile Length for free and fixed-head conditions is shown in Figure 
6.14.  
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Figure 6.11  Shear Force versus Top Deflection and Maximum Bending Moment versus Top 

Shear Load for Free-head Conditions in Example 2b. 

  
Figure 6.12  Shear Force versus Top Deflection and Maximum Bending Moment versus Top 

Shear Load for Fixed-head Conditions in Example 2c. 
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Figure 6.13  Results for Free-head and Fixed-head Loading Conditions for Example 2d 

 
Figure 6.14  Top Deflection versus Pile Length for Example 2d 

 Perhaps it is of interest to note that the lateral loads that were computed for the steel pile 
and for the bored pile were of significant magnitude, indicating that different types of piles can be 
used economically to sustain lateral loads. 
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6.3 Example 3 – Offshore Pipe Pile 
 The illustration in Figure 6.15 shows an offshore platform of the type used in water depths 
of 100 m or more. Thousands of such structures have been built where a structure is fabricated on 
shore, barged or floated to the site, and placed by lifting or controlled submergence. For the case 
indicated, the weight of the jacket causes the extensions of the legs to push into the soil. With the 
top of the template above still water, piles are stabbed and driven through the main legs. The tops 
of the piles are trimmed, and welded to the jacket, and the annular space between the outside of 
the piles and the inside of the jacket leg is filled with grout. Finally, a deck section is lifted and its 
support columns are stabbed into the tops of the main legs and then welded. 

 
Figure 6.15  Idealized View of an Offshore Platform Subjected to Wave Loading, Example 3 

 The soil profile at the site is not shown in the sketch. In this example, it is soft clay with 
some overconsolidation due to wave action at the mudline, but with an increase in strength with 
depth as for normal consolidation. An assumption is made that some scour will occur around the 
piles to a depth of 1.5 meters (5 feet). The undrained strength of the clay at that depth is 24 kPa 
(500 psf) and the strength at 30 m is 72 kPa (1,500 psf). The submerged unit weight is 9.00 kN/m3 
(57 pcf); ε50 is 0.02 at 1.5 m (5.0 ft) and decreases to 0.01 at 30 meters (98 feet).  
 The sketches of Figure 6.16 show one of the piles from the structure with the rotational 
restraint given approximately by an equation. The number 3.5 indicates that the bracing has been 
discounted and that the member is acting as one whose far end is intermediate between fixed and 
free. The approximation is adequate for a preliminary solution but, for the final analysis, the 
superstructure and the piles should be considered as continuous, and the piles analyzed as a group. 
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Figure 6.16  Superstructure and Pile Details, Example 3 

 The critical loading occurs during a severe storm, and Figure 6.15 shows the approximate 
position of a wave as it moves past the structure. The selection of a particular wave height and 
velocity of the wind is a problem in statistics, and the factor of safety to be employed is related to 
those selections. For this problem, it is assumed that a load factor of 2.4 is appropriate. The axial 
loading of the pile that is analyzed is 1,250 kN (281 kips); thus, the load in the design computations 
is 3,000 kN (674 kips). A solution consists of finding the lateral loading that will cause a plastic 
hinge to develop in the pile, and the safe load by dividing that load by the global factor of safety. 
 The sketch in Figure 6.16 shows that the pile to a distance of 4.0 m (13.1 ft) from its top 
consists of two pipes that are acting together. The outside diameter of this combined section is 838 
mm (33 in.), the wall thickness is 28.14 mm (1.11 in.), and its moment of inertia is 5.876×10-3 m4 
(4,117 in4). The lower section has an outside diameter of 762 mm (30 in.), a wall thickness of 
19.05 mm (0.75 in.), and a moment of inertia of 3.070×10-3 m4 (7,376 in4). The ultimate strength 
of the steel for the piles is assumed is 0.395 MPa (57,290 psi). 
 Figure 6.17 shows the results of computations for the moment versus curvature analysis of 
the sections of the pile in the example. As shown in the Technical Manual, the stress-strain curve 
for the steel is assumed as bilinear; thus, the ultimate bending moment will continue to increase 
slightly as the full section of the pile approaches the plastic range. It was decided to accept the 
value of Mnom as the value where the maximum curvature is 0.015 radians/meter. For the upper 
section, a nominal moment capacity of 7,140 kN-m was computed. The corresponding value for 
the lower section of the pile was 4,040 kN-m. 
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Figure 6.17  Moment versus Curvature, Example 3 

 The soil conditions at the site are in the range of soft clay below the water, and the 
recommendations for that soil are employed in the computations. Cyclic loading is employed 
because the design is to reflect the response of the structure to a storm. 
 Some comment is needed about the number of cycles of loading. If the documentation is 
reviewed for the experiments that resulted in the development of the recommendations, it will be 
noticed that the cycles of loading were continued until an apparent equilibrium was reached; thus, 
the criteria reflect the limiting condition (or worst condition). However, during a particular storm, 
there may be only a small number of loads of the largest magnitude during the peak of the storm. 
Therefore, the recommendations may be somewhat more conservative than necessary, but at the 
present, recommendations are unavailable to allow the introduction of the number of cycles into 
the procedure. 
 In reference to the previously shown Figure 6.16, initial computations were necessary to 
learn if the lateral loading on the selected pile would cause a critical moment in the upper or lower 
section. A series of computer runs and plots were made of the maximum moment as a function of 
Vtop for both the upper and lower sections. Figure 6.18 shows that the maximum moment for the 
upper section, 7,140 kN-m and negative in sign, occurred with a lateral load of 1,200 kN. At that 
value of Vtop, the maximum moment for the lower section was about 2,500 kN-m, which was far 
less than the yield value of 4,040 kN-m. Thus, the upper section of the pile controls the loading. 
 The deflection of the top of the pile, ytop, for the failure loading of 1,200 kN was computed 
to be 339 mm and, in some designs, the deflection might have controlled the loading. However, 
the computed deflection will be much less when the factored load is used; furthermore, excessive 
deflection is rarely a problem in the design of an offshore platform. It is true that personnel could 
experience distress on a deck that was moving radically; however, in normal circumstances, the 
personnel are removed from the platform during the occurrence of the design storm. 
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Figure 6.18  Results of Initial Computation with p-y Curves, Example 3 

 Employing a load factor of 2.4 (global factor of safety), the service value of pile-head shear 
force Vtop is 500 kN and, as noted before, the axial thrust force Q is 1,250 kN. The resulting moment 
diagram is shown in Figure 6.19. The computed value of pile-head deflection ytop, not plotted here, 
was 62 mm, which is acceptable.  
 An examination of Figure 6.19 finds that the moment diagram is virtually zero below a 
depth of 21 m; therefore, the selection of the thickness of the wall of the pile below this depth will 
be based on the requirements of pile driving analysis and axial pile capacity, rather than lateral 
loading. Additionally, it is evident that the maximum bending moment could be reduced 
significantly if the designer has some control over the value of the rotational restraint at the 
mudline. Thus, the opportunity exists for minimizing the cost of the foundation by a judicious 
selection of the manner in which the piles are connected to the superstructure. For example, a less 
expensive solution could have been achieved if shims had been used at the bottom of jacket-leg 
extension and at the joints, with the result that no grouting would have been needed. Finally, the 
thick-walled section of the pile, whatever the final design, will be needed in the upper 21 m; 
therefore, the methods of installation must be such that the pile can be installed to the required 
penetration into the soil profile.  
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Figure 6.19  Pile Deflection and Bending Moment versus Depth for Vtop = 500 kN, Example 3 
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6.4 Example 4 – Buckling of a Pile-Column  
 One analytical feature of LPile is an automatic analysis for buckling capacity of a pile. It 
is not often that such a problem is encountered in practice, but a rational solution is desired if such 
a problem occurs. 
 In this example, the lateral load at the pile head is 44.5 kN (10 kips) and the loading was 
static. The lateral load and the axial load are applied at the top of the pile, which was 2.5 m (8.3 
ft) above the groundline. The bending moment at the pile head is zero. 
 The solution to the problem seeks the same answer as does the Euler solution for a column, 
but, because the response of the soil is nonlinear, an Eigen value solution is not applicable. Rather, 
the answer is obtained by successive solutions of the nonlinear, beam-column equation with the 
axial load being increased until excessive lateral deflection is computed or the bending moment 
capacity of the pile is fully mobilized. 
 The example pile is an elastic steel pipe, 610 mm (24 in.) in outside diameter, and with a 
wall thickness of 22.2 millimeters (0.875 inch). The EI is 354,312 kN-m2 (1.235×1011 lb-in2). The 
length is 15.2 meters (50 feet). Had the portion of the pile above the groundline been greater than 
2.54 m (8.33 ft), the buckling load that was found would have been much less than the computed 
value. 
 The soil profile is sand with an angle of internal friction of 35 degrees. The water table is 
below the tip of the pile. The effective unit weight of the sand is 19 kN/m3 (121 pcf). 
 The p-y curves for static loading of sand above the water table are appropriate for the 
problem. Presumably, the soil properties are those that exist after the pile has been installed. 
 The results from the pile buckling analysis are shown in Figure 6.20. Note that this figure 
was drawn for this manual and was not generated by LPile, The deflection at the top of the pile, as 
a function of the axial thrust force is shown as the black line and the maximum bending moment 
as the blue line. The estimated buckling capacity is shown by the red line (19,592 kN). 
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Figure 6.20  Pile-head Deflection and Maximum Bending Moment versus Axial Thrust Loading 

 LPile estimates the pile buckling capacity by fitting a hyperbolic curve to the computed 
results of top deflection versus axial thrust force. The procedure used to fit the hyperbolic curve is 
discussed in Section 0. A graph of the pile buckling analysis results generated by LPile for 
Example 4 is shown in Figure 6.21. 
 While the solution to the problem appears to be rather straightforward using LPile, there 
presently are no other analytical solutions for pile buckling available to take the nonlinear load 
transfer from the pile to the soil into account. It is also important to note that the pile buckling 
analysis feature of LPile can also be used to investigate the effects of the eccentric application of 
axial loading and the effect of accidental batter.  
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Figure 6.21  Results from LPile Solution for Buckling Analysis, Example 4 
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6.5 Example 5 – Computation of Nominal Moment Capacity and 
Interaction Diagram 

 Example 5 is presented to illustrate a feature of LPile for computation of the nominal 
bending moment capacity and to display an interaction diagram. A total of 17 axial loads were 
specified for the program to compute the ultimate bending moment at each axial load and to 
construct the interaction diagram (ultimate bending moment versus axial load).  
 The ultimate bending moment of a reinforces-concrete section is taken at a maximum 
compressive strain in concrete of 0.003 based on the ACI 318 code. It should be noted that the 
bending stiffness (EI), corresponding to the ultimate bending moment, is significantly lower than 
that of the uncracked EI value. Therefore, the user should also pay attention to the variation of EI 
versus moment for nonlinear piles. In general, the moment distribution in the pile is not affected 
much by the EI used in the computation. However, if the deflection is more critical for the design, 
then analysis using nonlinear values of EI should be done. 
 Curves showing the development of moment versus curvature for various axial thrust 
values are shown in Figure 6.22. The curves showing the greatest amount of ductility are the curves 
with tensile axial thrust loadings. In general, the amount of ductility decreases as the axial thrust 
level increases. 

 
Figure 6.22  Moment versus Curvature for Example 5 

 Curves of bending stiffness versus bending moment are shown in Figure 6.23. In general, 
three ranges of EI magnitude can be found in the output. The first range of EI magnitude is 
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associated with the uncracked stage. The concrete is uncracked and the EI is more-or-less constant 
and is equal to the calculated EI for the gross section. The second range of EI magnitude is for the 
cracked stage. A significant decrease in the EI value takes place as cracks continue propagating. 
The third range of EI magnitude is for the cracked and large strain stage. The EI value is further 
reduced because the concrete stress-strain curve (shown in the Technical Manual) is softened at 
large strains. 
 The curves for tensile axial thrust show a behavior that is not found for compressive axial 
thrusts. For these curves (see the blue and black curves in the lower left corner of the graph), the 
bending stiffness rises at higher levels of bending moment. The reason for this is the cracking and 
tensile thrust decreases the size of the compression zone in the cross-section. This causes a larger 
fraction of the moment to be carried by the reinforcing steel. Since the steel has a higher modulus 
than that for the concrete, the bending stiffness is seen to increase at higher levels of moment. 
 The resulting interaction diagram for the reinforced concrete section is shown in Figure 
6.24. Note that this graph was produced using the presentation graph utility in order to show the 
factored curves. 

 
Figure 6.23  Bending Stiffness versus Bending Moment, Example 5 
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Figure 6.24  Factored Interaction Diagram of Reinforced-concrete Pile, Example 5 
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6.6 Example 6 – Pile-head Stiffness Matrix 
 This example is presented to illustrate the capability of LPile to perform analyses that can 
yield results of direct benefit to the designer of a reinforced-concrete pile. The pile is 30-inches in 
diameter and 25-ft in length. The pile is embedded in dense sand with an angle of internal friction 
of 38 degrees. The program will compute the nonlinear moment-curvature behavior and bending 
moment capacity as the first step. Loading and preliminary data on piles are selected, and the 
program yields values of pile deflection, moment, shear, and soil resistance as the second step. The 
third step in the analysis is to compute the optional special analyses, such as pile-head stiffness, 
pushover analysis, or pile buckling analysis. 
 The user can compute the ratio of the bending moment capacity computed in the first step 
to the maximum bending moment computed in the second step to compare to an allowable factor 
of safety. The properties of the pile can then be changed, if necessary, and further computations 
made to achieve the final selection of the properties of the pile. 
 The nonlinear EI values computed for a given pile may have a significant effect on the 
resulting deflections of the modeled pile. The relationship between bending moment, curvature in 
the pile, and EI is computed during the first part of the analysis.  
 In many computer programs used for superstructure analyses, the user is allowed to input 
spring stiffnesses in the form of a stiffness matrix to represent foundations under column bases. 
To demonstrate another useful tool of LPile, this example problem includes a check mark on the 
option to generate the foundation stiffness matrix. Since the program only deals with lateral 
loading, only four components of a 6×6 stiffness matrix are generated. Values for the axial spring 
stiffness and torsional pile response should be generated using other tools.  
 In general, values are nonlinear in nature and only valid for a certain range of loading. 
Iterations might be necessary to achieve convergence between superstructure and pile analyses. 
Output curves obtained from this example problem for stiffness matrix components are shown 
versus displacements in Figure 6.25 and versus forces in Figure 6.26. 



CHAPTER 6 – Example Problem 6 – 6-30 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

 
Figure 6.25  Stiffness Matrix Components versus Displacement and Rotation, Example 6 

 
Figure 6.26  Stiffness Matrix Components versus Force and Moment, Example 6 
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6.7 Example 7 – Pile with User-Input p-y Curves and Distributed Load 
 This example is included to illustrate a common case in which a 16-in. (406 mm)-diameter 
pipe pile is subjected to both, concentrated loads at the pile head and distributed loads along the 
pile. The head of the pile will be assumed unrestrained against rotations (free-head case) with no 
applied moment. A lateral load of 5,000 lbs (22 kN) will be applied at the pile head. The non-
uniform distributed loads are 20 lbs/in (3.5kN/m) at the depth of 2 ft (0.6 m) and linearly increase 
to 100 lbs/in. (17.5 kN/m) at the depth of 5 feet (1.5 meters). Figure 6.27 shows a general view of 
the pile and soil. The distributed load in this case occurs over a pile length of 3 feet (0.9 meters), 
and an increment length of 0.25 feet (0.075 meters); therefore, the distributed lateral load can be 
properly reflected by the 12 increments of length of the pile. 
 To demonstrate another feature of LPile, the p-y curves shown in Figure 6.28 will be 
entered for this problem. The program interpolates linearly between points on a p-y curve and 
between depths of p-y curves.  

 
Figure 6.27  Pile and soil details for Example 7 
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Figure 6.28  User-input p-y Curves for Example 7 (Lower curve for Layer 7 not shown) 
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6.8 Example 8 – Pile in Cemented Sand 
 A field test for behavior of laterally loaded, bored piles in cemented sands (c-φ soil) was 
conducted in Kuwait (Ismael, 1990). Twelve bored piles that were 0.3-m in diameter were tested. 
Piles 1 to 4 were 3-m long, while piles 5 to 12 were 5-m long. The study was on the behavior of 
both single piles and piles in a group. The measured load versus deflection curves at the pile head 
for a 3-m long single pile and a 5-m long single pile are presented in the paper and can be studied 
by using the soil criteria for c-φ soils. 
 The piles were reinforced with a 0.25-m diameter cage made of four 22-mm bars for the 3 
m-long piles and six 22-mm bars for the 5 m-long piles. In addition, a 36-mm reinforcing bar was 
positioned at the center of each pile. 
 The flexural rigidity EI varies with the applied moment but a constant value was reported. 
After lateral-load tests were completed, the soil to a depth of 2 m was excavated to expose the 
level of the strain gauges for a calibration test. The pile was reloaded and the curvature was 
calculated from the measurements of strain. The moment in the pile at the strain gauges was 
determined from statics and the moment versus curvature relationship was determined. The 
reported flexural rigidity was calculated from the initial slope of the moment-curvature curves as 
20.2 MN-m2, which seems to be on the upper extreme of the normal range for a bored pile with 
the reported concrete and reinforcing properties. 
 The subsurface profile at the test site consisted of two layers as shown in Figure 6.29. The 
upper layer, described as medium dense cemented silty sand, was about 3 m in thickness. The 
values of c and φ for this layer were found by drained triaxial compression tests and were 20 kPa 
and 35 degrees respectively. The upper layer was underlain by medium dense to very dense silty 
sand with cemented lumps. The values of c and φ were zero kPa and 43 degrees, respectively. 

 
Figure 6.29  Soil details for Example 8 
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pile-head load versus deflection and is shown in Figure 6.30. A comparison between measured 
and predicted behavior for bending moment versus depth for a shear force of 50 kN is shown in 
Figure 6.31. 

 
Figure 6.30  Comparison between Measured and Predicted Pile-head Load versus Deflection 
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Figure 6.31  Comparison between Measured and Computed Bending Moment versus Depth 
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6.9 Example 9 – Drilled Shaft with Tip Resistance 
 This example application has been prepared for an idealized drilled shaft whose head is 
embedded 1 foot in soil. The general pile geometry and soil profile is shown in Figure 6.32. 
 The soil stratigraphy is composed of three different layers of sand, soft clay, and stiff clay. 
The soil properties are also shown in Figure 6.32. In addition, there is a water-bearing sand layer 
at a depth of 60 feet not shown in the figure. 

 
Figure 6.32  Shaft Geometry and Soil Properties for Example 9 

 The construction procedure for the shaft is to set a temporary surface casing through the 
upper sand layer and to seal the casing in the soft clay layer. Drilling through the soft clay layer 
into the stiff clay layer is accomplished in the dry. The use of the enlarged base was selected to 
avoid tipping the shaft in the underlying water-bearing sand layer. Had a straight-sided shaft been 
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used, the overall shaft length would have been 30 feet longer and drilling with slurry would have 
been required. In this case, the use of a shorter shaft with an enlarged base would result in faster 
and more economical construction. The final shaft dimensions consists of four sections, which are 
a 6-ft long straight section of 42-in. diameter, 19-ft long straight section of 3-ft (0.91-m) diameter, 
a 4-ft (1.22-m) long section with a 11-ft (3.35-m) diameter enlarged base at the bottom with a 0.5-
ft toe section. 
 The loads shown acting at the top of the pile are primarily axial and the axial bearing 
capacity and settlement must be checked to withstand the axial load using a separate analysis. The 
analysis using LPile is performed to check the lateral performance and to design the shaft 
reinforcement. 
 The reinforcement in the shaft was sized so that one reinforcement cage could be placed 
over the full length of the shaft. The reinforcement chosen was 14 No. 9 bars, sized with a diameter 
that had a 6-inch cover in the upper 42-inch section and a 3-inch cover in the 36 inch section. This 
amount of reinforcement provided 1.01% reinforcement in the 42-inch section and 1.38% 
reinforcement in the 36-inch section.  
 The enlarged base sections were modeled as elastic sections, with the specified dimensions 
and an elastic modulus of 3,500,000 psi. 
 A first run of the problem showed that the shaft acted mainly as a short pile with lateral 
movements observed at the bottom of the shaft. The design engineer then decided to account for 
the additional amount of soil resistance provided by the large shear forces developed at the 
enlarged base of the shaft. This was accomplished by checking the option in the Program Options 
and Settings dialog to include shear resistance at pile tip. Inclusion of tip shear resistance had little 
effect on the top deflection, reducing the top deflection from 0.994 inches without tip shear to 
0.909 inches with tip shear.  
 The computer-generated p-y curves were adjusted to account for closely spaced piles by 
utilizing p-reduction factors that varied with depth from 0.75 for the straight shaft down to 0.3 at 
the bottom of the enlarged base. 
 Curves of moment versus curvature for Sections 1 (42-inch) and 2 (36-inch) are shown in 
Figure 6.33. The factored moment capacities for these two sections for a resistance factor of 0.65 
are 14,000 and 11,600 in-kips respectively  
 The curves of lateral deflection and bending moment versus depth are shown in Figure 
6.34. 
 In addition, the program was asked to generate a plot of pile length versus pile-top 
deflections in order to optimize the design length. The resulting plot included in Figure 6.35 shows 
that the pile length should not be further reduced in order to have an appreciable factor of safety 
from the critical length nor could the length of shaft be increased without the base of the shaft 
coming too close to the water-bearing sand layer below. 
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Figure 6.33  Moment versus Curvature for Sections 1 and 2, Example 9 

 
Figure 6.34  Lateral Deflection and Bending Moment versus Depth, Example 9 
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Figure 6.35  Top Deflection versus Pile Length, Example 9 
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6.10 Example 10 – Drilled Shaft in Soft Clay 
 This drilled shaft in this example is a 24-inch diameter drilled shaft with eight US#7 
reinforcing bars. Often designers elect to use fewer than eight bars in small diameter drilled shafts. 
In general, using fewer than eight bars is not recommended because when fewer than eight bars 
are used there is a direction of loading effect on the moment capacity of the drilled shaft. When 
the number of bars is eight or more, the effect of the direction of loading is largely eliminated. 
 The summary plots of this analysis are shown in Figure 6.36. This analysis was made using 
the displacement-moment pile-head loading condition. By examining these graphs, user can see 
that the pile in not overloaded at the maximum deflection of 1.25 inches and that the moment 
developed in the shaft is sufficiently large for the cracked-section bending stiffness to be in effect 
for almost one half of the shaft length. Also, shown are the p-y curves for static loading at specified 
depths for output by the program. 

 
Figure 6.36  Summary Plots of Results for Example 10 
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6.11 Example 11 – LRFD Analysis  
 This example is provided as a demonstration of the LRFD analysis features of LPile. The 
LRFD features of LPile are discussed in Section 3.18. 
 The computational procedures for making an analysis in LRFD mode are the same as for 
conventional analysis, except for how the unfactored loads and the load and resistance factor 
combinations are entered. The entry of data for pile structural properties and for soil layering and 
properties is the same as for conventional analysis. 
 The user switches to LRFD mode by marking the check box for LRFD Analysis Mode in 
the Computational Options group of the Program Options and Settings dialog.  
 The user should be aware that it is possible to store the load and resistance factor 
combinations in a separate data file that can be re-used in subsequent analyses. The feature for 
reading of the load and resistance factor combinations is activated through the Program Options 
and Settings dialog. The saving of the load and resistance factor combinations is activated by the 
command on the File Menu. Please note that the File Menu command to save the load and 
resistance factor combinations is visible only when LPile is operating in LRFD Analysis Mode. 
 All load conditions must be horizontal shear, vertical load, and moment in the LRFD mode 
combined with distributed lateral loading. The pile-head loads will be converted to their axial and 
transverse components for battered piles. 
 One of the features of LPile is the capability to compute the factored load combinations. 
Once all unfactored loads are entered, LPile will sum all unfactored loads of the same type, 
including distributed loads, and compute the factored load combination. The factored load 
combinations can be reviewed prior to analysis by pressing the Display Summary of LRFD 
Loadings (the Σ button on the button bar). An excerpt from an example of a summary report is 
shown in Figure 6.37. 
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Figure 6.37  Example from Summary Report of LRFD Loadings, Example 11 

 After running the LRFD analysis, an information message will be displayed to alert the 
user whether or not all load case combinations have been met. The message for a successful 
analysis is displayed as Figure 6.38. 

 
Figure 6.38  Message for Successful LRFD Analysis for Example 11 

 The LRFD analysis of LPile is currently limited to checking mobilized bending moment 
values in every pile section against the factored moment capacity of the section and mobilized 
shear force against input values of structural shear capacity. Checks for displacements and pile-
head rotations (i.e. serviceability checks) depend on the purpose of the foundation and are left to 
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the user. Internally computed values of structural shear capacity of the pile are not computed by 
LPile because standardized methods for computing shear capacity of all section types are between 
the design standards being followed. However, the user may enter an input value for structural 
shear capacity and LPile will check the mobilized shear force in the pile against the input value. If 
the input structural shear capacity is left equal to zero, the checks for shear capacity will be 
skipped. 
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6.12 Example 12 – Pile in Liquefied Sand with Lateral Spread 
 This example is provided as an example of seismic lateral spread loading of a pile. In this 
example, the pile-head is loaded only by axial load and all lateral loading on the pile is due to 
seismic lateral spread. 
 The pile is a 15.2 m-long pipe pile with a diameter of 373 mm and a wall thickness of 10 
mm. The soil profile has liquefied sand in the upper 5 meters and a lateral spread profile with a 
maximum movement of 300 mm that is greatest at the ground surface and decreases down to zero 
at a depth of 5 meters. The pile and soil profile is shown in Figure 6.39 and the lateral spread 
profile versus depth is shown in Figure 6.40. 

 
Figure 6.39  Pile and Soil Profile for Example 12 
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Figure 6.40  Lateral Spread Profile versus Depth for Example 12 

 The summary graphs of the analysis are shown in Figure 6.41. The graph of moment versus 
curvature indicates that the plastic moment capacity of the pile is 320 kN-m and the maximum 
moment developed in the pile is about 165 kN-m, so the pile remains elastic. The graph of lateral 
spread and pile deflection versus depth shows that the soil flows around the upper portion of the 
pile. The lateral deflection of the pile head is about 50 mm and the maximum lateral spread 
displacement is 300 mm, about six times higher. 
 The performance of the pile would have been significantly worse is a non-liquefied layer 
were present at the ground surface. In such a case, the non-liquefied layer would move on top of 
the liquefied layer, thereby creating a large displacement relative to the position of the pile. The 
lateral loading on the pile would depend on the load-transfer properties of the non-liquefied layer, 
but failure of the pile by formation of a plastic hinge would be probable. 
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Figure 6.41  Summary Graphs for Example 12 
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6.13 Example 13 – Square Elastic Pile with Top Deflection versus 
Length 

 This example is to demonstrate the feature to compute pile top deflection versus pile length 
and the use of the modified stiff clay without water p-y curve. The pile is modeled as a 25-foot 
long, 14-inch square elastic pile with a Young’s modulus of 3,500,000 psi.  
 The pile-head loads are shear forces of 5,000, 10,000, 20,000, 30,000, and 40,000 lbs, zero 
moment, and an axial thrust load of 150,000 lbs. The option to compute pile top deflection versus 
pile length is turned on in the Pile-head Loadings and Options dialog. 
 The properties of the modified stiff clay without free water are an effective unit weight of 
108 pcf, undrained shear strength of 2,000 psf, k of 500 pci, and ε50 of 0.005. 
 The primary use of the modified stiff clay without free water is to generate a p-y curve with 
a softened initial slope. In some areas, load testing has found that the original p-y curve 
computations result in p-y curves that have initial slopes that are too stiff. As an example, pile-
head load versus deflection curves were computed using both the original and modified p-y curve 
formulations. Theses curves along with the percentage of reduction in stiffness are graphed in 
Figure 6.42. 

 
Figure 6.42  Pile-head Load versus Deflection Curves Using Original and Modified p-y Curves 

for Stiff Clay without Free Water and Percentage Reduction in Stiffness for Example 13 

 The curves of pile top deflection versus pile length are shown in Figure 6.43.  

0%

10%

20%

30%

40%

50%

60%

70%

80%

90%

100%

0

5000

10000

15000

20000

25000

30000

35000

40000

45000

50000

0 0.2 0.4 0.6 0.8 1 1.2

%
 R

ed
uc

tio
n 

in
 S

tif
fn

es
s

La
te

ra
l L

oa
d 

 (l
bs

)

Pile Head Deflection (in)

Original
Modified
% Reduction



CHAPTER 6 – Example Problem 13 – 6-47 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

 
Figure 6.43  Curves of Pile Top Deflection versus Pile Length for Example 13 

 It should be noted that the length of pile needed to reach the “long pile” behavior (i.e. when 
the curve becomes horizontal) is depended on the level of loading being consider. Thus, it is 
important to specify the generation of the pile top deflection versus pile length curve for the 
maximum loading being considered. It should also be noted that if the pile top deflection is too 
large for the “long pile” portion of the curve, the deflection can be lowered only by re-configuring 
the foundation to use either larger diameter piles or more piles.  
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6.14 Example 14 – Pushover Analysis of Prestressed Concrete Pile 
 This example is provided as an example of a pushover analysis of a prestressed concrete 
pile. The pile is a 25-foot long, 14-inch wide, prestressed concrete pile with 1-inch chamfered 
corners. The reinforcement details for the pile are shown in Figure 6.44. 

 
Figure 6.44  Reinforcement Details for Prestressed Concrete Pile of Example 14 

 It should be noted that the value for Fraction of Loss of Prestressed must be obtained from 
the pile manufacturer and that this number can vary from supplier to supplier because the 
procedures and materials used for the pile vary. The magnitude of prestressed after losses typically 
varies from 600 to 1,200 psi in the United States, with pile driven in softer soils typically having 
higher prestress values to permit higher resistance to tensile stresses during pile driving. The use 
of higher levels of prestress also permits lifting of longer piles without damage. 
 This example uses the Pushover Analysis option available in the Program Options and 
Settings dialog. One useful feature of the pushover analysis is to determine the lateral deflection 
and load required to fail a pile under lateral loading. 
 As will all LPile analyses for piles with nonlinear bending properties, LPile computes the 
curve of nonlinear bending versus curvature. The curve generated for Example 14 is shown in 
Figure 6.45 for the two values of axial thrust specified in the Pile-head Loading and Options dialog. 
The curve shown here indicates that the plastic moment capacity for the pile is approximately 
2,100 in-kips. 
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Figure 6.45  Moment versus Curvature of Prestressed Pile for Example 14 

 The results of the pushover analysis are shown in the two graphs of Figure 6.46. These 
graphs shown the results for both fixed-head and pinned-head loading conditions for lateral 
displacements up to 5 inches. For fixed-head conditions, the plastic moment capacity is mobilized 
at a pile top deflection of 0.625 inches and a shear load of 60,900 lbs. For free-head conditions, 
the plastic moment capacity is mobilized at a pile top deflection of 2.5 inches and a shear load of 
52,400 lbs. Other information gained from these graphs is maximum lateral capacity is 
approximately 81,000 lbs for fixed-head conditions and is 52,000 lbs for pinned-head conditions.  
 When interpreting these results, the designer is faced with the decision about which curve 
is most representative of the pile design being analyzed. For prestressed concrete pile, the answer 
depends on the pile-head connection conditions utilized for the pile. If the pile is attached to the 
pile cap with dowels and an inset of a few inches, the pile-head fixity condition is very close to the 
free-head condition. If the pile is deeply embedded into the pile cap, say 2.5 pile widths or more, 
the pile-head fixity condition is very close to the fixed-head condition.  
 For pile-head embedments in between the two conditions discussed above, the pile-head 
fixity condition is likely to be elastically restrained. Evaluation of the stiffness of the elastic 
restraint will depend on the structural properties of the pile cap and the pile to pile cap 
reinforcement details. It will be necessary to use a special computer program to evaluate these 
conditions.  
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Figure 6.46  Results of Pushover Analysis of Prestressed Concrete Pile of Example 14 
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6.15 Example 15 – Pile with Defined Nonlinear Bending Properties 
 This example was provided as an example of a pile with defined nonlinear bending 
properties. Two analyses were made. The first analysis was of a drilled shaft with internally 
generated nonlinear bending properties. The second analysis was of a pile with defined nonlinear 
bending properties in which the output file of curvature and moment values was input. Both SI and 
USCS unit versions of these data files are provided. A check of the pile response computed by 
LPile for the two types of piles found that the pile responses were identical, as they should be. 
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6.16 Example 16 – Pile with Distributed Lateral Loadings 
 This example was provided as an example of pile with distributed lateral loading. In this 
example, the pile extends 20 feet above the ground surface and the distributed lateral load is a 
uniform loading of 50 lbs/inch. 
 The uniform distributed loading can be checked by evaluating the computed shear force 
and bending moment at the ground line. The computed shear force at the ground line is  

lbs 000,12
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 A check of the output report for values of shear and moment at a depth of 20 feet (240 
inches) finds that the compute shear and moment are 12,000 lbs and 1,440,000 in-lbs as expected. 
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6.17 Example 17 – Analysis of a Drilled Shaft 
 This example is provided as an example of an analysis of a drilled shaft (bored pile) that 
was constructed with two sections of different diameters; 42 and 36 inches. The pile and soil profile 
for this example are shown in Figure 6.47. This is an example of a drilled shaft that was constructed 
using a temporary casing that extended through the upper sand layer and was sealed into the 
underlying clay layer. A single-diameter cage was inserted the full length of the shaft, with the 
diameter of the upper section six inches larger than the drilled diameter of the lower section. This 
results in the clear cover over the reinforcing steel to be 6 inches in the upper section and 3 inches 
in the lower section. 
 

 
Figure 6.47  Pile and Soil Profile for Example 17 

 For this example, it was desired that the percent of steel in the shaft be no less than 1 
percent. This resulted in a cage with 14 No. 9 bars that resulted in 1.01% steel in the upper section 
and 1.38% steel in the lower section. The curves of moment versus curvature for the two sections 
are shown in Figure 6.48. The nominal moment capacity of the upper and lower sections are 14,280 
and 12,200 in-kips and the ultimate (factored using a resistance factor of 0.65) are 9,280 and 7,950 
in-kips. 
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Figure 6.48  Moment versus Curvature for Dual Section Drilled Shaft of Example 17 
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6.18 Example 18 – Analysis of Drilled Shaft with Permanent Casing 
 This example is based on Example 17, except that a permanent casing is modeled for the 
upper section. The nominal moment capacities of the upper and lower sections are 47,900 and 
12,200 in-kips and the ultimate (factored using a resistance factor of 0.65) are 31,100 and 7,950 
in-kips. The moment capacity of the second section is identical to the second section of Example 
17 because the section properties are identical. The curves of moment versus capacity are shown 
in Figure 6.49. 
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6.19 Example 19 – Analysis of Drilled Shaft with Casing and Core 
 This example is based on Example 18, except that a permanent core has been added. In 
modeling of this pile, it was assumed that the core extended over the full length of the shaft and 
that the interior of the core was void of concrete. 
 When modeling the lower section, the section type was drilled shaft with casing and core, 
but the wall thickness of the casing was set equal to zero to model the section with an interior core 
only. 
 The nominal moment capacity of the upper and lower sections are 51,900 and 16,990 in-
kips and the ultimate (factored using a resistance factor of 0.65) are 33,700 and 11,040 in-kips. 
The curves of moment versus curvature are shown in Figure 6.50. 

 
Figure 6.49  Moment versus Curvature for Dual Section Drilled Shaft with Permanent Casing 

of Example 18 
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Figure 6.50  Moment versus Curvature for Dual Section Drilled Shaft with Permanent Casing 

and Core of Example 19 
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6.20 Example 20 – Analysis of Embedded Pole 
 This example is provided as an example of the embedded pole option. Embedded poles are 
commonly used in the electrical utility industry.  The embedded pole of Example 20 has an overall 
length of 40 feet and an embedment of 6 feet.  The pile and soil profile for this example are shown 
in Figure 6.51. 

 
Figure 6.51  Pile and Soil Profile for Embedded Pole of Example 20 

 The sample LPILE model defines a pile with two sections.  The top Section 1 (Data > 
Structural Dimensions and Material Properties) is defined as “Elastic Section” with a section 
length of 34 ft using a “Pipe” as “Structural Shape” with 12-in OD and 0.375-in wall thickness 
(same from top to bottom).  The bottom Section 2 is defined using “Embedded Pole” as “Structural 
Shape” with a section length of 6 ft and “Emb. Pole Diam.” (Embedded Pole Diameter) of 12 
inches from top to bottom (using the same “Area” and “Moment of Inertia” as that of the top 
Section 1 with a 0.375-in wall thickness).  For both sections the standard “Elastic Mod.” (Modulus 
of Elasticity) of steel was used as example. 
 In some of the practical applications for electric utilities, an oversize hole is drilled to the 
specified depth, with either a wood or steel pole inserted on the hole, and with backfill compacted 
in the open void.  This type of application would be very difficult to model, since the lateral 
response of the foundation system is directly related to the stiffness/response of the compacted soil 
around the embedded pole.  It would be difficult to ascertain if the backfill has the proper level of 
humidity for compaction and if it is well compacted along the full depth of excavation without 
voids.  If the modeler assumes that the soil is “well compacted” around the pole then the model in 
LPILE should conservatively use for the bottom Section 2 (Embedded Pole) the same value of 
“Drilled Diameter” entry as that of the pole diameter (12 inches Drilled Diameter for this example).  
The “Drilled Diameter” entry defines the diameter that will be used for the creation of the lateral 
response (p-y) curves from the soil. 
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In other applications, the pole is placed in the center of the oversized hole and a cemented-
stabilized, flowable fill (or flowable concrete) is placed in the annular space around the pole.  In 
this case the annular space between the embedded pole and the soil is going to be solid and likely 
without voids.  This situation is the one modeled in the LPILE example with a “Drilled Diameter” 
entry equal to that of the oversized hole, which in this example was 24 inches.  This is the most 
recommended installation and modeling procedure for the case of embedded poles. 
 The loading on the pole is representative of a 100-mph wind loading on the pile and 
transformer mounted on top of the pole (the transformer is not shown in the above figure).  The 
wind load is equivalent to a uniform pressure of 40 psf acting over the projected area of the pole 
and transformer.  The weight of the transformer is in pile-head loading for the pole.  For this 
example, the computed pile-head deflection is near 4 inches and the ground line deflection is 
approximately 0.05 inches. 
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6.21 Example 21 – Analysis of Tapered Elastic Pile 
 This example is provided to demonstrate the modeling of a tapered elastic pile and to show 
that the values of cross-sectional area and moment of inertia are computed from the interpolated 
dimensional properties along the length of the tapered section. 
 It is possible to check two different results computed by LPile; the computed values of total 
stress and bending stiffness. The pile in this example is a 30-foot long tapered pipe pile with a top 
diameter of 16 inches, a tip diameter of 10 inches, a wall thickness of 0.5 inches, and a modulus 
of elasticity of 29,000,000 psi. Values of cross-sectional area and moment of inertia are computed 
using: 
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 The table below shows the values of interpolated dimensional properties, cross-sectional 
area, moment of inertia, theoretical bending stiffness EI, and bending stiffness computed by LPile. 
The values of theoretical bending stiffness and bending stiffness computed by LPile are identical. 

Depth, ft do, in. t, in. A, in2 I, in4 EI,  
lb-in2 

LPile EI, 
lb-in2 

0 16 0.5 24.347 731.942 2.123×1010 2.123×1010 
5 15 0.5 22.776 599.308 1.738×1010 1.738×1010 
10 14 0.5 21.205 483.756 1.403×1010 1.403×1010 
15 13 0.5 19.634 384.109 1.114×1010 1.114×1010 
20 12 0.5 18.064 299.188 8.676×109 8.676×109 
25 11 0.5 16.493 227.815 6.607×109 6.607×109 
30 10 0.5 14.923 168.812 4.896×109 4.896×109 

Table 6.1  Dimensions, Cross-sectional Area, and Bending Stiffness of Tapered Pile 

 Values of maximum total stress are computed utilizing the absolute value of bending 
moment and using 

I
cM

A
P

total +=σ
 

 The axial thrust specified in this example is 30,000 lbs. The table below shows values of 
interpolated dimensional properties, cross-sectional area, moment of inertia, bending moment 
computed by LPile, theoretical total stress, and total stress computed by LPile. The values of total 
stress computed by LPile are identical to the theoretical values, with the exception of the digits 
after the decimal point, where the difference is due to the limited output precision of LPile. The 
internal value computed by LPile is identical. 
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Depth, ft do, 
inches c, inches A, in2 I, in4 M, in-lbs σ, psi LPile σ, 

psi 
0 16 8.0 24.347 731.942 720,000 9101.64 9102.00 
5 15 7.5 22.777 599.308 1,0660.050 14658.16 14658.00 
10 14 7.0 21.206 483.756 359,980 6623.66 6624.00 
15 13 6.5 19.635 384.109 -34,446 2110.79 2111.00 
20 12 6.0 18.064 299.188 -5,783 1776.72 1777.00 
25 11 5.5 16.493 227.815 931 1841.39 1841.0 
30 10 5.0 14.923 168.812 0 2010.38 2010.0 

Table 6.2  Interpolated Dimensional Properties, Cross-sectional Area, Moment of 
Inertia, Bending Moment of Tapered Pile Computed by LPile 
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6.22 Example 22 – Analysis of Tapered Elastic-Plastic Pile 
 This example is a variation of Example 21, except that the pile section type has been 
changed to an “Elastic Section with Specified Moment Capacity” with a plastic moment capacity 
at the pile head equal to 3,293,739 in-lbs. The plastic moment capacity was computed as the yield 
moment for a pipe section with 16-inch diameter, 0.5-inch wall thickness, and 36,000-psi yield 
stress. A graph of moment and computed yield moment versus depth is shown in Figure 6.52. 

 
Figure 6.52  Bending Moment and Plastic Moment Capacity versus Depth for Example 22 

 A close examination of Figure 6.52 will find that the variation in plastic moment capacity 
is nonlinear with depth due to the tapered dimensions. This is because LPile will compute the yield 
stress of the pile material from the dimensional properties and input value of plastic moment 
capacity at the top of the section. LPile then computes the plastic moment capacity at other points 
in the section using the dimensions interpolated with depth and the interpreted value of yield stress. 
 LPile does not perform computations for tapered sections if the geometric shape is 
specified as an H-pile section. In those cases, the plastic moment capacity of the full section is set 
equal to the input value for plastic moment capacity for the section. 
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6.23 Example 23 – Output of p-y Curves 
 LPile is capable of generating 17-point p-y curves at user-specified depths. Example 23 is 
provided as a demonstration of this feature of LPile. The feature to generate p-y curves for output 
is enabled by checking the box in the Output Options of the Program Options and Settings dialog 
as shown in Figure 6.53.  

 
Figure 6.53  Program and Setting Dialog Showing Check for Generation of p-y Curves  

 The pile and soil profile for Example 23 is shown in Figure 6.54. The soil profile is 
composed of a number of different soil types, plus the lowest layer is defined as having user-input 
p-y curves. 
 When the graph of p-y curves is created, 17-points along the curves are generated. The 
spacing of the points depends on the formulation of the p-y curves. For most types of p-y curves, 
the points are representative of the shape of the curves, but for others, the y-values are chosen as 
fixed fractions of the pile diameter. In these cases, the plotted shape of the p-y curve is accurate 
only at the data points. The graph of p-y curves for Example 23 is shown in Figure 6.55. 
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Figure 6.54  Pile and Soil Profile for Example 23  

 
Figure 6.55  Standard Output of 17-point p-y Curves for Example 23 

 Figure 6.56 is the same as Figure 6.55 except that the display of the curves for the upper 
depths is turned off. The user-input curves are defined using only five points, not 17 and the curves 
are defined at the top and bottom of the layer at 35 and 75 feet below the pile head. The curves 
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displayed in Figure 6.56 are composed of 17 points and the curves are interpolated with depth at 
40 and 49 feet below the pile head. 

 
Figure 6.56  User-input p-y Curves Interpolated with Depth Using 17 Points for Example 23 

 LPile can also output the user-input p-y curves using the defined points at the top and 
bottom of the layer defined as a user-input p-y curve. An example of the user input p-y curve is 
shown as Figure 6.57. 
 A common feature of all output p-y curves is a truncation of the curve once it becomes 
horizontal. This is done to avoid hiding the shorter curves. 
 The user should be aware how LPile uses p-y curves in computations. LPile generates the 
p-values from the p-y curve formulation at every y-value at every node on the pile for every 
iterative solution of pile response. In other words, no interpolation along or in between curves is 
performed, except in the layer defined as user-input p-y curves. Thus, the p-values used by the 
program are the most accurate values possible. 
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Figure 6.57  Output of User-input p-y Curves with Five Points for Example 23 
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6.24 Example 24 – Analysis with Lateral Soil Movements 
 This example is provided as a demonstration of how to model a pile foundation subjected 
to lateral spreading. The pile and soil profile for this problem is shown in Figure 6.58. The soil 
profile is composed of a stiff clay crust, overlying a layer of liquefied sand, overlying a deep layer 
of stiff clay with free water. This soil profile was used because it represents the type of soil profile 
for which lateral spread problems are most severe. 
 The pile is a 48-inch drilled shaft with 18 No. 9 reinforcing bars. This reinforcement 
provides 0.99 percent steel. The nominal moment capacity of the shaft was computed to be 
21,360,000 in-lbs and the factored moment capacities ranged from 13,880,000 in-lbs to 16,020,000 
in-lbs for resistance factors of 0.65 to 0.75. 
 The option for loading by soil movements is enabled by checking the box for “Include 
Loading by Lateral Soil Movements” in the Program Options and Settings dialog, shown in Figure 
6.59. Once this box is checked, the input of the lateral soil movement profile versus depth is 
activated. The input dialog for lateral soil movements is shown in Figure 6.60. 

 
Figure 6.58  Pile and Soil Profile for Example 24 
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Figure 6.59  Program and Setting Dialog Showing Check for Inclusion of Loadings by Lateral 

Soil Movements 
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Figure 6.60  Input Dialog for Lateral Soil Movements versus Depth for Example 24 

 The results of the analysis with loading by soil movements are shown in Figure 6.61. In 
this problem, the upper clay crust moves along with the spreading liquefied sand layer. As a result, 
the maximum moment developed in the drilled shaft is 17,990,000 in-lbs and the factored moment 
capacity of the shaft is exceeded. 

 
Figure 6.61  Results of Analysis for Example 24 
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 The important factor to recognize in this example is the presence of the clay crust above 
the layer of spreading liquefied sand can result in loading conditions that are severe and that these 
conditions loading will fail all but the strongest of foundations. 
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6.25 Example 25- Verification of Elastic Pile in Elastic Subgrade Soil 
This example is provided for comparison to closed-form solutions. 

Closed-form solutions for the behavior of a semi-infinite elastic beam on an elastic foundation 
have been presented by numerous authors. These solutions are the only means of checking the 
solutions obtained using LPile by hand computation because any problem that involves either a 
nonlinear p-y curve or a beam with nonlinear moment-curvature behavior does not have a 
corresponding closed-form solution. 
 For the case of a semi-infinite beam with shear and moment applied to the end, the close-
form solutions for deflection, bending moment, and shear force in the beam are the following. 
 Define the modulus of elasticity, E, and moment of inertia, I, of the beam, and the subgrade 
constant, k. Compute the constant β as  

4
4EI

k
=β

 

Timoshenko (1941) states that the pile is considered “long” if the product of β and the pile length 
(βL) is greater than 4. 
 The closed-form solution for pile deflection, y, moment, M, and shear force, V, along the 
length of the pile (x) as a function of pile-head shear, Vt, and pile-head moment, Mt, is 
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 Analyses of elastic piles in elastic soils can be performed using LPile using the elastic 
subgrade soil model. The elastic subgrade constant k is computed as the product of the pile 
diameter times the elastic modulus of subgrade reaction. 
 For the verification problem, define the following input for LPile. 

An elastic pile with diameter = 12 inches, a wall thickness of 0.5 inch, and a Young’s 
modulus of elasticity of 29,000,000 psi. This results in a moment of inertia of  
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Use the elastic subgrade soil model in LPile with a subgrade modulus of 500 pci. Compute 
the elastic subgrade constant k using  
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000,6)12)(500( === dEk s  psi 

Define Vt = 10,000 lbs and Mt = 250,000 in-lbs 
 
 To provide the best check on the accuracy of the computations performed by LPile, the 
equations above were programed in an electronic spreadsheet program and the computed results 
were imported into the spreadsheet program from the plot output file in which all output is written 
in scientific notation. Graphs of closed-form versus computed solutions were prepared for lateral 
deflection, bending moment, and shear force. The graphs of the closed-form versus computed 
results are presented in Figure 6-62 through Figure 6-64, along with regression equations. As can 
be seen, for a linear regression, the coefficient of determination, R2, is 1.0 in all cases, indicating 
that the accuracy of the solution is excellent. 

 
Figure 6-62 Verification of Pile Deflections 
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Figure 6-63 Verification of Bending Moments  
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Figure 6-64 Verification of Shear Forces 

 

6.26 Example 26 – Verification of P-Delta Effect 
 LPile includes the P-Delta (P-δ) effect in its computations of bending moment for axially 
loaded piles subjected to lateral loading. Example 26 is a simple verification of the P-δ effect. 
 The pile geometry and soil profile for the verification problem is shown in Figure 6.65. 
The pile is an elastic pipe section, 36 inches in diameter with a wall thickness of 0.5 inches. The 
pile length is 60 feet and the pile extends 300 inches above the ground surface (Le). The upper soil 
layer is soft clay and the lower soil layer is sand. The pile is modeled using 240 increments with a 
convergence tolerance of 0.00001 inches. 
 In this problem, the axial load on the pile is 100,000 lbs. The pile is loaded using the 
displacement-moment loading condition with a pile-head deflection specified equal to 1.0 inches 
and the pile-head moment equal to zero.  
 The computed pile-head shear force, Vtop, is 8,859.8755 lbs and the ground line deflection, 
yGL, is 0.14478516 inches (these numbers were retrieved from the plot output file in order to obtain 
the maximum number of significant digits). 

-10,000

-5,000

0

5,000

10,000

15,000

-10,000 -5,000 0 5,000 10,000 15,000

Sh
ea

r F
or

ce
 C

om
pu

te
d 

by
 L

Pi
le

, l
bs

Shear Force Computed by Theory, lbs



CHAPTER 6 – Example Problem 26 – 6-75 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

 
Figure 6.65  Pile and Soil Profile for Verification of P-Delta Effect 

 The moment at the ground line, MV, from the pile-head shear force is 

 lbs-in 652,657,962.)in. 300)(lb 8755.859,8( === etopV LVM  

 The P-δ moment due to the eccentricity of the axial load, MP, is equal to the relative 
displacement of the pile-head to the ground line displacement multiplied by the axial thrust force. 

 lbs-in  85,521.484  )in. 14478516.0in. 0.1(lbs .000,100)( =−=−= GLtopP yyPM  

 The total moment at the ground line due to the shear force and eccentric axial load is  

   =+= PVtotal MMM lbs-in  1342,743,484.  

 The computed moment by LPile at the ground line is 2,743,484.100 in-lbs. 
 The error in the computed moment is −0.034 in-lbs. This is an error of 1.24×10−6 percent. 
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7.2 EULA 
PROGRAM LICENSE AGREEMENT & DISCLAIMER 

IMPORTANT NOTICE:  The software you are about to install or previously have installed from Ensoft 
Incorporated (“ENSOFT”) is licensed only on the condition that you agree to the terms and conditions set forth 
below.  Please read the terms of this License Agreement & Disclaimer ("LICENSE") carefully. 
If you agree to be bound by the terms of this LICENSE, please check mark the box labeled “YES – I Accept the 
terms of this License Agreement!” during software installation so it can be installed on your computer. 
If you do not agree to the terms of this LICENSE, please check mark the box labeled “NO – I DO NOT Accept the 
terms of this License Agreement!” which will terminate the software installation. 
If the software is already installed and licensed, you have already agreed to the terms and conditions of this license, 
or someone has done so on your behalf. 
This LICENSE is a legal agreement between you (“USER”) – either an individual or a single entity– and ENSOFT 
for the ENSOFT software product that you are about to install or previously have installed (“PRODUCT”).  The 
PRODUCT collectively includes computer software and associated media, printed materials, hardware key (dongle), 
and electronic documentation.  The PRODUCT also includes any updates and supplements to the original 
PRODUCT that may have been produced by ENSOFT.  By installing, copying, downloading, accessing or otherwise 
using the PRODUCT, the USER agrees to be bound by the terms of this LICENSE.  If you (the USER) do not agree 
to the terms of this LICENSE, do not install or use the PRODUCT. 

SOFTWARE LICENSE & DISCLAIMER 

The PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual 
property laws and treaties.  The PRODUCT is licensed, not sold.  

1.  GRANT OF LICENSE 

This LICENSE grants you the following rights: 

1.1  INSTALLATION AND USE 

1.1.1  Single-User Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with ENSOFT and for 
one specific physical site (“SITE”) registered with ENSOFT.  You may install and use the PRODUCT on any 
number of computers at the licensed SITE.  However, the PRODUCT is fully operational only in the SITE computer 
that carries the appropriate PRODUCT’s hardware key (“KEY”) that is used as software protection device. 

1.1.2  Network Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with ENSOFT and for 
the specific physical site(s) (“SITE(S)”) and IP range registered with ENSOFT.  Each network seat that is purchased 
is provided with access for SITE(S) clients located within up to 2 subnets with unique third octets (“CLIENT 
SUBNETS”).  The minimum two-seat network license can be associated to a maximum of 4 CLIENT SUBNETS 
(within up to 4 unique third octets).  Purchase of additional network seats can extend the allowable range of 
CLIENT SUBNETS. 
The USER may install and use the PRODUCT on any computer in the licensed SITE(S) that is within the allowable 
CLIENT SUBNETS registered with ENSOFT.  Any one computer in the network can be designated as license 
server for the PRODUCT by carrying the appropriate PRODUCT’s hardware key (“KEY”) that is used as software 
protection device. 
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This Network License strictly prohibits the PRODUCT to be used in or from computers located in office locations 
that are different than the licensed SITE(S) or outside the registered CLIENT SUBNETS.  Users in physical office 
locations other than the registered SITE(S) with ENSOFT are required to purchase additional licenses of the 
PRODUCT, even if the COMPANY is the same and/or if the additional offices are located in the same city. 

2.  OTHER RIGHTS AND LIMITATIONS 

2.1  EDUCATIONAL VERSION 

If the PRODUCT was licensed with educational discounts, the use of the PRODUCT is strictly limited to academic 
or research activities of educators and/or students.  Any other usage voids all the rights under this LICENSE.  If in 
doubt, please contact ENSOFT to determine if you have a PRODUCT version that was licensed for educational 
purposes. 

2.2  LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY 

You may not reverse engineer, decompile, or disassemble the PRODUCT, except and only to the extent that such 
activity is expressly permitted by applicable law notwithstanding this limitation. 

2.3  RENTAL 

You may not rent, lease or lend the PRODUCT to third parties. 

2.4  TRADEMARKS 

This LICENSE does not grant you any rights in connection with any trademarks or service marks of ENSOFT. 

2.5  SUPPORT SERVICES 

ENSOFT shall provide you with limited support and maintenance services (“SUPPORT”) related to the PRODUCT 
during the initial year after purchase and for any additional SUPPORT term that the COMPANY elects to purchase 
for PRODUCT after the initial warranty period expires.   
Use of SUPPORT is limited to the ENSOFT policies and programs described in the PRODUCT’s User’s Manual, in 
documentation on the ENSOFT web site, and/or in other materials provided by ENSOFT. 
Any supplemental software code that may be provided to you as part of the SUPPORT or that is downloaded from 
the ENSOFT web site shall be considered part of the PRODUCT and subject to the terms and conditions of this 
LICENSE.  With respect to technical information you provide to ENSOFT as part of the SUPPORT, ENSOFT may 
use such information for its business purposes, including for product support, development or advertisements.  
However, ENSOFT will not utilize such technical information in a form that personally identifies the USER. 

2.6  SOFTWARE TRANSFER 

The initial user of the PRODUCT may make a permanent transfer of this LICENSE and PRODUCT and only 
directly to an end user.  This transfer must include all of the PRODUCT (including all component parts, the media 
and printed materials, any upgrades, this LICENSE, and the PRODUCT’s appropriate hardware KEY).  Such 
transfer may not be by way of consignment or any other indirect transfer.  The transferee of such one-time transfer 
must agree to comply with the terms of this LICENSE, including the obligation not to further transfer this LICENSE 
and PRODUCT. 

2.7  TERMINATION 

Without prejudice to any other rights, ENSOFT may terminate this LICENSE immediately if you fail to comply 
with the terms and conditions of this LICENSE.  In such event, you must destroy all copies of the PRODUCT and 
all of its component parts and provide evidence of such destruction in writing to ENSOFT within 3 business days. 

2.8  INDEMNIFICATION 
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Within and during the terms of this LICENSE, ENSOFT warrants that the use of the initially provided PRODUCT 
does not infringe any patent, copyright, or trademark in the United States, and ENSOFT shall indemnify and hold 
USER harmless against any and all losses, damages and expenses, (including attorney’s fees) which USER may 
sustain or incur as a result of a breach of this warranty. 

2.9  CONFIDENTIAL INFORMATION 

ENSOFT and the USER may have access to certain proprietary information and materials of the other that are 
confidential and of substantial value to the respective party, which value would be impaired if such information 
were disclosed to third parties ("CONFIDENTIAL INFORMATION").  ENSOFT and the USER agree that neither 
shall disclose any CONFIDENTIAL INFORMATION to any third party and shall take every reasonable precaution 
to protect CONFIDENTIAL INFORMATION. 
The provisions of this section shall not apply to any information which (i) is or becomes available to the public other 
than by breach of the LICENSE agreement by the receiving party, (ii) is rightfully received by receiving party from 
a third party without confidential limitations, (iii) is independently developed by receiving party's employees 
without access to CONFIDENTIAL INFORMATION, or (iv) is known to the receiving party without any restriction 
on its use or disclosure prior to first receipt of it from the disclosing party. 

3.  COPYRIGHT 

All title and intellectual property rights in and to the PRODUCT (including but not limited to any images, 
photographs, animations, video, audio, music, and text that may be incorporated into the PRODUCT), the 
accompanying printed materials, and any copies of the PRODUCT are owned by ENSOFT.  All title and intellectual 
property rights in and to the content which may be accessed through use of the PRODUCT is the property of the 
respective content owner and may be protected by applicable copyright or other intellectual property laws and 
treaties.  This LICENSE grants you no rights to use such content.  All rights not expressly granted are reserved by 
ENSOFT.  This PRODUCT is protected by the United States Copyright Law and International Copyright Treaty. 

4.  SOFTWARE DISCLAIMER  

Although the PRODUCT has been used with apparent success in many analyses, new information is developed 
continuously and new or updated PRODUCT releases may be written from time to time.  All users are requested to 
inform ENSOFT immediately if any errors are found in the PRODUCT.  As modifications, updates, or new versions 
are produced, the latest codes are posted on ENSOFT’s web site and made available to all visitors for free 
downloading. 
No warranty, expressed or implied, is offered as to the accuracy of results from ENSOFT’s PRODUCT.  The 
PRODUCT should not be used for design unless caution is exercised in interpreting the results and independent 
calculations are available to verify the general correctness of the results.  Users are assumed to be knowledgeable of 
the information in the printed documentation that is distributed with the digital media.  Users are assumed to 
recognize that the input parameters, eg., soil properties, increment length, tolerance on solution convergence, and 
many others, can have a significant effect on the solution and must be chosen carefully. Users should have a 
thorough understanding of the relevant theoretical criteria (appropriate references are suggested in the software 
documentation).  

5.  GOVERNING LAW 

This LICENSE is governed by the laws of the State of Texas and laws and treaties of the United States of America. 

6.  CONTACT INFORMATION 

Should you have any questions concerning this LICENSE or if you desire to contact ENSOFT for any reason, please 
use the following: 
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Ensoft Incorporated 
3003 West Howard Lane 
Austin, Texas 78728 
United States of America 

NO OTHER WARRANTIES 

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, ENSOFT DISCLAIMS ALL OTHER 
WARRANTIES AND CONDITIONS, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED 
TO, IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 
PURPOSE, AND TITLE, WITH REGARD TO THE PRODUCT, AND THE PROVISION OF SUPPORT 
SERVICES.  THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS.  YOU MAY HAVE 
OTHERS, WHICH VARY FROM STATE/JURISDICTION TO STATE/JURISDICTION. 

LIMITATION OF LIABILITY 

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL ENSOFT BE 
LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES 
WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, 
BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) 
ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT OR THE FAILURE 
TO PROVIDE SUPPORT, EVEN IF ENSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.  IN ANY CASE, ENSOFT’S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS LICENSE 
AGREEMENT SHALL BE LIMITED TO THE GREATER OF THE AMOUNT ACTUALLY PAID BY YOU 
FOR THE PRODUCT OR U.S.$1.00. 
 

 
 

 



 

 

Appendix 1 – Input Error Messages 
  



Appendix 1 – Input Error Messages – 2 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

Un-numbered: Version mismatch between main program and dynamic link library for computation 
files. 

Input Data Error No. 1: An error was detected in the input data for computing a p-y curve using 
the API sand criteria. A value of zero was input for the friction angle of the sand. 

Input Data Error No. 2: An error was detected in the input data when computing a p-y curve using 
the API criteria for sand. The angle of the ground slope cannot be greater than the internal 
friction angle of the sand at the ground surface. 

Input Data Error No. 3: The pile tip is below the deepest extent of the input data for soil shear 
strength versus depth. 

Input Data Error No. 4: The pile extends below the deepest extent of the input data for soil shear 
strength versus depth. 

Input Data Error No. 5: The pile tip is below the deepest extent of the input curve for soil shear 
strength versus depth. 

Input Data Error No. 6: Use of p-y multipliers cannot be specified for use with user-specified p-y 
curves. 

Input Data Error No. 7: The number of points defining effective unit weight versus depth is zero 
and number of input p-y curves is also zero. 

Input Data Error No. 8: A value of zero was input for the friction angle for a sand when computing 
a p-y curve using the Reese et al. criteria. 

Input Data Error No. 9: The angle of the slope cannot be greater than the friction angle of the sand 
at the ground surface. 

Input Data Error No. 10: A negative or zero value was input for the friction angle for silt. 
Input Data Error No. 11: The angle of the ground surface slope cannot be greater than the angle of 

internal friction angle of the silt (c-phi) soil at the ground surface. 
Input Data Error No. 12: An error was detected that is related to an incompatibility between the 

input data defining soil layering and soil shear strength values when computing a p-y curve 
using the Matlock soft clay criteria. 

Input Data Error No. 13: A cohesion of zero was input for a stiff clay without free water. 
Input Data Error No. 14: An error was detected in the input data used to compute p-y curves in 

stiff clay with free water. A value of zero was input for the cohesion of a stiff clay. 
Input Data Error No. 15: The pile extends below the deepest extent of the input curve for effective 

unit weight versus depth. 
Input Data Error No. 16: The input value for the compressive strength of a weak rock was input as 

negative or zero. 
Input Data Error No. 17: The value number of points to define the pile properties is 2 to 40. Either 

too few or too many points were input for the definition of pile properties. 
Input Data Error No. 18: The depth at the bottom of the last layer is higher than the tip of the pile. 



Appendix 1 – Input Error Messages – 3 

User’s Manual (Rel. Feb. 2022)  LPILE v2022 

Input Data Error No. 19: The depth of the first point of the data for effective unit is not located at 
the ground surface. 

Input Data Error No. 20: The depth of the first point of the soil strength profile is not located at 
the ground surface. 

Input Data Error No. 21: The depth for the first data point for p-multipliers is not located at the 
ground surface. 

Input Data Error No. 22: Loading was specified to be cyclic, but the number of cycles of loading 
was specified outside the range of 2 to 5000. 

Input Data Error No. 23: Deleted. 
Input Data Error No. 24: Deleted. 
Input Data Error No. 25: The input file is empty. No analysis can be performed. 
Input Data Error No. 26: The number of rebar cannot exceed 300 in this version of LPile. 
Input Data Error No. 27: Zero values were entered for one of pile diameter, pile area, or moment 

of inertia. 
Input Data Error No. 28: Cyclic loading type was specified and the number of cycles of loading 

are outside the valid range of 2 to 5,000. 
Input Data Error No. 29: A depth above the ground surface was specified for the printing of a p-y 

curve. 
Input Data Error No. 30: A depth below the pile tip was specified for the printing of a p-y curve. 
Input Data Error No. 31: The pile extends below the deepest extent of the input data for RQD 

versus depth. 
Input Data Error No. 32: Type of reinforcement is unrecognized by LPile. 
Input Data Error No. 33: Tapered rebar option type is unrecognized. 
Input Data Error No. 34: Specified rebar cover is greater than one-half of pile diameter. 
Input Data Error No. 35: Too many pile sections specified for analysis. 
Input Data Error No. 36: Deleted. 
Input Data Error No. 37: Deleted. 
Input Data Error No. 38: Deleted. 
Input Data Error No. 39: Deleted. 
Input Data Error No. 40: Deleted. 
Input Data Error No. 41: Deleted. 
Input Data Error No. 42: Deleted. 
Input Data Error No. 43: Pile section type unrecognized. 
Input Data Error No. 44: Units of computation option unrecognized by program. 
Input Data Error No. 45: Input data for pile properties specifies a negative pile station coordinate. 
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Input Data Error No. 46: Input data for pile properties specified a pile station below the pile tip. 
Input Data Error No. 47: The depth of the top of a layering is greater than or equal to the depth of 

the bottom of the layer. 
Input Data Error No. 48: A negative or zero value was input for the cohesion for silt. 
Input Data Error No. 49: The interpolated value of RQD used for p-y curves in weak rock was 

found to be invalid because it was either less than zero or more than 100 percent. 
Input Data Error No. 50: The pile-tip movement data for shear resistance at the pile tip is in error. 

Either the first point is not zero or one of the other points is less than or equal to the previous 
point. 

Input Data Error No. 51: The nonlinear bending stiffness input by the user varies by more than a 
factor of 100 for a given axial thrust force. This indicates that either unrealistic or erroneous 
data was input. 

Input Data Error No. 52: The nonlinear bending stiffness input by the user exhibits strain hardening 
behavior. LPile can handle nonlinear bending cases only with strain softening behavior. 

Input Data Error No. 53: The number of lines of soil movement data is outside the range of 2 to 
50. 

Input Data Error No. 54: The top and bottom elevations for weak rock layer are equal. 
Input Data Error No. 55: The specified number of pile increments is less than 40. 
Input Data Error No. 56: The specified number of pile increments is more than 500. 
Input Data Error No. 57: The input value for pile length is zero. 
Input Data Error No. 58: The pile tip is below the deepest extent of the input curve for weak rock 

parameter krm versus depth. 
Input Data Error No. 59: The number of input pile diameters is more than 40. 
Input Data Error No. 60: An error was detected in the shear strength of soil input data when 

interpolating to obtain values of cohesion or uniaxial compressive strength. The depth 
increment between the upper and lower soil depths in a layer is zero. 

Input Data Error No. 61: The depth of the bottom of the top soil layer is less than or equal to zero. 
This will cause the algorithm for layering correction to p-y curves to generate incorrect p-
y curves for layers below the top layer. 

Input Data Error No. 62: An error was detected for input values for uniaxial compressive strength. 
Values cannot be less than zero. 

Input Data Error No. 63: The input value of krm is less than or equal to zero for weak rock. 
Input Data Error No. 64: The input value for the number of iterations is less than 40 or more than 

1000. 
Input Data Error No. 65: The input value for the convergence tolerance cannot be smaller than 

1×10−10 inches. 
Input Data Error No. 66: The input value for the convergence tolerance cannot be larger than 0.001 

inches. 
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Input Data Error No. 67: The input value for the convergence tolerance cannot be smaller than 
2.54×10−12 meters. 

Input Data Error No. 68: The input value for the convergence tolerance cannot be larger than 
2.54×10−5 meters. 

Input Data Error No. 69: The input value for the excessive deflection limit is smaller than 10 
percent of the pile diameter. 

Input Data Error No. 70: The input value for the number of cycles of loading is greater than 10 
and one of the soil layers is loess. The soil model for loess is valid only for 1 to 10 cycles 
of loading. 

Input Data Error No. 71: An error was detected in the soil shear strength values to be used for 
computing a p-y curve using the Matlock soft clay with user-defined J criteria. A negative 
or zero value of cohesion was input for a soft clay soil. 

Input Data Errors 72-94 are reserved for future use. 
Input Data Error No. 95: An input line was unrecognized. See the output report for further details. 
Input Data Error No. 99: An input line was unrecognized. See the output report for further details. 
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Runtime Error No. 1: Internal error occurred in the LPile computation dynamic link library. This 
error is reported when the dynamic link library fails to load into memory. 

Runtime Error No. 2: Contents of file NAMES.DAT is corrupted. This file contains the path and 
name of all data and output files used by LPile. 

Runtime Error No. 3: The name of the input data file is corrupted. 
Runtime Error No. 4: The name of the output report file is corrupted. 
Runtime Error No. 5: The name of the plot output file is corrupted. 
Runtime Error No. 6: The name of the runtime message file is corrupted. 
Runtime Error No. 7: The user name is corrupted. 
Runtime Error No. 8: User company name is corrupted. 
Runtime Error No. 9: The computed deflection of the pile head is larger than the allowable 

deflection. This error may be due to overloading the pile or bad input data. 
Runtime Error No. 10: LPile was unable to obtain an answer within the specified convergence 

tolerance within the specified limit on iterations. 
Runtime Error No. 11: The numerical solution failed due to a small pivot number. 
Runtime Error No. 12: An error occurred because the computed value of compressive strain in 

concrete is larger than 0.001. This indicates that that the drilled shaft has failed due to 
crushing of concrete. 

Runtime Error No. 13: Deleted. 
Runtime Error No. 14: An internal error occurred in computing area of concrete for prestressing 

computations. 
Runtime Error No. 15: An error occurred in computing area of steel for prestressing computations. 
Runtime Error No. 16: The location of neutral axis was not found within 1,000 iterations during 

computation of non-linear moment-curvature behavior. 
Runtime Error No. 17: Filename information corrupted. No analysis can be performed. 
Runtime Error Nos. 18-21: Deleted. 
Runtime Error No. 22: A runtime error was caused by the input value krm being less than or equal 

to 0. 
Runtime Error No. 23: A runtime error was caused by the input value for combined ground slope 

and pile batter being greater than the angle of friction of a silt layer. 
Runtime Error No. 24: The input value for axial thrust force is greater than the structural capacity 

in compression. 
Runtime Error No. 25: The input value for axial thrust force is greater than the structural capacity 

in tension. 
Runtime Error No. 26: An LRFD load case value for axial thrust force is greater than the structural 

capacity in compression. 
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Runtime Error No. 27: An LRFD load case value for axial thrust force is greater than the structural 
capacity in tension. 

Runtime Error No. 28: An unrecoverable numerical error has occurred. Either pile-top deflection 
or computed maximum change in deflection is not a number and further computations are 
impossible. 

Runtime Error No. 29: A layer thickness was too thin to contain a nodal point. This prevents the 
correct computation of the layer’s p-y curve.  

Runtime Error No. 30: An error occurred in the computation of the undrained shear strength value 
for a soil layer. 

Runtime Error No. 31: The computed value of soil modulus computed in Reese sand is not-a-
number. This is due to one or more of the required soil properties being equal to zero. See 
the output report for more information. 

Runtime Error No. 32: The default value of soil modulus computed in Reese sand is not-a-number. 
This is due to one or more of the required soil properties being equal to zero. See the output 
report for more information. 

Runtime Error No. 33: The default value of soil modulus computed in soft clay is not-a-number. 
This is due to one or more of the required soil properties being equal to zero. See the output 
report for more information. 

Runtime Error No. 34: The computed value of soil modulus computed in soft clay is not-a-number. 
This is due to one or more of the required soil properties being equal to zero. See the output 
report for more information. 

Runtime Error No. 35: The default value of soil modulus computed in API soft clay is not-a-
number. This is due to one or more of the required soil properties being equal to zero. See 
the output report for more information. 

Runtime Error No. 36: The computed value of soil modulus computed in API soft clay is not-a-
number. This is due to one or more of the required soil properties being equal to zero. See 
the output report for more information. 
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1 Note, the warning message number is not displayed by LPile 
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Warning Message No. 300: Multiple warning messages have been generated. See the output report 
file for more details. 

Warning Message No. 301: An unreasonable input value for k has been specified See the output 
report file for more details. 

Warning Message No. 302: An unreasonable input value for friction angle has been specified for 
a soil layer defined using the sand criteria. See the output report file for more details. 

Warning Message No. 303: An unreasonable input value for friction angle has been specified for 
a soil layer defined using the API sand criteria. See the output report file for more details. 

Warning Message No. 304: An unreasonable input value for shear strength has been specified for 
a soil layer defined using the soft clay criteria. See the output report file for more details. 

Warning Message No. 3041: An unreasonable input value for shear strength has been specified for 
a layer defined using the soft clay criteria. The input value is greater than 1,250 psf (8.68 
psi). 

Warning Message No. 3042: An unreasonable input value for shear strength has been specified for 
a layer defined using the soft clay criteria. The input value is greater than 59.85 kPa. See 
the output report file for more details. 

Warning Message No. 305: Too many values were calculated for moment-curvature. This may 
indicate that the pile is too weak or is under-reinforced. You should examine your input 
data and increase the amount of steel reinforcement if necessary. 

Warning Message No. 3051: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay with free water criteria. The input value is less than 500 
psf (3.47 psi). 

Warning Message No. 3052: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay with free water criteria. The input value is greater than 
8,000 psf (55.55 psi). 

Warning Message No. 3053: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay with free water criteria. The input value is less than 
23.94 kPa. 

Warning Message No. 3054: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay with free water criteria. The input value is greater than 
383.04 kPa. See the output report file for more details. 

Warning Message No. 306: Negative values of bending moment were computed in nonlinear EI 
computations. This may indicate that the pile is too weak or is under-reinforced and that 
all reinforcing steel has yielded.  

Warning Message No. 3061: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay without free water criteria. The input value is less than 
500 psf (3.47 psi).  

Warning Message No. 3062: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay without free water criteria. The input value is greater 
than 8,000 psf (55.55 psi). 
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Warning Message No. 3063: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay without free water criteria. The input value is less than 
23.94 kPa. 

Warning Message No. 3064: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay without free water criteria. The input value is greater 
than 383.04 kPa. 

Warning Message No. 307: The input data for nonlinear bending appears to be have been input 
incorrectly. Negative values of bending moment should not be input.  

Warning Message No. 3071: An unreasonable input value for the uniaxial compressive strength 
has been specified for a layer defined using the weak rock criteria. The input value is less 
than 100 psi. 

Warning Message No. 3072: An unreasonable input value for unconfined compressive strength 
has been specified for a soil defined using the weak rock criteria. The input value is greater 
than 1,000 psi. 

Warning Message No. 3073: An unreasonable input value for unconfined compressive strength 
has been specified for a soil defined using the weak rock criteria. The input value is less 
than 689.5 kPa. 

Warning Message No. 3074: An unreasonable input value for unconfined compressive strength 
has been specified for a soil defined using the weak rock criteria. The input value is greater 
than 6895 kPa. 

Warning Message No. 308: An unreasonable input value for uniaxial compressive strength has 
been specified for a layer defined using the vuggy limestone (strong rock) criteria. 

Warning Message No. 309: An unreasonable input value for compressive strength of concrete has 
been specified. 

Warning Message No. 3091: An unreasonable input value for compressive strength of concrete 
has been specified. The input value is either smaller than 2,000 psi or larger than 8,000 psi.  

Warning Message No. 3092: An unreasonable input value for compressive strength of concrete 
has been specified. The input value is either smaller than 13,790 kPa or larger than 55,160 
kPa.  

Warning Message No. 310: An unreasonable input value for modulus of elasticity for steel has 
been specified. 

Warning Message No. 311: An unreasonable input value for yield strength of reinforcement has 
been specified. 

Warning Message No. 3101: An unreasonable input value for modulus of elasticity  has been 
specified for the reinforcing steel. The input value is either smaller than 27,500,000 psi or 
larger than 30,500,000 psi.  

Warning Message No. 3102: An unreasonable input value for modulus of elasticity  has been 
specified for the reinforcing steel. The input value is either smaller than 189,600,000 kPa 
or larger than 210,300,000 kPa.  
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Warning Message No. 3111: An unreasonable input value for yield strength of reinforcing steel 
has been specified. The input value is either smaller than 38,000 psi or larger than 80,000 
psi. 

Warning Message No. 3112: An unreasonable input value for yield strength of reinforcing steel 
has been specified. The input value is either smaller than 262,000 kPa or larger than 
551,600 kPa.  

Warning Message No. 312: An input value for cover of reinforcement has been specified that may 
be unreasonable.  

Warning Message No. 3121: An unreasonable input value for concrete cover thickness has been 
specified. The input value is either smaller than 0.8 inches or larger than 6 inches. 

Warning Message No. 3122: An unreasonable input value for concrete cover thickness has been 
specified. The input value is either smaller than 0.02 meters or larger than 0.16 meters. You 
should check your input for accuracy. 

Warning Message No. 313: An unreasonable input value for loss of prestress has been specified.  
Warning Message No. 314: An unreasonable input value for prestressing force has been specified.  
Warning Message No. 315: Pile deflection has exceeded the failure deflection for the vuggy 

limestone criteria for one or more of the loading cases analyzed. You should check the 
computed output for both deflection and bending moment. 

Warning Message No. 316: The input value for krm used by the weak rock criteria is smaller than 
0.00005. This value is outside the recommended range of 0.00005 to 0.0005.  

Warning Message No. 317: The input value for krm used by the weak rock criteria is larger than 
0.0005. This value is outside the recommended range of 0.00005 to 0.0005. You should 
check your input data for accuracy. 

Warning Message No. 318: The pile deflection is less than 1×10−14. LPile  used the limiting value 
of soil modulus when computing the p-y curve for soft clay. 

Warning Message No. 3261: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay without free water criteria with user-defined k. The input 
value is less than 500 psf (3.47 psi). 

Warning Message No. 3262: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay without free water criteria with user-defined k. The input 
value is greater than 8,000 psf (55.55 psi). 

Warning Message No. 3263: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay without free water criteria with user-defined k. The input 
value is less than 23.94 kPa. 

Warning Message No. 3264: An unreasonable input value for shear strength has been specified for 
a layer defined using the stiff clay without free water criteria with user-defined k. The input 
value is greater than 383.04 kPa. 

Warning Message No. 351: Values entered for effective unit weights of soil were outside the limits 
of 0.011574 pci (20 pcf) or 0.0810019 pci (140 pcf). This data may be erroneous. 
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Warning Message No. 352: Values entered for effective unit weights of soil were outside the limits 
of 3.15 kN/m3 or 22 kN/m3. This data may be erroneous. 

Warning Message No. 353: Values of effective unit weight cannot be checked because general 
units have been selected. 

Warning Message No. 354: The maximum depth of a soil layer defined as liquefiable sand is 
greater than meters or 236.22 inches. This is greater than the maximum depth 
recommended for this p-y curve criteria. 

Warning Message No. 355: Computation of nonlinear bending stiffness found that moment 
capacity was developed at compressive strains smaller than 0.003. This usually indicates 
that a section is under-reinforced or the level of prestressing is too small.  

Warning Message No. 400: One or more of the LRFD load cases have overloaded the structural 
capacity of the pile. See the LRFD Performance by Load Case Combination section of the 
output report file for more details. 
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