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COPYRIGHT, WARRANTY & DISCLAIMER 
Copyright 1987-2023 by ENSOFT, INC. 

All rights reserved. 
 
Printed in the Unites States of America. Except as permitted under the 
United States Copyright Act of 1976, no part of this publication may be 
reproduced, translated, or distributed without the prior written approval 
of ENSOFT, INC. 
 
Although the program has been used with apparent success in many 
analyses, new information is being developed and new or updated 
versions may be written from time to time.  All users are requested to 
inform ENSOFT, INC. immediately of any possible errors that are found in 
the coding of our software.  As modifications, updates, or new versions are 
produced, notices will be sent to subscribed users that keep their address 
current on ENSOFT, INC.’s files. 
 
No warranty, expressed or implied, is offered as to the accuracy of results 
from ENSOFT, INC.’s software products.  The software products should not 
be used for design unless caution is exercised in interpreting the results 
and independent calculations are available to verify the general 
correctness of the results.  Users are assumed to be knowledgeable of the 
information in the printed documentation that are distributed with the 
digital media.  Users are assumed to recognize that the input parameters, 
eg., soil and rock properties, shaft length, diameter of rock socket, and 
many others, can have a significant effect on the solution and must be 
chosen carefully.  Users should have a thorough understanding of the 
relevant theoretical criteria (appropriate references are suggested in the 
software documentation). 
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1.1 General Description 
The interaction among the piles and the surrounding soil are complex.  Pile driving generally alters 

the character of the soil and intense strains are set up locally near the piles.  The load transfer mechanics 
(side friction and tip resistance from soils) vary with many factors such as the types of soils, the installation 
method, the pile material, the pile geometry and others.  Because of the inherent complexities of pile 
behavior, it is necessary to use practical semi-empirical methods of design, and to focus attention on 
significant factors rather than minor or peripheral details.  APILE utilizes two related codes to provide the 
user with information on the behavior of driven piles under axial loading. 

The first of these codes makes use of four different sets of established empirical methods for 
computing the axial capacity of piles as a function of depth.  Those methods include: API method 
(established by American Petroleum Institute), USACE method (published by U.S. Army Corps of 
Engineers), FHWA method (published by U.S. Federal Highway Administration), and Lambda method 
(with the effective-stress contribution).  Most of the semi-empirical design methods for prediction of axial 
capacity of piles require internal friction angles (φ) for calculating the side friction in sand layers, and the 
undrained cohesive strength for calculating the side friction in clay layers.  The design engineers should 
gather all the necessary soil parameters based on the geotechnical investigation report prepared for the 
application site.  The subsurface can be divided into sub-layers based on the soil properties (cohesive or 
non-cohesive) with the associated layer depth and soil parameters. 

Recently, the cone penetration test (CPT) has been widely used in subsurface explorations 
worldwide.  Four empirical methods for prediction of the axial capacity of driven piles based on CPT data 
have been recommended by the offshore industry and are included in APILE Offshore Version.  Those four 
coned-based empirical methods include: NGI-99 method (published by Norwegian Geotechnical Institute), 
ICP/MTD method (published by Richard Jardine et al from Imperial College in London in 2005), Fugro 
method (published by Fugro in 2005), and UWA method (published by the University of Western Australia 
in 2005). 

The second of the two codes employ t-z curves to compute the load versus settlement of the pile at 
the greatest length that is specified in the input.  If these results fail to satisfy the requirements of a particular 
application, the user may refer to the results of load versus depth and select a revised length. Each of these 
codes is described in detail in the following sections and example computations are also presented. 

APILE is a special-purpose program based on rational procedures for analyzing a driven pile under 
axial loading.  The program computes settlement of the top and base of the driven pile as a function of axial 
loading, along with the distribution of axial load along the length of the pile. 

1.2 Features of the Program  
Program APILE has the following features that are designed to enhance the ability of the engineer to 

obtain usable results. 
1. Unit load transfer in side resistance (skin friction) and end bearing are computed, along with 

the capacity of a pile to sustain axial loading. 
2. Results from four different analytical methods are provided in the basic version for 

comparison and/or code compliance.  Additional results from four cone-based analytical 
methods are available in the special Offshore version of APILE.  
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3. The APILE program makes internal computations of the development of a plug in an open-
ended pile as it is driven into the ground. 

4. At the user’s discretion, the values of unit load transfer computed by the program or those 
provided by the user (externally from APILE) can be used to estimate load versus settlement. 

5. Graphical output of load-distribution curves, load-settlement curves, and bearing capacity as a 
function of depth are provided. 

6. APILE has options for computation of pile capacity under tension (uplift loads) with 
considerations for buoyancy effects where necessary. 

7. Option for applying reduction factors for each soil layer, such as strength reduction during pile 
driving, pile-group reduction factor, or LRFD strength reduction factor. 

8. The cone penetration test (CPT) has been widely used in subsurface explorations worldwide.  
The latest APILE has an option to read a CPT data via an external file, and then convert the 
CPT data to equivalent SPT-N values and equivalent cohesive strength internally for the user. 

1.3 History of Development 

1.3.1 APILE1 (1987) 

With the advent of wide-spread availability of personal computers, the founder of ENSOFT, Inc., 
had a vision to improve the engineering capability for analysis and design of deep foundations by providing 
useful software tools.  The development of APILE1 was completed under the direction of Dr. Lymon C. 
Reese and was first commercially distributed in 1987.  While based on an earlier mainframe program, 
APILE1 was developed to use an interactive input method.  

1.3.2 APILE Plus v1 (1989) 

APILE Plus was released in 1989.  This version incorporated the program APILE2 (Portion of 
TZPILE), which was developed as a subroutine for computing the load-vs-settlement at the pile head based 
on the t-z curve method.  Therefore, Program APILE Plus is a complete program for analyzing the behavior 
of driven piles under axial loading.  It not only calculates the ultimate skin friction and tip resistance at each 
depth, but also computes the load-vs.-settlement relationship at the pile head.  In addition, a menu-based 
DOS interface was introduced. 

1.3.3 APILE Plus v2 (1995) 

The success of Windows 3.1 from Microsoft, Inc., as the dominant platform for personal computers 
pushed software development to adopt a standard, graphical-user interface.  This version of APILE Plus 
utilized Windows-based pre- and post-processors, while retaining the original computing engine from 
Version 1. 

1.3.4 APILE Plus v3 (1998) 

This version of APILE Plus was a complete recoding of both the pre-and post-processing programs 
running under Windows 95/NT and the computing engine.  The graphical-user interface was recoded to 
provide a more intuitive process for data input and to enhance the graphical capabilities.  
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In addition, in the technical side, Version3 includes two new methods for computing the axial 
capacity of driven piles.  One is the FHWA method recommended by the Federal Highway and Works 
Administration (FHWA).  The other one is the USACE method recommended by the US Army Corps of 
Engineers (USACE). 

The program presents the computed results for all four different methods and the user can make a 
selection based on the site condition and the application. 

1.3.5 APILE Plus v4 (2004) 

This version of APILE Plus is upgraded for the requirement under Windows 2000/XP and the later 
system.  The most recent files of the input data will be listed under File Menu for users to load or retrieve 
quickly and conveniently. 

APILE Plus Version 4 now has an option to generate compatible data file used by GRLWEAP for 
pile driving analyses.  The program also provides the user with an option to generate t-z curves at depths 
specified by the user.  Furthermore, the program prints and plots the unit side friction and accumulated side 
friction as a function of depth for comparison. 

1.3.6 APILE Plus v5 (2007) 

APILE Plus Version 5 added an option for computation of pile capacity under tension (uplift loads).  
Another new feature in Version 5 is to allow the user entering the variation of cross-sectional area as a 
function of depth.  This feature is particularly useful for tapered piles or long pipe piles with sections using 
different inside diameters (ID).  Recently the cone penetration test (CPT) has been widely used in 
subsurface explorations worldwide.   APILE Plus Version 5 now has an option to read the CPT data via an 
external file, and then convert the CPT data to equivalent SPT-N values and equivalent cohesive strength 
internally for the user.  

Two empirical methods for prediction of the axial capacity of driven piles based on the CPT data 
have been evaluated by API.  The first one is NGI-99 method published by Norwegian Geotechnical 
Institute and the other one is MTD method published by Richard Jardine et al (2005) from Imperial College 
in London.  Several uncommon soil parameters particularly are required for MTD method, which may not 
be of interest to driven piles installed onshore. APILE Plus provides the user with the basic version and an 
offshore version.  The difference between these two versions is that the offshore version includes the 
predicted pile capacity based on NGI-99 and MTD methods for offshore applications. 

1.3.7 APILE 2014 (v6) 

Program APILE uses the year number as the version sequence starting in 2014, while keeping the 
second number of the release equal to the input data format (input data format 6).  The major improvements 
in v2014.6 were a complete rewrite for a more intuitive interface and to provide options for specifying the 
reduction factors on side friction and tip resistance for each soil/rock layer if the user selects the LRFD 
method. 

The new release also introduces the ability to compute elastic shortening for pile portions above 
ground level (either in air or water), which is useful for many offshore applications. 

Two more cone-based empirical methods, including Fugro method (published by Fugro in 2005), 
and UWA method (published by the University of Western Australia in 2005), were added into the APILE 
2014 Offshore version. 
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The new program allows the user to change the line width and font sizes in the generated plots.  In 
addition, v2014 introduces compatibility to Windows 8 and 8.1.  The program text book was updated and 
released in separate User’s and Technical Manuals, both improved plus released electronically in protected 
PDF format. 

1.3.8 APILE 2015 (v7) 

Improvements in v2015 (data format 7) included an extended set of user-selectable parameters for 
the FHWA criteria (users can now select a desired adhesion factor in each CLAY layer), introduced a SILT 
criteria for USACE computations, improved computational options for SAND criteria, added a new feature 
for export of any output plot into a new Microsoft Excel spreadsheet (created by APILE) to help users in 
presentation graphics for reports and also added new sets of speed buttons. 

1.3.9 APILE 2018 (v8) 

This new full version introduces data format 8 with four new main features: i) the ability to analyze 
batter piles (installed at an angle from vertical), ii) new 3D graphics for display of the pile, soils and load 
transfers, iii) ability to specify the use of long-pile factors for USACE method, and iv) introduction of the 
FHWA 2016 method of neutral plane method for estimations of downdrag forces.  All new features are 
described in more details in associated sections of the new User’s and Technical Manuals. 

1.3.10 APILE 2019 (v9) 

The main new feature in v2019 is the ability for users to modify certain shapes of the internal t-z 
curves produced by the program.  This new feature ensures compliance with guidelines set since the API 
2A-WSD from November 2014.  New features are described in more details in associated sections of the 
new User’s and Technical Manuals. 

1.3.11 APILE 2023 (v10) 

The most important improvements implemented in APILE v2023 (equivalent to APILE v10 when 
using the old release numbering) are included in the list below. 

1. Introducing a new feature to import and analyze files from any cone penetrometer (CPT) to 
create soil layering and properties for inputting into APILE for capacity estimations: 
⁍ Users can interactively import any CPT data in any format and in any units. 
⁍ Users can select Sand or Clay layers quickly based on interpreted Cohesion and Friction 

Angles. 
⁍ CPT can be quickly evaluated and interactive plot helps users for the selection of desired 

mechanical parameters for top and bottom of each layer. 
⁍ Interpreted data can be exported to APILE and later edited using CPT screen and/or using 

the standard APILE dialog boxes. 
2. Background programming has been improved for the data entry process. 
3. Users can now enter data for soil layers and pile length in Elevations or in Depths (distance 

from grade) and can switch between them as needed for any part of the data-entry process. 
4. Output graphics will display program results in the selected Elevations or Depths. 
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5. A new feature allows users to specify the depths above/below pile tip that should be used to 
average the computations of end bearing. 

6. Users can specify t-z multipliers for any depth along the pile. 
7. Users can specify Q-w multipliers for the pile tip. 
8. APILE v2023 has a feature for exporting a data file with definition of soil transfers for 

drivability analyses with the separate GRLWeap 14 software. 
9. There is a new viewer of output plots where users can quickly observe results in graphical 

form and/or produce/export of basic plots (more detailed formatting of output plots are 
recommended with Exporting to Excel spreadsheet). 

10. Users are able to open the new v2023 Technical Manual in standard PDF file format. 
11. A new reporting tool introduces a pre-formatted Microsoft Word file that contains input data 

of the model along with a selection of output tables and charts. 

1.4 Organization of APILE Manuals 
The documentation provided with the computer program APILE consists of two volumes.  The 

User’s Manual contains full documentation about the operation of the program on personal computers.  The 
User’s Manual covers the areas of installation, preparation of input data, program execution, view of 
computational results, and example applications. 

The Technical Manual provides information about: the theory of pile behavior under axial loading, 
the semi-empirical equations for pile-capacity computation, the concept of load-transfer, and load-vs.-
settlement of piles in different types of soil strata.  The Technical Manual includes other helpful references 
related to concepts utilized in program APILE.   

ENSOFT holds a copyright of both manuals.  The manuals are distributed in protected Adobe© PDF 
file format to licensed users of the APILE program.  The content of these files/manuals cannot be copied 
and/or distributed to others unless specific written approval by ENSOFT. 

Both Manuals are installed with the APILE program and accessible via any one of the following 
three methods: i) from the Windows Start Menu, ii) from the Ensoft tile in Windows 11, 10, 8.1 and 8, or 
iii) from the Help menu within the APILE program. 

1.5 Typographical Conventions 
To orient the user to different software features, certain terms are set in typefaces that distinguish 

them from the body text.  The following formatting conventions are used throughout the Manual: 
• Commands that are typed directly on the keyboard: “Enter”; “F1”; “Esc”  

• Commands with keys simultaneously pressed in the keyboard: “Alt+F”; “Ctr+O”  

• Menu items and other text displayed on the screen are in sans serif:  
From the File menu choose Open  

• File names and names of directories and folder and icon names are in italics:  
Open the example file example1.sf10d 

• Internet and electronic mail addresses are underlined: 
Send email to support@ensoftinc.com 

mailto:support@ensoftinc.com
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1.6 Contents of the APILE Package 
The standard package sent with APILE consists of the following items: 
• One USB Key (sometimes known as hardware key or dongle), 

• One USB Memory Stick with installation programs for all Ensoft software products (this may 
be missing in future releases, since the full program is available for downloading from the 
www.ensoftinc.com website). 

 
Figure 1.1   Sample USB Key for Ensoft Software. 

1.7 Default Installation Directories 
The directories for installation of program files and for example files are selected by the user during 

program installation.  Default values are provided by the installer and confirmed or changed by the user. 

1.7.1 Directory for Main Program Files 

Program files are installed by default in the following directory:  

Root Drive:\Program Files (x86)\Ensoft\Apile2023 

In most cases the Root Drive is the c:\ drive so the default is: 

c:\Program Files (x86)\Ensoft\Apile2023 

Main program files are the following: 

Apile2023.exe is the main Windows-program module (executable/application), 

Apile2023.dll  is the program engine for direct computations, 

User’s and Technical Manuals are also included in the main installation directory. 

1.7.2 Directory for Example Files 

Several modeling examples with input files (files with name/extension of the type filename.sh9d) are 
installed on a separate folder that defaults to: 

Root Drive:\Ensoft\Apile2023-Examples 

In most cases the Root Drive is the c:\ drive so the default is: 

c:\Ensoft\Apile2023-Examples 

http://www.ensoftinc.com/
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1.8 Hardware Requirements  
To use APILE, the user needs the following minimum hardware configuration:  
• Any personal computer with an Intel® Pentium® or newer processor. 

• A hard disk with at least 50 MB of free space. 

• Microsoft Windows® 2000, XP, VISTA, Windows 7, Windows 8, Windows 8.1, Win 10 or 
Windows 11.  A newer release of the Microsoft Windows® operating system may need a more 
recent update of the SHAFT software. 

• Minimum of 640 KB of free RAM memory. 

• Open (available) USB port (v2 or newer). 

• A mouse or similar pointing device. 

• Optional: Any windows-compatible printer. 

1.9 Technical Support 
Although computer program APILE was designed to be distinguished by its ease of use and by the 

accompanying User’s and Technical Manuals, some users may still have questions.  The technical staff at 
ENSOFT strongly supports all licensed users with questions related to the installation or use of APILE.  For 
instance, we evaluate and troubleshoot when a specific model (input data file) provides some errors or when 
users have a specific question regarding an apparent discrepancy of results when comparing two different 
models/scenarios. However, our free services of technical support do not include free training or technical 
interpretations that would require engineering judgment. 

New software purchases include free maintenance service for the first year (included in purchase 
price).  After the first year the user is encouraged to purchase/renew the services for yearly maintenance.  
The yearly maintenance services include free download of the latest version and free technical support (as 
explained earlier). 

1.9.1 Preferred Methods of Software Support  

Software support is given, in order of preference, by the following methods:  
• Electronic mail to: support@ensoftinc.com 

• Fax to: (512) 244-6067 

• Telephone call to: (512) 244-6464, extension 2 

Users are strongly encouraged to utilize electronic means of support via email.  In all technical 
support requests via email, please include the following information: 

• full software version/release/update (obtained from the Help > About dialog), 

• a description of the user’s problem or concern, 
• attach a copy of the input-data file that is associated with the issue/concern (files with 

name/extension of the type filename.ap10d), and  
• name and telephone number of the contact person and of the licensed user (or name and office 

location of the licensed company site and/or serial number of the USB Key). 

mailto:support@ensoftinc.com
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Although immediate answers are offered on most technical support requests, please allow up to two 
business days for a resolution in case of difficulties or schedule conflicts. 

Technical help by means of direct calls to our local telephone number, (512) 244-6464, is available, 
but is limited to the business hours of 9 a.m. to 5 p.m. (US central time zone, UTC −6:00). The current 
policy of Ensoft is that all telephone calls for software support will be answered free of charge if the user 
has a valid maintenance contract. 

1.9.2 Upgrade Verification and Internet Site  

Starting from APILE v2018 the software provides options for the user to check the most recent 
maintenance release through an internet connection by selecting Help > Check for Updates from within 
the software.  This command starts the default internet browser and will display the user’s maintenance 
expiration date, the user’s software release number and the most recent release number that is available for 
downloading. 

If the user’s version is not the latest version and the maintenance has not expired, the user can 
download the latest version from our web server directly (www.ensoftinc.com).  Users may also consult 
our internet site for additional information on software updates, demos, and new applications; technical 
news; and company information. 

1.9.3 Renewal of Program Maintenance 

The cost to renew program maintenance will depend on the length of time for which the program 
maintenance has been expired.  There are small price increases with time after expiration.  The pricing 
policy for renewing a program maintenance that has not expired can be found on the Ensoft website at 
https://www.ensoftinc.com/order_form 

1.9.4 Changes of Support Policy  

The software support policy and associated expenses are subject to change at ENSOFT’s discretion 
and without specific mailed notices to the users. However, any change of rules will be verbally provided 
during telephone calls for software support.  

 
 

http://www.ensoftinc.com/
https://www.ensoftinc.com/order_form
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2.1 Installation Procedures 
Program APILE is distributed with an associated USB Key (hardware key or dongle, see Figure 1.1).  

The USB Key consists of a device that is attached to an empty USB port (or USB hub) of the computer in 
use (or in the designated License Manager/Server in the case of local network licenses).  This method of 
software protection has been found to provide compatibility with existing operating systems, better stability 
than other alternatives, and allows users to obtain software updates or replacements via downloads from 
the internet. 

Users with standard single-user licenses can check the following link to a PDF with Installation 
Notes: https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf 

Users with local network licenses can check the following link to a PDF with Network Installation 
Notes: https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf 

2.1.1 Installation of Single-User Version 

This version of APILE has been tested to be compatible with the following versions of the Microsoft 
Windows® operating systems: 2000, XP, Vista, and Windows 7 and 8, 8.1, 10 and 11 in 32 and 64-bit 
releases. 

The following guidelines are recommended during the installation process of APILE for single-user 
licenses. 
1. Plug the supplied USB Key (Figure 1.1) into one of the available and working USB ports in your 

computer.  The USB Key is plug-and-play compatible so the operating system will recognize the 
USB Key automatically and a small but solid green light should appear at the end of the USB Key (a 
flickering green light or no light indicate problems with the standard windows driver or with the 
USB Key). 

2. If the user installs from a distribution USB Memory Stick and the main installation program does not 
start automatically upon insertion of the Memory Stick then click on the Windows Start Menu 
button and select Run.  On the command line, type d:\setup.exe or e:\setup.exe, where d: or e: 
represents the drive that contains the distribution Memory Stick.  Click OK to execute the command 
and start the main installation program for ENSOFT’s software.  A screen similar to the one in 
Figure 2.1 should appear. 

3. If the user installs from a downloaded file, then please run the downloaded file (double click) and go 
to instruction #5. 

4. Click anywhere on the Apile 2023 icon and then click on the Install Standard button to start the 
installation of APILE. 

5. The user should read the license agreement shown in Figure 2.2.  Users can review the License 
Agreement online in the following link: 

https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf 
The installer will place the same file (Ensoft License and Disclaimer.pdf) in the installation 
directory.  Please click Yes if you agree and would like to proceed. 

6. Select Single-User License in Figure 2.3 then click Next.  For network installations please contact 
Ensoft support (support@ensoftinc.com). 

https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf
mailto:support@ensoftinc.com
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7. The user will be provided with an option to select a drive and directory for the installation of 
example files (see Figure 2.4).  Default installation directory is the following: 

(Root Drive):\Ensoft\Apile2023-Examples 
8. The user will also be asked to select a drive and directory for the installation of LPILE (see Figure 

2.5).  Default installation directory (varies according to the Windows release where it is installed) is 
one of the following: 

(Root Drive):\Program Files (x86)\Ensoft\Apile2023 
(Root Drive):\Program Files\Ensoft\Apile2023 

If the desired directory does not exist, the installation program will automatically create a new 
directory in the chosen hard drive. 

 

Figure 2.1   Main Installation Screen for ENSOFT Software (may change with time) 

9. During the installation the user will be asked to set the file extension association for opening APILE 
v2023 input data files (see Figure 2.6).  If the user agrees (leaves the default check mark) then 
double clicking (or running) any input data file with extensions of the type filename.ap10d will start 
the installed APILE v2023 software. 
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10. The user will be prompted to confirm the shortcut directory name that will be created in the 
Windows Start Menu (See Figure 2.7).  The default is Start Menu/Programs/Ensoft/Apile2023.  
Windows 11, 10 and 8 will automatically create an Ensoft tile with the same shortcuts. 

After the installation is finished, it is usually not necessary to reboot Windows for the program to 
run.  The user may run the program by selecting APILE v2023 from the standard links installed in the 
Microsoft Windows® Start Menu:  Start Menu > All Programs > Ensoft > Apile2023 

 

 
Figure 2.2   Installation screen with License Agreement (may change with time)  
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Figure 2.3   Selection of Single-User License (may change with time)  

 
Figure 2.4  Default Installation Directory for Example Files (may change with time) 
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Figure 2.5   Default Installation Directory for Program Files (may change with time)  

 

Figure 2.6   File Extension Association for APILE 2023 Data Files (may change with time)  
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Figure 2.7   Default Shortcut Folder in Windows Start Menu (may change with time)  

2.1.2 Introduction of Network Version 

Special network licenses and Net USB Key (network hardware key) are available for users that desire 
to operate APILE on a Windows network.  The network version is limited to users within a limited range 
of IP addresses that are employed at a specified licensed office site. 

Network versions of APILE have special subroutines written for installations in “software servers” 
(License Servers) and for installations of “individual clients” (Client Computers).  The “software server” is 
the computer that will be carrying the network key provided by ENSOFT, INC.  The software server is not 
necessarily the same as the existing network server.  Any computer in the existing Windows network may 
be designated software server for APILE as long as the Net USB Key is attached to a working USB port 
(or through an USB hub) and the “server” version of the software or of the Ensoft Utilities is installed on 
its hard drive. 

Software “clients” are other computers of the network that are accessed by employees of the licensed 
office site and that have the software installed as client.  Client computers do not need any hardware key or 
dongle attached to their local system.  The program installed in “client computers” will be allowed to run 
as long as the computer designated as “software server” is accessible on the network with the proper 
operating system and with its network key secured in place. 

2.1.2.1 Installation of Network Version 

Installers of network licenses should refer to a separate booklet with installation instructions for the 
Network version of this product.  The document can be downloaded from the Ensoft web site 
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(http://www.ensoftinc.com/updates/Ensoft Network Installation Notes.pdf) or can be requested via email 
to support@ensoftinc.com 

2.1.2.2 Silent Installations on Client Computers 

For installation of network licenses on local client computers there is an option for command-based 
installations that are completely silent (performed without other user input).  Instructions for silent 
installations on client computers can be downloaded from the Ensoft web site using the following link: 

http://www.ensoftinc.com/updates/Silent Install on Client Computers.pdf 

Alternatively, the document can be requested via email to support@ensoftinc.com 

2.1.3 Backup of Original Software 

The distributed software may be copied for backup purposes. The program may be installed in several 
computers at the same time.  However, unless network licenses are purchased, the program will only operate 
in computers that carry the appropriate hardware key. 

2.1.4 Software Updates on the Internet 

Occasionally, ENSOFT will produce software improvements and/or fixes and place the latest 
software programs on ENSOFT’s internet site.  Users can check for available updates by selecting Help > 
Check for Updates from the SHAFT menu.  Software users may freely download the latest program 
update from the PRODUCTS > Downloads link in the following site:  http://www.ensoftinc.com 

2.2 Getting Started 
A general diagram showing the menu choices and operational flow chart of program APILE is 

presented in Figure 2.8.  The following paragraphs provide a short description of the operational features 
of APILE and should quickly enable the user to get started with the program.  

http://www.ensoftinc.com/updates/Ensoft%20Network%20Installation%20Notes.pdf
mailto:support@ensoftinc.com
http://www.ensoftinc.com/updates/Silent%20Install%20on%20Client%20Computers.pdf
mailto:support@ensoftinc.com
http://www.ensoftinc.com/
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Figure 2.8   Sample organization and operational flow chart  

 

2.2.1 Starting the Program 

The program is started by double clicking the left mouse button anywhere in the APILE icon.  A new 
window will appear on the screen, with the following top-menu choices: File, Data, Options, 
Computation, Graphics, Window, and Help. 
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2.2.2 File Management 

The File menu option contains five standard entries, as shown in Figure 2.9; they are: 
• New to create a new data file. 
• Open… to open an existing data file. 
• Save to save input data under the current file name. 
• Save As… to save input data under a different file name. 
• Exit to exit program APILE. 
• Other entries include quick access to a history of up to 10 recently-opened files. 

 

 
Figure 2.9   Sample File Menu 

Several additional files are created in every new APILE run.  A general description of these files is 
presented in Table 2.1.  Every run of APILE generates these text files in the same drive and directory where 
the input-data file was saved or opened.  Any of these files may be opened with standard text editors or 
word processing programs. 
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File Name 
Extension 

Usage 
Description 

File 
Format 

Example 
Files 

*.ap10d Input-data file Text file example1.ap10d 
example2.ap10d 

*.ap10o Output-data file Text file example1.ap10o 
example2.ap10o 

*.ap10p Plot-data file Text file example1.ap10p 
example2.ap10p 

*.acpt CPT-data file Text file example1.acpt 
example2.acpt 

*.gwi GRLWEAP-data file Text file example1.gwi 
example2.gwi 

*.srp GRLWEAP 14-data 
file Text file example1.srp 

example2.srp 

Table 2.1   Files created in APILE runs 

2.2.3 Data Menu 

The Data menu contains several entries, as shown in Figure 2.10.  The entries are listed below, along 
with a general description of their use.  Some entries may be disabled since they depend on other input 
selections specified under the Data menu. 

Title ..................  to enter a single line of text with a general description for the project. 

Computational Method . ..the user may select any one of the four (regular version) to eight (offshore 
version) methods of internal computation of load-vs-settlement and one or more methods 
of pile capacity, or the user may choose to input specific values of unit load transfers.  The 
user can also specify in this menu the usage of reduction factors for LRFD analyses. 

Pile Material.. . used to enter the material type of piles such as steel piles, prestressed concrete piles, timber 
piles, etc.  This selection also provides control for values that are used in computations of 
elastic deformation of the pile. 

Circular-Section Pile ..... to describe dimensions and material properties of piles with circular sections.  
This menu also provides a selection of computations of pile plugging. 

Noncircular-Section Pile…to describe dimensions and material properties of piles that are not circular. 

Soil Layers ...... this is used to define the type and depth of each soil layer and to enter the associated soil 
parameters.  Users are able to edit layers using the standard APILE table or with the new 
CPT interpreter (if data was imported from a CPT file). 

Import CPT Data .......... this submenu is optional and is used to read an external file containing data from 
the cone penetration test (CPT) which can be analyzed for soil layering into APILE. 
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Figure 2.10   Sample Data Menu 

2.2.4 Options Menu 

The Options menu is provided for the control of program variables and preferences.  The listing of 
menu options is shown in Figure 2.11 and the different choices are briefly described below.  The user may 
select any of the entries without concern for the sequential order. 

Units ................ the user may select either English Units (using kips, feet and inches) or S.I. Units (using 
kN, meters and millimeters).  English units are enabled, as a default, for all new runs.  The 
user may change the system of units as many times as desired and values that were 
previously input will be automatically converted by the program to the new selection of 
units. 

Print t-z Curves at Additional Depths…Although the program generates t-z curves at the top, the middle, 
and the bottom of each soil layer, the user may ask the program for printing of additional 
t-z curves at user-specified depths.  The depth of t-z curves is zero at the ground surface 
and it cannot exceed the tip of the pile. 

Control Options .............. the user may select the length of each computation increment and also how often 
to print results.  The observation of text files associated with APILE (input, output or 
processor notes) is done using the text editor that is here selected by the user.  The user 
should input in this box the complete path and command line for the preferred text editor 
or word processor that will be used to examine and print the input, output and processor 
plain text files created by the program.  As a default, the command line 
c:\windows\notepad.exe is used to operate the standard text editor Microsoft Notepad that 
is normally included with all Windows installations. 

 

 

Figure 2.11   Options Menu 
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2.2.5 Computation Menu 

The Computation menu is provided to run the analytical computations after all data are entered and 
saved.  After the computation is executed successfully this menu also provides options for the reviews of 
plain-text input data, notes produced during computation, and output data.  It also provides an option for 
the graphical observation of the modeled pile and soil layers.  Choices under the Computation menu, 
shown in Figure 2.12, are briefly described below. 

Run Analysis ..  ............... this option is chosen to run the analytical computations.  This option should be 
selected after all data have been entered and saved. 

Edit Input Text  ............... this option calls the chosen Text Editor (selected under Options > Text Editor) 
to observe and/or edit the analytical input data in plain-text format.  The option becomes 
available after the input data has been saved to disk, or when opening an existing input-
data file. 

Edit Processor-Run Notes ............... this option calls the chosen Text Editor (selected under Options > 
Text Editor) to observe, format, and/or print the notes provided during processing.  This 
menu becomes available only when an error is detected after a run command 
(Computation > Run Analysis).  The user is encouraged to read the processor-run notes 
when the APILE model is not running successfully.  The processor-run notes may provide 
the user with some additional information about possible causes of the problem. 

Edit Output Text ............. this option calls the chosen Text Editor (selected under Options > Text Editor) 
to observe, format, and/or print the analytical-output data.  The option becomes available 
only after a successful run has been made.  Certain output files may be too large for the 
Microsoft Notepad editor, so other text editors would have to be used (Microsoft Word Pad 
should be able to open most text files). 

3D View ........... for a three-dimensional representation of the modeled pile, soil layers, layer depths, and 
graphical plots of axial capacity vs. pile penetration. 

View GRLWeap Data .... calls the chosen Text Editor (selected under Options > Text Editor) to display 
the internally-generated data which are needed for pile-drivability study with the separate 
GRLWEAP software.  The program prints and saves the distribution of the side friction 
based on the format requested by GRLWEAP software.  The user is encouraged to verify 
the pile dimension/property data and to select the proper driving hammer after the data file 
is accepted by GRLWEAP. 
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Figure 2.12   Computation Menu 

2.2.6 Graphics Menu 

The Graphics menu can be accessed for a quick observation of plots of output data provided after a 
successful computational run of an APILE model.   

Choices for the observation of output curves under this menu are only enabled after a successful 
computational run.  Even after performing successful runs, some choices may still be disabled since the 
output data depends on specifications provided in the input file of each model.  The various choices, shown 
in Figure 2.13, are briefly described below. 

Unit Skin Friction vs Depth .............. provides a plot of unit load transfers in side resistance (skin friction) 
versus depth of the modeled pile according to computational methods for pile capacity that 
were selected by the user. 

Accumulated Skin Friction vs Depth…provides a plot of accumulated load transfers in side resistance 
(skin friction) versus depth of the modeled pile according to computational methods for 
pile capacity that were selected by the user. 

Tip Resistance vs Depth…. provides a plot of ultimate end bearing (tip resistance) versus depth of the 
modeled pile according to computational methods for pile capacity that were selected by 
the user. 

Total Capacity vs Depth…. provides a plot of the ultimate total capacity (skin friction plus tip resistance) 
versus depth of the modeled pile according to computational methods for pile capacity that 
were selected by the user. 

Load Distribution…. provides a plot of distributions of axial loads versus depth of the modeled pile 
according to the computational method for load-vs-settlement that was selected by the user. 

Combined Plot…. provides a plot of ultimate skin friction, ultimate tip resistance, and the ultimate total 
capacity versus depth on a single graph, according to the computational method for load-
vs-settlement that was selected by the user. 

Axial Load vs Settlement…. provides a plot of the axial loads versus settlement at the pile head based on 
t-z curves and Q-w curves, according to the computational method for load-vs-settlement 
that was selected by the user. 
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Internally-Generated t-z Curves…. provides a plot of the t-z curves generated by the program at the top, 
the middle, and the bottom of each soil layer, according to the computational method for 
load-vs-settlement that was selected by the user.. 

Extra t-z Curves at User-Specified Depths….this menu is only enabled for certain models, it provides 
a plot of the t-z curves generated by the program at user-specified depths. 

Internally Generated Q-w Curve…. provides a plot of the Q-w (tip resistance vs. movement) that was 
generated according to the computational method for load-vs-settlement that was selected 
by the user. 

Neutral Plane Analysis (Downdrag – FHWA)…. provides an option to determine the FHWA 2016 
approximate method for downdrag design. 

Exports Plots to Excel….this allows the user to export some (or all) of the above plots to an excel file. 
Each plot will be exported to two sheets, one contains the data and the second the chart. 

Print Soil Profile….this menu prints out an elevation view of the modeled pile along with the soil profile 
including depths and major mechanical properties of each soil layer. 

 

 

Figure 2.13   Sample Graphics Menu 

2.2.7 Arrangement of Windows 

The Window menu provides two standard functions for organizing opened windows and/or 
minimized window icons.  Submenu options, shown in Figure 2.14, are briefly described below. 

Cascade .......... this option organizes all open-windowed menus so that all become visible with their tops 
cascading from the top left portion of the screen. 
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Arrange Icons .  ............... this option organizes the icons of all minimized windowed menus so that all 
become visible and aligned at the bottom portion of the screen. 

Other entries under the Window menu are names of any open windows or plot file, that the user may 
select to navigate between open windows. 

 

 

Figure 2.14   Window Menu 

2.2.8 Help Files 

 The Help menu provides access to the software manuals (PDF files) and to some helpful utilities 
that the user may need when running the program.  Submenu options, shown in Error! Reference source 
not found., are briefly described below. 

Ensoft Key Inquirer........ this choice is only available for single-user licenses (not available in local 
network licenses). This utility allows the user to check information contained in the USB 
Key that is attached to the computer in use.  With this utility the user can see the following 
information: dongle serial number and expiration date, licensed program names and type 
of licenses, maintenance expiration date of each software license, licensed company name, 
allowed IP subnets.  This utility is installed in the selected installation directory with the 
following filename: ensoft_key_inquirer_v5.exe (may change with time). 

Check Network Dongle .   this choice is only available in client computers of local network licenses (not 
available in single-user licenses).  This calls the utility that is used to check the licensing 
and to troubleshoot communications with a license manager (or software server).  This 
utility is very useful in case of problems in clients while trying to run the licensed software.  
This utility is installed in the selected installation directory with the following filename: 
CheckNetworkDongle_ipv_512.exe (may change with time). 

User’s Manual  ............... this selection calls for any installed PDF reader (Adobe Acrobat, Acrobat Reader 
or similar) to open the User’s Manual.  This document is formatted as a protected PDF file. 

Technical Manual ..........  this selection calls for any installed PDF reader (Adobe Acrobat, Acrobat 
Reader or similar) to open the Technical Manual.  This document is formatted as a 
protected PDF file. 

About.. ............. this screen describes the program version, date, maintenance expiration date, USB serial 
number and methods for accessing technical support. 

Check for Updates ........ starts the default Internet browser and sends the user to a page that describes 
information about the user’s license (release and maintenance expiration date) as well as 
the latest release that is available for downloading at the Ensoft site.  Users may only run 
in full mode maintenance updates that were released before the expiration date of the user’s 
license. 
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 a. Single-User License b. Client on Local Network License 

Figure 2.15   Help Menu 
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3.1 File Menu 
This menu contains options related to the management of input-data files and to exit the program.  

Input-data files created for APILE are provided with a standard file-name extension in the form of 
*filename*.ap10d (where *filename* represents any allowable file name).  All input data files are standard 
text files and may be edited with any text editor or word-processing program. 

3.1.1 File Menu Speed Buttons 

The first group of three speed buttons at the left side of the button bar (shown in Figure 3.1) provides 
access to the following commands (from left to right): File > New, File > Open, and File > Save. 

 

Figure 3.1   Speed Buttons for the File Menu (within rounded rectangle) 

3.1.2 File > New 

Once the program is started, default values are used for certain operating parameters and a blank 
input-data file is created.  Selecting New under the File menu resets all APILE variables to either 
default or blank values, as appropriate.  This option should be selected when a new data file is 

desired to be created from a blank form.  This menu option may also be accessed with the Ctrl+N keyboard 
combination. 

3.1.3 File > Open 

This is used to open a file that has been previously prepared and saved to disk. The File > Open 
window dialog, shown in Figure 3.2, is used to search and open an existing input-data file.  By 
default, the file is initially searched in the directory where APILE was installed.  Standard 

windows-navigation procedures may be used to locate the name and directory of the desired project file.  
This menu option may be accessed with the Ctrl+O keyboard combination. 

Every analytical run of APILE produces several additional files (previously described in Table 2.1 
of this manual).  The name of the input-data file indicates the names of all related files produced by a 
successful program run (output, graphics, and processor text files).  All the additional program files will be 
created in the same directory as the input data file.  Input-data files that are partially completed may be 
saved and later opened for completion, run, and observation of results. 

Opening some partially-completed APILE input files or invalid data files (or files with incorrect data 
formats) may produce an information window reporting that an “invalid or incomplete” file is being opened 
(Figure 3.3).  The user should click the OK button and all partial-input data that was previously prepared 
should become available. 
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The program allows users to read input-data files created by previous APILE versions (*.apd, *.ap6d, 
*.ap7d, *.ap8d and *.ap10d file extensions) by selecting the drop-down arrow at the bottom right corner of 
the File > Open window screen.  The program will automatically convert the opened previous APILE input 
file to the current version of APILE when the user saves the opened file. 

 

 
Figure 3.2   File > Open Dialog 

 
Figure 3.3   Sample message for incomplete or invalid file 

3.1.4 File > Save 

This selection is used to save input data under the current file name.  With this method of storing 
data to disk, any input data that was previously saved with the same file name is replaced with 
the current parameters.  Input-data files should be saved every time before proceeding with runs 

for analytical computation.  This menu option may also be accessed with the Ctrl+S keyboard combination. 
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3.1.5 File > Save As 

This selection allows the user to save any opened or new input data file under a different file name 
or different directory.  Any input data file saved under an existing file name will replace the contents of the 
existing file. 

3.1.6 File > Exit 

This is selected to exit APILE.  Any input-data file that was modified and not yet saved to disk will 
produce a confirmation window before exiting the program (see Figure 3.4). 

 
Figure 3.4   Message window advising that changes were not saved to disk 

3.2 Data Menu 
The input of specific parameters for an application is controlled under options contained within this 

menu (shown in Figure 3.5).  It is recommended that the user choose each submenu and enter parameters 
in a sequential order starting from the top. 

Selecting or clicking any of the submenu choices contained in the Data menu produces various types 
of windows.  As a reminder of standard commands of Microsoft Windows®, open windows may be closed 
by all or some of the following methods: 

• clicking the OK button (if available),or 
• clicking the X-box on the upper-right corner of the window, or 

• pressing the “Ctrl+F4” keyboard combination, or 

• double-clicking the APILE icon on the upper-left corner of the window, or 

• clicking once on the APILE icon on the upper-left corner of the window and then choosing 
Close. 

Many sub-windows of the Data menu will show an Add Row, Insert Row and/or Delete Row 
buttons.  The Add Row button always adds new rows at the end after all existing rows.  The Insert Row 
button always inserts a new row below the row where the cursor is located.  Clicking on the Delete Row 
button deletes the row where the cursor is located. 
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Figure 3.5   Sample Data Menu 

3.2.1 Numeric Data Entries 

Cells that require numeric data may accept entries of mathematical expressions in addition to simple 
numeric entries.  Entering a mathematical expression works similarly to normal numeric data.  The user 
types the expression that represents the data and presses the Return key to calculate the entered expression 
and to display the numeric result in the same cell. 

Table 3.1 below shows the list of supported operations and constants.  The order of operations 
follows the order in the list of Table 3.1.  Note that implicit multiplication (i.e. 2(4+6)) is not supported 
(instead, use 2*(4+6) for the previous example). 
 

 OPERATORS  
Symbol  Description  

()  Parenthesis (may be nested)  
^  Exponentiation  
*  Multiplication  
/  Division  
+  Addition  
- Subtraction  
- Negation (same as subtraction)  
  
 CONSTANTS  

Symbol  Value  
PI (or pi)  3.1415927  
e (or E)  2.7182818  

Table 3.1   Supported mathematical operations and constants 

The two constants that are currently supported are PI and e.  Implicit multiplications using constants 
is not supported (use 2*e instead of 2e).  Negation of the constants PI or e is not allowed.  For instance, 
instead of entering -PI the user must enter - (PI). 

Scientific notation (i.e. 1.65e8 or 1.65e-8) may be used to input very large or very small numbers.  
After an expression is calculated, very large or very small numbers will be displayed using scientific 
notation. 
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3.2.2 Data Menu Speed Buttons 

The second group of six speed buttons at the left side of the button bar (shown in Figure 3.6) provides 
access to the following commands (from left to right): Data > Title, Data > Computation Method, Data 
> Pile Material, Data > Circular-Section Pile, Data > NonCircular-Section Pile, and Data > Soil 
Layers. 

 

Figure 3.6   Speed Buttons for the Data Menu (within rounded rectangle) 

3.2.3 Data > Title 

This selection activates the window shown in Figure 3.7, where the user can enter a line of text 
containing a general description for the application problem.  Any combination of characters may 
be entered in the text box in order to describe a particular application.  The user input will be 

restrained automatically once the maximum length of text is reached.  This is done to prevent the user from 
going beyond the maximum permissible length of characters allowed for the title line. 
 

 
Figure 3.7   Sample Data > Title 

3.2.4 Data > Computational Methods 

The selection provides a dialog box window with two tabs, shown in Figure 3.8   
Data > Computational Methods > Method for Pile Capacity 
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 and Error! Reference source not found.  (some options in these tabs may be grayed out since they are 
only available for the APILE Offshore Version): Method for Pile Capacity and Method for Load 
Settlement.  Within these tabs, the user can respectively select the preferred method for computations of 
pile capacity and for computations of load-vs-settlement curves (i.e., instructions for generation of t-z and 
Q-w curves). 

3.2.4.1 Method for Pile Capacity 

For computations of axial pile capacity, the APILE program offers four methods for the Standard 
Version and four additional methods for the Offshore Version.  Alternatively to those embedded methods, 
the user may also select to input any arbitrary unit load transfers in skin friction and end bearing at top and 
bottom of each soil layer in the model.  The user may select a single method, several, or all methods to 
compare results from various recommendations.  APILE automatically selects the method that is selected 
by the user for computations of load-vs-settlement (the selection is preceded by the words LS in the Method 
for Pile Capacity tab). 

The automated computation methods for pile capacity in APILE are the following: 

FHWA .............. uses recommendations from the Federal Highway Administration (FHWA) of the United 
States.  The theoretical background of this method is included in Section 3.5 of the APILE 
Technical Manual. 

USACE .......... uses recommendations from the United States Army Corps of Engineers.  The theoretical 
background of this method is included in Section 3.4 of the APILE Technical Manual.  For 
this particular method, the user is offered an additional control regarding the critical depth 
that should be used in sand layers (see Section 3.4 of the APILE Technical Manual): 

Critical Depth Method for Sand ....... For design purposes, USACE established that the skin friction of 
piles in sand increases linearly to an assumed critical depth (Dc) and then remains constant 
below that depth.  APILE provides the users with some control regarding this limitation to 
increases in load transfers of side resistance in sand. 

 Original Recommendations With this selection, APILE will use the original USACE 
code with a critical depth (Dc) that depends on sand density, which is equal to 10 pile 
diameters in loose sand, 15 pile diameters in medium sand and 20 pile diameters in dense 
sand.  For multiple layers, the criteria that is used depends on the soil layer at the pile tip 
and the computations of depth always starts from ground surface. 

 At Effective Stress Reaching 3,500 psi (185 kPa)…With this selection, APILE will 
use a critical depth equal to the one where the effective stress (γ’z) reach 3,500 lb/in2 (185 
kPa).  This selection has been opted for practical reasons by some engineers when modeling 
multiple soil layers. 

 At User-Specified Critical Depth…With this selection, APILE will use a critical depth 
that is here entered by the user, in ft or meter.  This option is provided by APILE since 
some engineers that employ the USACE method may not want to limit the increases of 
transfers in side resistances in sand (thus entering a depth that is equal to the pile length) 
or want to see the effects of entering a different depth than those from the original USACE 
method. 
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 Use Long-Pile Option (for Alpha)…A check mark on this selection box instructs APILE 
to calculate values of α (alpha) for side resistance in cohesive soils that correspond to long 
piles.  If this box has no checkmark, the program will calculate regular alpha values as 
defined in Figure 3.5 of the Technical Manual.  If this box has a checkmark, then the 
program will calculate long-pile alpha (α1 and α2) values as defined in Figure 3.6 of the 
Technical Manual. 

Revised Lambda............ uses recommendations from Vijayvergiya and Focht (1972), also known as the 
“Lambda method.”  The theoretical background of this method is included in Section 3.3 
of the APILE Technical Manual. 

API RP 2A  ..... uses Recommended Practice 2A of the American Petroleum Institute, also known as the 
“revised API method” (2007).  The theoretical background of this method is included in 
Section 3.2 of the APILE Technical Manual. 

Load Transfers Specified by User…in addition to the internal methods of computations provided by the 
program, the user also has the option to specify any values of load transfers by selecting 
this method of computation.  With this selection, the user can enter unit load transfers in 
skin friction and end bearing for top and bottom of each soil layer under Data > Soil 
Layers > Edit Layer x. 

NGI .................. (available only for the “APILE Offshore” version) uses CPT-based semi-empirical 
formulations recommended by the Norwegian Geotechnical Institute in 1999.  The 
theoretical background of this method is included in Section 3.6 of the APILE Technical 
Manual. 

ICP/MTD  ....... (available only for the “APILE Offshore” version) uses CPT-based semi-empirical 
formulations recommended by the Imperial College in 2005.  The theoretical background 
of this method is included in Section 3.7 of the APILE Technical Manual. 

 For this particular method, the user must also select whether the loading produces drained 
or undrained conditions for end bearing in clay layers (see Section 3.7.3.2 of the APILE 
Technical Manual): 

 Use Drained Condition for Clay  some users tend to evaluate long-term behavior 
by the assumption of drained conditions in the cohesive soil. 

 Use Undrained Condition for Clay  this is the default and most common condition, 
though some users relate this condition to short-term responses. 

FUGRO ........... (available only for the “APILE Offshore” version) uses CPT-based semi-empirical 
formulations recommended by Fugro in 2004.  The theoretical background of this method 
is included Section 3.8 of the APILE Technical Manual.  

UWA  ............. (available only for the “APILE Offshore” version) uses CPT-based semi-empirical 
formulations recommended by the University of Western Australia (UWA), Perth in 2005.  
The theoretical background of this method is included in Section 3.9 of the APILE 
Technical Manual. 

Type of Loading - Compression or Tension 
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The user may specify either compressive loading or tensile loading with these radio buttons.  If the 
tensile loading is selected, the user may enter a reduction factor on side friction which is applicable only 
with the API method.  For other methods (outside API) this tensile reduction factor is not taken into account 
since the APILE program will follow the recommendations from each theory (see Chapter 3 of the APILE 
Technical Manual). 

3.2.4.2 Method for Load-vs-Settlement 

The computations of load-vs-settlement involves two procedures: i) computation of the unit-load 
transfers, and ii) computation of the shape of the nonlinear, load-transfer curves (t-z and Q-w). 

The APILE program automatically selects the nonlinear shape of the load-transfer curves (t-z and Q-
w) based on two methods, as indicated in the notes of Figure 3.8.  The method for USACE (*) is based on 
the theories of Reese/Mosher/Skempton referenced in Table 3.2 which are also described in Chapter 4 of 
the APILE Technical Manual (Section 4.4 through Section 4.7). 

All other methods (FHWA, Revised Lambda, API, etc) are based on the recommendations from the 
American Petroleum Institute (API RP 2A-WSD, 2014) which are also described in Section 4.8 of the 
APILE Technical Manual. 

Type of Load 
Transfer Type of Soil 

Method for Shape of Load-
Transfer Curve 

Side Resistance 
Cohesive Coyle & Reese (1966) 

Cohesionless Mosher (1984) 

End Bearing 
Cohesive Skempton (1951) 

Cohesionless Vijayvergiya & Mosher (1984) 

Table 3.2   Shape of Nonlinear Load-Transfer Curves from Reese/Mosher/Skempton 

For computations of unit load transfers, the APILE program offers four methods for the Standard 
Version and four additional methods for the Offshore Version.  Alternatively to those embedded methods, 
the user may also select to input any arbitrary unit load transfers in skin friction and end bearing at top and 
bottom of each soil layer in the model. 

The automated computation methods for unit load transfers in APILE are the following: 

FHWA .............. uses recommendations from the Federal Highway Administration (FHWA) of the United 
States.  The theoretical background of this method is included in Section 3.5 of the APILE 
Technical Manual.  When the user selects this method of computation for unit-load 
transfers, the APILE program automatically uses the API RP 2A (Section 4.8 of the APILE 
Technical Manual) for computations of the shape of the load-transfer curves. 

USACE .......... uses recommendations from the United States Army Corps of Engineers.  The theoretical 
background of this method is included in Section 3.4 of the APILE Technical Manual.  
When the user selects this method of computation for unit-load transfers, the APILE 
program automatically uses the Method (*) (Reese/Mosher/Skempton in Table 3.2) for 
computations of the shape of the load-transfer curves. 

Revised Lambda............ uses recommendations from Vijayvergiya and Focht (1972), also known as the 
“Lambda method.”  The theoretical background of this method is included in Section 3.3 
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of the APILE Technical Manual.  When the user selects this method of computation for 
unit-load transfers, the APILE program automatically uses the API RP 2A (Section 4.8 of 
the APILE Technical Manual) for computations of the shape of the load-transfer curves. 

API RP 2A  ..... uses Recommended Practice 2A of the American Petroleum Institute, also known as the 
“revised API method” (2014).  The theoretical background of this method is included in 
Section 3.2 of the APILE Technical Manual.  When the user selects this method of 
computation for unit-load transfers, the APILE program automatically uses the API RP 
2A-WSD (Section 4.8 of the APILE Technical Manual) for computations of the shape of 
the load-transfer curves. 

Load Transfers Specified by User…in addition to the internal methods of computations provided by the 
program, the user also has the option to specify any values of load transfers by selecting 
this method of computation.  When the user selects this method of computation for unit-
load transfers, the APILE program automatically uses the API RP 2A (Section 4.8 of the 
APILE Technical Manual) for computations of the shape of the load-transfer curves. 

NGI .................. (available only for the “APILE Offshore” version) uses CPT-based semi-empirical 
formulations recommended by the Norwegian Geotechnical Institute in 1999.  The 
theoretical background of this method is included in Section 3.6 of the APILE Technical 
Manual.  When the user selects this method of computation for unit-load transfers, the 
APILE program automatically uses the API RP 2A (Section 4.8 of the APILE Technical 
Manual) for computations of the shape of the load-transfer curves. 

ICP/MTD  ....... (available only for the “APILE Offshore” version) uses CPT-based semi-empirical 
formulations recommended by the Imperial College in 2005.  The theoretical background 
of this method is included in Section 3.7 of the APILE Technical Manual.  When the user 
selects this method of computation for unit-load transfers, the APILE program 
automatically uses the API RP 2A (Section 4.8 of the APILE Technical Manual) for 
computations of the shape of the load-transfer curves. 

FUGRO ........... (available only for the “APILE Offshore” version) uses CPT-based semi-empirical 
formulations recommended by Fugro in 2004.  The theoretical background of this method 
is included Section 3.8 of the APILE Technical Manual.  When the user selects this method 
of computation for unit-load transfers, the APILE program automatically uses the API RP 
2A (Section 4.8 of the APILE Technical Manual) for computations of the shape of the load-
transfer curves. 

UWA  ............. (available only for the “APILE Offshore” version) uses CPT-based semi-empirical 
formulations recommended by the University of Western Australia (UWA), Perth in 2005.  
The theoretical background of this method is included in Section 3.9 of the APILE 
Technical Manual.  When the user selects this method of computation for unit-load 
transfers, the APILE program automatically uses the API RP 2A (Section 4.8 of the APILE 
Technical Manual) for computations of the shape of the load-transfer curves. 

Factors for t-z and Q-w Curves 
Unfactored ...... the selection of this radio button will use the LRFD factors (on Side Friction and End 

Bearing) that are inputted by the user for each soil layer under Data > Soil Layers (entries 
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in the last two columns) and apply them only to pile capacity and not to t-z nor Q-w curves.  
This is the default and expected selection for most applications, even for users of the LRFD 
method from AASHTO.  This is because LRFD resistance factors are only applicable to 
pile capacity and not to load-vs-settlement. 

Reduced ......... the selection of this radio button will use the LRFD factors (as t-multipliers for t-z curves 
and Q-multipliers for Q-w curves) that are inputted by the user for each soil layer under 
Data > Soil Layers (entries in the last two columns).  This selection may be preferred by 
users for special analytical cases, such as hypothetical computations of load-vs-settlement 
for evaluations of losses of strength during pile driving or to match measured load-test data. 
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Figure 3.8   Data > Computational Methods > Method for Pile Capacity 
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Figure 3.9   Data > Computational Methods > Method for Load vs Settlement 
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3.2.5 Data > Pile Material 

This selection allows the user to select the pile type and pile material that are used for the driven 
pile.  An illustration of the Pile Material window for an example application is shown in Figure 
3.12.  A general description for the data needed in the Data > Pile Material submenu is listed 

below. 

3.2.5.1 Select Pile Type 

The user may select one of the following pile types: 

Steel pipe piles and non-tapered portion of monotube piles… includes any steel pile with circular 
section or for circular tubing.  Piles with a taper (changing diameter) can be considered 
here but the extra load transfer from the tapered portion will be ignored when using this 
selection. 

 Open-Ended Pile…specifies that the pipe pile is driven open ended.  With an Open-
Ended Pile the user will have the option to select a method to calculate the internal pile 
plug (under Data > Circular-Section Pile).  For the FHWA method (see Section 3.5 of 
the APILE Technical Manual), this entry also determines the influence in pile capacity due 
to the displaced volume. 

 Close-Ended Pile… specifies that the pipe pile is driven close ended.  With a Close-
Ended Pile the user will not have any option for the internal pile plug (under Data > 
Circular-Section Pile).  For the FHWA method (see Section 3.5 of the APILE Technical 
Manual), this entry also determines the influence in pile capacity due to the displaced 
volume. 

H-Piles/Steel Shapes…this selection includes any steel pile that is not circular in section, such as H-piles 
or wide flanges that are used as driven piles. 

Precast concrete piles…this is for any type of concrete pile, where the user also selects if the pile section 
is circular or not.  If circular pile then the user may also select if Open-Ended Pile or 
Close-Ended Pile (see comments above). 

Tapered portion of monotube piles…this selection is for steel piles with varying circular section.  The 
theory for extra load transfer from the angle of pile taper is only applicable to the FHWA 
method (see Section 3.5 of the APILE Technical Manual).  For this pile type, the angle of 
pile taper should be entered by the user in degrees and is measured from the vertical (less 
than 90 degrees), where an entry of 0 indicates a straight pile. 

Raymond step-taper piles…this selection is for specialized steel piles that are composed of several short 
sections of varying diameters that are joined together to form the pile, that is normally 
referred as “step taper.”  The theory for extra load transfer from Raymond step-taper piles 
is only applicable to the FHWA method (see Section 3.5 of the APILE Technical Manual). 

Raymond uniform-taper piles…this selection is for Raymond steel piles with uniformly varying circular 
section.  The theory for extra load transfer from the angle of pile taper is only applicable 
to the FHWA method (see Section 3.5 of the APILE Technical Manual).  For this pile type, 
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the angle of pile taper should be entered by the user in degrees and is measured from the 
vertical (less than 90 degrees), where an entry of 0 indicates a straight pile. 

Timber piles…this selection is for timber piles with uniformly varying circular section (more common) or 
even applicable to straight timber (not used often).  The theory for extra load transfer from 
the angle of pile taper is only applicable to the FHWA method (see Section 3.5 of the 
APILE Technical Manual).  In addition to elastic deformation, a distinction for the response 
of timber piles (based on pile material) is also provided by the USACE method (see Section 
3.4 of the APILE Technical Manual). 

 

Figure 3.10   Data > Pile Material 
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Angle of taper for a tapered pile…For any pile type selected as tapered, the angle of pile taper should be 
entered by the user in degrees and is measured from the vertical (less than 90 degrees), 
where an entry of 0 indicates a non-tapered (straight) pile.  The analysis of tapered piles is 
only envisioned in the FHWA codes (Data > Computational Method > Method for Pile 
Capacity).  For capacity computations in methods other than FHWA, the APILE software 
will use the reduced end bearing that corresponds to the area at the tip of the pile.  However, 
for side resistance (in methods other than FHWA), the program will use for the complete 
pile length the surface area that corresponds to the top diameter. 

3.2.5.2 Data for Axial Stiffness 

The entries in this section are only used to calculate the elastic deformation of the pile (which has a 
direct effect on load-vs-settlement) and thus do not have any effect in computations of pile capacity. 

Modulus of Elasticity, E…this number (always positive) represents the elastic modulus of the pile.  The 
elastic modulus of the pile is used for load-vs-settlement analysis to calculate the elastic 
deformation of the pile.  The English unit for this variable is “psi” or “lb/in2“ while “kPa” 
or “kN/m2“ is used for SI units. 

Cross Section Area 
Calculate from Pile Section…the selection of this radio button instructs APILE to calculate a cross-

sectional area of the pile automatically based on input from the user under Data > Circular-
Section Pile (Outer Diameter and Inner Diameter) or under Data > Noncircular-
Section Pile (Tip Area for Noncircular Section).  Notice that for H piles and pipe piles 
the user may select a close-ended section for capacity analysis but should use only the 
metal (steel) area for elastic deformation.  For those cases, the user may need to enter a 
different area using the next option below.  The automatically calculated entry in this radio 
button is provided in units of “in2” when using English units or in “m2” when using SI 
units. 

Constant Cross Section Area…the selection of this radio button instructs APILE to use any cross-
sectional area that is here entered by the user.  This is particularly important for pipe piles 
and H piles (or wide flanges) since the value that is here entered is normally only the metal 
(steel) area, even if the pile is closed ended for capacity calculations.  For solid piles 
(concrete/timber) the value that is here entered is the gross cross-sectional area.  The entry 
in this radio button shall be provided in units of “in2” when using English units or in “m2” 
when using SI units. 

Non-Constant Cross Section Area…the selection of this radio button instructs APILE to use the 
variations of cross-sectional areas that are here entered by the user.  For proper 
computations of elastic deformation with any type of tapered pile, the user must select this 
option and enter the cross-sectional areas.  A minimum of two entries (top and bottom of 
section or pile) must be specified and APILE interpolates linearly between entries. 

 Data Button .............. The entries of Distance from pile head in this table shall be 
provided in units of “ft” when using English units or in “m” when using SI units.  The 
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entries of Cross section area in this table shall be provided in units of “in2” when using 
English units or in “m2” when using SI units. 

3.2.5.3 Self-Weight of Piles 

The self weight of the modeled pile is automatically calculated by APILE and added to the uplift 
capacity.  Internal self-weight calculations are based on the reference values shown in Table 3.3.  Weight 
of water is subtracted when the pile is below the water table.  Calculated self weight is printed in output 
text when analyzing for uplift. 

 
Pile 

Material 
Self Weight 

Pile Types (lb/ft3) (kN/m3) 

Steel 490 77 

Steel Pipe Piles, H-
Piles, Steel Piles, 

Tapered Monotube, 
Raymond 

Concrete 150 23.6 Precast Concrete Piles 
Timber 50 7.9 Timber Piles 

Table 3.3   Notes about Self Weight for Uplift Capacity 

Self weight of the modeled pile is not taken into account for compression loads since the influence 
is minimal and often ignored.  If needed, users can subtract a calculated weight (submerged or not, as 
appropriate) from the compression capacity provided by APILE. 

3.2.6 Data > Circular-Section Pile 

This selection is automatically enabled if the user selected to analyze a pile type with a circular 
cross section (under Data > Pile Material).  This submenu option allows the user to input 
dimensions and section properties for piles with circular cross sections.  A general description 

for the data needed under each entry of the Data > Circular-Section Pile submenu option is listed below 
and shown in Figure 3.11. 

Outer Diameter, OD 
This is the outside diameter that will be used in the computations.  The English unit for this variable 

is “inch”, while “millimeter” is for the SI unit. 

Inner Diameter, ID 
This is the inside diameter that will be used in the computations.  The English unit for this variable 

is “inch”, while “millimeter” is for the SI unit. 

This entry is disabled for pile types where it is not applicable, such as concrete, Raymond, timber or 
tapered monotube piles.  For close-ended pipe piles, the inner diameter can be entered as zero or the user 
may enter an inner diameter and select “plugged” condition at the bottom of this window screen.  However, 
the inner diameter entry for close-ended piles is used to calculate the Cross Section Area (when selecting 
Data > Pile Material > Calculate from Pile Section).  User must enter valid Inner Diameter for those 
cases. 
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The APILE program computes skin friction on both outside and inside area for pipe piles.  In clay 
layers, the user-specified remolded shear strength is used to compute the inside skin friction. 

Total Length, TL 
This is equal to the summation of the stickup length (if any) plus maximum pile penetration that is 

expected for the pile.  The program will compute side resistance and end bearing at every depth interval 
until reaching the specified total length. 

The load-vs-settlement curve will also be computed based on the total length.  For the final design, 
the user may need to enter the exact total length in order to generate proper load-vs-settlement data.  The 
English unit for this variable is “ft”, while “meter” is for the SI unit. 

Batter Angle 
This is the batter angle that should be entered by the user in degrees and measured as deviation from 

the vertical (less than 90 degrees), where an entry of 0 indicates a vertical/straight pile. 

Pile Stickup Length, PSL 
This input represents the length of pile that is sticking up above ground level.  This length is only 

used in computations of elastic shortening since no axial load transfer occurs above ground.  The English 
unit for this variable is “ft” while “meter” is for the SI unit. 

Zero-Friction Length from Ground, ZFL 
This number (always positive) represents the length of pile immediately below grade level that is 

declared noncontributing to side resistance.  The English unit for this variable is “ft” while “meter” is for 
the SI unit. 

Inner Diameter of Lower-End Section, EID 
In open-ended pipe piles, occasionally, a thick-walled section is used in the lower end of the piles to 

prevent damage during driving.  This enlarged-end section is usually referred to as “driving shoe.” 

The user may specify in this entry a value for the inner diameter of a thick-walled end section.  The 
inner diameter of the end section must be entered in inches when using English units or millimeters when 
using SI units. 

This value can be left as zero when the pile section is uniform along the complete length.  This entry 
is disabled for close-ended piles. 

Lower End Section Length, ESL 
In direct relationship to the previous entry (EID), the user here specifies the length of the thick-walled 

end section of the pile.  Again, this length is specified to be zero if a driving shoe is not used during pile 
driving (for uniform piles).  The English unit for this variable is “ft”, while “meter” is for the SI unit.  This 
entry is disabled for close-ended piles. 

Internal load transfers in side resistance (on open-ended piles) are ignored after (above) this Lower 
End Section Length (ESL).  This is because the soil is highly disturbed after the change in pile diameter 
(from a smaller to a larger inner diameter, or after an internal stiffener).  If the user wants to keep 
considering internal side resistances even after the change in diameter (from the driving shoe) then the user 
could enter a fictitiously long value for Lower End Section Length (ESL). 
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Plugged/Unplugged Conditions 
This entry is only shown for pipe piles, where the user is provided with controls for the load transfers 

from the internal pile plug.  This entry is not shown in pile types where it is not applicable, such as concrete, 
Raymond, timber or tapered monotube piles. 

For close-ended pipe piles, the user may enter an inner diameter of zero or the user may enter a value 
for inner diameter and select the radio button for “plugged” condition.  Both methods provide the same 
results for close-ended pipe piles. 

For practical reasons, in open-ended piles with Internal Pile Plug Calculated by Program the 
internal side friction is added to the end bearing.  This is partly because in the APILE program the end 
bearing plus internal side friction are added together until a plug forms (until it reaches the equivalent end 
bearing of a close-ended pipe). 

In the CPT-based methods (NGI 99, ICP/MTD, FUGRO and UWA) for APILE Offshore the user is 
required to specify either plugged or unplugged condition for computations of static capacity on open-ended 
pipe piles.  APILE will determine the plugged or unplugged conditions for the CPT-based methods based 
on the internal computations of pile plug (when users select Internal Pile Plug Calculated by Program). 

 
Figure 3.11   Sample Data > Circular-Section Pile 

3.2.7 Data > Noncircular Section Pile 

This selection is automatically enabled if the user selected to analyze a pile type with a noncircular 
cross section (under Data > Pile Material).  This submenu option allows the user to input 
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dimensions and section properties for piles with noncircular cross sections.  A general description for the 
data needed under each entry of the Data > Noncircular-Section Pile submenu option is listed below and 
shown in Figure 3.12 

Total Length, TL 
This is equal to the summation of the stickup length (if any) plus maximum pile penetration that is 

expected for the pile.  The program will compute side resistance and end bearing at every depth interval 
until reaching the specified total length. 

The load-vs-settlement curve will also be computed based on the total length.  For the final design, 
the user may need to enter the exact total length in order to generate proper load-vs-settlement data.  The 
English unit for this variable is “ft”, while “meter” is for the SI unit. 

Batter Angle 
This is the batter angle that should be entered by the user in degrees and measured as deviation from 

the vertical (less than 90 degrees), where an entry of 0 indicates a vertical/straight pile. 

Pile Stickup Length, PSL 
This input represents the length of pile that is sticking up above ground level.  This length is only 

used in computations of elastic shortening since no axial load transfer occurs above ground.  The English 
unit for this variable is “ft” while “meter” is for the SI unit. 

Zero-Friction Length from Ground, ZFL 
This number (always positive) represents the length of pile immediately below ground level that is 

declared noncontributing to side resistance.  The English unit for this variable is “ft” while “meter” is for 
the SI unit. 

Perimeter for Noncircular Section 
The perimeter is used by the program for computations of skin friction.  For H-piles, most users 

would conservatively input the perimeter of the rectangular box formed between the flanges.  The English 
unit for this variable is “inch”, while “millimeter” is for the SI unit. 

Tip Area for Noncircular Section 
The tip area for the noncircular section is needed by the program for computations of tip resistance 

(resistance in end bearing).  For H-piles, most users would input the area of the rectangular box formed 
between the flanges.  However, in very soft clay the soil between the flanges will probably not plug the H-
pile and it is recommended to be more conservative using only the cross-sectional area of the metal.  The 
English unit for this variable is “inch”, while “millimeter” is for the SI unit.  This entry is used to calculate 
the Cross Section Area (when selecting Data > Pile Material > Calculate from Pile Section) for elastic 
deformations of the pile. 
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Figure 3.12   Sample Data > Noncircular Pile Section 

3.2.8 Data > Soil Layers 

This selection allows the user to enter a layering system and to specify the different types of soil 
and their mechanical properties.  Users are able to edit soil layers using the Standard APILE Soils 
Table (Edit Soil Layer Table) or with the new CPT (Cone Penetration Test) Interpreter (Edit 

Soil Layers with CPT).  The latter CPT Interpreter option is only available in models where layering data 
was imported from a CPT file. 

3.2.8.1 Editing Soil Layers with Standard APILE Soils Table 

An illustration of the Soil Layers > Edit Soil Layer Table window using the standard APILE Soil 
Tables for an example application is shown in Figure 3.13. 

In general, each sub-window that comes up under the Layer button consists of entry fields for the 
top and bottom of the soil layer.  The user may enter different parameters for the top and the bottom of each 
layer.  The program will linearly interpolate the data for any point between those two depths.  The following 
sections will provide general description on data needed for each soil type. 

Layer 
This is a sequential number and button that is provided to each soil layer.  This number is computed 

automatically by the program as new layers are added using the Add Layer or Insert Layer buttons at the 
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lower part of Figure 3.14.  The maximum number of soil layers that may be used in each data file is limited 
to 40. 

Inputs of mechanical properties for the different types of soil layers are explained in Section 3.2.8.2 
to Section 3.2.8.4 of this Manual. 

The Add Layer button inserts a new soil layer at the bottom of the profile that is already defined.  
The Insert Layer button inserts a new soil layer immediately below the layer where the cursor is located.  
The Delete Layer deletes the soil layer where the cursor is located. 

Soil Type 
There are two internal types of soils that may be specified for program APILE.  The user specifies 

the desired soil type using a dropdown list with the following choices: 
 Code Number Internal Soil Type 
 1 Sand  
 2 Clay  
 3 Silt*  

Silt is only available for models with the USACE method. 

Depth at Bottom of Each Layer 
Values for the bottom of each soil layer are entered with respect to an origin of coordinates set at the 

ground surface and positive downwards.  As a minimum, the bottom of the last soil layer must be two pile 
diameters deeper than the depth of the modeled pile.  This is because the APILE program, for computations 
of end bearing, uses an average of soil properties within 1.5 pile diameters above and below the pile tip. 

Max. Side Friction 
In this entry the user may specify the maximum value of skin-friction transfer that is permissible for 

a given stratum.  The APILE program will compare its internally-computed value (according to the selected 
design method) with the maximum provided by the user in this entry and use the smaller of these two values 
for the final computation.  If the user does not want to add any restriction on the computed value from 
APILE, simply enter 0 to suppress this option and always use the internally-computed values. 

Max. End Bearing 
In this entry the user may specify the maximum value of end-bearing transfer that is permissible for 

a given stratum.  The APILE program will compare its internally-computed value (according to the selected 
design method) with the maximum provided by the user in this entry and use the smaller of these two values 
for the final computation.  If the user does not want to add any restriction on the computed value from 
APILE, simply enter 0 to suppress this option and always use the internally-computed values. 

Reduction/Resistance Factor (Side Friction) 
The column is provided for entering a factor or multiplier that applies to one of the following 

conditions: 
• An LRFD resistance factor on side friction (if the user selected the radio button 

Data>Computational Method>Method for Load Settlement>Factors for t-z and Q-w 
Curves>Use Unfactored Unit Side Friction and Unit Tip Resistance), or  
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• A t-multiplier/factor in the t-z curves (if the user selected the radio button Data>Computational 
Method>Method for Load Settlement>Factors for t-z and Q-w Curves>Use Reduced Unit 
Side Friction and Unit Tip Resistance). 

Enter 1.0 (default) for no reductions on the computed values of side friction. 

Reduction/Resistance Factor (End Bearing) 
The column is provided for entering a factor or multiplier that applies to one of the following 

conditions: 
• An LRFD resistance factor on tip resistance (if the user selected the radio button Data > 

Computational Method > Method for Load Settlement > Factors for t-z and Q-w Curves > 
Use Unfactored Unit Side Friction and Unit Tip Resistance), or  

• A Q-multiplier/factor in the Q-w curves (if the user selected the radio button Data > 
Computational Method > Method for Load Settlement > Factors for t-z and Q-w Curves > 
Use Reduced Unit Side Friction and Unit Tip Resistance). 

Enter 1.0 (default) for no reductions on the computed values of tip resistance. 

 
Figure 3.13   Sample Data > Soil Layers > Edit Soil Layer Table (using APILE Tables) 

3.2.8.2 Soil Data for Sand Layers 

A sample dialog box for this soil type is shown in Figure 3.14.  Notice that some of the input 
parameters may be grayed out (inactive/disabled), since they depend on input-data selections specified 
under the Data > Computational Methods menu.  Inactive/disabled (grayed out) parameter parameters 
are not necessary and thus not taken into account for the model that is being evaluated. 

The required properties for sand layers are explained below.  Values are entered for top and bottom 
of each layer, the APILE program automatically interpolates linearly the intermediate values between those 
entries.  Notice that for computations of end bearing, APILE uses by default an average of soil properties 
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within 1.5 pile diameters above and below the pile tip (which may be modified by the user under the 
Options > Control Options > Average Depth to Estimate Tip Resistance). 

 

Figure 3.14   Sample soil data for sand layers 

Effective Unit Weight 
These entries are required (enabled) for all sand models and correspond to values of effective unit 

weight of the soil. The effective unit weight is equal to the total unit weight when above the water table and 
equal to the submerged unit weight when below the water table. Values for the top and bottom of the layer 
are entered in standard units of force per unit volume (either lb/ ft3 or kN/ m3). 

Friction Angle 
These entries are required (enabled) for all sand models and correspond to values of the internal angle 

of friction (also known as friction angle or φ angle) for the top and bottom of the sand layer.  It is 
recommended that the user enters actual values of Friction Angle using the standard units of degrees. 
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If the actual Friction Angle values are not available, the user may alternatively Enter Blow Counts 
from SPT (Standard Penetration Test).  For friction transfers (transfers in side resistance), APILE converts 
internally between the user-specified values of Blow Counts from SPT to equivalent Friction Angle using 
the general relationship reported by AASHTO 2012 (modified after Bowles, 1977) that is shown in Table 
3.4. 

Please notice that releases of APILE prior to v2019 used the older correlation shown in Table 3.5 
after Gibbs and Holtz, 1957.  Properties estimated from these correlations tend to have greater variability 
than actual laboratory measurements.  Some geotechnical manuals recommend that properties estimated 
from correlation to in-situ field tests or to laboratory tests should be based on multiple measurements within 
the geologic unit.  Users should consult the accompanying Technical Manual for other comments of side 
resistance in sand layers (for each method). 

When the user provides values of Blow Counts from SPT the computer program APILE uses those 
values for computations of end bearing following equations and limits specified in the Technical Manual 
(comments of end bearing in sand layers). 

 

N60 from SPT 
(blows/ft) 

Overburden Stress 
0 lb/in2 20 lb/in2 40 lb/in2 

Friction Angle φ (degrees) 
<4 25 27.5 30 
4 27 29.5 32 

10 30 32.5 35 
30 35 37.5 40 
50 38 40.5 43 

Table 3.4   Current correlation between SPT N and φ (AASHTO, 2012) 
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Table 3.5   Older relationship between N and φ (Gibbs and Holtz, 1957) 

Coefficient of Lateral Earth Pressure, Ko (API and Lambda Methods) 
Entries for Ko are required (enabled/active) only for models using the API and/or Revised Lambda 

methods (Data > Computational Methods > Method for Pile Capacity).  These entries are disabled 
(grayed out) if those methods are not selected by the user.  When other methods are used, merely for 
comparative purposes, the Ko values are assigned internally within APILE. 

These entries represent values of the lateral earth pressure coefficient, Ko, for the top and bottom of 
the sand layer.  Values for Ko depend on the relative density of the sand and the process by which the sand 
deposits were formed.  If the sand deposits did not receive any artificial compaction, values of Ko range 
from about 0.40 for loose to 0.50 for dense sand.  Artificial compaction or tamping may increase Ko values 
to 0.80. 

The earth pressure coefficient, Ko, is used to calculate the skin friction in granular soils.  A Ko of 0.8 
is recommended for open-ended pipe piles that are driven unplugged for loadings in both tension and 
compression.  A Ko of 1.0 is recommended for full-displacement piles. 

Bearing Capacity Factor, Nq (API only) 
Entries for Nq are required (enabled/active) only for models using the API method (Data > 

Computational Methods > Method for Pile Capacity).  These entries are disabled (grayed out) if the 
API method is not selected by the user.  When other methods are used, merely for comparative purposes, 
the Nq values are assigned internally within APILE. 
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The Nq factor is used to calculate the end-bearing capacity of piles in granular soils.  Recommended 
values of Nq and maximum unit end bearing are provided in Table 3.6.  

 

Table 3.6   Guidelines for tip resistance in siliceous soil 

Data for User-Specified Load Transfers 
These entries are enabled if the user selects Load Transfers specified by User under the Data > 

Computational Method > Method for Pile Capacity.  The user-specified values in these entries are not 
used in any other method.  Values are entered in standard units of force per unit area (either lb/ft2 or kN/m2). 

Cone Penetration Data, Qc 
Entries for Qc are required (enabled/active) only for APILE Offshore Version and for models using 

CPT-based methods such as NGI 99, MTD, Fugro and/or UWA methods (Data > Computational 
Methods > Method for Pile Capacity).  These entries are disabled (grayed out) in APILE Standard 
Version and if a CPT-based method is not selected by the user. 

The user can enter Qc values for the top and bottom of each sand layer using standard units of force 
per unit area (either lb/ ft2 or kN/ m2).  The Qc values are used to calculate the end bearing in granular soils 
according to the recommendations provided by each CPT-based method as explained in Chapter 3 of the 
separate Technical Manual. 

Z Peak Value for t-z Curves, zpeak 
Entries for Zpeak are required (enabled/active) only for models using the API method for load 

settlement (Data > Computational Methods > Method for Load Settlement).  These entries are disabled 
(grayed out) if other methods are selected by the user. 

The user can enter a value for the Zpeak variable for the API Load Settlement Method as explained in 
Section 4.8.1 of the APILE Technical Manual.  Leaving this entry as zero instructs APILE to use the default 
of one percent of the pile outer diameter (i.e., Zpeak/D=0.01) as recommended by API RP 2A-WSD (2014) 
for routine design purposes.  However, there is significant uncertainty on this value and it ranges from 
0.25% to 2.0% of the pile diameter.  Values other than the APILE default may be considered in cases where 
axial pile stiffness is critical in the model/design. 

Limiting q ,
Soil N q kips/ft2 (MPa)

Very loose to medium,
sand to silt 8 40 (1.9)

Loose to dense,
sand to silt 12 60 (2.9)

Medium to dense,
sand to sand-silt 20 100 (4.8)

Dense to very dense,
sand to sand-silt 40 200 (9.6)

Dense to very dense,
gravel to sand 50 250 (12.0)
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3.2.8.3 Soil Data for Clay Layers 

A sample dialog box for this soil type is shown in Figure 3.15.  Notice that some of the input 
parameters may be grayed out (inactive/disabled), since they depend on input-data selections specified 
under the Data > Computational Methods menu.  Inactive/disabled (grayed out) parameter parameters 
are not necessary and thus not taken into account for the model that is being evaluated. 

The required properties for clay layers are explained below.  Values are entered for top and bottom 
of each layer, the APILE program automatically interpolates linearly the intermediate values between those 
entries.  Notice that for computations of end bearing, APILE uses by default an average of soil properties 
within 1.5 pile diameters above and below the pile tip (which may be modified by the user under the 
Options > Control Options > Average Depth to Estimate Tip Resistance). 

Effective Unit Weight 
These entries are required (enabled) for all clay models and correspond to values of effective unit 

weight of the soil. The effective unit weight is equal to the total unit weight when above the water table and 
equal to the submerged unit weight when below the water table. Values for the top and bottom of the layer 
are entered in standard units of force per unit volume (either lb/ ft3 or kN/ m3). 

Undrained Shear Strength 
These entries are required (enabled) for all clay models and correspond to values of the undrained 

shear strength at the top and bottom of the clay layer.  Ordinarily, these values are taken as one half of the 
compression strength of samples obtained from unconsolidated-unconfined triaxial tests.  Values for the 
top and bottom of the layer are entered in standard units of force per unit area (either lb/ ft2 or kN/ m2). 

Remolded Shear Strength 
Entries for Remolded Shear Strength are available (enabled/active) only for models with Open-

Ended Piles (under Data > Pile Material either Steel Pipe Piles or Precast Concrete).  These entries 
are disabled (grayed out) if those pile types are not selected by the user. 

When a pipe pile is driven into clay soils, the clay inside the pipe forms a plug.  The plugged clay 
may be remolded during the driving process.  The Remolded Shear Strength variable represents the 
values for the shear strength that will be used for computing the side friction from the remolded soil plug 
inside the pipe pile. 

Data for User-Specified Load Transfers 
These entries are enabled if the user selects Load Transfers specified by User under the Data > 

Computational Method > Method for Pile Capacity.  The user-specified values in these entries are not 
used in any other method.  Values are entered in standard units of force per unit area (either lb/ft2 or kN/m2). 
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Figure 3.15   Sample soil data for clay layers 

Data for APILE Offshore Methods 
The following entries are required (enabled/active) only for APILE Offshore Version and for models 

using CPT-based methods such as NGI, MTD, Fugro and/or UWA methods (Data > Computational 
Methods > Method for Pile Capacity).  These entries are disabled (grayed out) in APILE Standard 
Version and if a CPT-based method is not selected by the user. 

Qc from Cone Penetration Data 
The user should enter Qc values for the top and bottom of each clay layer using standard units 

of force per unit area (either lb/ ft2 or kN/ m2).  The Qc values are used to calculate the end bearing 
according to the recommendations provided by each CPT-based method as explained in Chapter 3 
of the separate Technical Manual. 

Plasticity Index (PI) 



CHAPTER 3 –References for Data Input – 3-30 
 

User’s Manual (Rel. Aug/2023)  APILE v2023 
 

The user should enter Plasticity Index (PI) values in percentage (%) for the top and bottom 
of each clay layer.  As explained the Technical Manual, the NGI method uses the Plasticity Index 
(referenced as ‘Plastic Index, Ip’) to calculate the βNC value (for side friction).  The other CPT-based 
methods use the Plasticity Index to calculate the interface angle of friction δf as recommended by 
the ring shear interface results δultimate in clays after Saldivar-Moguel (2002) and Shell UK Ltd 
(recommended in ICP documentation). 

Yield Stress Ratio (YSR) 
The Yield Stress Ratio, YSR is not necessary (grayed out/disabled) for the NGI (Norwegian 

Geotechnical Institute) method but available (active) for all other APILE Offshore methods.  YSR 
is defined as the ratio of effective vertical yield stress (σ’vy) to the vertical in situ effective stress 
(σ’vo).  The similar OCR (over-consolidation ratio) is defined as the ratio of vertical maximum pre-
consolidation effective stress (σ’vc) to the vertical in situ effective stress (σ’vo).  YSR is also named 
as ‘Apparent OCR’ in some literature, but generally YSR is greater than OCR. 

Z Peak Value for t-z Curves, zpeak 

Entries for Zpeak are required (enabled/active) only for models using the API method for load 
settlement (Data > Computational Methods > Method for Load Settlement).  These entries are disabled 
(grayed out) if other methods are selected by the user. 

The user can enter a value for the Zpeak variable for the API Load Settlement Method as explained in 
Section 4.8.1 of the APILE Technical Manual.  Leaving this entry as zero instructs APILE to use the default 
of one percent of the pile outer diameter (i.e., Zpeak/D=0.01) as recommended by API RP 2A-WSD (2014) 
for routine design purposes.  However, there is significant uncertainty on this value and it ranges from 
0.25% to 2.0% of the pile diameter.  Values other than the APILE default may be considered in cases where 
axial pile stiffness is critical in the model/design. 

t Residual Value for t-z Curves, tres 
Entries for tres are required (enabled/active) only for models using the API method for load settlement 

(Data > Computational Methods > Method for Load Settlement).  These entries are disabled (grayed 
out) if other methods are selected by the user. 

The user can enter a value for the tres variable for the API Load Settlement Method as explained in 
Section 4.8.1 of the APILE Technical Manual.  Leaving this entry as zero instructs APILE to use the default 
of 0.9 tmax (i.e., tres = 0.9 tmax) as recommended by API RP 2A-WSD (2014) as upper range for clays.  The 
user may select to enter the lower range of 0.7 (i.e., tres = 0.7 tmax) or anything in between. 

Estimation of Adhesion Factor 
Entries for Adhesion Factor are required (enabled/active) only for models using the FHWA method 

for pile capacity (Data > Computational Methods > Method for Pile Capacity).  These entries are 
disabled (grayed out) if other methods are selected by the user. 

With this entry, the select can choose the graph that is used to estimate the Adhesion Factor.  Further 
details are described in Section 3.5.3 of the Technical Manual.  The options are (reference Graphs A, B and 
C for each option are provided by the Show Graph button): 

0 – Default.  Program will choose the method based on the layout of the soil layers. 
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1 – Using Tomlinson Graph A 
2 – Using Tomlinson Graph B 
3 – Using Tomlinson Graph C 

3.2.8.4 Soil Data for Silt Layers 

This soil type is available for models using the USACE method (on its own, not with others) for load 
settlement (Data > Computational Methods > Method for Load Settlement) and for pile capacity (Data 
> Computational Methods > Method for Pile Capacity).  This soil type is not visible if any other method 
is selected by the user (even if combined with the USACE method). 

A sample dialog box for this soil type is shown in Figure 3.16.  The required properties for silt layers 
are explained below.  Values are entered for top and bottom of each layer, the APILE program automatically 
interpolates linearly the intermediate values between those entries.  Notice that for computations of end 
bearing, APILE uses by default an average of soil properties within 1.5 pile diameters above and below the 
pile tip (which may be modified by the user under the Options > Control Options > Average Depth to 
Estimate Tip Resistance). 

 
Figure 3.16   Sample soil data for silt layers 
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Please notice that releases of APILE prior to v2019 used the older correlation shown in Table 3.5 
after Gibbs and Holtz, 1957.  Properties estimated from these correlations tend to have greater variability 
than actual laboratory measurements.  Some geotechnical manuals recommend that properties estimated 
from correlation to in-situ field tests or to laboratory tests should be based on multiple measurements within 
the geologic unit.  Users should consult the accompanying Technical Manual for other comments of side 
resistance in sand layers (for each method). 

When the user provides values of Blow Counts from SPT the computer program APILE uses those 
values for computations of end bearing following equations and limits specified in the Technical Manual 
(comments of end bearing in sand layers). 

Coefficient of Lateral Earth Pressure, Ko 

These entries represent values of the lateral earth pressure coefficient, Ko, for the top and bottom of 
the silt layer.  The earth pressure coefficient, Ko, is used to calculate the skin friction.  USACE recommends 
a Ko value of 0.8 for compression and a value that ranges from 0.5 to 0.7 for tension. 

Shear Strength 
These entries correspond to values of the undrained shear strength at the top and bottom of the silt 

layer.  Ordinarily, the values of effective cohesive strength (c) are obtained from the direct shear test or the 
triaxial consolidated drained test.  Values for the top and bottom of the layer are entered in standard units 
of force per unit area (either lb/ ft2 or kN/ m2). 

3.2.8.5 Editing Soil Layers with CPT Interpreter 

The Data > Soil Layers > Edit Soil Layers with CPT menu is only available (enabled) if the user 
previously selected to Data > Import CPT Data from a cone penetration test.  The menu and option to 
edit data with CPT is otherwise unavailable (grayed out).  Users should check the next Section 3.2.9 to see 
how to Data > Import CPT Data from a cone penetration test. 

An illustration of the Data > Soil Layers > Edit Soil Layers with CPT for an example application is 
shown in Figure 3.17.  The figure also provides a reference for the organization of data and some of the 
main commands. 

The left side of the screen shows the CPT data in graphical form.  At bottom left, users can select the desired 
parameter to display in the graph.  The parameters are separated between Imported values (Q Tip and Side 
friction) and Interpreted values (Unit Weight, Undrained Shear Strength, Friction Angle, and N(60)). 

Suggested steps for newly imported CPT data (with no defined soil layers): 

1. Users may first choose to display the plot of an Interpreted parameter that can help to define the 
soil layers.  Choosing Undrained Shear Strength or Friction Angle can help the user to define 
the general depths for cohesive (Clay) and/or cohesionless (Sand) layers.   

2. The user clicks the green + icon on the upper right to create soil layers and enters the appropriate 
depth of the bottom of each layer. 

3. For each defined layer, click the drop down under Soil Type to select either Clay or Sand layer. 

4. Click on button labeled Fill layers with CPT data so that CPT data (Imported and Interpreted) 
is used to fill applicable variables for top and bottom of each defined soil layer. 
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5. Select each soil layer (double click on left graph or at row on top table) and edit the layer properties 
to rounded and desired values (users may select averaged or lower-case envelopes to fit 
imported/interpreted parameters for each layer). 

6. Click Ok button and select Yes to transfer edited soil data (overwrite) to APILE. 

7. Select Data > Soil Layers > Edit Soil Layer Table to make refined edits of each soil layer with 
APILE. 

8. Select Data > Soil Layers > Edit Soil Layers with CPT to make any further checks or edits using 
the CPT comparisons. 

 

Figure 3.17   Sample File & Commands for Edit Soil Layers with CPT 
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3.2.9 Data > Import CPT Data 

This selection allows the user to browse to an external file that contains ASCII (text) data from a 
cone penetration test (CPT) from any equipment manufacturer.  An example of CPT data captured in metric 
units (which also uses the period as decimal character) is included in Figure 3.18.  This figure also contains 
additional information regarding features of the Import CPT Data dialog screen. 

 

 

Figure 3.18  CPT Data Import Dialog 

When first triggered, the Import CPT Data dialog tries to automatically select the best configuration 
for the data, and displays the data to be imported on the right pane. This preview pane of data to be imported 
can be updated at any time with the Update View button (middle of dialog, at bottom). 

Using default values, the CPT data importer in APILE is normally able to open and interpret any 
CPT data file format, so as to recognize its organization of data and units.  As indicated in Figure 3.18, the 
organized imported data is displayed on the table to the right of the screen (green shaded). 

On the CPT data file to be imported, APILE requires the three or four entries per CPT record that are 
listed in Table 3.7.  The following limitations are required for the source CPT data file: 



CHAPTER 3 –References for Data Input – 3-35 
 

User’s Manual (Rel. Aug/2023)  APILE v2023 
 

• each record is written on a single line, 
• each record is identifiable using a “depth” entry/parameter, 
• records are sorted in ascending order of depth, 
• three or four entries/parameters are listed per record (entries/parameters are shown in Table 3.7, 

they can be listed in any column order). 

If the import data file does not satisfy the above criteria, it must be first manually adjusted before 
attempting to import it to APILE.  If duplicate depth values (up to a tolerance) are present, only the first 
record (as read from top to bottom) is imported and other records with the same depth value are ignored. 
Each entry/parameter is identified by a column number and must be associated with a specific unit of 
measurement.  Note that the separation of columns depends on the choice of Delimiters (bottom of Figure 
3.18) that are specified by the user. 

The units of the CPT data will be converted to the units that were selected by the user in the APILE 
model where the data is being imported.  Existing data of the APILE model, outside soil layers, are not 
changed but rather complemented by the newly imported CPT soil data. 

Users should verify that the data organization, units and values that are shown on the right table panel 
in Figure 3.18 are in accordance to the references provided by the CPT equipment manufacturer (or service 
agency).  If the data was not recognized properly, the user should manually adjust the interpretation by 
changing the parameters that are shown at the bottom left of the screen in Figure 3.18.  For any change to 
be effective, the user must select the desired entries and then click the Update View button in the lower 
middle. 

 
Entry/Parameter Description 

Depth Depth where the CPT readings took place. These entries are expected to be 
unique and sorted in ascending order from top to bottom. 

Tip Resistance 
Recorded tip resistance at each depth, in units of force per unit area. Once 
imported, these values are stored under the Qtip or Qc column/values in the 
import data table. 

Friction 
Recorded friction at each depth, in units of force per unit area. Once imported, 
these values are stored under the Friction or Fs column/values in the import data 
table. 

Pore Pressure 
(optional) 

Recorded hydrostatic pressure at each Depth, in units of force per unit area. Once 
imported, these values are stored under the U2 column/values in the import data 
table. If the checkbox is not selected, pore pressure is imported to be zero for all 
records. 

Table 3.7   Required Input Entries/Parameters on Source CPT Data File 

3.2.9.1 Manual Adjustments of CPT Data 

Some references for manual adjustments of data recognition (under the Data header in Figure 3.18) are as 
follows: 

Main variables of Depth, Tip Resistance and Friction are normally provided by all CPT data files.  
Users can enter the proper order of these variables by changing the assigned Column number.  
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Users may also change the units that are assigned to these variables by clicking and selecting 
in the drop down under Unit.  Many CPT data files use mixed English and SI units. 

One or more secondary variables may also be included in the CPT data file.  The sample in 

 

Figure 3.18  CPT Data Import Dialog 

 includes the variable Pore Pressure which may optionally be used during interpretations (users may 
also choose to remove the check mark and APILE will use zero for all pro pressure).  Any other 
secondary variables contained in the CPT data file may be shown on the left table but will be 
ignored (not used) when importing into APILE (not shown on the interpreted table at the right 
side of the screen). 

In the First Row and Last Row entries the user can specify which row on the left table has the first 
valid data entry (outside titles or comment fields/rows) and which has the last valid data entry 
(before ending/closing notes that maybe included in the CPT data file). Data lines that are found 
to not satisfy the required input properties are automatically discarded. 

The Water Depth entry is left as zero by default but users are strongly encouraged to edit and enter 
the appropriate value if they know the depth to the water table during the field investigation 
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(using the same units as Depth field).  This information is normally not included in the CPT 
data file but usually measured and registered in the CPT field logs. 

The user may select the Decimal Character, either period (dot) (.) or comma (,) that applies to their 
CPT data.  This is useful for tests done in certain countries that also use the metric system. 

The Delimiters entries indicate the characters that may be used in the CPT data file to separate 
columns of data.  By default, the program includes a comma (,), space ( ), semi colon (;) and 
the tab (\t) indicators to separate variables included in the CPT data file. 

3.2.9.2 Options Button 

A sample of the selections under the Options button is shown in Figure 3.19.  This button allows the user 
to select and enter various parameters that are used for interpretation of the CPT data. 

The drop down for Friction Angle Method allows the user to select one of three different methods for the 
interpretation of friction angles: 

Mayne (2006) as described in: Mayne. P.W. Cone Penetration Testing, A Synthesis of Highway 
Practice, NCHRP Synthesis 368, Transportation Research Board, Washington, DC, 2007. 

Kulhawy & Mayne (1990) as described in: Kulhawy. F.H. and P.W. Mayne. Manual on Estimating 
Soil Properties for Foundation Design, Report EPRI EL-6800, Electric Power Research 
Institute, Palo Alto, CA, 1990. 

Robertson & Companella (1983) as described in: Robertson. P.K., Campanella, R.G., Gillespie, D., 
and Greig, J., 1986. Use of Piezometer Cone Data. IN-SITU ’86, Use of In-situ testing in 
Geotechnical Engineering, GSP 6, ASCE, Reston, VA, Specialty Publication, SM 92, pp 1263-
1280. 

The Nkt Value is a cone factor used to obtain the estimated undrained shear strength of clays: 

cu = (qt - σv) / Nkt  

Where qt is the corrected cone resistance, σv is the vertical stress and cu is the undrained shear strength 
of the clay. 

The Nkt Value usually varies from 10.5 to 18 and depends on the type of clay.  Users may enter a 
Fixed value or may select for the program to Auto Compute.  The Auto Compute uses the 
formulation suggested by Robertson & Cabal (2022): 

 Nkt = 10.5 + 7 log10 (FR) (used for FR > 0), where FR is a Normalized Friction Ratio that is 
calculated internally based on other parameters. 

The Net Area Ratio of Cone Tip is a parameter used to obtain the corrected cone resistance: 

qt = qc + u2 (1+ a) 

Where qt is the corrected cone resistance, qc is the measured cone resistance, u2 is the pore water 
pressure (see Pore Pressure in Section 3.2.9.1) and a is the Net Area Ratio of Cone Tip. 

The 0.78 used by default is a common value for Net Area Ratio of Cone Tip.  However, this value 
usually varies from 0.70 to 0.85 and should be obtained from the CPT manufacturer. 
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Users should read the referenced literature above for specifics about each method and parameter.  If the 
user needs further description and control of the various intermediate parameters, they should investigate 
the separate EnCPT software which provides an enhanced version of the CPT Interpreter that is included 
with APILE: https://www.ensoftinc.com/products/encpt/ 

 

 
Figure 3.19  Sample Options button for Import CPT Data 

3.3 Options Menu 

3.3.1 Options > Units 

This selection provides the user with a choice of input data in English Units, and S.I. Units 
(international units) as shown in Figure 3.20.  In general, the following specific units of measurements are 
used frequently in the program: 
 Units Length Force   Stress/Modulus 

 English foot (ft) pounds (lbs)  psf or psi 

 International meters (m) kiloNewtons (kN)  kPa 

The user should always check the unit descriptions which are associated to each variable in the 
program interface.  For instance, psi instead of psf is used for the elastic modulus of pile material (Data > 
Pile Material > Modulus of Elasticity). 

The user may change from one system of units to the other as many times as desired.  The program 
will automatically convert all the appropriate input that was already specified by the user before the time 
of selection of a different system of units.  Small rounding differences may appear if multiple changes of 
units are performed.  The user must always check that input data have been converted appropriately. 

By default, APILE always starts a new model in English Units.  The selection of the desired units is 
important prior to importing CPT data (Data > Import CPT Data) since the imported values will always 
be converted to the units that were previously selected in the APILE model. 

https://www.ensoftinc.com/products/encpt/
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Figure 3.20   Options for units selection 

3.3.2 Options > Print t-z Curves at Additional Depths 

The user can instruct the program to generate t-z curves at user-specified depths.  The windows dialog 
screen that comes up under this menu option is shown in Figure 3.21.  The APILE program automatically 
generates t-z curves at the top, middle, and bottom of each soil layer.  The user can enter up to 50 other 
depths for printing of additional t-z curves. 

3.3.3 Options > Control Options 

This selection allows the user to enter certain control parameters for program performance and 
output.  An illustration of the Options > Control Options dialog box for an example application is shown 
in Figure 3.22. 

Length of each computation increment 
This entry represents the length, in ft or m, of each element into which the pile is divided.  A default 

of 1 ft (0.3048 m) is provided by the program.  As a general reference, users should not select a length of 
computation increment that is larger than about half of the smallest soil layer.  In some models, large 
increments may produce noticeable changes in the computational results which should be avoided.   
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Figure 3.21   Options > Print t-z Curves at Additional Depths 

Print increment 
The user may select how often results are plotted (outputted) according to the number that is provided 

in this entry.  The length of each “computation increment” is defined in the previous entry.  The number 
used for print increment will not produce any effect in the internal computations of the program. 

t-z and Q-w factors 
The user may specify any t and/or z multipliers that is desired to be applied along the length of the 

modeled pile.  The user may also specify any Q and/or w multiplier that is desired to be applied for the pile 
tip.  This may be useful for certain LRFD-based codes that may suggest the use of a reduction factor (less 
than one) for load transfers in side resistance (t multiplier less than one) and/or in end bearing (Q multiplier 
less than one).  The multiplier for associated movements (z and w multipliers) are normally left as one 
(unchanged). 

Load Settlement Curve 
Users may choose to enter specific tip movements by placement of a check mark under Specify Tip 

Movements and entering the desired movements (from smallest to largest).  This can be useful if the user 
wants to obtain a smoother curve of load-vs-settlement (Graphics > Axial Load vs Settlement). 

Text Editor 
The user should input in this box the complete path and command line for the preferred-text editor 

or word processor that will be used to examine and print the input, output, and the processor run notes files 
created by the APILE program. 
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As a default, the command line c:\windows\notepad.exe is used to operate a standard text editor.  
Microsoft Notepad is included with Microsoft Windows XP, VISTA and Windows 7, 8, 10 and 11.  
However, the path to the directory where notepad.exe is installed varies in different versions of the 
Microsoft Windows operating system. 

There may be some instances when the output files are too large for Notepad and a different text 
editor or word processor should be used.  In those cases, it is suggested to use Microsoft WordPad 
(c:\windows\wordpad.exe). 

Depth/Elevation 
Many users may prefer to enter the depths of soil layers in elevations and thus visualize the results 

of load transfers in the same elevation references.  To use elevations, the user simply places a check mark 
under Use Elevations instead of Depth and enters the value of the elevation at the grade level (top of 
first soil layer). 

For a model with a batter pile (Section 3.2.6 and Section 3.2.7), the selection (check mark) of Use 
Elevations instead of Depth will provide tabular and plot results of load transfers for vertical elevations.  
When using the default display of depth (no check mark), the tabular and plot results of load transfers are 
provided for length of pile (length along the pile axis). 

The number that the user enters as Elevation at soil surface can be positive or negative and in the 
same base units (either ft or m) as the one selected for the APILE model.  Any previously entered Depth 
parameters (under Data > Soil Layers) will be converted to the specified elevations.  A model can be 
changed from Elevation to Depth as desired by the user. 

Tip Resistance 
By default, APILE averages soil properties from 1.5 diameters of pile tip (above and below pile tip).  

Using the Average Depth to Estimate Tip Resistance drop-down menu, the user may select to change 
that averaging to 0 D (no averaging), 1.5 D (default averaging) or 3.0 D (three diameters above/below pile 
tip).  This averaging is recommended to prevent piles from punching through to a weaker soil layer.  For 
additional comments, users can read the notes on “Punch Through Commentary on End Bearing” in the 
separate APILE Technical Manual. 
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Figure 3.22   Options > Control Options 

3.4 Help Menu 
The Help menu provides an online help reference on topics such as: using the program, entering 

data, information about variables used in the program and methods of analyses.  Submenu options, shown 
in Figure 3.23, are briefly described below. 

User’s Manual  ............... this selection calls for any installed PDF reader (Adobe Acrobat, Acrobat Reader 
or similar) to open the User’s Manual (contains a Chapter of examples installed with the 
program).  This document is formatted as a protected PDF file. 

Examples Manual .......... this selection calls for any installed PDF reader (Adobe Acrobat, Acrobat Reader 
or similar) to open the Examples Manual.  This document is formatted as a protected PDF 
file. 
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Technical Manual ..........  this selection calls for any installed PDF reader (Adobe Acrobat, Acrobat 
Reader or similar) to open the Technical Manual.  This document is formatted as a 
protected PDF file. 

About ............... this provides a screen describing the program version, date, maintenance expiration date, 
USB serial number and methods for accessing technical support. 

Check for Updates ........ starts the default Internet browser and sends the user to a page that describes 
information about the user’s license (release and maintenance expiration date) as well as 
the latest release that is available for downloading at the Ensoft site.  Users may only run 
in full mode maintenance updates that were released before the expiration date of the user’s 
license. 

  
 a. Single-User License b. Client on Local Network License 

Figure 3.23   Help Menu 

Ensoft Key Inquirer........ this selection is only available for single-user licenses (not available in local 
network licenses). This utility allows the user to check information contained in the USB 
Key that is attached to the computer in use.  With this utility the user can see the following 
information: dongle serial number and expiration date, licensed program names and type 
of licenses, maintenance expiration date of each software license, licensed company name, 
allowed IP subnets.  This utility is installed in the selected installation directory with the 
following filename: ensoft_key_inquirer_v5.exe (may change with time). 

Check Network Dongle .   this selection is only available in client computers of local network licenses (not 
available in single-user licenses).  This calls the utility that is used to check the licensing 
and to troubleshoot communications with a license manager (or software server).  This 
utility is very useful in case of problems in clients while trying to run the licensed software.  
This utility is installed in the selected installation directory with the following filename: 
CheckNetworkDongle_ipv_511.exe (may change with time). 

 



 

 

CHAPTER 4. References for Program 
Execution and Output 
Reviews 
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4.1 Introduction 
CHAPTER 4 presents options related to execution of the program and includes methods of 

addressing run-time errors.  This Chapter also includes suggestions for reviewing input, output, and 
processor text files.  The final section of this Chapter includes descriptions about all the output curves that 
may be observed in graphical form.  The commands covered in this chapter are contained in the top menu, 
under the Computation and the Graphics titles. 

4.2 Computation Menu 
This menu option is selected to execute the program using the parameters that were saved in the 

input-data file.  Within the options contained under this menu, shown in Figure 4.2, there are commands 
that facilitate the reviews of the text files produced for storing input data, output results, and processor 
notes.  In addition, the user may select an option to observe a graphical representation of the modeled pile 
and soil layers.  Detailed description of the submenu options contained under the Computation menu are 
explained in the following topics. 

4.2.1 Computation Menu Speed Buttons 

Three speed buttons in the button bar (shown in Figure 4.1) provide access to the following 
commands (from left to right): Computation > Run Analysis, Computation > Edit Output Text, and 
Computation > 3D View. 

 
Figure 4.1   Speed Buttons for the Computation Menu (within rounded rectangle) 

4.2.2 Computation > Run Analysis 

The input-data file will be first saved to disk after selecting the Computation > Run Analysis 
submenu option, which executes the analytical portion of program APILE. 

The user should remember to save the input data under an user-specified name before 
executing the analytical module.  When saving data to disk, APILE will automatically add an extension of 
the type *.ap10d to the name of the input file. 
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Figure 4.2   Sample Computation menu. 

When the execution process is finished the active command is returned to the main APILE program 
with a screen indicating that computations are completed.  The user should check the output text file for 
any warning and/or error messages that were produced during computations. 

At the beginning of the run, the analytical module will read the saved input data progressively.  If an 
input-data format is incorrect during reading, the analytical module may stop and display an error message 
along with a status report in a file with the same name as the input and with the extension *.ap10r.  This 
file may be accessed by selecting Edit Processor-Run Notes in the Computation menu.  Within the 
processor-run notes, if all input data was read correctly, the analytical module will show the message THE 
EXECUTION IS IN PROGRESS. 

The analytical module automatically creates an output file with the same name as the input and with 
the extension *.ap10o.  This file may be accessed by selecting Edit Output Text in the Computation 
menu.  Once a successful run is produced, the user may proceed to the next items for observation of results. 

4.2.3 Computation > Edit Input Text 

This command is used to edit the input-data file in plain text mode.  This command becomes active 
after new data files have been saved to disk or when opening existing data files.  The command is helpful 
for experienced users who may want to change one or two parameters quickly using the text editor, or for 
those users wishing to observe the prepared input data in text mode. 

This submenu automatically invokes the word processor or text editor specified under 
Options/Control Options/Text Editor.  The default setting is to use the utility program named notepad.exe 
provided by Microsoft Windows©. 

Input-data files are automatically saved to disk with the user-specified file name and the extension 
of *.ap10d by program APILE. 

4.2.4 Computation > Edit Processor Run Notes 

This command is used to edit an intermediate text file that may be produced during each analytical 
run.  This feature is not used in early editions of APILE but in the future it will include notes produced 
during the processing of the input data. 
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This submenu will automatically invoke the word processor or text editor specified under 
Options/Control Options/Text Editor.  The default setting is to use the utility program named notepad.exe 
provided by Microsoft Windows©. 

Files containing processor-run notes will be automatically saved to disk with the same file name as 
the input-data file but with the extension *.ap10r. 

4.2.5 Computation > Edit Output Text 

This command is used to edit the output-text file that is automatically produced during each 
analytical run.  This command becomes active after new data files have been saved to disk and 
successfully executed, or when opening previously-executed data files. 

This submenu will automatically invoke the word processor or text editor specified under 
Options/Control Options/Text Editor.  The default setting is to use the utility program named notepad.exe 
provided by Microsoft Windows©. 

Output files are automatically saved to disk with the same file name as the input-data file but with 
the extension *.ap10o.  Use of Microsoft Notepad© for editing the output file for Example Problem 1 is 
shown in Figure 4.3. 
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Figure 4.3   Sample use of Microsoft Notepad © for editing the output-text file of 
Example Problem 1 (may change with time). 

4.2.6 Computation > 3D View 

The Computation > 3D View provides a graphical screen that displays a three-dimensional view 
of the pile and soil layers along with their various depths and other user-selected elements.  This 
command becomes active after data of Pile Properties and Soil Layer Data have been entered 

under the Data menu, or when opening previously-executed data files.  The Show 3D View and new speed 
buttons provide additional parameters for modifications of the graphical display.   

A sample graphics of this command option is shown in Figure 4.4, which also includes the Show 
3D View > Combined Plots which may be selected after a successful computational run. 

This selection can be useful to quickly visualize the results of pile capacity for skin friction, end 
bearing and total capacity for various shaft penetrations.  The observation can also be helpful to determine 
the impact of certain soil layers in the contribution to total capacity. 
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Figure 4.4   Sample Computation > 3D View. 

4.2.6.1 3D View Speed Buttons 

A group of seven speed buttons provide access to the following commands (from left to right): 
Panning (to pan click and hold anywhere in 3D graphics plus drag mouse up, down or sideways), Zooming 
(to zoom click and hold anywhere in 3D graphics plus drag mouse up to enlarge graphics or drag mouse 
down to reduce graphics), Rotating (to rotate click and hold anywhere in 3D graphics plus drag in any 
desired direction), Zoom Windows (to zoom into a windows click on top left of desired window to be 
zoomed in 3D graphics and drag mouse to bottom right), Zoom In (to zoom in click anywhere in 3D 
graphics), Zoom Out (to zoom out click anywhere in 3D graphics), Restart View (restarts the original 3D 
graphics before any pan, rotate or zoom operations). 

4.2.6.2 Show 3D View Menu 

In this menu, users can select to turn on/off the pile image, soil layers and/or the labels for the soil 
layers.  After a successful run, users may also be able to display the Combined Plots (shown in Figure 
4.4) with a graphical reorientation of select result charts. 

4.2.7 Computation > Generate GRLWEAP Data 

APILE has an option to export the soil profile and computed load transfers per pile increment from 
any model to an external file that can be read by the separate GRLWEAP software for evaluations of pile 
driving efforts (driveability).  The dialog box in Figure 4.5 is provided for reference. 

4.2.7.1 Importing into GRLWEAP14 

The Generate button in Figure 4.5 prompts the user to save a file of the type ‘filename.srp’.  The 
‘srp’ extension is used by GRLWEAP14 to import a ‘Soil Resistance File’ for Customized Soil Parameters.  
The following steps are recommended for importing into GRLWEAP14: 

1. Create or open a model for Driveability analysis. 
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2. Select Input > Soil Model. 
3. Click Customize Soil Param. Button. 
4. Select Import button. 
5. Browse and select to Open the ‘srp’ file that was generated in APILE. 
6. Check imported data table to make sure the parameters (see next section for references) are 

appropriate for the modeled pile system. 
7. Click Ok button twice and proceed with interface (other input/features) of the GRLWEAP14 

software. 

4.2.7.2 APILE’s GRLWEAP Output Data 

APILE exports the set of parameters listed below to the ‘srp’ file when generating GRLWEAP14 
data.  Please note that while some of the values are determined from static axial analysis of piles, others are 
evaluated solely based on soil parameters and some are set to be constant.  Please review the generated 
values and adjust as needed based on your use case. 

Depth: This is the depth, measured from the ground surface downward, used internally by APILE analysis. 
Maximum number of points accepted by GRLWEAP14 is limited to 100 points. 

Unit Shaft Resistance: Unit skin friction obtained by APILE analysis. 

Unit Toe Resistance: Tip resistance of pile obtained by APILE analysis, normalized by the pile’s end-
bearing area. See “end bearing area” further below. 

Shaft Quake: Uniformly set to 2.5 mm (please see notes in GRLWEAP manuals: “Clear relationships 
between soil type and shaft quake or pile size and shaft quake are unestablished.  A 2.5 mm 
(0.1 in) shaft quake is reasonable and generally accepted.  Although shaft quakes are 
assumed to be the same in all soils, the driveability input allows for variation of those 
values per soil layer.”). 

Toe Quake: The outputted value for toe quake is evaluated based on the table below using solely the soil 
layer properties (please see notes in GRLWEAP manuals: “The GRLWEAP toe quake 
recommendation similarly expresses its magnitude as a function of pile diameter (size). 
For very dense or hard soils the recommendation is D/120 and for softer materials D/60. 
Note: Much larger toe quake values have been observed. Toe quakes are often quite 
different when driving, restriking, or statically loading the same pile. Large toe quakes 
cause a high rebound and can cause damaging tension stresses in concrete piles even with 
high resistance values. Further, large toe quakes can produce high blow counts, which 
makes driving displacement piles difficult.”). 

Table 4.1   Toe Quake Reference (GRLWEAP14 Manual) 

Clay Sand Toe Quake 
Value Undrained Shear 

Strength (kPa) SPT Blow Count Friction Angle 
(degrees) 

su ≤ 15 N ≤ 5 φ ≤ 30 D/60 
15 < su < 150 5 < N < 30 30 < φ < 41 Linearly interpolated 

su ≥ 150 N ≥ 30 φ ≥ 41 D/120 
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Shaft damping: The value is set to be 0.15 s/m and 0.65 s/m for sand and clay soil types (Standard Smith). 

Toe damping: The toe damping is set to a fixed value of 0.5 s/m for all layers (Standard Smith). 

Setup factor: User-specified per soil type, with defaults shown in application window (please see notes in 
GRLWEAP manuals: “For example, a setup factor of 5 is reasonable in a submerged sand, 
which is typically 1 or 1.2 for impact driving. This means that only 20% of its long term 
shaft resistance is present during vibratory driving. On the other hand, for highly plastic 
cohesive soils, not much resistance is lost. The setup factor may be as low as 1.0 for 
vibratory driving. Often, it is 2 for impact driving. Alternatively, soft clays or any material 
that tends to behave in a thixotropic manner may lose as much resistance as for impact 
driving and should be considered with a higher setup factor.”). 

Setup time: Outputted value is the user-inputted value and set to be constant for all data points (please see 
notes in GRLWEAP manuals: “A Variable Setup Analysis considers the partial setup that 
occurs during pile driving caused by driving interruptions. For the Variable Setup 
Analysis, a set-up time and a limit distance needs considered. The set-up time specifies the 
time period necessary for the soil to reach the full LTSR. The Limit Distance specifies how 
far the pile needs driven until it loses all soil set up, or until it reaches the SRD. All soil 
related static and dynamic resistance parameters, SRD, LTSR, Setup, Friction Fatigue, 
and Gain/Loss factors and calculations are explained in GW14 Background Report, Part 
2.”). 

Limit Distance: Outputted value is the user-inputted value and set to be constant for all data points (please 
see notes above and others in GRLWEAP manuals: “The limit distance, LL, is a constant 
and may be considered a soil property. The user can enter this soil property in the soil 
resistance profile and has the dimension of length, of m or ft.” 

 .........................  “There is no point in specifying set-up time if the limit distance is unknown or vice-versa. 
Entering 1 parameter while not specifying the other leads to curious results” 

 ......................... “If no set-up factors are specified, GRLWEAP assumes set-up factors of 1 for all layers. 
Gain/loss factors then produce uniform capacity gains or losses in all soil layers along the 
pile”). 

Shape factor: Outputted value is the user-inputted value and set to be constant for all data points. 

End bearing area: The end bearing area is outputted as follows. 

Circular piles: 

 ...... Unplugged: π/4 (D_o^2-D_i^2 ) 

 ...... Plugged:  π/4 D_o^2 

Non-circular piles: 

 ...... Pile-tip cross-sectional area. 

In the above D_o and D_i are the outer and inner pile diameters, respectively. 

Please see notes in GRLWEAP manuals: “GRLWEAP users should be aware that modeling 
plugged (or partially plugged) end bearing requires additional considerations. Most 
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importantly, they should be reminded that for non-displacement piles the soil quake 
recommendations are 2.5 mm (0.1 in). For displacement piles, the toe quake is GRLWEAP 
14 Background Report Part 2 69 recommended to be D/60, where D is the pile diameter 
or width, for all not very dense or hard soils and D/120 for very dense or hard soils.”. 

Users must check and make sure that the generated ‘srp’ file contains values that 
are appropriate for their models based on GRLWEAP Technical Manual and/or 

Technical References. 

Any of the exported values can be changed either by editing the outputted ‘srp’ 
files with a text editor, or by editing them directly within GRLWEAP14. 

 

Figure 4.5   Sample Computation > Generate GRLWEAP Data. 

4.2.8 Computation > Generate Report in MS-Word 

This menu selection allows users to export parameters for the APILE model along with optional data 
groups (see Figure 4.7) into a pre-formatted Microsoft Word file.  Each generated report is provided with 
the following information: 

• Software name, version and update. 
• License information (serial number, company name and licensed office site). 
• Name and path of input/output data files. 
• Date of computational run. 
• Echo printing of various model data parameters (computational and unit load transfer methods, 

type of loading, pile type). 

In addition, in the dialog box in Figure 4.7 users can select to include the following optional content: 
Input > Model Schematic adds to the Word report a graphical representation of the pile, soil layers 

(with some mechanical properties) and layer depths (or elevations). 
Input > Pile Properties adds a Word table with echo printing of the properties that were entered 

by the user for the modeled pile. 
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Input > Soil Properties adds a Word table with echo printing of the soil layers and mechanical 
properties that were defined by the user.  This table also includes any soil properties that were 
estimated or assumed internally by APILE based on other parameters. 

Results > Pile Capacity adds a Word table and/or graphical plots with computational results of 
Total Skin Friction, Skin Friction (or Self Weight), End Bearing and Ultimate Capacity for each 
Method of Pile Capacity that were selected by the user. 

Results > tz Curves adds a Word table and/or graphical plots with the t-z curves that were internally 
generated by APILE for top, middle and bottom of each soil layer (and for each optional depth that 
may have been selected by the user). 

Users may copy and paste the contents of any of the tables above from Word to a spreadsheet if they prefer 
different units or plot format.  Keep in mind that the separate Graphics > Export Plots to MS-Excel 
described in the next section provides a simple method for editing plots. 

 

Figure 4.6   Dialog box for Generate Report in MS Word. 

4.3 Graphics Menu 
This menu is selected to observe the different graphical representations of the program results 

contained in the output file.  Options contained under this menu are shown in Figure 4.7.  Not all of the 
graphics may be enabled for observation, since active curves depend on specifications contained in the 
input. 

Notes Regarding Computation Methods 
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1. Some graphics and output data will be generated for all four methods of computations, regardless 
of the internal method that the user selects.  Data and plots that will always be generated for all 
methods of computations (under Data > Computational Method > Method for Pile Capacity) 
are the following: 

 Unit Skin Friction vs. Depth 
 Accumulated Skin Friction vs. Depth 
 Tip Resistance vs. Depth 
 Total Capacity vs. Depth 

2. The following graphics will only be generated using the selected method of computation (under 
Data > Computational Method > Method for Load Settlement): 

 Load Distribution 
 Combined Plot 
 Axial load vs. Settlement 
 Internally-Generated t-z Curves 

All of the graphical representation of output data that may be produced by the program are contained 
in the following commands of the Graphics menu: 

Unit Skin Friction vs Depth 
Accumulated Skin Friction vs Depth 
Tip Resistance vs Depth 
Total Capacity vs Depth 
Load Distribution Curves 
Combined Plots vs Depth 
Axial Load vs Settlement   
Internally Generated t-z Curves 
Extra t-z Curves at User Specified Depths 
Internally Generated Q-w Curve 

The observation of any of the above-listed curves will activate the new graphics mode of APILE.  
Several changes occur during use of the graphics mode. 
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Figure 4.7   Sample Graphics menu. 

4.3.1 Mouse Commands in the Graphics Mode 

Table 4.2 describes mouse commands that become enabled automatically during all graphical 
observations of output curves. 

Event Description 
Mouse Left Click Zooms in on the graphics at the clicked position  (up to five zoom levels) 
Mouse Right Click Zooms out from the graphics 
Mouse Double Click on Legend Turns the selected curve on/off at every click 

Table 4.2  Mouse commands in the graphics mode 

4.3.2 Plot Options Menu 

A sample plot in graphics mode is shown in Figure 4.8.  While in graphics mode, users can select 
the desired plot on the left side of the screen and also some plot options (shown in the middle of Figure 
4.8).   

The Plot Options menu offers some changes that users can make to the chart settings.  Please notice 
that the changes that are made in this menu are not saved with the model, they are only for visual aid while 
looking at the results from a model. 

Users that need more involved formatting of the plot files are encouraged to select the APILE feature 
for exporting plot data to a pre-formatted spreadsheet (see Section 4.3.14 of this manual).  The simple 
APILE plots are useful for immediate observation of results while the formatting on a spreadsheet allows 
for a wide variety of presentations in report format.  Another option for exporting of plots into a report 
format was presented in Section 4.2.8 of this manual. 
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Figure 4.8   Sample Plot and Plot Options Menu in Graphics Mode 

Show Legend 
This activates or deactivates the floating legend included in the graphics mode.  The legend box can 

be moved with click-and-drag operations of the mouse to any position in the graphics screen.  Despite its 
location in the screen, the legend is always located at the right-bottom corner on the printouts. 

Show Soil Layer 
Click this menu-item to activate or deactivate a soil profile plotted at the right side of the graphics.  

This option is not available in some plots (where not applicable). 

Show Markers 
This menu provides the option to activate or deactivate the markers for each point of all the curves 

displayed in the active screen of the graphics mode.  By default, the program automatically plots at every 
foot of penetration, or every 30 cm when using metric units.  The user may optionally select to show markers 
every 1, 2, 3, 5, or 10 increments of unit.  The type of markers used in each curve is automatically selected 
by the program.  Once activated, the markers are enabled for all visible curves of the active graphics screen. 

Font Size 

This menu provides the option to enlarge the default size of fonts used in plots.  The user may 
optionally select to enlarge the font by 1.5, 2, 2.5, 3, or 4 times of the default size. 
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Line Width 

This menu provides the option to enlarge the default width of lines used in plots.  The user may 
optionally select to enlarge the width by 2, 4, 6, or 10 times of the default width. 

Graph Title 

The user may optionally add a title to the active graphics using this command.  However, the 
parameters selected here are not saved with the output file and must be changed each time the file is opened. 

Edit Legend 

The user may change the text of the legend in the active graphics using this command.  However, the 
modified names are not saved with the output file and must be changed each time the file is opened. 

Active Curves 
This command is used to activate or de-activate the graphs that are displayed on the screen. 

Print... 

This command is used to produce a hard copy of the active graphics screen.  The Print dialog box 
includes a drop-down menu that allows the user to select any of the installed Windows printers, allows for 
change of printer properties, and allows the selection of the total number of copies to be printed.  The 
printed graphics is sized according to the margins that the user specifies in the Plot > Page Setup menu. 

Page Setup 

The user can here specify the printed size of the active-graphics screen.  The size of the plot is based 
on the specified margins and selection of paper orientation.  The parameters selected here are not saved 
with the output file and must be changed each time that the graphics is plotted. 

Plot to Disk... 

This command is used to save the active-graphics screen to disk.  The format of the saved file is as 
bmp graphics (bitmap file), which is the internal-file format used in Microsoft Windows©. 

4.3.3 Graphics > Unit Skin Friction vs Depth 

This command provides a graphical representation of the unit load transfers in side resistance (skin 
friction) versus pile length below grade (or versus Elevation) for the modeled pile according to the 
computational methods that were selected by the user.  Unit load transfers in side resistance are presented 
in units of axial force per area (surface area) of the modeled pile.  The data value at each length/depth 
represents the unit side resistance that was used during internal capacity computations. 

For vertical piles (no batter) the vertical axis represents depth or actual pile penetration below ground 
line (stickup length, if any in the model, is not shown).  When the model has batter piles, the vertical axis 
represents vertical elevation (if check marked in Section 3.3.3) or length of pile below grade along the batter 
line.  If needed, the output text file for models with batter piles also include an extra column with 
corresponding vertical depth (elevation) below ground. 

A sample graphics screen of the Unit Skin Friction vs Depth command option is shown in Figure 
4.9.  These curves are automatically generated after successful analytical runs of a driven pile. 
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Notice that the values of unit skin friction represented in these graphics are shown after modifications 
from the reduction/resistance factors, if any, that were specified by the user (under the Data > Soil Layers 
menu). 

 

Figure 4.9   Sample Unit Skin Friction vs Depth. 
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4.3.4 Graphics > Accumulated Skin Friction vs Depth 

This command provides a graphical representation of the accumulated load transfers in side 
resistance (skin friction) versus pile length below grade (or versus Elevation) for the modeled pile according 
to the computational methods that were selected by the user.  Accumulated load transfers in side resistance 
are presented in units of axial force.  The data values represent the total axial load that is transferred to the 
soil in side resistance at each length/depth. 

For vertical piles (no batter) the vertical axis represents depth or actual pile penetration below ground 
line (stickup length, if any in the model, is not shown).  When the model has batter piles, the vertical axis 
represents vertical elevation (if check marked in Section 3.3.3) or length of pile below grade along the batter 
line.  If needed, the output text file for models with batter piles also include an extra column with 
corresponding vertical depth (elevation) below ground. 

A sample graphics screen of the Accumulated Skin Friction vs Depth command option is shown 
in Figure 4.10.  These curves are automatically generated after successful analytical runs of a driven pile. 

Notice that the values of accumulated skin friction represented in these graphics are shown after 
modifications from the reduction/resistance factors, if any, that were specified by the user (under the Data 
> Soil Layers menu). 

 

Figure 4.10   Sample Accumulated Skin Friction vs Depth. 
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4.3.5 Graphics > Tip Resistance vs Depth 

This command provides a graphical representation of the tip resistance (end bearing) versus pile 
length below grade (or versus Elevation) for the modeled pile according to the computational methods that 
were selected by the user.  Tip resistance is presented in units of axial force.  The data values represent the 
total axial load that is transferred to the soil in end bearing for each length/depth (starting from ground 
surface). 

For practical reasons, in open-ended piles with Internal Pile Plus Calculated by Program the 
internal side friction is added to the end bearing.  This is partly because in the APILE program the end 
bearing plus internal side friction are added together until a plug forms (until it reaches the equivalent end 
bearing of a close-ended pipe). 

For vertical piles (no batter) the vertical axis represents depth or actual pile penetration below ground 
line (stickup length, if any in the model, is not shown).  When the model has batter piles, the vertical axis 
represents vertical elevation (if check marked in Section 3.3.3) or length of pile below grade along the batter 
line.  If needed, the output text file for models with batter piles also include an extra column with 
corresponding vertical depth (elevation) below ground. 

A sample graphics screen of the Tip Resistance vs Depth command option is shown in Figure 
4.11.  These curves are automatically generated after successful analytical runs of a driven pile that is 
subjected to compression loads (under the Data > Computation Method menu).  This command option is 
grayed out for tension loads. 

Notice that the values of tip resistance represented in these graphics are shown after modifications 
from the reduction/resistance factors, if any, that were specified by the user (under the Data > Soil Layers 
menu). 

 
Figure 4.11   Sample Tip Resistance vs Depth. 
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4.3.6 Graphics > Total Capacity vs Depth 

This command provides a graphical representation of the ultimate total capacity versus pile length 
below grade (or versus Elevation) for the modeled pile according to the computational methods 
that were selected by the user.  Total capacity is presented in units of axial force.  The data values 

represent the total axial load that is transferred to the soil in end bearing plus side resistance for each 
length/depth (starting from ground surface/grade).   

Values of total capacity are equal to skin friction plus tip resistance for compressive loads.  Total 
capacity is equal to skin friction plus self-weight of piles for uplift loads (self-weight is estimated internally 
according to user selections on Data > Pile Material and Data > Circular-Section Pile or Data > 
Noncircular-Section Pile). 

For vertical piles (no batter) the vertical axis represents depth or actual pile penetration below ground 
line (stickup length, if any in the model, is not shown).  When the model has batter piles, the vertical axis 
represents vertical elevation (if check marked in Section 3.3.3) or length of pile below grade along the batter 
line.  If needed, the output text file for models with batter piles also include an extra column with 
corresponding vertical depth (elevation) below ground. 

A sample graphics screen of the Total Capacity vs Depth command option is shown in Figure 4.12.  
These curves are automatically generated after successful analytical runs of a driven pile.  Notice that the 
values of tip resistance represented in these graphics are shown after modifications from the 
reduction/resistance factors, if any, that were specified by the user (under the Data > Soil Layers menu). 

 
Figure 4.12   Sample Total Capacity vs Depth.  
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4.3.7 Graphics > Axial Load vs Settlement 

This command provides a graphical representation of the curves of axial load versus settlement 
for the modeled pile based on the t-z/Q-w curves generated according to the user-specified 
computation method (under the Data > Computational Method > Method for Load 

Settlement menu).  For tension loads the settlement curve goes up in the graph to represent pile pullouts. 

A sample graphics screen of the Axial Load vs Settlement command option is shown in Figure 
4.13.  These curves are automatically generated after successful analytical runs of a driven pile. 

 

 

Figure 4.13   Sample Axial Load vs Settlement. 
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4.3.8 Graphics > Combined Plots vs Depth 

This command provides a single graph with the curves of skin friction, tip resistance, and total 
capacity versus pile length below grade (or versus Elevation) for the modeled pile.  The plotted 
curves of load transfers correspond to the particular criteria selected by the user (under the Data 

> Computational Method > Method for Load Settlement menu). 

For vertical piles (no batter) the vertical axis represents depth or actual pile penetration below ground 
line (stickup length, if any in the model, is not shown).  When the model has batter piles, the vertical axis 
represents vertical elevation (if check marked in Section 3.3.3) or length of pile below grade along the batter 
line.  If needed, the output text file for models with batter piles also include an extra column with 
corresponding vertical depth (elevation) below ground. 

A sample graphics screen of the Combined Plots vs Depth command option is shown in Figure 
4.14.  These curves are automatically generated after successful analytical runs of a driven pile.  Notice that 
the values represented in these graphics are shown after modifications from the reduction/resistance factors, 
if any, that were specified by the user (under the Data > Soil Layers menu). 

 

Figure 4.14   Sample Combined Plots vs Depth. 
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4.3.9 Graphics > Load Distribution 

The user may select this command option to observe a graphical representation of distributions of 
axial loads versus depth for the modeled pile.  From this presentation the user can identify the side friction 
contributed by each soil layer based on the strength parameters.  The plotted curves of load distributions 
correspond to the particular criteria selected by the user (under the Data > Computational Method > 
Method for Load Settlement menu). 

For vertical piles (no batter) the vertical axis represents depth or actual pile penetration below ground 
line (stickup length, if any in the model, is not shown).  When the model has batter piles, the vertical axis 
represents vertical elevation (if check marked in Section 3.3.3) or length of pile below grade along the batter 
line.  If needed, the output text file for models with batter piles also include an extra column with 
corresponding vertical depth (elevation) below ground. 

A sample graphics screen of the Axial Load vs Load Distribution command option is shown in 
Figure 4.15.  These curves are automatically generated after successful analytical runs of a driven pile. 

 

Figure 4.15   Sample Load distribution curves. 
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4.3.10 Graphics > Internally-Generated t-z Curves 

This command provides a graphical representation of the t-z curves that were generated internally 
by APILE based on the user-specified computation method (under the Data > Computational 
Method > Method for Load Settlement menu).  The program automatically generates three t-

z curves for each soil layer (top, middle, and bottom).  The legend for the t-z curves indicate depth below 
grade or elevation (if check marked in Section 3.3.3). 

A sample graphics screen of the Internally Generated t-z Curves command option is shown in 
Figure 4.16.  These curves are automatically generated after successful analytical runs of a driven pile. 

 

 

Figure 4.16   Sample of internally-generated t-z curves. 
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4.3.11 Graphics > Extra t-z Curves at User Specified Depths 

This command provides a graphical representation of extra t-z curves requested by the user to print 
out at specific depths (under the Options > Print t-z Curves at Additional Depths menu).  The t-z curves 
were generated internally by APILE based on the user-specified computation method (under the Data > 
Computational Method > Method for Load Settlement menu).  These curves are in addition to the t-z 
curves that are automatically generated at the top, middle, and bottom of each layer. 

This command option is grayed out if the user did not select to the option to print extra t-z curves (no 
check mark under the Options > Print t-z Curves at Additional Depths menu). 

A sample graphics screen of the Extra t-z Curves at User Specified Depths command option is 
shown in Figure 4.17. 

 

 
Figure 4.17   Sample of extra t-z curves at user specified depths. 
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4.3.12 Graphics > Internally-Generated Q-w Curve 

This command provides a graphical representation of the Q-w curve (tip resistance vs. movement) 
that was generated based on the user-specified computation method (under the Data > Computational 
Method/Method for Load Settlement menu).  The tip resistance is represented as Q in units of axial force 
representing total tip resistance at the pile tip, not the unit tip resistance. 

This curve is automatically generated after successful analytical runs of a driven pile that is subjected 
to compression loads (under the Data > Computation Method > Method for Pile Capacity menu).  This 
command option is grayed out for tension loads. 

A sample graphics screen of the Internally Generated Q-w Curve command option is shown in 
Figure 4.18. 

 
Figure 4.18   Sample of internally-generated Q-w Curve. 

4.3.13 Graphics > Neutral Plane Analysis (Downdrag – FHWA) 

Models selecting the FHWA Method for pile capacity will provide the curves for Neutral Plane 
Analysis following FHWA (2016) recommendations.  Please see Section 3.5.4 of the APILE Technical 
Manual for notes and further references on this method. 

A sample output of these curves is provided in Figure 4.19.  The APILE program allows the users to 
select the curves of total mobilized resistance based on the shaft resistance plus a mobilized toe resistance 
of 100%, 50%, and 0% of the nominal toe resistance.  Users may change the Pile Penetration at Toe 
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and/or the Permanent Load as desired.  Graphics will change according to the values entered by the user.  
A tabulated display is provided with resulting values of Axial Load and Drag Force. 

For ease of reference, the selection (check mark) of the Show Resistance Curves will replace the 
Neutral Axis curves with the calculated curves (from APILE using FHWA Method) of transfers in side 
resistance, end bearing and total resistance versus depth. 

Any of the charts observed under this display can be printed with the Print Chart button or exported 
(along with data points) to a pre-formatted excel spreadsheet with the Export Chart to Excel button. 

 
Figure 4.19   Sample Curves of Neutral Plane Analysis. 

4.3.14 Graphics > Export Plots to MS-Excel 

This command is selected to export some (or all) of the output plots to a pre-formatted spreadsheet 
file for Microsoft Excel©.  Each check-marked plot will be exported to two spreadsheet tabs, one contains 
the data points and the second the plotted chart.  A sample graphics screen of the Graphics > Export Plots 
to Excel dialog box is shown in Figure 4.20. 
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Figure 4.20   Export to Excel Window. 

Options contained in this dialog box are explained below. 

Select All 
Marks all available plots for export to an Excel file. 

Unselect All 
Unselect all available plots so none will be exported. 

Generate Excel File 
After clicking this button, the Microsoft Excel software will be started (only if available in the 

computer in use).  The user must wait until all the data has been exported to the file.  User must save the 
generated excel file before closing. 

Close Window 
Click this button to close the Export to Excel dialog box. 

 



 

 

CHAPTER 5. Example Problems 
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5.1 Introduction  
This chapter presents several examples that were solved using APILE.  In order to assure accuracy 

from the computer results, some examples have been compared with the results from hand calculations.  
The step-by-step hand calculations were carried out based on the procedures described in the accompanying 
APILE Technical Manual.  The users can have confidence in their results if limited amounts of hand 
calculations can be done for comparisons.  The studies in this chapter also provide guidance for the analysis 
of axially loaded piles with APILE. 

There are three types of output data provided by the computer.  The first type is the output file which 
contains formatted text that consists of an echo-print of the input data; the distribution of skin friction, end 
bearing, and total capacity; and the final load-settlement curve.  The second type of output presents the data 
for a graphics file that allows the code to produce plots.  All of the data are saved with ASCII format and 
the user may access the files with any text editor. 

Several problems are provided herein as examples of different applications that may be solved using 
our computer program APILE.  Each example focuses on a particular computational feature of the program.  
Input files for each example are automatically copied to the APILE data directory during installation (<Root 
Drive>\Ensoft\APILE2018-Examples). 

Example problems provide the user information on input and output of various cases, and present a 
quick tutorial for real-world applications.  The user is encouraged to study these examples and, with 
modifications, may even use them to solve similar problems.  However, by no means can these limited 
examples explore the full functions and features provided by APILE. 

The main features of each example included with APILE are summarized as follows. 

Example Problem 1 – Steel Pipe Pile 
• non-uniform soil deposit, two layers of sand and two layers of clay, 

• open-ended steel pipe pile, 

• example with English units, and 
• hand calculations with FHWA, USACE and API methods for verification. 

Example Problem 2 – Offshore Steel Pipe Pile in Sand 
• sand layers with varying soil parameters, 
• open-ended steel pipe pile with internal plug computed within APILE, 

• example with S.I. units, and 

• hand calculations with API method for verification. 

Example Problem 3 – Open-Ended Steel-Pipe Pile in Clay 
• clay layers with varying soil parameters, 

• open-ended steel pipe pile with internal plug computed within APILE, and 

• example with S.I. units. 

Example Problem 4 – Prestressed Concrete Pile for Bridge Foundation 
• non-uniform soil deposit, one layers of stiff clay and one layer of sand, 
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• prestressed concrete pile, 

• example with S.I. units, and 

• hand calculations with API, FHWA, and USACE methods for verification (including 
accounting for code-specified limiting values). 

Example Problem 5 – FHWA Tapered Pile 
• sand layers, 

• tapered pile for FHWA method (other methods do not account for tapered pile effects), 

• example with English units, 
• hand calculations with FHWA method for verification (including accounting for code-

specified limiting values). 

Example Problem 6 – Uplift Pile Capacity 
• non-uniform soil layers, and 
• study uplift (tension) capacity of pile. 

Example Problem 7 – CPT Based Method for Close-Ended Pile 
• non-uniform soil layers, 
• steel-pipe pile with closed end,  

• hand-calculation with NGI and MTD methods for verification, and 

• example with S.I. units. 

Example Problem 8 – CPT Based Method for Open-Ended Pile 
• non-uniform soil layers, 

• steel pipe pile with open end,  

• hand-calculation with NGI and MTD methods for verification, and 

• example with S.I. units. 

Example Problem 9 – LRFD Based Method 
• non-uniform sand layers, 
• steel pipe pile with closed end,  

• LRFD load factors and reduction factors, and 

• example with S.I. units. 

Example Problem 10 – API Method on Battered Pile 
• non-uniform clay layers, 

• fully plugged, open ended steel pipe pile, 

• 1.0H:1.5V pile batter, 

• hand-calculation with API method for verification, and 
example with English units. 
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Example Problem 11 – CPT to APILE 
• example for importing and interpreting CPT data into APILE, 

• mixed layers of sand and clay, 

• extra input of PI and YSR for CPT-based methods (NGI, MTD, Fugro and UWA), and 

• example of CPT data imported into APILE with English units. 
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5.2 Example Problem 1 – Steel Pipe Pile in Sand and Clay 
This example is included to illustrate a common case in which a 10 in. diameter steel pile is subjected 

to a vertical load.  The soil deposit is not uniform as shown in Figure 5.1.  It is assumed that the pile is not 
plugged. 

The computational results from APILE for various methods in this example are compared with 
approximated hand computations performed using a spreadsheet.  Selected graphics outputted by APILE 
are also presented along with the output text file.  The user may select to eliminate the printing of capacity 
for each increment length to shorten the length of the output text. 

 

Figure 5.1   General soil description of Example Problem 1. 

5.2.1 Comparison of APILE Results with Hand Computations 

This section contains some comparisons of the results obtained from hand computations against those 
from the computer run in APILE for three different methods. 

5.2.1.1 FHWA Method 

a.  Sand layer from 0 to 10 ft 

Depth 
(ft) 

Inc. 
(ft) 

Avg. 
Effect. 
Stress 
(psf) 

Surface 
Friction 
Angle 

δ (deg) 

Coefficient 
of Lateral 

Stress 
(kδ) 

Correction 
Factor 

(Cf) 

Unit Side 
Friction 

(ksf) 

Incremental 
Side 

Friction 
(lbs) 

2 2 60 11.9 1.15 0.56 7.968 41.72  0(1) 

4 2 180 11.9 1.15 0.56 23.903 125.16 0(1) 
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6 2 300 11.9 1.15 0.56 39.839 208.60 

8 2 420 11.9 1.15 0.56 55.774 292.03 

10 2 540 11.9 1.15 0.56 71.710 375.47 

Summation: 876.1 
(1) APILE model is instructed to ignore top 5 ft 

b.  Clay layer from 10 to 20 ft 

Depth 
(ft) 

Inc. 
(ft) 

Avg 
Shear 
Stress 
(psf) 

Length/ 
Diameter 

Ratio 

Adhesion 
Coefficient 

(α) 

Unit Side 
Friction 

(ksf) 

Incremental 
Side 

Friction 
(lbs) 

12 2 1000 12 1 1000 5236 

14 2 1000 12 1 1000 5236 

16 2 1000 12 1 1000 5236 

18 2 1000 12 1 1000 5236 

20 2 1000 12 1 1000 5236 

Summation: 26180 

c.  Sand layer from 20 to 30 ft 

Depth 
(ft) 

Inc. 
(ft) 

Avg. 
Effect. 
Stress 
(psf) 

Surface 
Friction 
Angle 

δ (deg) 

Coefficient 
of Lateral 

Stress 
(kδ) 

Correction 
Factor 

(Cf) 

Unit Side 
Friction 

(ksf) 

Incremental 
Side 

Friction 
(lbs) 

22 2 1160 11.9 1.15 0.56 154.043 806.57 

24 2 1280 11.9 1.15 0.56 169.979 890.01 

26 2 1400 11.9 1.15 0.56 185.914 973.45 

28 2 1520 11.9 1.15 0.56 201.850 1056.88 

30 2 1640 11.9 1.15 0.56 217.785 1140.32 

Summation: 4867.23 

d.  Summary and Comparison with FHWA Method 

Total side friction = 876+26,180+4,867 = 31,923 lbs vs. 32.0 kips (from APILE)  

Total tip resistance = Ap σv α Nq = (0.104) (1700) (0.67) (64) = 7,582 vs. 7.7 kips (from APILE) 

5.2.1.2 USACE Method 

a.  Sand layer from 0 to 10 ft 

Depth 
(ft) 

Inc. 
(ft) 

Avg. 
Effect. 
Stress 

Surface 
Friction 
Angle 

Coefficient 
of Lateral 

Stress 

Correction 
Factor 

(Cf) 

Unit Side 
Friction 

(ksf) 

Incremental 
Side 

Friction 
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(psf) δ (deg) (kδ) (lbs) 

2 2 60 26.3 1.25 1 37.067 194.08 0(1) 

4 2 180 26.3 1.25 1 99.691 521.98 0(1) 

6 2 300 26.3 1.25 1 166.152 869.97 

8 2 420 26.3 1.25 1 232.613 1217.96 

10 2 540 26.3 1.25 1 299.074 1565.95 

Summation: 3653.88 
(1) APILE model is instructed to ignore top 5 ft 

b.  Clay layer from 10 to 20 ft 

Depth 
(ft) 

Inc. 
(ft) 

Avg 
Shear 
Stress 
(psf) 

Length/ 
Diameter 

Ratio 

Adhesion 
Coefficient 

(α) 

Unit Side 
Friction 

(ksf) 

Incremental 
Side 

Friction 
(lbs) 

12 2 1000 12 0.75 750 3927 

14 2 1000 12 0.75 750 3927 

16 2 1000 12 0.75 750 3927 

18 2 1000 12 0.75 750 3927 

20 2 1000 12 0.75 750 3927 

Summation: 19635 

c.  Sand layer from 20 to 30 ft 

Depth 
(ft) 

Inc. 
(ft) 

Avg. 
Effect. 
Stress 
(psf) 

Surface 
Friction 
Angle 

δ (deg) 

Coefficient 
of Lateral 

Stress 
(kδ) 

Correction 
Factor 

(Cf) 

Unit Side 
Friction 

(ksf) 

Incremental 
Side 

Friction 
(lbs) 

22 2 750 26.3 1.25 1 463.343 2426.06 

24 2 750 26.3 1.25 1 463.343 2426.06 

26 2 750 26.3 1.25 1 463.343 2426.06 

28 2 750 26.3 1.25 1 463.343 2426.06 

30 2 750 26.3 1.25 1 463.343 2426.06 

Summation: 12130.31 

d.  Summary and Comparison with USACE Method 

Total side friction = 3,654+19,635+12,130 = 35,419 lbs vs. 35.1 kips (from APILE) 

Total tip resistance = Ap σv Nq = (0.104) (750) (47) = 3,666 vs. 3.7 kips (from APILE) 

5.2.1.3 API Method 

a.  Sand layer from 0 to 10 ft 
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Depth 
(ft) 

Inc. 
(ft) 

Avg. 
Effect. 
Stress 
(psf) 

Surface 
Friction 
Angle 

δ (deg) 

Coefficient 
of Lateral 

Stress 
(kδ) 

Correction 
Factor 

(Cf) 

Unit Side 
Friction 

(ksf) 

Incremental 
Side 

Friction 
(lbs) 

2 2 60 30 0.8 1 27.713 145.10 0(1) 

4 2 180 30 0.8 1 72.000 376.99 0(1) 

6 2 300 30 0.8 1 120.000 628.32 

8 2 420 30 0.8 1 168.000 879.65 

10 2 540 30 0.8 1 216.000 1130.98 

Summation: 2638.95 
(1) APILE model is specified to ignore top 5 ft 

b.  Clay layer from 10 to 20 ft 

Depth 
(ft) 

Inc. 
(ft) 

Avg 
Shear 
Stress 
(psf) 

Length/ 
Diameter 

Ratio 

Adhesion 
Coefficient 

(α) 

Unit Side 
Friction 

(ksf) 

Incremental 
Side 

Friction 
(lbs) 

12 2 1000 12 0.45 448.95 2350.70 

14 2 1000 12 0.47 465.30 2436.32 

16 2 1000 12 0.48 480.09 2513.76 

18 2 1000 12 0.49 493.63 2584.64 

20 2 1000 12 0.51 512.35 2682.65 

Summation: 12568 

c.  Sand layer from 20 to 30 ft 

Depth 
(ft) 

Inc. 
(ft) 

Avg. 
Effect. 
Stress 
(psf) 

Surface 
Friction 
Angle 

δ (deg) 

Coefficient 
of Lateral 

Stress 
(kδ) 

Correction 
Factor 

(Cf) 

Unit Side 
Friction 

(ksf) 

Incremental 
Side 

Friction 
(lbs) 

22 2 1160 30 0.8 1 535.783 2805.36 

24 2 1280 30 0.8 1 591.208 3095.57 

26 2 1400 30 0.8 1 646.634 3385.78 

28 2 1520 30 0.8 1 702.060 3675.99 

30 2 1640 30 0.8 1 757.486 3966.20 

Summation: 16928.88 

d.  Summary and Comparison with API Method 

Total side friction = 2,639+12,568+16,928 = 32,136 lbs vs. 32.2 kips (from APILE) 

Total tip resistance = Ap σv Nq = (0.104) (1700) (40) = 7,072 vs. 7.0 kips (from APILE) 
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5.2.2 Input and Output Data Files for Example 1 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 1 is the following: 

Example 1 - Steel Pipe Pile in Sand and Clay.ap10d 

The output-data filename for Example 1 is the following: 

Example 1 - Steel Pipe Pile in Sand and Clay.ap10o 

5.2.3 Graphical Results of Computer Analysis 

The resulting plots of unit skin friction, accumulated skin friction, tip resistance, and total capacity 
versus depth provided by the computer program based on different methods, may be seen in Figure 5.2, 
Figure 5.3, Figure 5.4 and Figure 5.5 respectively. 

Results of combined plots versus depth, shown in Figure 5.6, only contains the curves of skin friction, 
tip resistance, and total capacity versus depth for the API RP 2A method specified under Data > 
Computational Method > Method for Load Settlement. 

 
 

 
Figure 5.2   Curves of Unit Skin Friction vs Depth for Example Problem 1. 
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Figure 5.3   Curves of Accumulated Skin Friction vs Depth for Example Problem 1. 

 

Figure 5.4   Curves of Tip Resistance vs Depth or Example Problem 1. 
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Figure 5.5   Curves of Total Capacity vs Depth or Example Problem 1. 

  

Figure 5.6   Combined Plots vs Depth based on API method for Example Problem 1. 
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5.3 Example Problem 2 – Offshore Steel-Pipe Pile in Sand 
This example is included to illustrate a case of a pile on an offshore structure.  The pile is a steel pipe 

and in this example with on outside diameter of 1000 mm and inside diameter of 860 mm.  The subsurface 
condition mainly consists of cohesionless soils and the pile was driven to a depth of 33.3 meters.  The 
computer program APILE calculated 8,004 kN for the total bearing capacity (API RP-2A), which is similar 
to the value of 8,187 kN that is obtained from simplified hand calculations.  Pile and soil data are given in 
Table 5.1. 

 

Table 5.1   Soil Data for Example Problem 2 

5.3.1 Hand Computations for API Method 

The program output will be compared to the results from the following hand calculations. 

5.3.1.1 Skin Friction 

The general equation for skin friction is: 

 
L

x sf o
Q f dA= ∫  

(5.1) 

where 
Qf  =  axial load capacity in skin friction, lb (kN); 

L  =  penetration of pile below ground surface, ft (m); 

fx  =   unit resistance at depth x, measured from ground surface, lb/ft2 (kPa); and 

As  =  side surface area of pile, ft2 (m2). 

At each increment, 

Depth Soil Type γ' φ Ko Nq

(m) (kN/m3) (Deg.)
0 sand 18.1 33 0.46 32
2 sand 19 37.5 0.39 40
2 sand 9.2 37.5 0.39 40
3 sand 10.2 39 0.37 40
3 sand 10.2 39 0.37 40
5 sand 5.7 30 0.5 20
5 sand 5.7 30 0.5 20
25 sand 5.7 30 0.5 20
25 sand 5.7 30 0.5 20

30.5 sand 11.2 40.5 0.35 40
30.5 sand 11.2 40.5 0.35 40
36 sand 11.2 40.5 0.35 40

6

Layer

5

4

3

2

1
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 tan ) )( (x s o sf A k p Aδ=  

 tan( 5))( ( ))( )(x s h Dhf A k φ γ π−= ∑ ∑  

(5.2) 

Or, 

 )( )(x s Max Skin Friction Dhf A π= ∑  

 (5.3) 

where 

k  =  coefficient of lateral earth (ratio of horizontal to vertical normal effective stress), a value of 
k = 0.8 was recommended for open-ended pipe piles, that are driven unplugged, for 
loadings in both tension and compression.  A value of k = 1.0 was recommended for full 
displacement piles. 

po =   effective overburden pressure at the point in question; 

δ  =  the friction angle between the soil and the pile wall.  In the absence of data on δ, APILE 
computes 5oδ φ= −  (in degrees) based on user’s inputted value of friction angle (φ).  The 

limiting f  is interpolated linearly within APILE for intermediate values of δ. 

D  =  outside pile diameter. 

Combining Eq. (5.1) and Eq. (5.2): 

𝑸𝑸𝒇𝒇 = 𝒌𝒌(𝒕𝒕𝒕𝒕𝒕𝒕(∅ − 𝟓𝟓))�𝜸𝜸𝜸𝜸�𝝅𝝅𝝅𝝅𝝅𝝅 

(5.4) 

where k, ∅ and γ are averaged values. 

Using the values from Table 5.1 we can make computations of ∑𝛾𝛾ℎ at various sample depths: 

at 2m:  ∑𝛾𝛾ℎ = �18.1+19
2

� ∗ 2 = 37.1 kN/m2 

At 3m:  ∑𝛾𝛾ℎ = ��9.2+10.2
2

� ∗ 1� + 37.1 = 46.8 kN/m2 

At 5m:  ∑𝛾𝛾ℎ = ��10.2+5.7
2

� ∗ 2� + 46.8 = 62.7 kN/m2 

Values of unit side resistance (fx) at various sample depths can be computed as follows: 

At 2m,  𝑓𝑓2𝑚𝑚 = ��0.46+0.39
2

� �𝑡𝑡𝑡𝑡𝑡𝑡 �33+37.5
2

− 5�� (37.1)� = 9.20 kN/m2 

At 3m:  𝑓𝑓3𝑚𝑚 = ��0.39+0.37
2

� �𝑡𝑡𝑡𝑡𝑡𝑡 �37.5+39
2

− 5�� (46.8)� = 11.66 kN/m2 

At 5m:  𝑓𝑓5𝑚𝑚 = ��0.37+0.50
2

� �𝑡𝑡𝑡𝑡𝑡𝑡 �39+30
2

− 5�� (62.7)� = 15.43 kN/m2 
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We can now solve Eq. (5.4) at the various sample depths: 
At depth of 2m: 

 𝑄𝑄𝑓𝑓,2𝑚𝑚 = ��𝑓𝑓2𝑚𝑚+𝑓𝑓0𝑚𝑚
2

� ∗ 𝜋𝜋𝜋𝜋ℎ� +  𝑄𝑄𝑓𝑓,0𝑚𝑚  

𝑄𝑄𝑓𝑓,2𝑚𝑚 = ��9.20+0
2

� (𝜋𝜋 ∗ 1 ∗ 2)� + 0 = 28.89 kN 

At depth of 3m: 

𝑄𝑄𝑓𝑓,3𝑚𝑚 = ��𝑓𝑓3𝑚𝑚+𝑓𝑓2𝑚𝑚
2

� ∗ 𝜋𝜋𝜋𝜋ℎ� + 𝑄𝑄𝑓𝑓,2𝑚𝑚  

𝑄𝑄𝑓𝑓,3𝑚𝑚 = ��11.66+9.20
2

� (𝜋𝜋 ∗ 1 ∗ 1)� + 28.89 = 61.65 kN 

At depth of 5m: 

𝑄𝑄𝑓𝑓,5𝑚𝑚 = ��𝑓𝑓5𝑚𝑚+𝑓𝑓2𝑚𝑚
2

� ∗ 𝜋𝜋𝜋𝜋ℎ� + 𝑄𝑄𝑓𝑓,3𝑚𝑚  

𝑄𝑄𝑓𝑓,5𝑚𝑚 = ��15.43+11.66
2

� (𝜋𝜋 ∗ 1 ∗ 2)� + 61.65 = 146.76 kN 

Following similar computations methods used in the sample depths above we can now compute 
values for the remaining depths, with the results included in  Table 5.2. 

 

Table 5.2   Hand Computations of Side Resistances for Example Problem 2 

• In table above the calculated f values were compared with the limiting values in the Technical 
Manual.  For each depth, the lower of the two values was used. 

• For this example, the program has produced output at 0.5-meter increments.  Changing the depth 
increment of the hand calculations to the 0.5-meter increment of depth will produce a more 
accurate final result (with exact match to the results from the computer program). 

5.3.1.2 Base Resistance 

The general equation for end bearing in Sands is: 

 p pQ qA=  

Depth φ  - 5 γ(h) Σ γ(h) f Qf

(m) (deg) (kN/m2) (kN/m2) (kPa) (kN)

2 30.25 0.58318 37.1 37.10 9.20 6.28 28.89 28.89

3 33.25 0.65563 9.7 46.80 11.66 3.14 32.76 61.65

5 29.5 0.56577 15.9 62.70 15.43 6.28 85.11 146.76

25 25 0.46631 114 176.70 41.20 62.83 1779.07 1925.82

30.5 30.25 0.58318 46.475 223.18 55.31 17.28 833.81 2759.63

33 35.5 0.71329 28 251.18 62.71 7.85 463.47 3223.10

π (d)(h)fπ (d)(h)tan (φ -5)
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(5.5) 

and 

 
o qq p N=  

(5.6) 

Where 
Qp  =  axial load capacity in end bearing; 

q  =  unit end bearing resistance; 
Ap  =  cross-sectional area of tip of pile. 

po =   effective overburden pressure at the pile tip; and 

Nq  =  bearing capacity factor. 

To check soil plugging, calculate the average end bearing value from depth H to (H+2D) as follows: 

 

1.5

1.5

( )

3

H D

H D
p x dx

D

Q
+

−
∫

 

(5.7) 

 ( . )p pQ Max Unit End Bearing A=  

(5.8) 

For an open-ended pipe pile for end bearing we must consider both a plugged and unplugged case.  
The plugged and unplugged values are computed in the following sub sections. 

5.3.1.3 Plugged Case 

For a plugged case the area is computed as follows: 

𝑨𝑨𝒑𝒑 = 𝒇𝒇𝒇𝒇𝒇𝒇𝒇𝒇 𝒃𝒃𝒃𝒃𝒃𝒃𝒃𝒃𝒃𝒃𝒃𝒃 𝒂𝒂𝒂𝒂𝒂𝒂𝒂𝒂 𝒐𝒐𝒐𝒐 𝒕𝒕𝒕𝒕𝒕𝒕 =
𝝅𝝅 ∗ 𝑫𝑫𝟐𝟐

𝟒𝟒
= 𝟎𝟎.𝟕𝟕𝟕𝟕𝟕𝟕𝟑𝟑𝟑𝟑𝟑𝟑 𝒎𝒎𝟐𝟐 

Combining Eq. (5.5) and (5.6): 

𝑸𝑸𝒑𝒑 = 𝒒𝒒𝑨𝑨𝒑𝒑 = ��𝜸𝜸𝜸𝜸�𝑵𝑵𝒒𝒒𝑨𝑨𝒑𝒑 

(5.9) 

where γ is an averaged value and the calculated q values are compared with the limiting values 
in the Technical Manual.  For each depth, the lower of the two values is used. 
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Using the values from Table 5.1 and Eq. (5.9) we calculate the following: 
At depth 0m: 
 𝑄𝑄𝑝𝑝,0𝑚𝑚,𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝 = 0  (𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠 𝑞𝑞 = 0) 

At depth 2m: 

𝑄𝑄𝑝𝑝,2𝑚𝑚,𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝 = ��18.1+19
2

� ∗ 2� ∗ 40 ∗ 0.785398 = 1165.5 𝑘𝑘𝑘𝑘  

At depth 3m: 

𝑄𝑄𝑝𝑝,3𝑚𝑚,𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝 = �37.1 + �19+10.2
2

� ∗ 1� ∗ 40 ∗ 0.785398 = 1624.2 𝑘𝑘𝑘𝑘  

At depth 5m: 

𝑄𝑄𝑝𝑝,5𝑚𝑚,𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝 = �37.1 + 14.6 + �10.2+5.7
2

� ∗ 2� ∗ 20 ∗ 0.785398 = 1061.8 𝑘𝑘𝑘𝑘  

Following similar computations methods used in the sample depths above we can now compute 
values for the remaining depths, with the results included in Table 5.3. 

 

Table 5.3   Hand Computations of Plugged End Bearing for Example Problem 2 

• In table above the calculated q values were compared with the limiting values in the Technical 
Manual.  For each depth, the lower of the two values was used (this is the case at the 33-m depth). 

• For this example, the program has produced output at a 0.5-meter increments.  Changing the 
depth increment of the hand calculations to the 0.5-meter increment of depth will produce a more 
accurate final result (with exact match to the results from the computer program). 

• The APILE program uses averaged values of Q over a length of 1.5 pile diameter above and 
below the pile depth.  This is done following Eq. (5.7). 

5.3.1.4 Unplugged Case 

For the unplugged case the area is computed as follows: 

𝐴𝐴𝑝𝑝 = 𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠 𝑐𝑐𝑐𝑐𝑐𝑐𝑐𝑐𝑐𝑐 𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠 𝑎𝑎𝑎𝑎𝑎𝑎𝑎𝑎 =
𝜋𝜋 ∗ (𝐷𝐷𝐷𝐷𝐷𝐷𝐷𝐷2 − 𝐷𝐷𝐷𝐷𝐷𝐷2)

4
= 0.204518𝑚𝑚2 

Adding effect of side friction from the inner wall of the pile, the previous Eq.  (5.10) is now calculated 
as follows: 

Depth γ(h) Σ γ(h) Qp (plugged
(m) (kN/m2) (kN/m2) (kN)

0 0 0 0

2 37.1 37.1 1165.53

3 14.6 51.7 1624.2

5 15.9 67.6 1061.86

25 114 181.6 2852.57

30.5 46.475 228.075 7165.19
33 28 256.075 7539.82
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𝑸𝑸𝒑𝒑 = 𝒒𝒒𝑨𝑨𝒑𝒑 = ��𝜸𝜸𝜸𝜸�𝑵𝑵𝒒𝒒𝑨𝑨𝒑𝒑 + 𝑸𝑸𝒇𝒇,𝒊𝒊𝒊𝒊𝒊𝒊𝒊𝒊𝒊𝒊 𝒘𝒘𝒘𝒘𝒘𝒘𝒍𝒍 

 (5.10) 

where γ is an averaged value and the calculated q values are compared with the limiting values 
in the Technical Manual.  For each depth, the lower of the two values is used. 

Using the values from Table 5.1 and Eq. (5.10) we calculate the following: 
At depth 0m: 
 𝑄𝑄𝑝𝑝,0𝑚𝑚,𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢 = 0  (𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠 𝑞𝑞 = 0) 

At depth 2m: 

𝑄𝑄𝑓𝑓,𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖 𝑤𝑤𝑤𝑤𝑤𝑤𝑤𝑤 = 𝜋𝜋𝜋𝜋ℎ𝑓𝑓 = 3.14 ∗ 0.86 ∗ 2 ∗ 0+9.20
2

= 24.8 𝑘𝑘𝑘𝑘  

𝑄𝑄𝑝𝑝,2𝑚𝑚,𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢 = (37.1 ∗ 40 ∗ 0.204518) + 24.84 = 328.3 𝑘𝑘𝑘𝑘  

At depth 3m: 

𝑄𝑄𝑓𝑓,𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖 𝑤𝑤𝑤𝑤𝑤𝑤𝑤𝑤,3𝑚𝑚 = (𝜋𝜋𝜋𝜋ℎ𝑓𝑓) + 𝑄𝑄𝑓𝑓,𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖 𝑤𝑤𝑤𝑤𝑤𝑤𝑤𝑤,2𝑚𝑚 = �3.14 ∗ 0.86 ∗ 1 ∗ 9.20+12.88
2

� + 24.84 =
54.6 𝑘𝑘𝑘𝑘  

𝑄𝑄𝑝𝑝,2𝑚𝑚,𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢 = (51.7 ∗ 40 ∗ 0.204518) + 54.66 = 477.6 𝑘𝑘𝑘𝑘  

At depth 5m: 
𝑄𝑄𝑓𝑓,𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖 𝑤𝑤𝑤𝑤𝑤𝑤𝑤𝑤,5𝑚𝑚 = (𝜋𝜋𝜋𝜋ℎ𝑓𝑓) + 𝑄𝑄𝑓𝑓,𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖𝑖 𝑤𝑤𝑤𝑤𝑤𝑤𝑤𝑤,3𝑚𝑚

= �3.14 ∗ 0.86 ∗ 1 ∗
12.88 + 16.64

2
�+ 54.6 = 134.4 𝑘𝑘𝑘𝑘 

𝑄𝑄𝑝𝑝,2𝑚𝑚,𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢𝑢 = (67.6 ∗ 20 ∗ 0.204518) + 134.4 = 410.9 𝑘𝑘𝑘𝑘  

Following similar computations methods used in the sample depths above we can now compute 
values for the remaining depths, with the results included in Table 5.5. 

 

Table 5.4   Hand Computations of Unplugged End Bearing for Example Problem 2 

• In table above the calculated q values were compared with the limiting values in the Technical 
Manual.  For each depth, the lower of the two values was used. 

Depth γ(h) Σ γ(h) Qp (unplugged)
(m) (kN/m2) (kN/m2) (kN)

0 0 0 0

2 37.1 37.1 328.35

3 14.6 51.7 477.61

5 15.9 67.6 410.92

25 114 181.6 2470.67

30.5 46.475 228.075 4328.26
33 28 256.075 4964.14
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• For this example, the program has produced output at 0.5-meter increments.  Changing the depth 
increment of the hand calculations to the 0.5-meter increment of depth will produce a more 
accurate final result (thus with exact match to the results from the computer program). 

• The APILE program uses averaged values of Q over a length of 1.5 pile diameter above and 
below the pile depth.  This is done following Eq. (5.7). 

5.3.1.5 Total Resistance 

The total bearing capacity of the pile is given in Eq. (5.11).  To determine the total bearing capacity 
of the pile, the smallest value from the skin friction equations in Eq. (5.2) and Eq. (5.3) and the end bearing 
equations in Eq. (5.7) and Eq. (5.8) must be used in Eq. (5.11). 

 pTotal fQ Q Q+=  

 (5.11) 

5.3.2 Comparison of APILE Results with Hand Computations 

Table 5.5 contains a comparison of the results obtained from hand computations against those from 
the computer run in APILE (for API Method). 

Since Qp,unplugged < Qp,plugged at all depths then the values in Table 5.4 control the end bearing 
capacity.  Using the computed values from Table 5.2 and Table 5.4 we can find the total resistance displayed 
in Table 5.5 along with comparisons against the computer run in APILE (API Method). 

 

Table 5.5   Comparison of Total Resistances for Example Problem 2 

• Some discrepancies are noticed between the rough hand calculations and the computed results 
from APILE.  If the user refines the computational depths to match the more accurate 0.5-meter 
increments used by APILE, the hand computed values should then be much closer to the APILE 
software calculations. 

Depth Qf Qp QT(Hand) QT(APILE)
(m) (kN) (kN) (kN) (kN)

2 28.89 328.35 357.24 349.30

3 61.65 477.61 539.26 497.10

5 146.76 410.92 557.68 561.70

25 1925.82 2470.67 4396.49 4257.70

30.5 2759.63 4328.26 7087.89 6877.90

33 3223.10 4964.14 8187.24 8003.90
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5.3.3 Input and Output Data Files for Example 2 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 2 is the following: 

Example 2 - Large Steel Pipe Pile in Sand.ap10d 

The output-data filename for Example 2 is the following: 

Example 2 - Large Steel Pipe Pile in Sand.ap10o 

5.3.4 Graphical Results of Computer Analysis 

Resulting plots of accumulated skin friction, ultimate tip resistance, and ultimate total capacity versus 
depth provided by the computer program may be observed in Figure 5.7, Figure 5.8 and Figure 5.9 
respectively.  Results of axial load versus short-term settlement are included in Figure 5.10. 

  
Figure 5.7   Curves of Accumulated Skin Friction vs Depth for Example Problem 2. 
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Figure 5.8   Curves of Ultimate Tip Resistance vs Depth for Example Problem 2. 

 

Figure 5.9   Curves of Ultimate Total Capacity vs Depth for Example Problem 2. 
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Figure 5.10   Curve of Axial Load vs Settlement for Example Problem 2. 
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5.4 Example Problem 3 – Steel Pipe Pile in Clay 

5.4.1 Description 

This example is included to show the response of a steel pile embedded in cohesive soils.  The 
modeled pile is 39 meters long and open-ended steel pipe, with an outer diameter of 500 mm and an inner 
diameter of 480 mm.  The soil data is given in Table 5.6.  The bearing capacity was calculated by APILE, 
using the API RP2A method.  Because this pile is open ended, a plug of soil may be forced up the inside of 
the pile.  In this APILE model, the soil resistance from the plug is compared to the resistance from the end-
bearing over the full area of the base and the smaller of the two values is used (Data > Circular Pile 
Section > Internal Pile Plug Calculated by Program). 

 

Table 5.6   Soil Data for Example Problem 3 

5.4.2 Input and Output Data Files for Example 3 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 3 is the following: 

Example 3 - Steel Pipe Pile in Clay.ap10d 

The output-data filename for Example 3 is the following: 

Example 3 - Steel Pipe Pile in Clay.ap10o 

5.4.3 Graphical Results of Computer Analysis 

The resulting plot of combined ultimate axial capacities versus depth provided by APILE may be 
observed in Figure 5.11.  Results of axial load versus short-term settlement are included in Figure 5.12. 

Depth Soil Type γ' C
(m) (kN/m3) (kN/m2)

0 clay 18.6 9.8
4 clay 18.6 9.8
4 clay 8.8 9.8
10 clay 8.8 9.8
10 clay 8.8 19.6
20 clay 8.8 19.6
20 clay 8.8 58.8
36 clay 8.8 58.8
36 clay 9 78.4
40 clay 9 78.4

Layer

5

4

3

2

1
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Figure 5.11   Curve of Combined Plots vs Depth (ultimate) for Example Problem 3. 

 

Figure 5.12   Curve of Axial Load vs Settlement for Example Problem 3. 
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5.5 Example Problem 4 – Prestressed Concrete Pile for Bridge 
Foundation  

This example is included to illustrate a modeling case that may be applicable for a simple bridge 
foundation.  The soil deposit consists of two sublayers as shown in Figure 5.13.  The top layer is a 3-meter 
stiff clay underlain by a medium dense to dense sand layer.  One meter of the top clay layer is not considered 
for axial friction (side resistance) transfers.  The proposed pile for these foundations is composed of 
prestressed concrete piles with 450 mm (18-in.) in outside diameter.  The elastic modulus of the prestressed 
pile is 25,000,000 kN/m2 (3,626,000 psi).  Each pile is required to provide about 2000 kN for a service 
load. 

The APILE output for this example is shown in detail so the user can examine the increase in pile 
capacity with depth.  The user may elect to eliminate the printing of capacity for each increment length to 
shorten the length of output. 

 
Figure 5.13   Pile layout and soil conditions of Example Problem 4. 
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5.5.1 Hand Computations and Comparisons with APILE 

The program output will be compared to the results from the following hand calculations. 

5.5.1.1 API Method – Skin Friction 

A. For the top Clay layer (ignoring friction on top 1 meter) 

 fAs (clay) = ( α ) ( c )*π *D* h 

(5.12) 

where 
Avg. effective overburden pressure (p) is 18.9 * 1.5 = 28.35 kN/m2 
α = (0.5)(c/p) - 0.25 = (0.5)(95/28.35)-0.25 = 0.37 

fAs (clay) = (0.37) (95)*π *(0.45)* (3-1) = 99 kN 

B. For the bottom Sand layer 

 fAs (sand) = ko*(Σγh)*tan (φ- 5)*π *D* h 

(5.13) 

where 
Avg. effective overburden pressure (p) from 0 to 3 m  
18.9 * 1.5 = 28.3  kN/m2 
Avg. effective overburden pressure (p) from 3 to 5 m  
18.9 * 3 + (9.1) (1) = 65.8 kN/m2 
Avg. effective overburden pressure (p) from 5 to 10 m  
18.9 * 3 + (9.1) (2) + (9.1) (2.5) = 97.6 kN/m2 
Avg. effective overburden pressure (p) from 10 to 15 m  
18.9 * 3 + (9.1) (7) + (9.1) (2.5) = 143.1 kN/m2 
Avg. effective overburden pressure (p) from 15 to 20 m  
18.9 * 3 + (9.1) (12) + (9.1) (2.5) = 188.6 kN/m2 
Avg. effective overburden pressure (p) from 20 to 25 m  
18.9 * 3 + (9.1) (17) + (9.1) (2.5) = 234.2 kN/m2 
Computation of skin friction from each sub-layer based on API Method: 

(1) 
Depth 

interval 

(2) 
Total area 
(π *D* h) 

(3) 
Avg. 

effective 
stress 

(4) 
ko*tan (φ-5) 
ko= 1, φ = 36 

(5) 
fs = (3)*(4)  
< limiting 

value (99.3) 

(6) 
fs A = (2)*(5) 

3 – 5 m 2.83 m2 65.8 kN/m2 0.6 39.5 111.8 kN 
5 – 10 m 7.07 m2 97.6 kN/m2 0.6 58.6 414.3 kN 

10 – 15 m 7.07 m2 143.1 kN/m2 0.6 85.9 607.3 kN 
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15 – 20 m 7.07 m2 188.6 kN/m2 0.6 99.3 702.1 kN 
20 – 25 m 7.07 m2 234.2 kN/m2 0.6 99.3 702.1. kN 

ΣfAs = 2537.6 kN 

5.5.1.2 API Method – End Bearing 

The general equation for end bearing is: 

 Qp = (Nq) (σv) (Ap) 

(5.14) 

where  
Ap (tip area) = (0.45) (0.45) (π./4) = 0.159 m2,  

σv (effective stress at tip) = 18.9 *3 + (9.1) (22) = 258 kN/m2, and 

Nq = 40.   
Therefore: 
Qp = (40) (258) (0.159) = 1641 

Limiting Tip Resistance = 9,600 kPa (see Technical Manual) 
Qp = (9600) (0.159) = 1526.4 

5.5.1.3 API Method – Comparisons of APILE Results with Hand Computations 

The total transfer in side resistance is provided by adding the results from Eq. (5.12) plus Eq. (5.13): 

Qf  = 99 + 2537.6 = 2636.6 kN which compares to 2659.6 kN computed by APILE 

(APILE is more accurate since it divides the soil layers using smaller increments) 

The transfer in end bearing is provided by the result from Eq. (5.14): 

Qp  = 1526.4 kN which compares to 1526.8 kN computed by APILE 

5.5.1.4 FHWA Method – Skin Friction 

A. For the top Clay layer (ignoring friction on top 1 meter) 

 fAs (clay) = ( α ) ( cu )*π *D* h 

(5.15) 

  = ( 0.72 ) ( 95 )*π *(0.45)* (3-1)  
 = 193 kN 

B. For the bottom Sand layer 

 fAs (sand) = ko*Cf*(Σγh)*sin (δ)*π *D* h 
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(5.16) 

The average displaced volume per foot is π (0.45)2 /4 = 0.159 m3.per meter 
For a precast concrete pile with V=1.71 ft3 per ft, δ = 0.9φ. 

Computation of skin friction from each sub-layer based on FHWA Method: 

(1) 
Depth 

interval 

(2) 
Total area 
(π *D* h) 

(3) 
Avg. 

effective 
stress 

(4) 
ko *Cf *sin (δ) 
ko=2.1,δ =0.9φ 

Cf =0.95. 

(5) 
fs = (3)*(4)  
< limiting 

value (95.5) 

(6) 
fs A = (2)*(5) 

3 – 5 m 2.83 m2 65.8 kN/m2 1.07 70.4 199.2 kN 
5 – 10 m 7.07 m2 97.6 kN/m2 1.07 104.4 738.3 kN 
10 – 15 m 7.07 m2 143.1 kN/m2 1.07 153.1 1082.5 kN 
15 – 20 m 7.07 m2 188.6 kN/m2 1.07 201.8 1426.7 kN 
20 – 25 m 7.07 m2 234.2 kN/m2 1.07 250.6 1771.7 kN 

ΣfAs = 5218.4 kN 

5.5.1.5 FHWA Method – End Bearing 

The general equation for end bearing is: 

 Qp = (α ) (Nq) (σv) (Ap) 

(5.17) 

where  

Ap (tip area) = (0.45) (0.45) (π./4) = 0.159 m2,  

σv (effective stress at tip) = 18.9 *3 + (9.1) (22) = 258 kN/m2, 

Nq = 60,  
α  = 0.7, and 

The limiting value from Meyerhof (1976) is 7258 kN/m2. 
Qp = (0.7) (60) (258) = 9702 > 7258 kN/m2    

Therefore the limiting value should be used for the bearing capacity.  
Qp = (7258) (0.159) = 1154 

5.5.1.6 FHWA Method – Comparisons of APILE Results with Hand Computations 

The total transfer in side resistance is provided by adding the results from Eq. (5.15) plus Eq. (5.16): 

Qf  = 193 + 5218.4 = 5411.4 kN which compares to 5279.9 kN computed by APILE 

(APILE is more accurate since it divides the soil layers using smaller increments) 

The transfer in end bearing is provided by the result from Eq. (5.17): 

Qp  = 1154 kN which compares to 1154.4 kN computed by APILE 
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5.5.1.7 USACE Method – Skin Friction 

A. For the top Clay layer (ignoring friction on top 1 meter) 

 fAs (clay) = ( α ) ( cu )*π *D* h 

(5.18) 

 = ( 0.5 ) ( 95 )*π *(0.45)* (3-1)  
 = 134 kN 

B. For the bottom Sand layer 

 fAs (sand) = ko*(Σγh)*tan (δ)*π *D* h 

 (5.19) 

The skin friction in sand increases linearly to an assumed critical depth (Dc). 
Dc = 20B for dense sand = 20 (0.45 m) = 9 m. 
Effective overburden pressure (p) at 9 m  
18.9 * 3 + (9.1) (6) = 111.3 kN/m2 
Computation of skin friction from each sub-layer based on USACE Method: 

(1) 
Depth 

interval 

(2) 
Total area 
(π *D* h) 

(3) 
Avg. effective stress 

(4) 
ko*tan (δ) 

ko= 1.25, δ = 
0.95φ 

(5) 
fAs = 

(2)*(3)*(4) 

3 – 5 m 2.83 m2 65.8 kN/m2 0.85 158.3 kN 
5 – 9 m 6.65 m2 84.0 kN/m2 0.85 403.4 kN 

9 – 25 m 22.62 m2 111.3 kN/ m2 
(critical depth controls) 0.85 2139.9kN 

ΣfAs = 2701.6 kN 

5.5.1.8 USACE Method – End Bearing 

The general equation for end bearing is: 

 Qp = (Nq) (σv) (Ap) 

(5.20) 

where  
Ap (tip area) = (0.45) (0.45) (π/4) = 0.159 m2,   

σv (effective stress at Dc) = 18.9 *3 + (9.1) (6) = 111.3 kN/m2 (assuming Dc=9m but should be 
computed based on Table in Technical Manual), and 

Nq = 55 (approximate, from Figure in Technical Manual), so 
Qp = (55) (111.3) (0.159) = 973 kN. 
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5.5.1.9 USACE Method – Comparisons of APILE Results with Hand Computations 

The total transfer in side resistance is provided by adding the results from Eq. (5.18) plus Eq. (5.19): 

Qf  = 134 + 2701.6 = 2835.6 kN which compares to 2894.8 kN computed by APILE 

(APILE is more accurate since it divides the soil layers using smaller increments) 

The transfer in end bearing is provided by the result from Eq. (5.20): 

Qp  = 973 kN as compared to 991.3 kN computed by APILE 

(APILE uses a better approximation than the hand computations for the critical depth Dc and for 
the bearing capacity factor Nq for the USACE method) 

5.5.2 Input and Output Data Files for Example 4 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 4 is the following: 

Example 4 - Prestressed Concrete Pile.ap10d 

The output-data filename for Example 4 is the following: 

Example 4 - Prestressed Concrete Pile.ap10o 

5.5.3 Graphical Results of Computer Analysis 

The resulting plots of ultimate accumulated skin friction and ultimate tip resistance versus depth 
provided by the APILE computer program may be observed in Figure 5.14 and Figure 5.15, respectively. 

Note that the load-transfer curve of skin friction versus depth in Figure 5.14 starts from about the 1-
m depth (actually from the previous finite increment in some methods).  This is because the program was 
instructed to ignore skin friction at the top 1 meter. 
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Figure 5.14   Curve of Ultimate Skin Friction vs Depth for Example Problem 4. 

 

Figure 5.15   Curve of Ultimate Tip Resistance vs Depth for Example Problem 4. 
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5.6 Example Problem 5 – Tapered Pile Capacity 
Driven piles with a depth-variable circumference or perimeter over all of their length are called 

tapered piles.  They are usually installed using some type of impact hammer and have long been recognized 
as the most cost effective driven pile alternative to use in applications calling for “friction piles”, especially 
in coarse-grain soil condition (Peck 1958). 

This example is included to illustrate an application in which a Raymond Uniform Tapered Pile 
(made of steel) was considered for the deep foundation.  The tapered pile has a diameter of 12 inches at the 
pile tip and the taper angle is 0.5 degrees extending from the pile tip to the pile head.  The length of the 
proposed pile is 30 feet, which results in a diameter of 18.28 inches at the pile head. 

The soil deposit consists of two sublayers as shown in Figure 5.16.  The top layer is 18-ft loose sand 
with the internal friction angle of 30 deg., underlain by a very dense sand layer with the internal friction 
angle of 40 deg.  The theory for extra load transfer from the angle of pile taper in sand layers is only 
applicable by the FHWA method, which adopts the recommendations by Nordlund (1963, 1970). 

 

Figure 5.16   Pile layout and soil conditions of Example Problem 5. 

5.6.1 Hand Computations and Comparisons with APILE 

The program output will be compared to the results from the following hand calculations. 
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Step 1. Compute effective stresses in the middle of soil layers: 

Layer 1: 𝜎𝜎�𝑣𝑣0 =  𝑃𝑃𝐷𝐷 = 383.4 𝑝𝑝𝑝𝑝𝑝𝑝 

Layer 2: 𝜎𝜎�𝑣𝑣0 =  𝑃𝑃𝐷𝐷 = 1130.4 𝑝𝑝𝑝𝑝𝑝𝑝 

Step 2. Compute 𝛿𝛿 𝜙𝜙�  for each one of the layers (pile segments): 

Layer 1. Compute volume: 

The depth of pile at middle of first layer is equal to 9 ft + 18 ft/2 = 21 ft 

The increase of radius at 21 ft above the pile tip: 

𝑡𝑡𝑡𝑡𝑡𝑡 =  𝑥𝑥
ℎ 

=>  𝑥𝑥 = ℎ ∙ tan𝜔𝜔  

𝑥𝑥 = 21 𝑓𝑓𝑓𝑓 tan(0.5) => 0.1832642 𝑓𝑓𝑓𝑓 

Diameter of pile at middle of first layer in inches 
𝐷𝐷1 = 12 + 2 * 12 * x = 12 + 2 * 12 * 0.1832642 = 16.398341 

𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉 =  𝜋𝜋𝐷𝐷
�12

4
=  𝜋𝜋∗16.3983412

4∗144
= 1.4666524 𝑓𝑓𝑓𝑓3

𝑓𝑓𝑓𝑓
  

Compute 𝛿𝛿 𝜙𝜙�  for layer 1 (interpolate linearly): 

V = 1.4 𝛿𝛿
𝜙𝜙� = 1.159 

V = 1.5 𝛿𝛿
𝜙𝜙� = 1.184 

�𝛿𝛿 𝜙𝜙� − 1.159� =  
1.184− 1.159

1.5 − 1.4
(1.4666524− 1.4) 

(𝛿𝛿 𝜙𝜙� )𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 #1 = 1.1756631 

Layer 2. Compute volume: 

The increase of radius at 6 ft above the pile tip 

𝑥𝑥 = ℎ ∙ tan(𝑤𝑤) = 6 ∗ tan(0.5) => 0.0523612 𝑓𝑓𝑓𝑓 

Diameter of pile at middle of second layer: 

𝐷𝐷2 = 12" + 2 ∗ 12 ∗ 0.0523612 = 13.256669" 

𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉 =  
𝜋𝜋𝐷𝐷�22

4
=
𝜋𝜋13.2566692

4 ∗ 144
= 0.958509𝑓𝑓𝑓𝑓3 𝑓𝑓𝑓𝑓⁄  

Compute 𝛿𝛿 𝜙𝜙�  for layer 2 (interpolate linearly): 

V = 0.9 𝛿𝛿
𝜙𝜙� = 1.025 

V = 1.0 𝛿𝛿
𝜙𝜙� = 1.053 

�𝛿𝛿 𝜙𝜙� − 1.025� =  
1.053− 1.025

1.0 − 0.9
(0.958509− 0.9) 
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(𝛿𝛿 𝜙𝜙� )𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 #2 = 1.0413825 

Step 3. Compute values of Kδ for both layers: 

Layer 1:   𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉 = 1.4666524𝑓𝑓𝑓𝑓3 𝑓𝑓𝑓𝑓⁄  

𝜙𝜙 = 30° 

Interpolate linearly for 𝑤𝑤 = 0.5°: 

V = 1 Kδ = 2.928 

V = 10 Kδ = 3.180 

(𝐾𝐾𝛿𝛿 − 2.928) =  
3.18− 2.928

log(10) − log (1)
[log(1.4666524)− log(1)] 

𝐾𝐾𝛿𝛿𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 1 = 2.9699145 

Layer 2:  𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉 = 0.958509𝑓𝑓𝑓𝑓3 𝑓𝑓𝑓𝑓⁄  

𝜙𝜙 = 40° 

For w = 0.5° and any volume between 0.1 and 10 ft3/ft the value of Kδ = 17.28. 

𝐾𝐾𝛿𝛿𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 2 = 17.28 

Step 4. Compute the correction factor (use same digitized curves as computer program): 

Layer 1:  𝛿𝛿
𝜙𝜙� = 1.1756631;  𝜙𝜙 = 30° 

𝛿𝛿
𝜙𝜙� = 1 CF = 1.0 

𝛿𝛿
𝜙𝜙� = 1.2 CF = 1.03 

(𝐶𝐶𝐶𝐶 − 1) =
1.03 − 1
1.2 − 1

(1.1756631− 1) 

𝐶𝐶𝐶𝐶𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 1 = 1.0263495 

Layer 2:  𝛿𝛿
𝜙𝜙� = 1.0413825;  𝜙𝜙 = 40° 

For 𝜙𝜙 = 38° 

𝛿𝛿
𝜙𝜙� = 1 CF = 1.0 

𝛿𝛿
𝜙𝜙� = 1.2 CF = 1.07 

(𝐶𝐶𝐶𝐶 − 1) =
1.07 − 1
1.2 − 1

(1.0413825− 1) 

𝐶𝐶𝐶𝐶𝜙𝜙=38 = 1.0144839 

For 𝜙𝜙 = 42° 
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𝛿𝛿
𝜙𝜙� = 1 CF = 1.0 

𝛿𝛿
𝜙𝜙� = 1.2 CF = 1.09 

(𝐶𝐶𝐶𝐶 − 1) =
1.09 − 1
1.2 − 1

(1.0413825− 1) 

𝐶𝐶𝐶𝐶𝜙𝜙=38 = 1.0186221 

Interpolate linearly for Φ = 40° 

𝐶𝐶𝐶𝐶Φ=40° 𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 2 = 1.016553 

Step 5. Compute values of δ: 

Layer 1:  𝛿𝛿𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 1 = 1.1756631 ∗ 30° = 35.269893° 

Layer 2:  𝛿𝛿𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 = 1.0413825 ∗ 40° = 41.6553° 

Step 6. Compute friction contribution for each layer: 

𝑄𝑄𝑠𝑠 = 𝐾𝐾𝛿𝛿 ∗ 𝐶𝐶𝐶𝐶 ∗ 𝑃𝑃𝐷𝐷 ∗ �
sin(𝛿𝛿 + 𝑤𝑤)

cos𝑤𝑤
� ∗ 𝐶𝐶𝑑𝑑 ∗ Δ𝑑𝑑 

Layer 1 

𝑄𝑄𝑆𝑆1 = 2.9699145 ∗ 1.0263495 ∗ 383.4 ∗
sin(35.269893 + 0.5)

cos(0.5) ∗ 3.1415927 ∗ 16.398341 ∗ 18 

𝑄𝑄𝑆𝑆1 = 52790.621 [𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝] 

Layer 2 

𝑄𝑄𝑆𝑆2 = 17.28 ∗ 1.016553 ∗ 1130.4 ∗
sin(41.6553 + 0.5)

cos(0.5) ∗ 3.1415927 ∗
13.25669

12
∗ 12 

𝑄𝑄𝑆𝑆2 = 555037.24 [𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝𝑝] 

Compute total frictional resistance: 

𝑄𝑄𝑠𝑠 = 𝑄𝑄𝑆𝑆1 + 𝑄𝑄𝑆𝑆2 = 52.79[𝑘𝑘𝑘𝑘𝑘𝑘𝑘𝑘] + 555.04[𝑘𝑘𝑘𝑘𝑘𝑘𝑘𝑘] = 607.83[𝑘𝑘𝑘𝑘𝑘𝑘𝑘𝑘] 

which compares to 575.5 kips computed by APILE 

Step 7. Compute tip resistance contribution from FHWA method: 

 '
t qp p NQ A qα=  (5.21) 

where 
Ap is the pile tip bearing area, 
q is the vertical stress at pile base level, 

qN ′   =  bearing capacity factor (see figure in Technical Manual), and 
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αt =  dimensionless factor dependent on the depth-width relationship of the pile (see figure in 
Technical Manual). 

𝐴𝐴𝑝𝑝  = π 𝐷𝐷𝑝𝑝2 /4 = 3.14 (12)2 /4 = 113.1 in2  = 0.785 ft2  

q = 42.6 lb/ft3 x 18 ft + 60.6 lb/ft3 x 12 ft = 1494 lb/ft2 

qN ′   =  160 

αt =  0.75 

Qp = 140.7 kips which compares well to 140.8 kips computed by APILE 

Step 8. Compute limiting tip resistance: 

QL = 327.98 kips which is higher so not controlling 

Step 9.  Total static pile capacity is then 

𝑄𝑄𝑇𝑇 = 607.83[𝑘𝑘𝑘𝑘𝑘𝑘𝑘𝑘] + 140.81[𝑘𝑘𝑘𝑘𝑘𝑘𝑘𝑘] => 748.64 𝑘𝑘𝑘𝑘𝑘𝑘𝑘𝑘 , which compares well to the 716.3 kips 
obtained from the APILE model. 

(APILE is more accurate since it divides the pile sections into smaller increments) 

5.6.2 Input and Output Data Files for Example 5 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 5 is the following: 

Example 5 - FHWA Tapered Pile.ap10d 

The output-data filename for Example 5 is the following: 

Example 5 - FHWA Tapered Pile.ap10o 

5.6.3 Graphical Results of Computer Analysis 

The resulting plots of ultimate total capacity versus depth provided by the computer program may 
be observed in Figure 5.17.  Figure 5.18 includes a plot of axial load versus settlement. 
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Figure 5.17   Curve of Combined Plots (Ultimate Total Capacity) vs Depth for Example 

Problem 5. 

 
Figure 5.18   Axial Load vs Settlement for Example Problem 5. 
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5.7 Example Problem 6 – Uplift Pile Capacity 

5.7.1 Description 

Piles may be subjected to loads in tension instead of compression.  The tension capacity of piles 
differs from the compression capacity of piles in both the side friction and end bearing.  For piles under 
tension the soil resistance is from the side friction only. 

Some research recommends applying a reduction factor to the side friction when the pile moves 
upward based on field experimental studies.  This may be caused by less confining pressure from the soil 
around the pile under tension.  This example includes an arbitrary reduction factor of 0.8 for tension 
capacity (under Data > Computational Method > Method for Pile Capacity > Type of Loading > 
Tension). 

A different reduction in side friction may be specified primarily to cover a distance near the shallow 
depth.  This example includes an arbitrary 4-meter exclusion of friction in the top soil layer (under Data > 
Circular Pile Section > Zero-Friction Length from Ground). 

The tension capacity of piles should also include the self-weight of piles.  This is automatically 
accounted within APILE according to the pile type/material selected by the user.  The values computed by 
APILE are included in a column in the output text file. 

This example illustrates a common case for study of the tension capacity of a pipe pile.  The soil 
deposit consists of six sub-layers as shown in Table 5.7.  The pile is a 60-m long, open-ended steel pipe, 
with an outer diameter of 1000 mm and an inner diameter of 936 mm. 

The output is shown in detail so the user can examine the increase in pile capacity with depth.  The 
user may elect to eliminate the printing of capacity for each increment length to shorten the length of output. 

 

Table 5.7   Soil data for Example Problem 6 

Depth Soil Type γ' Cu φ

(m) (kN/m3) (kN/m2) (Deg.)
0 0.1
10 20
10
20
20 200
30 200
30
40
40 350
50 350
50

100
0.6

Nq

---

20

---

30

---

30

---

---

---

Ko

---

0.6

---

0.6

---

---

---

---

34

36

386 Sand

4

9

6

9

9

9

Clay

Sand

Clay

Sand

Clay

Layer

5

4

3

2

1
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5.7.2 Input and Output Data Files for Example 6 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename is the following: 

Example 6 - Uplift Pile Capacity.ap10d 

The output-data filename is the following: 

Example 6 - Uplift Pile Capacity.ap10o 

5.7.3 Graphical Results of Computer Analysis 

The resulting plots of ultimate total capacity versus depth provided by the computer program may 
be observed in Figure 5.19.  The self-weight of the pile is included in the total capacity for the uplift (tensile) 
capacity.  Figure 5.20 includes a plot of uplift load versus uplift movement. 

 

  
Figure 5.19   Curve of Ultimate Total Capacity vs Depth for Example Problem 6. 
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Figure 5.20   Curve of Axial Load vs Movement for Example Problem 6. 
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5.8 Example Problem 7 (Offshore Version) – CPT Based Methods for 
Close-Ended Pile  

Many of the existing semi-empirical methods for predicting the axial capacity of driven piles were 
developed approximately two decades ago on the basis of an extended database of static-loading tests.  The 
soil properties and subsurface conditions were obtained primarily by conventional sampling methods and 
testing equipment, including the Standard Penetration Test (SPT), field-vane test, and triaxial-undrained 
(UU) tests using undisturbed soil samples, taken by the use of Shelby tubes. 

Recently, the cone penetration test (CPT) has been widely used in subsurface exploration worldwide, 
especially in the offshore industry.  The American Petroleum Institute (API) conducted a review of CPT-
based methods for assessment of the axial capacity of driven piles.  Two CPT-based methods have been 
studied and adopted by API as alternate design methods.  Those two CPT-based methods that were selected 
by API are: the NGI-99 method developed by the Norwegian Geotechnical Institute and the MTD method 
developed by Imperial College in London (Richard Jardine et al, 2005). 

The example included here are for the customers who purchased the offshore-version of APILE.  
This example is for an offshore application and will focus on the axial capacity of closed-ended piles 
predicted by different semi-empirical methods.  Computed results from four CPT-based methods are 
included for comparison.  The pile is a 60-m long pipe with a closed end and with an outer diameter of 
2134 mm and an inner diameter of 2044 mm.  The soil deposit consists of six sub-layers and the soil 
properties, including those from CPT tests, are shown in Table 5.8. 

 

Table 5.8   Soil data for Example Problem 7 

5.8.1 Comparison of APILE Results with Hand Computations 

Table 5.9 and Table 5.10 contains various comparisons of the results obtained from approximate 
hand computations (spreadsheet) against those from the computer run in APILE for two different offshore 
methods. 

Depth γ' Cu φ
(m) (kN/m3) (kN/m2) (Deg.)

0 0.1 1
10 20 200
10 10,500
20 20,000
20 200 2,000
30 200 2,000
30 30,500
40 39,500
40 350 5,000
50 350 5,000
50 50,000

100 50,000

0.6 30

--- ---Sand 9 --- 38 0.6 30

2 Sand

--- ---

5 Clay 9 --- --- --- 15 3

Sand 9 --- 36

Qc PI

--- ---

3 Clay 6 --- --- --- 20 3

0.6 2034---9

Layer

4

6

YSR

1 Clay 4 --- --- --- 50 2

Soil Type Ko Nq
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Table 5.9   Comparison of results for NGI Method in Example Problem 7 

 

Table 5.10   Comparison of results for MTD Method in Example Problem 7 

5.8.2 Input and Output Data Files for Example 7 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename is the following: 

Example 7 - CPT Methods on Close Ended Pile.ap10d 

Depth Soil Type
(m) Hand Calc Computer

0
10
10
20
20
30
30
40
40
50
50
60

NGI METHOD

14,780

5 Clay 12,014 11,844

4 Sand 14,859

3,571

3

6 Sand 30,033 28,619

Clay 6,280 6,251

2 Sand 3,504

Layer

1 Clay 516 537

Total Skin Friction (kN)

Depth Soil Type
(m) Hand Calc Computer

0
10
10
20
20
30
30
40
40
50
50
60

6 Sand 30,114 33,711

4 Sand 12,360 13,503

5 Clay 17,572 15,206

2 Sand 4,048 3,783

3 Clay 5,767 5,313

MTD METHOD

Layer Total Skin Friction (kN)

1 Clay 295 268
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The output-data filename is the following: 

Example 7 - CPT Methods on Close Ended Pile.ap10o 

5.8.3 Graphical Results of Computer Analysis 

The resulting plots of total capacity from different empirical methods and axial load versus settlement 
computed based on MTD method may be observed in Figure 5.21 and Figure 5.22. 

  
Figure 5.21   Curves of Ultimate Total Capacity vs Depth for Example Problem 7. 
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Figure 5.22   Curve of Axial Load vs Settlement for Example Problem 7. 
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5.9 Example Problem 8 (Offshore Version) – CPT Based Method for 
Open-Ended Pile  

Many large offshore piles are driven with an open-ended tip.  It is obvious that soil will be pushed 
into the pile through the pile tip during pile driving, forming a soil plug inside the pipe pile.  If the soil plug 
develops excessive side friction on the inner wall at a certain depth, the soil plug may not be pushed further 
into the pipe pile by driving.  This condition is typically referenced as a fully plugged pile.  On the other 
hand, the soil plug may be pushed up continuously during pile driving because the friction developed on 
the inner wall is not strong.  In this case the pile tip is not fully plugged and it is usually referenced as an 
unplugged pile. 

The determination if the pile acts as a fully plugged pile or as an unplugged pile is a very complicated 
task.  One simple approach is described in the APILE Technical Manual.  For unplugged conditions, the 
total soil resistance at the tip is the sum of the side friction along the inner surface of the pile and the end 
bearing from the metal area at the pile tip.  If the pile is fully plugged, the soil resistance at the pile tip is 
derived from end bearing over the full area of the base.  Comparing the soil resistance at the tip, based on 
the above two different conditions, the user may take the results from APILE with the smaller one for the 
recommended tip resistance. 

The total length of soil plug formed inside the pipe pile depends on the soil properties in each sub-
layer.  In many cases the length of the soil plug may be less than 50% of the total pile penetration.  The 
MTD method (as well as other offshore methods) directly asks the user to determine the plug condition as 
one of the required input parameters. 

This example is included for the customers who purchased the offshore-version of APILE.  This 
example will focus on the axial capacity of open-ended, unplugged piles predicted by four CPT-based semi-
empirical methods (NGI, MTD, Fugro, and UWA methods) for an offshore application.  The pile is a 60-
m-long pipe with an outer diameter of 2134 mm and an inner diameter of 2044 mm.  The soil deposit 
consists of six sub-layers and the soil properties, including Qc from the CPT tests, are shown in Table 5.11.  

Notice that from the output text file from APILE, a pile plug fully develops (no asterisk in output 
table) after 34 meters of pile penetration using the NGI Method and after 29 meters of pile penetration for 
the MTD Method. 

 

Depth γ' Cu φ
(m) (kN/m3) (kN/m2) (Deg.)

0 0.1 1
10 20 200
10 10,500
20 20,000
20 200 2,000
30 200 2,000
30 30,500
40 39,500
40 350 5,000
50 350 5,000
50 50,000

100 50,000

0.6 30

--- ---Sand 9 --- 38 0.6 30

2 Sand

--- ---

5 Clay 9 --- --- --- 15 3

Sand 9 --- 36

Qc PI

--- ---

3 Clay 6 --- --- --- 20 3

0.6 2034---9

Layer

4

6

YSR

1 Clay 4 --- --- --- 50 2

Soil Type Ko Nq
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Table 5.11   Soil data for Example Problem 8 

5.9.1 Comparison of APILE Results with Hand Computations 

Table 5.12 and Table 5.13 contains various comparisons of the results obtained from approximate 
hand computations (spreadsheet) against those from the computer run in APILE for two different offshore 
methods. 

 

Table 5.12   Comparison of results for NGI Method in Example Problem 8 

 
Table 5.13   Comparison of results for MTD Method in Example Problem 8 

Depth Soil Type
(m) Hand Calc Computer

0
10
10
20
20
30
30
40
40
50
50
60

6,145

2 Sand 2,513

Layer

1 Clay 516 537

Total Skin Friction (kN)

6 Sand 18,771 18,111

NGI METHOD

9,361

5 Clay 12,014 11,498

4 Sand 9,288

2,253

3 Clay 6,280

Depth Soil Type
(m) Hand Calc Computer

0
10
10
20
20
30
30
40
40
50
50
60

6 Sand 24,032 26,010

4 Sand 7,771 8,535

5 Clay 13,697 11,720

2 Sand 2,563 2,399

3 Clay 4,495 4,099

MTD METHOD

Layer
Total Skin Friction (kN)

1 Clay 230 209
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5.9.2 Input and Output Data Files for Example 8 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename is the following: 

Example 8 - CPT Methods on Open Ended Pile.ap10d 

The output-data filename is the following: 

Example 8 - CPT Methods on Open Ended Pile.ap10o 

5.9.3 Graphical Results of Computer Analysis 

The resulting plots of the total capacity predicted by different methods and the axial load versus 
settlement based on the NGI method may be observed in Figure 5.23 and Figure 5.24, respectively. 

 

Figure 5.23   Curves of Ultimate Total Capacity vs Depth for Example Problem 8. 
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Figure 5.24   Curve of Axial Load vs Settlement for Example Problem 8. 
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5.10 Example Problem 9 – LRFD Method on Closed Pipe Pile 
An example is presented from the National Highway Institute’s publication titled “Load and 

Resistance Factor Design (LRFD) for Highway Bridge Substructures” (NHI, 2001) to illustrate a simple 
example of driven piles as foundations based on the LRFD method.  This example is included to 
demonstrate the convenience of using APILE in the design of driven piles under axial loads based on the 
new LRFD design procedures. 

The proposed driven pile is a close-ended steel pipe pile with an outside diameter of 460 mm.  The 
wall thickness is 12.7 mm.  The total length (penetration) below the original grade (without scouring) is 12 
meters.  The configuration and loading of the proposed bridge substructures are shown in Figure 5.25. 

 

Figure 5.25   Bridge substructures configuration and loading for Example Problem 9. 

5.10.1 Soil Profile and Properties 

A generalized subsurface profile along the alignment of the bridge is shown in Figure 5.26.  The 
subsurface soils are predominated by fine sand and medium dense to dense sand.  The soil density and 
strength increase with depth. 
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The water table is at the 2 m below the existing ground surface.  Soil properties for use in analysis 
includes unit weight and the penetration resistance (SPT blow counts). 

5.10.2 Loading Computations 

The unfactored vertical loads on the pile group (substructure) shown in Figure 5.25 include: 

DC (Dead load of structural components and non-structural attachments) = 4600 kN. 

DW (Dead load of wearing surfaces and utilities) = 3900 kN. 

LL (Vertical live load) = 3450 kN. 

The total unfactored load (Q) is: 

Q = DC + DW + LL 

    = 4600 kN + 3900 kN + 3450 kN 

    = 11950 kN 

For the Strength I and Service I Limit States, the factor load is expressed as 

��η𝑖𝑖𝛾𝛾𝑖𝑖𝑄𝑄𝑖𝑖 

Assume a typical structure such that ηi = 1.0.  The load factors for Limit States of Strength I and 
Service I are listed in Table 5.14. 

 

Limit State γDC γDW γLL 

Strength I 1.25 1.25 1.75 

Service I 1.00 1.00 1.00 

Table 5.14   Summary of factored loads for Example Problem 9 
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Figure 5.26   General soil description of Example Problem 9 

The total factored load effects are then calculated as follows. 

For the Strength I Limit State: 

∑η𝑖𝑖𝛾𝛾𝑖𝑖𝑄𝑄𝑖𝑖 =  ηi [ γDC DC + γDW DW + γLL LL ] 

                = (1.0) [ (1.25) (4600 kN) + (1.50) (3900 kN) + (1.75) (3450 kN) ] 

                = 17638 kN 
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For the Service I Limit State: 

∑ η𝑖𝑖𝛾𝛾𝑖𝑖𝑄𝑄𝑖𝑖 =  ηi [ γDC DC + γDW DW + γLL LL ] 

                = (1.0) [ (1.0) (4600 kN) + (1.0) (3900 kN) + (1.0) (3450 kN) ] 

               = 11950 kN 

5.10.3 APILE Estimated Axial Capacity of Single Pile from N60 SPT 

Calculations of nominal side and base resistance were carried out in APILE (filename “Example 9 - 
LRFD Method on Closed Pipe Pile - Initial.ap10d”).  Table 5.15 shows the calculated ultimate side friction 
and ultimate tip resistance for various methods and the values provided by the referenced publication (NHI, 
2001).  The NHI manual uses Meyerhof (1976) which provides low estimate of side friction rom SPT 
values.  The NHI manual also references the Field Tests from Vesic (1970) done on a test pile at the same 
site.  The FHWA results from APILE are close to those from the Vesic, 1970, field tests. 

Methods Side Friction, kN Tip Resistance, kN Total Ultimate 
Capacity, kN 

NHI 2001 (Meyerhof, 1976) 445 1460 1905 
FHWA method 1028 1267 2295 
US ARMY method 730 1047 1777 
API method 759 802 1561 
Field Test (Vesic, 1970) 1180 1900 3080 

Table 5.15   Initial calculations of ultimate axial compressive capacity for Example 9 

The factored axial resistance of a single pile is: 

QR = φ Qult =   φqp Qp + φqs Qs 

The reduction factors for the computation methods based on SPTs are: 

φqp = 0.45 

φqs = 0.45 

The reduction factors for the axial capacity of a driven pile based on a full-scale loading test are: 

φqp = 0.8 

φqs = 0.8 

The factored side friction and tip resistance for the methods above (filename “Example 9 - LRFD 
Method on Closed Pipe Pile - Final.ap10d”) and the result from the full-scale loading test are presented in 
Table 5.16.  Based on Strength I Limit State, the total factored load is 17638 kN.  If the designer selects the 
factored pile capacity based on FHWA method (Total Factored Capacity of 1033 kN), the substructure pile 
group will need 17 piles.  On the other hand, having a local site test (Vesic, Total Factored Capacity of 
2464 kN) can reduce the pile group to 7 or 8 piles. 
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Methods Side Friction, kN Tip Resistance, kN Total Factored 
Capacity, kN 

NHI 2001 (Meyerhof, 1976) 200 657 857 
FHWA method 463 570 1033 
US ARMY method 329 471 800 
API method 341 361 702 
Field Test (Vesic, 1970) 944 1520 2464 

Table 5.16   Final calculations of factored axial compressive capacity for Example 9 

5.10.4 Input and Output Data Files for Example 9 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filenames are the following: 

Example 9 - LRFD Method on Closed Pipe Pile - Initial.ap10d 

Example 9 - LRFD Method on Closed Pipe Pile - Final.ap10d 

The output-data filenames are the following: 

Example 9 - LRFD Method on Closed Pipe Pile - Initial.ap10o 

Example 9 - LRFD Method on Closed Pipe Pile - Final.ap10o 

5.10.5 Graphical Results of Computer Analysis 

The results of factored side friction, tip resistance, and total capacity versus depth provided by the 
computer program for FHWA method were plotted together in Figure 5.27 and Figure 5.28 includes a plot 
of axial load versus settlement.  Based on Service I Limit States, the total factored load is 11950 kN on a 
total of 17 piles.  Therefore, each pile will take 703 kN, which will have an approximate settlement of 0.003 
m as indicated in Figure 5.28. 
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Figure 5.27   Curve of LRFD Geotechnical Capacity (Factored Capacity) vs Depth for 
Example Problem 9 (FHWA Method). 

 

Figure 5.28   Curve of Axial Load vs Settlement for Example Problem 9. 
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5.11 Example Problem 10 – Battered Pile 
Battered piles are used to resist large lateral loads when there is a large unsupported pile length or in 

weak soils where there is little lateral support.  Many offshore or marine structures are subjected to 
overturning moments due to wind load, wave pressure, and ship impacts.  Also, retaining walls are subjected 
to horizontal forces and bending moments due to earth pressure.  For foundations in such structures, 
designers often evaluate the use of combinations of vertical and batter piles. 

The ability to install driven piles on an angle, or batter, gives such piles a distinct advantage with 
respect to their ability to carry lateral loads.  Batter piles carry lateral loads primarily in axial compression 
and/or tension while vertical deep foundations carry lateral loads in shear and bending.  When subjected to 
lateral loading, batter piles will therefore generally have a greater capacity and be subject to smaller 
deformations than vertical piles of the same dimensions and material. 

A pile driven on an angle is usually expressed as a batter ratio (horizontal to vertical).  Example of 
1:6 batter ratio is a 1-foot horizontal to 6-feet vertical, and sometimes the batter ratio is also expressed as a 
batter angle between the pile axis and the vertical. 

5.11.1 Soil Profile and Pile Properties 

A generalized subsurface profile along the alignment of the bridge is shown in Figure 5.29.  The 
subsurface soils are predominantly soft to medium stiff and stiff normal consolidated clay nearby a coastal 
area.  The soil density and strength increase with the increase of soil depth.  The water table is at the existing 
ground surface.  Soil properties for use in analysis include effective unit weight (γ’) and undrained shear 
strength (c), which are presented in the soil profile. 

Steel pipe piles with 24-in OD and wall thickness of 0.5 inches are considered for this application.  
The pile will be installed with 1 to 1.5 batter ratio degrees (1.0H:1.5V), which represents a batter angle of 
approximately 33.7 degrees (input into APILE).  The total embedded pile length is 144 ft, which will 
penetrate approximately 6 ft into the bottom stiff clay layer.  The pile will be driven based on the specified 
batter ratio with a close-ended pile tip.  The API method is used for prediction of the axial compressive 
capacity of the battered pile for this application.  The total side resistance can also be considered as pull-
out capacity (under tension).  Some applications may apply a reduction factor on the side friction for the 
uplift (pull-out) capacity if the pile has short embedded length. 
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Figure 5.29   General soil description of Example Problem 10 

5.11.2 Hand Computations and Comparisons with APILE 

The program output will be compared to the results from the following hand calculations. 

5.11.2.1 API Method – Skin Friction 

Computations of side resistance were performed using a spreadsheet, with the following results: 

 
The total side friction from the table above is approximately 641 kips vs. 633 kips from APILE. 
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5.11.2.2 API Method – End Bearing 

The tip area (closed ended tip) = 3.14 ft2 

The unit tip resistance  = 9 (1500 psf) = 13,500 lbs/ft2 = 13.5 k/ft2 

The total tip resistance  = 13.5 (3.14) =42.4 kips vs. 42.4 kips from APILE. 

5.11.2.3 API Method – Comparisons of APILE Results with Hand Computations 

The total compressive capacity is approximately 683 kips, while the total pull-out capacity without 
applying reduction factor is 641kips for the battered pile.  If the pile is driven vertically, without the batter, 
to the same tip elevation (the pile tip at 6 ft into the bottom clay layer), the compressive capacity will be 
only 582 kips for comparison. 

5.11.3 Input and Output Data Files for Example 10 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename is the following: 

Example 10 - API Method on Battered Pile.ap10d 

The output-data filename is the following: 

Example 10 - API Method on Battered Pile.ap10o 

5.11.4 Graphical Results of Computer Analysis 

The APILE results of factored side friction, tip resistance, and total capacity versus length along the 
battered pile for the API method are plotted together in Figure 5.30. Axial load versus settlement is in 
Figure 5.31. 
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Figure 5.30   Curve of Combined Plots (Ultimate Total Capacity) vs Battered Length for 

Example Problem 10. 
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Figure 5.31   Axial Load vs Settlement for Example Problem 10. 
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5.12 Example Problem 11 – CPT to APILE 
This example is used to demonstrate various features for importing and processing of data files 

obtained from cone penetration tests (CPT) into soil layers for APILE.  Users may start with a new data file 
(File > New) and select to import CPT data (Data > Import CPT Data) or users may open an existing 
APILE model that needs to be modified with a new soil profile generated from imported CPT data.  This 
example describes importing into a new data file, but the process is similar for importing into an existing 
file/APILE model. 

5.12.1 Sample CPT Data 

A soil testing agency that was contracted for the CPT test at a site provides the user with a CPT data 
file and the information in Table 5.17.  This is the only required information for importing and interpreting 
the CPT data into APILE.  The sample CPT data file ‘Example 11 - CPT-01 - Ensoft Site.cpd’ in included 
within the files for this APILE example. 

CPT File Name: Example 11 - CPT-
01 - Ensoft Site.cpd 

Column 1: Depth (m) 
Column 2: Qc (tsf) 
Column 3: Fs (tsf) 
Column 4: Pore Pressure (psi) 

Column 5: Inclinometer 
(degrees)* 

Cone: 15 cm with Net Area Ratio = 0.80 
Ground Water: 15.8 ft during testing 

*  This value/parameter is not currently used or necessary for importing or interpretation 

Table 5.17   Summary of Sample CPT Data from Testing Agency 

5.12.2 Importing & Interpreting CPT Data 

Selection of Data > Import CPT Data for the sample CPT data file (Example 11 - CPT-01 - Ensoft 
Site.cpd) using parameters from Table 5.17 above are displayed in Figure 5.32.  Selecting the Import button 
(lower right in Figure 5.32) provides a new screen similar to Figure 5.33. 

Notice that the units in the screen are now consistent English units (Depth in feet and Qtip in psf), 
since the new APILE data file was started with English units.  If the user desires to have metric/SI units 
then start the process again with a new APILE file and select SI Units (Options > Units > S.I. Units). 

The user has to enter new soil layers (using the green + button), select soil types, select layer depths, 
and enter the mechanical properties for the top and bottom of each soil layer.  After close evaluations of the 
different interpreted parameters from the CPT file, the user may reach similar modeling decisions as those 
partially shown in Figure 5.34.  The full set of parameters can be found by opening Example 11 (Example 
11 - CPT to APILE.ap10d) and selecting Data > Soil Layers > Edit Soil Layers with CPT. 

5.12.3 Pile Properties & Computation Methods 

The pile data is not consequential for this example, but the model assumes a steel pipe pile with 24-
in OD and wall thickness of 0.5 inches with a length/penetration of 65 ft.  The FHWA, USACE and API 
methods are used for prediction of the axial compressive capacity, while the API method is used for the 
load-settlement curves. 
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In addition, this model also selects the NGI, MTD, Fugro and UWA methods (for the APILE 
Offshore Version) since those are better associated to CPT-based parameters.  For side resistance in 
cohesive soils, these CPT methods also use two other variables (Plasticity Index in NGI and Yield Stress 
Ratio in the other methods) which need to be provided by the soil investigation or computed by the user 
outside APILE.  This example uses the values shown in Table 5.18, but the user should read the applicable 
sections in Chapter 3 of the APILE Technical Manual for notes regarding these variables. 

In particular, the following reference is provided for the Yield Stress Ratio:  

Yield Stress Ratio (YSR) is defined as the vertical effective yield stress (σ’vy) to the vertical 

in situ effective stress (σ’vo). OCR (over-consolidation ratio) is defined as the vertical 

maximum pre-consolidation effective stress (σ’vc) to the vertical in situ effective stress 

(σ’vo).   YSR is also named as apparent OCR in some literature, but generally YSR is greater 
than OCR. 

Layer Depths (ft) Plasticity 
Index (%) 

Yield Stress 
Ratio 

Clay 10.5 
26.6 

30 
30 

2.0 
2.0 

Clay 30.0 
42.0 

25 
25 

2.0 
2.0 

Clay 53.5 
59.0 

20 
20 

3.0 
3.0 

Table 5.18   PI and YSR for Example 11. 

5.12.4 Input and Output Data Files for Example 10 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Apile2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename is the following: 

Example 11 - CPT to APILE.ap10d 

The output-data filename is the following: 

Example 11 - CPT to APILE.ap10o 

5.12.5 Graphical Results of Computer Analysis 

APILE results of unfactored total capacity versus length for the various computational methods are 
plotted together in Figure 5.35. Axial load versus settlement is in Figure 5.36. 
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Figure 5.32  CPT Data Import Parameters for Example 11 
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Figure 5.33  Sample Blank Soil Data from Newly Imported CPT Data 

  



CHAPTER 5 – Example Problem 11 – 5-59 
 

User’s Manual (Rel. Aug/2023)  APILE v2023 
 

 

Figure 5.34  Sample Soil Data from Imported CPT for Example 11 
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Figure 5.35   Ultimate Total Capacity vs Pile Length for Example Problem 11. 

 
Figure 5.36   Axial Load vs Settlement for Example Problem 11. 
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PROGRAM LICENSE AGREEMENT & DISCLAIMER 

IMPORTANT NOTICE:  The software you are about to install or previously have installed from Ensoft 
Incorporated (“ENSOFT”) is licensed only on the condition that you agree to the terms and conditions set forth 
below.  Please read the terms of this License Agreement & Disclaimer ("LICENSE") carefully. 
If you agree to be bound by the terms of this LICENSE, please check mark the box labeled “YES – I Accept the 
terms of this License Agreement!” during software installation so it can be installed on your computer. 
If you do not agree to the terms of this LICENSE, please check mark the box labeled “NO – I DO NOT Accept the 
terms of this License Agreement!” which will terminate the software installation. 
If the software is already installed and licensed, you have already agreed to the terms and conditions of this license, 
or someone has done so on your behalf. 
This LICENSE is a legal agreement between you (“USER”) – either an individual or a single entity– and ENSOFT 
for the ENSOFT software product that you are about to install or previously have installed (“PRODUCT”).  The 
PRODUCT collectively includes computer software and associated media, printed materials, hardware key (dongle), 
and electronic documentation.  The PRODUCT also includes any updates and supplements to the original 
PRODUCT that may have been produced by ENSOFT.  By installing, copying, downloading, accessing or otherwise 
using the PRODUCT, the USER agrees to be bound by the terms of this LICENSE.  If you (the USER) do not agree 
to the terms of this LICENSE, do not install or use the PRODUCT. 

SOFTWARE LICENSE & DISCLAIMER 

The PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual 
property laws and treaties.  The PRODUCT is licensed, not sold.  

1.  GRANT OF LICENSE 

This LICENSE grants you the following rights: 

1.1  INSTALLATION AND USE 

1.1.1  Single-User Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with ENSOFT and for 
one specific physical site (“SITE”) registered with ENSOFT.  You may install and use the PRODUCT on any 
number of computers at the licensed SITE.  However, the PRODUCT is fully operational only in the SITE computer 
that carries the appropriate PRODUCT’s hardware key (“KEY”) that is used as software protection device. 

1.1.2  Network Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with ENSOFT and for 
the specific physical site(s) (“SITE(S)”) and IP range registered with ENSOFT.  Each network seat that is purchased 
is provided with access for SITE(S) clients located within up to 2 subnets with unique third octets (“CLIENT 
SUBNETS”).  The minimum two-seat network license can be associated to a maximum of 4 CLIENT SUBNETS 
(within up to 4 unique third octets).  Purchase of additional network seats can extend the allowable range of 
CLIENT SUBNETS. 
The USER may install and use the PRODUCT on any computer in the licensed SITE(S) that is within the allowable 
CLIENT SUBNETS registered with ENSOFT.  Any one computer in the network can be designated as license 
server for the PRODUCT by carrying the appropriate PRODUCT’s hardware key (“KEY”) that is used as software 
protection device. 
This Network License strictly prohibits the PRODUCT to be used in or from computers located in office locations 
that are different than the licensed SITE(S) or outside the registered CLIENT SUBNETS.  Users in physical office 
locations other than the registered SITE(S) with ENSOFT are required to purchase additional licenses of the 
PRODUCT, even if the COMPANY is the same and/or if the additional offices are located in the same city. 
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2.  OTHER RIGHTS AND LIMITATIONS 

2.1  EDUCATIONAL VERSION 

If the PRODUCT was licensed with educational discounts, the use of the PRODUCT is strictly limited to academic 
or research activities of educators and/or students.  Any other usage voids all the rights under this LICENSE.  If in 
doubt, please contact ENSOFT to determine if you have a PRODUCT version that was licensed for educational 
purposes. 

2.2  LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY 

You may not reverse engineer, decompile, or disassemble the PRODUCT, except and only to the extent that such 
activity is expressly permitted by applicable law notwithstanding this limitation. 

2.3  RENTAL 

You may not rent, lease or lend the PRODUCT to third parties. 

2.4  TRADEMARKS 

This LICENSE does not grant you any rights in connection with any trademarks or service marks of ENSOFT. 

2.5  SUPPORT SERVICES 

ENSOFT shall provide you with limited support and maintenance services (“SUPPORT”) related to the PRODUCT 
during the initial year after purchase and for any additional SUPPORT term that the COMPANY elects to purchase 
for PRODUCT after the initial warranty period expires.   
Use of SUPPORT is limited to the ENSOFT policies and programs described in the PRODUCT’s User’s Manual, in 
documentation on the ENSOFT web site, and/or in other materials provided by ENSOFT. 
Any supplemental software code that may be provided to you as part of the SUPPORT or that is downloaded from 
the ENSOFT web site shall be considered part of the PRODUCT and subject to the terms and conditions of this 
LICENSE.  With respect to technical information you provide to ENSOFT as part of the SUPPORT, ENSOFT may 
use such information for its business purposes, including for product support, development or advertisements.  
However, ENSOFT will not utilize such technical information in a form that personally identifies the USER. 

2.6  SOFTWARE TRANSFER 

The initial user of the PRODUCT may make a permanent transfer of this LICENSE and PRODUCT and only 
directly to an end user.  This transfer must include all of the PRODUCT (including all component parts, the media 
and printed materials, any upgrades, this LICENSE, and the PRODUCT’s appropriate hardware KEY).  Such 
transfer may not be by way of consignment or any other indirect transfer.  The transferee of such one-time transfer 
must agree to comply with the terms of this LICENSE, including the obligation not to further transfer this LICENSE 
and PRODUCT. 

2.7  TERMINATION 

Without prejudice to any other rights, ENSOFT may terminate this LICENSE immediately if you fail to comply 
with the terms and conditions of this LICENSE.  In such event, you must destroy all copies of the PRODUCT and 
all of its component parts and provide evidence of such destruction in writing to ENSOFT within 3 business days. 

2.8  INDEMNIFICATION 

Within and during the terms of this LICENSE, ENSOFT warrants that the use of the initially provided PRODUCT 
does not infringe any patent, copyright, or trademark in the United States, and ENSOFT shall indemnify and hold 
USER harmless against any and all losses, damages and expenses, (including attorney’s fees) which USER may 
sustain or incur as a result of a breach of this warranty. 

2.9  CONFIDENTIAL INFORMATION 
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ENSOFT and the USER may have access to certain proprietary information and materials of the other that are 
confidential and of substantial value to the respective party, which value would be impaired if such information 
were disclosed to third parties ("CONFIDENTIAL INFORMATION").  ENSOFT and the USER agree that neither 
shall disclose any CONFIDENTIAL INFORMATION to any third party and shall take every reasonable precaution 
to protect CONFIDENTIAL INFORMATION. 
The provisions of this section shall not apply to any information which (i) is or becomes available to the public other 
than by breach of the LICENSE agreement by the receiving party, (ii) is rightfully received by receiving party from 
a third party without confidential limitations, (iii) is independently developed by receiving party's employees 
without access to CONFIDENTIAL INFORMATION, or (iv) is known to the receiving party without any restriction 
on its use or disclosure prior to first receipt of it from the disclosing party. 

3.  COPYRIGHT 

All title and intellectual property rights in and to the PRODUCT (including but not limited to any images, 
photographs, animations, video, audio, music, and text that may be incorporated into the PRODUCT), the 
accompanying printed materials, and any copies of the PRODUCT are owned by ENSOFT.  All title and intellectual 
property rights in and to the content which may be accessed through use of the PRODUCT is the property of the 
respective content owner and may be protected by applicable copyright or other intellectual property laws and 
treaties.  This LICENSE grants you no rights to use such content.  All rights not expressly granted are reserved by 
ENSOFT.  This PRODUCT is protected by the United States Copyright Law and International Copyright Treaty. 

4.  SOFTWARE DISCLAIMER  

Although the PRODUCT has been used with apparent success in many analyses, new information is developed 
continuously and new or updated PRODUCT releases may be written from time to time.  All users are requested to 
inform ENSOFT immediately if any errors are found in the PRODUCT.  As modifications, updates, or new versions 
are produced, the latest codes are posted on ENSOFT’s web site and made available to all visitors for free 
downloading. 
No warranty, expressed or implied, is offered as to the accuracy of results from ENSOFT’s PRODUCT.  The 
PRODUCT should not be used for design unless caution is exercised in interpreting the results and independent 
calculations are available to verify the general correctness of the results.  Users are assumed to be knowledgeable of 
the information in the printed documentation that is distributed with the digital media.  Users are assumed to 
recognize that the input parameters, eg., soil properties, increment length, tolerance on solution convergence, and 
many others, can have a significant effect on the solution and must be chosen carefully. Users should have a 
thorough understanding of the relevant theoretical criteria (appropriate references are suggested in the software 
documentation).  

5.  GOVERNING LAW 

This LICENSE is governed by the laws of the State of Texas and laws and treaties of the United States of America. 

6.  CONTACT INFORMATION 

Should you have any questions concerning this LICENSE or if you desire to contact ENSOFT for any reason, please 
use the following: 
Ensoft Incorporated 
3003 West Howard Lane 
Austin, Texas 78728 
United States of America 

NO OTHER WARRANTIES 
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TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, ENSOFT DISCLAIMS ALL OTHER 
WARRANTIES AND CONDITIONS, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED 
TO, IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 
PURPOSE, AND TITLE, WITH REGARD TO THE PRODUCT, AND THE PROVISION OF SUPPORT 
SERVICES.  THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS.  YOU MAY HAVE 
OTHERS, WHICH VARY FROM STATE/JURISDICTION TO STATE/JURISDICTION. 

LIMITATION OF LIABILITY 

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL ENSOFT BE 
LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES 
WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, 
BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) 
ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT OR THE FAILURE 
TO PROVIDE SUPPORT, EVEN IF ENSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.  IN ANY CASE, ENSOFT’S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS LICENSE 
AGREEMENT SHALL BE LIMITED TO THE GREATER OF THE AMOUNT ACTUALLY PAID BY YOU 
FOR THE PRODUCT OR U.S.$1.00. 
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